GTP Illumination Module in Ogre3D
This documentation describes the main concept of the Illumination Module created for the Ogre3D engine. It includes a User's Guide that describes the basics of the different techniques implemented in the module and how to use them, and also inculdes a C++ class reference for developers.

OGRE Illumination Module User's Guide
OGRE Illumination Module C++ Reference


Ogre Illumination Module user's guide

For information about the basic usage of the Illumination Module in Ogre3D see:
Ogre Illumination Module Basics
For information about the implemented techniques and how to set up them see:
Technique Reference


Ogre Illumination Module Basics

This section covers the following topics:

Exporting Scenes from Maya
Extending the Ogre Material Scripts
The Path Map Tool
Using the Module In C++


Exporting Scenes from Maya

We've provided a mel script that can export a Maya scene into our .level file format. This script assumes that you have installed the Ogre Maya exporter plugin, as it saves the objects in OGRE .xml file format. For further information about installing and using the Ogre Maya exporter plugin please refer to the Ogre3D documentation.

The name of the script file is:

"GTPSceneExport.mel"

This maya script file should be copied into Maya's default scrip folder:

"My Documents\maya\7.0\scripts\"

The following line should be added to userSetup.mel located in Maya7.0 script folder:

source GTPSceneExport;

After executing Maya a new menu should appear named "GTP" (if the Ogre plugin is installed properly the "Ogre" menu should also be present):

If we have a scene ready to export we can use the "GTP" menu's "Export Scene" entry:

This will show the "GTP Scene Exporter" window:

The controls have the following meanings:

General Controls:
  • Output Directory: The directory where all output files will be created. Default: the Maya scene file directory.
  • Scene File Name: The name of the level file to export. Default: Maya file name with .level extension
MaterialControls:
  • Export Materials: If turned on the materials used by the object will be saved in an Ogre material file. Same as turning on the "Export materials to Ogre .material file" checkbox in the Ogre exporter. Default: off
  • Material File Name: The name of the Ogre .material file to export. Only active if "Export Materials" is turned on. Default: Maya scene file name with .material extension.
  • Material name prefix: The material exporter exports the materials with a name identical to their names used in Maya. This prefix will be added to the material name so you can avoid name duplications among different levels. Only active if "Export Materials" is turned on. Default: Maya scene file name.
Mesh Controls:
  • Export Meshes: If turned on all shapes will be exported to an Ogre .xml file. The file names will be the name of the shape used in Maya. Note that the shapes are exported and not the transforms, so if two objets share the same shape in the Maya scene (eg. they were created with an instance duplication) only one shape will be exported. The exported data are in object space, all transformations are saved in the .level file. The exported mesh data will contain vertex positions, normals and texture coordinates. Default: on.
  • Create Binary Mesh Files: If turned on binary Ogre .mesh files will be created from the .xml files . Only active if "Export Meshes" is turned on. Default: on.
  • Build Edge List: If turned on edge information for shadow volume computation will be stored in the binary .mesh files. Only active if "Create Binary Mesh Files" is turned on. Default: off
  • Build Tangent Vectors: If turned on tangent vectors (for normal mapping) will be computed and stored in the binary .mesh file. Only active if "Create Binary Mesh Files" is turned on. Default: off.
  • Ogre Dir: The full path where the Ogre dll's and the OgreXMLConverter.exe are located. These files are essential for binary mesh creation. Only active if "Create Binary Mesh Files" is turned on. Default: "%OGRE_PATH%/Samples/Common/bin/Release" (where OGRE_PATH is a system variable defining the Ogre root directory, this variable should be set if the Ogre Illumination Module is used)
Path Map Options:

See in The Path Map Tool.


Extending the Ogre Material Scripts

The Ogre implementation of the Illumination Module was designed to have a simple usage, and to fit to the concepts of a typical Ogre application. In Ogre RenderTechniques should operate on a Pass of the object’s material (note that most of the techniques set outputs from a resource to some input of a Material, typically to a texture unit state of a Pass). It would be very comfortable to define the RenderTechniques to be used in the material script within the pass the technique should operate on.
We followed this solution so added a new keyword IllumTechniques within the pass definition of the materials. Within this scope we can define the techniques to be used for the given pass with the keyword RenderTechnique. This keyword needs a parameter that defines the type (refered by Name in the Technique Reference) of the technique. Within the RenderTechnique scope we can set some technique specific parameters which will be passed to the technique’s constructor. (see RenderTechnique for details about render techniques)
An example of this technique definition which defines an object as a caustic and a shadow receiver is the following:

material exampleMaterial
{
technique
{
pass // this pass will use Illumination Module techniques
{
IllumTechniques // this scope will define techniques to use
{
RenderTechnique DepthShadowReceiver // this scope will define a shadow receiver technique
{
max_light_count 1 // attribute of depth shadow receiver technique
 }
RenderTechnique CausticReceiver // this scope will define a caustic receiver technique
{
max_caster_count 2 // attribute of caustic receiver technique
}
}
// … usual pass definition
 }
}
}

An other example that shows how a technique can output it's resource to a specified input of the pass (renders and binds a cube texture to a specific texture unit of the pass):
material exampleMaterial2
{
technique
{
pass // this pass will use Illumination Module techniques
{
IllumTechniques // this scope will define techniques to use
{
RenderTechnique ColorCubeMap // this scope will define a color cube map
{
resolution 256 // resolution of the cubemap to be created
texture_unit_id 0 // the texture unit this cubemap will be boud to in this pass
 }
}
// … pass attributes like gpu program references etc.
 texture_unit // the cubemap will be bound to here as this is the first texture unit (id = 0)
{
}
// .... other texture units if needed
}
}
}

For more information about implemented techniques and their parameters see Technique Reference .


The Path Map Tool

Indirect illumination with Precomputed Radiance Maps (PRM)
Running pathmap.exe
 Path Map attributes in Maya
Indirect illumination with Precomputed Radiance Maps (PRM)
The Path Map tool implements the Light Path Map approach for indirect lighting. Its purpose is to add realism to computer games by computing dynamically changing indirect illumination. It is an improvement over ambient lighting or static light maps. Not unlike light maps, global illumination computations are performed in a precomputing step, using ray casting and indirect photon mapping (the virtual light sources method). The contributions of virtual light samples are computed on the GPU, with depth mapping. However, instead of computing a single light map, multiple texture atlases (constituting the PRM) are generated for the scene objects, all corresponding to a cluster of indirect lighting samples. Then these atlases are combined according to actual lighting conditions. Weighting factors depend on how much light actually arrives at the sample points used for PRM generation. This computation is also performed in a GPU pass.
The final result will be a plausible rendering of indirect illumination. Indirect shadows and color bleeding effects will appear. Indirect illumination will change as the light sources move. However, this comes at the price of fetching data from all PRM texture panes (clusters of indirect illumination) instead of just fetching a light map color. This limits the number of panes we can use. The accuracy will depend on a number of factors:

  • First of all, the number of samples (entry points). Increasing this number will make preprocessing longer, but not influence rendering times.
  • Then, the number of PRM panes (independent entry point clusters). In the standalone implementation this number is 32, which provides pretty accurate, lighting dependant indirect illumination, but may not be affordable if the approach is combined with other effects. Decreasing this number will still produce nice indirect illumination, although with less fidelity to the changes of actual lighting.
  • The resolution of the PRM atlas is of course important. In the program this is 256 x 256 for every pane, requiring 4 Mbytes of video RAM for every static object. As indirect illumination tends to be low frequency, this resolution is usually sufficient. However, large objects will have large texels, and should be avoided. Large objects like complete levels should be separated into smaller ones like rooms. This will also make it possible to use a large number of indirect illumination clusters, but only store and use some of them for individual objects.
The program performs two tasks: compute the PRM, and use it to display the scene with indirect illumination. The PRM, along with the location of the sample points, is saved to files, and does not need to be computed every time. When this approach will be integrated into a game engine, only the final rendering must be implemented. This tool should be adapted to process the level description format used, and compute the PRM textures for the static geometry. The textures and sample point data should be associated with the levels and their entities, and applied in the game engine.

Building pathmap.exe

This is a standalone DirectX 9.0 application, compiles under Visual C++ 2003 with DirectX SDK April 2006 (identical to June 2006).
The source code and the precompiled pathmap.exe can be found in the GTP repository in the following path:

www.gametools.org/repos/gametools/gtp/trunk/App/Demos/Illum/pathmap/

Running pathmap.exe
Command line options
> pathmap.exe [s|p/v] -D <media input directory> -L <level file> -M <materials file> -O <mesh output dir> -P <prm out put dir> -E <number of entry points> -C <number of clusters> -S <shadow map resolution>

Operations

s - Segment input meshes: creates new versions of input meshes, and outputs them to the <mesh output dir> . These processed meshes will contain smaller submeshes, to which PRM textures will be assigned.
p - Precompute PRM textures. Outputs textures (hdr format), a new level file (with cluster assigment info), and an entry point file.
sp - Do both of the above.
v - Do neither of the above, only visualize results.

Switches

D - directory for input files (level file, material file, meshes in .x or OGRE xml format, texture images)
L - file name of level file (txt file listing meshes and entities)
M - file name for material file (txt file listing material name - color texture pairs)
O - output directory for segmented meshes and the new level file (this is also the input directory for the same files if operation 's' is not specified)
P - output directory for PRM textures and the entry point file. (this is also the input directory for the same if operation 'p' is not specified)
E - number of entry points. Must be 4096*n.
C - number of entry point clusters overall. How many of them influences a single entity is given in the level file.
S -depth map resolution used for indirect illumination precomputation.

Level files and material files can be generated with the "GTP Scene Exporter" mel script provided with the Ogre Illumination Module. For information about exporting objects into .level files see Exporting Scenes from Maya.

Path Map attributes in Maya
The path map tool requires some addition information about the meshes, which are not provided in the Ogre .xml format and they don't have a representation in Maya either. These attributes can be set with a command located in the GTP menu and they will be saved in the .level file:

The "Add Path Map attributes" command adds these attributes to the selected objects (they appear under "Extra Attributes").

For shapes two extra attributes are added:

  • Photon Map Resolution: The photon map resolution for this geometry.
  • Photon Map Subdivision: The number of segments this geometry should be devided into.

For transforms one extra attribute is added:

  • Path Map Clusters: The number of clusters this object belongs to.
These attributes will be saved in the .level file after exporting the scene using the Export Scene command in the GTP menu.

This will show the "GTP Scene Exporter" window:

For information about the options not realted to path map see Exporting Scenes from Maya.

Path Map Options:
  • Export Path Map Attributes: If turned on path map attributes will be saved in the .level file. Default: off.
  • Export Path Map Materials: If turned on all materials present in the scene will be saved to a format that can be used by pathmap.exe. These materials will use the first texture channel of the Maya material -or it's diffuse color if no textures are assigned- to display objects. Only active if "Export Path Map Attributes" is turned on. Default: off.
  • Path Map Material File: The name of the material file where materials for pathmap.exe will be saved. Only active if "Export Path Map Materials" is turned on. Default: Maya scene file name with .materials extension.


Using the Module in C++

To use the Ogre illumination module in your C++ application you have to:

Compile the Illumination Module for Ogre
 Extend your application
Compiling the Illumination Module for Ogre
All Ogre projects that will use the GTP Illumination techniques have to use a library called IllumModule (this is an astract interface) and its Ogre implementation called OgreIllumModule. The source code for these libraries can be found in the GTP repository in the following path:

www.gametools.org/repos/gametools/GTP/trunk/Lib/Illum/IllumModule
There is a prepared Visual Studio 7.1 solution file that can be used to compile these libraries:

www.gametools.org/repos/gametools/GTP/trunk/Lib/Illum/shared/scripts/GTPIllumination.7.1.sln
This solution also containes the projects of Ogre demo applications that demonstrates the integrated effects. The source code of these demos can be found in the repository in:

www.gametools.org/repos/gametools/GTP/trunk/App/Demos/Illum/Ogre/src
The OgreIllumModule (and also the demo applications) use Ogre 1.2 with the Ogre changes that can be found in the svn:

www.gametools.org/repos/gametools/OGRE/trunk/ogre_changes/Ogre1.2
These OGRE changes should be copied to the OGRE 1.2 directory and OGRE should be rebuilt. It's important to set the prepocessor definition GAMETOOLS_ILLUMINATION_MODULE for all the Ogre projects. Also important to add SpriteSet.h, SpriteSet.cpp, SpriteParticleRenderer.h and SpriteParticleRenderer.cpp to the OgreMain project. To compile the OgreIllumModule an environment variable named OGRE_PATH should also be set to the OGRE root directory. After these steps the build of the libraries and demos should succeed without errors.

After the compile process the following library files will be created:

repos/gametools/gtp/trunk/Lib/Illum/IllumModule/IllumModule/bin/release/IllumModule.lib
repos/gametools/gtp/trunk/Lib/Illum/IllumModule/IllumModule/bin/debug/IllumModule.lib
repos/gametools/gtp/trunk/Lib/Illum/IllumModule/OgreIllumModule/bin/release/IllumModule_Ogre.lib
repos/gametools/gtp/trunk/Lib/Illum/IllumModule/OgreIllumModule/bin/debug/IllumModule_Ogre.lib

Ogre Illumination Module C++ Application Requirements

To use the Ogre Illumination Module in an Ogre application the following steps are required:

Project configuration changes:
  • Set the preprocessor definition GAMETOOLS_ILLUMINATION_MODULE
  • Add additional library dependencies: IllumModule.lib and OgreIllumModule.lib (also add additional libray directories according to the exact locations of these library files - taking care of the configuration type: debug or release)
Source code changes:

In the following we assume that the Ogre application is based on the examples provided with Ogre, namely the main calss is a derivative of ExampleApplication. Other implementations should change their code not just as it is stated here but implicitly according the structure of their application.

  • Include "OgreIlluminationManager.h" (and also add the additional include directory where this file is located: repos/gametools/gtp/trunk/Lib/Illum/IllumModule/OgreIllumModule/include)
  • After adding all the objects to the scene graf (eg.: in the last line of createScene() ) call OgreIlluminationManager::getSingleton().initTechniques();
  • Add the Ogre Illumination Manager Singleton as a frame listener (in createFrameListener() with this code line: mRoot->addFrameListener(&OgreIlluminationManager::getSingleton()) );
OgreIlluminationManager::getSingleton().initTechniques() is needed to initialize the techniques that were given by the material scripts. This function seraches the scene graph and for each object that has a material with an illumination technique defined creates these techniques. For objects that are added later to the scene graph later you can explicitly call OgreIlluminationManager::getSingleton().initTechniques(Entity* e) to initialize the technique only for this entity.

mRoot->addFrameListener(&OgreIlluminationManager::getSingleton()) is needed because illumination techniques requires resources like textures etc. These resources should be updated in each frame before rendering o the screen. As the OgreIlluminationManager singleton is also a FrameListener it will be called in each frame if it is added to the active frame listeners. One thing that should be considered here is the priority of the frame listeners. OgreIlluminationManager should be called after all the other frame listeners as frame listeners can change object positions and OgreIlluminationManager does rendering processes which require data consistent with the data used when rendering to the framebuffer. This can be ensured with the use of the FrameListener::setPriority(int) method (note that this is part of the Ogre changes made by GTP Illumination Module). The priority of OgreIlluminationManager should be set higher than the priority of other frame listeners to be executed later (the default priority of frame listeners is 1, except for ControllerManager::mFrameTimeController that has 0 priority).

Additional parameters of OgreIlluminationManager
The Illumination Module also nneds some information that are not provided in the material scripts. These can be given explicitly by code and cover the following topics:

  • Basic information about the main camera (required):
    OgreIlluminationManager::setMainCamera(Camera *camera) - pass a pointer to the player's camera
    OgreIlluminationManager::setMainViewport(Viewport *viewport) - pass a pointer to the main viewport

  • Resource joining:
    Resource joining means that if two objects are close enought to be treated as a single object and they need the same kind of resource (eg. both needs a cube map of the colors of the surrounding environment) they can use a single shared resource. This saves us processing time but of cource reduces quality and richness (eg. if two reflective object share the same environment map they can not see each other in their reflections). The metric describing that two (or more) objects can be joined is the maximum sphere radius that can contain these objects. This of cource depends on the size of the scene. The bounding radius can be given for all resource type or for a specific type.

    OgreIlluminationManager::setMaxJoinRadius(float rad) - sets the maximum bounding sphere radius for all resource types
    OgreIlluminationManager::setMaxJoinRadius(RenderingRunType type, float rad) - sets the maximum bounding sphere radius for a specific resource type

  • Shadow mapping:
    The Ogre Illumination Module implements shadow mapping independent from Ogre's built in shadowing techniques. If an object should recieve shadows with the Illumination Module's shadow mapping technique it's material should define the DepthShadowReceiver tehcnique. This will create additional shadow rendering passes to the material. The properties of this shadow mapping can be set with the following functions:

    setShadowMapSize(unsigned int size) - sets the size of the shadow maps to use
    setShadowMapMaterialName(String name) - sets the name of the materials that should be used while rendering the shadow maps
    setFocusingSM(bool use) - sets if the light projection should be focused
    setFocusingMapSize(unsigned int size) - size of the texture that is used in focusing (higher resolution yields to more preciese focusing but slower)
    setUseLISPSM(bool use) - sets if Light Space Perspective correction should be used (only implemented for directional lights)
    setBlurShadowMap(bool use) - sets if the shadow map should be blurred (useful if Variance Shadow Mapping is used)
In the following you can find a sample Ogre ExampleApplication code:

class App : public ExampleApplication
{
protected:

void createScene(void)
{
//usual Ogre code (mesh loading, transformations, material setup)
 ....
//set global parameters
 //required parameters for main camera and viewport identification
 OgreIlluminationManager::getSingleton().setMainCamera(mCamera);
OgreIlluminationManager::getSingleton().setMainViewport(mWindow->getViewport(0));
 //resource joining parameters
//set boundig sphere radius for all run type
 OgreIlluminationManager::getSingleton().setMaxJoinRadius(400);
 //set boundig sphere radius for a given run type
 OgreIlluminationManager::getSingleton().setMaxJoinRadius(ILLUMRUN_PHOTONMAP, 200);
 //shadow mapping attributes (attributes for a spotlight using variance shadow mapping)
 OgreIlluminationManager::getSingleton().setShadowMapSize(512);
OgreIlluminationManager::getSingleton().setFocusingSM(false);
OgreIlluminationManager::getSingleton().setUseLISPSM(false);
OgreIlluminationManager::getSingleton().setBlurShadowMap(true);
OgreIlluminationManager::getSingleton().setShadowMapMaterialName("GTP/Basic/Distance_Normalized");
 //search for techniques and initialize them
 OgreIlluminationManager::getSingleton().initTechniques();
}

void createFrameListener(void)
{
 // This is where we instantiate our own frame listener
mFrameListener= new myFrameListener(...);
 // Set priority of the frame listener.
// The default priority value is 1
mFrameListener->setPriority(2);
 // set priority of OgreIlluminationManager.
// It should be higher that the other frame listener's
 OgreIlluminationManager::getSingleton().setPriority(3);
 // add the frame listeners to the active frame listeners
mRoot->addFrameListener(mFrameListener);
mRoot->addFrameListener(&OgreIlluminationManager::getSingleton());
}
}


Implemented Techniques

This section describes the rendering techniques that have been implemented in the Ogre Illumination Module.

Techniques related to environment mapping:
  • ColorCubeMap
  • DistanceCubeMap
Techniques related to caustic generation:
  • CausticCaster
  • CausticReceiver
Techniques related to indirect illumination:
  • ReducedColorCubeMap
  • PathMap
Techniques related to particle systems and volumetric media:
  • SphericalBillboard
  • Fire
  • HPS
  • IllumVolume
Other techniques:
  • DepthShadowReceiver


Back to List of Techniques

Color Cube Map Render Technique

Defines that the rendering will need a color cube map. The color cube map can be used to display reflections and refractions.

Name:

ColorCubeMap

Parameters:

Name | Type | Default Value | Description
update_interval | unsigned int | 1 | update frequency (if 0 only updates once)
start_frame | unsigned int | 1 | adds an offset to the current frame number to help evenly distribute updates between frames (the frame number of the first update)
resolution | unsigned int | 256 | cubemap resolution
texture_unit_id | unsigned int | 0 | the id of the texture unit state the resulting cube map should be bound to
distance_calc | bool followed by float | true 2.0 | flag to skip cube face update if object is far away - bool value to set calculation on - float value defines the distance tolerance used in face skip
face_angle_calc | bool followed by float | true 2.0 | flag to skip cube face update if face is neglible - bool value to set calculation on - float value defines angle tolerance used in face skip
update_all_face | bool | false | defines if all cubemap faces should be updated in a frame or only one face per frame
render_self | bool | false | sets if the object should be rendered to the cube map
render_env | bool | true | sets if the environment should be rendered to the cube map
self_material | string | "" | the material that should be set for the object while rendering the cubemap (if no string is given the original materials are used)
env_material | string | "" | the material that should be set for the environment while rendering the cubemap (if no string is given the original materials are used)
attach_to_texture_unit | bool | true | sets if this cubemap should be attach to a texture unit of the pass
layer | unsigned int | 0 | the layer of this cubemap (multiple layers are used by shaders dealing with multiple reflections and refractions)
get_min_max | bool | 0 | sets if the minimum and maximum values of the cubemap should be computed (it is quite a slow process as it requires texture read back to system memory - it is used to speed up linear search in cube maps while finding intersection points in multiple reflections)
min_var_name | string | "" | sets the name of the GPU fragment shader program parameter to which the minium value should be bound to (if no string is given the variable is not bound)
max_var_name | string | "" | sets the name of the GPU fragment shader program parameter to which the maximum value should be bound to (if no string is given the variable is not bound)
 use technique technique
see also: Extending the Ogre Material Scripts


Back to List of Techniques

Distance Cubemap Render Technique

Defines that the rendering will need a distance impostor cubemap (a cube map of the distance of the surrounding environment from the cubemap center). The distance impostor is a sampled representation of the scene and makes possible to find intersection points of an arbitrary ray with the environment which makes reflection and refraction calculations more accurate.

Name:

DistanceCubeMap

Parameters:

Name | Type | Default Value | Description
update_interval | unsigned int | 1 | update frequency (if 0 only updates once)
start_frame | unsigned int | 1 | adds an offset to the current frame number to help evenly distribute updates between frames (the frame number of the first update)
resolution | unsigned int | 256 | cubemap resolution
texture_unit_id | unsigned int | 1 | the id of the texture unit state the resulting cube map should be bound to
distance_calc | bool followed by float | true 2.0 | flag to skip cube face update if object is far away - bool value to set calculation on - float value defines the distance tolerance used in face skip
face_angle_calc | bool followed by float | true 2.0 | flag to skip cube face update if face is neglible - bool value to set calculation on - float value defines angle tolerance used in face skip
update_all_face | bool | false | defines if all cubemap faces should be updated in a frame or only one face per frame
render_self | bool | false | sets if the object should be rendered to the cube map
render_env | bool | true | sets if the environment should be rendered to the cube map
self_material | string | "GTP/Basic/Distance" | the material that should be set for the object while rendering the cubemap (if no string is given the original materials are used)
env_material | string | "GTP/Basic/Distance" | the material that should be set for the environment while rendering the cubemap (if no string is given the original materials are used)
attach_to_texture_unit | bool | true | sets if this cubemap should be attach to a texture unit of the pass
layer | unsigned int | 0 | the layer of this cubemap (multiple layers are used by shaders dealing with multiple reflections and refractions)
get_min_max | bool | 0 | sets if the minimum and maximum values of the cubemap should be computed (it is quite a slow process as it requires texture read back to system memory - it is used to speed up linear search in cube maps while finding intersection points in multiple reflections)
min_var_name | string | "" | sets the name of the GPU fragment shader program parameter to which the minium value should be bound to (if no string is given the variable is not bound)
max_var_name | string | "" | sets the name of the GPU fragment shader program parameter to which the maximum value should be bound to (if no string is given the variable is not bound)

see also: Extending the Ogre Material Scripts


Back to List of Techniques

Caustic Caster Technique

This technique defines that the object can cast caustics.

Name:

CausticCaster

Parameters:

Name | Type | Default Value | Description
update_interval | unsigned int | 1 | update frequency (if 0 only updates once)
start_frame | unsigned int | 1 | adds an offset to the current frame number to help evenly distribute updates between frames (the frame number of the first update)
photonmap_resolution | unsigned int | 64 | photon map resolution
caustic_cubemap_resolution | unsigned int | 128 | caustic cube map resolution
photon_map_material | string | "GTP/Caustic/PhotonMap_HitEnv" | the name of the material should be used when rendering the photon hit map - the default material needs a distance impostor cubemap and finds photon hits with secant search
caustic_map_material | string | "GTP/Caustic/CauCube_PointSprite" | the name of the material that should be used when rendering the caustic cubemap
photon_map_tex_id | unsigned int | 0 | the texture unit state id of the caustic map generation material where the photon hit map should be bound to
distance_impostor | bool | true | tells if a distance cubemap impostor should be used in photon hit calculation (recommended)(the cubemap will be bound to the first texture unit of the photon hit map material)
update_all_face | bool | false | defines if all cubemap faces of the caustic cube map should be updated in a frame or only one face per frame
attenuation | float | 1.0 | attenuation distance of the caustic
use_triangles | bool | false | sets if triangles should be rendered into the caustic cubemap instead of sprites - the two different methods need different caustic map materials: for sprites use "GTP/Caustic/CauCube_PointSprite", for triangles use "GTP/Caustic/CauCube_Triangles"
blur_caustic_cubemap | bool | false | sets if the caustic cubemap should be blurred (recommended if rendering caustic triangles)
see also: Extending the Ogre Material Scripts


Back to List of Techniques

Caustic Receiver Technique

This technique defines that the object will recieve caustic lighting from caustic caster objects. The caustic light spots will be calculated by caustic caster's techniques. These techniques will only be updated if caustic receivers are visible, so it is the receiver technique's responsibility to update them. Each caustic caster's light contribution will be added in separate passes (these passes will be inserted just after the pass in which the CausticReceiver technique is defined).

Name:

CausticReceiver

Parameters:

Name | Type | Default Value | Description
max_caster_count | unsigned int | 1 | the maximum number of caustic casters from which this receiver can recieve caustic light
vertex_program_name | string | "GTP/Basic/Shaded_VS" | the name of the vertex program that should be used in the caustic gathering passes
fragment_program_name | string | "GTP/Caustic/GatherCaustic_Cube_PS" | the name of the fragment program that should be used in the caustic gathering passes
see also: Extending the Ogre Material Scripts


Back to List of Techniques

Downsampled Color Cube Map Render Technique

Defines that the rendering will need a downsampled color cube map. This reduced sized cubemap is created with averaging the original cubemap. This downsampled cubemap can easily be convolved in the final shading to achieve special effects like diffuse reflections. This technique will automaticly create a color cube map (if it is not already defined with a ColorCubeMap technique) with the given parameters.

Name:

ReducedColorCubeMap

Parameters:

Name | Type | Default Value | Description
update_interval | unsigned int | 1 | update frequency (if 0 only updates once)
start_frame | unsigned int | 1 | adds an offset to the current frame number to help evenly distribute updates between frames (the frame number of the first update)
resolution | unsigned int | 256 | cubemap resolution
reduced_resolution | unsigned int | 8 | resolution of the downsampled cubemap
texture_unit_id | unsigned int | 0 | the id of the texture unit state the resulting cube map should be bound to
distance_calc | bool followed by float | true 2.0 | flag to skip cube face update if object is far away - bool value to set calculation on - float value defines the distance tolerance used in face skip
face_angle_calc | bool followed by float | true 2.0 | flag to skip cube face update if face is neglible - bool value to set calculation on - float value defines angle tolerance used in face skip
update_all_face | bool | false | defines if all cubemap faces should be updated in a frame or only one face per frame
render_self | bool | false | sets if the object should be rendered to the cube map
render_env | bool | true | sets if the environment should be rendered to the cube map
self_material | string | "" | the material that should be set for the object while rendering the cubemap (if no string is given the original materials are used)
env_material | string | "" | the material that should be set for the environment while rendering the cubemap (if no string is given the original materials are used)
attach_to_texture_unit | bool | true | sets if this cubemap should be attach to a texture unit of the pass
layer | unsigned int | 0 | the layer of this cubemap (multiple layers are used by shaders dealing with multiple reflections and refractions)
get_min_max | bool | 0 | sets if the minimum and maximum values of the cubemap should be computed (it is quite a slow process as it requires texture read back to system memory - it is used to speed up linear search in cube maps while finding intersection points in multiple reflections)
min_var_name | string | "" | sets the name of the GPU fragment shader program parameter to which the minium value should be bound to (if no string is given the variable is not bound)
max_var_name | string | "" | sets the name of the GPU fragment shader program parameter to which the maximum value should be bound to (if no string is given the variable is not bound)
see also: Extending the Ogre Material Scripts


Back to List of Techniques

Spherical Billboards Technique

This is a technique for rendering particle systems with the spherical billboard method. This technique defines that the final rendering will need a depth map (camera space z-values) of the scene. With the use of this map scene geometry can be taken into account during final rendering of the particles, and we can eliminate billboard clipping and popping artifacts.

Name:

SphericalBillboard

Parameters:

Name | Type | Default Value | Description
texture_unit_id | unsigned int | 1 | the texture unit id where the scene depth texture will be bound
see also: Extending the Ogre Material Scripts


Back to List of Techniques

Fire Technique

This is technique is similar to the spherical billboards render technique. It also defines that the rendering will need a scene depth map from the camera for the same purposes as in the spherical billboard technique. The difference is that the particles will be rendered to a separate texture instead of the default frame buffer. This image can be blended with the frame buffer in a post process eg. with a compositor. Not only one texture is used while rendering the particles but two (with multiple render targets): one for the color of the particles and one is a so called heat texture. With the second texture we can simulate fire heat shimmering. It should store offset values that are used at post processing. Higher offset values result higher distorsion in the image. So the shader that renders fire particles should be prepared to render into two render targets, output the color in the first and output 2D offset values in the second texture. One compositor script should use these textures. It can refer to them by name: ILLUM_FIRE_COLOR_TEXTURE and ILLUM_FIRE_HEAT_TEXTURE. The compositior should blend the color texture with the frame buffer using the offsets stored in the heat texture.
There is also an option to set the resolution of these two textures smaller than the frame buffer. This speeds up rendering but decreases quality. This can be set with the function OgreIlluminationManager::setFireRenderTargetSize(int size). (If size is two the resolution of these textures will be half of the frame buffer resolution, if it is three it will be third of the frame buffer resolution etc..)

Name:

Fire

Parameters:

Name | Type | Default Value | Description
texture_unit_id | unsigned int | 1 | the texture unit id where the scene depth texture will be bound
see also: Extending the Ogre Material Scripts


Back to List of Techniques

Hierarchical Particle System Technique

This is a technique for rendering a hierarchical particle system. A hierarchical particle system is a particle system made out of a multiplication of a smaller particle system. It renders an image of the smaller particle system (impostor image) and multiplies this image to achieve a bigger particle system. This way fewer computation is needed to simulate large number of particles, while the trick is usually unnoticable.

Name:

HPS

Parameters:

Name | Type | Default Value | Description
update_interval | unsigned int | 1 | update frequency (if 0 only updates once)
start_frame | unsigned int | 1 | adds an offset to the current frame number to help evenly distribute updates between frames (the frame number of the first update)
resolution | unsigned int | 256 | resolution of the impostor texture
texture_unit_id | unsigned int | 0 | the id of the texture unit state where the impostor texture should be bound to
perspective | bool | true | sets if the impostor should be rendered with a perspective projection or orthogonal
particle_script | string | "" | the texture unit id where the scene depth texture will be bound
material | string | "" | use this specific material for the small particle system while rendering the impostor - if empty string it will use the material defined in the particle script of the small particle system (particle_script)
vparam_radius | string | "" | name of the gpu vertex program parameter where the small particle system bounding radius should be bound to - if empty string no parameter is bound
fparam_radius | string | "" | name of the gpu fragment program parameter where the small particle system bounding radius should be bound to - if empty string no parameter is bound
see also: Extending the Ogre Material Scripts


Back to List of Techniques

Light Illumination Volume Technique

This is a technique for rendering a light illumination volume of a particle system. Light illumination volumes are used when self shadowing of particle systems should be simulated. Each layer of the volume represents the amount of transmitted light. The current implementation uses four grayscale layers, and places these layers to the four channel of a 2D light volume texture. The gpu shader of the pass defining this technique can use this texture to shadow the particles.

Name:

IllumVolume

Parameters:

Name | Type | Default Value | Description
update_interval | unsigned int | 1 | update frequency (if 0 only updates once)
start_frame | unsigned int | 1 | adds an offset to the current frame number to help evenly distribute updates between frames (the frame number of the first update)
resolution | unsigned int | 256 | resolution of the light volume texture
texture_unit_id | unsigned int | 2 | the id of the texture unit state where the resulting light illumination volume texture should be bound to (in the pass defining this technique)
material | string | "Smoke_IllumVolume" | the name of the material that is used while rendering the light volume
use_hier_system | bool | false | set this flag to true if the particle system is a hierarchical particle system
impostor_texture_unit_id | unsigned int | 0 | the id of the texture unit state where the impostor image of the smaller system should be bound to (in the material used while rendering the light volume) - only used if this is a hierearchical particle system
lightmatrix_param_name | string | "lightViewProj" | the name of the gpu vertex program parameter where the light matrix should be bound to (in the pass defining this technique)
see also: Extending the Ogre Material Scripts


Back to List of Techniques

Depth Shadow Receiver Technique

This technique defines that the object will recieve shadows from light sources using the shadow mapping method.

Name:

DepthShadowReceiver

Parameters:

Name | Type | Default Value | Description
max_light_count | unsigned int | 1 | the maximum number of light sources to recieve shadow from
vertex_program_name | string | "GTP/Basic/LightCPos_VS" | the vertex program to be used in the shadow receiving passes
fragment_program_name | string | "GTP/Basic/SM/Dist_PS" | the fragment program to be used in the shadow receiving passes - it should have one pass and the depth map of a light will be bound to the first texture unit
set_light_viewproj | bool | true | bound light space view-projection matrix to a gpu program parameter (in the shadow receiving vertex program)
set_light_view | bool | true | bound light space view matrix to a gpu program parameter (in the shadow receiving vertex program)
set_light_farplane | bool | false | bound light space projection far plane to a gpu program parameter (in the shadow receiving fragment program)
light_viewproj_param_name | string | "LightViewProj" | the name of the gpu program parameter the light space view-projection matrix should be bound to (in the shadow receiving vertex program)
light_view_param_name | string | "LightView" | the name of the gpu program parameter the light space view matrix should be bound to (in the shadow receiving vertex program)
world_view_proj_param_name | string | "WorldViewProj" | the name of the GPU program parameter the world-view-projection matrix should be bound to (in the shadow receiving vertex program)
world_param_name | string | "World" | the name of the GPU program parameter the world matrix should be bound to (in the shadow receiving vertex program)
light_farplane_param_name | string | "lightFarPlane" | the name of the gpu program parameter the light space projection far plane should be bound to (in the shadow receiving fragment program)
see also: Extending the Ogre Material Scripts


GTP Illumination Module: Main Page

  • Main Page
  • Namespaces
  • Classes

GTP Illumination Module Documentation

Generated on Wed Mar 28 11:48:46 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: Class List

  • Class List
  • Class Hierarchy
  • Class Members

GTP Illumination Module Class List

Here are the classes, structs, unions and interfaces with brief descriptions:
CausticCasterRenderTechnique | Base abstract class of a caustic caster
CausticCubeMapRenderingRun | Base abstract class that defines a rendering process of a caustic cubemap
CausticReceiverRenderTechnique | Base abstract class of rendering a caustic receiver object
ChildPsystemRenderingRun | Base abstract class that defines a rendering process of a particle system impostor image
ColorCubeMapRenderTechnique | Base abstract class of rendering a color cube map
ConvolvedCubeMapRenderTechnique | Base abstract class of rendering a color cube map which will be reduced
CubeMapRenderingRun | Base abstract class that defines a rendering process of a cubemap
CubeMapRenderTechnique | Base abstract class of rendering a cube map
DepthShadowMapRenderingRun | Base abstract class that defines a rendering process of a shadow map
DepthShadowReceiverRenderTechnique | Base abstract class of rendering an object that recieves shadows with depth map shadow technique
DistanceCubeMapRenderTechnique | Base abstract class of rendering a distance cube map
ElementaryRenderable | Base abstract class for an elementary renderable
HierarchicalParticleSystemTechnique | Base abstract class of rendering a hierarchical particle system
IlluminationManager | Base abstract class of the illumination manager
IllumVolumeRenderTechnique | Base abstract class of rendering a light volume of a particle system
LightVolumeRenderingRun | Base abstract class that defines a rendering process of a light volume texture
OgreCausticCasterRenderTechnique | CausticCasterRenderTechnique used in an OGRE environment
OgreCausticCasterRenderTechniqueFactory | RenderTechniqueFactory to create OgreCausticCasterRenderTechnique instances
OgreCausticCubeMapRenderingRun | CausticCubeMapRenderingRun used in an OGRE environment
OgreCausticReceiverRenderTechnique | CausticReceiverRenderTechnique used in an OGRE environment
OgreCausticReceiverRenderTechniqueFactory | RenderTechniqueFactory to create OgreCausticReceiverRenderTechnique instances
OgreChildPSystemRenderingRun | ChildPsystemRenderingRun used in an OGRE environment
OgreColorCubeMapRenderTechnique | ColorCubeMapRenderTechnique used in an Ogre environment
OgreColorCubeMapRenderTechniqueFactory | RenderTechniqueFactory to create OgreColorCubeMapRenderTechnique instances
OgreConvoledCubeMapRenderTechniqueFactory | RenderTechniqueFactory to create OgreConvoledCubeMapRenderTechnique instances
OgreConvolvedCubeMapRenderTechnique | ConvolvedCubeMapRenderTechnique used in an Ogre environment
OgreCubeMapRenderingRun | CubeMapRenderingRun used in an OGRE environment
OgreCubeMapRenderTechnique | CubeMapRenderTechnique used in an Ogre environment
OgreCubeMapRenderTechniqueFactory | RenderTechniqueFactory to create OgreCubeMapRenderTechnique instances
OgreDepthShadowMapRenderingRun | DepthShadowMapRenderingRun used in an OGRE environment
OgreDepthShadowReceiverRenderTechnique | DepthShadowReceiverRenderTechnique used in an OGRE environment
OgreDepthShadowReceiverRenderTechniqueFactory | RenderTechniqueFactory to create OgreDepthShadowReceiverRenderTechnique instances
OgreDistanceCubeMapRenderTechnique | DistanceCubeMapRenderTechnique used in an Ogre environment
OgreDistanceCubeMapRenderTechniqueFactory | RenderTechniqueFactory to create OgreDistanceCubeMapRenderTechnique instances
OgreFireRenderTechnique | A special SBBRenderTechnique used in an OGRE environment
OgreFireRenderTechniqueFactory | RenderTechniqueFactory to create OgreFireRenderTechnique instances
OgreFocusingMapRenderingRun | FocusingMapRenderingRun
OgreHierarchicalParticleSystemTechnique | HierarchicalParticleSystemTechnique used in an OGRE environment
OgreHierarchicalParticleSystemTechniqueFactory | RenderTechniqueFactory to create OgreHierarchicalParticleSystemTechnique instances
OgreIlluminationManager | Implementation of IlluminationManager in an OGRE environment
OgreIllumVolumeRenderTechnique | IllumVolumeRenderTechnique used in an OGRE environment
OgreIllumVolumeRenderTechniqueFactory | RenderTechniqueFactory to create OgreIllumVolumeRenderTechnique instances
OgreLightVolumeRenderingRun | LightVolumeRenderingRun used in an OGRE environment
OgrePathMapRenderTechnique | A technique that defines that the rendering of the object will use the path map technique
OgrePathMapRenderTechniqueFactory | RenderTechniqueFactory to create OgrePathMapRenderTechnique instances
OgrePhaseTextureRenderingRun | PhaseTextureRenderingRun used in an OGRE environment
OgrePhotonMapRenderingRun | PhotonMapRenderingRun used in an OGRE environment
OgrePMEntryPointMapRenderingRun | Entry point map computing run
OgrePMWeightComputeRenderingRun | Weight computing rendering run
OgreReducedCubeMapRenderingRun | ReducedCubeMapRenderingRun used in an OGRE environment
OgreRenderable | Class to wrap different Ogre Renderable types
OgreRenderingRun | Base class of a RenderingRun in an OGRE environment
OgreRenderTechnique | Class of RenderTechniques used in an OGRE environment
OgreSBBRenderTechnique | SBBRenderTechnique used in an OGRE environment
OgreSBBRenderTechniqueFactory | RenderTechniqueFactory to create OgreSBBRenderTechnique instances
OgreSceneCameraDepthRenderingRun | SceneCameraDepthRenderingRun used in an OGRE environment
OgreSharedRuns | Class of SharedRuns used in an OGRE environment
OgreTechniqueGroup | Base class of a SharedRuns in an OGRE environment
PathMapClusters | Structure to store path map cluster information for a subentity
PathMapEntryPoint | Structure of a path map entry point
PhaseTextureRenderingRun | Base abstract class that defines a rendering process that creates phase texture
PhotonMapRenderingRun | Base abstract class that defines a rendering process of a photon hit map
ReducedCubeMapRenderingRun | Base abstract class that defines a rendering process of a downsampled color-cubemap
RenderingRun | Base class for a computation module
RenderTechnique | Base class for a rendering technique
RenderTechniqueFactory | Base abstract class for creating RenderTechnique instances
SBBRenderTechnique | Base abstract class of rendering a particle system with the spherical billboard method
SceneCameraDepthRenderingRun | Base abstract class that defines a rendering process that creates depth map fro the camera
SharedRuns | Base abstract class for a collection of shared resources (RenderingRuns)
TechniqueGroup | Base abstract class for a collection of techniques
UpdateListener | Event handler class
Generated on Wed Mar 28 11:48:46 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: CausticCasterRenderTechnique Class Reference

CausticCasterRenderTechnique Class Reference

Base abstract class of a caustic caster. More...

Inheritance diagram for CausticCasterRenderTechnique:

RenderTechnique OgreCausticCasterRenderTechnique List of all members.

Public Member Functions

CausticCasterRenderTechnique (unsigned long startFrame, unsigned long photonMapUpdateInterval, unsigned int photonMapResolution, unsigned int causticCubeMapResolution, bool updateAllFace, bool useDistance, ElementaryRenderable *parentRenderable, TechniqueGroup *parentTechniqueGroup)
Constructor.
void | runChanged (RenderingRunType runType, RenderingRun *run)
Called after one of he shared runs changes.
virtual void | runUpdated (RenderingRunType runType, RenderingRun *run)
Called after one of he shared runs updates.
virtual void | update (unsigned long frameNum)
Updates the resources in the given frame.
virtual class OgreRenderTechnique * | asOgreRenderTechnique ()
Conversion to OgreRenderTechnique.
ElementaryRenderable * getParentRenderable ()
Retrieves the renderable this technique operates on.

Protected Member Functions

virtual void | photonMapRunChanged (RenderingRun *run)=0
Called if the changed run is a PhotonMapRenderingRun.
virtual void | causticCubeMapRunChanged (RenderingRun *run)=0
Called if the changed run is a CausticCubeMapRenderingRun.
virtual void | distanceCubeMapRunChanged (RenderingRun *run)=0
Called if the changed run is a DistanceCubeMapRenderingRun.
virtual void | distanceCubeMapRunUpdated (RenderingRun *run)=0
Called if the updated run is a DistanceCubeMapRenderingRun.
virtual RenderingRun * | createPhotonMapRun ()=0
Creates a PhotonMapRenderingRun.
virtual RenderingRun * | createCausticCubeMapRun ()=0
Creates a CausticCubeMapRenderingRun.
virtual RenderingRun * | createDistanceCubeMapRun ()=0
Creates a DistanceCubeMapRenderingRun.

Protected Attributes

bool | updateAllFace
defines if all cubemap faces should be updated in a frame or only one face per frame
bool | useDistance
tells if a distance cubemap impostor should be used in photon hit calculation (recommended)
unsigned long | photonMapUpdateInterval
photonmap update frequency
unsigned int | photonMapResolution
photonmap resolution
unsigned int | causticCubeMapResolution
caustic cubemap resolution
unsigned long | startFrame
offset in frame number used during update
ElementaryRenderable * parentRenderable
The renderable this technique operates on.
TechniqueGroup * parentTechniqueGroup
The TechniqueGroup this RenderedTechnique is attached to.
SharedRuns * sharedRuns
The SharedRuns this RenderedTechnique is attached to.

Detailed Description

Base abstract class of a caustic caster.

This technique defines that the given object needs a caustic photon map and a caustic cubemap. The caustic cube map will be used by caustic receivers.

Constructor & Destructor Documentation

CausticCasterRenderTechnique::CausticCasterRenderTechnique | ( | unsigned long | startFrame,
 |  | unsigned long | photonMapUpdateInterval,
 |  | unsigned int | photonMapResolution,
 |  | unsigned int | causticCubeMapResolution,
 |  | bool | updateAllFace,
 |  | bool | useDistance,
 |  | ElementaryRenderable * | parentRenderable,
 |  | TechniqueGroup * | parentTechniqueGroup
 | ) |  |

Constructor.

Parameters:
startFrame | adds an offset to the current frame number to help evenly distribute updates between frames
photonMapUpdateInterval | photon map and caustic cubemap update frequency
photonMapResolution | photon map resolution
causticCubeMapResolution | caustic cubemap resolution
updateAllFace | defines if all cubemap faces should be updated in a frame or only one face per frame
useDistance | tells if a distance cubemap impostor should be used in photon hit calculation (recommended)
parentRenderable | the object to operate on
parentTechniqueGroup | the TechniqueGroup this RenderedTechnique is attached to

Member Function Documentation

void CausticCasterRenderTechnique::runChanged | ( | RenderingRunType | runType,
 |  | RenderingRun * | run |
 | ) |  |  | [virtual]

Called after one of he shared runs changes.

Parameters:
runType | enum describing the type of the changed run
run | pointer to the changed RenderingRun

Reimplemented from RenderTechnique.

void CausticCasterRenderTechnique::runUpdated | ( | RenderingRunType | runType,
 |  | RenderingRun * | run |
 | ) |  |  | [virtual]

Called after one of he shared runs updates.

Parameters:
runType | enum describing the type of the updated run
run | pointer to the updated RenderingRun

Reimplemented from RenderTechnique.

virtual void CausticCasterRenderTechnique::photonMapRunChanged ( RenderingRun * run ) [protected, pure virtual]

Called if the changed run is a PhotonMapRenderingRun.

Parameters:
run pointer to the changed PhotonMapRenderingRun

Implemented in OgreCausticCasterRenderTechnique.

virtual void CausticCasterRenderTechnique::causticCubeMapRunChanged ( RenderingRun * run ) [protected, pure virtual]

Called if the changed run is a CausticCubeMapRenderingRun.

Parameters:
run pointer to the changed CausticCubeMapRenderingRun

Implemented in OgreCausticCasterRenderTechnique.

virtual void CausticCasterRenderTechnique::distanceCubeMapRunChanged ( RenderingRun * run ) [protected, pure virtual]

Called if the changed run is a DistanceCubeMapRenderingRun.

Parameters:
run pointer to the changed DistanceCubeMapRenderingRun

Implemented in OgreCausticCasterRenderTechnique.

virtual void CausticCasterRenderTechnique::distanceCubeMapRunUpdated ( RenderingRun * run ) [protected, pure virtual]

Called if the updated run is a DistanceCubeMapRenderingRun.

Parameters:
run pointer to the updated DistanceCubeMapRenderingRun

Implemented in OgreCausticCasterRenderTechnique.

virtual RenderingRun* CausticCasterRenderTechnique::createPhotonMapRun ( ) [protected, pure virtual]

Creates a PhotonMapRenderingRun.

Returns:
the new PhotonMapRenderingRun instance.

Implemented in OgreCausticCasterRenderTechnique.

virtual RenderingRun* CausticCasterRenderTechnique::createCausticCubeMapRun ( ) [protected, pure virtual]

Creates a CausticCubeMapRenderingRun.

Returns:
the new CausticCubeMapRenderingRun instance.

Implemented in OgreCausticCasterRenderTechnique.

virtual RenderingRun* CausticCasterRenderTechnique::createDistanceCubeMapRun ( ) [protected, pure virtual]

Creates a DistanceCubeMapRenderingRun.

Returns:
the new DistanceCubeMapRenderingRun instance.

Implemented in OgreCausticCasterRenderTechnique.

virtual void RenderTechnique::update ( unsigned long frameNum ) [inline, virtual, inherited]

Updates the resources in the given frame.

A RenderTechnique is usually need some resources from several runs, so these runs will be updated.

Parameters:
frameNum the actual framenumber

Reimplemented in ColorCubeMapRenderTechnique, ConvolvedCubeMapRenderTechnique, DistanceCubeMapRenderTechnique, HierarchicalParticleSystemTechnique, IllumVolumeRenderTechnique, OgreCausticReceiverRenderTechnique, OgreColorCubeMapRenderTechnique, OgreConvolvedCubeMapRenderTechnique, OgreDepthShadowReceiverRenderTechnique, OgreDistanceCubeMapRenderTechnique, OgreFireRenderTechnique, OgrePathMapRenderTechnique, and OgreSBBRenderTechnique.

virtual class OgreRenderTechnique* RenderTechnique::asOgreRenderTechnique ( ) [inline, virtual, inherited]

Conversion to OgreRenderTechnique.

This function is needed because of virtual inheritance.

Reimplemented in OgreRenderTechnique.

Generated on Wed Mar 28 11:48:46 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: CausticCubeMapRenderingRun Class Reference

CausticCubeMapRenderingRun Class Reference

Base abstract class that defines a rendering process of a caustic cubemap. More...

Inheritance diagram for CausticCubeMapRenderingRun:

RenderingRun OgreCausticCubeMapRenderingRun List of all members.

Public Member Functions

CausticCubeMapRenderingRun (unsigned long startFrame, unsigned long updateInterval, unsigned int resolution, bool updateAllFace)
Constructor.
virtual void | photonMapChanged (RenderingRun *run)=0
Called if the changed run is a PhotonMapRenderingRun.
bool | update (unsigned long frameNum)
Calls updateFrame() if the run needs update according to its starting frame and update interval and has not been allready updated in this frame.
virtual class OgreRenderingRun * | asOgreRenderingRun ()
Conversion to OgreRenderRun.
virtual bool | canJoin (RenderingRun *run)
Returns true if two runs can be joined.

Protected Member Functions

virtual void | createCausticCubeMap ()=0
Creates a cubemap texture used for the caustic-cubemap.
virtual void | updateCubeFace (int facenum)=0
Updates one face of the cubemap.
virtual bool | faceNeedsUpdate (int facenum)=0
Checks if a cubemap face needs to be updated.
virtual void | updateFrame (unsigned long frameNum)
This function does the actual update in a frame.
virtual bool | needUpdate (unsigned long frameNum)
Returns if this run needs update.

Protected Attributes

bool | updateAllFace
defines if all cubemap faces should be updated in a frame or only one face per frame
unsigned char | currentFace
the number of the face to be updated
unsigned int | resolution
the resolution of the cubemap texture that was created by this run
unsigned long | lastupdated
The number of the last frame this run was updated.
unsigned long | startFrame
The number of the frame this run should be updated first.
unsigned long | updateInterval
Refresh frequency in frames.

Detailed Description

Base abstract class that defines a rendering process of a caustic cubemap.

A caustic cubemap stores caustic light spots caused by a caustic emitter object.

Constructor & Destructor Documentation

CausticCubeMapRenderingRun::CausticCubeMapRenderingRun | ( | unsigned long | startFrame,
 |  | unsigned long | updateInterval,
 |  | unsigned int | resolution,
 |  | bool | updateAllFace
 | ) |  |

Constructor.

Parameters:
startFrame | adds an offset to the current frame number to help evenly distribute updates between frames
updateInterval | photon map update frequency
resolution | photon map resolution
updateAllFace | defines if all cubemap faces should be updated in a frame or only one face per frame

Member Function Documentation

virtual void CausticCubeMapRenderingRun::photonMapChanged ( RenderingRun * run ) [pure virtual]

Called if the changed run is a PhotonMapRenderingRun.

Parameters:
run pointer to the changed PhotonMapRenderingRun

Implemented in OgreCausticCubeMapRenderingRun.

virtual void CausticCubeMapRenderingRun::updateCubeFace ( int facenum ) [inline, protected, pure virtual]

Updates one face of the cubemap.

Parameters:
facenum the number of the face to be updated

Implemented in OgreCausticCubeMapRenderingRun.

virtual bool CausticCubeMapRenderingRun::faceNeedsUpdate ( int facenum ) [protected, pure virtual]

Checks if a cubemap face needs to be updated.

If the object we are updating the cubemap for is far from the camera, or too small, or the given cubemapface does not have significant effect on the rendering the face can be skipped.

Parameters:
facenum the number of the face to be checked

Implemented in OgreCausticCubeMapRenderingRun.

void CausticCubeMapRenderingRun::updateFrame ( unsigned long frameNum ) [protected, virtual]

This function does the actual update in a frame.

Parameters:
frameNum current frame number

Reimplemented from RenderingRun.

virtual class OgreRenderingRun* RenderingRun::asOgreRenderingRun ( ) [inline, virtual, inherited]

Conversion to OgreRenderRun.

This function is needed because of virtual inheritance.

Reimplemented in OgreRenderingRun, and OgreRenderingRun.

virtual bool RenderingRun::canJoin ( RenderingRun * run ) [inline, virtual, inherited]

Returns true if two runs can be joined.

In some cases special requirements should stand to join two runs (even if they have the same type). Eg.: two caustic cube map generation technique should only be joined if they use the same material when rendering the caustic cubemap.

Reimplemented in OgreCausticCubeMapRenderingRun, OgreChildPSystemRenderingRun, and OgrePhotonMapRenderingRun.

virtual bool RenderingRun::needUpdate ( unsigned long frameNum ) [inline, protected, virtual, inherited]

Returns if this run needs update.

This tipically depends on the upate interval and the starting frame number.

Parameters:
frameNum current frame number

Reimplemented in OgreFocusingMapRenderingRun, and OgrePMEntryPointMapRenderingRun.

Generated on Wed Mar 28 11:48:46 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: CausticReceiverRenderTechnique Class Reference

CausticReceiverRenderTechnique Class Reference

Base abstract class of rendering a caustic receiver object. More...

Inheritance diagram for CausticReceiverRenderTechnique:

RenderTechnique OgreCausticReceiverRenderTechnique List of all members.

Public Member Functions

CausticReceiverRenderTechnique (ElementaryRenderable *parentRenderable, TechniqueGroup *parentTechniqueGroup)
Constructor.
virtual void | update (unsigned long frameNum)
Updates the resources in the given frame.
virtual void | runChanged (RenderingRunType runType, RenderingRun *run)
Called after one of he shared runs changes.
virtual void | runUpdated (RenderingRunType runType, RenderingRun *run)
Called after one of he shared runs updates.
virtual class OgreRenderTechnique * | asOgreRenderTechnique ()
Conversion to OgreRenderTechnique.
ElementaryRenderable * getParentRenderable ()
Retrieves the renderable this technique operates on.

Protected Attributes

ElementaryRenderable * parentRenderable
The renderable this technique operates on.
TechniqueGroup * parentTechniqueGroup
The TechniqueGroup this RenderedTechnique is attached to.
SharedRuns * sharedRuns
The SharedRuns this RenderedTechnique is attached to.

Detailed Description

Base abstract class of rendering a caustic receiver object.

Constructor & Destructor Documentation

CausticReceiverRenderTechnique::CausticReceiverRenderTechnique | ( | ElementaryRenderable * | parentRenderable,
 |  | TechniqueGroup * | parentTechniqueGroup
 | ) |  |

Constructor.

Parameters:
parentRenderable | the object to operate on
parentTechniqueGroup | the TechniqueGroup this RenderedTechnique is attached to

Member Function Documentation

virtual void RenderTechnique::update ( unsigned long frameNum ) [inline, virtual, inherited]

Updates the resources in the given frame.

A RenderTechnique is usually need some resources from several runs, so these runs will be updated.

Parameters:
frameNum the actual framenumber

Reimplemented in ColorCubeMapRenderTechnique, ConvolvedCubeMapRenderTechnique, DistanceCubeMapRenderTechnique, HierarchicalParticleSystemTechnique, IllumVolumeRenderTechnique, OgreCausticReceiverRenderTechnique, OgreColorCubeMapRenderTechnique, OgreConvolvedCubeMapRenderTechnique, OgreDepthShadowReceiverRenderTechnique, OgreDistanceCubeMapRenderTechnique, OgreFireRenderTechnique, OgrePathMapRenderTechnique, and OgreSBBRenderTechnique.

virtual void RenderTechnique::runChanged | ( | RenderingRunType | runType,
 |  | RenderingRun * | run |
 | ) |  |  | [inline, virtual, inherited]

Called after one of he shared runs changes.

Parameters:
runType | enum describing the type of the changed run
run | pointer to the changed RenderingRun

Reimplemented in CausticCasterRenderTechnique, ColorCubeMapRenderTechnique, ConvolvedCubeMapRenderTechnique, CubeMapRenderTechnique, DistanceCubeMapRenderTechnique, HierarchicalParticleSystemTechnique, and IllumVolumeRenderTechnique.

virtual void RenderTechnique::runUpdated | ( | RenderingRunType | runType,
 |  | RenderingRun * | run |
 | ) |  |  | [inline, virtual, inherited]

Called after one of he shared runs updates.

Parameters:
runType | enum describing the type of the updated run
run | pointer to the updated RenderingRun

Reimplemented in CausticCasterRenderTechnique, ColorCubeMapRenderTechnique, CubeMapRenderTechnique, DistanceCubeMapRenderTechnique, HierarchicalParticleSystemTechnique, and IllumVolumeRenderTechnique.

virtual class OgreRenderTechnique* RenderTechnique::asOgreRenderTechnique ( ) [inline, virtual, inherited]

Conversion to OgreRenderTechnique.

This function is needed because of virtual inheritance.

Reimplemented in OgreRenderTechnique.

Generated on Wed Mar 28 11:48:47 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: ChildPsystemRenderingRun Class Reference

ChildPsystemRenderingRun Class Reference

Base abstract class that defines a rendering process of a particle system impostor image. More...

Inheritance diagram for ChildPsystemRenderingRun:

RenderingRun OgreChildPSystemRenderingRun List of all members.

Public Member Functions

ChildPsystemRenderingRun (unsigned int resolution, bool perspectiveRendering, unsigned long startFrame, unsigned long updateInterval)
Constructor.
bool | update (unsigned long frameNum)
Calls updateFrame() if the run needs update according to its starting frame and update interval and has not been allready updated in this frame.
virtual class OgreRenderingRun * | asOgreRenderingRun ()
Conversion to OgreRenderRun.
virtual bool | canJoin (RenderingRun *run)
Returns true if two runs can be joined.

Protected Member Functions

virtual void | updateFrame (unsigned long frameNum)=0
This function does the actual update in a frame.
virtual void | createImpostorTexture ()=0
Creates an impostor texture that can be used as a rendertarget during impostor rendering.
virtual bool | needUpdate (unsigned long frameNum)
Returns if this run needs update.

Protected Attributes

unsigned int | resolution
the resolution of the impostor image
bool | perspectiveRendering
sets if the impostor should be rendered with a perspective projection or orthogonal
unsigned long | lastupdated
The number of the last frame this run was updated.
unsigned long | startFrame
The number of the frame this run should be updated first.
unsigned long | updateInterval
Refresh frequency in frames.

Detailed Description

Base abstract class that defines a rendering process of a particle system impostor image.

This impostor can be used as a texture for ither particle systems. This rendering method is called hieararchical particle system.

Constructor & Destructor Documentation

ChildPsystemRenderingRun::ChildPsystemRenderingRun | ( | unsigned int | resolution,
 |  | bool | perspectiveRendering,
 |  | unsigned long | startFrame,
 |  | unsigned long | updateInterval |
 | ) |  |  | [inline]

Constructor.

Parameters:
resolution | the resolution of the impostor image
perspectiveRendering | sets if the impostor should be rendered with a perspective projection or orthogonal
startFrame | adds an offset to the current frame number to help evenly distribute updates between frames
updateInterval | update frequency

Member Function Documentation

virtual void ChildPsystemRenderingRun::updateFrame ( unsigned long frameNum ) [protected, pure virtual]

This function does the actual update in a frame.

Parameters:
frameNum current frame number

Reimplemented from RenderingRun.

Implemented in OgreChildPSystemRenderingRun.

virtual class OgreRenderingRun* RenderingRun::asOgreRenderingRun ( ) [inline, virtual, inherited]

Conversion to OgreRenderRun.

This function is needed because of virtual inheritance.

Reimplemented in OgreRenderingRun, and OgreRenderingRun.

virtual bool RenderingRun::canJoin ( RenderingRun * run ) [inline, virtual, inherited]

Returns true if two runs can be joined.

In some cases special requirements should stand to join two runs (even if they have the same type). Eg.: two caustic cube map generation technique should only be joined if they use the same material when rendering the caustic cubemap.

Reimplemented in OgreCausticCubeMapRenderingRun, OgreChildPSystemRenderingRun, and OgrePhotonMapRenderingRun.

virtual bool RenderingRun::needUpdate ( unsigned long frameNum ) [inline, protected, virtual, inherited]

Returns if this run needs update.

This tipically depends on the upate interval and the starting frame number.

Parameters:
frameNum current frame number

Reimplemented in OgreFocusingMapRenderingRun, and OgrePMEntryPointMapRenderingRun.

Generated on Wed Mar 28 11:48:47 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: ColorCubeMapRenderTechnique Class Reference

ColorCubeMapRenderTechnique Class Reference

Base abstract class of rendering a color cube map. More...

Inheritance diagram for ColorCubeMapRenderTechnique:

CubeMapRenderTechnique RenderTechnique OgreColorCubeMapRenderTechnique List of all members.

Public Member Functions

ColorCubeMapRenderTechnique (unsigned long startFrame, unsigned long cubeMapUpdateInterval, unsigned int cubeMapResolution, bool useDistCalc, bool useFaceAngleCalc, float distTolerance, float angleTolerance, bool updateAllFace, bool renderSelf, bool renderEnvironment, int layer, ElementaryRenderable *parentRenderable, TechniqueGroup *parentTechniqueGroup)
Constructor.
virtual void | update (unsigned long frameNum)
Updates the resources in the given frame.
void | runChanged (RenderingRunType runType, RenderingRun *run)
Called after one of he shared runs changes.
void | runUpdated (RenderingRunType runType, RenderingRun *run)
Called after one of he shared runs updates.
virtual class OgreRenderTechnique * | asOgreRenderTechnique ()
Conversion to OgreRenderTechnique.
ElementaryRenderable * getParentRenderable ()
Retrieves the renderable this technique operates on.

Protected Member Functions

virtual void | colorCubeMapRunChanged (RenderingRun *run)=0
Called if the color cubemap rendering run object changes.
virtual void | colorCubeMapRunUpdated (RenderingRun *run)=0
Called if the color cubemap rendering run object is updated.
virtual RenderingRun * | createCubeMapRun ()=0
Creates a CubeMapRenderingRun.
virtual void | cubeMapRunChanged (RenderingRun *run)=0
Called if the changed run is a CubeMapRenderingRun.
virtual void | cubeMapRunUpdated (RenderingRun *run)=0
Called if the updated run is a CubeMapRenderingRun.

Protected Attributes

bool | useDistCalc
a flag to skip cube face update if object is far away or too small.
bool | useFaceAngleCalc
a flag to skip cube face update the face is neglible.
float | distTolerance
A value used in face skip test.
float | angleTolerance
A value used in face skip test.
bool | updateAllFace
defines if all cubemap faces should be updated in a frame or only one face per frame
unsigned long | cubeMapUpdateInterval
color-cubemap update frequency
unsigned int | cubeMapResolution
color-cubemap resolution
unsigned long | startFrame
offset in frame number used during update
bool | renderSelf
Sets if the object should be rendered to the cube map.
bool | renderEnvironment
Sets if the environment should be rendered to the cube map.
int | layer
The layer of the cubemap.
RenderingRunType | cubemapLayer
The exact run type of this run (according to the actual layer).
ElementaryRenderable * parentRenderable
The renderable this technique operates on.
TechniqueGroup * parentTechniqueGroup
The TechniqueGroup this RenderedTechnique is attached to.
SharedRuns * sharedRuns
The SharedRuns this RenderedTechnique is attached to.

Detailed Description

Base abstract class of rendering a color cube map.

This technique defines that the final rendering of an object needs a cubmap of the colors of the surrounding environment.

Constructor & Destructor Documentation

ColorCubeMapRenderTechnique::ColorCubeMapRenderTechnique | ( | unsigned long | startFrame,
 |  | unsigned long | cubeMapUpdateInterval,
 |  | unsigned int | cubeMapResolution,
 |  | bool | useDistCalc,
 |  | bool | useFaceAngleCalc,
 |  | float | distTolerance,
 |  | float | angleTolerance,
 |  | bool | updateAllFace,
 |  | bool | renderSelf,
 |  | bool | renderEnvironment,
 |  | int | layer,
 |  | ElementaryRenderable * | parentRenderable,
 |  | TechniqueGroup * | parentTechniqueGroup
 | ) |  |

Constructor.

Parameters:
startFrame | adds an offset to the current frame number to help evenly distribute updates between frames
cubeMapUpdateInterval | update frequency
cubeMapResolution | color cubemap resolution
useDistCalc | flag to skip cube face update if object is far away
useFaceAngleCalc | flag to skip cube face update if face is neglible
distTolerance | distance tolerance used in face skip
angleTolerance | angle tolerance used in face skip
updateAllFace | defines if all cubemap faces should be updated in a frame or only one face per frame
renderSelf | sets if the object should be rendered to the cube map
renderEnvironment | sets if the environment should be rendered to the cube map
layer | the layer of this cubemap
parentRenderable | the object to operate on
parentTechniqueGroup | the TechniqueGroup this RenderedTechnique is attached to

Member Function Documentation

void ColorCubeMapRenderTechnique::update ( unsigned long frameNum ) [virtual]

Updates the resources in the given frame.

Parameters:
frameNum the actual framenumber

Reimplemented from RenderTechnique.

Reimplemented in OgreColorCubeMapRenderTechnique.

void ColorCubeMapRenderTechnique::runChanged | ( | RenderingRunType | runType,
 |  | RenderingRun * | run |
 | ) |  |  | [virtual]

Called after one of he shared runs changes.

Parameters:
runType | enum describing the type of the changed run
run | pointer to the changed RenderingRun

Reimplemented from CubeMapRenderTechnique.

void ColorCubeMapRenderTechnique::runUpdated | ( | RenderingRunType | runType,
 |  | RenderingRun * | run |
 | ) |  |  | [virtual]

Called after one of he shared runs updates.

Parameters:
runType | enum describing the type of the updated run
run | pointer to the updated RenderingRun

Reimplemented from CubeMapRenderTechnique.

virtual void ColorCubeMapRenderTechnique::colorCubeMapRunChanged ( RenderingRun * run ) [protected, pure virtual]

Called if the color cubemap rendering run object changes.

Parameters:
run pointer to the new rendering run object

Implemented in OgreColorCubeMapRenderTechnique.

virtual void ColorCubeMapRenderTechnique::colorCubeMapRunUpdated ( RenderingRun * run ) [protected, pure virtual]

Called if the color cubemap rendering run object is updated.

Parameters:
run pointer to the rendering run object

Implemented in OgreColorCubeMapRenderTechnique.

virtual RenderingRun* CubeMapRenderTechnique::createCubeMapRun ( ) [protected, pure virtual, inherited]

Creates a CubeMapRenderingRun.

Returns:
the new CubeMapRenderingRun instance.

Implemented in OgreCubeMapRenderTechnique.

virtual void CubeMapRenderTechnique::cubeMapRunChanged ( RenderingRun * run ) [protected, pure virtual, inherited]

Called if the changed run is a CubeMapRenderingRun.

Parameters:
run pointer to the new CubeMapRenderingRun

Implemented in OgreCubeMapRenderTechnique.

virtual void CubeMapRenderTechnique::cubeMapRunUpdated ( RenderingRun * run ) [protected, pure virtual, inherited]

Called if the updated run is a CubeMapRenderingRun.

Parameters:
run pointer to the updated CubeMapRenderingRun

Implemented in OgreCubeMapRenderTechnique.

virtual class OgreRenderTechnique* RenderTechnique::asOgreRenderTechnique ( ) [inline, virtual, inherited]

Conversion to OgreRenderTechnique.

This function is needed because of virtual inheritance.

Reimplemented in OgreRenderTechnique.

Member Data Documentation

bool CubeMapRenderTechnique::useDistCalc [protected, inherited]

a flag to skip cube face update if object is far away or too small.

See also:
distTolerance

bool CubeMapRenderTechnique::useFaceAngleCalc [protected, inherited]

a flag to skip cube face update the face is neglible.

See also:
angleTolerance

float CubeMapRenderTechnique::distTolerance [protected, inherited]

A value used in face skip test.

The higher this value gets the more precise, but slower the method will be.

float CubeMapRenderTechnique::angleTolerance [protected, inherited]

A value used in face skip test.

The higher this value gets the more precise, but slower the method will be.

int CubeMapRenderTechnique::layer [protected, inherited]

The layer of the cubemap.

This extension was created to achieve effect such as multiple reflections and refractions that require more complete sampling of the scene. With this extension we can render the environment into several cubemap layers eg. with depth peeling.

Generated on Wed Mar 28 11:48:47 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: ConvolvedCubeMapRenderTechnique Class Reference

ConvolvedCubeMapRenderTechnique Class Reference

Base abstract class of rendering a color cube map which will be reduced. More...

Inheritance diagram for ConvolvedCubeMapRenderTechnique:

CubeMapRenderTechnique RenderTechnique OgreConvolvedCubeMapRenderTechnique List of all members.

Public Member Functions

ConvolvedCubeMapRenderTechnique (unsigned long startFrame, unsigned long cubeMapUpdateInterval, unsigned int cubeMapResolution, unsigned int reducedCubeMapResolution, bool useDistCalc, bool useFaceAngleCalc, float distTolerance, float angleTolerance, bool updateAllFace, bool renderSelf, bool renderEnvironment, ElementaryRenderable *parentRenderable, TechniqueGroup *parentTechniqueGroup)
Constructor.
virtual void | update (unsigned long frameNum)
Updates the resources in the given frame.
void | runChanged (RenderingRunType runType, RenderingRun *run)
Called after one of he shared runs changes.
void | runUpdated (RenderingRunType runType, RenderingRun *run)
Called after one of he shared runs updates.
virtual class OgreRenderTechnique * | asOgreRenderTechnique ()
Conversion to OgreRenderTechnique.
ElementaryRenderable * getParentRenderable ()
Retrieves the renderable this technique operates on.

Protected Member Functions

virtual void | reducedCubeMapRunChanged (RenderingRun *run)=0
Called if the changed run is a ReducedCubeMapRenderingRun.
virtual void | colorCubeMapRunChanged (RenderingRun *run)=0
Called if the changed run is a CubeMapRenderingRun (containing colors of the environment).
virtual RenderingRun * | createReducedCubeMapRun ()=0
Creates a ReducedCubeMapRenderingRun.
virtual RenderingRun * | createCubeMapRun ()=0
Creates a CubeMapRenderingRun.
virtual void | cubeMapRunChanged (RenderingRun *run)=0
Called if the changed run is a CubeMapRenderingRun.
virtual void | cubeMapRunUpdated (RenderingRun *run)=0
Called if the updated run is a CubeMapRenderingRun.

Protected Attributes

unsigned int | reducedCubeMapResolution
The resolution of the downsampled cubemap created by this run.
bool | useDistCalc
a flag to skip cube face update if object is far away or too small.
bool | useFaceAngleCalc
a flag to skip cube face update the face is neglible.
float | distTolerance
A value used in face skip test.
float | angleTolerance
A value used in face skip test.
bool | updateAllFace
defines if all cubemap faces should be updated in a frame or only one face per frame
unsigned long | cubeMapUpdateInterval
color-cubemap update frequency
unsigned int | cubeMapResolution
color-cubemap resolution
unsigned long | startFrame
offset in frame number used during update
bool | renderSelf
Sets if the object should be rendered to the cube map.
bool | renderEnvironment
Sets if the environment should be rendered to the cube map.
int | layer
The layer of the cubemap.
RenderingRunType | cubemapLayer
The exact run type of this run (according to the actual layer).
ElementaryRenderable * parentRenderable
The renderable this technique operates on.
TechniqueGroup * parentTechniqueGroup
The TechniqueGroup this RenderedTechnique is attached to.
SharedRuns * sharedRuns
The SharedRuns this RenderedTechnique is attached to.

Detailed Description

Base abstract class of rendering a color cube map which will be reduced.

This technique defines that the final rendering of an object needs a reduced sized cubmap of the colors of the surrounding environment. This reduced sized cubemap is created with averaging the original cubemap. This reduced cubemap can easily be convolved in the final shading to acheve special effects like diffuse reflections.

Constructor & Destructor Documentation

ConvolvedCubeMapRenderTechnique::ConvolvedCubeMapRenderTechnique | ( | unsigned long | startFrame,
 |  | unsigned long | cubeMapUpdateInterval,
 |  | unsigned int | cubeMapResolution,
 |  | unsigned int | reducedCubeMapResolution,
 |  | bool | useDistCalc,
 |  | bool | useFaceAngleCalc,
 |  | float | distTolerance,
 |  | float | angleTolerance,
 |  | bool | updateAllFace,
 |  | bool | renderSelf,
 |  | bool | renderEnvironment,
 |  | ElementaryRenderable * | parentRenderable,
 |  | TechniqueGroup * | parentTechniqueGroup
 | ) |  |

Constructor.

Parameters:
startFrame | adds an offset to the current frame number to help evenly distribute updates between frames
cubeMapUpdateInterval | update frequency
cubeMapResolution | color cubemap resolution
reducedCubeMapResolution | the resolution of the reduced cube map
useDistCalc | flag to skip cube face update if object is far away
useFaceAngleCalc | flag to skip cube face update if face is neglible
distTolerance | distance tolerance used in face skip
angleTolerance | angle tolerance used in face skip
updateAllFace | defines if all cubemap faces should be updated in a frame or only one face per frame
renderSelf | sets if the object should be rendered to the cube map
renderEnvironment | sets if the environment should be rendered to the cube map
parentRenderable | the object to operate on
parentTechniqueGroup | the TechniqueGroup this RenderedTechnique is attached to

Member Function Documentation

void ConvolvedCubeMapRenderTechnique::update ( unsigned long frameNum ) [virtual]

Updates the resources in the given frame.

Parameters:
frameNum the actual framenumber

Reimplemented from RenderTechnique.

Reimplemented in OgreConvolvedCubeMapRenderTechnique.

void ConvolvedCubeMapRenderTechnique::runChanged | ( | RenderingRunType | runType,
 |  | RenderingRun * | run |
 | ) |  |  | [virtual]

Called after one of he shared runs changes.

Parameters:
runType | enum describing the type of the changed run
run | pointer to the changed RenderingRun

Reimplemented from CubeMapRenderTechnique.

virtual void ConvolvedCubeMapRenderTechnique::reducedCubeMapRunChanged ( RenderingRun * run ) [protected, pure virtual]

Called if the changed run is a ReducedCubeMapRenderingRun.

Parameters:
run pointer to the changed ReducedCubeMapRenderingRun

Implemented in OgreConvolvedCubeMapRenderTechnique.

virtual void ConvolvedCubeMapRenderTechnique::colorCubeMapRunChanged ( RenderingRun * run ) [protected, pure virtual]

Called if the changed run is a CubeMapRenderingRun (containing colors of the environment).

Parameters:
run pointer to the changed CubeMapRenderingRun

Implemented in OgreConvolvedCubeMapRenderTechnique.

virtual RenderingRun* ConvolvedCubeMapRenderTechnique::createReducedCubeMapRun ( ) [protected, pure virtual]

Creates a ReducedCubeMapRenderingRun.

Returns:
the new ReducedCubeMapRenderingRun instance.

Implemented in OgreConvolvedCubeMapRenderTechnique.

void CubeMapRenderTechnique::runUpdated | ( | RenderingRunType | runType,
 |  | RenderingRun * | run |
 | ) |  |  | [virtual, inherited]

Called after one of he shared runs updates.

Parameters:
runType | enum describing the type of the updated run
run | pointer to the updated RenderingRun

Reimplemented from RenderTechnique.

Reimplemented in ColorCubeMapRenderTechnique, and DistanceCubeMapRenderTechnique.

virtual RenderingRun* CubeMapRenderTechnique::createCubeMapRun ( ) [protected, pure virtual, inherited]

Creates a CubeMapRenderingRun.

Returns:
the new CubeMapRenderingRun instance.

Implemented in OgreCubeMapRenderTechnique.

virtual void CubeMapRenderTechnique::cubeMapRunChanged ( RenderingRun * run ) [protected, pure virtual, inherited]

Called if the changed run is a CubeMapRenderingRun.

Parameters:
run pointer to the new CubeMapRenderingRun

Implemented in OgreCubeMapRenderTechnique.

virtual void CubeMapRenderTechnique::cubeMapRunUpdated ( RenderingRun * run ) [protected, pure virtual, inherited]

Called if the updated run is a CubeMapRenderingRun.

Parameters:
run pointer to the updated CubeMapRenderingRun

Implemented in OgreCubeMapRenderTechnique.

virtual class OgreRenderTechnique* RenderTechnique::asOgreRenderTechnique ( ) [inline, virtual, inherited]

Conversion to OgreRenderTechnique.

This function is needed because of virtual inheritance.

Reimplemented in OgreRenderTechnique.

Member Data Documentation

bool CubeMapRenderTechnique::useDistCalc [protected, inherited]

a flag to skip cube face update if object is far away or too small.

See also:
distTolerance

bool CubeMapRenderTechnique::useFaceAngleCalc [protected, inherited]

a flag to skip cube face update the face is neglible.

See also:
angleTolerance

float CubeMapRenderTechnique::distTolerance [protected, inherited]

A value used in face skip test.

The higher this value gets the more precise, but slower the method will be.

float CubeMapRenderTechnique::angleTolerance [protected, inherited]

A value used in face skip test.

The higher this value gets the more precise, but slower the method will be.

int CubeMapRenderTechnique::layer [protected, inherited]

The layer of the cubemap.

This extension was created to achieve effect such as multiple reflections and refractions that require more complete sampling of the scene. With this extension we can render the environment into several cubemap layers eg. with depth peeling.

Generated on Wed Mar 28 11:48:48 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: CubeMapRenderingRun Class Reference

CubeMapRenderingRun Class Reference

Base abstract class that defines a rendering process of a cubemap. More...

Inheritance diagram for CubeMapRenderingRun:

RenderingRun OgreCubeMapRenderingRun List of all members.

Public Member Functions

CubeMapRenderingRun (unsigned long startFrame, unsigned long updateInterval, unsigned int resolution, bool useDistCalc, bool useFaceAngleCalc, float distTolerance, float angleTolerance, bool updateAllFace, bool renderSelf, bool renderEnvironment)
Constructor.
bool | update (unsigned long frameNum)
Calls updateFrame() if the run needs update according to its starting frame and update interval and has not been allready updated in this frame.
virtual class OgreRenderingRun * | asOgreRenderingRun ()
Conversion to OgreRenderRun.
virtual bool | canJoin (RenderingRun *run)
Returns true if two runs can be joined.

Protected Member Functions

virtual void | createCubeMap ()=0
Creates a cubemap texture used for the color-cubemap.
virtual void | updateCubeFace (int facenum)=0
Updates one face of the cubemap.
virtual bool | faceNeedsUpdate (int facenum)=0
Checks if a cubemap face needs to be updated.
virtual void | updateFrame (unsigned long frameNum)
This function does the actual update in a frame.
virtual bool | needUpdate (unsigned long frameNum)
Returns if this run needs update.

Protected Attributes

bool | updateAllFace
defines if all cubemap faces should be updated in a frame or only one face per frame
unsigned char | currentFace
the number of the face to be updated
unsigned int | resolution
the resolution of the cubemap texture that was created by this run
bool | useDistCalc
a flag to skip cube face update if object is far away or too small.
bool | useFaceAngleCalc
a flag to skip cube face update the face is neglible.
float | distTolerance
A value used in face skip test.
float | angleTolerance
A value used in face skip test.
bool | renderSelf
sets if the object should be rendered to the cube map
bool | renderEnvironment
sets if the environment should be rendered to the cube map
unsigned long | lastupdated
The number of the last frame this run was updated.
unsigned long | startFrame
The number of the frame this run should be updated first.
unsigned long | updateInterval
Refresh frequency in frames.

Detailed Description

Base abstract class that defines a rendering process of a cubemap.

Constructor & Destructor Documentation

CubeMapRenderingRun::CubeMapRenderingRun | ( | unsigned long | startFrame,
 |  | unsigned long | updateInterval,
 |  | unsigned int | resolution,
 |  | bool | useDistCalc,
 |  | bool | useFaceAngleCalc,
 |  | float | distTolerance,
 |  | float | angleTolerance,
 |  | bool | updateAllFace,
 |  | bool | renderSelf,
 |  | bool | renderEnvironment
 | ) |  |

Constructor.

Parameters:
startFrame | adds an offset to the current frame number to help evenly distribute updates between frames
updateInterval | update frequency
resolution | color cubemap resolution
useDistCalc | flag to skip cube face update if object is far away
useFaceAngleCalc | flag to skip cube face update if face is neglible
distTolerance | distance tolerance used in face skip
angleTolerance | angle tolerance used in face skip
updateAllFace | defines if all cubemap faces should be updated in a frame or only one face per frame
renderSelf | sets if the object should be rendered to the cube map
renderEnvironment | sets if the environment should be rendered to the cube map

Member Function Documentation

virtual void CubeMapRenderingRun::updateCubeFace ( int facenum ) [inline, protected, pure virtual]

Updates one face of the cubemap.

Parameters:
facenum the number of the face to be updated

Implemented in OgreCubeMapRenderingRun.

virtual bool CubeMapRenderingRun::faceNeedsUpdate ( int facenum ) [protected, pure virtual]

Checks if a cubemap face needs to be updated.

If the object we are updating the cubemap for is far from the camera, or too small, or the given cubemapface does not have significant effect on the rendering the face can be skipped.

Parameters:
facenum the number of the face to be checked

Implemented in OgreCubeMapRenderingRun.

void CubeMapRenderingRun::updateFrame ( unsigned long frameNum ) [protected, virtual]

This function does the actual update in a frame.

Parameters:
frameNum current frame number

Reimplemented from RenderingRun.

virtual class OgreRenderingRun* RenderingRun::asOgreRenderingRun ( ) [inline, virtual, inherited]

Conversion to OgreRenderRun.

This function is needed because of virtual inheritance.

Reimplemented in OgreRenderingRun, and OgreRenderingRun.

virtual bool RenderingRun::canJoin ( RenderingRun * run ) [inline, virtual, inherited]

Returns true if two runs can be joined.

In some cases special requirements should stand to join two runs (even if they have the same type). Eg.: two caustic cube map generation technique should only be joined if they use the same material when rendering the caustic cubemap.

Reimplemented in OgreCausticCubeMapRenderingRun, OgreChildPSystemRenderingRun, and OgrePhotonMapRenderingRun.

virtual bool RenderingRun::needUpdate ( unsigned long frameNum ) [inline, protected, virtual, inherited]

Returns if this run needs update.

This tipically depends on the upate interval and the starting frame number.

Parameters:
frameNum current frame number

Reimplemented in OgreFocusingMapRenderingRun, and OgrePMEntryPointMapRenderingRun.

Member Data Documentation

bool CubeMapRenderingRun::useDistCalc [protected]

a flag to skip cube face update if object is far away or too small.

See also:
distTolerance

bool CubeMapRenderingRun::useFaceAngleCalc [protected]

a flag to skip cube face update the face is neglible.

See also:
angleTolerance

float CubeMapRenderingRun::distTolerance [protected]

A value used in face skip test.

The higher this value gets the more precise, but slower the method will be.

float CubeMapRenderingRun::angleTolerance [protected]

A value used in face skip test.

The higher this value gets the more precise, but slower the method will be.

Generated on Wed Mar 28 11:48:48 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: CubeMapRenderTechnique Class Reference

CubeMapRenderTechnique Class Reference

Base abstract class of rendering a cube map. More...

Inheritance diagram for CubeMapRenderTechnique:

RenderTechnique ColorCubeMapRenderTechnique ConvolvedCubeMapRenderTechnique DistanceCubeMapRenderTechnique OgreCubeMapRenderTechnique OgreColorCubeMapRenderTechnique OgreConvolvedCubeMapRenderTechnique OgreDistanceCubeMapRenderTechnique OgreColorCubeMapRenderTechnique OgreConvolvedCubeMapRenderTechnique OgreDistanceCubeMapRenderTechnique List of all members.

Public Member Functions

CubeMapRenderTechnique (unsigned long startFrame, unsigned long cubeMapUpdateInterval, unsigned int cubeMapResolution, bool useDistCalc, bool useFaceAngleCalc, float distTolerance, float angleTolerance, bool updateAllFace, bool renderSelf, bool renderEnvironment, int layer, ElementaryRenderable *parentRenderable, TechniqueGroup *parentTechniqueGroup)
Constructor.
void | runChanged (RenderingRunType runType, RenderingRun *run)
Called after one of he shared runs changes.
void | runUpdated (RenderingRunType runType, RenderingRun *run)
Called after one of he shared runs updates.
virtual void | update (unsigned long frameNum)
Updates the resources in the given frame.
virtual class OgreRenderTechnique * | asOgreRenderTechnique ()
Conversion to OgreRenderTechnique.
ElementaryRenderable * getParentRenderable ()
Retrieves the renderable this technique operates on.

Protected Member Functions

virtual RenderingRun * | createCubeMapRun ()=0
Creates a CubeMapRenderingRun.
virtual void | cubeMapRunChanged (RenderingRun *run)=0
Called if the changed run is a CubeMapRenderingRun.
virtual void | cubeMapRunUpdated (RenderingRun *run)=0
Called if the updated run is a CubeMapRenderingRun.

Protected Attributes

bool | useDistCalc
a flag to skip cube face update if object is far away or too small.
bool | useFaceAngleCalc
a flag to skip cube face update the face is neglible.
float | distTolerance
A value used in face skip test.
float | angleTolerance
A value used in face skip test.
bool | updateAllFace
defines if all cubemap faces should be updated in a frame or only one face per frame
unsigned long | cubeMapUpdateInterval
color-cubemap update frequency
unsigned int | cubeMapResolution
color-cubemap resolution
unsigned long | startFrame
offset in frame number used during update
bool | renderSelf
Sets if the object should be rendered to the cube map.
bool | renderEnvironment
Sets if the environment should be rendered to the cube map.
int | layer
The layer of the cubemap.
RenderingRunType | cubemapLayer
The exact run type of this run (according to the actual layer).
ElementaryRenderable * parentRenderable
The renderable this technique operates on.
TechniqueGroup * parentTechniqueGroup
The TechniqueGroup this RenderedTechnique is attached to.
SharedRuns * sharedRuns
The SharedRuns this RenderedTechnique is attached to.

Detailed Description

Base abstract class of rendering a cube map.

This technique defines that the final rendering of an object needs a cubmap of the surrounding environment and/or the object itself.

Constructor & Destructor Documentation

CubeMapRenderTechnique::CubeMapRenderTechnique | ( | unsigned long | startFrame,
 |  | unsigned long | cubeMapUpdateInterval,
 |  | unsigned int | cubeMapResolution,
 |  | bool | useDistCalc,
 |  | bool | useFaceAngleCalc,
 |  | float | distTolerance,
 |  | float | angleTolerance,
 |  | bool | updateAllFace,
 |  | bool | renderSelf,
 |  | bool | renderEnvironment,
 |  | int | layer,
 |  | ElementaryRenderable * | parentRenderable,
 |  | TechniqueGroup * | parentTechniqueGroup
 | ) |  |

Constructor.

Parameters:
startFrame | adds an offset to the current frame number to help evenly distribute updates between frames
cubeMapUpdateInterval | update frequency
cubeMapResolution | color cubemap resolution
useDistCalc | flag to skip cube face update if object is far away
useFaceAngleCalc | flag to skip cube face update if face is neglible
distTolerance | distance tolerance used in face skip
angleTolerance | angle tolerance used in face skip
updateAllFace | defines if all cubemap faces should be updated in a frame or only one face per frame
renderSelf | sets if the object should be rendered to the cube map
renderEnvironment | sets if the environment should be rendered to the cube map
layer | the layer of this cubemap
parentRenderable | the object to operate on
parentTechniqueGroup | the TechniqueGroup this RenderedTechnique is attached to

Member Function Documentation

void CubeMapRenderTechnique::runChanged | ( | RenderingRunType | runType,
 |  | RenderingRun * | run |
 | ) |  |  | [virtual]

Called after one of he shared runs changes.

Parameters:
runType | enum describing the type of the changed run
run | pointer to the changed RenderingRun

Reimplemented from RenderTechnique.

Reimplemented in ColorCubeMapRenderTechnique, ConvolvedCubeMapRenderTechnique, and DistanceCubeMapRenderTechnique.

void CubeMapRenderTechnique::runUpdated | ( | RenderingRunType | runType,
 |  | RenderingRun * | run |
 | ) |  |  | [virtual]

Called after one of he shared runs updates.

Parameters:
runType | enum describing the type of the updated run
run | pointer to the updated RenderingRun

Reimplemented from RenderTechnique.

Reimplemented in ColorCubeMapRenderTechnique, and DistanceCubeMapRenderTechnique.

virtual RenderingRun* CubeMapRenderTechnique::createCubeMapRun ( ) [protected, pure virtual]

Creates a CubeMapRenderingRun.

Returns:
the new CubeMapRenderingRun instance.

Implemented in OgreCubeMapRenderTechnique.

virtual void CubeMapRenderTechnique::cubeMapRunChanged ( RenderingRun * run ) [protected, pure virtual]

Called if the changed run is a CubeMapRenderingRun.

Parameters:
run pointer to the new CubeMapRenderingRun

Implemented in OgreCubeMapRenderTechnique.

virtual void CubeMapRenderTechnique::cubeMapRunUpdated ( RenderingRun * run ) [protected, pure virtual]

Called if the updated run is a CubeMapRenderingRun.

Parameters:
run pointer to the updated CubeMapRenderingRun

Implemented in OgreCubeMapRenderTechnique.

virtual void RenderTechnique::update ( unsigned long frameNum ) [inline, virtual, inherited]

Updates the resources in the given frame.

A RenderTechnique is usually need some resources from several runs, so these runs will be updated.

Parameters:
frameNum the actual framenumber

Reimplemented in ColorCubeMapRenderTechnique, ConvolvedCubeMapRenderTechnique, DistanceCubeMapRenderTechnique, HierarchicalParticleSystemTechnique, IllumVolumeRenderTechnique, OgreCausticReceiverRenderTechnique, OgreColorCubeMapRenderTechnique, OgreConvolvedCubeMapRenderTechnique, OgreDepthShadowReceiverRenderTechnique, OgreDistanceCubeMapRenderTechnique, OgreFireRenderTechnique, OgrePathMapRenderTechnique, and OgreSBBRenderTechnique.

virtual class OgreRenderTechnique* RenderTechnique::asOgreRenderTechnique ( ) [inline, virtual, inherited]

Conversion to OgreRenderTechnique.

This function is needed because of virtual inheritance.

Reimplemented in OgreRenderTechnique.

Member Data Documentation

bool CubeMapRenderTechnique::useDistCalc [protected]

a flag to skip cube face update if object is far away or too small.

See also:
distTolerance

bool CubeMapRenderTechnique::useFaceAngleCalc [protected]

a flag to skip cube face update the face is neglible.

See also:
angleTolerance

float CubeMapRenderTechnique::distTolerance [protected]

A value used in face skip test.

The higher this value gets the more precise, but slower the method will be.

float CubeMapRenderTechnique::angleTolerance [protected]

A value used in face skip test.

The higher this value gets the more precise, but slower the method will be.

int CubeMapRenderTechnique::layer [protected]

The layer of the cubemap.

This extension was created to achieve effect such as multiple reflections and refractions that require more complete sampling of the scene. With this extension we can render the environment into several cubemap layers eg. with depth peeling.

Generated on Wed Mar 28 11:48:48 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: DepthShadowMapRenderingRun Class Reference

DepthShadowMapRenderingRun Class Reference

Base abstract class that defines a rendering process of a shadow map. More...

Inheritance diagram for DepthShadowMapRenderingRun:

RenderingRun OgreDepthShadowMapRenderingRun List of all members.

Public Member Functions

DepthShadowMapRenderingRun (unsigned int resolutionX, unsigned int resolutionY)
Constructor.
bool | update (unsigned long frameNum)
Calls updateFrame() if the run needs update according to its starting frame and update interval and has not been allready updated in this frame.
virtual class OgreRenderingRun * | asOgreRenderingRun ()
Conversion to OgreRenderRun.
virtual bool | canJoin (RenderingRun *run)
Returns true if two runs can be joined.

Protected Member Functions

virtual void | createDepthMap ()=0
Creates the depth map texture (2D or CUBE according to light type).
virtual void | updateDepthCubeFace (int facenum)=0
Updates one face of the depth cubemap (used only in case of point lights).
virtual void | updateDepthMap ()=0
Updates the depth map (in case of directional and spot lights).
virtual void | updateFrame (unsigned long frameNum)=0
This function does the actual update in a frame.
virtual bool | needUpdate (unsigned long frameNum)
Returns if this run needs update.

Protected Attributes

unsigned int | resolutionX
width of the depth map texture
unsigned int | resolutionY
height of the depth map texture
unsigned long | lastupdated
The number of the last frame this run was updated.
unsigned long | startFrame
The number of the frame this run should be updated first.
unsigned long | updateInterval
Refresh frequency in frames.

Detailed Description

Base abstract class that defines a rendering process of a shadow map.

A shadow map stores depth values from the lightsource.

Constructor & Destructor Documentation

DepthShadowMapRenderingRun::DepthShadowMapRenderingRun | ( | unsigned int | resolutionX,
 |  | unsigned int | resolutionY |
 | ) |  |  | [inline]

Constructor.

Parameters:
resolutionX | width of the depth map texture
resolutionY | height of the depth map texture

Member Function Documentation

virtual void DepthShadowMapRenderingRun::updateDepthCubeFace ( int facenum ) [inline, protected, pure virtual]

Updates one face of the depth cubemap (used only in case of point lights).

Parameters:
facenum the number of the face to be updated

Implemented in OgreDepthShadowMapRenderingRun.

virtual void DepthShadowMapRenderingRun::updateFrame ( unsigned long frameNum ) [protected, pure virtual]

This function does the actual update in a frame.

Parameters:
frameNum current frame number

Reimplemented from RenderingRun.

Implemented in OgreDepthShadowMapRenderingRun.

virtual class OgreRenderingRun* RenderingRun::asOgreRenderingRun ( ) [inline, virtual, inherited]

Conversion to OgreRenderRun.

This function is needed because of virtual inheritance.

Reimplemented in OgreRenderingRun, and OgreRenderingRun.

virtual bool RenderingRun::canJoin ( RenderingRun * run ) [inline, virtual, inherited]

Returns true if two runs can be joined.

In some cases special requirements should stand to join two runs (even if they have the same type). Eg.: two caustic cube map generation technique should only be joined if they use the same material when rendering the caustic cubemap.

Reimplemented in OgreCausticCubeMapRenderingRun, OgreChildPSystemRenderingRun, and OgrePhotonMapRenderingRun.

virtual bool RenderingRun::needUpdate ( unsigned long frameNum ) [inline, protected, virtual, inherited]

Returns if this run needs update.

This tipically depends on the upate interval and the starting frame number.

Parameters:
frameNum current frame number

Reimplemented in OgreFocusingMapRenderingRun, and OgrePMEntryPointMapRenderingRun.

Generated on Wed Mar 28 11:48:48 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: DepthShadowReceiverRenderTechnique Class Reference

DepthShadowReceiverRenderTechnique Class Reference

Base abstract class of rendering an object that recieves shadows with depth map shadow technique. More...

Inheritance diagram for DepthShadowReceiverRenderTechnique:

RenderTechnique OgreDepthShadowReceiverRenderTechnique List of all members.

Public Member Functions

DepthShadowReceiverRenderTechnique (ElementaryRenderable *parentRenderable, TechniqueGroup *parentTechniqueGroup)
Constructor.
virtual void | update (unsigned long frameNum)
Updates the resources in the given frame.
virtual void | runChanged (RenderingRunType runType, RenderingRun *run)
Called after one of he shared runs changes.
virtual void | runUpdated (RenderingRunType runType, RenderingRun *run)
Called after one of he shared runs updates.
virtual class OgreRenderTechnique * | asOgreRenderTechnique ()
Conversion to OgreRenderTechnique.
ElementaryRenderable * getParentRenderable ()
Retrieves the renderable this technique operates on.

Protected Attributes

ElementaryRenderable * parentRenderable
The renderable this technique operates on.
TechniqueGroup * parentTechniqueGroup
The TechniqueGroup this RenderedTechnique is attached to.
SharedRuns * sharedRuns
The SharedRuns this RenderedTechnique is attached to.

Detailed Description

Base abstract class of rendering an object that recieves shadows with depth map shadow technique.

Constructor & Destructor Documentation

DepthShadowReceiverRenderTechnique::DepthShadowReceiverRenderTechnique | ( | ElementaryRenderable * | parentRenderable,
 |  | TechniqueGroup * | parentTechniqueGroup
 | ) |  |

Constructor.

Parameters:
parentRenderable | the object to operate on
parentTechniqueGroup | the TechniqueGroup this RenderedTechnique is attached to

Member Function Documentation

virtual void RenderTechnique::update ( unsigned long frameNum ) [inline, virtual, inherited]

Updates the resources in the given frame.

A RenderTechnique is usually need some resources from several runs, so these runs will be updated.

Parameters:
frameNum the actual framenumber

Reimplemented in ColorCubeMapRenderTechnique, ConvolvedCubeMapRenderTechnique, DistanceCubeMapRenderTechnique, HierarchicalParticleSystemTechnique, IllumVolumeRenderTechnique, OgreCausticReceiverRenderTechnique, OgreColorCubeMapRenderTechnique, OgreConvolvedCubeMapRenderTechnique, OgreDepthShadowReceiverRenderTechnique, OgreDistanceCubeMapRenderTechnique, OgreFireRenderTechnique, OgrePathMapRenderTechnique, and OgreSBBRenderTechnique.

virtual void RenderTechnique::runChanged | ( | RenderingRunType | runType,
 |  | RenderingRun * | run |
 | ) |  |  | [inline, virtual, inherited]

Called after one of he shared runs changes.

Parameters:
runType | enum describing the type of the changed run
run | pointer to the changed RenderingRun

Reimplemented in CausticCasterRenderTechnique, ColorCubeMapRenderTechnique, ConvolvedCubeMapRenderTechnique, CubeMapRenderTechnique, DistanceCubeMapRenderTechnique, HierarchicalParticleSystemTechnique, and IllumVolumeRenderTechnique.

virtual void RenderTechnique::runUpdated | ( | RenderingRunType | runType,
 |  | RenderingRun * | run |
 | ) |  |  | [inline, virtual, inherited]

Called after one of he shared runs updates.

Parameters:
runType | enum describing the type of the updated run
run | pointer to the updated RenderingRun

Reimplemented in CausticCasterRenderTechnique, ColorCubeMapRenderTechnique, CubeMapRenderTechnique, DistanceCubeMapRenderTechnique, HierarchicalParticleSystemTechnique, and IllumVolumeRenderTechnique.

virtual class OgreRenderTechnique* RenderTechnique::asOgreRenderTechnique ( ) [inline, virtual, inherited]

Conversion to OgreRenderTechnique.

This function is needed because of virtual inheritance.

Reimplemented in OgreRenderTechnique.

Generated on Wed Mar 28 11:48:48 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: DistanceCubeMapRenderTechnique Class Reference

DistanceCubeMapRenderTechnique Class Reference

Base abstract class of rendering a distance cube map. More...

Inheritance diagram for DistanceCubeMapRenderTechnique:

CubeMapRenderTechnique RenderTechnique OgreDistanceCubeMapRenderTechnique List of all members.

Public Member Functions

DistanceCubeMapRenderTechnique (unsigned long startFrame, unsigned long cubeMapUpdateInterval, unsigned int cubeMapResolution, bool useDistCalc, bool useFaceAngleCalc, float distTolerance, float angleTolerance, bool updateAllFace, bool renderSelf, bool renderEnvironment, int layer, ElementaryRenderable *parentRenderable, TechniqueGroup *parentTechniqueGroup)
Constructor.
virtual void | update (unsigned long frameNum)
Updates the resources in the given frame.
virtual void | runUpdated (RenderingRunType runType, RenderingRun *run)
Called after one of he shared runs updates.
void | runChanged (RenderingRunType runType, RenderingRun *run)
Called after one of he shared runs changes.
virtual class OgreRenderTechnique * | asOgreRenderTechnique ()
Conversion to OgreRenderTechnique.
ElementaryRenderable * getParentRenderable ()
Retrieves the renderable this technique operates on.

Protected Member Functions

virtual void | distanceCubeMapRunChanged (RenderingRun *run)=0
Called if the changed run is a CubeMapRenderingRun (containing distances of the current layer).
virtual void | distanceCubeMapRunUpdated (RenderingRun *run)=0
Called if the changed run is a CubeMapRenderingRun (containing distances of the current layer).
virtual RenderingRun * | createCubeMapRun ()=0
Creates a CubeMapRenderingRun.
virtual void | cubeMapRunChanged (RenderingRun *run)=0
Called if the changed run is a CubeMapRenderingRun.
virtual void | cubeMapRunUpdated (RenderingRun *run)=0
Called if the updated run is a CubeMapRenderingRun.

Protected Attributes

bool | useDistCalc
a flag to skip cube face update if object is far away or too small.
bool | useFaceAngleCalc
a flag to skip cube face update the face is neglible.
float | distTolerance
A value used in face skip test.
float | angleTolerance
A value used in face skip test.
bool | updateAllFace
defines if all cubemap faces should be updated in a frame or only one face per frame
unsigned long | cubeMapUpdateInterval
color-cubemap update frequency
unsigned int | cubeMapResolution
color-cubemap resolution
unsigned long | startFrame
offset in frame number used during update
bool | renderSelf
Sets if the object should be rendered to the cube map.
bool | renderEnvironment
Sets if the environment should be rendered to the cube map.
int | layer
The layer of the cubemap.
RenderingRunType | cubemapLayer
The exact run type of this run (according to the actual layer).
ElementaryRenderable * parentRenderable
The renderable this technique operates on.
TechniqueGroup * parentTechniqueGroup
The TechniqueGroup this RenderedTechnique is attached to.
SharedRuns * sharedRuns
The SharedRuns this RenderedTechnique is attached to.

Detailed Description

Base abstract class of rendering a distance cube map.

This technique defines that the final rendering of an object needs a cubemap of the distance of the surrounding environment from the cubemap center.

Constructor & Destructor Documentation

DistanceCubeMapRenderTechnique::DistanceCubeMapRenderTechnique | ( | unsigned long | startFrame,
 |  | unsigned long | cubeMapUpdateInterval,
 |  | unsigned int | cubeMapResolution,
 |  | bool | useDistCalc,
 |  | bool | useFaceAngleCalc,
 |  | float | distTolerance,
 |  | float | angleTolerance,
 |  | bool | updateAllFace,
 |  | bool | renderSelf,
 |  | bool | renderEnvironment,
 |  | int | layer,
 |  | ElementaryRenderable * | parentRenderable,
 |  | TechniqueGroup * | parentTechniqueGroup
 | ) |  |

Constructor.

Parameters:
startFrame | adds an offset to the current frame number to help evenly distribute updates between frames
cubeMapUpdateInterval | update frequency
cubeMapResolution | distance cubemap resolution
useDistCalc | flag to skip cube face update if object is far away
useFaceAngleCalc | flag to skip cube face update if face is neglible
distTolerance | distance tolerance used in face skip
angleTolerance | angle tolerance used in face skip
updateAllFace | defines if all cubemap faces should be updated in a frame or only one face per frame
renderSelf | sets if the object should be rendered to the cube map
renderEnvironment | sets if the environment should be rendered to the cube map
layer | the layer of this cubemap
parentRenderable | the object to operate on
parentTechniqueGroup | the TechniqueGroup this RenderedTechnique is attached to

Member Function Documentation

void DistanceCubeMapRenderTechnique::update ( unsigned long frameNum ) [virtual]

Updates the resources in the given frame.

Parameters:
frameNum the actual framenumber

Reimplemented from RenderTechnique.

Reimplemented in OgreDistanceCubeMapRenderTechnique.

void DistanceCubeMapRenderTechnique::runUpdated | ( | RenderingRunType | runType,
 |  | RenderingRun * | run |
 | ) |  |  | [virtual]

Called after one of he shared runs updates.

Parameters:
runType | enum describing the type of the updated run
run | pointer to the updated RenderingRun

Reimplemented from CubeMapRenderTechnique.

void DistanceCubeMapRenderTechnique::runChanged | ( | RenderingRunType | runType,
 |  | RenderingRun * | run |
 | ) |  |  | [virtual]

Called after one of he shared runs changes.

Parameters:
runType | enum describing the type of the changed run
run | pointer to the changed RenderingRun

Reimplemented from CubeMapRenderTechnique.

virtual void DistanceCubeMapRenderTechnique::distanceCubeMapRunChanged ( RenderingRun * run ) [protected, pure virtual]

Called if the changed run is a CubeMapRenderingRun (containing distances of the current layer).

Parameters:
run pointer to the changed CubeMapRenderingRun

Implemented in OgreDistanceCubeMapRenderTechnique.

virtual void DistanceCubeMapRenderTechnique::distanceCubeMapRunUpdated ( RenderingRun * run ) [protected, pure virtual]

Called if the changed run is a CubeMapRenderingRun (containing distances of the current layer).

Parameters:
run pointer to the changed CubeMapRenderingRun

Implemented in OgreDistanceCubeMapRenderTechnique.

virtual RenderingRun* CubeMapRenderTechnique::createCubeMapRun ( ) [protected, pure virtual, inherited]

Creates a CubeMapRenderingRun.

Returns:
the new CubeMapRenderingRun instance.

Implemented in OgreCubeMapRenderTechnique.

virtual void CubeMapRenderTechnique::cubeMapRunChanged ( RenderingRun * run ) [protected, pure virtual, inherited]

Called if the changed run is a CubeMapRenderingRun.

Parameters:
run pointer to the new CubeMapRenderingRun

Implemented in OgreCubeMapRenderTechnique.

virtual void CubeMapRenderTechnique::cubeMapRunUpdated ( RenderingRun * run ) [protected, pure virtual, inherited]

Called if the updated run is a CubeMapRenderingRun.

Parameters:
run pointer to the updated CubeMapRenderingRun

Implemented in OgreCubeMapRenderTechnique.

virtual class OgreRenderTechnique* RenderTechnique::asOgreRenderTechnique ( ) [inline, virtual, inherited]

Conversion to OgreRenderTechnique.

This function is needed because of virtual inheritance.

Reimplemented in OgreRenderTechnique.

Member Data Documentation

bool CubeMapRenderTechnique::useDistCalc [protected, inherited]

a flag to skip cube face update if object is far away or too small.

See also:
distTolerance

bool CubeMapRenderTechnique::useFaceAngleCalc [protected, inherited]

a flag to skip cube face update the face is neglible.

See also:
angleTolerance

float CubeMapRenderTechnique::distTolerance [protected, inherited]

A value used in face skip test.

The higher this value gets the more precise, but slower the method will be.

float CubeMapRenderTechnique::angleTolerance [protected, inherited]

A value used in face skip test.

The higher this value gets the more precise, but slower the method will be.

int CubeMapRenderTechnique::layer [protected, inherited]

The layer of the cubemap.

This extension was created to achieve effect such as multiple reflections and refractions that require more complete sampling of the scene. With this extension we can render the environment into several cubemap layers eg. with depth peeling.

Generated on Wed Mar 28 11:48:49 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: ElementaryRenderable Class Reference

ElementaryRenderable Class Reference

Base abstract class for an elementary renderable. More...

Inheritance diagram for ElementaryRenderable:

OgreRenderable List of all members.

Public Member Functions

virtual void | setVisible (bool visible)=0
Shows or hides the renderable.
virtual void | setRenderGroup (unsigned char groupID)=0
Sets the rendering group this renderable belongs to.
virtual bool | isVisible ()=0
Retrieves if the renderable is hided or shown.
virtual void | updateBounds ()=0
Updates bounding volumes.

Detailed Description

Base abstract class for an elementary renderable.

Member Function Documentation

virtual void ElementaryRenderable::setVisible ( bool visible ) [pure virtual]

Shows or hides the renderable.

Parameters:
visible visibility

Implemented in OgreRenderable.

virtual void ElementaryRenderable::setRenderGroup ( unsigned char groupID ) [pure virtual]

Sets the rendering group this renderable belongs to.

Rendering groups are to distinguish groups of rendering types (eg.: caustic casters, caustic receivers, shadow casters) if needed. Each group has a unique ID.

Parameters:
groupID the ID of the group to use

Implemented in OgreRenderable.

Generated on Wed Mar 28 11:48:49 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: HierarchicalParticleSystemTechnique Class Reference

HierarchicalParticleSystemTechnique Class Reference

Base abstract class of rendering a hierarchical particle system. More...

Inheritance diagram for HierarchicalParticleSystemTechnique:

RenderTechnique OgreHierarchicalParticleSystemTechnique List of all members.

Public Member Functions

HierarchicalParticleSystemTechnique (unsigned long startFrame, unsigned long impostorUpdateInterval, unsigned int impostorResolution, bool useDistCalc, bool perspectiveRendering, ElementaryRenderable *parentRenderable, TechniqueGroup *parentTechniqueGroup)
Constructor.
void | update (unsigned long frameNum)
Updates the resources in the given frame.
void | runChanged (RenderingRunType runType, RenderingRun *run)
Called after one of he shared runs changes.
void | runUpdated (RenderingRunType runType, RenderingRun *run)
Called after one of he shared runs updates.
virtual class OgreRenderTechnique * | asOgreRenderTechnique ()
Conversion to OgreRenderTechnique.
ElementaryRenderable * getParentRenderable ()
Retrieves the renderable this technique operates on.

Protected Member Functions

virtual RenderingRun * | createChildPSysRenderingRun ()=0
Creates the ChildParticleSystemRenderingRun needed by this technique.
virtual void | impostorChanged (RenderingRun *run)=0
Called if the impostor rendering run changed.
virtual void | impostorUpdated (RenderingRun *run)=0
Called if the impostor rendering run is updated.

Protected Attributes

unsigned long | impostorUpdateInterval
update frequency of the impostor texture (image of the smaller system)
unsigned int | impostorResolution
resolution of the impostor texture
unsigned long | startFrame
offset in frame number used during update
bool | useDistCalc
flag to skip impostor update if object is far away (//not used)
bool | perspectiveRendering
sets if the impostor should be rendered with a perspective projection or orthogonal
ElementaryRenderable * parentRenderable
The renderable this technique operates on.
TechniqueGroup * parentTechniqueGroup
The TechniqueGroup this RenderedTechnique is attached to.
SharedRuns * sharedRuns
The SharedRuns this RenderedTechnique is attached to.

Detailed Description

Base abstract class of rendering a hierarchical particle system.

A hierarchical particle system is a particle system made out of a smaller particle system. It renders an image of the smaller particle system and multiplies this image to achieve a bigger particle system. This way fewer computation is needed to simulate large number of particles, while the trick is usually unnoticable.

Constructor & Destructor Documentation

HierarchicalParticleSystemTechnique::HierarchicalParticleSystemTechnique | ( | unsigned long | startFrame,
 |  | unsigned long | impostorUpdateInterval,
 |  | unsigned int | impostorResolution,
 |  | bool | useDistCalc,
 |  | bool | perspectiveRendering,
 |  | ElementaryRenderable * | parentRenderable,
 |  | TechniqueGroup * | parentTechniqueGroup
 | ) |  |

Constructor.

Parameters:
startFrame | adds an offset to the current frame number to help evenly distribute updates between frames
impostorUpdateInterval | update frequency of the impostor texture (image of the smaller system)
impostorResolution | resolution of the impostor texture
useDistCalc | flag to skip impostor update if object is far away (//not used)
perspectiveRendering | sets if the impostor should be rendered with a perspective projection or orthogonal
parentRenderable | the object to operate on
parentTechniqueGroup | the TechniqueGroup this RenderedTechnique is attached to

Member Function Documentation

void HierarchicalParticleSystemTechnique::update ( unsigned long frameNum ) [virtual]

Updates the resources in the given frame.

A RenderTechnique is usually need some resources from several runs, so these runs will be updated.

Parameters:
frameNum the actual framenumber

Reimplemented from RenderTechnique.

void HierarchicalParticleSystemTechnique::runChanged | ( | RenderingRunType | runType,
 |  | RenderingRun * | run |
 | ) |  |  | [virtual]

Called after one of he shared runs changes.

Parameters:
runType | enum describing the type of the changed run
run | pointer to the changed RenderingRun

Reimplemented from RenderTechnique.

void HierarchicalParticleSystemTechnique::runUpdated | ( | RenderingRunType | runType,
 |  | RenderingRun * | run |
 | ) |  |  | [virtual]

Called after one of he shared runs updates.

Parameters:
runType | enum describing the type of the updated run
run | pointer to the updated RenderingRun

Reimplemented from RenderTechnique.

virtual RenderingRun* HierarchicalParticleSystemTechnique::createChildPSysRenderingRun ( ) [protected, pure virtual]

Creates the ChildParticleSystemRenderingRun needed by this technique.

Returns:
pointer to the ChildParticleSystemRenderingRun created instance

Implemented in OgreHierarchicalParticleSystemTechnique.

virtual void HierarchicalParticleSystemTechnique::impostorChanged ( RenderingRun * run ) [protected, pure virtual]

Called if the impostor rendering run changed.

Parameters:
run pointer to the new ChildParticleSystemRenderingRun instance to use

Implemented in OgreHierarchicalParticleSystemTechnique.

virtual void HierarchicalParticleSystemTechnique::impostorUpdated ( RenderingRun * run ) [protected, pure virtual]

Called if the impostor rendering run is updated.

Parameters:
run pointer to the updated ChildParticleSystemRenderingRu.

Implemented in OgreHierarchicalParticleSystemTechnique.

virtual class OgreRenderTechnique* RenderTechnique::asOgreRenderTechnique ( ) [inline, virtual, inherited]

Conversion to OgreRenderTechnique.

This function is needed because of virtual inheritance.

Reimplemented in OgreRenderTechnique.

Generated on Wed Mar 28 11:48:49 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: IlluminationManager Class Reference

IlluminationManager Class Reference

Base abstract class of the illumination manager. More...

List of all members.

Public Member Functions

virtual void | update (unsigned long frameNumber)=0
The function to be called to render one frame.
virtual void | sharedRunSplit (SharedRuns *old, SharedRuns *new1, SharedRuns *new2)
The function to be called when a shared run is splitted.
virtual void | sharedRunJoin (SharedRuns *old1, SharedRuns *old2, SharedRuns *newsr)
The function to be called when two shared runs are joined.
virtual void | joinSharedRuns ()
Joins shared runs if needed.
virtual void | addSharedRuns (SharedRuns *runs)
Register a shared run object.

Detailed Description

Base abstract class of the illumination manager.

The illumination manager is responsible for refreshing rendering techniques connected to visible renderables. It also has the resposibility to manage shared runs, to join and split them if needed.

Member Function Documentation

virtual void IlluminationManager::update ( unsigned long frameNumber ) [pure virtual]

The function to be called to render one frame.

This is the main refreshing function. It seasrches for visible objects, manages shared runs and updates render techniques. It should be called after all animations are done and before rendering to the frame buffer.

Parameters:
frameNumber current framenumber

virtual void IlluminationManager::sharedRunSplit | ( | SharedRuns * | old,
 |  | SharedRuns * | new1,
 |  | SharedRuns * | new2 |
 | ) |  |  | [inline, virtual]

The function to be called when a shared run is splitted.

Parameters:
old | pointer to the SharedRuns instance that is split
new1 | pointer to one of the SharedRuns instance that remain after split
new2 | pointer to the other SharedRuns instance that remain after split

virtual void IlluminationManager::sharedRunJoin | ( | SharedRuns * | old1,
 |  | SharedRuns * | old2,
 |  | SharedRuns * | newsr |
 | ) |  |  | [inline, virtual]

The function to be called when two shared runs are joined.

Parameters:
old1 | pointer to one of the SharedRuns instance that are joined
old2 | pointer to the other SharedRuns instance that are joined
newsr | pointer to the resulting parent SharedRuns instance

virtual void IlluminationManager::joinSharedRuns ( ) [inline, virtual]

Joins shared runs if needed.

Searches the registered shared run roots and join them if necessary (they are close enough).

virtual void IlluminationManager::addSharedRuns ( SharedRuns * runs ) [inline, virtual]

Register a shared run object.

Only called when new techniques are created.

Parameters:
runs pointer to the SharedRuns instance to add

Generated on Wed Mar 28 11:48:49 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: IllumVolumeRenderTechnique Class Reference

IllumVolumeRenderTechnique Class Reference

Base abstract class of rendering a light volume of a particle system. More...

Inheritance diagram for IllumVolumeRenderTechnique:

RenderTechnique OgreIllumVolumeRenderTechnique List of all members.

Public Member Functions

IllumVolumeRenderTechnique (unsigned long startFrame, unsigned long illumVolumeUpdateInterval, unsigned int illumTextureResolution, unsigned int textureDepth, bool useDistCalc, bool useHierarchicalImpostor, ElementaryRenderable *parentRenderable, TechniqueGroup *parentTechniqueGroup)
Constructor.
void | update (unsigned long frameNum)
Updates the resources in the given frame.
void | runChanged (RenderingRunType runType, RenderingRun *run)
Called after one of he shared runs changes.
void | runUpdated (RenderingRunType runType, RenderingRun *run)
Called after one of he shared runs updates.
virtual class OgreRenderTechnique * | asOgreRenderTechnique ()
Conversion to OgreRenderTechnique.
ElementaryRenderable * getParentRenderable ()
Retrieves the renderable this technique operates on.

Protected Member Functions

virtual RenderingRun * | createLightVolumeRenderingRun ()=0
creates a light volume rendering run needed by this technique
virtual void | lightVolumeChanged (RenderingRun *run)=0
Called if the LightVolumeRenderingRun is chaged.
virtual void | lightVolumeUpdated (RenderingRun *run)=0
Called if the LightVolumeRenderingRun is updated.
virtual void | hierarchicalImpostorUpdated (RenderingRun *run)=0
Called if the ChildParticleSystemRenderingRun is chaged.

Protected Attributes

unsigned long | illumVolumeUpdateInterval
the update frequency of the light volume
unsigned int | illumTextureResolution
the resolution of the light volume texture
unsigned int | textureDepth
the number of layers to use (should be set to 1)
unsigned long | startFrame
offset in frame number used during update
bool | useDistCalc
flag to skip updates if the shaded particle system is far away (not used)
bool | useHierarchicalImpostor
set this flag to true if the particle system is a hierarchical particle system
ElementaryRenderable * parentRenderable
The renderable this technique operates on.
TechniqueGroup * parentTechniqueGroup
The TechniqueGroup this RenderedTechnique is attached to.
SharedRuns * sharedRuns
The SharedRuns this RenderedTechnique is attached to.

Detailed Description

Base abstract class of rendering a light volume of a particle system.

Light volumes are used when self shadowing of particle systems should be simulated. Each layer of the volume represents the amount of transmitted light. The current implementation uses four grayscale layers, and places these layers to the four channel of the light volume texture.

Constructor & Destructor Documentation

IllumVolumeRenderTechnique::IllumVolumeRenderTechnique | ( | unsigned long | startFrame,
 |  | unsigned long | illumVolumeUpdateInterval,
 |  | unsigned int | illumTextureResolution,
 |  | unsigned int | textureDepth,
 |  | bool | useDistCalc,
 |  | bool | useHierarchicalImpostor,
 |  | ElementaryRenderable * | parentRenderable,
 |  | TechniqueGroup * | parentTechniqueGroup
 | ) |  |

Constructor.

Parameters:
startFrame | adds an offset to the current frame number to help evenly distribute updates between frames
illumVolumeUpdateInterval | the update frequency of the light volume
illumTextureResolution | the resolution of the light volume texture
textureDepth | the number of layers to use (should be set to 1)
useDistCalc | flag to skip updates if the shaded particle system is far away (not used)
useHierarchicalImpostor | set this flag to true if the particle system is a hierarchical particle system
parentRenderable | the object to operate on
parentTechniqueGroup | the TechniqueGroup this RenderedTechnique is attached to

Member Function Documentation

void IllumVolumeRenderTechnique::update ( unsigned long frameNum ) [virtual]

Updates the resources in the given frame.

A RenderTechnique is usually need some resources from several runs, so these runs will be updated.

Parameters:
frameNum the actual framenumber

Reimplemented from RenderTechnique.

void IllumVolumeRenderTechnique::runChanged | ( | RenderingRunType | runType,
 |  | RenderingRun * | run |
 | ) |  |  | [virtual]

Called after one of he shared runs changes.

Parameters:
runType | enum describing the type of the changed run
run | pointer to the changed RenderingRun

Reimplemented from RenderTechnique.

void IllumVolumeRenderTechnique::runUpdated | ( | RenderingRunType | runType,
 |  | RenderingRun * | run |
 | ) |  |  | [virtual]

Called after one of he shared runs updates.

Parameters:
runType | enum describing the type of the updated run
run | pointer to the updated RenderingRun

Reimplemented from RenderTechnique.

virtual RenderingRun* IllumVolumeRenderTechnique::createLightVolumeRenderingRun ( ) [protected, pure virtual]

creates a light volume rendering run needed by this technique

Returns:
pointer to the created LightVolumeRenderingRun instance

Implemented in OgreIllumVolumeRenderTechnique.

virtual void IllumVolumeRenderTechnique::lightVolumeChanged ( RenderingRun * run ) [protected, pure virtual]

Called if the LightVolumeRenderingRun is chaged.

Parameters:
pointer to the new LightVolumeRenderingRun instance to use

Implemented in OgreIllumVolumeRenderTechnique.

virtual void IllumVolumeRenderTechnique::lightVolumeUpdated ( RenderingRun * run ) [protected, pure virtual]

Called if the LightVolumeRenderingRun is updated.

Parameters:
pointer to the updated LightVolumeRenderingRun instance

Implemented in OgreIllumVolumeRenderTechnique.

virtual void IllumVolumeRenderTechnique::hierarchicalImpostorUpdated ( RenderingRun * run ) [protected, pure virtual]

Called if the ChildParticleSystemRenderingRun is chaged.

Only called if this particle system is a hierarchical particle system.

Parameters:
pointer to the new ChildParticleSystemRenderingRun instance to use

Implemented in OgreIllumVolumeRenderTechnique.

virtual class OgreRenderTechnique* RenderTechnique::asOgreRenderTechnique ( ) [inline, virtual, inherited]

Conversion to OgreRenderTechnique.

This function is needed because of virtual inheritance.

Reimplemented in OgreRenderTechnique.

Generated on Wed Mar 28 11:48:49 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: LightVolumeRenderingRun Class Reference

LightVolumeRenderingRun Class Reference

Base abstract class that defines a rendering process of a light volume texture. More...

Inheritance diagram for LightVolumeRenderingRun:

RenderingRun OgreLightVolumeRenderingRun List of all members.

Public Member Functions

LightVolumeRenderingRun (unsigned long startFrame, unsigned long updateInterval, unsigned int resolution, unsigned int textureDepth)
Constructor.
bool | update (unsigned long frameNum)
Calls updateFrame() if the run needs update according to its starting frame and update interval and has not been allready updated in this frame.
virtual class OgreRenderingRun * | asOgreRenderingRun ()
Conversion to OgreRenderRun.
virtual bool | canJoin (RenderingRun *run)
Returns true if two runs can be joined.

Protected Member Functions

virtual void | updateFrame (unsigned long frameNum)=0
This function does the actual update in a frame.
virtual void | createLightVolumeMap ()=0
Creates a light volume map.
virtual bool | needUpdate (unsigned long frameNum)
Returns if this run needs update.

Protected Attributes

unsigned int | resolution
the resolution of the light volume map
unsigned int | textureDepth
number of layers (should be 1)
unsigned long | lastupdated
The number of the last frame this run was updated.
unsigned long | startFrame
The number of the frame this run should be updated first.
unsigned long | updateInterval
Refresh frequency in frames.

Detailed Description

Base abstract class that defines a rendering process of a light volume texture.

Light volumes are used when self shadowing of particle systems should be simulated. Each layer of the volume represents the amount of transmitted light. The current implementation uses four grayscale layers, and places these layers to the four channel of the light volume texture.

Constructor & Destructor Documentation

LightVolumeRenderingRun::LightVolumeRenderingRun | ( | unsigned long | startFrame,
 |  | unsigned long | updateInterval,
 |  | unsigned int | resolution,
 |  | unsigned int | textureDepth |
 | ) |  |  | [inline]

Constructor.

Parameters:
startFrame | adds an offset to the current frame number to help evenly distribute updates between frames
updateInterval | update frequency
resolution | the resolution of the light volume texture
textureDepth | the number of layers (should be set to 1)

Member Function Documentation

virtual void LightVolumeRenderingRun::updateFrame ( unsigned long frameNum ) [protected, pure virtual]

This function does the actual update in a frame.

Parameters:
frameNum current frame number

Reimplemented from RenderingRun.

Implemented in OgreLightVolumeRenderingRun.

virtual class OgreRenderingRun* RenderingRun::asOgreRenderingRun ( ) [inline, virtual, inherited]

Conversion to OgreRenderRun.

This function is needed because of virtual inheritance.

Reimplemented in OgreRenderingRun, and OgreRenderingRun.

virtual bool RenderingRun::canJoin ( RenderingRun * run ) [inline, virtual, inherited]

Returns true if two runs can be joined.

In some cases special requirements should stand to join two runs (even if they have the same type). Eg.: two caustic cube map generation technique should only be joined if they use the same material when rendering the caustic cubemap.

Reimplemented in OgreCausticCubeMapRenderingRun, OgreChildPSystemRenderingRun, and OgrePhotonMapRenderingRun.

virtual bool RenderingRun::needUpdate ( unsigned long frameNum ) [inline, protected, virtual, inherited]

Returns if this run needs update.

This tipically depends on the upate interval and the starting frame number.

Parameters:
frameNum current frame number

Reimplemented in OgreFocusingMapRenderingRun, and OgrePMEntryPointMapRenderingRun.

Generated on Wed Mar 28 11:48:49 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: OgreCausticCasterRenderTechnique Class Reference

OgreCausticCasterRenderTechnique Class Reference

CausticCasterRenderTechnique used in an OGRE environment. More...

Inheritance diagram for OgreCausticCasterRenderTechnique:

OgreRenderTechnique CausticCasterRenderTechnique RenderTechnique RenderTechnique List of all members.

Public Member Functions

OgreCausticCasterRenderTechnique (unsigned long startFrame, unsigned long photonMapUpdateInterval, unsigned int photonMapResolution, unsigned int causticCubeMapResolution, String photonMapMaterialName, String causticMapMaterialName, unsigned char photonMapTexID, bool updateAllFace, bool useDistance, float attenuation, bool useTriangles, bool blurCauCubeMap, Pass *pass, OgreRenderable *parentRenderable, OgreTechniqueGroup *parentTechniqueGroup)
Constructor.
~OgreCausticCasterRenderTechnique ()
Destructor.
const String & | getCausticCubeMapName ()
Returns the name of the created caustic cubemap.
float | getAttenuation ()
virtual OgreRenderTechnique * | asOgreRenderTechnique ()
Conversion to OgreRenderTechnique.
virtual void | update (unsigned long frameNum)
Updates the resources in the given frame.
virtual void | runChanged (RenderingRunType runType, RenderingRun *run)
Called after one of he shared runs changes.
virtual void | runUpdated (RenderingRunType runType, RenderingRun *run)
Called after one of he shared runs updates.
ElementaryRenderable * getParentRenderable ()
Retrieves the renderable this technique operates on.
void | runChanged (RenderingRunType runType, RenderingRun *run)
Called after one of he shared runs changes.
virtual void | runUpdated (RenderingRunType runType, RenderingRun *run)
Called after one of he shared runs updates.

Protected Member Functions

void | photonMapRunChanged (RenderingRun *run)
Called if the changed run is a PhotonMapRenderingRun.
void | causticCubeMapRunChanged (RenderingRun *run)
Called if the changed run is a CausticCubeMapRenderingRun.
void | distanceCubeMapRunChanged (RenderingRun *run)
Called if the changed run is a DistanceCubeMapRenderingRun.
void | distanceCubeMapRunUpdated (RenderingRun *run)
Called if the updated run is a DistanceCubeMapRenderingRun.
RenderingRun * createPhotonMapRun ()
Creates a PhotonMapRenderingRun.
RenderingRun * createCausticCubeMapRun ()
Creates a CausticCubeMapRenderingRun.
RenderingRun * createDistanceCubeMapRun ()
Creates a DistanceCubeMapRenderingRun.

Protected Attributes

String | photonMapMaterialName
name of the created photon hit map texture
String | causticMapMaterialName
name of the created caustic cubemap texture
unsigned char | photonMapTexID
the texture unit state id of the caustic map generation material where the photonhit map should be bound to.
float | attenuation
attenuation distance of the caustic
bool | useTriangles
sets if triangles should be rendered into the caustic cubemap instead of sprites
bool | blurCauCubeMap
sets if the caustic cubemap should be blurred (recommended if rendering caustic triangles)
OgreRenderable * parentOgreRenderable
a OgreRenderable pointer to the renderable this technique operates on.
OgreTechniqueGroup * parentOgreTechniqueGroup
a OgreTechniqueGroup pointer to the TechniqueGroup this technique is attached to.
Pass * | pass
a pointer to the pass this technique operates on.
ElementaryRenderable * parentRenderable
The renderable this technique operates on.
TechniqueGroup * parentTechniqueGroup
The TechniqueGroup this RenderedTechnique is attached to.
SharedRuns * sharedRuns
The SharedRuns this RenderedTechnique is attached to.
bool | updateAllFace
defines if all cubemap faces should be updated in a frame or only one face per frame
bool | useDistance
tells if a distance cubemap impostor should be used in photon hit calculation (recommended)
unsigned long | photonMapUpdateInterval
photonmap update frequency
unsigned int | photonMapResolution
photonmap resolution
unsigned int | causticCubeMapResolution
caustic cubemap resolution
unsigned long | startFrame
offset in frame number used during update

Detailed Description

CausticCasterRenderTechnique used in an OGRE environment.

Constructor & Destructor Documentation

OgreCausticCasterRenderTechnique::OgreCausticCasterRenderTechnique | ( | unsigned long | startFrame,
 |  | unsigned long | photonMapUpdateInterval,
 |  | unsigned int | photonMapResolution,
 |  | unsigned int | causticCubeMapResolution,
 |  | String | photonMapMaterialName,
 |  | String | causticMapMaterialName,
 |  | unsigned char | photonMapTexID,
 |  | bool | updateAllFace,
 |  | bool | useDistance,
 |  | float | attenuation,
 |  | bool | useTriangles,
 |  | bool | blurCauCubeMap,
 |  | Pass * | pass,
 |  | OgreRenderable * | parentRenderable,
 |  | OgreTechniqueGroup * | parentTechniqueGroup
 | ) |  |

Constructor.

Parameters:
startFrame | adds an offset to the current frame number to help evenly distribute updates between frames
photonMapUpdateInterval | photon map and caustic cubemap update frequency
photonMapResolution | photon map resolution
causticCubeMapResolution | caustic cubemap resolution
photonMapMaterialName | the name of the material should be used when rendering the photon hit map
causticMapMaterialName | the name of the material that should be used when rendering the caustic cubemap
photonMapTexID | the texture unit state id of the caustic map generation material where the photonhit map should be bound to
updateAllFace | defines if all cubemap faces should be updated in a frame or only one face per frame
useDistance | tells if a distance cubemap impostor should be used in photon hit calculation (recommended)
attenuation | attenuation distance of the caustic
useTriangles | sets if triangles should be rendered into the caustic cubemap instead of sprites
blurCauCubeMap | sets if the caustic cubemap should be blurred (recommended if rendering caustic triangles)
pass | the pass to operate on
parentRenderable | the object to operate on
parentTechniqueGroup | the TechniqueGroup this RenderedTechnique is attached to

Member Function Documentation

const String & OgreCausticCasterRenderTechnique::getCausticCubeMapName ( )

Returns the name of the created caustic cubemap.

Returns:
name of the caustic cubemap texture

float OgreCausticCasterRenderTechnique::getAttenuation ( ) [inline]

See also:
attenuation

void OgreCausticCasterRenderTechnique::photonMapRunChanged ( RenderingRun * run ) [protected, virtual]

Called if the changed run is a PhotonMapRenderingRun.

Parameters:
run pointer to the changed PhotonMapRenderingRun

Implements CausticCasterRenderTechnique.

void OgreCausticCasterRenderTechnique::causticCubeMapRunChanged ( RenderingRun * run ) [protected, virtual]

Called if the changed run is a CausticCubeMapRenderingRun.

Parameters:
run pointer to the changed CausticCubeMapRenderingRun

Implements CausticCasterRenderTechnique.

void OgreCausticCasterRenderTechnique::distanceCubeMapRunChanged ( RenderingRun * run ) [protected, virtual]

Called if the changed run is a DistanceCubeMapRenderingRun.

Parameters:
run pointer to the changed DistanceCubeMapRenderingRun

Implements CausticCasterRenderTechnique.

void OgreCausticCasterRenderTechnique::distanceCubeMapRunUpdated ( RenderingRun * run ) [protected, virtual]

Called if the updated run is a DistanceCubeMapRenderingRun.

Parameters:
run pointer to the updated DistanceCubeMapRenderingRun

Implements CausticCasterRenderTechnique.

RenderingRun * OgreCausticCasterRenderTechnique::createPhotonMapRun ( ) [protected, virtual]

Creates a PhotonMapRenderingRun.

Returns:
the new PhotonMapRenderingRun instance.

Implements CausticCasterRenderTechnique.

RenderingRun * OgreCausticCasterRenderTechnique::createCausticCubeMapRun ( ) [protected, virtual]

Creates a CausticCubeMapRenderingRun.

Returns:
the new CausticCubeMapRenderingRun instance.

Implements CausticCasterRenderTechnique.

RenderingRun * OgreCausticCasterRenderTechnique::createDistanceCubeMapRun ( ) [protected, virtual]

Creates a DistanceCubeMapRenderingRun.

Returns:
the new DistanceCubeMapRenderingRun instance.

Implements CausticCasterRenderTechnique.

virtual OgreRenderTechnique* OgreRenderTechnique::asOgreRenderTechnique ( ) [inline, virtual, inherited]

Conversion to OgreRenderTechnique.

This function is needed because of virtual inheritance.

Reimplemented from RenderTechnique.

virtual void RenderTechnique::update ( unsigned long frameNum ) [inline, virtual, inherited]

Updates the resources in the given frame.

A RenderTechnique is usually need some resources from several runs, so these runs will be updated.

Parameters:
frameNum the actual framenumber

Reimplemented in ColorCubeMapRenderTechnique, ConvolvedCubeMapRenderTechnique, DistanceCubeMapRenderTechnique, HierarchicalParticleSystemTechnique, IllumVolumeRenderTechnique, OgreCausticReceiverRenderTechnique, OgreColorCubeMapRenderTechnique, OgreConvolvedCubeMapRenderTechnique, OgreDepthShadowReceiverRenderTechnique, OgreDistanceCubeMapRenderTechnique, OgreFireRenderTechnique, OgrePathMapRenderTechnique, and OgreSBBRenderTechnique.

virtual void RenderTechnique::runChanged | ( | RenderingRunType | runType,
 |  | RenderingRun * | run |
 | ) |  |  | [inline, virtual, inherited]

Called after one of he shared runs changes.

Parameters:
runType | enum describing the type of the changed run
run | pointer to the changed RenderingRun

Reimplemented in CausticCasterRenderTechnique, ColorCubeMapRenderTechnique, ConvolvedCubeMapRenderTechnique, CubeMapRenderTechnique, DistanceCubeMapRenderTechnique, HierarchicalParticleSystemTechnique, and IllumVolumeRenderTechnique.

virtual void RenderTechnique::runUpdated | ( | RenderingRunType | runType,
 |  | RenderingRun * | run |
 | ) |  |  | [inline, virtual, inherited]

Called after one of he shared runs updates.

Parameters:
runType | enum describing the type of the updated run
run | pointer to the updated RenderingRun

Reimplemented in CausticCasterRenderTechnique, ColorCubeMapRenderTechnique, CubeMapRenderTechnique, DistanceCubeMapRenderTechnique, HierarchicalParticleSystemTechnique, and IllumVolumeRenderTechnique.

void CausticCasterRenderTechnique::runChanged | ( | RenderingRunType | runType,
 |  | RenderingRun * | run |
 | ) |  |  | [virtual, inherited]

Called after one of he shared runs changes.

Parameters:
runType | enum describing the type of the changed run
run | pointer to the changed RenderingRun

Reimplemented from RenderTechnique.

void CausticCasterRenderTechnique::runUpdated | ( | RenderingRunType | runType,
 |  | RenderingRun * | run |
 | ) |  |  | [virtual, inherited]

Called after one of he shared runs updates.

Parameters:
runType | enum describing the type of the updated run
run | pointer to the updated RenderingRun

Reimplemented from RenderTechnique.

Generated on Wed Mar 28 11:48:50 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: OgreCausticCasterRenderTechniqueFactory Class Reference

OgreCausticCasterRenderTechniqueFactory Class Reference

RenderTechniqueFactory to create OgreCausticCasterRenderTechnique instances. More...

Inheritance diagram for OgreCausticCasterRenderTechniqueFactory:

RenderTechniqueFactory List of all members.

Public Member Functions

OgreCausticCasterRenderTechniqueFactory ()
Technique factory.
OgreRenderTechnique * | createInstance (IllumTechniqueParams *params, Pass *pass, OgreRenderable *parentRenderable, OgreTechniqueGroup *parentTechniqueGroup)
Creates a RenderTechnique of the factory type.
bool | isType (String type)
Returns if this factory can create a RenderTechnique of the given type.
virtual void | parseParams (IllumTechniqueParams *params)
parses parameters from the material file.

Protected Types

typedef void(*) | ILLUM_ATTRIBUTE_PARSER (String &params, RenderTechniqueFactory *factory)
function for parsing RenderTechnique attributes
typedef std::map< String,
ILLUM_ATTRIBUTE_PARSER > 		AttribParserList
Keyword-mapped attribute parsers.

Protected Attributes

AttribParserList attributeParsers
map of parser functions
String | typeName
factoryname

Detailed Description

RenderTechniqueFactory to create OgreCausticCasterRenderTechnique instances.

Member Typedef Documentation

typedef void(*) RenderTechniqueFactory::ILLUM_ATTRIBUTE_PARSER(String &params, RenderTechniqueFactory *factory) [protected, inherited]

function for parsing RenderTechnique attributes

Parameters:
params attribute value stored in a String

Member Function Documentation

OgreRenderTechnique * OgreCausticCasterRenderTechniqueFactory::createInstance | ( | IllumTechniqueParams * | params,
 |  | Pass * | pass,
 |  | OgreRenderable * | parentRenderable,
 |  | OgreTechniqueGroup * | parentTechniqueGroup |
 | ) |  |  | [virtual]

Creates a RenderTechnique of the factory type.

Parameters:
params | containes constructor parameters as NameValuePairList
pass | the Pass to use in RenderTechnique constructor
pass | the parentRenderable to pass to RenderTechnique constructor
pass | the parentTechniqueGroup to pass to RenderTechnique constructor

Implements RenderTechniqueFactory.

bool RenderTechniqueFactory::isType ( String type ) [inline, inherited]

Returns if this factory can create a RenderTechnique of the given type.

Parameters:
type RenderTechnique type

void RenderTechniqueFactory::parseParams ( IllumTechniqueParams * params ) [virtual, inherited]

parses parameters from the material file.

The parsed parameters will be passed to the new RenderTechnique's constructor.

Parameters:
params pointer to the IllumTechniqueParams structure that was read from the material script and containes the parameters to be parsed.

Generated on Wed Mar 28 11:48:50 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: OgreCausticCubeMapRenderingRun Class Reference

OgreCausticCubeMapRenderingRun Class Reference

CausticCubeMapRenderingRun used in an OGRE environment. More...

Inheritance diagram for OgreCausticCubeMapRenderingRun:

OgreRenderingRun CausticCubeMapRenderingRun RenderingRun RenderingRun RenderingRun List of all members.

Public Member Functions

OgreCausticCubeMapRenderingRun (OgreSharedRuns *sharedRuns, String name, unsigned long startFrame, unsigned long updateInterval, unsigned int resolution, String materialName, unsigned char photonMapTexId, bool updateAllFace, float attenuation, bool useTriangles, bool blurMap)
Constructor.
const String & | getCausticCubeMapTextureName ()
returns the name of the resulting caustic cubemap texture
void | photonMapChanged (RenderingRun *run)
Called if the changed run is a PhotonMapRenderingRun.
float | getAttenuation ()
bool | canJoin (RenderingRun *run)
Returns true if two runs can be joined.
void | setBlurMap (bool blur)
OgreRenderingRun * asOgreRenderingRun ()
Conversion to OgreRenderRun.
OgreRenderingRun * asOgreRenderingRun ()
Conversion to OgreRenderRun.
bool | update (unsigned long frameNum)
Calls updateFrame() if the run needs update according to its starting frame and update interval and has not been allready updated in this frame.

Protected Member Functions

void | createCausticCubeMap ()
Creates a cubemap texture used for the caustic-cubemap.
void | updateCubeFace (int facenum)
Updates one face of the cubemap.
bool | faceNeedsUpdate (int facenum)
Checks if a cubemap face needs to be updated.
Vector3 | getCubeMapFaceDirection (unsigned char faceId)
Returns a direction for a cubemap face id.
Vector3 | getCubeMapFaceDirection (unsigned char faceId)
Returns a direction for a cubemap face id.
Texture * | createCubeRenderTexture (String name, const Vector3 position, unsigned int resolution=512, PixelFormat format=PF_FLOAT16_RGBA, int numMips=0, ColourValue clearColor=ColourValue::Black)
Creates a cubemap texture.
Texture * | createCubeRenderTexture (String name, const Vector3 position, unsigned int resolution=512, PixelFormat format=PF_FLOAT16_RGBA, int numMips=0, ColourValue clearColor=ColourValue::Black)
Creates a cubemap texture.
void | setMaterialForRenderables (String &materialName, RenderQueue *rq)
Sets the given material for each Renderable in a RenderQueue.
void | setMaterialForRenderables (String &materialName, RenderQueue *rq, bool solidsonly=false)
Sets the given material for each Renderable in a RenderQueue.
void | setMaterialForVisibles (String &materialName, Camera *cam, bool shadowcastersonly=false)
Sets the given material for each Renderable visible from a given camera.
void | setMaterialForVisibles (String &materialName, Camera *cam, bool shadowcastersonly=false, bool solidsonly=false)
Sets the given material for each Renderable visible from a given camera.
void | restoreMaterials ()
Restores previously stored materials.
void | restoreMaterials ()
Restores previously stored materials.
void | renderFullscreenQuad (String materialName, RenderTarget *target)
Renderes a full screen quad on a given RendderTarget with a given material.
void | renderFullscreenQuad (String materialName, RenderTarget *target)
Renderes a full screen quad on a given RendderTarget with a given material.
void | renderPixelSprites (String &materialName, RenderTarget *rt, int width, int height)
Renderes sprites to pixels of the screen on a given RendderTarget with a given material.
void | renderPixelSprites (String &materialName, RenderTarget *rt, int width, int height)
Renderes sprites to pixels of the screen on a given RendderTarget with a given material.
void | renderFullscreenGrid (String &materialName, RenderTarget *rt, int width, int height)
Renders a grid onto the screen.
virtual bool | needUpdate (unsigned long frameNum)
Returns if this run needs update.
virtual void | updateFrame (unsigned long frameNum)
This function does the actual update in a frame.
virtual void | updateFrame (unsigned long frameNum)
This function does the actual update in a frame.

Protected Attributes

unsigned char | photonMapTexId
the texture unit state id of the caustic map generation material where the photonhit map should be bound to
OgreSharedRuns * sharedRuns
a pointer to the OgreSharedRuns this run belongs to
String | name
the name of the cubemap texture that was created by this run
Texture * | causticCubemapTexture
a pointer to the cubemap texture that was created by this run
Texture * | bluredCausticCubemapTexture
a pointer to the blurred cubemap texture that was created by this run
String | materialName
the name of the material that should be used when rendering the caustic cubemap
float | attenuation
attenuation distance of the caustic
bool | useTriangles
sets if triangles should be rendered into the caustic cubemap instead of sprites
bool | blurMap
sets if the caustic cubemap should be blurred (recommended if rendering caustic triangles)
std::map< Renderable *, String > | visibleObjects
map of Renderables which will be rendered with a given material
std::map< Renderable *, String > | visibleObjects
map of Renderables which will be rendered with a given material
SpriteSet * | pixelSprites
SpriteSet used in pixel sprite rendering.
BillboardSet * | pixelSprites
SpriteSet used in pixel sprite rendering.
String | spriteSetName
unique name of the SpriteSet used in pixel sprite rendering
Entity * | fullscreenGrid
Entity used in fullscreen grid rendering.
unsigned long | lastupdated
The number of the last frame this run was updated.
unsigned long | startFrame
The number of the frame this run should be updated first.
unsigned long | updateInterval
Refresh frequency in frames.
bool | updateAllFace
defines if all cubemap faces should be updated in a frame or only one face per frame
unsigned char | currentFace
the number of the face to be updated
unsigned int | resolution
the resolution of the cubemap texture that was created by this run

Static Protected Attributes

static MovablePlane * | fullScreenQuad
fulls screen quad plane used in full screen quad rendering
static MovablePlane * | fullScreenQuad
fulls screen quad plane used in full screen quad rendering
static Entity * | fullScreenQuadEntity
fulls screen quad Entity used in full screen quad rendering
static Entity * | fullScreenQuadEntity
fulls screen quad Entity used in full screen quad rendering
static SceneNode * | fullScreenQuadNode
fulls screen quad SceneNode used in full screen quad rendering
static SceneNode * | fullScreenQuadNode
fulls screen quad SceneNode used in full screen quad rendering

Detailed Description

CausticCubeMapRenderingRun used in an OGRE environment.

Constructor & Destructor Documentation

OgreCausticCubeMapRenderingRun::OgreCausticCubeMapRenderingRun | ( | OgreSharedRuns * | sharedRuns,
 |  | String | name,
 |  | unsigned long | startFrame,
 |  | unsigned long | updateInterval,
 |  | unsigned int | resolution,
 |  | String | materialName,
 |  | unsigned char | photonMapTexId,
 |  | bool | updateAllFace,
 |  | float | attenuation,
 |  | bool | useTriangles,
 |  | bool | blurMap
 | ) |  |

Constructor.

Parameters:
sharedRuns | a pointer to the OgreSharedRuns this run belongs to
name | the name of the cubemap texture to be created
startFrame | adds an offset to the current frame number to help evenly distribute updates between frames
updateInterval | update frequency
resolution | cubemap resolution
materialName | the name of the material that should be used when rendering the caustic cubemap
photonMapTexId | the texture unit state id of the caustic map generation material where the photonhit map should be bound to
updateAllFace | defines if all cubemap faces should be updated in a frame or only one face per frame
attenuation | attenuation distance of the caustic
useTriangles | sets if triangles should be rendered into the caustic cubemap instead of sprites
blurMap | sets if the caustic cubemap should be blurred (recommended if rendering caustic triangles)

Member Function Documentation

void OgreCausticCubeMapRenderingRun::photonMapChanged ( RenderingRun * run ) [virtual]

Called if the changed run is a PhotonMapRenderingRun.

Parameters:
run pointer to the changed PhotonMapRenderingRun

Implements CausticCubeMapRenderingRun.

float OgreCausticCubeMapRenderingRun::getAttenuation ( ) [inline]

See also:
attenuation

bool OgreCausticCubeMapRenderingRun::canJoin ( RenderingRun * run ) [inline, virtual]

Returns true if two runs can be joined.

In some cases special requirements should stand to join two runs (even if they have the same type). Eg.: two caustic cube map generation technique should only be joined if they use the same material when rendering the caustic cubemap.

Reimplemented from RenderingRun.

void OgreCausticCubeMapRenderingRun::setBlurMap ( bool blur ) [inline]

See also:
blurMap

void OgreCausticCubeMapRenderingRun::updateCubeFace ( int facenum ) [inline, protected, virtual]

Updates one face of the cubemap.

Parameters:
facenum the number of the face to be updated

Implements CausticCubeMapRenderingRun.

bool OgreCausticCubeMapRenderingRun::faceNeedsUpdate ( int facenum ) [protected, virtual]

Checks if a cubemap face needs to be updated.

If the object we are updating the cubemap for is far from the camera, or too small, or the given cubemapface does not have significant effect on the rendering the face can be skipped.

Parameters:
facenum the number of the face to be checked

Implements CausticCubeMapRenderingRun.

OgreRenderingRun* OgreRenderingRun::asOgreRenderingRun ( ) [inline, virtual, inherited]

Conversion to OgreRenderRun.

This function is needed because of virtual inheritance.

Reimplemented from RenderingRun.

OgreRenderingRun* OgreRenderingRun::asOgreRenderingRun ( ) [inline, virtual, inherited]

Conversion to OgreRenderRun.

This function is needed because of virtual inheritance.

Reimplemented from RenderingRun.

Vector3 OgreRenderingRun::getCubeMapFaceDirection ( unsigned char faceId ) [protected, inherited]

Returns a direction for a cubemap face id.

This is a helper function to retrieve the normal direction of a given cubemap face.

Parameters:
faceId the number of the face

Vector3 OgreRenderingRun::getCubeMapFaceDirection ( unsigned char faceId ) [protected, inherited]

Returns a direction for a cubemap face id.

This is a helper function to retrieve the normal direction of a given cubemap face.

Parameters:
faceId the number of the face

Texture * OgreRenderingRun::createCubeRenderTexture | ( | String | name,
 |  | const Vector3 | position,
 |  | unsigned int | resolution = 512,
 |  | PixelFormat | format = PF_FLOAT16_RGBA,
 |  | int | numMips = 0,
 |  | ColourValue | clearColor = ColourValue::Black |
 | ) |  |  | [protected, inherited]

Creates a cubemap texture.

This is a helper function to easily create a cubemap texture and automaticly attach viewports to each face so it can be used as a rendertarget.

Parameters:
name | the name of the texture to be created
position | the initial position of the cubemap
resolution | the resolution of one cubemapface
format | the pixel format of the cubemap
numMips | the number of mipmap levels
clearColor | initial color

Texture* OgreRenderingRun::createCubeRenderTexture | ( | String | name,
 |  | const Vector3 | position,
 |  | unsigned int | resolution = 512,
 |  | PixelFormat | format = PF_FLOAT16_RGBA,
 |  | int | numMips = 0,
 |  | ColourValue | clearColor = ColourValue::Black |
 | ) |  |  | [protected, inherited]

Creates a cubemap texture.

This is a helper function to easily create a cubemap texture and automaticly attach viewports to each face so it can be used as a rendertarget.

Parameters:
name | the name of the texture to be created
position | the initial position of the cubemap
resolution | the resolution of one cubemapface
format | the pixel format of the cubemap
numMips | the number of mipmap levels
clearColor | initial color

void OgreRenderingRun::setMaterialForRenderables | ( | String & | materialName,
 |  | RenderQueue * | rq |
 | ) |  |  | [protected, inherited]

Sets the given material for each Renderable in a RenderQueue.

This is a helper function to set a material to each element of a previously filled Renderque. The orginal material of the Renderables are stored so they can be restored later. The function also tells the current SceneManager not to search for visible objects, as we are going to use the given RenderQueue during the next rendering.

Parameters:
materialName | the name of the material to set for the Renderables
rq | pointer to the filled Renderqueue instance to set material for

void OgreRenderingRun::setMaterialForRenderables | ( | String & | materialName,
 |  | RenderQueue * | rq,
 |  | bool | solidsonly = false |
 | ) |  |  | [protected, inherited]

Sets the given material for each Renderable in a RenderQueue.

This is a helper function to set a material to each element of a previously filled Renderque. The orginal material of the Renderables are stored so they can be restored later. The function also tells the current SceneManager not to search for visible objects, as we are going to use the given RenderQueue during the next rendering.

Parameters:
materialName | the name of the material to set for the Renderables
rq | pointer to the filled Renderqueue instance to set material for

void OgreRenderingRun::setMaterialForVisibles | ( | String & | materialName,
 |  | Camera * | cam,
 |  | bool | shadowcastersonly = false |
 | ) |  |  | [protected, inherited]

Sets the given material for each Renderable visible from a given camera.

This helper function is similar to setMaterialForRenderables but it is also responsible for filling the RenderQueue. First the RenderQueue of the current SceneManager fill be filled with the visible objects seen from the given camera. Then the required material will be set for each element of the RenderQueue. The orginal material of the Renderables are stored so they can be restored later. The function also tells the current SceneManager not to search for visible objects, as we are going to use the filled RenderQueue during the next rendering.

Parameters:
materialName | the name of the material to set for the Renderables
cam | pointer to the camera from which visible objects should be searched
shadowcastersonly | flag to search for only shadow casters

void OgreRenderingRun::setMaterialForVisibles | ( | String & | materialName,
 |  | Camera * | cam,
 |  | bool | shadowcastersonly = false,
 |  | bool | solidsonly = false |
 | ) |  |  | [protected, inherited]

Sets the given material for each Renderable visible from a given camera.

This helper function is similar to setMaterialForRenderables but it is also responsible for filling the RenderQueue. First the RenderQueue of the current SceneManager fill be filled with the visible objects seen from the given camera. Then the required material will be set for each element of the RenderQueue. The orginal material of the Renderables are stored so they can be restored later. The function also tells the current SceneManager not to search for visible objects, as we are going to use the filled RenderQueue during the next rendering.

Parameters:
materialName | the name of the material to set for the Renderables
cam | pointer to the camera from which visible objects should be searched
shadowcastersonly | flag to search for only shadow casters

void OgreRenderingRun::restoreMaterials ( ) [protected, inherited]

Restores previously stored materials.

This helper function is typically used after a setMaterialForRenderables or setMaterialForVisibles call and a rendering process to restore the original material settings. The function also tells the current SceneManager to search for visible objects, as this is the default behaviour of SceneManager.

void OgreRenderingRun::restoreMaterials ( ) [protected, inherited]

Restores previously stored materials.

This helper function is typically used after a setMaterialForRenderables or setMaterialForVisibles call and a rendering process to restore the original material settings. The function also tells the current SceneManager to search for visible objects, as this is the default behaviour of SceneManager.

void OgreRenderingRun::renderFullscreenQuad | ( | String | materialName,
 |  | RenderTarget * | target |
 | ) |  |  | [protected, inherited]

Renderes a full screen quad on a given RendderTarget with a given material.

Parameters:
materialName | the name of the material bind to the quad
target | the RenderTarget the quad should be rendered on

void OgreRenderingRun::renderFullscreenQuad | ( | String | materialName,
 |  | RenderTarget * | target |
 | ) |  |  | [protected, inherited]

Renderes a full screen quad on a given RendderTarget with a given material.

Parameters:
materialName | the name of the material bind to the quad
target | the RenderTarget the quad should be rendered on

void OgreRenderingRun::renderPixelSprites | ( | String & | materialName,
 |  | RenderTarget * | rt,
 |  | int | width,
 |  | int | height |
 | ) |  |  | [protected, inherited]

Renderes sprites to pixels of the screen on a given RendderTarget with a given material.

Pixel sprites are pixel sized quads, placed on each pixel of the RenderTarget. The number of sprites not necessary corresponds to the resolution of the rendertarget. The pixel quads will evenly fill the rendertarget's area with sizes corresponding to the given resolution. We can render fewer or more pixel quads than the number of pixels the rendertarget has (eg.: in case of caustic cubemap generation).

Parameters:
materialName | the name of the material bind to the pixel sprites
rt | the RenderTarget the quads should be rendered on
width | the desired resolution width of the sprites
height | the desired resolution height of the sprites

void OgreRenderingRun::renderPixelSprites | ( | String & | materialName,
 |  | RenderTarget * | rt,
 |  | int | width,
 |  | int | height |
 | ) |  |  | [protected, inherited]

Renderes sprites to pixels of the screen on a given RendderTarget with a given material.

Pixel sprites are pixel sized quads, placed on each pixel of the RenderTarget. The number of sprites not necessary corresponds to the resolution of the rendertarget. The pixel quads will evenly fill the rendertarget's area with sizes corresponding to the given resolution. We can render fewer or more pixel quads than the number of pixels the rendertarget has (eg.: in case of caustic cubemap generation).

Parameters:
materialName | the name of the material bind to the pixel sprites
rt | the RenderTarget the quads should be rendered on
width | the desired resolution width of the sprites
height | the desired resolution height of the sprites

void OgreRenderingRun::renderFullscreenGrid | ( | String & | materialName,
 |  | RenderTarget * | rt,
 |  | int | width,
 |  | int | height |
 | ) |  |  | [protected, inherited]

Renders a grid onto the screen.

Parameters:
rt | the RenderTarget the grid should be rendered on
width | the desired horizontal resolution of the grid
height | the desired vertical resolution of the grid

virtual bool RenderingRun::needUpdate ( unsigned long frameNum ) [inline, protected, virtual, inherited]

Returns if this run needs update.

This tipically depends on the upate interval and the starting frame number.

Parameters:
frameNum current frame number

Reimplemented in OgreFocusingMapRenderingRun, and OgrePMEntryPointMapRenderingRun.

virtual void RenderingRun::updateFrame ( unsigned long frameNum ) [inline, protected, virtual, inherited]

This function does the actual update in a frame.

Parameters:
frameNum current frame number

Reimplemented in CausticCubeMapRenderingRun, ChildPsystemRenderingRun, CubeMapRenderingRun, DepthShadowMapRenderingRun, LightVolumeRenderingRun, PhaseTextureRenderingRun, PhotonMapRenderingRun, ReducedCubeMapRenderingRun, SceneCameraDepthRenderingRun, OgreChildPSystemRenderingRun, OgreDepthShadowMapRenderingRun, OgreFocusingMapRenderingRun, OgreLightVolumeRenderingRun, OgrePhaseTextureRenderingRun, OgrePhotonMapRenderingRun, OgrePMEntryPointMapRenderingRun, OgrePMWeightComputeRenderingRun, and OgreSceneCameraDepthRenderingRun.

void CausticCubeMapRenderingRun::updateFrame ( unsigned long frameNum ) [protected, virtual, inherited]

This function does the actual update in a frame.

Parameters:
frameNum current frame number

Reimplemented from RenderingRun.

Member Data Documentation

std::map<Renderable*, String> OgreRenderingRun::visibleObjects [protected, inherited]

map of Renderables which will be rendered with a given material

The String stores the original material name that will be restored after rendering.

See also:
setMaterialForVisibles

setMaterialForRenderables

restoreMaterials

std::map<Renderable*, String> OgreRenderingRun::visibleObjects [protected, inherited]

map of Renderables which will be rendered with a given material

The String stores the original material name that will be restored after rendering.

See also:
setMaterialForVisibles

setMaterialForRenderables

restoreMaterials

MovablePlane * OgreRenderingRun::fullScreenQuad [static, protected, inherited]

fulls screen quad plane used in full screen quad rendering

See also:
renderFullscreenQuad

MovablePlane* OgreRenderingRun::fullScreenQuad [static, protected, inherited]

fulls screen quad plane used in full screen quad rendering

See also:
renderFullscreenQuad

Entity * OgreRenderingRun::fullScreenQuadEntity [static, protected, inherited]

fulls screen quad Entity used in full screen quad rendering

See also:
renderFullscreenQuad

Entity* OgreRenderingRun::fullScreenQuadEntity [static, protected, inherited]

fulls screen quad Entity used in full screen quad rendering

See also:
renderFullscreenQuad

SceneNode * OgreRenderingRun::fullScreenQuadNode [static, protected, inherited]

fulls screen quad SceneNode used in full screen quad rendering

See also:
renderFullscreenQuad

SceneNode* OgreRenderingRun::fullScreenQuadNode [static, protected, inherited]

fulls screen quad SceneNode used in full screen quad rendering

See also:
renderFullscreenQuad

SpriteSet* OgreRenderingRun::pixelSprites [protected, inherited]

SpriteSet used in pixel sprite rendering.

See also:
renderPixelSprites

BillboardSet* OgreRenderingRun::pixelSprites [protected, inherited]

SpriteSet used in pixel sprite rendering.

See also:
renderPixelSprites

String OgreRenderingRun::spriteSetName [protected, inherited]

unique name of the SpriteSet used in pixel sprite rendering

See also:
renderPixelSprites

Entity* OgreRenderingRun::fullscreenGrid [protected, inherited]

Entity used in fullscreen grid rendering.

See also:
renderPixelGrid

Generated on Wed Mar 28 11:48:50 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: OgreCausticReceiverRenderTechnique Class Reference

OgreCausticReceiverRenderTechnique Class Reference

CausticReceiverRenderTechnique used in an OGRE environment. More...

Inheritance diagram for OgreCausticReceiverRenderTechnique:

OgreRenderTechnique CausticReceiverRenderTechnique RenderTechnique RenderTechnique List of all members.

Public Member Functions

OgreCausticReceiverRenderTechnique (int maxcasters, String causticVertexProgram, String causticFragmentProgram, Pass *pass, OgreRenderable *parentRenderable, OgreTechniqueGroup *parentTechniqueGroup)
Constructor.
~OgreCausticReceiverRenderTechnique ()
Destructor.
virtual void | update (unsigned long frameNum)
Updates the resources in the given frame.
virtual OgreRenderTechnique * | asOgreRenderTechnique ()
Conversion to OgreRenderTechnique.
virtual void | runChanged (RenderingRunType runType, RenderingRun *run)
Called after one of he shared runs changes.
virtual void | runUpdated (RenderingRunType runType, RenderingRun *run)
Called after one of he shared runs updates.
ElementaryRenderable * getParentRenderable ()
Retrieves the renderable this technique operates on.

Protected Attributes

int | maxcasters
the maximum number of caustic casters from which this receiver can recieve caustic light
String | causticVertexProgram
the vertex program to be used in the caustic gathering passes
String | causticFragmentProgram
the fragment program to be used in the caustic gathering passes
std::vector< Pass * > | passes
std::vector< OgreSharedRuns * > | causticCasters
the nearest caustic casters found during update
OgreRenderable * parentOgreRenderable
a OgreRenderable pointer to the renderable this technique operates on.
OgreTechniqueGroup * parentOgreTechniqueGroup
a OgreTechniqueGroup pointer to the TechniqueGroup this technique is attached to.
Pass * | pass
a pointer to the pass this technique operates on.
ElementaryRenderable * parentRenderable
The renderable this technique operates on.
TechniqueGroup * parentTechniqueGroup
The TechniqueGroup this RenderedTechnique is attached to.
SharedRuns * sharedRuns
The SharedRuns this RenderedTechnique is attached to.

Detailed Description

CausticReceiverRenderTechnique used in an OGRE environment.

This technique defines that the object will recieve caustic lighting from caustic caster objects. The caustic light spots will be calculated by the caustic caster's RenderingRuns. These runs will only be updated if caustic redievers are visible, so it is the receiver technique's responsibility to update them.

Each caustic caster's light contribution will be added in separate passes. Each pass will add some light to the shaded image, so these passes should be the last passes. In the constructor the given Pass* parameter will be the pass after which the caustic lighting passes will be added by the technique.

Constructor & Destructor Documentation

OgreCausticReceiverRenderTechnique::OgreCausticReceiverRenderTechnique | ( | int | maxcasters,
 |  | String | causticVertexProgram,
 |  | String | causticFragmentProgram,
 |  | Pass * | pass,
 |  | OgreRenderable * | parentRenderable,
 |  | OgreTechniqueGroup * | parentTechniqueGroup
 | ) |  |

Constructor.

Parameters:
maxcasters | the maximum number of caustic casters from which this receiver can recieve caustic light
causticVertexProgram | the vertex program to be used in the caustic gathering passes
causticFragmentProgram | the fragment program to be used in the caustic gathering passes. It should have one pass and the caustic cubemap of a caster will be bound to the first sampler unit.
pass | the pass after which caustic gathering passes should be added
parentRenderable | the object to operate on
parentTechniqueGroup | the TechniqueGroup this RenderedTechnique is attached to

Member Function Documentation

void OgreCausticReceiverRenderTechnique::update ( unsigned long frameNum ) [virtual]

Updates the resources in the given frame.

A RenderTechnique is usually need some resources from several runs, so these runs will be updated.

Parameters:
frameNum the actual framenumber

Reimplemented from RenderTechnique.

virtual OgreRenderTechnique* OgreRenderTechnique::asOgreRenderTechnique ( ) [inline, virtual, inherited]

Conversion to OgreRenderTechnique.

This function is needed because of virtual inheritance.

Reimplemented from RenderTechnique.

virtual void RenderTechnique::runChanged | ( | RenderingRunType | runType,
 |  | RenderingRun * | run |
 | ) |  |  | [inline, virtual, inherited]

Called after one of he shared runs changes.

Parameters:
runType | enum describing the type of the changed run
run | pointer to the changed RenderingRun

Reimplemented in CausticCasterRenderTechnique, ColorCubeMapRenderTechnique, ConvolvedCubeMapRenderTechnique, CubeMapRenderTechnique, DistanceCubeMapRenderTechnique, HierarchicalParticleSystemTechnique, and IllumVolumeRenderTechnique.

virtual void RenderTechnique::runUpdated | ( | RenderingRunType | runType,
 |  | RenderingRun * | run |
 | ) |  |  | [inline, virtual, inherited]

Called after one of he shared runs updates.

Parameters:
runType | enum describing the type of the updated run
run | pointer to the updated RenderingRun

Reimplemented in CausticCasterRenderTechnique, ColorCubeMapRenderTechnique, CubeMapRenderTechnique, DistanceCubeMapRenderTechnique, HierarchicalParticleSystemTechnique, and IllumVolumeRenderTechnique.

Member Data Documentation

String OgreCausticReceiverRenderTechnique::causticFragmentProgram [protected]

the fragment program to be used in the caustic gathering passes

It should have one pass and the caustic cubemap of a caster will be bound to the first sampler unit.

std::vector<Pass*> OgreCausticReceiverRenderTechnique::passes [protected]

new passes created by this technique

Generated on Wed Mar 28 11:48:50 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: OgreCausticReceiverRenderTechniqueFactory Class Reference

OgreCausticReceiverRenderTechniqueFactory Class Reference

RenderTechniqueFactory to create OgreCausticReceiverRenderTechnique instances. More...

Inheritance diagram for OgreCausticReceiverRenderTechniqueFactory:

RenderTechniqueFactory List of all members.

Public Member Functions

OgreRenderTechnique * | createInstance (IllumTechniqueParams *params, Pass *pass, OgreRenderable *parentRenderable, OgreTechniqueGroup *parentTechniqueGroup)
Creates a RenderTechnique of the factory type.
bool | isType (String type)
Returns if this factory can create a RenderTechnique of the given type.
virtual void | parseParams (IllumTechniqueParams *params)
parses parameters from the material file.

Protected Types

typedef void(*) | ILLUM_ATTRIBUTE_PARSER (String &params, RenderTechniqueFactory *factory)
function for parsing RenderTechnique attributes
typedef std::map< String,
ILLUM_ATTRIBUTE_PARSER > 		AttribParserList
Keyword-mapped attribute parsers.

Protected Attributes

AttribParserList attributeParsers
map of parser functions
String | typeName
factoryname

Detailed Description

RenderTechniqueFactory to create OgreCausticReceiverRenderTechnique instances.

Member Typedef Documentation

typedef void(*) RenderTechniqueFactory::ILLUM_ATTRIBUTE_PARSER(String &params, RenderTechniqueFactory *factory) [protected, inherited]

function for parsing RenderTechnique attributes

Parameters:
params attribute value stored in a String

Member Function Documentation

OgreRenderTechnique * OgreCausticReceiverRenderTechniqueFactory::createInstance | ( | IllumTechniqueParams * | params,
 |  | Pass * | pass,
 |  | OgreRenderable * | parentRenderable,
 |  | OgreTechniqueGroup * | parentTechniqueGroup |
 | ) |  |  | [virtual]

Creates a RenderTechnique of the factory type.

Parameters:
params | containes constructor parameters as NameValuePairList
pass | the Pass to use in RenderTechnique constructor
pass | the parentRenderable to pass to RenderTechnique constructor
pass | the parentTechniqueGroup to pass to RenderTechnique constructor

Implements RenderTechniqueFactory.

bool RenderTechniqueFactory::isType ( String type ) [inline, inherited]

Returns if this factory can create a RenderTechnique of the given type.

Parameters:
type RenderTechnique type

void RenderTechniqueFactory::parseParams ( IllumTechniqueParams * params ) [virtual, inherited]

parses parameters from the material file.

The parsed parameters will be passed to the new RenderTechnique's constructor.

Parameters:
params pointer to the IllumTechniqueParams structure that was read from the material script and containes the parameters to be parsed.

Generated on Wed Mar 28 11:48:51 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: OgreChildPSystemRenderingRun Class Reference

OgreChildPSystemRenderingRun Class Reference

ChildPsystemRenderingRun used in an OGRE environment. More...

Inheritance diagram for OgreChildPSystemRenderingRun:

OgreRenderingRun ChildPsystemRenderingRun RenderingRun RenderingRun RenderingRun List of all members.

Public Member Functions

OgreChildPSystemRenderingRun (OgreSharedRuns *sharedRuns, String name, unsigned long startFrame, unsigned long updateInterval, unsigned int resolution, bool perspectiveRendering, String childParticleSystemName, String particleScriptName, bool useOwnMaterial, String materialName)
Constructor.
String | getImpostorTextureName ()
returns the name of the resulting photon hit map
bool | canJoin (RenderingRun *run)
Returns true if two runs can be joined.
Real | getSmallSysRadius ()
Returns the radius of the small particle system.
OgreRenderingRun * asOgreRenderingRun ()
Conversion to OgreRenderRun.
OgreRenderingRun * asOgreRenderingRun ()
Conversion to OgreRenderRun.
bool | update (unsigned long frameNum)
Calls updateFrame() if the run needs update according to its starting frame and update interval and has not been allready updated in this frame.

Protected Member Functions

void | updateFrame (unsigned long frameNum)
This function does the actual update in a frame.
void | createImpostorTexture ()
Creates an impostor texture that can be used as a rendertarget during impostor rendering.
Vector3 | getCubeMapFaceDirection (unsigned char faceId)
Returns a direction for a cubemap face id.
Vector3 | getCubeMapFaceDirection (unsigned char faceId)
Returns a direction for a cubemap face id.
Texture * | createCubeRenderTexture (String name, const Vector3 position, unsigned int resolution=512, PixelFormat format=PF_FLOAT16_RGBA, int numMips=0, ColourValue clearColor=ColourValue::Black)
Creates a cubemap texture.
Texture * | createCubeRenderTexture (String name, const Vector3 position, unsigned int resolution=512, PixelFormat format=PF_FLOAT16_RGBA, int numMips=0, ColourValue clearColor=ColourValue::Black)
Creates a cubemap texture.
void | setMaterialForRenderables (String &materialName, RenderQueue *rq)
Sets the given material for each Renderable in a RenderQueue.
void | setMaterialForRenderables (String &materialName, RenderQueue *rq, bool solidsonly=false)
Sets the given material for each Renderable in a RenderQueue.
void | setMaterialForVisibles (String &materialName, Camera *cam, bool shadowcastersonly=false)
Sets the given material for each Renderable visible from a given camera.
void | setMaterialForVisibles (String &materialName, Camera *cam, bool shadowcastersonly=false, bool solidsonly=false)
Sets the given material for each Renderable visible from a given camera.
void | restoreMaterials ()
Restores previously stored materials.
void | restoreMaterials ()
Restores previously stored materials.
void | renderFullscreenQuad (String materialName, RenderTarget *target)
Renderes a full screen quad on a given RendderTarget with a given material.
void | renderFullscreenQuad (String materialName, RenderTarget *target)
Renderes a full screen quad on a given RendderTarget with a given material.
void | renderPixelSprites (String &materialName, RenderTarget *rt, int width, int height)
Renderes sprites to pixels of the screen on a given RendderTarget with a given material.
void | renderPixelSprites (String &materialName, RenderTarget *rt, int width, int height)
Renderes sprites to pixels of the screen on a given RendderTarget with a given material.
void | renderFullscreenGrid (String &materialName, RenderTarget *rt, int width, int height)
Renders a grid onto the screen.
virtual bool | needUpdate (unsigned long frameNum)
Returns if this run needs update.

Protected Attributes

bool | perspectiveRendering
Sets if the impostor should be rendered with a perspective projection or orthogonal.
bool | useOwnMaterial
Use the material that was defined in the particle script.
String | materialName
Use this specific material while rendering the impostor.
String | childParticleSystemName
The name of the small particle system.
String | particleScriptName
The name of the small particle system script.
Real | sysRad
Radius of the small particle system.
Camera * | impostorCamera
Camera used while rendering the impostor image.
OgreSharedRuns * sharedRuns
A pointer to the OgreSharedRuns this run belongs to.
String | name
The name of the imostor texture that was created by this run.
Texture * | impostorTexture
A pointer to the impostor texture that was created by this run.
std::map< Renderable *, String > | visibleObjects
map of Renderables which will be rendered with a given material
std::map< Renderable *, String > | visibleObjects
map of Renderables which will be rendered with a given material
SpriteSet * | pixelSprites
SpriteSet used in pixel sprite rendering.
BillboardSet * | pixelSprites
SpriteSet used in pixel sprite rendering.
String | spriteSetName
unique name of the SpriteSet used in pixel sprite rendering
Entity * | fullscreenGrid
Entity used in fullscreen grid rendering.
unsigned long | lastupdated
The number of the last frame this run was updated.
unsigned long | startFrame
The number of the frame this run should be updated first.
unsigned long | updateInterval
Refresh frequency in frames.
unsigned int | resolution
the resolution of the impostor image

Static Protected Attributes

static MovablePlane * | fullScreenQuad
fulls screen quad plane used in full screen quad rendering
static MovablePlane * | fullScreenQuad
fulls screen quad plane used in full screen quad rendering
static Entity * | fullScreenQuadEntity
fulls screen quad Entity used in full screen quad rendering
static Entity * | fullScreenQuadEntity
fulls screen quad Entity used in full screen quad rendering
static SceneNode * | fullScreenQuadNode
fulls screen quad SceneNode used in full screen quad rendering
static SceneNode * | fullScreenQuadNode
fulls screen quad SceneNode used in full screen quad rendering

Detailed Description

ChildPsystemRenderingRun used in an OGRE environment.

Constructor & Destructor Documentation

OgreChildPSystemRenderingRun::OgreChildPSystemRenderingRun | ( | OgreSharedRuns * | sharedRuns,
 |  | String | name,
 |  | unsigned long | startFrame,
 |  | unsigned long | updateInterval,
 |  | unsigned int | resolution,
 |  | bool | perspectiveRendering,
 |  | String | childParticleSystemName,
 |  | String | particleScriptName,
 |  | bool | useOwnMaterial,
 |  | String | materialName
 | ) |  |

Constructor.

Parameters:
sharedRuns | a pointer to the OgreSharedRuns this run belongs to
name | the name of the texture to be created
startFrame | adds an offset to the current frame number to help evenly distribute updates between frames
updateInterval | update frequency
resolution | resolution of the impostor texture
perspectiveRendering | sets if the impostor should be rendered with a perspective projection or orthogonal
childPSysScriptName | the name of the particle system script
useOwnMaterial | use the material that was defined in the particle script
materialName | use this specific material while rendering the impostor

Member Function Documentation

bool OgreChildPSystemRenderingRun::canJoin ( RenderingRun * run ) [inline, virtual]

Returns true if two runs can be joined.

In some cases special requirements should stand to join two runs (even if they have the same type). Eg.: two caustic cube map generation technique should only be joined if they use the same material when rendering the caustic cubemap.

Reimplemented from RenderingRun.

void OgreChildPSystemRenderingRun::updateFrame ( unsigned long frameNum ) [protected, virtual]

This function does the actual update in a frame.

Parameters:
frameNum current frame number

Implements ChildPsystemRenderingRun.

OgreRenderingRun* OgreRenderingRun::asOgreRenderingRun ( ) [inline, virtual, inherited]

Conversion to OgreRenderRun.

This function is needed because of virtual inheritance.

Reimplemented from RenderingRun.

OgreRenderingRun* OgreRenderingRun::asOgreRenderingRun ( ) [inline, virtual, inherited]

Conversion to OgreRenderRun.

This function is needed because of virtual inheritance.

Reimplemented from RenderingRun.

Vector3 OgreRenderingRun::getCubeMapFaceDirection ( unsigned char faceId ) [protected, inherited]

Returns a direction for a cubemap face id.

This is a helper function to retrieve the normal direction of a given cubemap face.

Parameters:
faceId the number of the face

Vector3 OgreRenderingRun::getCubeMapFaceDirection ( unsigned char faceId ) [protected, inherited]

Returns a direction for a cubemap face id.

This is a helper function to retrieve the normal direction of a given cubemap face.

Parameters:
faceId the number of the face

Texture * OgreRenderingRun::createCubeRenderTexture | ( | String | name,
 |  | const Vector3 | position,
 |  | unsigned int | resolution = 512,
 |  | PixelFormat | format = PF_FLOAT16_RGBA,
 |  | int | numMips = 0,
 |  | ColourValue | clearColor = ColourValue::Black |
 | ) |  |  | [protected, inherited]

Creates a cubemap texture.

This is a helper function to easily create a cubemap texture and automaticly attach viewports to each face so it can be used as a rendertarget.

Parameters:
name | the name of the texture to be created
position | the initial position of the cubemap
resolution | the resolution of one cubemapface
format | the pixel format of the cubemap
numMips | the number of mipmap levels
clearColor | initial color

Texture* OgreRenderingRun::createCubeRenderTexture | ( | String | name,
 |  | const Vector3 | position,
 |  | unsigned int | resolution = 512,
 |  | PixelFormat | format = PF_FLOAT16_RGBA,
 |  | int | numMips = 0,
 |  | ColourValue | clearColor = ColourValue::Black |
 | ) |  |  | [protected, inherited]

Creates a cubemap texture.

This is a helper function to easily create a cubemap texture and automaticly attach viewports to each face so it can be used as a rendertarget.

Parameters:
name | the name of the texture to be created
position | the initial position of the cubemap
resolution | the resolution of one cubemapface
format | the pixel format of the cubemap
numMips | the number of mipmap levels
clearColor | initial color

void OgreRenderingRun::setMaterialForRenderables | ( | String & | materialName,
 |  | RenderQueue * | rq |
 | ) |  |  | [protected, inherited]

Sets the given material for each Renderable in a RenderQueue.

This is a helper function to set a material to each element of a previously filled Renderque. The orginal material of the Renderables are stored so they can be restored later. The function also tells the current SceneManager not to search for visible objects, as we are going to use the given RenderQueue during the next rendering.

Parameters:
materialName | the name of the material to set for the Renderables
rq | pointer to the filled Renderqueue instance to set material for

void OgreRenderingRun::setMaterialForRenderables | ( | String & | materialName,
 |  | RenderQueue * | rq,
 |  | bool | solidsonly = false |
 | ) |  |  | [protected, inherited]

Sets the given material for each Renderable in a RenderQueue.

This is a helper function to set a material to each element of a previously filled Renderque. The orginal material of the Renderables are stored so they can be restored later. The function also tells the current SceneManager not to search for visible objects, as we are going to use the given RenderQueue during the next rendering.

Parameters:
materialName | the name of the material to set for the Renderables
rq | pointer to the filled Renderqueue instance to set material for

void OgreRenderingRun::setMaterialForVisibles | ( | String & | materialName,
 |  | Camera * | cam,
 |  | bool | shadowcastersonly = false |
 | ) |  |  | [protected, inherited]

Sets the given material for each Renderable visible from a given camera.

This helper function is similar to setMaterialForRenderables but it is also responsible for filling the RenderQueue. First the RenderQueue of the current SceneManager fill be filled with the visible objects seen from the given camera. Then the required material will be set for each element of the RenderQueue. The orginal material of the Renderables are stored so they can be restored later. The function also tells the current SceneManager not to search for visible objects, as we are going to use the filled RenderQueue during the next rendering.

Parameters:
materialName | the name of the material to set for the Renderables
cam | pointer to the camera from which visible objects should be searched
shadowcastersonly | flag to search for only shadow casters

void OgreRenderingRun::setMaterialForVisibles | ( | String & | materialName,
 |  | Camera * | cam,
 |  | bool | shadowcastersonly = false,
 |  | bool | solidsonly = false |
 | ) |  |  | [protected, inherited]

Sets the given material for each Renderable visible from a given camera.

This helper function is similar to setMaterialForRenderables but it is also responsible for filling the RenderQueue. First the RenderQueue of the current SceneManager fill be filled with the visible objects seen from the given camera. Then the required material will be set for each element of the RenderQueue. The orginal material of the Renderables are stored so they can be restored later. The function also tells the current SceneManager not to search for visible objects, as we are going to use the filled RenderQueue during the next rendering.

Parameters:
materialName | the name of the material to set for the Renderables
cam | pointer to the camera from which visible objects should be searched
shadowcastersonly | flag to search for only shadow casters

void OgreRenderingRun::restoreMaterials ( ) [protected, inherited]

Restores previously stored materials.

This helper function is typically used after a setMaterialForRenderables or setMaterialForVisibles call and a rendering process to restore the original material settings. The function also tells the current SceneManager to search for visible objects, as this is the default behaviour of SceneManager.

void OgreRenderingRun::restoreMaterials ( ) [protected, inherited]

Restores previously stored materials.

This helper function is typically used after a setMaterialForRenderables or setMaterialForVisibles call and a rendering process to restore the original material settings. The function also tells the current SceneManager to search for visible objects, as this is the default behaviour of SceneManager.

void OgreRenderingRun::renderFullscreenQuad | ( | String | materialName,
 |  | RenderTarget * | target |
 | ) |  |  | [protected, inherited]

Renderes a full screen quad on a given RendderTarget with a given material.

Parameters:
materialName | the name of the material bind to the quad
target | the RenderTarget the quad should be rendered on

void OgreRenderingRun::renderFullscreenQuad | ( | String | materialName,
 |  | RenderTarget * | target |
 | ) |  |  | [protected, inherited]

Renderes a full screen quad on a given RendderTarget with a given material.

Parameters:
materialName | the name of the material bind to the quad
target | the RenderTarget the quad should be rendered on

void OgreRenderingRun::renderPixelSprites | ( | String & | materialName,
 |  | RenderTarget * | rt,
 |  | int | width,
 |  | int | height |
 | ) |  |  | [protected, inherited]

Renderes sprites to pixels of the screen on a given RendderTarget with a given material.

Pixel sprites are pixel sized quads, placed on each pixel of the RenderTarget. The number of sprites not necessary corresponds to the resolution of the rendertarget. The pixel quads will evenly fill the rendertarget's area with sizes corresponding to the given resolution. We can render fewer or more pixel quads than the number of pixels the rendertarget has (eg.: in case of caustic cubemap generation).

Parameters:
materialName | the name of the material bind to the pixel sprites
rt | the RenderTarget the quads should be rendered on
width | the desired resolution width of the sprites
height | the desired resolution height of the sprites

void OgreRenderingRun::renderPixelSprites | ( | String & | materialName,
 |  | RenderTarget * | rt,
 |  | int | width,
 |  | int | height |
 | ) |  |  | [protected, inherited]

Renderes sprites to pixels of the screen on a given RendderTarget with a given material.

Pixel sprites are pixel sized quads, placed on each pixel of the RenderTarget. The number of sprites not necessary corresponds to the resolution of the rendertarget. The pixel quads will evenly fill the rendertarget's area with sizes corresponding to the given resolution. We can render fewer or more pixel quads than the number of pixels the rendertarget has (eg.: in case of caustic cubemap generation).

Parameters:
materialName | the name of the material bind to the pixel sprites
rt | the RenderTarget the quads should be rendered on
width | the desired resolution width of the sprites
height | the desired resolution height of the sprites

void OgreRenderingRun::renderFullscreenGrid | ( | String & | materialName,
 |  | RenderTarget * | rt,
 |  | int | width,
 |  | int | height |
 | ) |  |  | [protected, inherited]

Renders a grid onto the screen.

Parameters:
rt | the RenderTarget the grid should be rendered on
width | the desired horizontal resolution of the grid
height | the desired vertical resolution of the grid

virtual bool RenderingRun::needUpdate ( unsigned long frameNum ) [inline, protected, virtual, inherited]

Returns if this run needs update.

This tipically depends on the upate interval and the starting frame number.

Parameters:
frameNum current frame number

Reimplemented in OgreFocusingMapRenderingRun, and OgrePMEntryPointMapRenderingRun.

Member Data Documentation

std::map<Renderable*, String> OgreRenderingRun::visibleObjects [protected, inherited]

map of Renderables which will be rendered with a given material

The String stores the original material name that will be restored after rendering.

See also:
setMaterialForVisibles

setMaterialForRenderables

restoreMaterials

std::map<Renderable*, String> OgreRenderingRun::visibleObjects [protected, inherited]

map of Renderables which will be rendered with a given material

The String stores the original material name that will be restored after rendering.

See also:
setMaterialForVisibles

setMaterialForRenderables

restoreMaterials

MovablePlane * OgreRenderingRun::fullScreenQuad [static, protected, inherited]

fulls screen quad plane used in full screen quad rendering

See also:
renderFullscreenQuad

MovablePlane* OgreRenderingRun::fullScreenQuad [static, protected, inherited]

fulls screen quad plane used in full screen quad rendering

See also:
renderFullscreenQuad

Entity * OgreRenderingRun::fullScreenQuadEntity [static, protected, inherited]

fulls screen quad Entity used in full screen quad rendering

See also:
renderFullscreenQuad

Entity* OgreRenderingRun::fullScreenQuadEntity [static, protected, inherited]

fulls screen quad Entity used in full screen quad rendering

See also:
renderFullscreenQuad

SceneNode * OgreRenderingRun::fullScreenQuadNode [static, protected, inherited]

fulls screen quad SceneNode used in full screen quad rendering

See also:
renderFullscreenQuad

SceneNode* OgreRenderingRun::fullScreenQuadNode [static, protected, inherited]

fulls screen quad SceneNode used in full screen quad rendering

See also:
renderFullscreenQuad

SpriteSet* OgreRenderingRun::pixelSprites [protected, inherited]

SpriteSet used in pixel sprite rendering.

See also:
renderPixelSprites

BillboardSet* OgreRenderingRun::pixelSprites [protected, inherited]

SpriteSet used in pixel sprite rendering.

See also:
renderPixelSprites

String OgreRenderingRun::spriteSetName [protected, inherited]

unique name of the SpriteSet used in pixel sprite rendering

See also:
renderPixelSprites

Entity* OgreRenderingRun::fullscreenGrid [protected, inherited]

Entity used in fullscreen grid rendering.

See also:
renderPixelGrid

Generated on Wed Mar 28 11:48:51 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: OgreColorCubeMapRenderTechnique Class Reference

OgreColorCubeMapRenderTechnique Class Reference

ColorCubeMapRenderTechnique used in an Ogre environment. More...

Inheritance diagram for OgreColorCubeMapRenderTechnique:

ColorCubeMapRenderTechnique OgreCubeMapRenderTechnique CubeMapRenderTechnique CubeMapRenderTechnique OgreRenderTechnique RenderTechnique RenderTechnique RenderTechnique List of all members.

Public Member Functions

OgreColorCubeMapRenderTechnique (unsigned long startFrame, unsigned long cubeMapUpdateInterval, unsigned int cubeMapResolution, unsigned char texID, bool useDistCalc, bool useFaceAngleCalc, float distTolerance, float angleTolerance, bool updateAllFace, bool renderSelf, bool renderEnvironment, String selfMaterial, String environmentMaterial, int layer, bool getMinMax, bool attachToTexUnit, String minVariableName, String maxVariableName, Pass *pass, OgreRenderable *parentRenderable, OgreTechniqueGroup *parentTechniqueGroup)
Constructor.
~OgreColorCubeMapRenderTechnique ()
Destructor.
void | update (unsigned long frameNum)
Updates the resources in the given frame.
void | runChanged (RenderingRunType runType, RenderingRun *run)
Called after one of he shared runs changes.
void | runUpdated (RenderingRunType runType, RenderingRun *run)
Called after one of he shared runs updates.
virtual class OgreRenderTechnique * | asOgreRenderTechnique ()
Conversion to OgreRenderTechnique.
ElementaryRenderable * getParentRenderable ()
Retrieves the renderable this technique operates on.
virtual OgreRenderTechnique * | asOgreRenderTechnique ()
Conversion to OgreRenderTechnique.

Protected Member Functions

void | colorCubeMapRunChanged (RenderingRun *run)
Called if the color cubemap rendering run object changes.
void | colorCubeMapRunUpdated (RenderingRun *run)
Called if the color cubemap rendering run object is updated.
virtual RenderingRun * | createCubeMapRun ()=0
Creates a CubeMapRenderingRun.
virtual void | cubeMapRunChanged (RenderingRun *run)=0
Called if the changed run is a CubeMapRenderingRun.
virtual void | cubeMapRunUpdated (RenderingRun *run)=0
Called if the updated run is a CubeMapRenderingRun.
RenderingRun * createCubeMapRun ()
Creates a CubeMapRenderingRun.
void | cubeMapRunChanged (RenderingRun *run)
Called if the changed run is a CubeMapRenderingRun.
void | cubeMapRunUpdated (RenderingRun *run)
Called if the updated run is a CubeMapRenderingRun.

Protected Attributes

bool | useDistCalc
a flag to skip cube face update if object is far away or too small.
bool | useFaceAngleCalc
a flag to skip cube face update the face is neglible.
float | distTolerance
A value used in face skip test.
float | angleTolerance
A value used in face skip test.
bool | updateAllFace
defines if all cubemap faces should be updated in a frame or only one face per frame
unsigned long | cubeMapUpdateInterval
color-cubemap update frequency
unsigned int | cubeMapResolution
color-cubemap resolution
unsigned long | startFrame
offset in frame number used during update
bool | renderSelf
Sets if the object should be rendered to the cube map.
bool | renderEnvironment
Sets if the environment should be rendered to the cube map.
int | layer
The layer of the cubemap.
RenderingRunType | cubemapLayer
The exact run type of this run (according to the actual layer).
ElementaryRenderable * parentRenderable
The renderable this technique operates on.
TechniqueGroup * parentTechniqueGroup
The TechniqueGroup this RenderedTechnique is attached to.
SharedRuns * sharedRuns
The SharedRuns this RenderedTechnique is attached to.
unsigned char | texID
the id of the texture unit state the resulting cubemap should be bound to
String | selfMaterial
the material that should be set for the object while rendering the cubemap
String | environmentMaterial
the material that should be set for the environment while rendering the cubemap
bool | getMinMax
sets if the minimum and maximum values of the cubemap should be computed
bool | attachToTexUnit
sets if this cubemap should be attach to a texture unit of the pass
String | minVariableName
sets the name of the gpu shader program parameter to which the minimum value should be bound to
String | maxVariableName
sets the name of the gpu shader program parameter to which the maximum value should be bound to
OgreRenderable * parentOgreRenderable
a OgreRenderable pointer to the renderable this technique operates on.
OgreTechniqueGroup * parentOgreTechniqueGroup
a OgreTechniqueGroup pointer to the TechniqueGroup this technique is attached to.
Pass * | pass
a pointer to the pass this technique operates on.

Detailed Description

ColorCubeMapRenderTechnique used in an Ogre environment.

Constructor & Destructor Documentation

OgreColorCubeMapRenderTechnique::OgreColorCubeMapRenderTechnique | ( | unsigned long | startFrame,
 |  | unsigned long | cubeMapUpdateInterval,
 |  | unsigned int | cubeMapResolution,
 |  | unsigned char | texID,
 |  | bool | useDistCalc,
 |  | bool | useFaceAngleCalc,
 |  | float | distTolerance,
 |  | float | angleTolerance,
 |  | bool | updateAllFace,
 |  | bool | renderSelf,
 |  | bool | renderEnvironment,
 |  | String | selfMaterial,
 |  | String | environmentMaterial,
 |  | int | layer,
 |  | bool | getMinMax,
 |  | bool | attachToTexUnit,
 |  | String | minVariableName,
 |  | String | maxVariableName,
 |  | Pass * | pass,
 |  | OgreRenderable * | parentRenderable,
 |  | OgreTechniqueGroup * | parentTechniqueGroup
 | ) |  |

Constructor.

Parameters:
startFrame | adds an offset to the current frame number to help evenly distribute updates between frames
cubeMapUpdateInterval | update frequency
cubeMapResolution | color cubemap resolution
texID | the id of the texture unit state the resulting cubemap should be bound to
useDistCalc | flag to skip cube face update if object is far away
useFaceAngleCalc | flag to skip cube face update if face is neglible
distTolerance | distance tolerance used in face skip
angleTolerance | angle tolerance used in face skip
updateAllFace | defines if all cubemap faces should be updated in a frame or only one face per frame
renderSelf | sets if the object should be rendered to the cube map
renderEnvironment | sets if the environment should be rendered to the cube map
selfMaterial | the material that should be set for the object while rendering the cubemap
environmentMaterial | the material that should be set for the environment while rendering the cubemap
layer | the layer of this cubemap
getMinMax | sets if the minimum and maximum values of the cubemap should be computed
attachToTexUnit | sets if this cubemap should be attach to a texture unit of the pass
minVariableName | sets the name of the gpu shader program parameter to which the minimum value should be bound to
maxVariableName | sets the name of the gpu shader program parameter to which the maximum value should be bound to
pass | the pass to operate on
parentRenderable | the object to operate on
parentTechniqueGroup | the TechniqueGroup this RenderedTechnique is attached to

Member Function Documentation

void OgreColorCubeMapRenderTechnique::update ( unsigned long frameNum ) [virtual]

Updates the resources in the given frame.

Parameters:
frameNum the actual framenumber

Reimplemented from ColorCubeMapRenderTechnique.

void OgreColorCubeMapRenderTechnique::colorCubeMapRunChanged ( RenderingRun * run ) [protected, virtual]

Called if the color cubemap rendering run object changes.

Parameters:
run pointer to the new rendering run object

Implements ColorCubeMapRenderTechnique.

void OgreColorCubeMapRenderTechnique::colorCubeMapRunUpdated ( RenderingRun * run ) [protected, virtual]

Called if the color cubemap rendering run object is updated.

Parameters:
run pointer to the rendering run object

Implements ColorCubeMapRenderTechnique.

void ColorCubeMapRenderTechnique::runChanged | ( | RenderingRunType | runType,
 |  | RenderingRun * | run |
 | ) |  |  | [virtual, inherited]

Called after one of he shared runs changes.

Parameters:
runType | enum describing the type of the changed run
run | pointer to the changed RenderingRun

Reimplemented from CubeMapRenderTechnique.

void ColorCubeMapRenderTechnique::runUpdated | ( | RenderingRunType | runType,
 |  | RenderingRun * | run |
 | ) |  |  | [virtual, inherited]

Called after one of he shared runs updates.

Parameters:
runType | enum describing the type of the updated run
run | pointer to the updated RenderingRun

Reimplemented from CubeMapRenderTechnique.

virtual RenderingRun* CubeMapRenderTechnique::createCubeMapRun ( ) [protected, pure virtual, inherited]

Creates a CubeMapRenderingRun.

Returns:
the new CubeMapRenderingRun instance.

Implemented in OgreCubeMapRenderTechnique.

virtual void CubeMapRenderTechnique::cubeMapRunChanged ( RenderingRun * run ) [protected, pure virtual, inherited]

Called if the changed run is a CubeMapRenderingRun.

Parameters:
run pointer to the new CubeMapRenderingRun

Implemented in OgreCubeMapRenderTechnique.

virtual void CubeMapRenderTechnique::cubeMapRunUpdated ( RenderingRun * run ) [protected, pure virtual, inherited]

Called if the updated run is a CubeMapRenderingRun.

Parameters:
run pointer to the updated CubeMapRenderingRun

Implemented in OgreCubeMapRenderTechnique.

virtual class OgreRenderTechnique* RenderTechnique::asOgreRenderTechnique ( ) [inline, virtual, inherited]

Conversion to OgreRenderTechnique.

This function is needed because of virtual inheritance.

Reimplemented in OgreRenderTechnique.

RenderingRun * OgreCubeMapRenderTechnique::createCubeMapRun ( ) [protected, virtual, inherited]

Creates a CubeMapRenderingRun.

Returns:
the new CubeMapRenderingRun instance.

Implements CubeMapRenderTechnique.

void OgreCubeMapRenderTechnique::cubeMapRunChanged ( RenderingRun * run ) [protected, virtual, inherited]

Called if the changed run is a CubeMapRenderingRun.

Parameters:
run pointer to the new CubeMapRenderingRun

Implements CubeMapRenderTechnique.

void OgreCubeMapRenderTechnique::cubeMapRunUpdated ( RenderingRun * run ) [protected, virtual, inherited]

Called if the updated run is a CubeMapRenderingRun.

Parameters:
run pointer to the updated CubeMapRenderingRun

Implements CubeMapRenderTechnique.

virtual OgreRenderTechnique* OgreRenderTechnique::asOgreRenderTechnique ( ) [inline, virtual, inherited]

Conversion to OgreRenderTechnique.

This function is needed because of virtual inheritance.

Reimplemented from RenderTechnique.

Member Data Documentation

bool CubeMapRenderTechnique::useDistCalc [protected, inherited]

a flag to skip cube face update if object is far away or too small.

See also:
distTolerance

bool CubeMapRenderTechnique::useFaceAngleCalc [protected, inherited]

a flag to skip cube face update the face is neglible.

See also:
angleTolerance

float CubeMapRenderTechnique::distTolerance [protected, inherited]

A value used in face skip test.

The higher this value gets the more precise, but slower the method will be.

float CubeMapRenderTechnique::angleTolerance [protected, inherited]

A value used in face skip test.

The higher this value gets the more precise, but slower the method will be.

int CubeMapRenderTechnique::layer [protected, inherited]

The layer of the cubemap.

This extension was created to achieve effect such as multiple reflections and refractions that require more complete sampling of the scene. With this extension we can render the environment into several cubemap layers eg. with depth peeling.

Generated on Wed Mar 28 11:48:51 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: OgreColorCubeMapRenderTechniqueFactory Class Reference

OgreColorCubeMapRenderTechniqueFactory Class Reference

RenderTechniqueFactory to create OgreColorCubeMapRenderTechnique instances. More...

Inheritance diagram for OgreColorCubeMapRenderTechniqueFactory:

OgreCubeMapRenderTechniqueFactory RenderTechniqueFactory List of all members.

Public Member Functions

OgreColorCubeMapRenderTechniqueFactory ()
Technique factory.
OgreRenderTechnique * | createInstance (IllumTechniqueParams *params, Pass *pass, OgreRenderable *parentRenderable, OgreTechniqueGroup *parentTechniqueGroup)
Creates a RenderTechnique of the factory type.
bool | isType (String type)
Returns if this factory can create a RenderTechnique of the given type.
virtual void | parseParams (IllumTechniqueParams *params)
parses parameters from the material file.

Protected Types

typedef void(*) | ILLUM_ATTRIBUTE_PARSER (String &params, RenderTechniqueFactory *factory)
function for parsing RenderTechnique attributes
typedef std::map< String,
ILLUM_ATTRIBUTE_PARSER > 		AttribParserList
Keyword-mapped attribute parsers.

Protected Attributes

AttribParserList attributeParsers
map of parser functions
String | typeName
factoryname

Detailed Description

RenderTechniqueFactory to create OgreColorCubeMapRenderTechnique instances.

Member Typedef Documentation

typedef void(*) RenderTechniqueFactory::ILLUM_ATTRIBUTE_PARSER(String &params, RenderTechniqueFactory *factory) [protected, inherited]

function for parsing RenderTechnique attributes

Parameters:
params attribute value stored in a String

Member Function Documentation

OgreRenderTechnique * OgreColorCubeMapRenderTechniqueFactory::createInstance | ( | IllumTechniqueParams * | params,
 |  | Pass * | pass,
 |  | OgreRenderable * | parentRenderable,
 |  | OgreTechniqueGroup * | parentTechniqueGroup |
 | ) |  |  | [virtual]

Creates a RenderTechnique of the factory type.

Parameters:
params | containes constructor parameters as NameValuePairList
pass | the Pass to use in RenderTechnique constructor
pass | the parentRenderable to pass to RenderTechnique constructor
pass | the parentTechniqueGroup to pass to RenderTechnique constructor

Reimplemented from OgreCubeMapRenderTechniqueFactory.

bool RenderTechniqueFactory::isType ( String type ) [inline, inherited]

Returns if this factory can create a RenderTechnique of the given type.

Parameters:
type RenderTechnique type

void RenderTechniqueFactory::parseParams ( IllumTechniqueParams * params ) [virtual, inherited]

parses parameters from the material file.

The parsed parameters will be passed to the new RenderTechnique's constructor.

Parameters:
params pointer to the IllumTechniqueParams structure that was read from the material script and containes the parameters to be parsed.

Generated on Wed Mar 28 11:48:52 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: OgreConvoledCubeMapRenderTechniqueFactory Class Reference

OgreConvoledCubeMapRenderTechniqueFactory Class Reference

RenderTechniqueFactory to create OgreConvoledCubeMapRenderTechnique instances. More...

Inheritance diagram for OgreConvoledCubeMapRenderTechniqueFactory:

OgreCubeMapRenderTechniqueFactory RenderTechniqueFactory List of all members.

Public Member Functions

OgreConvoledCubeMapRenderTechniqueFactory ()
Technique factory.
OgreRenderTechnique * | createInstance (IllumTechniqueParams *params, Pass *pass, OgreRenderable *parentRenderable, OgreTechniqueGroup *parentTechniqueGroup)
Creates a RenderTechnique of the factory type.
bool | isType (String type)
Returns if this factory can create a RenderTechnique of the given type.
virtual void | parseParams (IllumTechniqueParams *params)
parses parameters from the material file.

Protected Types

typedef void(*) | ILLUM_ATTRIBUTE_PARSER (String &params, RenderTechniqueFactory *factory)
function for parsing RenderTechnique attributes
typedef std::map< String,
ILLUM_ATTRIBUTE_PARSER > 		AttribParserList
Keyword-mapped attribute parsers.

Protected Attributes

AttribParserList attributeParsers
map of parser functions
String | typeName
factoryname

Detailed Description

RenderTechniqueFactory to create OgreConvoledCubeMapRenderTechnique instances.

Member Typedef Documentation

typedef void(*) RenderTechniqueFactory::ILLUM_ATTRIBUTE_PARSER(String &params, RenderTechniqueFactory *factory) [protected, inherited]

function for parsing RenderTechnique attributes

Parameters:
params attribute value stored in a String

Member Function Documentation

OgreRenderTechnique * OgreConvoledCubeMapRenderTechniqueFactory::createInstance | ( | IllumTechniqueParams * | params,
 |  | Pass * | pass,
 |  | OgreRenderable * | parentRenderable,
 |  | OgreTechniqueGroup * | parentTechniqueGroup |
 | ) |  |  | [virtual]

Creates a RenderTechnique of the factory type.

Parameters:
params | containes constructor parameters as NameValuePairList
pass | the Pass to use in RenderTechnique constructor
pass | the parentRenderable to pass to RenderTechnique constructor
pass | the parentTechniqueGroup to pass to RenderTechnique constructor

Reimplemented from OgreCubeMapRenderTechniqueFactory.

bool RenderTechniqueFactory::isType ( String type ) [inline, inherited]

Returns if this factory can create a RenderTechnique of the given type.

Parameters:
type RenderTechnique type

void RenderTechniqueFactory::parseParams ( IllumTechniqueParams * params ) [virtual, inherited]

parses parameters from the material file.

The parsed parameters will be passed to the new RenderTechnique's constructor.

Parameters:
params pointer to the IllumTechniqueParams structure that was read from the material script and containes the parameters to be parsed.

Generated on Wed Mar 28 11:48:52 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: OgreConvolvedCubeMapRenderTechnique Class Reference

OgreConvolvedCubeMapRenderTechnique Class Reference

ConvolvedCubeMapRenderTechnique used in an Ogre environment. More...

Inheritance diagram for OgreConvolvedCubeMapRenderTechnique:

ConvolvedCubeMapRenderTechnique OgreCubeMapRenderTechnique CubeMapRenderTechnique CubeMapRenderTechnique OgreRenderTechnique RenderTechnique RenderTechnique RenderTechnique List of all members.

Public Member Functions

OgreConvolvedCubeMapRenderTechnique (unsigned long startFrame, unsigned long cubeMapUpdateInterval, unsigned int cubeMapResolution, unsigned int reducedCubeMapResolution, unsigned char texID, bool useDistCalc, bool useFaceAngleCalc, float distTolerance, float angleTolerance, bool updateAllFace, bool renderSelf, bool renderEnvironment, String selfMaterial, String environmentMaterial, bool getMinMax, bool attachToTexUnit, String minVariableName, String maxVariableName, Pass *pass, OgreRenderable *parentRenderable, OgreTechniqueGroup *parentTechniqueGroup)
Constructor.
~OgreConvolvedCubeMapRenderTechnique ()
Destructor.
void | update (unsigned long frameNum)
Updates the resources in the given frame.
void | runChanged (RenderingRunType runType, RenderingRun *run)
Called after one of he shared runs changes.
void | runUpdated (RenderingRunType runType, RenderingRun *run)
Called after one of he shared runs updates.
virtual class OgreRenderTechnique * | asOgreRenderTechnique ()
Conversion to OgreRenderTechnique.
ElementaryRenderable * getParentRenderable ()
Retrieves the renderable this technique operates on.
virtual OgreRenderTechnique * | asOgreRenderTechnique ()
Conversion to OgreRenderTechnique.

Protected Member Functions

void | reducedCubeMapRunChanged (RenderingRun *run)
Called if the changed run is a ReducedCubeMapRenderingRun.
void | colorCubeMapRunChanged (RenderingRun *run)
Called if the changed run is a CubeMapRenderingRun (containing colors of the environment).
RenderingRun * createReducedCubeMapRun ()
Creates a ReducedCubeMapRenderingRun.
virtual RenderingRun * | createCubeMapRun ()=0
Creates a CubeMapRenderingRun.
virtual void | cubeMapRunChanged (RenderingRun *run)=0
Called if the changed run is a CubeMapRenderingRun.
virtual void | cubeMapRunUpdated (RenderingRun *run)=0
Called if the updated run is a CubeMapRenderingRun.
RenderingRun * createCubeMapRun ()
Creates a CubeMapRenderingRun.
void | cubeMapRunChanged (RenderingRun *run)
Called if the changed run is a CubeMapRenderingRun.
void | cubeMapRunUpdated (RenderingRun *run)
Called if the updated run is a CubeMapRenderingRun.

Protected Attributes

unsigned int | reducedCubeMapResolution
The resolution of the downsampled cubemap created by this run.
bool | useDistCalc
a flag to skip cube face update if object is far away or too small.
bool | useFaceAngleCalc
a flag to skip cube face update the face is neglible.
float | distTolerance
A value used in face skip test.
float | angleTolerance
A value used in face skip test.
bool | updateAllFace
defines if all cubemap faces should be updated in a frame or only one face per frame
unsigned long | cubeMapUpdateInterval
color-cubemap update frequency
unsigned int | cubeMapResolution
color-cubemap resolution
unsigned long | startFrame
offset in frame number used during update
bool | renderSelf
Sets if the object should be rendered to the cube map.
bool | renderEnvironment
Sets if the environment should be rendered to the cube map.
int | layer
The layer of the cubemap.
RenderingRunType | cubemapLayer
The exact run type of this run (according to the actual layer).
ElementaryRenderable * parentRenderable
The renderable this technique operates on.
TechniqueGroup * parentTechniqueGroup
The TechniqueGroup this RenderedTechnique is attached to.
SharedRuns * sharedRuns
The SharedRuns this RenderedTechnique is attached to.
unsigned char | texID
the id of the texture unit state the resulting cubemap should be bound to
String | selfMaterial
the material that should be set for the object while rendering the cubemap
String | environmentMaterial
the material that should be set for the environment while rendering the cubemap
bool | getMinMax
sets if the minimum and maximum values of the cubemap should be computed
bool | attachToTexUnit
sets if this cubemap should be attach to a texture unit of the pass
String | minVariableName
sets the name of the gpu shader program parameter to which the minimum value should be bound to
String | maxVariableName
sets the name of the gpu shader program parameter to which the maximum value should be bound to
OgreRenderable * parentOgreRenderable
a OgreRenderable pointer to the renderable this technique operates on.
OgreTechniqueGroup * parentOgreTechniqueGroup
a OgreTechniqueGroup pointer to the TechniqueGroup this technique is attached to.
Pass * | pass
a pointer to the pass this technique operates on.

Detailed Description

ConvolvedCubeMapRenderTechnique used in an Ogre environment.

Constructor & Destructor Documentation

OgreConvolvedCubeMapRenderTechnique::OgreConvolvedCubeMapRenderTechnique | ( | unsigned long | startFrame,
 |  | unsigned long | cubeMapUpdateInterval,
 |  | unsigned int | cubeMapResolution,
 |  | unsigned int | reducedCubeMapResolution,
 |  | unsigned char | texID,
 |  | bool | useDistCalc,
 |  | bool | useFaceAngleCalc,
 |  | float | distTolerance,
 |  | float | angleTolerance,
 |  | bool | updateAllFace,
 |  | bool | renderSelf,
 |  | bool | renderEnvironment,
 |  | String | selfMaterial,
 |  | String | environmentMaterial,
 |  | bool | getMinMax,
 |  | bool | attachToTexUnit,
 |  | String | minVariableName,
 |  | String | maxVariableName,
 |  | Pass * | pass,
 |  | OgreRenderable * | parentRenderable,
 |  | OgreTechniqueGroup * | parentTechniqueGroup
 | ) |  |

Constructor.

Parameters:
startFrame | adds an offset to the current frame number to help evenly distribute updates between frames
cubeMapUpdateInterval | update frequency
cubeMapResolution | color cubemap resolution
reducedCubeMapResolution | reduced sized color cubemap resolution
reducedTexID | the id of the texture unit state the resulting cubemap should be bound to
useDistCalc | flag to skip cube face update if object is far away
useFaceAngleCalc | flag to skip cube face update if face is neglible
distTolerance | distance tolerance used in face skip
angleTolerance | angle tolerance used in face skip
updateAllFace | defines if all cubemap faces should be updated in a frame or only one face per frame
renderSelf | sets if the object should be rendered to the cube map
renderEnvironment | sets if the environment should be rendered to the cube map
selfMaterial | the material that should be set for the object while rendering the cubemap
environmentMaterial | the material that should be set for the environment while rendering the cubemap
getMinMax | sets if the minimum and maximum values of the cubemap should be computed
attachToTexUnit | sets if this cubemap should be attach to a texture unit of the pass
minVariableName | sets the name of the gpu shader program parameter to which the minimum value should be bound to
maxVariableName | sets the name of the gpu shader program parameter to which the maximum value should be bound to
pass | the pass to operate on
parentRenderable | the object to operate on
parentTechniqueGroup | the TechniqueGroup this RenderedTechnique is attached to

Member Function Documentation

void OgreConvolvedCubeMapRenderTechnique::update ( unsigned long frameNum ) [virtual]

Updates the resources in the given frame.

Parameters:
frameNum the actual framenumber

Reimplemented from ConvolvedCubeMapRenderTechnique.

void OgreConvolvedCubeMapRenderTechnique::reducedCubeMapRunChanged ( RenderingRun * run ) [protected, virtual]

Called if the changed run is a ReducedCubeMapRenderingRun.

Parameters:
run pointer to the changed ReducedCubeMapRenderingRun

Implements ConvolvedCubeMapRenderTechnique.

void OgreConvolvedCubeMapRenderTechnique::colorCubeMapRunChanged ( RenderingRun * run ) [protected, virtual]

Called if the changed run is a CubeMapRenderingRun (containing colors of the environment).

Parameters:
run pointer to the changed CubeMapRenderingRun

Implements ConvolvedCubeMapRenderTechnique.

RenderingRun * OgreConvolvedCubeMapRenderTechnique::createReducedCubeMapRun ( ) [protected, virtual]

Creates a ReducedCubeMapRenderingRun.

Returns:
the new ReducedCubeMapRenderingRun instance.

Implements ConvolvedCubeMapRenderTechnique.

void ConvolvedCubeMapRenderTechnique::runChanged | ( | RenderingRunType | runType,
 |  | RenderingRun * | run |
 | ) |  |  | [virtual, inherited]

Called after one of he shared runs changes.

Parameters:
runType | enum describing the type of the changed run
run | pointer to the changed RenderingRun

Reimplemented from CubeMapRenderTechnique.

void CubeMapRenderTechnique::runUpdated | ( | RenderingRunType | runType,
 |  | RenderingRun * | run |
 | ) |  |  | [virtual, inherited]

Called after one of he shared runs updates.

Parameters:
runType | enum describing the type of the updated run
run | pointer to the updated RenderingRun

Reimplemented from RenderTechnique.

Reimplemented in ColorCubeMapRenderTechnique, and DistanceCubeMapRenderTechnique.

virtual RenderingRun* CubeMapRenderTechnique::createCubeMapRun ( ) [protected, pure virtual, inherited]

Creates a CubeMapRenderingRun.

Returns:
the new CubeMapRenderingRun instance.

Implemented in OgreCubeMapRenderTechnique.

virtual void CubeMapRenderTechnique::cubeMapRunChanged ( RenderingRun * run ) [protected, pure virtual, inherited]

Called if the changed run is a CubeMapRenderingRun.

Parameters:
run pointer to the new CubeMapRenderingRun

Implemented in OgreCubeMapRenderTechnique.

virtual void CubeMapRenderTechnique::cubeMapRunUpdated ( RenderingRun * run ) [protected, pure virtual, inherited]

Called if the updated run is a CubeMapRenderingRun.

Parameters:
run pointer to the updated CubeMapRenderingRun

Implemented in OgreCubeMapRenderTechnique.

virtual class OgreRenderTechnique* RenderTechnique::asOgreRenderTechnique ( ) [inline, virtual, inherited]

Conversion to OgreRenderTechnique.

This function is needed because of virtual inheritance.

Reimplemented in OgreRenderTechnique.

RenderingRun * OgreCubeMapRenderTechnique::createCubeMapRun ( ) [protected, virtual, inherited]

Creates a CubeMapRenderingRun.

Returns:
the new CubeMapRenderingRun instance.

Implements CubeMapRenderTechnique.

void OgreCubeMapRenderTechnique::cubeMapRunChanged ( RenderingRun * run ) [protected, virtual, inherited]

Called if the changed run is a CubeMapRenderingRun.

Parameters:
run pointer to the new CubeMapRenderingRun

Implements CubeMapRenderTechnique.

void OgreCubeMapRenderTechnique::cubeMapRunUpdated ( RenderingRun * run ) [protected, virtual, inherited]

Called if the updated run is a CubeMapRenderingRun.

Parameters:
run pointer to the updated CubeMapRenderingRun

Implements CubeMapRenderTechnique.

virtual OgreRenderTechnique* OgreRenderTechnique::asOgreRenderTechnique ( ) [inline, virtual, inherited]

Conversion to OgreRenderTechnique.

This function is needed because of virtual inheritance.

Reimplemented from RenderTechnique.

Member Data Documentation

bool CubeMapRenderTechnique::useDistCalc [protected, inherited]

a flag to skip cube face update if object is far away or too small.

See also:
distTolerance

bool CubeMapRenderTechnique::useFaceAngleCalc [protected, inherited]

a flag to skip cube face update the face is neglible.

See also:
angleTolerance

float CubeMapRenderTechnique::distTolerance [protected, inherited]

A value used in face skip test.

The higher this value gets the more precise, but slower the method will be.

float CubeMapRenderTechnique::angleTolerance [protected, inherited]

A value used in face skip test.

The higher this value gets the more precise, but slower the method will be.

int CubeMapRenderTechnique::layer [protected, inherited]

The layer of the cubemap.

This extension was created to achieve effect such as multiple reflections and refractions that require more complete sampling of the scene. With this extension we can render the environment into several cubemap layers eg. with depth peeling.

Generated on Wed Mar 28 11:48:52 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: OgreCubeMapRenderingRun Class Reference

OgreCubeMapRenderingRun Class Reference

CubeMapRenderingRun used in an OGRE environment. More...

Inheritance diagram for OgreCubeMapRenderingRun:

OgreRenderingRun CubeMapRenderingRun RenderingRun RenderingRun RenderingRun List of all members.

Public Member Functions

OgreCubeMapRenderingRun (OgreSharedRuns *sharedRuns, String name, unsigned long startFrame, unsigned long updateInterval, unsigned int resolution, bool useDistCalc, bool useFaceAngleCalc, float distTolerance, float angleTolerance, bool updateAllFace, bool renderSelf, bool renderEnvironment, String selfMaterial, String environmentMaterial, bool getMinMax, RenderingRunType cubemapRunType)
Constructor.
String | getCubeMapTextureName ()
returns the name of the resulting color cubemap texture
OgreRenderingRun * asOgreRenderingRun ()
Conversion to OgreRenderRun.
OgreRenderingRun * asOgreRenderingRun ()
Conversion to OgreRenderRun.
bool | update (unsigned long frameNum)
Calls updateFrame() if the run needs update according to its starting frame and update interval and has not been allready updated in this frame.
virtual bool | canJoin (RenderingRun *run)
Returns true if two runs can be joined.

Protected Member Functions

void | createCubeMap ()
Creates a cubemap texture used for the color-cubemap.
void | updateCubeFace (int facenum)
Updates one face of the cubemap.
bool | faceNeedsUpdate (int facenum)
Checks if a cubemap face needs to be updated.
Vector3 | getCubeMapFaceDirection (unsigned char faceId)
Returns a direction for a cubemap face id.
Vector3 | getCubeMapFaceDirection (unsigned char faceId)
Returns a direction for a cubemap face id.
Texture * | createCubeRenderTexture (String name, const Vector3 position, unsigned int resolution=512, PixelFormat format=PF_FLOAT16_RGBA, int numMips=0, ColourValue clearColor=ColourValue::Black)
Creates a cubemap texture.
Texture * | createCubeRenderTexture (String name, const Vector3 position, unsigned int resolution=512, PixelFormat format=PF_FLOAT16_RGBA, int numMips=0, ColourValue clearColor=ColourValue::Black)
Creates a cubemap texture.
void | setMaterialForRenderables (String &materialName, RenderQueue *rq)
Sets the given material for each Renderable in a RenderQueue.
void | setMaterialForRenderables (String &materialName, RenderQueue *rq, bool solidsonly=false)
Sets the given material for each Renderable in a RenderQueue.
void | setMaterialForVisibles (String &materialName, Camera *cam, bool shadowcastersonly=false)
Sets the given material for each Renderable visible from a given camera.
void | setMaterialForVisibles (String &materialName, Camera *cam, bool shadowcastersonly=false, bool solidsonly=false)
Sets the given material for each Renderable visible from a given camera.
void | restoreMaterials ()
Restores previously stored materials.
void | restoreMaterials ()
Restores previously stored materials.
void | renderFullscreenQuad (String materialName, RenderTarget *target)
Renderes a full screen quad on a given RendderTarget with a given material.
void | renderFullscreenQuad (String materialName, RenderTarget *target)
Renderes a full screen quad on a given RendderTarget with a given material.
void | renderPixelSprites (String &materialName, RenderTarget *rt, int width, int height)
Renderes sprites to pixels of the screen on a given RendderTarget with a given material.
void | renderPixelSprites (String &materialName, RenderTarget *rt, int width, int height)
Renderes sprites to pixels of the screen on a given RendderTarget with a given material.
void | renderFullscreenGrid (String &materialName, RenderTarget *rt, int width, int height)
Renders a grid onto the screen.
virtual bool | needUpdate (unsigned long frameNum)
Returns if this run needs update.
virtual void | updateFrame (unsigned long frameNum)
This function does the actual update in a frame.
virtual void | updateFrame (unsigned long frameNum)
This function does the actual update in a frame.

Protected Attributes

OgreSharedRuns * sharedRuns
A pointer to the OgreSharedRuns this run belongs to.
String | name
The name of the cubemap texture that was created by this run.
Texture * | cubemapTexture
A pointer to the cubemap texture that was created by this run.
std::map< Renderable *, String > | visibleObjects
map of Renderables which will be rendered with a given material
std::map< Renderable *, String > | visibleObjects
map of Renderables which will be rendered with a given material
SpriteSet * | pixelSprites
SpriteSet used in pixel sprite rendering.
BillboardSet * | pixelSprites
SpriteSet used in pixel sprite rendering.
String | spriteSetName
unique name of the SpriteSet used in pixel sprite rendering
Entity * | fullscreenGrid
Entity used in fullscreen grid rendering.
unsigned long | lastupdated
The number of the last frame this run was updated.
unsigned long | startFrame
The number of the frame this run should be updated first.
unsigned long | updateInterval
Refresh frequency in frames.
bool | updateAllFace
defines if all cubemap faces should be updated in a frame or only one face per frame
unsigned char | currentFace
the number of the face to be updated
unsigned int | resolution
the resolution of the cubemap texture that was created by this run
bool | useDistCalc
a flag to skip cube face update if object is far away or too small.
bool | useFaceAngleCalc
a flag to skip cube face update the face is neglible.
float | distTolerance
A value used in face skip test.
float | angleTolerance
A value used in face skip test.
bool | renderSelf
sets if the object should be rendered to the cube map
bool | renderEnvironment
sets if the environment should be rendered to the cube map

Static Protected Attributes

static MovablePlane * | fullScreenQuad
fulls screen quad plane used in full screen quad rendering
static MovablePlane * | fullScreenQuad
fulls screen quad plane used in full screen quad rendering
static Entity * | fullScreenQuadEntity
fulls screen quad Entity used in full screen quad rendering
static Entity * | fullScreenQuadEntity
fulls screen quad Entity used in full screen quad rendering
static SceneNode * | fullScreenQuadNode
fulls screen quad SceneNode used in full screen quad rendering
static SceneNode * | fullScreenQuadNode
fulls screen quad SceneNode used in full screen quad rendering

Detailed Description

CubeMapRenderingRun used in an OGRE environment.

Constructor & Destructor Documentation

OgreCubeMapRenderingRun::OgreCubeMapRenderingRun | ( | OgreSharedRuns * | sharedRuns,
 |  | String | name,
 |  | unsigned long | startFrame,
 |  | unsigned long | updateInterval,
 |  | unsigned int | resolution,
 |  | bool | useDistCalc,
 |  | bool | useFaceAngleCalc,
 |  | float | distTolerance,
 |  | float | angleTolerance,
 |  | bool | updateAllFace,
 |  | bool | renderSelf,
 |  | bool | renderEnvironment,
 |  | String | selfMaterial,
 |  | String | environmentMaterial,
 |  | bool | getMinMax,
 |  | RenderingRunType | cubemapRunType
 | ) |  |

Constructor.

Parameters:
sharedRuns | a pointer to the OgreSharedRuns this run belongs to
name | the name of the cubemap texture to be created
startFrame | adds an offset to the current frame number to help evenly distribute updates between frames
updateInterval | update frequency
resolution | cubemap resolution
useDistCalc | flag to skip cube face update if object is far away
useFaceAngleCalc | flag to skip cube face update if face is neglible
distTolerance | distance tolerance used in face skip
angleTolerance | angle tolerance used in face skip
updateAllFace | defines if all cubemap faces should be updated in a frame or only one face per frame
renderSelf | sets if the object should be rendered to the cube map
renderEnvironment | sets if the environment should be rendered to the cube map
selfMaterial | the material that should be set for the object while rendering the cubemap
environmentMaterial | the material that should be set for the environment while rendering the cubemap
getMinMax | sets if the minimum and maximum values of the cubemap should be computed

Member Function Documentation

void OgreCubeMapRenderingRun::updateCubeFace ( int facenum ) [inline, protected, virtual]

Updates one face of the cubemap.

Parameters:
facenum the number of the face to be updated

Implements CubeMapRenderingRun.

bool OgreCubeMapRenderingRun::faceNeedsUpdate ( int facenum ) [protected, virtual]

Checks if a cubemap face needs to be updated.

If the object we are updating the cubemap for is far from the camera, or too small, or the given cubemapface does not have significant effect on the rendering the face can be skipped.

Parameters:
facenum the number of the face to be checked

Implements CubeMapRenderingRun.

OgreRenderingRun* OgreRenderingRun::asOgreRenderingRun ( ) [inline, virtual, inherited]

Conversion to OgreRenderRun.

This function is needed because of virtual inheritance.

Reimplemented from RenderingRun.

OgreRenderingRun* OgreRenderingRun::asOgreRenderingRun ( ) [inline, virtual, inherited]

Conversion to OgreRenderRun.

This function is needed because of virtual inheritance.

Reimplemented from RenderingRun.

Vector3 OgreRenderingRun::getCubeMapFaceDirection ( unsigned char faceId ) [protected, inherited]

Returns a direction for a cubemap face id.

This is a helper function to retrieve the normal direction of a given cubemap face.

Parameters:
faceId the number of the face

Vector3 OgreRenderingRun::getCubeMapFaceDirection ( unsigned char faceId ) [protected, inherited]

Returns a direction for a cubemap face id.

This is a helper function to retrieve the normal direction of a given cubemap face.

Parameters:
faceId the number of the face

Texture * OgreRenderingRun::createCubeRenderTexture | ( | String | name,
 |  | const Vector3 | position,
 |  | unsigned int | resolution = 512,
 |  | PixelFormat | format = PF_FLOAT16_RGBA,
 |  | int | numMips = 0,
 |  | ColourValue | clearColor = ColourValue::Black |
 | ) |  |  | [protected, inherited]

Creates a cubemap texture.

This is a helper function to easily create a cubemap texture and automaticly attach viewports to each face so it can be used as a rendertarget.

Parameters:
name | the name of the texture to be created
position | the initial position of the cubemap
resolution | the resolution of one cubemapface
format | the pixel format of the cubemap
numMips | the number of mipmap levels
clearColor | initial color

Texture* OgreRenderingRun::createCubeRenderTexture | ( | String | name,
 |  | const Vector3 | position,
 |  | unsigned int | resolution = 512,
 |  | PixelFormat | format = PF_FLOAT16_RGBA,
 |  | int | numMips = 0,
 |  | ColourValue | clearColor = ColourValue::Black |
 | ) |  |  | [protected, inherited]

Creates a cubemap texture.

This is a helper function to easily create a cubemap texture and automaticly attach viewports to each face so it can be used as a rendertarget.

Parameters:
name | the name of the texture to be created
position | the initial position of the cubemap
resolution | the resolution of one cubemapface
format | the pixel format of the cubemap
numMips | the number of mipmap levels
clearColor | initial color

void OgreRenderingRun::setMaterialForRenderables | ( | String & | materialName,
 |  | RenderQueue * | rq |
 | ) |  |  | [protected, inherited]

Sets the given material for each Renderable in a RenderQueue.

This is a helper function to set a material to each element of a previously filled Renderque. The orginal material of the Renderables are stored so they can be restored later. The function also tells the current SceneManager not to search for visible objects, as we are going to use the given RenderQueue during the next rendering.

Parameters:
materialName | the name of the material to set for the Renderables
rq | pointer to the filled Renderqueue instance to set material for

void OgreRenderingRun::setMaterialForRenderables | ( | String & | materialName,
 |  | RenderQueue * | rq,
 |  | bool | solidsonly = false |
 | ) |  |  | [protected, inherited]

Sets the given material for each Renderable in a RenderQueue.

This is a helper function to set a material to each element of a previously filled Renderque. The orginal material of the Renderables are stored so they can be restored later. The function also tells the current SceneManager not to search for visible objects, as we are going to use the given RenderQueue during the next rendering.

Parameters:
materialName | the name of the material to set for the Renderables
rq | pointer to the filled Renderqueue instance to set material for

void OgreRenderingRun::setMaterialForVisibles | ( | String & | materialName,
 |  | Camera * | cam,
 |  | bool | shadowcastersonly = false |
 | ) |  |  | [protected, inherited]

Sets the given material for each Renderable visible from a given camera.

This helper function is similar to setMaterialForRenderables but it is also responsible for filling the RenderQueue. First the RenderQueue of the current SceneManager fill be filled with the visible objects seen from the given camera. Then the required material will be set for each element of the RenderQueue. The orginal material of the Renderables are stored so they can be restored later. The function also tells the current SceneManager not to search for visible objects, as we are going to use the filled RenderQueue during the next rendering.

Parameters:
materialName | the name of the material to set for the Renderables
cam | pointer to the camera from which visible objects should be searched
shadowcastersonly | flag to search for only shadow casters

void OgreRenderingRun::setMaterialForVisibles | ( | String & | materialName,
 |  | Camera * | cam,
 |  | bool | shadowcastersonly = false,
 |  | bool | solidsonly = false |
 | ) |  |  | [protected, inherited]

Sets the given material for each Renderable visible from a given camera.

This helper function is similar to setMaterialForRenderables but it is also responsible for filling the RenderQueue. First the RenderQueue of the current SceneManager fill be filled with the visible objects seen from the given camera. Then the required material will be set for each element of the RenderQueue. The orginal material of the Renderables are stored so they can be restored later. The function also tells the current SceneManager not to search for visible objects, as we are going to use the filled RenderQueue during the next rendering.

Parameters:
materialName | the name of the material to set for the Renderables
cam | pointer to the camera from which visible objects should be searched
shadowcastersonly | flag to search for only shadow casters

void OgreRenderingRun::restoreMaterials ( ) [protected, inherited]

Restores previously stored materials.

This helper function is typically used after a setMaterialForRenderables or setMaterialForVisibles call and a rendering process to restore the original material settings. The function also tells the current SceneManager to search for visible objects, as this is the default behaviour of SceneManager.

void OgreRenderingRun::restoreMaterials ( ) [protected, inherited]

Restores previously stored materials.

This helper function is typically used after a setMaterialForRenderables or setMaterialForVisibles call and a rendering process to restore the original material settings. The function also tells the current SceneManager to search for visible objects, as this is the default behaviour of SceneManager.

void OgreRenderingRun::renderFullscreenQuad | ( | String | materialName,
 |  | RenderTarget * | target |
 | ) |  |  | [protected, inherited]

Renderes a full screen quad on a given RendderTarget with a given material.

Parameters:
materialName | the name of the material bind to the quad
target | the RenderTarget the quad should be rendered on

void OgreRenderingRun::renderFullscreenQuad | ( | String | materialName,
 |  | RenderTarget * | target |
 | ) |  |  | [protected, inherited]

Renderes a full screen quad on a given RendderTarget with a given material.

Parameters:
materialName | the name of the material bind to the quad
target | the RenderTarget the quad should be rendered on

void OgreRenderingRun::renderPixelSprites | ( | String & | materialName,
 |  | RenderTarget * | rt,
 |  | int | width,
 |  | int | height |
 | ) |  |  | [protected, inherited]

Renderes sprites to pixels of the screen on a given RendderTarget with a given material.

Pixel sprites are pixel sized quads, placed on each pixel of the RenderTarget. The number of sprites not necessary corresponds to the resolution of the rendertarget. The pixel quads will evenly fill the rendertarget's area with sizes corresponding to the given resolution. We can render fewer or more pixel quads than the number of pixels the rendertarget has (eg.: in case of caustic cubemap generation).

Parameters:
materialName | the name of the material bind to the pixel sprites
rt | the RenderTarget the quads should be rendered on
width | the desired resolution width of the sprites
height | the desired resolution height of the sprites

void OgreRenderingRun::renderPixelSprites | ( | String & | materialName,
 |  | RenderTarget * | rt,
 |  | int | width,
 |  | int | height |
 | ) |  |  | [protected, inherited]

Renderes sprites to pixels of the screen on a given RendderTarget with a given material.

Pixel sprites are pixel sized quads, placed on each pixel of the RenderTarget. The number of sprites not necessary corresponds to the resolution of the rendertarget. The pixel quads will evenly fill the rendertarget's area with sizes corresponding to the given resolution. We can render fewer or more pixel quads than the number of pixels the rendertarget has (eg.: in case of caustic cubemap generation).

Parameters:
materialName | the name of the material bind to the pixel sprites
rt | the RenderTarget the quads should be rendered on
width | the desired resolution width of the sprites
height | the desired resolution height of the sprites

void OgreRenderingRun::renderFullscreenGrid | ( | String & | materialName,
 |  | RenderTarget * | rt,
 |  | int | width,
 |  | int | height |
 | ) |  |  | [protected, inherited]

Renders a grid onto the screen.

Parameters:
rt | the RenderTarget the grid should be rendered on
width | the desired horizontal resolution of the grid
height | the desired vertical resolution of the grid

virtual bool RenderingRun::canJoin ( RenderingRun * run ) [inline, virtual, inherited]

Returns true if two runs can be joined.

In some cases special requirements should stand to join two runs (even if they have the same type). Eg.: two caustic cube map generation technique should only be joined if they use the same material when rendering the caustic cubemap.

Reimplemented in OgreCausticCubeMapRenderingRun, OgreChildPSystemRenderingRun, and OgrePhotonMapRenderingRun.

virtual bool RenderingRun::needUpdate ( unsigned long frameNum ) [inline, protected, virtual, inherited]

Returns if this run needs update.

This tipically depends on the upate interval and the starting frame number.

Parameters:
frameNum current frame number

Reimplemented in OgreFocusingMapRenderingRun, and OgrePMEntryPointMapRenderingRun.

virtual void RenderingRun::updateFrame ( unsigned long frameNum ) [inline, protected, virtual, inherited]

This function does the actual update in a frame.

Parameters:
frameNum current frame number

Reimplemented in CausticCubeMapRenderingRun, ChildPsystemRenderingRun, CubeMapRenderingRun, DepthShadowMapRenderingRun, LightVolumeRenderingRun, PhaseTextureRenderingRun, PhotonMapRenderingRun, ReducedCubeMapRenderingRun, SceneCameraDepthRenderingRun, OgreChildPSystemRenderingRun, OgreDepthShadowMapRenderingRun, OgreFocusingMapRenderingRun, OgreLightVolumeRenderingRun, OgrePhaseTextureRenderingRun, OgrePhotonMapRenderingRun, OgrePMEntryPointMapRenderingRun, OgrePMWeightComputeRenderingRun, and OgreSceneCameraDepthRenderingRun.

void CubeMapRenderingRun::updateFrame ( unsigned long frameNum ) [protected, virtual, inherited]

This function does the actual update in a frame.

Parameters:
frameNum current frame number

Reimplemented from RenderingRun.

Member Data Documentation

std::map<Renderable*, String> OgreRenderingRun::visibleObjects [protected, inherited]

map of Renderables which will be rendered with a given material

The String stores the original material name that will be restored after rendering.

See also:
setMaterialForVisibles

setMaterialForRenderables

restoreMaterials

std::map<Renderable*, String> OgreRenderingRun::visibleObjects [protected, inherited]

map of Renderables which will be rendered with a given material

The String stores the original material name that will be restored after rendering.

See also:
setMaterialForVisibles

setMaterialForRenderables

restoreMaterials

MovablePlane * OgreRenderingRun::fullScreenQuad [static, protected, inherited]

fulls screen quad plane used in full screen quad rendering

See also:
renderFullscreenQuad

MovablePlane* OgreRenderingRun::fullScreenQuad [static, protected, inherited]

fulls screen quad plane used in full screen quad rendering

See also:
renderFullscreenQuad

Entity * OgreRenderingRun::fullScreenQuadEntity [static, protected, inherited]

fulls screen quad Entity used in full screen quad rendering

See also:
renderFullscreenQuad

Entity* OgreRenderingRun::fullScreenQuadEntity [static, protected, inherited]

fulls screen quad Entity used in full screen quad rendering

See also:
renderFullscreenQuad

SceneNode * OgreRenderingRun::fullScreenQuadNode [static, protected, inherited]

fulls screen quad SceneNode used in full screen quad rendering

See also:
renderFullscreenQuad

SceneNode* OgreRenderingRun::fullScreenQuadNode [static, protected, inherited]

fulls screen quad SceneNode used in full screen quad rendering

See also:
renderFullscreenQuad

SpriteSet* OgreRenderingRun::pixelSprites [protected, inherited]

SpriteSet used in pixel sprite rendering.

See also:
renderPixelSprites

BillboardSet* OgreRenderingRun::pixelSprites [protected, inherited]

SpriteSet used in pixel sprite rendering.

See also:
renderPixelSprites

String OgreRenderingRun::spriteSetName [protected, inherited]

unique name of the SpriteSet used in pixel sprite rendering

See also:
renderPixelSprites

Entity* OgreRenderingRun::fullscreenGrid [protected, inherited]

Entity used in fullscreen grid rendering.

See also:
renderPixelGrid

bool CubeMapRenderingRun::useDistCalc [protected, inherited]

a flag to skip cube face update if object is far away or too small.

See also:
distTolerance

bool CubeMapRenderingRun::useFaceAngleCalc [protected, inherited]

a flag to skip cube face update the face is neglible.

See also:
angleTolerance

float CubeMapRenderingRun::distTolerance [protected, inherited]

A value used in face skip test.

The higher this value gets the more precise, but slower the method will be.

float CubeMapRenderingRun::angleTolerance [protected, inherited]

A value used in face skip test.

The higher this value gets the more precise, but slower the method will be.

Generated on Wed Mar 28 11:48:53 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: OgreCubeMapRenderTechnique Class Reference

OgreCubeMapRenderTechnique Class Reference

CubeMapRenderTechnique used in an Ogre environment. More...

Inheritance diagram for OgreCubeMapRenderTechnique:

CubeMapRenderTechnique OgreRenderTechnique RenderTechnique RenderTechnique OgreColorCubeMapRenderTechnique OgreConvolvedCubeMapRenderTechnique OgreDistanceCubeMapRenderTechnique List of all members.

Public Member Functions

OgreCubeMapRenderTechnique (unsigned long startFrame, unsigned long cubeMapUpdateInterval, unsigned int cubeMapResolution, unsigned char texID, bool useDistCalc, bool useFaceAngleCalc, float distTolerance, float angleTolerance, bool updateAllFace, bool renderSelf, bool renderEnvironment, String selfMaterial, String environmentMaterial, int layer, bool getMinMax, bool attachToTexUnit, String minVariableName, String maxVariableName, Pass *pass, OgreRenderable *parentRenderable, OgreTechniqueGroup *parentTechniqueGroup, bool createCubeRun=false)
Constructor.
~OgreCubeMapRenderTechnique ()
Destructor.
void | runChanged (RenderingRunType runType, RenderingRun *run)
Called after one of he shared runs changes.
void | runUpdated (RenderingRunType runType, RenderingRun *run)
Called after one of he shared runs updates.
virtual void | update (unsigned long frameNum)
Updates the resources in the given frame.
virtual class OgreRenderTechnique * | asOgreRenderTechnique ()
Conversion to OgreRenderTechnique.
ElementaryRenderable * getParentRenderable ()
Retrieves the renderable this technique operates on.
virtual OgreRenderTechnique * | asOgreRenderTechnique ()
Conversion to OgreRenderTechnique.

Protected Member Functions

RenderingRun * createCubeMapRun ()
Creates a CubeMapRenderingRun.
void | cubeMapRunChanged (RenderingRun *run)
Called if the changed run is a CubeMapRenderingRun.
void | cubeMapRunUpdated (RenderingRun *run)
Called if the updated run is a CubeMapRenderingRun.

Protected Attributes

unsigned char | texID
the id of the texture unit state the resulting cubemap should be bound to
String | selfMaterial
the material that should be set for the object while rendering the cubemap
String | environmentMaterial
the material that should be set for the environment while rendering the cubemap
bool | getMinMax
sets if the minimum and maximum values of the cubemap should be computed
bool | attachToTexUnit
sets if this cubemap should be attach to a texture unit of the pass
String | minVariableName
sets the name of the gpu shader program parameter to which the minimum value should be bound to
String | maxVariableName
sets the name of the gpu shader program parameter to which the maximum value should be bound to
bool | useDistCalc
a flag to skip cube face update if object is far away or too small.
bool | useFaceAngleCalc
a flag to skip cube face update the face is neglible.
float | distTolerance
A value used in face skip test.
float | angleTolerance
A value used in face skip test.
bool | updateAllFace
defines if all cubemap faces should be updated in a frame or only one face per frame
unsigned long | cubeMapUpdateInterval
color-cubemap update frequency
unsigned int | cubeMapResolution
color-cubemap resolution
unsigned long | startFrame
offset in frame number used during update
bool | renderSelf
Sets if the object should be rendered to the cube map.
bool | renderEnvironment
Sets if the environment should be rendered to the cube map.
int | layer
The layer of the cubemap.
RenderingRunType | cubemapLayer
The exact run type of this run (according to the actual layer).
ElementaryRenderable * parentRenderable
The renderable this technique operates on.
TechniqueGroup * parentTechniqueGroup
The TechniqueGroup this RenderedTechnique is attached to.
SharedRuns * sharedRuns
The SharedRuns this RenderedTechnique is attached to.
OgreRenderable * parentOgreRenderable
a OgreRenderable pointer to the renderable this technique operates on.
OgreTechniqueGroup * parentOgreTechniqueGroup
a OgreTechniqueGroup pointer to the TechniqueGroup this technique is attached to.
Pass * | pass
a pointer to the pass this technique operates on.

Detailed Description

CubeMapRenderTechnique used in an Ogre environment.

Constructor & Destructor Documentation

OgreCubeMapRenderTechnique::OgreCubeMapRenderTechnique | ( | unsigned long | startFrame,
 |  | unsigned long | cubeMapUpdateInterval,
 |  | unsigned int | cubeMapResolution,
 |  | unsigned char | texID,
 |  | bool | useDistCalc,
 |  | bool | useFaceAngleCalc,
 |  | float | distTolerance,
 |  | float | angleTolerance,
 |  | bool | updateAllFace,
 |  | bool | renderSelf,
 |  | bool | renderEnvironment,
 |  | String | selfMaterial,
 |  | String | environmentMaterial,
 |  | int | layer,
 |  | bool | getMinMax,
 |  | bool | attachToTexUnit,
 |  | String | minVariableName,
 |  | String | maxVariableName,
 |  | Pass * | pass,
 |  | OgreRenderable * | parentRenderable,
 |  | OgreTechniqueGroup * | parentTechniqueGroup,
 |  | bool | createCubeRun = false
 | ) |  |

Constructor.

Parameters:
startFrame | adds an offset to the current frame number to help evenly distribute updates between frames
cubeMapUpdateInterval | update frequency
cubeMapResolution | color cubemap resolution
texID | the id of the texture unit state the resulting cubemap should be bound to
useDistCalc | flag to skip cube face update if object is far away
useFaceAngleCalc | flag to skip cube face update if face is neglible
distTolerance | distance tolerance used in face skip
angleTolerance | angle tolerance used in face skip
updateAllFace | defines if all cubemap faces should be updated in a frame or only one face per frame
renderSelf | sets if the object should be rendered to the cube map
renderEnvironment | sets if the environment should be rendered to the cube map
selfMaterial | the material that should be set for the object while rendering the cubemap
environmentMaterial | the material that should be set for the environment while rendering the cubemap
layer | the layer of this cubemap
getMinMax | sets if the minimum and maximum values of the cubemap should be computed
attachToTexUnit | sets if this cubemap should be attach to a texture unit of the pass
minVariableName | sets the name of the gpu shader program parameter to which the minimum value should be bound to
maxVariableName | sets the name of the gpu shader program parameter to which the maximum value should be bound to
pass | the pass to operate on
parentRenderable | the object to operate on
parentTechniqueGroup | the TechniqueGroup this RenderedTechnique is attached to

Member Function Documentation

RenderingRun * OgreCubeMapRenderTechnique::createCubeMapRun ( ) [protected, virtual]

Creates a CubeMapRenderingRun.

Returns:
the new CubeMapRenderingRun instance.

Implements CubeMapRenderTechnique.

void OgreCubeMapRenderTechnique::cubeMapRunChanged ( RenderingRun * run ) [protected, virtual]

Called if the changed run is a CubeMapRenderingRun.

Parameters:
run pointer to the new CubeMapRenderingRun

Implements CubeMapRenderTechnique.

void OgreCubeMapRenderTechnique::cubeMapRunUpdated ( RenderingRun * run ) [protected, virtual]

Called if the updated run is a CubeMapRenderingRun.

Parameters:
run pointer to the updated CubeMapRenderingRun

Implements CubeMapRenderTechnique.

void CubeMapRenderTechnique::runChanged | ( | RenderingRunType | runType,
 |  | RenderingRun * | run |
 | ) |  |  | [virtual, inherited]

Called after one of he shared runs changes.

Parameters:
runType | enum describing the type of the changed run
run | pointer to the changed RenderingRun

Reimplemented from RenderTechnique.

Reimplemented in ColorCubeMapRenderTechnique, ConvolvedCubeMapRenderTechnique, and DistanceCubeMapRenderTechnique.

void CubeMapRenderTechnique::runUpdated | ( | RenderingRunType | runType,
 |  | RenderingRun * | run |
 | ) |  |  | [virtual, inherited]

Called after one of he shared runs updates.

Parameters:
runType | enum describing the type of the updated run
run | pointer to the updated RenderingRun

Reimplemented from RenderTechnique.

Reimplemented in ColorCubeMapRenderTechnique, and DistanceCubeMapRenderTechnique.

virtual void RenderTechnique::update ( unsigned long frameNum ) [inline, virtual, inherited]

Updates the resources in the given frame.

A RenderTechnique is usually need some resources from several runs, so these runs will be updated.

Parameters:
frameNum the actual framenumber

Reimplemented in ColorCubeMapRenderTechnique, ConvolvedCubeMapRenderTechnique, DistanceCubeMapRenderTechnique, HierarchicalParticleSystemTechnique, IllumVolumeRenderTechnique, OgreCausticReceiverRenderTechnique, OgreColorCubeMapRenderTechnique, OgreConvolvedCubeMapRenderTechnique, OgreDepthShadowReceiverRenderTechnique, OgreDistanceCubeMapRenderTechnique, OgreFireRenderTechnique, OgrePathMapRenderTechnique, and OgreSBBRenderTechnique.

virtual class OgreRenderTechnique* RenderTechnique::asOgreRenderTechnique ( ) [inline, virtual, inherited]

Conversion to OgreRenderTechnique.

This function is needed because of virtual inheritance.

Reimplemented in OgreRenderTechnique.

virtual OgreRenderTechnique* OgreRenderTechnique::asOgreRenderTechnique ( ) [inline, virtual, inherited]

Conversion to OgreRenderTechnique.

This function is needed because of virtual inheritance.

Reimplemented from RenderTechnique.

Member Data Documentation

bool CubeMapRenderTechnique::useDistCalc [protected, inherited]

a flag to skip cube face update if object is far away or too small.

See also:
distTolerance

bool CubeMapRenderTechnique::useFaceAngleCalc [protected, inherited]

a flag to skip cube face update the face is neglible.

See also:
angleTolerance

float CubeMapRenderTechnique::distTolerance [protected, inherited]

A value used in face skip test.

The higher this value gets the more precise, but slower the method will be.

float CubeMapRenderTechnique::angleTolerance [protected, inherited]

A value used in face skip test.

The higher this value gets the more precise, but slower the method will be.

int CubeMapRenderTechnique::layer [protected, inherited]

The layer of the cubemap.

This extension was created to achieve effect such as multiple reflections and refractions that require more complete sampling of the scene. With this extension we can render the environment into several cubemap layers eg. with depth peeling.

Generated on Wed Mar 28 11:48:53 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: OgreCubeMapRenderTechniqueFactory Class Reference

OgreCubeMapRenderTechniqueFactory Class Reference

RenderTechniqueFactory to create OgreCubeMapRenderTechnique instances. More...

Inheritance diagram for OgreCubeMapRenderTechniqueFactory:

RenderTechniqueFactory OgreColorCubeMapRenderTechniqueFactory OgreConvoledCubeMapRenderTechniqueFactory OgreDistanceCubeMapRenderTechniqueFactory List of all members.

Public Member Functions

OgreCubeMapRenderTechniqueFactory ()
Technique factory.
OgreRenderTechnique * | createInstance (IllumTechniqueParams *params, Pass *pass, OgreRenderable *parentRenderable, OgreTechniqueGroup *parentTechniqueGroup)
Creates a RenderTechnique of the factory type.
bool | isType (String type)
Returns if this factory can create a RenderTechnique of the given type.
virtual void | parseParams (IllumTechniqueParams *params)
parses parameters from the material file.

Protected Types

typedef void(*) | ILLUM_ATTRIBUTE_PARSER (String &params, RenderTechniqueFactory *factory)
function for parsing RenderTechnique attributes
typedef std::map< String,
ILLUM_ATTRIBUTE_PARSER > 		AttribParserList
Keyword-mapped attribute parsers.

Protected Attributes

AttribParserList attributeParsers
map of parser functions
String | typeName
factoryname

Detailed Description

RenderTechniqueFactory to create OgreCubeMapRenderTechnique instances.

Member Typedef Documentation

typedef void(*) RenderTechniqueFactory::ILLUM_ATTRIBUTE_PARSER(String &params, RenderTechniqueFactory *factory) [protected, inherited]

function for parsing RenderTechnique attributes

Parameters:
params attribute value stored in a String

Member Function Documentation

OgreRenderTechnique * OgreCubeMapRenderTechniqueFactory::createInstance | ( | IllumTechniqueParams * | params,
 |  | Pass * | pass,
 |  | OgreRenderable * | parentRenderable,
 |  | OgreTechniqueGroup * | parentTechniqueGroup |
 | ) |  |  | [virtual]

Creates a RenderTechnique of the factory type.

Parameters:
params | containes constructor parameters as NameValuePairList
pass | the Pass to use in RenderTechnique constructor
pass | the parentRenderable to pass to RenderTechnique constructor
pass | the parentTechniqueGroup to pass to RenderTechnique constructor

Implements RenderTechniqueFactory.

Reimplemented in OgreColorCubeMapRenderTechniqueFactory, OgreConvoledCubeMapRenderTechniqueFactory, and OgreDistanceCubeMapRenderTechniqueFactory.

bool RenderTechniqueFactory::isType ( String type ) [inline, inherited]

Returns if this factory can create a RenderTechnique of the given type.

Parameters:
type RenderTechnique type

void RenderTechniqueFactory::parseParams ( IllumTechniqueParams * params ) [virtual, inherited]

parses parameters from the material file.

The parsed parameters will be passed to the new RenderTechnique's constructor.

Parameters:
params pointer to the IllumTechniqueParams structure that was read from the material script and containes the parameters to be parsed.

Generated on Wed Mar 28 11:48:53 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: OgreDepthShadowMapRenderingRun Class Reference

OgreDepthShadowMapRenderingRun Class Reference

DepthShadowMapRenderingRun used in an OGRE environment. More...

Inheritance diagram for OgreDepthShadowMapRenderingRun:

OgreRenderingRun DepthShadowMapRenderingRun RenderingRun RenderingRun RenderingRun List of all members.

Public Member Functions

OgreDepthShadowMapRenderingRun (OgreSharedRuns *sharedRuns, String name, Light *light, unsigned int resolutionX, unsigned int resolutionY, String materialName)
Constructor.
const String & | getDepthMapTextureName ()
returns the depth shadow map texture created by this run
void | refreshLight (unsigned long frameNum)
Refreshes light camera matrices, called in each update.
Matrix4 | getLightViewMatrix ()
Retuns the view matrix of the camera from which the depth shadow map was created.
Matrix4 | getLightViewProjMatrix ()
Retuns the concatenation of the view and projection matrices of the camera from which the depth shadow map was created.
Real | getLightFarPlane ()
Retuns the far plane of the light projection.
OgreRenderingRun * asOgreRenderingRun ()
Conversion to OgreRenderRun.
OgreRenderingRun * asOgreRenderingRun ()
Conversion to OgreRenderRun.
bool | update (unsigned long frameNum)
Calls updateFrame() if the run needs update according to its starting frame and update interval and has not been allready updated in this frame.
virtual bool | canJoin (RenderingRun *run)
Returns true if two runs can be joined.

Protected Member Functions

void | updateFrame (unsigned long frameNum)
This function does the actual update in a frame.
void | createDepthMap ()
Creates the depth map texture (2D or CUBE according to light type).
void | updateDepthCubeFace (int facenum)
Updates one face of the depth cubemap (used only in case of point lights).
void | updateDepthMap ()
Updates the depth map (in case of directional and spot lights).
Vector3 | getCubeMapFaceDirection (unsigned char faceId)
Returns a direction for a cubemap face id.
Vector3 | getCubeMapFaceDirection (unsigned char faceId)
Returns a direction for a cubemap face id.
Texture * | createCubeRenderTexture (String name, const Vector3 position, unsigned int resolution=512, PixelFormat format=PF_FLOAT16_RGBA, int numMips=0, ColourValue clearColor=ColourValue::Black)
Creates a cubemap texture.
Texture * | createCubeRenderTexture (String name, const Vector3 position, unsigned int resolution=512, PixelFormat format=PF_FLOAT16_RGBA, int numMips=0, ColourValue clearColor=ColourValue::Black)
Creates a cubemap texture.
void | setMaterialForRenderables (String &materialName, RenderQueue *rq)
Sets the given material for each Renderable in a RenderQueue.
void | setMaterialForRenderables (String &materialName, RenderQueue *rq, bool solidsonly=false)
Sets the given material for each Renderable in a RenderQueue.
void | setMaterialForVisibles (String &materialName, Camera *cam, bool shadowcastersonly=false)
Sets the given material for each Renderable visible from a given camera.
void | setMaterialForVisibles (String &materialName, Camera *cam, bool shadowcastersonly=false, bool solidsonly=false)
Sets the given material for each Renderable visible from a given camera.
void | restoreMaterials ()
Restores previously stored materials.
void | restoreMaterials ()
Restores previously stored materials.
void | renderFullscreenQuad (String materialName, RenderTarget *target)
Renderes a full screen quad on a given RendderTarget with a given material.
void | renderFullscreenQuad (String materialName, RenderTarget *target)
Renderes a full screen quad on a given RendderTarget with a given material.
void | renderPixelSprites (String &materialName, RenderTarget *rt, int width, int height)
Renderes sprites to pixels of the screen on a given RendderTarget with a given material.
void | renderPixelSprites (String &materialName, RenderTarget *rt, int width, int height)
Renderes sprites to pixels of the screen on a given RendderTarget with a given material.
void | renderFullscreenGrid (String &materialName, RenderTarget *rt, int width, int height)
Renders a grid onto the screen.
virtual bool | needUpdate (unsigned long frameNum)
Returns if this run needs update.

Protected Attributes

Light * | light
The light source this depth shadow map belongs to.
Camera * | depthMapCamera
Pointer to the camera of the lightsource.
String | materialName
The name of the material to be used when rendering the depth shadow map.
OgreSharedRuns * sharedRuns
A pointer to the OgreSharedRuns this run belongs to.
String | name
The name of the depth shadow map texture that was created by this run.
String | blurredname
The name of the blurred depth shadow map texture that was created by this run.
Texture * | depthMapTexture
A pointer to the depth shadow texture that was created by this run.
Texture * | blurredDepthMapTexture
A pointer to the blurred depth shadow texture that was created by this run.
std::map< Renderable *, String > | visibleObjects
map of Renderables which will be rendered with a given material
std::map< Renderable *, String > | visibleObjects
map of Renderables which will be rendered with a given material
SpriteSet * | pixelSprites
SpriteSet used in pixel sprite rendering.
BillboardSet * | pixelSprites
SpriteSet used in pixel sprite rendering.
String | spriteSetName
unique name of the SpriteSet used in pixel sprite rendering
Entity * | fullscreenGrid
Entity used in fullscreen grid rendering.
unsigned long | lastupdated
The number of the last frame this run was updated.
unsigned long | startFrame
The number of the frame this run should be updated first.
unsigned long | updateInterval
Refresh frequency in frames.
unsigned int | resolutionX
width of the depth map texture
unsigned int | resolutionY
height of the depth map texture

Static Protected Attributes

static MovablePlane * | fullScreenQuad
fulls screen quad plane used in full screen quad rendering
static MovablePlane * | fullScreenQuad
fulls screen quad plane used in full screen quad rendering
static Entity * | fullScreenQuadEntity
fulls screen quad Entity used in full screen quad rendering
static Entity * | fullScreenQuadEntity
fulls screen quad Entity used in full screen quad rendering
static SceneNode * | fullScreenQuadNode
fulls screen quad SceneNode used in full screen quad rendering
static SceneNode * | fullScreenQuadNode
fulls screen quad SceneNode used in full screen quad rendering

Detailed Description

DepthShadowMapRenderingRun used in an OGRE environment.

Constructor & Destructor Documentation

OgreDepthShadowMapRenderingRun::OgreDepthShadowMapRenderingRun | ( | OgreSharedRuns * | sharedRuns,
 |  | String | name,
 |  | Light * | light,
 |  | unsigned int | resolutionX,
 |  | unsigned int | resolutionY,
 |  | String | materialName
 | ) |  |

Constructor.

Parameters:
sharedRuns | a pointer to the OgreSharedRuns this run belongs to
name | the name of the depth map texture to be created
light | the light source this depth shadow map belongs to
resolutionX | the resolution width of the depth shadow map
resolutionY | the resolution height of the depth shadow map
materialName | the name of the material to be used when rendering the depth shadow map

Member Function Documentation

void OgreDepthShadowMapRenderingRun::refreshLight ( unsigned long frameNum )

Refreshes light camera matrices, called in each update.

n = 100000;

n = 100000;

void OgreDepthShadowMapRenderingRun::updateFrame ( unsigned long frameNum ) [protected, virtual]

This function does the actual update in a frame.

Parameters:
frameNum current frame number

Implements DepthShadowMapRenderingRun.

void OgreDepthShadowMapRenderingRun::updateDepthCubeFace ( int facenum ) [protected, virtual]

Updates one face of the depth cubemap (used only in case of point lights).

Parameters:
facenum the number of the face to be updated

Implements DepthShadowMapRenderingRun.

OgreRenderingRun* OgreRenderingRun::asOgreRenderingRun ( ) [inline, virtual, inherited]

Conversion to OgreRenderRun.

This function is needed because of virtual inheritance.

Reimplemented from RenderingRun.

OgreRenderingRun* OgreRenderingRun::asOgreRenderingRun ( ) [inline, virtual, inherited]

Conversion to OgreRenderRun.

This function is needed because of virtual inheritance.

Reimplemented from RenderingRun.

Vector3 OgreRenderingRun::getCubeMapFaceDirection ( unsigned char faceId ) [protected, inherited]

Returns a direction for a cubemap face id.

This is a helper function to retrieve the normal direction of a given cubemap face.

Parameters:
faceId the number of the face

Vector3 OgreRenderingRun::getCubeMapFaceDirection ( unsigned char faceId ) [protected, inherited]

Returns a direction for a cubemap face id.

This is a helper function to retrieve the normal direction of a given cubemap face.

Parameters:
faceId the number of the face

Texture * OgreRenderingRun::createCubeRenderTexture | ( | String | name,
 |  | const Vector3 | position,
 |  | unsigned int | resolution = 512,
 |  | PixelFormat | format = PF_FLOAT16_RGBA,
 |  | int | numMips = 0,
 |  | ColourValue | clearColor = ColourValue::Black |
 | ) |  |  | [protected, inherited]

Creates a cubemap texture.

This is a helper function to easily create a cubemap texture and automaticly attach viewports to each face so it can be used as a rendertarget.

Parameters:
name | the name of the texture to be created
position | the initial position of the cubemap
resolution | the resolution of one cubemapface
format | the pixel format of the cubemap
numMips | the number of mipmap levels
clearColor | initial color

Texture* OgreRenderingRun::createCubeRenderTexture | ( | String | name,
 |  | const Vector3 | position,
 |  | unsigned int | resolution = 512,
 |  | PixelFormat | format = PF_FLOAT16_RGBA,
 |  | int | numMips = 0,
 |  | ColourValue | clearColor = ColourValue::Black |
 | ) |  |  | [protected, inherited]

Creates a cubemap texture.

This is a helper function to easily create a cubemap texture and automaticly attach viewports to each face so it can be used as a rendertarget.

Parameters:
name | the name of the texture to be created
position | the initial position of the cubemap
resolution | the resolution of one cubemapface
format | the pixel format of the cubemap
numMips | the number of mipmap levels
clearColor | initial color

void OgreRenderingRun::setMaterialForRenderables | ( | String & | materialName,
 |  | RenderQueue * | rq |
 | ) |  |  | [protected, inherited]

Sets the given material for each Renderable in a RenderQueue.

This is a helper function to set a material to each element of a previously filled Renderque. The orginal material of the Renderables are stored so they can be restored later. The function also tells the current SceneManager not to search for visible objects, as we are going to use the given RenderQueue during the next rendering.

Parameters:
materialName | the name of the material to set for the Renderables
rq | pointer to the filled Renderqueue instance to set material for

void OgreRenderingRun::setMaterialForRenderables | ( | String & | materialName,
 |  | RenderQueue * | rq,
 |  | bool | solidsonly = false |
 | ) |  |  | [protected, inherited]

Sets the given material for each Renderable in a RenderQueue.

This is a helper function to set a material to each element of a previously filled Renderque. The orginal material of the Renderables are stored so they can be restored later. The function also tells the current SceneManager not to search for visible objects, as we are going to use the given RenderQueue during the next rendering.

Parameters:
materialName | the name of the material to set for the Renderables
rq | pointer to the filled Renderqueue instance to set material for

void OgreRenderingRun::setMaterialForVisibles | ( | String & | materialName,
 |  | Camera * | cam,
 |  | bool | shadowcastersonly = false |
 | ) |  |  | [protected, inherited]

Sets the given material for each Renderable visible from a given camera.

This helper function is similar to setMaterialForRenderables but it is also responsible for filling the RenderQueue. First the RenderQueue of the current SceneManager fill be filled with the visible objects seen from the given camera. Then the required material will be set for each element of the RenderQueue. The orginal material of the Renderables are stored so they can be restored later. The function also tells the current SceneManager not to search for visible objects, as we are going to use the filled RenderQueue during the next rendering.

Parameters:
materialName | the name of the material to set for the Renderables
cam | pointer to the camera from which visible objects should be searched
shadowcastersonly | flag to search for only shadow casters

void OgreRenderingRun::setMaterialForVisibles | ( | String & | materialName,
 |  | Camera * | cam,
 |  | bool | shadowcastersonly = false,
 |  | bool | solidsonly = false |
 | ) |  |  | [protected, inherited]

Sets the given material for each Renderable visible from a given camera.

This helper function is similar to setMaterialForRenderables but it is also responsible for filling the RenderQueue. First the RenderQueue of the current SceneManager fill be filled with the visible objects seen from the given camera. Then the required material will be set for each element of the RenderQueue. The orginal material of the Renderables are stored so they can be restored later. The function also tells the current SceneManager not to search for visible objects, as we are going to use the filled RenderQueue during the next rendering.

Parameters:
materialName | the name of the material to set for the Renderables
cam | pointer to the camera from which visible objects should be searched
shadowcastersonly | flag to search for only shadow casters

void OgreRenderingRun::restoreMaterials ( ) [protected, inherited]

Restores previously stored materials.

This helper function is typically used after a setMaterialForRenderables or setMaterialForVisibles call and a rendering process to restore the original material settings. The function also tells the current SceneManager to search for visible objects, as this is the default behaviour of SceneManager.

void OgreRenderingRun::restoreMaterials ( ) [protected, inherited]

Restores previously stored materials.

This helper function is typically used after a setMaterialForRenderables or setMaterialForVisibles call and a rendering process to restore the original material settings. The function also tells the current SceneManager to search for visible objects, as this is the default behaviour of SceneManager.

void OgreRenderingRun::renderFullscreenQuad | ( | String | materialName,
 |  | RenderTarget * | target |
 | ) |  |  | [protected, inherited]

Renderes a full screen quad on a given RendderTarget with a given material.

Parameters:
materialName | the name of the material bind to the quad
target | the RenderTarget the quad should be rendered on

void OgreRenderingRun::renderFullscreenQuad | ( | String | materialName,
 |  | RenderTarget * | target |
 | ) |  |  | [protected, inherited]

Renderes a full screen quad on a given RendderTarget with a given material.

Parameters:
materialName | the name of the material bind to the quad
target | the RenderTarget the quad should be rendered on

void OgreRenderingRun::renderPixelSprites | ( | String & | materialName,
 |  | RenderTarget * | rt,
 |  | int | width,
 |  | int | height |
 | ) |  |  | [protected, inherited]

Renderes sprites to pixels of the screen on a given RendderTarget with a given material.

Pixel sprites are pixel sized quads, placed on each pixel of the RenderTarget. The number of sprites not necessary corresponds to the resolution of the rendertarget. The pixel quads will evenly fill the rendertarget's area with sizes corresponding to the given resolution. We can render fewer or more pixel quads than the number of pixels the rendertarget has (eg.: in case of caustic cubemap generation).

Parameters:
materialName | the name of the material bind to the pixel sprites
rt | the RenderTarget the quads should be rendered on
width | the desired resolution width of the sprites
height | the desired resolution height of the sprites

void OgreRenderingRun::renderPixelSprites | ( | String & | materialName,
 |  | RenderTarget * | rt,
 |  | int | width,
 |  | int | height |
 | ) |  |  | [protected, inherited]

Renderes sprites to pixels of the screen on a given RendderTarget with a given material.

Pixel sprites are pixel sized quads, placed on each pixel of the RenderTarget. The number of sprites not necessary corresponds to the resolution of the rendertarget. The pixel quads will evenly fill the rendertarget's area with sizes corresponding to the given resolution. We can render fewer or more pixel quads than the number of pixels the rendertarget has (eg.: in case of caustic cubemap generation).

Parameters:
materialName | the name of the material bind to the pixel sprites
rt | the RenderTarget the quads should be rendered on
width | the desired resolution width of the sprites
height | the desired resolution height of the sprites

void OgreRenderingRun::renderFullscreenGrid | ( | String & | materialName,
 |  | RenderTarget * | rt,
 |  | int | width,
 |  | int | height |
 | ) |  |  | [protected, inherited]

Renders a grid onto the screen.

Parameters:
rt | the RenderTarget the grid should be rendered on
width | the desired horizontal resolution of the grid
height | the desired vertical resolution of the grid

virtual bool RenderingRun::canJoin ( RenderingRun * run ) [inline, virtual, inherited]

Returns true if two runs can be joined.

In some cases special requirements should stand to join two runs (even if they have the same type). Eg.: two caustic cube map generation technique should only be joined if they use the same material when rendering the caustic cubemap.

Reimplemented in OgreCausticCubeMapRenderingRun, OgreChildPSystemRenderingRun, and OgrePhotonMapRenderingRun.

virtual bool RenderingRun::needUpdate ( unsigned long frameNum ) [inline, protected, virtual, inherited]

Returns if this run needs update.

This tipically depends on the upate interval and the starting frame number.

Parameters:
frameNum current frame number

Reimplemented in OgreFocusingMapRenderingRun, and OgrePMEntryPointMapRenderingRun.

Member Data Documentation

std::map<Renderable*, String> OgreRenderingRun::visibleObjects [protected, inherited]

map of Renderables which will be rendered with a given material

The String stores the original material name that will be restored after rendering.

See also:
setMaterialForVisibles

setMaterialForRenderables

restoreMaterials

std::map<Renderable*, String> OgreRenderingRun::visibleObjects [protected, inherited]

map of Renderables which will be rendered with a given material

The String stores the original material name that will be restored after rendering.

See also:
setMaterialForVisibles

setMaterialForRenderables

restoreMaterials

MovablePlane * OgreRenderingRun::fullScreenQuad [static, protected, inherited]

fulls screen quad plane used in full screen quad rendering

See also:
renderFullscreenQuad

MovablePlane* OgreRenderingRun::fullScreenQuad [static, protected, inherited]

fulls screen quad plane used in full screen quad rendering

See also:
renderFullscreenQuad

Entity * OgreRenderingRun::fullScreenQuadEntity [static, protected, inherited]

fulls screen quad Entity used in full screen quad rendering

See also:
renderFullscreenQuad

Entity* OgreRenderingRun::fullScreenQuadEntity [static, protected, inherited]

fulls screen quad Entity used in full screen quad rendering

See also:
renderFullscreenQuad

SceneNode * OgreRenderingRun::fullScreenQuadNode [static, protected, inherited]

fulls screen quad SceneNode used in full screen quad rendering

See also:
renderFullscreenQuad

SceneNode* OgreRenderingRun::fullScreenQuadNode [static, protected, inherited]

fulls screen quad SceneNode used in full screen quad rendering

See also:
renderFullscreenQuad

SpriteSet* OgreRenderingRun::pixelSprites [protected, inherited]

SpriteSet used in pixel sprite rendering.

See also:
renderPixelSprites

BillboardSet* OgreRenderingRun::pixelSprites [protected, inherited]

SpriteSet used in pixel sprite rendering.

See also:
renderPixelSprites

String OgreRenderingRun::spriteSetName [protected, inherited]

unique name of the SpriteSet used in pixel sprite rendering

See also:
renderPixelSprites

Entity* OgreRenderingRun::fullscreenGrid [protected, inherited]

Entity used in fullscreen grid rendering.

See also:
renderPixelGrid

Generated on Wed Mar 28 11:48:54 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: OgreDepthShadowReceiverRenderTechnique Class Reference

OgreDepthShadowReceiverRenderTechnique Class Reference

DepthShadowReceiverRenderTechnique used in an OGRE environment. More...

Inheritance diagram for OgreDepthShadowReceiverRenderTechnique:

OgreRenderTechnique DepthShadowReceiverRenderTechnique RenderTechnique RenderTechnique List of all members.

Public Member Functions

OgreDepthShadowReceiverRenderTechnique (int maxlights, String shadowVertexProgram, String shadowFragmentProgram, String WorldViewProjParamName, String WorldParamName, bool setLightViewMatrix, bool setLightViewProjMatrix, bool setLightProjFarPlane, String lightViewProjParamName, String lightViewParamName, String lightFarPlaneParamName, Pass *pass, OgreRenderable *parentRenderable, OgreTechniqueGroup *parentTechniqueGroup)
Constructor.
~OgreDepthShadowReceiverRenderTechnique ()
Destructor.
virtual void | update (unsigned long frameNum)
Updates the resources in the given frame.
virtual OgreRenderTechnique * | asOgreRenderTechnique ()
Conversion to OgreRenderTechnique.
virtual void | runChanged (RenderingRunType runType, RenderingRun *run)
Called after one of he shared runs changes.
virtual void | runUpdated (RenderingRunType runType, RenderingRun *run)
Called after one of he shared runs updates.
ElementaryRenderable * getParentRenderable ()
Retrieves the renderable this technique operates on.

Protected Attributes

int | maxlights
the maximum number of light sources to recieve shadow from
String | shadowVertexProgram
the vertex program to be used in the shadowing passes
String | shadowFragmentProgram
the fragment program to be used in the shadowing passes
std::vector< Pass * > | passes
bool | setLightViewMatrix
bound light space view matrix to a gpu program parameter
bool | setLightViewProjMatrix
bound light space view-projection matrix to a gpu program parameter
bool | setLightProjFarPlane
bound light space projection far plane to a gpu program parameter
String | lightViewProjParamName
the name of the gpu program parameter the light space view-projection matrix should be bound to
String | lightViewParamName
the name of the gpu program parameter the light space view matrix should be bound to
String | lightFarPlaneParamName
the name of the gpu program parameter the light space projection far plane should be bound to
String | WorldViewProjParamName
the name of the gpu program parameter the world-view-projection matrix should be bound to
String | WorldParamName
the name of the gpu program parameter the world matrix should be bound to
OgreRenderable * parentOgreRenderable
a OgreRenderable pointer to the renderable this technique operates on.
OgreTechniqueGroup * parentOgreTechniqueGroup
a OgreTechniqueGroup pointer to the TechniqueGroup this technique is attached to.
Pass * | pass
a pointer to the pass this technique operates on.
ElementaryRenderable * parentRenderable
The renderable this technique operates on.
TechniqueGroup * parentTechniqueGroup
The TechniqueGroup this RenderedTechnique is attached to.
SharedRuns * sharedRuns
The SharedRuns this RenderedTechnique is attached to.

Detailed Description

DepthShadowReceiverRenderTechnique used in an OGRE environment.

This technique defines that the object will recieve shadows with the help of depth shadow maps. Each lightsource can have a depth map assigned to it. These are going to be refreshed only if shadow receivers are visible. It is the shadow receiver technique's resposibility to refresh them.

The shadows from each light are calculated in separate passes. Each pass will modulate the shaded image, so thes should be the last passes (but before caustic passes). The given Pass* parameter n the constructor defines the pass after which new shadow recieving passes will be added by the technique.

Constructor & Destructor Documentation

OgreDepthShadowReceiverRenderTechnique::OgreDepthShadowReceiverRenderTechnique | ( | int | maxlights,
 |  | String | shadowVertexProgram,
 |  | String | shadowFragmentProgram,
 |  | String | WorldViewProjParamName,
 |  | String | WorldParamName,
 |  | bool | setLightViewMatrix,
 |  | bool | setLightViewProjMatrix,
 |  | bool | setLightProjFarPlane,
 |  | String | lightViewProjParamName,
 |  | String | lightViewParamName,
 |  | String | lightFarPlaneParamName,
 |  | Pass * | pass,
 |  | OgreRenderable * | parentRenderable,
 |  | OgreTechniqueGroup * | parentTechniqueGroup
 | ) |  |

Constructor.

Parameters:
maxlights | the maximum number of light sources to recieve shadow from
shadowVertexProgram | the vertex program to be used in the shadowing passes
shadowFragmentProgram | the fragment program to be used in the shadowing passes It should have one pass and the depth map of a light will be bound to the first sampler unit.
WorldViewProjParamName | the name of the gpu program parameter the world-view-projection matrix should be bound to
WorldParamName | the name of the gpu program parameter the world matrix should be bound to
setLightViewMatrix | bound light space view matrix to a gpu program parameter
setLightViewProjMatrix | bound light space view-projection matrix to a gpu program parameter
setLightProjFarPlane | bound light space projection far plane to a gpu program parameter
lightViewProjParamName | the name of the gpu program parameter the light space view-projection matrix should be bound to
lightViewParamName | the name of the gpu program parameter the light space view matrix should be bound to
lightFarPlaneParamName | the name of the gpu program parameter the light space projection far plane should be bound to
pass | the pass after which shadowing passes should be added
parentRenderable | the object to operate on
parentTechniqueGroup | the TechniqueGroup this RenderedTechnique is attached to

Member Function Documentation

void OgreDepthShadowReceiverRenderTechnique::update ( unsigned long frameNum ) [virtual]

Updates the resources in the given frame.

A RenderTechnique is usually need some resources from several runs, so these runs will be updated.

Parameters:
frameNum the actual framenumber

Reimplemented from RenderTechnique.

virtual OgreRenderTechnique* OgreRenderTechnique::asOgreRenderTechnique ( ) [inline, virtual, inherited]

Conversion to OgreRenderTechnique.

This function is needed because of virtual inheritance.

Reimplemented from RenderTechnique.

virtual void RenderTechnique::runChanged | ( | RenderingRunType | runType,
 |  | RenderingRun * | run |
 | ) |  |  | [inline, virtual, inherited]

Called after one of he shared runs changes.

Parameters:
runType | enum describing the type of the changed run
run | pointer to the changed RenderingRun

Reimplemented in CausticCasterRenderTechnique, ColorCubeMapRenderTechnique, ConvolvedCubeMapRenderTechnique, CubeMapRenderTechnique, DistanceCubeMapRenderTechnique, HierarchicalParticleSystemTechnique, and IllumVolumeRenderTechnique.

virtual void RenderTechnique::runUpdated | ( | RenderingRunType | runType,
 |  | RenderingRun * | run |
 | ) |  |  | [inline, virtual, inherited]

Called after one of he shared runs updates.

Parameters:
runType | enum describing the type of the updated run
run | pointer to the updated RenderingRun

Reimplemented in CausticCasterRenderTechnique, ColorCubeMapRenderTechnique, CubeMapRenderTechnique, DistanceCubeMapRenderTechnique, HierarchicalParticleSystemTechnique, and IllumVolumeRenderTechnique.

Member Data Documentation

int OgreDepthShadowReceiverRenderTechnique::maxlights [protected]

the maximum number of light sources to recieve shadow from

During update the nearest light sources will be found and used.

String OgreDepthShadowReceiverRenderTechnique::shadowFragmentProgram [protected]

the fragment program to be used in the shadowing passes

It should have one pass and the depth map of a light will be bound to the first sampler unit.

std::vector<Pass*> OgreDepthShadowReceiverRenderTechnique::passes [protected]

new passes created by this technique

Generated on Wed Mar 28 11:48:54 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: OgreDepthShadowReceiverRenderTechniqueFactory Class Reference

OgreDepthShadowReceiverRenderTechniqueFactory Class Reference

RenderTechniqueFactory to create OgreDepthShadowReceiverRenderTechnique instances. More...

Inheritance diagram for OgreDepthShadowReceiverRenderTechniqueFactory:

RenderTechniqueFactory List of all members.

Public Member Functions

OgreRenderTechnique * | createInstance (IllumTechniqueParams *params, Pass *pass, OgreRenderable *parentRenderable, OgreTechniqueGroup *parentTechniqueGroup)
Creates a RenderTechnique of the factory type.
bool | isType (String type)
Returns if this factory can create a RenderTechnique of the given type.
virtual void | parseParams (IllumTechniqueParams *params)
parses parameters from the material file.

Protected Types

typedef void(*) | ILLUM_ATTRIBUTE_PARSER (String &params, RenderTechniqueFactory *factory)
function for parsing RenderTechnique attributes
typedef std::map< String,
ILLUM_ATTRIBUTE_PARSER > 		AttribParserList
Keyword-mapped attribute parsers.

Protected Attributes

AttribParserList attributeParsers
map of parser functions
String | typeName
factoryname

Detailed Description

RenderTechniqueFactory to create OgreDepthShadowReceiverRenderTechnique instances.

Member Typedef Documentation

typedef void(*) RenderTechniqueFactory::ILLUM_ATTRIBUTE_PARSER(String &params, RenderTechniqueFactory *factory) [protected, inherited]

function for parsing RenderTechnique attributes

Parameters:
params attribute value stored in a String

Member Function Documentation

OgreRenderTechnique * OgreDepthShadowReceiverRenderTechniqueFactory::createInstance | ( | IllumTechniqueParams * | params,
 |  | Pass * | pass,
 |  | OgreRenderable * | parentRenderable,
 |  | OgreTechniqueGroup * | parentTechniqueGroup |
 | ) |  |  | [virtual]

Creates a RenderTechnique of the factory type.

Parameters:
params | containes constructor parameters as NameValuePairList
pass | the Pass to use in RenderTechnique constructor
pass | the parentRenderable to pass to RenderTechnique constructor
pass | the parentTechniqueGroup to pass to RenderTechnique constructor

Implements RenderTechniqueFactory.

bool RenderTechniqueFactory::isType ( String type ) [inline, inherited]

Returns if this factory can create a RenderTechnique of the given type.

Parameters:
type RenderTechnique type

void RenderTechniqueFactory::parseParams ( IllumTechniqueParams * params ) [virtual, inherited]

parses parameters from the material file.

The parsed parameters will be passed to the new RenderTechnique's constructor.

Parameters:
params pointer to the IllumTechniqueParams structure that was read from the material script and containes the parameters to be parsed.

Generated on Wed Mar 28 11:48:54 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: OgreDistanceCubeMapRenderTechnique Class Reference

OgreDistanceCubeMapRenderTechnique Class Reference

DistanceCubeMapRenderTechnique used in an Ogre environment. More...

Inheritance diagram for OgreDistanceCubeMapRenderTechnique:

DistanceCubeMapRenderTechnique OgreCubeMapRenderTechnique CubeMapRenderTechnique CubeMapRenderTechnique OgreRenderTechnique RenderTechnique RenderTechnique RenderTechnique List of all members.

Public Member Functions

OgreDistanceCubeMapRenderTechnique (unsigned long startFrame, unsigned long cubeMapUpdateInterval, unsigned int cubeMapResolution, unsigned char texID, bool useDistCalc, bool useFaceAngleCalc, float distTolerance, float angleTolerance, bool updateAllFace, bool renderSelf, bool renderEnvironment, String selfMaterial, String environmentMaterial, int layer, bool getMinMax, bool attachToTexUnit, String minVariableName, String maxVariableName, Pass *pass, OgreRenderable *parentRenderable, OgreTechniqueGroup *parentTechniqueGroup)
Constructor.
~OgreDistanceCubeMapRenderTechnique ()
Destructor.
void | update (unsigned long frameNum)
Updates the resources in the given frame.
virtual void | runUpdated (RenderingRunType runType, RenderingRun *run)
Called after one of he shared runs updates.
void | runChanged (RenderingRunType runType, RenderingRun *run)
Called after one of he shared runs changes.
virtual class OgreRenderTechnique * | asOgreRenderTechnique ()
Conversion to OgreRenderTechnique.
ElementaryRenderable * getParentRenderable ()
Retrieves the renderable this technique operates on.
virtual OgreRenderTechnique * | asOgreRenderTechnique ()
Conversion to OgreRenderTechnique.

Protected Member Functions

void | distanceCubeMapRunChanged (RenderingRun *run)
Called if the changed run is a CubeMapRenderingRun (containing distances of the current layer).
void | distanceCubeMapRunUpdated (RenderingRun *run)
Called if the changed run is a CubeMapRenderingRun (containing distances of the current layer).
virtual RenderingRun * | createCubeMapRun ()=0
Creates a CubeMapRenderingRun.
virtual void | cubeMapRunChanged (RenderingRun *run)=0
Called if the changed run is a CubeMapRenderingRun.
virtual void | cubeMapRunUpdated (RenderingRun *run)=0
Called if the updated run is a CubeMapRenderingRun.
RenderingRun * createCubeMapRun ()
Creates a CubeMapRenderingRun.
void | cubeMapRunChanged (RenderingRun *run)
Called if the changed run is a CubeMapRenderingRun.
void | cubeMapRunUpdated (RenderingRun *run)
Called if the updated run is a CubeMapRenderingRun.

Protected Attributes

bool | useDistCalc
a flag to skip cube face update if object is far away or too small.
bool | useFaceAngleCalc
a flag to skip cube face update the face is neglible.
float | distTolerance
A value used in face skip test.
float | angleTolerance
A value used in face skip test.
bool | updateAllFace
defines if all cubemap faces should be updated in a frame or only one face per frame
unsigned long | cubeMapUpdateInterval
color-cubemap update frequency
unsigned int | cubeMapResolution
color-cubemap resolution
unsigned long | startFrame
offset in frame number used during update
bool | renderSelf
Sets if the object should be rendered to the cube map.
bool | renderEnvironment
Sets if the environment should be rendered to the cube map.
int | layer
The layer of the cubemap.
RenderingRunType | cubemapLayer
The exact run type of this run (according to the actual layer).
ElementaryRenderable * parentRenderable
The renderable this technique operates on.
TechniqueGroup * parentTechniqueGroup
The TechniqueGroup this RenderedTechnique is attached to.
SharedRuns * sharedRuns
The SharedRuns this RenderedTechnique is attached to.
unsigned char | texID
the id of the texture unit state the resulting cubemap should be bound to
String | selfMaterial
the material that should be set for the object while rendering the cubemap
String | environmentMaterial
the material that should be set for the environment while rendering the cubemap
bool | getMinMax
sets if the minimum and maximum values of the cubemap should be computed
bool | attachToTexUnit
sets if this cubemap should be attach to a texture unit of the pass
String | minVariableName
sets the name of the gpu shader program parameter to which the minimum value should be bound to
String | maxVariableName
sets the name of the gpu shader program parameter to which the maximum value should be bound to
OgreRenderable * parentOgreRenderable
a OgreRenderable pointer to the renderable this technique operates on.
OgreTechniqueGroup * parentOgreTechniqueGroup
a OgreTechniqueGroup pointer to the TechniqueGroup this technique is attached to.
Pass * | pass
a pointer to the pass this technique operates on.

Detailed Description

DistanceCubeMapRenderTechnique used in an Ogre environment.

Constructor & Destructor Documentation

OgreDistanceCubeMapRenderTechnique::OgreDistanceCubeMapRenderTechnique | ( | unsigned long | startFrame,
 |  | unsigned long | cubeMapUpdateInterval,
 |  | unsigned int | cubeMapResolution,
 |  | unsigned char | texID,
 |  | bool | useDistCalc,
 |  | bool | useFaceAngleCalc,
 |  | float | distTolerance,
 |  | float | angleTolerance,
 |  | bool | updateAllFace,
 |  | bool | renderSelf,
 |  | bool | renderEnvironment,
 |  | String | selfMaterial,
 |  | String | environmentMaterial,
 |  | int | layer,
 |  | bool | getMinMax,
 |  | bool | attachToTexUnit,
 |  | String | minVariableName,
 |  | String | maxVariableName,
 |  | Pass * | pass,
 |  | OgreRenderable * | parentRenderable,
 |  | OgreTechniqueGroup * | parentTechniqueGroup
 | ) |  |

Constructor.

Parameters:
startFrame | adds an offset to the current frame number to help evenly distribute updates between frames
cubeMapUpdateInterval | update frequency
cubeMapResolution | distance cubemap resolution
texID | the id of the texture unit state the resulting cubemap should be bound to
useDistCalc | flag to skip cube face update if object is far away
useFaceAngleCalc | flag to skip cube face update if face is neglible
distTolerance | distance tolerance used in face skip
angleTolerance | angle tolerance used in face skip
updateAllFace | defines if all cubemap faces should be updated in a frame or only one face per frame
renderSelf | sets if the object should be rendered to the cube map
renderEnvironment | sets if the environment should be rendered to the cube map
selfMaterial | the material that should be set for the object while rendering the cubemap
environmentMaterial | the material that should be set for the environment while rendering the cubemap
layer | the layer of this cubemap
getMinMax | sets if the minimum and maximum values of the cubemap should be computed
attachToTexUnit | sets if this cubemap should be attach to a texture unit of the pass
minVariableName | sets the name of the gpu shader program parameter to which the minimum value should be bound to
maxVariableName | sets the name of the gpu shader program parameter to which the maximum value should be bound to
pass | the pass to operate on
parentRenderable | the object to operate on
parentTechniqueGroup | the TechniqueGroup this RenderedTechnique is attached to

Member Function Documentation

void OgreDistanceCubeMapRenderTechnique::update ( unsigned long frameNum ) [virtual]

Updates the resources in the given frame.

Parameters:
frameNum the actual framenumber

Reimplemented from DistanceCubeMapRenderTechnique.

void OgreDistanceCubeMapRenderTechnique::distanceCubeMapRunChanged ( RenderingRun * run ) [protected, virtual]

Called if the changed run is a CubeMapRenderingRun (containing distances of the current layer).

Parameters:
run pointer to the changed CubeMapRenderingRun

Implements DistanceCubeMapRenderTechnique.

void OgreDistanceCubeMapRenderTechnique::distanceCubeMapRunUpdated ( RenderingRun * run ) [protected, virtual]

Called if the changed run is a CubeMapRenderingRun (containing distances of the current layer).

Parameters:
run pointer to the changed CubeMapRenderingRun

Implements DistanceCubeMapRenderTechnique.

void DistanceCubeMapRenderTechnique::runUpdated | ( | RenderingRunType | runType,
 |  | RenderingRun * | run |
 | ) |  |  | [virtual, inherited]

Called after one of he shared runs updates.

Parameters:
runType | enum describing the type of the updated run
run | pointer to the updated RenderingRun

Reimplemented from CubeMapRenderTechnique.

void DistanceCubeMapRenderTechnique::runChanged | ( | RenderingRunType | runType,
 |  | RenderingRun * | run |
 | ) |  |  | [virtual, inherited]

Called after one of he shared runs changes.

Parameters:
runType | enum describing the type of the changed run
run | pointer to the changed RenderingRun

Reimplemented from CubeMapRenderTechnique.

virtual RenderingRun* CubeMapRenderTechnique::createCubeMapRun ( ) [protected, pure virtual, inherited]

Creates a CubeMapRenderingRun.

Returns:
the new CubeMapRenderingRun instance.

Implemented in OgreCubeMapRenderTechnique.

virtual void CubeMapRenderTechnique::cubeMapRunChanged ( RenderingRun * run ) [protected, pure virtual, inherited]

Called if the changed run is a CubeMapRenderingRun.

Parameters:
run pointer to the new CubeMapRenderingRun

Implemented in OgreCubeMapRenderTechnique.

virtual void CubeMapRenderTechnique::cubeMapRunUpdated ( RenderingRun * run ) [protected, pure virtual, inherited]

Called if the updated run is a CubeMapRenderingRun.

Parameters:
run pointer to the updated CubeMapRenderingRun

Implemented in OgreCubeMapRenderTechnique.

virtual class OgreRenderTechnique* RenderTechnique::asOgreRenderTechnique ( ) [inline, virtual, inherited]

Conversion to OgreRenderTechnique.

This function is needed because of virtual inheritance.

Reimplemented in OgreRenderTechnique.

RenderingRun * OgreCubeMapRenderTechnique::createCubeMapRun ( ) [protected, virtual, inherited]

Creates a CubeMapRenderingRun.

Returns:
the new CubeMapRenderingRun instance.

Implements CubeMapRenderTechnique.

void OgreCubeMapRenderTechnique::cubeMapRunChanged ( RenderingRun * run ) [protected, virtual, inherited]

Called if the changed run is a CubeMapRenderingRun.

Parameters:
run pointer to the new CubeMapRenderingRun

Implements CubeMapRenderTechnique.

void OgreCubeMapRenderTechnique::cubeMapRunUpdated ( RenderingRun * run ) [protected, virtual, inherited]

Called if the updated run is a CubeMapRenderingRun.

Parameters:
run pointer to the updated CubeMapRenderingRun

Implements CubeMapRenderTechnique.

virtual OgreRenderTechnique* OgreRenderTechnique::asOgreRenderTechnique ( ) [inline, virtual, inherited]

Conversion to OgreRenderTechnique.

This function is needed because of virtual inheritance.

Reimplemented from RenderTechnique.

Member Data Documentation

bool CubeMapRenderTechnique::useDistCalc [protected, inherited]

a flag to skip cube face update if object is far away or too small.

See also:
distTolerance

bool CubeMapRenderTechnique::useFaceAngleCalc [protected, inherited]

a flag to skip cube face update the face is neglible.

See also:
angleTolerance

float CubeMapRenderTechnique::distTolerance [protected, inherited]

A value used in face skip test.

The higher this value gets the more precise, but slower the method will be.

float CubeMapRenderTechnique::angleTolerance [protected, inherited]

A value used in face skip test.

The higher this value gets the more precise, but slower the method will be.

int CubeMapRenderTechnique::layer [protected, inherited]

The layer of the cubemap.

This extension was created to achieve effect such as multiple reflections and refractions that require more complete sampling of the scene. With this extension we can render the environment into several cubemap layers eg. with depth peeling.

Generated on Wed Mar 28 11:48:54 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: OgreDistanceCubeMapRenderTechniqueFactory Class Reference

OgreDistanceCubeMapRenderTechniqueFactory Class Reference

RenderTechniqueFactory to create OgreDistanceCubeMapRenderTechnique instances. More...

Inheritance diagram for OgreDistanceCubeMapRenderTechniqueFactory:

OgreCubeMapRenderTechniqueFactory RenderTechniqueFactory List of all members.

Public Member Functions

OgreDistanceCubeMapRenderTechniqueFactory ()
Technique factory.
OgreRenderTechnique * | createInstance (IllumTechniqueParams *params, Pass *pass, OgreRenderable *parentRenderable, OgreTechniqueGroup *parentTechniqueGroup)
Creates a RenderTechnique of the factory type.
bool | isType (String type)
Returns if this factory can create a RenderTechnique of the given type.
virtual void | parseParams (IllumTechniqueParams *params)
parses parameters from the material file.

Protected Types

typedef void(*) | ILLUM_ATTRIBUTE_PARSER (String &params, RenderTechniqueFactory *factory)
function for parsing RenderTechnique attributes
typedef std::map< String,
ILLUM_ATTRIBUTE_PARSER > 		AttribParserList
Keyword-mapped attribute parsers.

Protected Attributes

AttribParserList attributeParsers
map of parser functions
String | typeName
factoryname

Detailed Description

RenderTechniqueFactory to create OgreDistanceCubeMapRenderTechnique instances.

Member Typedef Documentation

typedef void(*) RenderTechniqueFactory::ILLUM_ATTRIBUTE_PARSER(String &params, RenderTechniqueFactory *factory) [protected, inherited]

function for parsing RenderTechnique attributes

Parameters:
params attribute value stored in a String

Member Function Documentation

OgreRenderTechnique * OgreDistanceCubeMapRenderTechniqueFactory::createInstance | ( | IllumTechniqueParams * | params,
 |  | Pass * | pass,
 |  | OgreRenderable * | parentRenderable,
 |  | OgreTechniqueGroup * | parentTechniqueGroup |
 | ) |  |  | [virtual]

Creates a RenderTechnique of the factory type.

Parameters:
params | containes constructor parameters as NameValuePairList
pass | the Pass to use in RenderTechnique constructor
pass | the parentRenderable to pass to RenderTechnique constructor
pass | the parentTechniqueGroup to pass to RenderTechnique constructor

Reimplemented from OgreCubeMapRenderTechniqueFactory.

bool RenderTechniqueFactory::isType ( String type ) [inline, inherited]

Returns if this factory can create a RenderTechnique of the given type.

Parameters:
type RenderTechnique type

void RenderTechniqueFactory::parseParams ( IllumTechniqueParams * params ) [virtual, inherited]

parses parameters from the material file.

The parsed parameters will be passed to the new RenderTechnique's constructor.

Parameters:
params pointer to the IllumTechniqueParams structure that was read from the material script and containes the parameters to be parsed.

Generated on Wed Mar 28 11:48:55 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: OgreFireRenderTechnique Class Reference

OgreFireRenderTechnique Class Reference

A special SBBRenderTechnique used in an OGRE environment. More...

Inheritance diagram for OgreFireRenderTechnique:

OgreRenderTechnique UpdateListener RenderTechnique List of all members.

Public Member Functions

OgreFireRenderTechnique (unsigned char depthTexID, Pass *pass, OgreRenderable *parentRenderable, OgreTechniqueGroup *parentTechniqueGroup)
Constructor.
virtual void | update (unsigned long frameNum)
Updates the resources in the given frame.
void | preAllUpdates ()
Called before RenderTechnique updates.
virtual OgreRenderTechnique * | asOgreRenderTechnique ()
Conversion to OgreRenderTechnique.
virtual void | runChanged (RenderingRunType runType, RenderingRun *run)
Called after one of he shared runs changes.
virtual void | runUpdated (RenderingRunType runType, RenderingRun *run)
Called after one of he shared runs updates.
ElementaryRenderable * getParentRenderable ()
Retrieves the renderable this technique operates on.
virtual void | postAllUpdates ()
Called after RenderTechnique updates.

Protected Attributes

unsigned char | depthTexID
OgreRenderable * parentOgreRenderable
a OgreRenderable pointer to the renderable this technique operates on.
OgreTechniqueGroup * parentOgreTechniqueGroup
a OgreTechniqueGroup pointer to the TechniqueGroup this technique is attached to.
Pass * | pass
a pointer to the pass this technique operates on.
ElementaryRenderable * parentRenderable
The renderable this technique operates on.
TechniqueGroup * parentTechniqueGroup
The TechniqueGroup this RenderedTechnique is attached to.
SharedRuns * sharedRuns
The SharedRuns this RenderedTechnique is attached to.

Detailed Description

A special SBBRenderTechnique used in an OGRE environment.

Instead of rendering to the frame buffer this Technique renders into two render targets at the same time. The firs render target will be used as it were an ordinary backbuffer. The second rendertarget will be used to simulate heat shimmering (offset values will be written to it). The shimmering effect will be achieved with post processing: combining the backbuffer with the first render target using the second render target as uv offset. Just like the spherical billboard techniqeue, this thechnique requires a depth image taken from main camera's viewpoint.

Constructor & Destructor Documentation

OgreFireRenderTechnique::OgreFireRenderTechnique | ( | unsigned char | depthTexID,
 |  | Pass * | pass,
 |  | OgreRenderable * | parentRenderable,
 |  | OgreTechniqueGroup * | parentTechniqueGroup
 | ) |  |

Constructor.

Parameters:
depthTexID | the id of the texture unit state the resulting scene depth map should be bound to
pass | the pass to operate on
parentRenderable | the object to operate on
parentTechniqueGroup | the TechniqueGroup this RenderedTechnique is attached to

Member Function Documentation

void OgreFireRenderTechnique::update ( unsigned long frameNum ) [virtual]

Updates the resources in the given frame.

A RenderTechnique is usually need some resources from several runs, so these runs will be updated.

Parameters:
frameNum the actual framenumber

Reimplemented from RenderTechnique.

virtual OgreRenderTechnique* OgreRenderTechnique::asOgreRenderTechnique ( ) [inline, virtual, inherited]

Conversion to OgreRenderTechnique.

This function is needed because of virtual inheritance.

Reimplemented from RenderTechnique.

virtual void RenderTechnique::runChanged | ( | RenderingRunType | runType,
 |  | RenderingRun * | run |
 | ) |  |  | [inline, virtual, inherited]

Called after one of he shared runs changes.

Parameters:
runType | enum describing the type of the changed run
run | pointer to the changed RenderingRun

Reimplemented in CausticCasterRenderTechnique, ColorCubeMapRenderTechnique, ConvolvedCubeMapRenderTechnique, CubeMapRenderTechnique, DistanceCubeMapRenderTechnique, HierarchicalParticleSystemTechnique, and IllumVolumeRenderTechnique.

virtual void RenderTechnique::runUpdated | ( | RenderingRunType | runType,
 |  | RenderingRun * | run |
 | ) |  |  | [inline, virtual, inherited]

Called after one of he shared runs updates.

Parameters:
runType | enum describing the type of the updated run
run | pointer to the updated RenderingRun

Reimplemented in CausticCasterRenderTechnique, ColorCubeMapRenderTechnique, CubeMapRenderTechnique, DistanceCubeMapRenderTechnique, HierarchicalParticleSystemTechnique, and IllumVolumeRenderTechnique.

Member Data Documentation

unsigned char OgreFireRenderTechnique::depthTexID [protected]

&brief the id of the texture unit state the resulting scene depth map should be bound to

Generated on Wed Mar 28 11:48:55 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: OgreFireRenderTechniqueFactory Class Reference

OgreFireRenderTechniqueFactory Class Reference

RenderTechniqueFactory to create OgreFireRenderTechnique instances. More...

Inheritance diagram for OgreFireRenderTechniqueFactory:

RenderTechniqueFactory List of all members.

Public Member Functions

OgreRenderTechnique * | createInstance (IllumTechniqueParams *params, Pass *pass, OgreRenderable *parentRenderable, OgreTechniqueGroup *parentTechniqueGroup)
Creates a RenderTechnique of the factory type.
bool | isType (String type)
Returns if this factory can create a RenderTechnique of the given type.
virtual void | parseParams (IllumTechniqueParams *params)
parses parameters from the material file.

Protected Types

typedef void(*) | ILLUM_ATTRIBUTE_PARSER (String &params, RenderTechniqueFactory *factory)
function for parsing RenderTechnique attributes
typedef std::map< String,
ILLUM_ATTRIBUTE_PARSER > 		AttribParserList
Keyword-mapped attribute parsers.

Protected Attributes

AttribParserList attributeParsers
map of parser functions
String | typeName
factoryname

Detailed Description

RenderTechniqueFactory to create OgreFireRenderTechnique instances.

Member Typedef Documentation

typedef void(*) RenderTechniqueFactory::ILLUM_ATTRIBUTE_PARSER(String &params, RenderTechniqueFactory *factory) [protected, inherited]

function for parsing RenderTechnique attributes

Parameters:
params attribute value stored in a String

Member Function Documentation

OgreRenderTechnique * OgreFireRenderTechniqueFactory::createInstance | ( | IllumTechniqueParams * | params,
 |  | Pass * | pass,
 |  | OgreRenderable * | parentRenderable,
 |  | OgreTechniqueGroup * | parentTechniqueGroup |
 | ) |  |  | [virtual]

Creates a RenderTechnique of the factory type.

Parameters:
params | containes constructor parameters as NameValuePairList
pass | the Pass to use in RenderTechnique constructor
pass | the parentRenderable to pass to RenderTechnique constructor
pass | the parentTechniqueGroup to pass to RenderTechnique constructor

Implements RenderTechniqueFactory.

bool RenderTechniqueFactory::isType ( String type ) [inline, inherited]

Returns if this factory can create a RenderTechnique of the given type.

Parameters:
type RenderTechnique type

void RenderTechniqueFactory::parseParams ( IllumTechniqueParams * params ) [virtual, inherited]

parses parameters from the material file.

The parsed parameters will be passed to the new RenderTechnique's constructor.

Parameters:
params pointer to the IllumTechniqueParams structure that was read from the material script and containes the parameters to be parsed.

Generated on Wed Mar 28 11:48:55 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: OgreFocusingMapRenderingRun Class Reference

OgreFocusingMapRenderingRun Class Reference

FocusingMapRenderingRun. More...

Inheritance diagram for OgreFocusingMapRenderingRun:

OgreRenderingRun RenderingRun RenderingRun List of all members.

Public Member Functions

OgreFocusingMapRenderingRun (String name, Matrix4 lightMatrix, unsigned int focusingMapSize)
Constructor.
String | getFocusingTextureName ()
returns the name of the focusing texture
void | getMinMax (Vector3 &min, Vector3 &max)
gets the boundig box min-max points
void | setLightMatrix (Matrix4 &m)
Sets the light matrix that should be focused.
void | setCameraMatrices (const Matrix4 &view, const Matrix4 &projection)
Sets the player camera matrices.
OgreRenderingRun * asOgreRenderingRun ()
Conversion to OgreRenderRun.
OgreRenderingRun * asOgreRenderingRun ()
Conversion to OgreRenderRun.
bool | update (unsigned long frameNum)
Calls updateFrame() if the run needs update according to its starting frame and update interval and has not been allready updated in this frame.
virtual bool | canJoin (RenderingRun *run)
Returns true if two runs can be joined.

Protected Member Functions

void | updateFrame (unsigned long frameNum)
This function does the actual update in a frame.
void | createFocusingMap ()
creates the focusing map texture
bool | needUpdate (unsigned long frameNum)
Returns if this run needs update.
Vector3 | getCubeMapFaceDirection (unsigned char faceId)
Returns a direction for a cubemap face id.
Vector3 | getCubeMapFaceDirection (unsigned char faceId)
Returns a direction for a cubemap face id.
Texture * | createCubeRenderTexture (String name, const Vector3 position, unsigned int resolution=512, PixelFormat format=PF_FLOAT16_RGBA, int numMips=0, ColourValue clearColor=ColourValue::Black)
Creates a cubemap texture.
Texture * | createCubeRenderTexture (String name, const Vector3 position, unsigned int resolution=512, PixelFormat format=PF_FLOAT16_RGBA, int numMips=0, ColourValue clearColor=ColourValue::Black)
Creates a cubemap texture.
void | setMaterialForRenderables (String &materialName, RenderQueue *rq)
Sets the given material for each Renderable in a RenderQueue.
void | setMaterialForRenderables (String &materialName, RenderQueue *rq, bool solidsonly=false)
Sets the given material for each Renderable in a RenderQueue.
void | setMaterialForVisibles (String &materialName, Camera *cam, bool shadowcastersonly=false)
Sets the given material for each Renderable visible from a given camera.
void | setMaterialForVisibles (String &materialName, Camera *cam, bool shadowcastersonly=false, bool solidsonly=false)
Sets the given material for each Renderable visible from a given camera.
void | restoreMaterials ()
Restores previously stored materials.
void | restoreMaterials ()
Restores previously stored materials.
void | renderFullscreenQuad (String materialName, RenderTarget *target)
Renderes a full screen quad on a given RendderTarget with a given material.
void | renderFullscreenQuad (String materialName, RenderTarget *target)
Renderes a full screen quad on a given RendderTarget with a given material.
void | renderPixelSprites (String &materialName, RenderTarget *rt, int width, int height)
Renderes sprites to pixels of the screen on a given RendderTarget with a given material.
void | renderPixelSprites (String &materialName, RenderTarget *rt, int width, int height)
Renderes sprites to pixels of the screen on a given RendderTarget with a given material.
void | renderFullscreenGrid (String &materialName, RenderTarget *rt, int width, int height)
Renders a grid onto the screen.

Protected Attributes

Matrix4 | lightMatrix
light matrix to be focused
Camera * | camera
fosusing map camera
String | name
the name of the focusing texture that was created by this run
Texture * | focusingTexture
a pointer to the focusing texture that was created by this run
unsigned int | focusingMapSize
the size of the focusing map
std::map< Renderable *, String > | visibleObjects
map of Renderables which will be rendered with a given material
std::map< Renderable *, String > | visibleObjects
map of Renderables which will be rendered with a given material
SpriteSet * | pixelSprites
SpriteSet used in pixel sprite rendering.
BillboardSet * | pixelSprites
SpriteSet used in pixel sprite rendering.
String | spriteSetName
unique name of the SpriteSet used in pixel sprite rendering
Entity * | fullscreenGrid
Entity used in fullscreen grid rendering.
unsigned long | lastupdated
The number of the last frame this run was updated.
unsigned long | startFrame
The number of the frame this run should be updated first.
unsigned long | updateInterval
Refresh frequency in frames.

Static Protected Attributes

static MovablePlane * | fullScreenQuad
fulls screen quad plane used in full screen quad rendering
static MovablePlane * | fullScreenQuad
fulls screen quad plane used in full screen quad rendering
static Entity * | fullScreenQuadEntity
fulls screen quad Entity used in full screen quad rendering
static Entity * | fullScreenQuadEntity
fulls screen quad Entity used in full screen quad rendering
static SceneNode * | fullScreenQuadNode
fulls screen quad SceneNode used in full screen quad rendering
static SceneNode * | fullScreenQuadNode
fulls screen quad SceneNode used in full screen quad rendering

Detailed Description

FocusingMapRenderingRun.

A run to help focusing light projections for shadow mapping.

Constructor & Destructor Documentation

OgreFocusingMapRenderingRun::OgreFocusingMapRenderingRun | ( | String | name,
 |  | Matrix4 | lightMatrix,
 |  | unsigned int | focusingMapSize
 | ) |  |

Constructor.

Parameters:
name | the name of the focusing map texture to be created
lightMatrix | the light matrix to be focused
focusingMapSize | size of the focusing map

Member Function Documentation

void OgreFocusingMapRenderingRun::getMinMax | ( | Vector3 & | min,
 |  | Vector3 & | max
 | ) |  |

gets the boundig box min-max points

These values are given in light space and can be used to adjust the light matrices to focuse on important objects only.

void OgreFocusingMapRenderingRun::updateFrame ( unsigned long frameNum ) [protected, virtual]

This function does the actual update in a frame.

Parameters:
frameNum current frame number

Reimplemented from RenderingRun.

bool OgreFocusingMapRenderingRun::needUpdate ( unsigned long frameNum ) [inline, protected, virtual]

Returns if this run needs update.

This tipically depends on the upate interval and the starting frame number.

Parameters:
frameNum current frame number

Reimplemented from RenderingRun.

OgreRenderingRun* OgreRenderingRun::asOgreRenderingRun ( ) [inline, virtual, inherited]

Conversion to OgreRenderRun.

This function is needed because of virtual inheritance.

Reimplemented from RenderingRun.

OgreRenderingRun* OgreRenderingRun::asOgreRenderingRun ( ) [inline, virtual, inherited]

Conversion to OgreRenderRun.

This function is needed because of virtual inheritance.

Reimplemented from RenderingRun.

Vector3 OgreRenderingRun::getCubeMapFaceDirection ( unsigned char faceId ) [protected, inherited]

Returns a direction for a cubemap face id.

This is a helper function to retrieve the normal direction of a given cubemap face.

Parameters:
faceId the number of the face

Vector3 OgreRenderingRun::getCubeMapFaceDirection ( unsigned char faceId ) [protected, inherited]

Returns a direction for a cubemap face id.

This is a helper function to retrieve the normal direction of a given cubemap face.

Parameters:
faceId the number of the face

Texture * OgreRenderingRun::createCubeRenderTexture | ( | String | name,
 |  | const Vector3 | position,
 |  | unsigned int | resolution = 512,
 |  | PixelFormat | format = PF_FLOAT16_RGBA,
 |  | int | numMips = 0,
 |  | ColourValue | clearColor = ColourValue::Black |
 | ) |  |  | [protected, inherited]

Creates a cubemap texture.

This is a helper function to easily create a cubemap texture and automaticly attach viewports to each face so it can be used as a rendertarget.

Parameters:
name | the name of the texture to be created
position | the initial position of the cubemap
resolution | the resolution of one cubemapface
format | the pixel format of the cubemap
numMips | the number of mipmap levels
clearColor | initial color

Texture* OgreRenderingRun::createCubeRenderTexture | ( | String | name,
 |  | const Vector3 | position,
 |  | unsigned int | resolution = 512,
 |  | PixelFormat | format = PF_FLOAT16_RGBA,
 |  | int | numMips = 0,
 |  | ColourValue | clearColor = ColourValue::Black |
 | ) |  |  | [protected, inherited]

Creates a cubemap texture.

This is a helper function to easily create a cubemap texture and automaticly attach viewports to each face so it can be used as a rendertarget.

Parameters:
name | the name of the texture to be created
position | the initial position of the cubemap
resolution | the resolution of one cubemapface
format | the pixel format of the cubemap
numMips | the number of mipmap levels
clearColor | initial color

void OgreRenderingRun::setMaterialForRenderables | ( | String & | materialName,
 |  | RenderQueue * | rq |
 | ) |  |  | [protected, inherited]

Sets the given material for each Renderable in a RenderQueue.

This is a helper function to set a material to each element of a previously filled Renderque. The orginal material of the Renderables are stored so they can be restored later. The function also tells the current SceneManager not to search for visible objects, as we are going to use the given RenderQueue during the next rendering.

Parameters:
materialName | the name of the material to set for the Renderables
rq | pointer to the filled Renderqueue instance to set material for

void OgreRenderingRun::setMaterialForRenderables | ( | String & | materialName,
 |  | RenderQueue * | rq,
 |  | bool | solidsonly = false |
 | ) |  |  | [protected, inherited]

Sets the given material for each Renderable in a RenderQueue.

This is a helper function to set a material to each element of a previously filled Renderque. The orginal material of the Renderables are stored so they can be restored later. The function also tells the current SceneManager not to search for visible objects, as we are going to use the given RenderQueue during the next rendering.

Parameters:
materialName | the name of the material to set for the Renderables
rq | pointer to the filled Renderqueue instance to set material for

void OgreRenderingRun::setMaterialForVisibles | ( | String & | materialName,
 |  | Camera * | cam,
 |  | bool | shadowcastersonly = false |
 | ) |  |  | [protected, inherited]

Sets the given material for each Renderable visible from a given camera.

This helper function is similar to setMaterialForRenderables but it is also responsible for filling the RenderQueue. First the RenderQueue of the current SceneManager fill be filled with the visible objects seen from the given camera. Then the required material will be set for each element of the RenderQueue. The orginal material of the Renderables are stored so they can be restored later. The function also tells the current SceneManager not to search for visible objects, as we are going to use the filled RenderQueue during the next rendering.

Parameters:
materialName | the name of the material to set for the Renderables
cam | pointer to the camera from which visible objects should be searched
shadowcastersonly | flag to search for only shadow casters

void OgreRenderingRun::setMaterialForVisibles | ( | String & | materialName,
 |  | Camera * | cam,
 |  | bool | shadowcastersonly = false,
 |  | bool | solidsonly = false |
 | ) |  |  | [protected, inherited]

Sets the given material for each Renderable visible from a given camera.

This helper function is similar to setMaterialForRenderables but it is also responsible for filling the RenderQueue. First the RenderQueue of the current SceneManager fill be filled with the visible objects seen from the given camera. Then the required material will be set for each element of the RenderQueue. The orginal material of the Renderables are stored so they can be restored later. The function also tells the current SceneManager not to search for visible objects, as we are going to use the filled RenderQueue during the next rendering.

Parameters:
materialName | the name of the material to set for the Renderables
cam | pointer to the camera from which visible objects should be searched
shadowcastersonly | flag to search for only shadow casters

void OgreRenderingRun::restoreMaterials ( ) [protected, inherited]

Restores previously stored materials.

This helper function is typically used after a setMaterialForRenderables or setMaterialForVisibles call and a rendering process to restore the original material settings. The function also tells the current SceneManager to search for visible objects, as this is the default behaviour of SceneManager.

void OgreRenderingRun::restoreMaterials ( ) [protected, inherited]

Restores previously stored materials.

This helper function is typically used after a setMaterialForRenderables or setMaterialForVisibles call and a rendering process to restore the original material settings. The function also tells the current SceneManager to search for visible objects, as this is the default behaviour of SceneManager.

void OgreRenderingRun::renderFullscreenQuad | ( | String | materialName,
 |  | RenderTarget * | target |
 | ) |  |  | [protected, inherited]

Renderes a full screen quad on a given RendderTarget with a given material.

Parameters:
materialName | the name of the material bind to the quad
target | the RenderTarget the quad should be rendered on

void OgreRenderingRun::renderFullscreenQuad | ( | String | materialName,
 |  | RenderTarget * | target |
 | ) |  |  | [protected, inherited]

Renderes a full screen quad on a given RendderTarget with a given material.

Parameters:
materialName | the name of the material bind to the quad
target | the RenderTarget the quad should be rendered on

void OgreRenderingRun::renderPixelSprites | ( | String & | materialName,
 |  | RenderTarget * | rt,
 |  | int | width,
 |  | int | height |
 | ) |  |  | [protected, inherited]

Renderes sprites to pixels of the screen on a given RendderTarget with a given material.

Pixel sprites are pixel sized quads, placed on each pixel of the RenderTarget. The number of sprites not necessary corresponds to the resolution of the rendertarget. The pixel quads will evenly fill the rendertarget's area with sizes corresponding to the given resolution. We can render fewer or more pixel quads than the number of pixels the rendertarget has (eg.: in case of caustic cubemap generation).

Parameters:
materialName | the name of the material bind to the pixel sprites
rt | the RenderTarget the quads should be rendered on
width | the desired resolution width of the sprites
height | the desired resolution height of the sprites

void OgreRenderingRun::renderPixelSprites | ( | String & | materialName,
 |  | RenderTarget * | rt,
 |  | int | width,
 |  | int | height |
 | ) |  |  | [protected, inherited]

Renderes sprites to pixels of the screen on a given RendderTarget with a given material.

Pixel sprites are pixel sized quads, placed on each pixel of the RenderTarget. The number of sprites not necessary corresponds to the resolution of the rendertarget. The pixel quads will evenly fill the rendertarget's area with sizes corresponding to the given resolution. We can render fewer or more pixel quads than the number of pixels the rendertarget has (eg.: in case of caustic cubemap generation).

Parameters:
materialName | the name of the material bind to the pixel sprites
rt | the RenderTarget the quads should be rendered on
width | the desired resolution width of the sprites
height | the desired resolution height of the sprites

void OgreRenderingRun::renderFullscreenGrid | ( | String & | materialName,
 |  | RenderTarget * | rt,
 |  | int | width,
 |  | int | height |
 | ) |  |  | [protected, inherited]

Renders a grid onto the screen.

Parameters:
rt | the RenderTarget the grid should be rendered on
width | the desired horizontal resolution of the grid
height | the desired vertical resolution of the grid

virtual bool RenderingRun::canJoin ( RenderingRun * run ) [inline, virtual, inherited]

Returns true if two runs can be joined.

In some cases special requirements should stand to join two runs (even if they have the same type). Eg.: two caustic cube map generation technique should only be joined if they use the same material when rendering the caustic cubemap.

Reimplemented in OgreCausticCubeMapRenderingRun, OgreChildPSystemRenderingRun, and OgrePhotonMapRenderingRun.

Member Data Documentation

std::map<Renderable*, String> OgreRenderingRun::visibleObjects [protected, inherited]

map of Renderables which will be rendered with a given material

The String stores the original material name that will be restored after rendering.

See also:
setMaterialForVisibles

setMaterialForRenderables

restoreMaterials

std::map<Renderable*, String> OgreRenderingRun::visibleObjects [protected, inherited]

map of Renderables which will be rendered with a given material

The String stores the original material name that will be restored after rendering.

See also:
setMaterialForVisibles

setMaterialForRenderables

restoreMaterials

MovablePlane * OgreRenderingRun::fullScreenQuad [static, protected, inherited]

fulls screen quad plane used in full screen quad rendering

See also:
renderFullscreenQuad

MovablePlane* OgreRenderingRun::fullScreenQuad [static, protected, inherited]

fulls screen quad plane used in full screen quad rendering

See also:
renderFullscreenQuad

Entity * OgreRenderingRun::fullScreenQuadEntity [static, protected, inherited]

fulls screen quad Entity used in full screen quad rendering

See also:
renderFullscreenQuad

Entity* OgreRenderingRun::fullScreenQuadEntity [static, protected, inherited]

fulls screen quad Entity used in full screen quad rendering

See also:
renderFullscreenQuad

SceneNode * OgreRenderingRun::fullScreenQuadNode [static, protected, inherited]

fulls screen quad SceneNode used in full screen quad rendering

See also:
renderFullscreenQuad

SceneNode* OgreRenderingRun::fullScreenQuadNode [static, protected, inherited]

fulls screen quad SceneNode used in full screen quad rendering

See also:
renderFullscreenQuad

SpriteSet* OgreRenderingRun::pixelSprites [protected, inherited]

SpriteSet used in pixel sprite rendering.

See also:
renderPixelSprites

BillboardSet* OgreRenderingRun::pixelSprites [protected, inherited]

SpriteSet used in pixel sprite rendering.

See also:
renderPixelSprites

String OgreRenderingRun::spriteSetName [protected, inherited]

unique name of the SpriteSet used in pixel sprite rendering

See also:
renderPixelSprites

Entity* OgreRenderingRun::fullscreenGrid [protected, inherited]

Entity used in fullscreen grid rendering.

See also:
renderPixelGrid

Generated on Wed Mar 28 11:48:55 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: OgreHierarchicalParticleSystemTechnique Class Reference

OgreHierarchicalParticleSystemTechnique Class Reference

HierarchicalParticleSystemTechnique used in an OGRE environment. More...

Inheritance diagram for OgreHierarchicalParticleSystemTechnique:

OgreRenderTechnique HierarchicalParticleSystemTechnique RenderTechnique RenderTechnique List of all members.

Public Member Functions

OgreHierarchicalParticleSystemTechnique (unsigned long startFrame, unsigned long impostorUpdateInterval, unsigned int impostorResolution, unsigned char impostorTexID, bool useDistCalc, bool perspectiveRendering, String childPSysScriptName, bool useOwnMaterial, String impostorMaterialName, bool useVParam, String VParamRadius, bool useFParam, String FParamRadius, Pass *pass, OgreRenderable *parentRenderable, OgreTechniqueGroup *parentTechniqueGroup)
Constructor.
~OgreHierarchicalParticleSystemTechnique ()
Destructor.
virtual OgreRenderTechnique * | asOgreRenderTechnique ()
Conversion to OgreRenderTechnique.
virtual void | update (unsigned long frameNum)
Updates the resources in the given frame.
virtual void | runChanged (RenderingRunType runType, RenderingRun *run)
Called after one of he shared runs changes.
virtual void | runUpdated (RenderingRunType runType, RenderingRun *run)
Called after one of he shared runs updates.
ElementaryRenderable * getParentRenderable ()
Retrieves the renderable this technique operates on.
void | update (unsigned long frameNum)
Updates the resources in the given frame.
void | runChanged (RenderingRunType runType, RenderingRun *run)
Called after one of he shared runs changes.
void | runUpdated (RenderingRunType runType, RenderingRun *run)
Called after one of he shared runs updates.

Protected Member Functions

RenderingRun * createChildPSysRenderingRun ()
Creates the ChildParticleSystemRenderingRun needed by this technique.
virtual void | impostorChanged (RenderingRun *run)
Called if the impostor rendering run changed.
virtual void | impostorUpdated (RenderingRun *run)
Called if the impostor rendering run is updated.

Protected Attributes

String | impostorMaterialName
use this specific material for the small particle system
String | childPSysScriptName
name of the small particle system script
String | childPSysName
name of the created child particle system
unsigned char | impostorTexID
the id of the texture unit state the impostor image should be bound to
bool | useOwnMaterial
use the material for the smaller system that was defined in the particle script
String | VParamRadius
name of the gpu vertex program parameter the particle radius should be bound to
String | FParamRadius
name of the gpu fragment program parameter the particle radius should be bound to
bool | useVParam
bound particle radius to a gpu vertex program parameter
bool | useFParam
bound particle radius to a gpu fragment program parameter
OgreRenderable * parentOgreRenderable
a OgreRenderable pointer to the renderable this technique operates on.
OgreTechniqueGroup * parentOgreTechniqueGroup
a OgreTechniqueGroup pointer to the TechniqueGroup this technique is attached to.
Pass * | pass
a pointer to the pass this technique operates on.
ElementaryRenderable * parentRenderable
The renderable this technique operates on.
TechniqueGroup * parentTechniqueGroup
The TechniqueGroup this RenderedTechnique is attached to.
SharedRuns * sharedRuns
The SharedRuns this RenderedTechnique is attached to.
unsigned long | impostorUpdateInterval
update frequency of the impostor texture (image of the smaller system)
unsigned int | impostorResolution
resolution of the impostor texture
unsigned long | startFrame
offset in frame number used during update
bool | useDistCalc
flag to skip impostor update if object is far away (//not used)
bool | perspectiveRendering
sets if the impostor should be rendered with a perspective projection or orthogonal

Detailed Description

HierarchicalParticleSystemTechnique used in an OGRE environment.

Constructor & Destructor Documentation

OgreHierarchicalParticleSystemTechnique::OgreHierarchicalParticleSystemTechnique | ( | unsigned long | startFrame,
 |  | unsigned long | impostorUpdateInterval,
 |  | unsigned int | impostorResolution,
 |  | unsigned char | impostorTexID,
 |  | bool | useDistCalc,
 |  | bool | perspectiveRendering,
 |  | String | childPSysScriptName,
 |  | bool | useOwnMaterial,
 |  | String | impostorMaterialName,
 |  | bool | useVParam,
 |  | String | VParamRadius,
 |  | bool | useFParam,
 |  | String | FParamRadius,
 |  | Pass * | pass,
 |  | OgreRenderable * | parentRenderable,
 |  | OgreTechniqueGroup * | parentTechniqueGroup
 | ) |  |

Constructor.

Parameters:
startFrame | adds an offset to the current frame number to help evenly distribute updates between frames
impostorUpdateInterval | update frequency of the impostor texture (image of the smaller system)
impostorResolution | resolution of the impostor texture
impostorTexID | the id of the texture unit state the impostor image should be bound to
useDistCalc | flag to skip impostor update if object is far away (//not used)
perspectiveRendering | sets if the impostor should be rendered with a perspective projection or orthogonal
childPSysScriptName | name of the small particle system script
useOwnMaterial | use the material for the smaller system that was defined in the particle script
impostorMaterialName | use this specific material for the small particle system
useVParam | bound particle radius to a gpu vertex program parameter
VParamRadius | name of the gpu vertex program parameter the particle radius should be bound to
useFParam | bound particle radius to a gpu fragment program parameter
FParamRadius | name of the gpu fragment program parameter the particle radius should be bound to
pass | the pass to operate on
parentRenderable | the object to operate on
parentTechniqueGroup | the TechniqueGroup this RenderedTechnique is attached to

Member Function Documentation

RenderingRun * OgreHierarchicalParticleSystemTechnique::createChildPSysRenderingRun ( ) [protected, virtual]

Creates the ChildParticleSystemRenderingRun needed by this technique.

Returns:
pointer to the ChildParticleSystemRenderingRun created instance

Implements HierarchicalParticleSystemTechnique.

void OgreHierarchicalParticleSystemTechnique::impostorChanged ( RenderingRun * run ) [protected, virtual]

Called if the impostor rendering run changed.

Parameters:
run pointer to the new ChildParticleSystemRenderingRun instance to use

Implements HierarchicalParticleSystemTechnique.

void OgreHierarchicalParticleSystemTechnique::impostorUpdated ( RenderingRun * run ) [protected, virtual]

Called if the impostor rendering run is updated.

Parameters:
run pointer to the updated ChildParticleSystemRenderingRu.

Implements HierarchicalParticleSystemTechnique.

virtual OgreRenderTechnique* OgreRenderTechnique::asOgreRenderTechnique ( ) [inline, virtual, inherited]

Conversion to OgreRenderTechnique.

This function is needed because of virtual inheritance.

Reimplemented from RenderTechnique.

virtual void RenderTechnique::update ( unsigned long frameNum ) [inline, virtual, inherited]

Updates the resources in the given frame.

A RenderTechnique is usually need some resources from several runs, so these runs will be updated.

Parameters:
frameNum the actual framenumber

Reimplemented in ColorCubeMapRenderTechnique, ConvolvedCubeMapRenderTechnique, DistanceCubeMapRenderTechnique, HierarchicalParticleSystemTechnique, IllumVolumeRenderTechnique, OgreCausticReceiverRenderTechnique, OgreColorCubeMapRenderTechnique, OgreConvolvedCubeMapRenderTechnique, OgreDepthShadowReceiverRenderTechnique, OgreDistanceCubeMapRenderTechnique, OgreFireRenderTechnique, OgrePathMapRenderTechnique, and OgreSBBRenderTechnique.

virtual void RenderTechnique::runChanged | ( | RenderingRunType | runType,
 |  | RenderingRun * | run |
 | ) |  |  | [inline, virtual, inherited]

Called after one of he shared runs changes.

Parameters:
runType | enum describing the type of the changed run
run | pointer to the changed RenderingRun

Reimplemented in CausticCasterRenderTechnique, ColorCubeMapRenderTechnique, ConvolvedCubeMapRenderTechnique, CubeMapRenderTechnique, DistanceCubeMapRenderTechnique, HierarchicalParticleSystemTechnique, and IllumVolumeRenderTechnique.

virtual void RenderTechnique::runUpdated | ( | RenderingRunType | runType,
 |  | RenderingRun * | run |
 | ) |  |  | [inline, virtual, inherited]

Called after one of he shared runs updates.

Parameters:
runType | enum describing the type of the updated run
run | pointer to the updated RenderingRun

Reimplemented in CausticCasterRenderTechnique, ColorCubeMapRenderTechnique, CubeMapRenderTechnique, DistanceCubeMapRenderTechnique, HierarchicalParticleSystemTechnique, and IllumVolumeRenderTechnique.

void HierarchicalParticleSystemTechnique::update ( unsigned long frameNum ) [virtual, inherited]

Updates the resources in the given frame.

A RenderTechnique is usually need some resources from several runs, so these runs will be updated.

Parameters:
frameNum the actual framenumber

Reimplemented from RenderTechnique.

void HierarchicalParticleSystemTechnique::runChanged | ( | RenderingRunType | runType,
 |  | RenderingRun * | run |
 | ) |  |  | [virtual, inherited]

Called after one of he shared runs changes.

Parameters:
runType | enum describing the type of the changed run
run | pointer to the changed RenderingRun

Reimplemented from RenderTechnique.

void HierarchicalParticleSystemTechnique::runUpdated | ( | RenderingRunType | runType,
 |  | RenderingRun * | run |
 | ) |  |  | [virtual, inherited]

Called after one of he shared runs updates.

Parameters:
runType | enum describing the type of the updated run
run | pointer to the updated RenderingRun

Reimplemented from RenderTechnique.

Generated on Wed Mar 28 11:48:56 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: OgreHierarchicalParticleSystemTechniqueFactory Class Reference

OgreHierarchicalParticleSystemTechniqueFactory Class Reference

RenderTechniqueFactory to create OgreHierarchicalParticleSystemTechnique instances. More...

Inheritance diagram for OgreHierarchicalParticleSystemTechniqueFactory:

RenderTechniqueFactory List of all members.

Public Member Functions

OgreHierarchicalParticleSystemTechniqueFactory ()
Technique factory.
OgreRenderTechnique * | createInstance (IllumTechniqueParams *params, Pass *pass, OgreRenderable *parentRenderable, OgreTechniqueGroup *parentTechniqueGroup)
Creates a RenderTechnique of the factory type.
bool | isType (String type)
Returns if this factory can create a RenderTechnique of the given type.
virtual void | parseParams (IllumTechniqueParams *params)
parses parameters from the material file.

Protected Types

typedef void(*) | ILLUM_ATTRIBUTE_PARSER (String &params, RenderTechniqueFactory *factory)
function for parsing RenderTechnique attributes
typedef std::map< String,
ILLUM_ATTRIBUTE_PARSER > 		AttribParserList
Keyword-mapped attribute parsers.

Protected Attributes

AttribParserList attributeParsers
map of parser functions
String | typeName
factoryname

Detailed Description

RenderTechniqueFactory to create OgreHierarchicalParticleSystemTechnique instances.

Member Typedef Documentation

typedef void(*) RenderTechniqueFactory::ILLUM_ATTRIBUTE_PARSER(String &params, RenderTechniqueFactory *factory) [protected, inherited]

function for parsing RenderTechnique attributes

Parameters:
params attribute value stored in a String

Member Function Documentation

OgreRenderTechnique * OgreHierarchicalParticleSystemTechniqueFactory::createInstance | ( | IllumTechniqueParams * | params,
 |  | Pass * | pass,
 |  | OgreRenderable * | parentRenderable,
 |  | OgreTechniqueGroup * | parentTechniqueGroup |
 | ) |  |  | [virtual]

Creates a RenderTechnique of the factory type.

Parameters:
params | containes constructor parameters as NameValuePairList
pass | the Pass to use in RenderTechnique constructor
pass | the parentRenderable to pass to RenderTechnique constructor
pass | the parentTechniqueGroup to pass to RenderTechnique constructor

Implements RenderTechniqueFactory.

bool RenderTechniqueFactory::isType ( String type ) [inline, inherited]

Returns if this factory can create a RenderTechnique of the given type.

Parameters:
type RenderTechnique type

void RenderTechniqueFactory::parseParams ( IllumTechniqueParams * params ) [virtual, inherited]

parses parameters from the material file.

The parsed parameters will be passed to the new RenderTechnique's constructor.

Parameters:
params pointer to the IllumTechniqueParams structure that was read from the material script and containes the parameters to be parsed.

Generated on Wed Mar 28 11:48:56 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: OgreIlluminationManager Class Reference

OgreIlluminationManager Class Reference

Implementation of IlluminationManager in an OGRE environment. More...

List of all members.

Public Member Functions

void | addUpdateListener (UpdateListener *l)
Registers an UpdateListener instance.
void | addRenderTechniqueFactory (RenderTechniqueFactory *factory)
registers a RenderTechniqueFactory
float | getMaxJoinRadius ()
retirieves the maximum bounding sphere radius with two SharedRuns can be joined.
float | getMaxJoinRadius (RenderingRunType type)
Retirieves the maximum shared bounding sphere radius for a given run type.
void | setMaxJoinRadius (float rad)
sets the maximum bounding sphere radius with two SharedRuns can be joined for all run type.
void | setMaxJoinRadius (RenderingRunType type, float rad)
Sets the maximum shared bounding sphere radius for a given run type.
void | setFocusingMapSize (unsigned int size)
void | setPhaseTextureSize (unsigned int size)
void | setShadowMapSize (unsigned int size)
void | update (unsigned long frameNumber, RenderTarget *rt)
The function to be called to render one frame.
void | initTechniques ()
searches for RenderTechniques in materials and creates them for all objects.
void | initTechniques (Entity *e)
searches for RenderTechniques in materials and creates them for an Entity.
void | initTechniques (BillboardSet *bbs, ParticleSystem *sys)
searches for RenderTechniques in materials and creates them for a Billboardset.
Camera * | getMainCamera ()
Returns a pointer to the player camera.
Viewport * | getMainViewport ()
Returns a pointer to the viewport attached to the player camera.
void | setMainCamera (Camera *camera)
Sets the player camera.
void | setMainViewport (Viewport *viewport)
Sets the viewport attached to the player camera.
void | sharedRunSplit (SharedRuns *old, SharedRuns *new1, SharedRuns *new2)
The function to be called when a shared run is splitted.
void | sharedRunJoin (SharedRuns *old1, SharedRuns *old2, SharedRuns *newsr)
The function to be called when two shared runs are joined.
void | joinSharedRuns ()
Joins shared runs if needed.
void | addSharedRuns (SharedRuns *runs)
Register a shared run object.
void | getNearestCausticCasters (Vector3 position, std::vector< OgreSharedRuns * > *nearestcasters, unsigned int maxCount)
Searches for the nearest object groups (SharedRuns) that are caustic casters from a given point.
void | createGlobalRun (RenderingRunType runType)
Creates a global RenderingRun of the given type.
RenderingRun * | getGlobalRun (RenderingRunType runType)
Returns the global RendderingRun with the given type.
void | updateGlobalRun (RenderingRunType runType, unsigned long frameNum)
Updates a global RenderingRun with the given type.
void | createPerLightRun (String lightName, RenderingRunType runType)
Creates a RenderingRun attached to a lightsource with the given type.
RenderingRun * | getPerLightRun (String lightName, RenderingRunType runType)
Retuns a RenderingRun attached to a lightsource with the given type.
void | updatePerLightRun (String lightName, RenderingRunType runType, unsigned long frameNum)
Updates a RenderingRun attached to a lightsource with the given type.
void | savePhaseTextureToFile (String filename)
Saves the phase texture to the given file.
bool | frameStarted (const FrameEvent &evt)
Frame listener event handler function.
bool | getUseLISPSM ()
bool | getFocusingShadowMap ()
bool | getBlurShadowMap ()
void | setUseLISPSM (bool use)
void | setFocusingSM (bool use)
void | setBlurShadowMap (bool use)
void | setShadowMapMaterialName (String name)
void | addPathMapClusters (String subEntityName, PathMapClusters clusters)
Registers a PathMapClusters structure for a given subentity.
PathMapClusters * | getPathMapClusters (String subEntityName)
Returns the PathMapClusters structure registered for a given subentity.
void | addPathMapEntryPoint (PathMapEntryPoint p)
Adds a new PathMapEntryPoint cluster to the entrypoint list.
std::vector< PathMapEntryPoint > & | getPathMapEntryPoints ()
Returns the list of entrypoints.
void | addPathMapClusterLength (unsigned int l)
Adds a new cluster size.
unsigned int | getPathMapClusterLengthsSize ()
Gets the number of clusters.
unsigned int | getPathMapClusterLength (unsigned int index)
Gets the size of the given cluster.
float | getAreaLightRadius ()
void | setAreaLigtRadius (float radius)
void | setFireRenderTargetSize (int size)
Sets the fire rendertarget - frame buffer resolution ratio.

Static Public Member Functions

static OgreIlluminationManager & | getSingleton ()
Returns the one and only OgreIlluminationManager instance.

Protected Member Functions

OgreIlluminationManager ()
Protected constructor (OgreIlluminationManager is a singleton).
virtual | ~OgreIlluminationManager ()
Protected destructor.
void | fillVisibleList (RenderQueue *rq)
Searches for visible renderables with valid TechniqueGroups in a renderqueue.
void | createTechnique (IllumTechniqueParams *params, Pass *pass, OgreRenderable *rend, OgreSharedRuns *sRuns)
creates a specific type of RenderTechnique for a Renderable's pass.
BillboardSet * | findRenderableInParticleSystem (ParticleSystem *system)
A helper function to find the renderable object attached to a particle system (ONLY BILLBOARDSETS ARE SUPPORTED).
void | preAllUpdates ()
Fires preAllUpdates for registered UpdateListeners.
void | postAllUpdates ()
Fires postAllUpdates for registered UpdateListeners.

Protected Attributes

std::list< RenderTechniqueFactory * > | techniqueFactories
registered RenderTechniqueFactories
float | maxRad
The maximum bounding sphere radius that groupped objects ( see SharedRuns class ) can have.
unsigned int | focusingMapSize
Size of the focusing map.
unsigned int | shadowMapSize
Size of the shadow maps.
float | areaLightRadius
Size of area lights for soft shadows.
bool | useLISPSM
Sets if light space perspective shadow mapping should be used.
bool | blurSM
Sets if the shadow maps should be blurred.
bool | focusingSM
Sets if shadow maps should be focused.
String | shadowMapMaterialName
The material name that should be used during rendering the shadow maps.
unsigned int | phaseTextureSize
Size of the phase texture.
std::map< RenderingRunType,
float > 		maxRads
Stores maximum bounding radius values for each rendering run type.
std::map< String, PathMapClusters > | pathMapClusters
Stores PathMapClusters structures for each subentity.
std::vector< PathMapEntryPoint > | pathMapEntryPoints
PathMapEntryPoint list.
std::vector< unsigned int > | pathMapClusterLengths
Stores cluster size for each path map cluster.
Camera * | mainCamera
The camera attached to the player.
Viewport * | mainViewport
The viewport of the player camera.
VisibleFinderVisitor * | visitor
VisibleFinderVisitor instance.
std::vector< const Renderable * > | visibleObjects
Vector containing visible renderables with valid TechniqueGroups that must be refreshed.
std::list< SharedRuns * > | sharedRunRoots
List containing SharedRuns roots.
OgreSharedRuns globalSharedRuns
Group of RenderingRuns that are used globaly.
std::map< String, OgreSharedRuns * > | perLightRuns
Stores groups of RenderingRuns that are attached to individual light sources.
std::vector< UpdateListener * > | updateListeners
Stores registered UpdateListeners.

Static Protected Attributes

static OgreIlluminationManager * | instance
The one and only OgreIlluminationManager instance.

Detailed Description

Implementation of IlluminationManager in an OGRE environment.

Member Function Documentation

void OgreIlluminationManager::fillVisibleList ( RenderQueue * rq ) [protected]

Searches for visible renderables with valid TechniqueGroups in a renderqueue.

Parameters:
rq pointer to the RenderQueue instance to search in

void OgreIlluminationManager::createTechnique | ( | IllumTechniqueParams * | params,
 |  | Pass * | pass,
 |  | OgreRenderable * | rend,
 |  | OgreSharedRuns * | sRuns |
 | ) |  |  | [protected]

creates a specific type of RenderTechnique for a Renderable's pass.

It searches all registered RenderTechniqueFactories.

BillboardSet * OgreIlluminationManager::findRenderableInParticleSystem ( ParticleSystem * system ) [protected]

A helper function to find the renderable object attached to a particle system (ONLY BILLBOARDSETS ARE SUPPORTED).

Parameters:
system pointer to the ParticleSystem instance to search in
Returns:
pointer the connected BillboardSet instance

void OgreIlluminationManager::preAllUpdates ( ) [protected]

Fires preAllUpdates for registered UpdateListeners.

This is called in each frame before updating the RenderTechniques.

void OgreIlluminationManager::postAllUpdates ( ) [protected]

Fires postAllUpdates for registered UpdateListeners.

This is called in each frame after updating the RenderTechniques.

void OgreIlluminationManager::addUpdateListener ( UpdateListener * l ) [inline]

Registers an UpdateListener instance.

See also:
UpdateListener

float OgreIlluminationManager::getMaxJoinRadius ( ) [inline]

retirieves the maximum bounding sphere radius with two SharedRuns can be joined.

Only valid fi all run types use the same radius. This can be set with calling setMaxJoinRadius().

See also:
setMaxJoinRadius

void OgreIlluminationManager::setFocusingMapSize ( unsigned int size ) [inline]

See also:
focusingMapSize

void OgreIlluminationManager::setPhaseTextureSize ( unsigned int size ) [inline]

See also:
phaseTextureSize

void OgreIlluminationManager::setShadowMapSize ( unsigned int size ) [inline]

See also:
shadowMapSize

void OgreIlluminationManager::update | ( | unsigned long | frameNumber,
 |  | RenderTarget * | rt
 | ) |  |

The function to be called to render one frame.

This is the main refreshing function. It seasrches for visible objects, manages shared runs, updates render techniques and finally renders the scene to framebuffer.

Parameters:
frameNumber | current framenumber
rt | the rendertarget window. Needed to find the viewports that need to be refresh.

Camera* OgreIlluminationManager::getMainCamera ( ) [inline]

Returns a pointer to the player camera.

Returns:
pointer to the main player camera. Needed by RenderTechnique and RenderingRun classes.

Viewport* OgreIlluminationManager::getMainViewport ( ) [inline]

Returns a pointer to the viewport attached to the player camera.

Returns:
pointer to the viewport. Needed by RenderTechnique and RenderingRun classes.

void OgreIlluminationManager::setMainCamera ( Camera * camera ) [inline]

Sets the player camera.

Parameters:
camera pointer to the main player camera

void OgreIlluminationManager::setMainViewport ( Viewport * viewport ) [inline]

Sets the viewport attached to the player camera.

Parameters:
viewport pointer to the viewport

void OgreIlluminationManager::sharedRunSplit | ( | SharedRuns * | old,
 |  | SharedRuns * | new1,
 |  | SharedRuns * | new2
 | ) |  |

The function to be called when a shared run is splitted.

Parameters:
old | pointer to the SharedRuns instance that is split
new1 | pointer to one of the SharedRuns instance that remain after split
new2 | pointer to the other SharedRuns instance that remain after split

void OgreIlluminationManager::sharedRunJoin | ( | SharedRuns * | old1,
 |  | SharedRuns * | old2,
 |  | SharedRuns * | newsr
 | ) |  |

The function to be called when two shared runs are joined.

Parameters:
old1 | pointer to one of the SharedRuns instance that are joined
old2 | pointer to the other SharedRuns instance that are joined
newsr | pointer to the resulting parent SharedRuns instance

void OgreIlluminationManager::joinSharedRuns ( )

Joins shared runs if needed.

Searches the registered shared run roots and join them if necessary (they are close enough).

void OgreIlluminationManager::addSharedRuns ( SharedRuns * runs )

Register a shared run object.

Only called when new techniques are created.

Parameters:
runs pointer to the SharedRuns instance to add

void OgreIlluminationManager::getNearestCausticCasters | ( | Vector3 | position,
 |  | std::vector< OgreSharedRuns * > * | nearestcasters,
 |  | unsigned int | maxCount
 | ) |  |

Searches for the nearest object groups (SharedRuns) that are caustic casters from a given point.

Parameters:
position | the point to obtain distances from
nearestcasters | vector to put the nearest caustic caster SharedRuns to
maxCount | the maximum number of nearest casters to search for

void OgreIlluminationManager::createGlobalRun ( RenderingRunType runType )

Creates a global RenderingRun of the given type.

If a RenderingRun with the given type already exist there is nothing to do.

Parameters:
runType type enum of the RenderingRun to create

RenderingRun * OgreIlluminationManager::getGlobalRun ( RenderingRunType runType )

Returns the global RendderingRun with the given type.

Parameters:
runType type enum of the RenderingRun to retrieve
Returns:
pointer to the RenderingRun, NULL if no RenderingRun with the given type exists

void OgreIlluminationManager::updateGlobalRun | ( | RenderingRunType | runType,
 |  | unsigned long | frameNum
 | ) |  |

Updates a global RenderingRun with the given type.

Parameters:
runType | type enum of the RenderingRun to update
frameNum | current framenumber

void OgreIlluminationManager::createPerLightRun | ( | String | lightName,
 |  | RenderingRunType | runType
 | ) |  |

Creates a RenderingRun attached to a lightsource with the given type.

Parameters:
lightName | name of the lightsource
runType | type enum of the RenderingRun to create

create sharedruns

RenderingRun * OgreIlluminationManager::getPerLightRun | ( | String | lightName,
 |  | RenderingRunType | runType
 | ) |  |

Retuns a RenderingRun attached to a lightsource with the given type.

Parameters:
lightName | name of the lightsource
runType | type enum of the RenderingRun to return
Returns:
pointer to the RenderingRun, NULL if no RenderingRun with the given type exists

void OgreIlluminationManager::updatePerLightRun | ( | String | lightName,
 |  | RenderingRunType | runType,
 |  | unsigned long | frameNum
 | ) |  |

Updates a RenderingRun attached to a lightsource with the given type.

Parameters:
lightName | name of the lightsource
runType | type enum of the RenderingRun to update
frameNum | current framenumber

bool OgreIlluminationManager::frameStarted ( const FrameEvent & evt ) [inline]

Frame listener event handler function.

Inherited from FrameListener. Called at the beginning of each frame.

bool OgreIlluminationManager::getUseLISPSM ( ) [inline]

See also:
useLISPSM

bool OgreIlluminationManager::getFocusingShadowMap ( ) [inline]

See also:
focusingSM

bool OgreIlluminationManager::getBlurShadowMap ( ) [inline]

See also:
blurSM

void OgreIlluminationManager::setUseLISPSM ( bool use ) [inline]

See also:
useLISPSM

void OgreIlluminationManager::setFocusingSM ( bool use ) [inline]

See also:
focusingSM

void OgreIlluminationManager::setBlurShadowMap ( bool use ) [inline]

See also:
blurSM

void OgreIlluminationManager::setShadowMapMaterialName ( String name ) [inline]

See also:
shadowMapMaterialName

void OgreIlluminationManager::addPathMapClusters | ( | String | subEntityName,
 |  | PathMapClusters | clusters |
 | ) |  |  | [inline]

Registers a PathMapClusters structure for a given subentity.

Parameters:
subEntityName | name of te subentity
clusters | the PathMapClusters that belongs to the given subentity

PathMapClusters* OgreIlluminationManager::getPathMapClusters ( String subEntityName ) [inline]

Returns the PathMapClusters structure registered for a given subentity.

Parameters:
subEntityName name of te subentity
Returns:
pointer to the PathMapClusters structure that belongs to the given subentity

unsigned int OgreIlluminationManager::getPathMapClusterLength ( unsigned int index ) [inline]

Gets the size of the given cluster.

Parameters:
index of the cluster
Returns:
the size of the cluster

float OgreIlluminationManager::getAreaLightRadius ( ) [inline]

See also:
areaLightRadius

void OgreIlluminationManager::setAreaLigtRadius ( float radius ) [inline]

See also:
areaLightRadius

Member Data Documentation

float OgreIlluminationManager::maxRad [protected]

The maximum bounding sphere radius that groupped objects ( see SharedRuns class ) can have.

See also:
canJoin

joinRuns

unsigned int OgreIlluminationManager::focusingMapSize [protected]

Size of the focusing map.

This map is used if the shadow maps should be focused.

bool OgreIlluminationManager::blurSM [protected]

Sets if the shadow maps should be blurred.

Used in variance shadow mapping.

String OgreIlluminationManager::shadowMapMaterialName [protected]

The material name that should be used during rendering the shadow maps.

There are several predefined materials that can be used to render shadow maps:

  • GTP/Basic/Depth : writes projected depth values of front facing polygons
  • GTP/Basic/DepthCCW : writes projected depth values of back facing polygons
  • GTP/Basic/Distance : writes distance values (from eyepoint) of front facing polygons
  • GTP/Basic/DistanceCCW : writes distance values (from eyepoint) of back facing polygons
  • GTP/Basic/Distance_Normalized : writes normalized distance values (distance values devided by projection farplane - which is set to the attenuation range in case of shadow maps) of front facing polygons
  • GTP/Basic/Distance_NormalizedCCW : writes normalized distance values of back facing polygons

The default material is GTP/Basic/Distance_NormalizedCCW. Recommended materials for different light types:

  • spot and point lights : GTP/Basic/Distance_NormalizedCCW or GTP/Basic/Distance_Normalized
  • directional lights : GTP/Basic/Depth or GTP/Basic/DepthCCW

std::map<String, PathMapClusters> OgreIlluminationManager::pathMapClusters [protected]

Stores PathMapClusters structures for each subentity.

The String key is the name of the subentity.

class VisibleFinderVisitor* OgreIlluminationManager::visitor [protected]

VisibleFinderVisitor instance.

Used for adding visible renderables with valid TechniqueGroups to the visibleObjects vector.

std::list<SharedRuns*> OgreIlluminationManager::sharedRunRoots [protected]

List containing SharedRuns roots.

It is the IlluminationManager's task to find the SharedRuns which can be joined. Only the root SharedRuns needs to be checked.

OgreSharedRuns OgreIlluminationManager::globalSharedRuns [protected]

Group of RenderingRuns that are used globaly.

Some RenderingRuns have only one instance per application (for example scene depth map). These resources are shared between all RenderTechniques.

std::map<String, OgreSharedRuns*> OgreIlluminationManager::perLightRuns [protected]

Stores groups of RenderingRuns that are attached to individual light sources.

These resources need separate instances for each lightsource ( for example depth shadow maps). They are grouped by the name of the lightsource.

Generated on Wed Mar 28 11:48:56 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: OgreIllumVolumeRenderTechnique Class Reference

OgreIllumVolumeRenderTechnique Class Reference

IllumVolumeRenderTechnique used in an OGRE environment. More...

Inheritance diagram for OgreIllumVolumeRenderTechnique:

OgreRenderTechnique IllumVolumeRenderTechnique RenderTechnique RenderTechnique List of all members.

Public Member Functions

OgreIllumVolumeRenderTechnique (unsigned long startFrame, unsigned long illumVolumeUpdateInterval, unsigned int illumTextureResolution, unsigned int textureDepth, unsigned char illumTexID, bool useDistCalc, String materialName, String lightMatrixGPUParamName, bool useHierarchicalImpostor, unsigned char impostorTexID, Pass *pass, OgreRenderable *parentRenderable, OgreTechniqueGroup *parentTechniqueGroup)
Constructor.
~OgreIllumVolumeRenderTechnique ()
Destructor.
virtual OgreRenderTechnique * | asOgreRenderTechnique ()
Conversion to OgreRenderTechnique.
virtual void | update (unsigned long frameNum)
Updates the resources in the given frame.
virtual void | runChanged (RenderingRunType runType, RenderingRun *run)
Called after one of he shared runs changes.
virtual void | runUpdated (RenderingRunType runType, RenderingRun *run)
Called after one of he shared runs updates.
ElementaryRenderable * getParentRenderable ()
Retrieves the renderable this technique operates on.
void | update (unsigned long frameNum)
Updates the resources in the given frame.
void | runChanged (RenderingRunType runType, RenderingRun *run)
Called after one of he shared runs changes.
void | runUpdated (RenderingRunType runType, RenderingRun *run)
Called after one of he shared runs updates.

Protected Member Functions

RenderingRun * createLightVolumeRenderingRun ()
creates a light volume rendering run needed by this technique
void | lightVolumeChanged (RenderingRun *run)
Called if the LightVolumeRenderingRun is chaged.
void | lightVolumeUpdated (RenderingRun *run)
Called if the LightVolumeRenderingRun is updated.
void | hierarchicalImpostorUpdated (RenderingRun *run)
Called if the ChildParticleSystemRenderingRun is chaged.

Protected Attributes

String | materialName
the name of the material that is used while rendering the light volume
unsigned char | illumTexID
the id of the texture unit state the resulting illumevolume should be bound to
String | lightMatrixGPUParamName
the name of the gpu program parameter where the light matrix should be bound to
unsigned char | impostorTexID
the id of the texture unit state where the impostor image of the smaller system should be bound to
OgreRenderable * parentOgreRenderable
a OgreRenderable pointer to the renderable this technique operates on.
OgreTechniqueGroup * parentOgreTechniqueGroup
a OgreTechniqueGroup pointer to the TechniqueGroup this technique is attached to.
Pass * | pass
a pointer to the pass this technique operates on.
ElementaryRenderable * parentRenderable
The renderable this technique operates on.
TechniqueGroup * parentTechniqueGroup
The TechniqueGroup this RenderedTechnique is attached to.
SharedRuns * sharedRuns
The SharedRuns this RenderedTechnique is attached to.
unsigned long | illumVolumeUpdateInterval
the update frequency of the light volume
unsigned int | illumTextureResolution
the resolution of the light volume texture
unsigned int | textureDepth
the number of layers to use (should be set to 1)
unsigned long | startFrame
offset in frame number used during update
bool | useDistCalc
flag to skip updates if the shaded particle system is far away (not used)
bool | useHierarchicalImpostor
set this flag to true if the particle system is a hierarchical particle system

Detailed Description

IllumVolumeRenderTechnique used in an OGRE environment.

Constructor & Destructor Documentation

OgreIllumVolumeRenderTechnique::OgreIllumVolumeRenderTechnique | ( | unsigned long | startFrame,
 |  | unsigned long | illumVolumeUpdateInterval,
 |  | unsigned int | illumTextureResolution,
 |  | unsigned int | textureDepth,
 |  | unsigned char | illumTexID,
 |  | bool | useDistCalc,
 |  | String | materialName,
 |  | String | lightMatrixGPUParamName,
 |  | bool | useHierarchicalImpostor,
 |  | unsigned char | impostorTexID,
 |  | Pass * | pass,
 |  | OgreRenderable * | parentRenderable,
 |  | OgreTechniqueGroup * | parentTechniqueGroup
 | ) |  |

Constructor.

Parameters:
startFrame | adds an offset to the current frame number to help evenly distribute updates between frames
illumVolumeUpdateInterval | the update frequency of the light volume
illumTextureResolution | the resolution of the light volume texture
textureDepth | the number of layers to use (should be set to 1)
illumTexID | the id of the texture unit state the resulting illumevolume should be bound to
useDistCalc | flag to skip updates if the shaded particle system is far away (not used)
materialName | the name of the material that is used while rendering the light volume
lightMatrixGPUParamName | the name of the gpu program parameter where the light matrix should be bound to
useHierarchicalImpostor | set this flag to true if the particle system is a hierarchical particle system
impostorTexID | the id of the texture unit state where the impostor image of the smaller system should be bound to
pass | the pass to operate on
parentRenderable | the object to operate on
parentTechniqueGroup | the TechniqueGroup this RenderedTechnique is attached to

Member Function Documentation

RenderingRun * OgreIllumVolumeRenderTechnique::createLightVolumeRenderingRun ( ) [protected, virtual]

creates a light volume rendering run needed by this technique

Returns:
pointer to the created LightVolumeRenderingRun instance

Implements IllumVolumeRenderTechnique.

void OgreIllumVolumeRenderTechnique::lightVolumeChanged ( RenderingRun * run ) [protected, virtual]

Called if the LightVolumeRenderingRun is chaged.

Parameters:
pointer to the new LightVolumeRenderingRun instance to use

Implements IllumVolumeRenderTechnique.

void OgreIllumVolumeRenderTechnique::lightVolumeUpdated ( RenderingRun * run ) [protected, virtual]

Called if the LightVolumeRenderingRun is updated.

Parameters:
pointer to the updated LightVolumeRenderingRun instance

Implements IllumVolumeRenderTechnique.

void OgreIllumVolumeRenderTechnique::hierarchicalImpostorUpdated ( RenderingRun * run ) [protected, virtual]

Called if the ChildParticleSystemRenderingRun is chaged.

Only called if this particle system is a hierarchical particle system.

Parameters:
pointer to the new ChildParticleSystemRenderingRun instance to use

Implements IllumVolumeRenderTechnique.

virtual OgreRenderTechnique* OgreRenderTechnique::asOgreRenderTechnique ( ) [inline, virtual, inherited]

Conversion to OgreRenderTechnique.

This function is needed because of virtual inheritance.

Reimplemented from RenderTechnique.

virtual void RenderTechnique::update ( unsigned long frameNum ) [inline, virtual, inherited]

Updates the resources in the given frame.

A RenderTechnique is usually need some resources from several runs, so these runs will be updated.

Parameters:
frameNum the actual framenumber

Reimplemented in ColorCubeMapRenderTechnique, ConvolvedCubeMapRenderTechnique, DistanceCubeMapRenderTechnique, HierarchicalParticleSystemTechnique, IllumVolumeRenderTechnique, OgreCausticReceiverRenderTechnique, OgreColorCubeMapRenderTechnique, OgreConvolvedCubeMapRenderTechnique, OgreDepthShadowReceiverRenderTechnique, OgreDistanceCubeMapRenderTechnique, OgreFireRenderTechnique, OgrePathMapRenderTechnique, and OgreSBBRenderTechnique.

virtual void RenderTechnique::runChanged | ( | RenderingRunType | runType,
 |  | RenderingRun * | run |
 | ) |  |  | [inline, virtual, inherited]

Called after one of he shared runs changes.

Parameters:
runType | enum describing the type of the changed run
run | pointer to the changed RenderingRun

Reimplemented in CausticCasterRenderTechnique, ColorCubeMapRenderTechnique, ConvolvedCubeMapRenderTechnique, CubeMapRenderTechnique, DistanceCubeMapRenderTechnique, HierarchicalParticleSystemTechnique, and IllumVolumeRenderTechnique.

virtual void RenderTechnique::runUpdated | ( | RenderingRunType | runType,
 |  | RenderingRun * | run |
 | ) |  |  | [inline, virtual, inherited]

Called after one of he shared runs updates.

Parameters:
runType | enum describing the type of the updated run
run | pointer to the updated RenderingRun

Reimplemented in CausticCasterRenderTechnique, ColorCubeMapRenderTechnique, CubeMapRenderTechnique, DistanceCubeMapRenderTechnique, HierarchicalParticleSystemTechnique, and IllumVolumeRenderTechnique.

void IllumVolumeRenderTechnique::update ( unsigned long frameNum ) [virtual, inherited]

Updates the resources in the given frame.

A RenderTechnique is usually need some resources from several runs, so these runs will be updated.

Parameters:
frameNum the actual framenumber

Reimplemented from RenderTechnique.

void IllumVolumeRenderTechnique::runChanged | ( | RenderingRunType | runType,
 |  | RenderingRun * | run |
 | ) |  |  | [virtual, inherited]

Called after one of he shared runs changes.

Parameters:
runType | enum describing the type of the changed run
run | pointer to the changed RenderingRun

Reimplemented from RenderTechnique.

void IllumVolumeRenderTechnique::runUpdated | ( | RenderingRunType | runType,
 |  | RenderingRun * | run |
 | ) |  |  | [virtual, inherited]

Called after one of he shared runs updates.

Parameters:
runType | enum describing the type of the updated run
run | pointer to the updated RenderingRun

Reimplemented from RenderTechnique.

Generated on Wed Mar 28 11:48:56 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: OgreIllumVolumeRenderTechniqueFactory Class Reference

OgreIllumVolumeRenderTechniqueFactory Class Reference

RenderTechniqueFactory to create OgreIllumVolumeRenderTechnique instances. More...

Inheritance diagram for OgreIllumVolumeRenderTechniqueFactory:

RenderTechniqueFactory List of all members.

Public Member Functions

OgreIllumVolumeRenderTechniqueFactory ()
Technique factory.
OgreRenderTechnique * | createInstance (IllumTechniqueParams *params, Pass *pass, OgreRenderable *parentRenderable, OgreTechniqueGroup *parentTechniqueGroup)
Creates a RenderTechnique of the factory type.
bool | isType (String type)
Returns if this factory can create a RenderTechnique of the given type.
virtual void | parseParams (IllumTechniqueParams *params)
parses parameters from the material file.

Protected Types

typedef void(*) | ILLUM_ATTRIBUTE_PARSER (String &params, RenderTechniqueFactory *factory)
function for parsing RenderTechnique attributes
typedef std::map< String,
ILLUM_ATTRIBUTE_PARSER > 		AttribParserList
Keyword-mapped attribute parsers.

Protected Attributes

AttribParserList attributeParsers
map of parser functions
String | typeName
factoryname

Detailed Description

RenderTechniqueFactory to create OgreIllumVolumeRenderTechnique instances.

Member Typedef Documentation

typedef void(*) RenderTechniqueFactory::ILLUM_ATTRIBUTE_PARSER(String &params, RenderTechniqueFactory *factory) [protected, inherited]

function for parsing RenderTechnique attributes

Parameters:
params attribute value stored in a String

Member Function Documentation

OgreRenderTechnique * OgreIllumVolumeRenderTechniqueFactory::createInstance | ( | IllumTechniqueParams * | params,
 |  | Pass * | pass,
 |  | OgreRenderable * | parentRenderable,
 |  | OgreTechniqueGroup * | parentTechniqueGroup |
 | ) |  |  | [virtual]

Creates a RenderTechnique of the factory type.

Parameters:
params | containes constructor parameters as NameValuePairList
pass | the Pass to use in RenderTechnique constructor
pass | the parentRenderable to pass to RenderTechnique constructor
pass | the parentTechniqueGroup to pass to RenderTechnique constructor

Implements RenderTechniqueFactory.

bool RenderTechniqueFactory::isType ( String type ) [inline, inherited]

Returns if this factory can create a RenderTechnique of the given type.

Parameters:
type RenderTechnique type

void RenderTechniqueFactory::parseParams ( IllumTechniqueParams * params ) [virtual, inherited]

parses parameters from the material file.

The parsed parameters will be passed to the new RenderTechnique's constructor.

Parameters:
params pointer to the IllumTechniqueParams structure that was read from the material script and containes the parameters to be parsed.

Generated on Wed Mar 28 11:48:56 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: OgreLightVolumeRenderingRun Class Reference

OgreLightVolumeRenderingRun Class Reference

LightVolumeRenderingRun used in an OGRE environment. More...

Inheritance diagram for OgreLightVolumeRenderingRun:

OgreRenderingRun LightVolumeRenderingRun RenderingRun RenderingRun RenderingRun List of all members.

Public Member Functions

OgreLightVolumeRenderingRun (OgreSharedRuns *sharedRuns, String name, unsigned long startFrame, unsigned long updateInterval, unsigned int resolution, unsigned int textureDepth, String materialName)
Constructor.
String | getLightVolumeTextureName ()
returns the name of the resulting light volume texture
void | refreshLight ()
Refreshes light camera matrices, called in each update.
Matrix4 | getLightViewProjectionMatrix ()
Returns the light matrix used while rendering the light volume.
OgreRenderingRun * asOgreRenderingRun ()
Conversion to OgreRenderRun.
OgreRenderingRun * asOgreRenderingRun ()
Conversion to OgreRenderRun.
bool | update (unsigned long frameNum)
Calls updateFrame() if the run needs update according to its starting frame and update interval and has not been allready updated in this frame.
virtual bool | canJoin (RenderingRun *run)
Returns true if two runs can be joined.

Protected Member Functions

void | updateFrame (unsigned long frameNum)
This function does the actual update in a frame.
void | createLightVolumeMap ()
Creates a light volume map.
Vector3 | getCubeMapFaceDirection (unsigned char faceId)
Returns a direction for a cubemap face id.
Vector3 | getCubeMapFaceDirection (unsigned char faceId)
Returns a direction for a cubemap face id.
Texture * | createCubeRenderTexture (String name, const Vector3 position, unsigned int resolution=512, PixelFormat format=PF_FLOAT16_RGBA, int numMips=0, ColourValue clearColor=ColourValue::Black)
Creates a cubemap texture.
Texture * | createCubeRenderTexture (String name, const Vector3 position, unsigned int resolution=512, PixelFormat format=PF_FLOAT16_RGBA, int numMips=0, ColourValue clearColor=ColourValue::Black)
Creates a cubemap texture.
void | setMaterialForRenderables (String &materialName, RenderQueue *rq)
Sets the given material for each Renderable in a RenderQueue.
void | setMaterialForRenderables (String &materialName, RenderQueue *rq, bool solidsonly=false)
Sets the given material for each Renderable in a RenderQueue.
void | setMaterialForVisibles (String &materialName, Camera *cam, bool shadowcastersonly=false)
Sets the given material for each Renderable visible from a given camera.
void | setMaterialForVisibles (String &materialName, Camera *cam, bool shadowcastersonly=false, bool solidsonly=false)
Sets the given material for each Renderable visible from a given camera.
void | restoreMaterials ()
Restores previously stored materials.
void | restoreMaterials ()
Restores previously stored materials.
void | renderFullscreenQuad (String materialName, RenderTarget *target)
Renderes a full screen quad on a given RendderTarget with a given material.
void | renderFullscreenQuad (String materialName, RenderTarget *target)
Renderes a full screen quad on a given RendderTarget with a given material.
void | renderPixelSprites (String &materialName, RenderTarget *rt, int width, int height)
Renderes sprites to pixels of the screen on a given RendderTarget with a given material.
void | renderPixelSprites (String &materialName, RenderTarget *rt, int width, int height)
Renderes sprites to pixels of the screen on a given RendderTarget with a given material.
void | renderFullscreenGrid (String &materialName, RenderTarget *rt, int width, int height)
Renders a grid onto the screen.
virtual bool | needUpdate (unsigned long frameNum)
Returns if this run needs update.

Protected Attributes

String | materialName
the name of the material should be used when rendering the light volume
Light * | light
pointer to the nearest light source to the particle system
Camera * | lightVolumeCamera
pointer to the camera used while rendering the light volume
OgreSharedRuns * sharedRuns
a pointer to the OgreSharedRuns this run belongs to
String | name
the name of the light volume texture that was created by this run
float | systemRadius
the radius of the particle system
std::map< Renderable *, String > | visibleObjects
map of Renderables which will be rendered with a given material
std::map< Renderable *, String > | visibleObjects
map of Renderables which will be rendered with a given material
SpriteSet * | pixelSprites
SpriteSet used in pixel sprite rendering.
BillboardSet * | pixelSprites
SpriteSet used in pixel sprite rendering.
String | spriteSetName
unique name of the SpriteSet used in pixel sprite rendering
Entity * | fullscreenGrid
Entity used in fullscreen grid rendering.
unsigned long | lastupdated
The number of the last frame this run was updated.
unsigned long | startFrame
The number of the frame this run should be updated first.
unsigned long | updateInterval
Refresh frequency in frames.
unsigned int | resolution
the resolution of the light volume map
unsigned int | textureDepth
number of layers (should be 1)

Static Protected Attributes

static MovablePlane * | fullScreenQuad
fulls screen quad plane used in full screen quad rendering
static MovablePlane * | fullScreenQuad
fulls screen quad plane used in full screen quad rendering
static Entity * | fullScreenQuadEntity
fulls screen quad Entity used in full screen quad rendering
static Entity * | fullScreenQuadEntity
fulls screen quad Entity used in full screen quad rendering
static SceneNode * | fullScreenQuadNode
fulls screen quad SceneNode used in full screen quad rendering
static SceneNode * | fullScreenQuadNode
fulls screen quad SceneNode used in full screen quad rendering

Detailed Description

LightVolumeRenderingRun used in an OGRE environment.

Constructor & Destructor Documentation

OgreLightVolumeRenderingRun::OgreLightVolumeRenderingRun | ( | OgreSharedRuns * | sharedRuns,
 |  | String | name,
 |  | unsigned long | startFrame,
 |  | unsigned long | updateInterval,
 |  | unsigned int | resolution,
 |  | unsigned int | textureDepth,
 |  | String | materialName
 | ) |  |

Constructor.

Parameters:
sharedRuns | a pointer to the OgreSharedRuns this run belongs to
name | the name of the light volume texture to be created
startFrame | adds an offset to the current frame number to help evenly distribute updates between frames
updateInterval | update frequency
resolution | light volume texture resolution
materialName | the name of the material should be used when rendering the light volume

Member Function Documentation

void OgreLightVolumeRenderingRun::updateFrame ( unsigned long frameNum ) [protected, virtual]

This function does the actual update in a frame.

Parameters:
frameNum current frame number

Implements LightVolumeRenderingRun.

OgreRenderingRun* OgreRenderingRun::asOgreRenderingRun ( ) [inline, virtual, inherited]

Conversion to OgreRenderRun.

This function is needed because of virtual inheritance.

Reimplemented from RenderingRun.

OgreRenderingRun* OgreRenderingRun::asOgreRenderingRun ( ) [inline, virtual, inherited]

Conversion to OgreRenderRun.

This function is needed because of virtual inheritance.

Reimplemented from RenderingRun.

Vector3 OgreRenderingRun::getCubeMapFaceDirection ( unsigned char faceId ) [protected, inherited]

Returns a direction for a cubemap face id.

This is a helper function to retrieve the normal direction of a given cubemap face.

Parameters:
faceId the number of the face

Vector3 OgreRenderingRun::getCubeMapFaceDirection ( unsigned char faceId ) [protected, inherited]

Returns a direction for a cubemap face id.

This is a helper function to retrieve the normal direction of a given cubemap face.

Parameters:
faceId the number of the face

Texture * OgreRenderingRun::createCubeRenderTexture | ( | String | name,
 |  | const Vector3 | position,
 |  | unsigned int | resolution = 512,
 |  | PixelFormat | format = PF_FLOAT16_RGBA,
 |  | int | numMips = 0,
 |  | ColourValue | clearColor = ColourValue::Black |
 | ) |  |  | [protected, inherited]

Creates a cubemap texture.

This is a helper function to easily create a cubemap texture and automaticly attach viewports to each face so it can be used as a rendertarget.

Parameters:
name | the name of the texture to be created
position | the initial position of the cubemap
resolution | the resolution of one cubemapface
format | the pixel format of the cubemap
numMips | the number of mipmap levels
clearColor | initial color

Texture* OgreRenderingRun::createCubeRenderTexture | ( | String | name,
 |  | const Vector3 | position,
 |  | unsigned int | resolution = 512,
 |  | PixelFormat | format = PF_FLOAT16_RGBA,
 |  | int | numMips = 0,
 |  | ColourValue | clearColor = ColourValue::Black |
 | ) |  |  | [protected, inherited]

Creates a cubemap texture.

This is a helper function to easily create a cubemap texture and automaticly attach viewports to each face so it can be used as a rendertarget.

Parameters:
name | the name of the texture to be created
position | the initial position of the cubemap
resolution | the resolution of one cubemapface
format | the pixel format of the cubemap
numMips | the number of mipmap levels
clearColor | initial color

void OgreRenderingRun::setMaterialForRenderables | ( | String & | materialName,
 |  | RenderQueue * | rq |
 | ) |  |  | [protected, inherited]

Sets the given material for each Renderable in a RenderQueue.

This is a helper function to set a material to each element of a previously filled Renderque. The orginal material of the Renderables are stored so they can be restored later. The function also tells the current SceneManager not to search for visible objects, as we are going to use the given RenderQueue during the next rendering.

Parameters:
materialName | the name of the material to set for the Renderables
rq | pointer to the filled Renderqueue instance to set material for

void OgreRenderingRun::setMaterialForRenderables | ( | String & | materialName,
 |  | RenderQueue * | rq,
 |  | bool | solidsonly = false |
 | ) |  |  | [protected, inherited]

Sets the given material for each Renderable in a RenderQueue.

This is a helper function to set a material to each element of a previously filled Renderque. The orginal material of the Renderables are stored so they can be restored later. The function also tells the current SceneManager not to search for visible objects, as we are going to use the given RenderQueue during the next rendering.

Parameters:
materialName | the name of the material to set for the Renderables
rq | pointer to the filled Renderqueue instance to set material for

void OgreRenderingRun::setMaterialForVisibles | ( | String & | materialName,
 |  | Camera * | cam,
 |  | bool | shadowcastersonly = false |
 | ) |  |  | [protected, inherited]

Sets the given material for each Renderable visible from a given camera.

This helper function is similar to setMaterialForRenderables but it is also responsible for filling the RenderQueue. First the RenderQueue of the current SceneManager fill be filled with the visible objects seen from the given camera. Then the required material will be set for each element of the RenderQueue. The orginal material of the Renderables are stored so they can be restored later. The function also tells the current SceneManager not to search for visible objects, as we are going to use the filled RenderQueue during the next rendering.

Parameters:
materialName | the name of the material to set for the Renderables
cam | pointer to the camera from which visible objects should be searched
shadowcastersonly | flag to search for only shadow casters

void OgreRenderingRun::setMaterialForVisibles | ( | String & | materialName,
 |  | Camera * | cam,
 |  | bool | shadowcastersonly = false,
 |  | bool | solidsonly = false |
 | ) |  |  | [protected, inherited]

Sets the given material for each Renderable visible from a given camera.

This helper function is similar to setMaterialForRenderables but it is also responsible for filling the RenderQueue. First the RenderQueue of the current SceneManager fill be filled with the visible objects seen from the given camera. Then the required material will be set for each element of the RenderQueue. The orginal material of the Renderables are stored so they can be restored later. The function also tells the current SceneManager not to search for visible objects, as we are going to use the filled RenderQueue during the next rendering.

Parameters:
materialName | the name of the material to set for the Renderables
cam | pointer to the camera from which visible objects should be searched
shadowcastersonly | flag to search for only shadow casters

void OgreRenderingRun::restoreMaterials ( ) [protected, inherited]

Restores previously stored materials.

This helper function is typically used after a setMaterialForRenderables or setMaterialForVisibles call and a rendering process to restore the original material settings. The function also tells the current SceneManager to search for visible objects, as this is the default behaviour of SceneManager.

void OgreRenderingRun::restoreMaterials ( ) [protected, inherited]

Restores previously stored materials.

This helper function is typically used after a setMaterialForRenderables or setMaterialForVisibles call and a rendering process to restore the original material settings. The function also tells the current SceneManager to search for visible objects, as this is the default behaviour of SceneManager.

void OgreRenderingRun::renderFullscreenQuad | ( | String | materialName,
 |  | RenderTarget * | target |
 | ) |  |  | [protected, inherited]

Renderes a full screen quad on a given RendderTarget with a given material.

Parameters:
materialName | the name of the material bind to the quad
target | the RenderTarget the quad should be rendered on

void OgreRenderingRun::renderFullscreenQuad | ( | String | materialName,
 |  | RenderTarget * | target |
 | ) |  |  | [protected, inherited]

Renderes a full screen quad on a given RendderTarget with a given material.

Parameters:
materialName | the name of the material bind to the quad
target | the RenderTarget the quad should be rendered on

void OgreRenderingRun::renderPixelSprites | ( | String & | materialName,
 |  | RenderTarget * | rt,
 |  | int | width,
 |  | int | height |
 | ) |  |  | [protected, inherited]

Renderes sprites to pixels of the screen on a given RendderTarget with a given material.

Pixel sprites are pixel sized quads, placed on each pixel of the RenderTarget. The number of sprites not necessary corresponds to the resolution of the rendertarget. The pixel quads will evenly fill the rendertarget's area with sizes corresponding to the given resolution. We can render fewer or more pixel quads than the number of pixels the rendertarget has (eg.: in case of caustic cubemap generation).

Parameters:
materialName | the name of the material bind to the pixel sprites
rt | the RenderTarget the quads should be rendered on
width | the desired resolution width of the sprites
height | the desired resolution height of the sprites

void OgreRenderingRun::renderPixelSprites | ( | String & | materialName,
 |  | RenderTarget * | rt,
 |  | int | width,
 |  | int | height |
 | ) |  |  | [protected, inherited]

Renderes sprites to pixels of the screen on a given RendderTarget with a given material.

Pixel sprites are pixel sized quads, placed on each pixel of the RenderTarget. The number of sprites not necessary corresponds to the resolution of the rendertarget. The pixel quads will evenly fill the rendertarget's area with sizes corresponding to the given resolution. We can render fewer or more pixel quads than the number of pixels the rendertarget has (eg.: in case of caustic cubemap generation).

Parameters:
materialName | the name of the material bind to the pixel sprites
rt | the RenderTarget the quads should be rendered on
width | the desired resolution width of the sprites
height | the desired resolution height of the sprites

void OgreRenderingRun::renderFullscreenGrid | ( | String & | materialName,
 |  | RenderTarget * | rt,
 |  | int | width,
 |  | int | height |
 | ) |  |  | [protected, inherited]

Renders a grid onto the screen.

Parameters:
rt | the RenderTarget the grid should be rendered on
width | the desired horizontal resolution of the grid
height | the desired vertical resolution of the grid

virtual bool RenderingRun::canJoin ( RenderingRun * run ) [inline, virtual, inherited]

Returns true if two runs can be joined.

In some cases special requirements should stand to join two runs (even if they have the same type). Eg.: two caustic cube map generation technique should only be joined if they use the same material when rendering the caustic cubemap.

Reimplemented in OgreCausticCubeMapRenderingRun, OgreChildPSystemRenderingRun, and OgrePhotonMapRenderingRun.

virtual bool RenderingRun::needUpdate ( unsigned long frameNum ) [inline, protected, virtual, inherited]

Returns if this run needs update.

This tipically depends on the upate interval and the starting frame number.

Parameters:
frameNum current frame number

Reimplemented in OgreFocusingMapRenderingRun, and OgrePMEntryPointMapRenderingRun.

Member Data Documentation

std::map<Renderable*, String> OgreRenderingRun::visibleObjects [protected, inherited]

map of Renderables which will be rendered with a given material

The String stores the original material name that will be restored after rendering.

See also:
setMaterialForVisibles

setMaterialForRenderables

restoreMaterials

std::map<Renderable*, String> OgreRenderingRun::visibleObjects [protected, inherited]

map of Renderables which will be rendered with a given material

The String stores the original material name that will be restored after rendering.

See also:
setMaterialForVisibles

setMaterialForRenderables

restoreMaterials

MovablePlane * OgreRenderingRun::fullScreenQuad [static, protected, inherited]

fulls screen quad plane used in full screen quad rendering

See also:
renderFullscreenQuad

MovablePlane* OgreRenderingRun::fullScreenQuad [static, protected, inherited]

fulls screen quad plane used in full screen quad rendering

See also:
renderFullscreenQuad

Entity * OgreRenderingRun::fullScreenQuadEntity [static, protected, inherited]

fulls screen quad Entity used in full screen quad rendering

See also:
renderFullscreenQuad

Entity* OgreRenderingRun::fullScreenQuadEntity [static, protected, inherited]

fulls screen quad Entity used in full screen quad rendering

See also:
renderFullscreenQuad

SceneNode * OgreRenderingRun::fullScreenQuadNode [static, protected, inherited]

fulls screen quad SceneNode used in full screen quad rendering

See also:
renderFullscreenQuad

SceneNode* OgreRenderingRun::fullScreenQuadNode [static, protected, inherited]

fulls screen quad SceneNode used in full screen quad rendering

See also:
renderFullscreenQuad

SpriteSet* OgreRenderingRun::pixelSprites [protected, inherited]

SpriteSet used in pixel sprite rendering.

See also:
renderPixelSprites

BillboardSet* OgreRenderingRun::pixelSprites [protected, inherited]

SpriteSet used in pixel sprite rendering.

See also:
renderPixelSprites

String OgreRenderingRun::spriteSetName [protected, inherited]

unique name of the SpriteSet used in pixel sprite rendering

See also:
renderPixelSprites

Entity* OgreRenderingRun::fullscreenGrid [protected, inherited]

Entity used in fullscreen grid rendering.

See also:
renderPixelGrid

Generated on Wed Mar 28 11:48:57 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: OgrePathMapRenderTechnique Class Reference

OgrePathMapRenderTechnique Class Reference

A technique that defines that the rendering of the object will use the path map technique. More...

Inheritance diagram for OgrePathMapRenderTechnique:

OgreRenderTechnique RenderTechnique List of all members.

Public Member Functions

OgrePathMapRenderTechnique (Pass *pass, OgreRenderable *parentRenderable, OgreTechniqueGroup *parentTechniqueGroup)
Constructor.
~OgrePathMapRenderTechnique ()
Destructor.
virtual void | update (unsigned long frameNum)
Updates the resources in the given frame.
virtual OgreRenderTechnique * | asOgreRenderTechnique ()
Conversion to OgreRenderTechnique.
virtual void | runChanged (RenderingRunType runType, RenderingRun *run)
Called after one of he shared runs changes.
virtual void | runUpdated (RenderingRunType runType, RenderingRun *run)
Called after one of he shared runs updates.
ElementaryRenderable * getParentRenderable ()
Retrieves the renderable this technique operates on.

Protected Member Functions

void | createWeightIndexTexture ()
create a weight index lookup map

Protected Attributes

Pass * | pathMapPass
the new pass created by this technique
PathMapClusters * clusters
the PathMapClusters structure that belongs to the subentity renderable
Texture * | weightIndexTexture
the weight index lookup map created by this technique
OgreRenderable * parentOgreRenderable
a OgreRenderable pointer to the renderable this technique operates on.
OgreTechniqueGroup * parentOgreTechniqueGroup
a OgreTechniqueGroup pointer to the TechniqueGroup this technique is attached to.
Pass * | pass
a pointer to the pass this technique operates on.
ElementaryRenderable * parentRenderable
The renderable this technique operates on.
TechniqueGroup * parentTechniqueGroup
The TechniqueGroup this RenderedTechnique is attached to.
SharedRuns * sharedRuns
The SharedRuns this RenderedTechnique is attached to.

Detailed Description

A technique that defines that the rendering of the object will use the path map technique.

This rendering technique can add indirect lighting to the scene.

Constructor & Destructor Documentation

OgrePathMapRenderTechnique::OgrePathMapRenderTechnique | ( | Pass * | pass,
 |  | OgreRenderable * | parentRenderable,
 |  | OgreTechniqueGroup * | parentTechniqueGroup
 | ) |  |

Constructor.

Parameters:
pass | the pass after which shadowing passes should be added
parentRenderable | the object to operate on
parentTechniqueGroup | the TechniqueGroup this RenderedTechnique is attached to

Member Function Documentation

void OgrePathMapRenderTechnique::update ( unsigned long frameNum ) [virtual]

Updates the resources in the given frame.

A RenderTechnique is usually need some resources from several runs, so these runs will be updated.

Parameters:
frameNum the actual framenumber

Reimplemented from RenderTechnique.

virtual OgreRenderTechnique* OgreRenderTechnique::asOgreRenderTechnique ( ) [inline, virtual, inherited]

Conversion to OgreRenderTechnique.

This function is needed because of virtual inheritance.

Reimplemented from RenderTechnique.

virtual void RenderTechnique::runChanged | ( | RenderingRunType | runType,
 |  | RenderingRun * | run |
 | ) |  |  | [inline, virtual, inherited]

Called after one of he shared runs changes.

Parameters:
runType | enum describing the type of the changed run
run | pointer to the changed RenderingRun

Reimplemented in CausticCasterRenderTechnique, ColorCubeMapRenderTechnique, ConvolvedCubeMapRenderTechnique, CubeMapRenderTechnique, DistanceCubeMapRenderTechnique, HierarchicalParticleSystemTechnique, and IllumVolumeRenderTechnique.

virtual void RenderTechnique::runUpdated | ( | RenderingRunType | runType,
 |  | RenderingRun * | run |
 | ) |  |  | [inline, virtual, inherited]

Called after one of he shared runs updates.

Parameters:
runType | enum describing the type of the updated run
run | pointer to the updated RenderingRun

Reimplemented in CausticCasterRenderTechnique, ColorCubeMapRenderTechnique, CubeMapRenderTechnique, DistanceCubeMapRenderTechnique, HierarchicalParticleSystemTechnique, and IllumVolumeRenderTechnique.

Generated on Wed Mar 28 11:48:57 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: OgrePathMapRenderTechniqueFactory Class Reference

OgrePathMapRenderTechniqueFactory Class Reference

RenderTechniqueFactory to create OgrePathMapRenderTechnique instances. More...

Inheritance diagram for OgrePathMapRenderTechniqueFactory:

RenderTechniqueFactory List of all members.

Public Member Functions

OgreRenderTechnique * | createInstance (IllumTechniqueParams *params, Pass *pass, OgreRenderable *parentRenderable, OgreTechniqueGroup *parentTechniqueGroup)
Creates a RenderTechnique of the factory type.
bool | isType (String type)
Returns if this factory can create a RenderTechnique of the given type.
virtual void | parseParams (IllumTechniqueParams *params)
parses parameters from the material file.

Protected Types

typedef void(*) | ILLUM_ATTRIBUTE_PARSER (String &params, RenderTechniqueFactory *factory)
function for parsing RenderTechnique attributes
typedef std::map< String,
ILLUM_ATTRIBUTE_PARSER > 		AttribParserList
Keyword-mapped attribute parsers.

Protected Attributes

AttribParserList attributeParsers
map of parser functions
String | typeName
factoryname

Detailed Description

RenderTechniqueFactory to create OgrePathMapRenderTechnique instances.

Member Typedef Documentation

typedef void(*) RenderTechniqueFactory::ILLUM_ATTRIBUTE_PARSER(String &params, RenderTechniqueFactory *factory) [protected, inherited]

function for parsing RenderTechnique attributes

Parameters:
params attribute value stored in a String

Member Function Documentation

OgreRenderTechnique * OgrePathMapRenderTechniqueFactory::createInstance | ( | IllumTechniqueParams * | params,
 |  | Pass * | pass,
 |  | OgreRenderable * | parentRenderable,
 |  | OgreTechniqueGroup * | parentTechniqueGroup |
 | ) |  |  | [virtual]

Creates a RenderTechnique of the factory type.

Parameters:
params | containes constructor parameters as NameValuePairList
pass | the Pass to use in RenderTechnique constructor
pass | the parentRenderable to pass to RenderTechnique constructor
pass | the parentTechniqueGroup to pass to RenderTechnique constructor

Implements RenderTechniqueFactory.

bool RenderTechniqueFactory::isType ( String type ) [inline, inherited]

Returns if this factory can create a RenderTechnique of the given type.

Parameters:
type RenderTechnique type

void RenderTechniqueFactory::parseParams ( IllumTechniqueParams * params ) [virtual, inherited]

parses parameters from the material file.

The parsed parameters will be passed to the new RenderTechnique's constructor.

Parameters:
params pointer to the IllumTechniqueParams structure that was read from the material script and containes the parameters to be parsed.

Generated on Wed Mar 28 11:48:57 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: OgrePhaseTextureRenderingRun Class Reference

OgrePhaseTextureRenderingRun Class Reference

PhaseTextureRenderingRun used in an OGRE environment. More...

Inheritance diagram for OgrePhaseTextureRenderingRun:

OgreRenderingRun PhaseTextureRenderingRun RenderingRun RenderingRun RenderingRun List of all members.

Public Member Functions

OgrePhaseTextureRenderingRun (String name, unsigned int resolutionX, unsigned int resolutionY, String materialName)
Constructor.
String | getPhaseTextureName ()
returns the name of thew phase texture created by this run
OgreRenderingRun * asOgreRenderingRun ()
Conversion to OgreRenderRun.
OgreRenderingRun * asOgreRenderingRun ()
Conversion to OgreRenderRun.
bool | update (unsigned long frameNum)
Calls updateFrame() if the run needs update according to its starting frame and update interval and has not been allready updated in this frame.
virtual bool | canJoin (RenderingRun *run)
Returns true if two runs can be joined.

Protected Member Functions

void | updateFrame (unsigned long frameNum)
This function does the actual update in a frame.
void | createPhaseTexture ()
Creates the phase texture.
Vector3 | getCubeMapFaceDirection (unsigned char faceId)
Returns a direction for a cubemap face id.
Vector3 | getCubeMapFaceDirection (unsigned char faceId)
Returns a direction for a cubemap face id.
Texture * | createCubeRenderTexture (String name, const Vector3 position, unsigned int resolution=512, PixelFormat format=PF_FLOAT16_RGBA, int numMips=0, ColourValue clearColor=ColourValue::Black)
Creates a cubemap texture.
Texture * | createCubeRenderTexture (String name, const Vector3 position, unsigned int resolution=512, PixelFormat format=PF_FLOAT16_RGBA, int numMips=0, ColourValue clearColor=ColourValue::Black)
Creates a cubemap texture.
void | setMaterialForRenderables (String &materialName, RenderQueue *rq)
Sets the given material for each Renderable in a RenderQueue.
void | setMaterialForRenderables (String &materialName, RenderQueue *rq, bool solidsonly=false)
Sets the given material for each Renderable in a RenderQueue.
void | setMaterialForVisibles (String &materialName, Camera *cam, bool shadowcastersonly=false)
Sets the given material for each Renderable visible from a given camera.
void | setMaterialForVisibles (String &materialName, Camera *cam, bool shadowcastersonly=false, bool solidsonly=false)
Sets the given material for each Renderable visible from a given camera.
void | restoreMaterials ()
Restores previously stored materials.
void | restoreMaterials ()
Restores previously stored materials.
void | renderFullscreenQuad (String materialName, RenderTarget *target)
Renderes a full screen quad on a given RendderTarget with a given material.
void | renderFullscreenQuad (String materialName, RenderTarget *target)
Renderes a full screen quad on a given RendderTarget with a given material.
void | renderPixelSprites (String &materialName, RenderTarget *rt, int width, int height)
Renderes sprites to pixels of the screen on a given RendderTarget with a given material.
void | renderPixelSprites (String &materialName, RenderTarget *rt, int width, int height)
Renderes sprites to pixels of the screen on a given RendderTarget with a given material.
void | renderFullscreenGrid (String &materialName, RenderTarget *rt, int width, int height)
Renders a grid onto the screen.
virtual bool | needUpdate (unsigned long frameNum)
Returns if this run needs update.

Protected Attributes

String | materialName
the name of the material to be used when rendering the depth shadow map
String | name
the name of the phase texture that was created by this run
Texture * | phaseTexture
a pointer to the phase texture that was created by this run
Camera * | phaseCamera
a pointer to the camera that was used while rendering the phase texture
std::map< Renderable *, String > | visibleObjects
map of Renderables which will be rendered with a given material
std::map< Renderable *, String > | visibleObjects
map of Renderables which will be rendered with a given material
SpriteSet * | pixelSprites
SpriteSet used in pixel sprite rendering.
BillboardSet * | pixelSprites
SpriteSet used in pixel sprite rendering.
String | spriteSetName
unique name of the SpriteSet used in pixel sprite rendering
Entity * | fullscreenGrid
Entity used in fullscreen grid rendering.
unsigned long | lastupdated
The number of the last frame this run was updated.
unsigned long | startFrame
The number of the frame this run should be updated first.
unsigned long | updateInterval
Refresh frequency in frames.
unsigned int | resolutionX
width of the texture
unsigned int | resolutionY
height of the texture

Static Protected Attributes

static MovablePlane * | fullScreenQuad
fulls screen quad plane used in full screen quad rendering
static MovablePlane * | fullScreenQuad
fulls screen quad plane used in full screen quad rendering
static Entity * | fullScreenQuadEntity
fulls screen quad Entity used in full screen quad rendering
static Entity * | fullScreenQuadEntity
fulls screen quad Entity used in full screen quad rendering
static SceneNode * | fullScreenQuadNode
fulls screen quad SceneNode used in full screen quad rendering
static SceneNode * | fullScreenQuadNode
fulls screen quad SceneNode used in full screen quad rendering

Detailed Description

PhaseTextureRenderingRun used in an OGRE environment.

Constructor & Destructor Documentation

OgrePhaseTextureRenderingRun::OgrePhaseTextureRenderingRun | ( | String | name,
 |  | unsigned int | resolutionX,
 |  | unsigned int | resolutionY,
 |  | String | materialName
 | ) |  |

Constructor.

Parameters:
name | the name of the phase texture to be created
resolutionX | the resolution width of the phase texture
resolutionY | the resolution height of the phase texture
materialName | the name of the material to be used when rendering the phase texture

Member Function Documentation

void OgrePhaseTextureRenderingRun::updateFrame ( unsigned long frameNum ) [protected, virtual]

This function does the actual update in a frame.

Parameters:
frameNum current frame number

Implements PhaseTextureRenderingRun.

OgreRenderingRun* OgreRenderingRun::asOgreRenderingRun ( ) [inline, virtual, inherited]

Conversion to OgreRenderRun.

This function is needed because of virtual inheritance.

Reimplemented from RenderingRun.

OgreRenderingRun* OgreRenderingRun::asOgreRenderingRun ( ) [inline, virtual, inherited]

Conversion to OgreRenderRun.

This function is needed because of virtual inheritance.

Reimplemented from RenderingRun.

Vector3 OgreRenderingRun::getCubeMapFaceDirection ( unsigned char faceId ) [protected, inherited]

Returns a direction for a cubemap face id.

This is a helper function to retrieve the normal direction of a given cubemap face.

Parameters:
faceId the number of the face

Vector3 OgreRenderingRun::getCubeMapFaceDirection ( unsigned char faceId ) [protected, inherited]

Returns a direction for a cubemap face id.

This is a helper function to retrieve the normal direction of a given cubemap face.

Parameters:
faceId the number of the face

Texture * OgreRenderingRun::createCubeRenderTexture | ( | String | name,
 |  | const Vector3 | position,
 |  | unsigned int | resolution = 512,
 |  | PixelFormat | format = PF_FLOAT16_RGBA,
 |  | int | numMips = 0,
 |  | ColourValue | clearColor = ColourValue::Black |
 | ) |  |  | [protected, inherited]

Creates a cubemap texture.

This is a helper function to easily create a cubemap texture and automaticly attach viewports to each face so it can be used as a rendertarget.

Parameters:
name | the name of the texture to be created
position | the initial position of the cubemap
resolution | the resolution of one cubemapface
format | the pixel format of the cubemap
numMips | the number of mipmap levels
clearColor | initial color

Texture* OgreRenderingRun::createCubeRenderTexture | ( | String | name,
 |  | const Vector3 | position,
 |  | unsigned int | resolution = 512,
 |  | PixelFormat | format = PF_FLOAT16_RGBA,
 |  | int | numMips = 0,
 |  | ColourValue | clearColor = ColourValue::Black |
 | ) |  |  | [protected, inherited]

Creates a cubemap texture.

This is a helper function to easily create a cubemap texture and automaticly attach viewports to each face so it can be used as a rendertarget.

Parameters:
name | the name of the texture to be created
position | the initial position of the cubemap
resolution | the resolution of one cubemapface
format | the pixel format of the cubemap
numMips | the number of mipmap levels
clearColor | initial color

void OgreRenderingRun::setMaterialForRenderables | ( | String & | materialName,
 |  | RenderQueue * | rq |
 | ) |  |  | [protected, inherited]

Sets the given material for each Renderable in a RenderQueue.

This is a helper function to set a material to each element of a previously filled Renderque. The orginal material of the Renderables are stored so they can be restored later. The function also tells the current SceneManager not to search for visible objects, as we are going to use the given RenderQueue during the next rendering.

Parameters:
materialName | the name of the material to set for the Renderables
rq | pointer to the filled Renderqueue instance to set material for

void OgreRenderingRun::setMaterialForRenderables | ( | String & | materialName,
 |  | RenderQueue * | rq,
 |  | bool | solidsonly = false |
 | ) |  |  | [protected, inherited]

Sets the given material for each Renderable in a RenderQueue.

This is a helper function to set a material to each element of a previously filled Renderque. The orginal material of the Renderables are stored so they can be restored later. The function also tells the current SceneManager not to search for visible objects, as we are going to use the given RenderQueue during the next rendering.

Parameters:
materialName | the name of the material to set for the Renderables
rq | pointer to the filled Renderqueue instance to set material for

void OgreRenderingRun::setMaterialForVisibles | ( | String & | materialName,
 |  | Camera * | cam,
 |  | bool | shadowcastersonly = false |
 | ) |  |  | [protected, inherited]

Sets the given material for each Renderable visible from a given camera.

This helper function is similar to setMaterialForRenderables but it is also responsible for filling the RenderQueue. First the RenderQueue of the current SceneManager fill be filled with the visible objects seen from the given camera. Then the required material will be set for each element of the RenderQueue. The orginal material of the Renderables are stored so they can be restored later. The function also tells the current SceneManager not to search for visible objects, as we are going to use the filled RenderQueue during the next rendering.

Parameters:
materialName | the name of the material to set for the Renderables
cam | pointer to the camera from which visible objects should be searched
shadowcastersonly | flag to search for only shadow casters

void OgreRenderingRun::setMaterialForVisibles | ( | String & | materialName,
 |  | Camera * | cam,
 |  | bool | shadowcastersonly = false,
 |  | bool | solidsonly = false |
 | ) |  |  | [protected, inherited]

Sets the given material for each Renderable visible from a given camera.

This helper function is similar to setMaterialForRenderables but it is also responsible for filling the RenderQueue. First the RenderQueue of the current SceneManager fill be filled with the visible objects seen from the given camera. Then the required material will be set for each element of the RenderQueue. The orginal material of the Renderables are stored so they can be restored later. The function also tells the current SceneManager not to search for visible objects, as we are going to use the filled RenderQueue during the next rendering.

Parameters:
materialName | the name of the material to set for the Renderables
cam | pointer to the camera from which visible objects should be searched
shadowcastersonly | flag to search for only shadow casters

void OgreRenderingRun::restoreMaterials ( ) [protected, inherited]

Restores previously stored materials.

This helper function is typically used after a setMaterialForRenderables or setMaterialForVisibles call and a rendering process to restore the original material settings. The function also tells the current SceneManager to search for visible objects, as this is the default behaviour of SceneManager.

void OgreRenderingRun::restoreMaterials ( ) [protected, inherited]

Restores previously stored materials.

This helper function is typically used after a setMaterialForRenderables or setMaterialForVisibles call and a rendering process to restore the original material settings. The function also tells the current SceneManager to search for visible objects, as this is the default behaviour of SceneManager.

void OgreRenderingRun::renderFullscreenQuad | ( | String | materialName,
 |  | RenderTarget * | target |
 | ) |  |  | [protected, inherited]

Renderes a full screen quad on a given RendderTarget with a given material.

Parameters:
materialName | the name of the material bind to the quad
target | the RenderTarget the quad should be rendered on

void OgreRenderingRun::renderFullscreenQuad | ( | String | materialName,
 |  | RenderTarget * | target |
 | ) |  |  | [protected, inherited]

Renderes a full screen quad on a given RendderTarget with a given material.

Parameters:
materialName | the name of the material bind to the quad
target | the RenderTarget the quad should be rendered on

void OgreRenderingRun::renderPixelSprites | ( | String & | materialName,
 |  | RenderTarget * | rt,
 |  | int | width,
 |  | int | height |
 | ) |  |  | [protected, inherited]

Renderes sprites to pixels of the screen on a given RendderTarget with a given material.

Pixel sprites are pixel sized quads, placed on each pixel of the RenderTarget. The number of sprites not necessary corresponds to the resolution of the rendertarget. The pixel quads will evenly fill the rendertarget's area with sizes corresponding to the given resolution. We can render fewer or more pixel quads than the number of pixels the rendertarget has (eg.: in case of caustic cubemap generation).

Parameters:
materialName | the name of the material bind to the pixel sprites
rt | the RenderTarget the quads should be rendered on
width | the desired resolution width of the sprites
height | the desired resolution height of the sprites

void OgreRenderingRun::renderPixelSprites | ( | String & | materialName,
 |  | RenderTarget * | rt,
 |  | int | width,
 |  | int | height |
 | ) |  |  | [protected, inherited]

Renderes sprites to pixels of the screen on a given RendderTarget with a given material.

Pixel sprites are pixel sized quads, placed on each pixel of the RenderTarget. The number of sprites not necessary corresponds to the resolution of the rendertarget. The pixel quads will evenly fill the rendertarget's area with sizes corresponding to the given resolution. We can render fewer or more pixel quads than the number of pixels the rendertarget has (eg.: in case of caustic cubemap generation).

Parameters:
materialName | the name of the material bind to the pixel sprites
rt | the RenderTarget the quads should be rendered on
width | the desired resolution width of the sprites
height | the desired resolution height of the sprites

void OgreRenderingRun::renderFullscreenGrid | ( | String & | materialName,
 |  | RenderTarget * | rt,
 |  | int | width,
 |  | int | height |
 | ) |  |  | [protected, inherited]

Renders a grid onto the screen.

Parameters:
rt | the RenderTarget the grid should be rendered on
width | the desired horizontal resolution of the grid
height | the desired vertical resolution of the grid

virtual bool RenderingRun::canJoin ( RenderingRun * run ) [inline, virtual, inherited]

Returns true if two runs can be joined.

In some cases special requirements should stand to join two runs (even if they have the same type). Eg.: two caustic cube map generation technique should only be joined if they use the same material when rendering the caustic cubemap.

Reimplemented in OgreCausticCubeMapRenderingRun, OgreChildPSystemRenderingRun, and OgrePhotonMapRenderingRun.

virtual bool RenderingRun::needUpdate ( unsigned long frameNum ) [inline, protected, virtual, inherited]

Returns if this run needs update.

This tipically depends on the upate interval and the starting frame number.

Parameters:
frameNum current frame number

Reimplemented in OgreFocusingMapRenderingRun, and OgrePMEntryPointMapRenderingRun.

Member Data Documentation

std::map<Renderable*, String> OgreRenderingRun::visibleObjects [protected, inherited]

map of Renderables which will be rendered with a given material

The String stores the original material name that will be restored after rendering.

See also:
setMaterialForVisibles

setMaterialForRenderables

restoreMaterials

std::map<Renderable*, String> OgreRenderingRun::visibleObjects [protected, inherited]

map of Renderables which will be rendered with a given material

The String stores the original material name that will be restored after rendering.

See also:
setMaterialForVisibles

setMaterialForRenderables

restoreMaterials

MovablePlane * OgreRenderingRun::fullScreenQuad [static, protected, inherited]

fulls screen quad plane used in full screen quad rendering

See also:
renderFullscreenQuad

MovablePlane* OgreRenderingRun::fullScreenQuad [static, protected, inherited]

fulls screen quad plane used in full screen quad rendering

See also:
renderFullscreenQuad

Entity * OgreRenderingRun::fullScreenQuadEntity [static, protected, inherited]

fulls screen quad Entity used in full screen quad rendering

See also:
renderFullscreenQuad

Entity* OgreRenderingRun::fullScreenQuadEntity [static, protected, inherited]

fulls screen quad Entity used in full screen quad rendering

See also:
renderFullscreenQuad

SceneNode * OgreRenderingRun::fullScreenQuadNode [static, protected, inherited]

fulls screen quad SceneNode used in full screen quad rendering

See also:
renderFullscreenQuad

SceneNode* OgreRenderingRun::fullScreenQuadNode [static, protected, inherited]

fulls screen quad SceneNode used in full screen quad rendering

See also:
renderFullscreenQuad

SpriteSet* OgreRenderingRun::pixelSprites [protected, inherited]

SpriteSet used in pixel sprite rendering.

See also:
renderPixelSprites

BillboardSet* OgreRenderingRun::pixelSprites [protected, inherited]

SpriteSet used in pixel sprite rendering.

See also:
renderPixelSprites

String OgreRenderingRun::spriteSetName [protected, inherited]

unique name of the SpriteSet used in pixel sprite rendering

See also:
renderPixelSprites

Entity* OgreRenderingRun::fullscreenGrid [protected, inherited]

Entity used in fullscreen grid rendering.

See also:
renderPixelGrid

Generated on Wed Mar 28 11:48:57 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: OgrePhotonMapRenderingRun Class Reference

OgrePhotonMapRenderingRun Class Reference

PhotonMapRenderingRun used in an OGRE environment. More...

Inheritance diagram for OgrePhotonMapRenderingRun:

OgreRenderingRun PhotonMapRenderingRun RenderingRun RenderingRun RenderingRun List of all members.

Public Member Functions

OgrePhotonMapRenderingRun (OgreSharedRuns *sharedRuns, String name, unsigned long startFrame, unsigned long updateInterval, unsigned int resolution, String materialName, bool useDistance)
Constructor.
String | getPhotonMapTextureName ()
returns the name of the resulting photon hit map texture
void | refreshLight ()
Refreshes light camera matrices, called in each update.
bool | canJoin (RenderingRun *run)
Returns true if two runs can be joined.
OgreRenderingRun * asOgreRenderingRun ()
Conversion to OgreRenderRun.
OgreRenderingRun * asOgreRenderingRun ()
Conversion to OgreRenderRun.
bool | update (unsigned long frameNum)
Calls updateFrame() if the run needs update according to its starting frame and update interval and has not been allready updated in this frame.

Protected Member Functions

void | updateFrame (unsigned long frameNum)
This function does the actual update in a frame.
void | createPhotonMap ()
Creates a photon hit map.
Vector3 | getCubeMapFaceDirection (unsigned char faceId)
Returns a direction for a cubemap face id.
Vector3 | getCubeMapFaceDirection (unsigned char faceId)
Returns a direction for a cubemap face id.
Texture * | createCubeRenderTexture (String name, const Vector3 position, unsigned int resolution=512, PixelFormat format=PF_FLOAT16_RGBA, int numMips=0, ColourValue clearColor=ColourValue::Black)
Creates a cubemap texture.
Texture * | createCubeRenderTexture (String name, const Vector3 position, unsigned int resolution=512, PixelFormat format=PF_FLOAT16_RGBA, int numMips=0, ColourValue clearColor=ColourValue::Black)
Creates a cubemap texture.
void | setMaterialForRenderables (String &materialName, RenderQueue *rq)
Sets the given material for each Renderable in a RenderQueue.
void | setMaterialForRenderables (String &materialName, RenderQueue *rq, bool solidsonly=false)
Sets the given material for each Renderable in a RenderQueue.
void | setMaterialForVisibles (String &materialName, Camera *cam, bool shadowcastersonly=false)
Sets the given material for each Renderable visible from a given camera.
void | setMaterialForVisibles (String &materialName, Camera *cam, bool shadowcastersonly=false, bool solidsonly=false)
Sets the given material for each Renderable visible from a given camera.
void | restoreMaterials ()
Restores previously stored materials.
void | restoreMaterials ()
Restores previously stored materials.
void | renderFullscreenQuad (String materialName, RenderTarget *target)
Renderes a full screen quad on a given RendderTarget with a given material.
void | renderFullscreenQuad (String materialName, RenderTarget *target)
Renderes a full screen quad on a given RendderTarget with a given material.
void | renderPixelSprites (String &materialName, RenderTarget *rt, int width, int height)
Renderes sprites to pixels of the screen on a given RendderTarget with a given material.
void | renderPixelSprites (String &materialName, RenderTarget *rt, int width, int height)
Renderes sprites to pixels of the screen on a given RendderTarget with a given material.
void | renderFullscreenGrid (String &materialName, RenderTarget *rt, int width, int height)
Renders a grid onto the screen.
virtual bool | needUpdate (unsigned long frameNum)
Returns if this run needs update.

Protected Attributes

String | materialName
the name of the material should be used when rendering the photon hit map
Light * | light
pointer to the nearest light source from the caster object
Camera * | photonMapCamera
the camera used while rendering the photon hit map
bool | useDistance
tells if a distance cubemap impostor should be used in photon hit calculation (recommended)
OgreSharedRuns * sharedRuns
a pointer to the OgreSharedRuns this run belongs to
String | name
the name of the photon map texture that was created by this run
Texture * | photonMapTexture
a pointer to the photon map texture that was created by this run
unsigned int | resolution
the resolution of the photonmap texture that was created by this run
std::map< Renderable *, String > | visibleObjects
map of Renderables which will be rendered with a given material
std::map< Renderable *, String > | visibleObjects
map of Renderables which will be rendered with a given material
SpriteSet * | pixelSprites
SpriteSet used in pixel sprite rendering.
BillboardSet * | pixelSprites
SpriteSet used in pixel sprite rendering.
String | spriteSetName
unique name of the SpriteSet used in pixel sprite rendering
Entity * | fullscreenGrid
Entity used in fullscreen grid rendering.
unsigned long | lastupdated
The number of the last frame this run was updated.
unsigned long | startFrame
The number of the frame this run should be updated first.
unsigned long | updateInterval
Refresh frequency in frames.

Static Protected Attributes

static MovablePlane * | fullScreenQuad
fulls screen quad plane used in full screen quad rendering
static MovablePlane * | fullScreenQuad
fulls screen quad plane used in full screen quad rendering
static Entity * | fullScreenQuadEntity
fulls screen quad Entity used in full screen quad rendering
static Entity * | fullScreenQuadEntity
fulls screen quad Entity used in full screen quad rendering
static SceneNode * | fullScreenQuadNode
fulls screen quad SceneNode used in full screen quad rendering
static SceneNode * | fullScreenQuadNode
fulls screen quad SceneNode used in full screen quad rendering

Detailed Description

PhotonMapRenderingRun used in an OGRE environment.

Constructor & Destructor Documentation

OgrePhotonMapRenderingRun::OgrePhotonMapRenderingRun | ( | OgreSharedRuns * | sharedRuns,
 |  | String | name,
 |  | unsigned long | startFrame,
 |  | unsigned long | updateInterval,
 |  | unsigned int | resolution,
 |  | String | materialName,
 |  | bool | useDistance
 | ) |  |

Constructor.

Parameters:
sharedRuns | a pointer to the OgreSharedRuns this run belongs to
name | the name of the texture to be created
startFrame | adds an offset to the current frame number to help evenly distribute updates between frames
updateInterval | update frequency
resolution | photon map resolution
materialName | the name of the material should be used when rendering the photon hit map
useDistance | tells if a distance cubemap impostor should be used in photon hit calculation (recommended)

Member Function Documentation

void OgrePhotonMapRenderingRun::refreshLight ( )

Refreshes light camera matrices, called in each update.

TODO: search nearest light, set light params

bool OgrePhotonMapRenderingRun::canJoin ( RenderingRun * run ) [inline, virtual]

Returns true if two runs can be joined.

In some cases special requirements should stand to join two runs (even if they have the same type). Eg.: two caustic cube map generation technique should only be joined if they use the same material when rendering the caustic cubemap.

Reimplemented from RenderingRun.

void OgrePhotonMapRenderingRun::updateFrame ( unsigned long frameNum ) [protected, virtual]

This function does the actual update in a frame.

Parameters:
frameNum current frame number

Implements PhotonMapRenderingRun.

OgreRenderingRun* OgreRenderingRun::asOgreRenderingRun ( ) [inline, virtual, inherited]

Conversion to OgreRenderRun.

This function is needed because of virtual inheritance.

Reimplemented from RenderingRun.

OgreRenderingRun* OgreRenderingRun::asOgreRenderingRun ( ) [inline, virtual, inherited]

Conversion to OgreRenderRun.

This function is needed because of virtual inheritance.

Reimplemented from RenderingRun.

Vector3 OgreRenderingRun::getCubeMapFaceDirection ( unsigned char faceId ) [protected, inherited]

Returns a direction for a cubemap face id.

This is a helper function to retrieve the normal direction of a given cubemap face.

Parameters:
faceId the number of the face

Vector3 OgreRenderingRun::getCubeMapFaceDirection ( unsigned char faceId ) [protected, inherited]

Returns a direction for a cubemap face id.

This is a helper function to retrieve the normal direction of a given cubemap face.

Parameters:
faceId the number of the face

Texture * OgreRenderingRun::createCubeRenderTexture | ( | String | name,
 |  | const Vector3 | position,
 |  | unsigned int | resolution = 512,
 |  | PixelFormat | format = PF_FLOAT16_RGBA,
 |  | int | numMips = 0,
 |  | ColourValue | clearColor = ColourValue::Black |
 | ) |  |  | [protected, inherited]

Creates a cubemap texture.

This is a helper function to easily create a cubemap texture and automaticly attach viewports to each face so it can be used as a rendertarget.

Parameters:
name | the name of the texture to be created
position | the initial position of the cubemap
resolution | the resolution of one cubemapface
format | the pixel format of the cubemap
numMips | the number of mipmap levels
clearColor | initial color

Texture* OgreRenderingRun::createCubeRenderTexture | ( | String | name,
 |  | const Vector3 | position,
 |  | unsigned int | resolution = 512,
 |  | PixelFormat | format = PF_FLOAT16_RGBA,
 |  | int | numMips = 0,
 |  | ColourValue | clearColor = ColourValue::Black |
 | ) |  |  | [protected, inherited]

Creates a cubemap texture.

This is a helper function to easily create a cubemap texture and automaticly attach viewports to each face so it can be used as a rendertarget.

Parameters:
name | the name of the texture to be created
position | the initial position of the cubemap
resolution | the resolution of one cubemapface
format | the pixel format of the cubemap
numMips | the number of mipmap levels
clearColor | initial color

void OgreRenderingRun::setMaterialForRenderables | ( | String & | materialName,
 |  | RenderQueue * | rq |
 | ) |  |  | [protected, inherited]

Sets the given material for each Renderable in a RenderQueue.

This is a helper function to set a material to each element of a previously filled Renderque. The orginal material of the Renderables are stored so they can be restored later. The function also tells the current SceneManager not to search for visible objects, as we are going to use the given RenderQueue during the next rendering.

Parameters:
materialName | the name of the material to set for the Renderables
rq | pointer to the filled Renderqueue instance to set material for

void OgreRenderingRun::setMaterialForRenderables | ( | String & | materialName,
 |  | RenderQueue * | rq,
 |  | bool | solidsonly = false |
 | ) |  |  | [protected, inherited]

Sets the given material for each Renderable in a RenderQueue.

This is a helper function to set a material to each element of a previously filled Renderque. The orginal material of the Renderables are stored so they can be restored later. The function also tells the current SceneManager not to search for visible objects, as we are going to use the given RenderQueue during the next rendering.

Parameters:
materialName | the name of the material to set for the Renderables
rq | pointer to the filled Renderqueue instance to set material for

void OgreRenderingRun::setMaterialForVisibles | ( | String & | materialName,
 |  | Camera * | cam,
 |  | bool | shadowcastersonly = false |
 | ) |  |  | [protected, inherited]

Sets the given material for each Renderable visible from a given camera.

This helper function is similar to setMaterialForRenderables but it is also responsible for filling the RenderQueue. First the RenderQueue of the current SceneManager fill be filled with the visible objects seen from the given camera. Then the required material will be set for each element of the RenderQueue. The orginal material of the Renderables are stored so they can be restored later. The function also tells the current SceneManager not to search for visible objects, as we are going to use the filled RenderQueue during the next rendering.

Parameters:
materialName | the name of the material to set for the Renderables
cam | pointer to the camera from which visible objects should be searched
shadowcastersonly | flag to search for only shadow casters

void OgreRenderingRun::setMaterialForVisibles | ( | String & | materialName,
 |  | Camera * | cam,
 |  | bool | shadowcastersonly = false,
 |  | bool | solidsonly = false |
 | ) |  |  | [protected, inherited]

Sets the given material for each Renderable visible from a given camera.

This helper function is similar to setMaterialForRenderables but it is also responsible for filling the RenderQueue. First the RenderQueue of the current SceneManager fill be filled with the visible objects seen from the given camera. Then the required material will be set for each element of the RenderQueue. The orginal material of the Renderables are stored so they can be restored later. The function also tells the current SceneManager not to search for visible objects, as we are going to use the filled RenderQueue during the next rendering.

Parameters:
materialName | the name of the material to set for the Renderables
cam | pointer to the camera from which visible objects should be searched
shadowcastersonly | flag to search for only shadow casters

void OgreRenderingRun::restoreMaterials ( ) [protected, inherited]

Restores previously stored materials.

This helper function is typically used after a setMaterialForRenderables or setMaterialForVisibles call and a rendering process to restore the original material settings. The function also tells the current SceneManager to search for visible objects, as this is the default behaviour of SceneManager.

void OgreRenderingRun::restoreMaterials ( ) [protected, inherited]

Restores previously stored materials.

This helper function is typically used after a setMaterialForRenderables or setMaterialForVisibles call and a rendering process to restore the original material settings. The function also tells the current SceneManager to search for visible objects, as this is the default behaviour of SceneManager.

void OgreRenderingRun::renderFullscreenQuad | ( | String | materialName,
 |  | RenderTarget * | target |
 | ) |  |  | [protected, inherited]

Renderes a full screen quad on a given RendderTarget with a given material.

Parameters:
materialName | the name of the material bind to the quad
target | the RenderTarget the quad should be rendered on

void OgreRenderingRun::renderFullscreenQuad | ( | String | materialName,
 |  | RenderTarget * | target |
 | ) |  |  | [protected, inherited]

Renderes a full screen quad on a given RendderTarget with a given material.

Parameters:
materialName | the name of the material bind to the quad
target | the RenderTarget the quad should be rendered on

void OgreRenderingRun::renderPixelSprites | ( | String & | materialName,
 |  | RenderTarget * | rt,
 |  | int | width,
 |  | int | height |
 | ) |  |  | [protected, inherited]

Renderes sprites to pixels of the screen on a given RendderTarget with a given material.

Pixel sprites are pixel sized quads, placed on each pixel of the RenderTarget. The number of sprites not necessary corresponds to the resolution of the rendertarget. The pixel quads will evenly fill the rendertarget's area with sizes corresponding to the given resolution. We can render fewer or more pixel quads than the number of pixels the rendertarget has (eg.: in case of caustic cubemap generation).

Parameters:
materialName | the name of the material bind to the pixel sprites
rt | the RenderTarget the quads should be rendered on
width | the desired resolution width of the sprites
height | the desired resolution height of the sprites

void OgreRenderingRun::renderPixelSprites | ( | String & | materialName,
 |  | RenderTarget * | rt,
 |  | int | width,
 |  | int | height |
 | ) |  |  | [protected, inherited]

Renderes sprites to pixels of the screen on a given RendderTarget with a given material.

Pixel sprites are pixel sized quads, placed on each pixel of the RenderTarget. The number of sprites not necessary corresponds to the resolution of the rendertarget. The pixel quads will evenly fill the rendertarget's area with sizes corresponding to the given resolution. We can render fewer or more pixel quads than the number of pixels the rendertarget has (eg.: in case of caustic cubemap generation).

Parameters:
materialName | the name of the material bind to the pixel sprites
rt | the RenderTarget the quads should be rendered on
width | the desired resolution width of the sprites
height | the desired resolution height of the sprites

void OgreRenderingRun::renderFullscreenGrid | ( | String & | materialName,
 |  | RenderTarget * | rt,
 |  | int | width,
 |  | int | height |
 | ) |  |  | [protected, inherited]

Renders a grid onto the screen.

Parameters:
rt | the RenderTarget the grid should be rendered on
width | the desired horizontal resolution of the grid
height | the desired vertical resolution of the grid

virtual bool RenderingRun::needUpdate ( unsigned long frameNum ) [inline, protected, virtual, inherited]

Returns if this run needs update.

This tipically depends on the upate interval and the starting frame number.

Parameters:
frameNum current frame number

Reimplemented in OgreFocusingMapRenderingRun, and OgrePMEntryPointMapRenderingRun.

Member Data Documentation

std::map<Renderable*, String> OgreRenderingRun::visibleObjects [protected, inherited]

map of Renderables which will be rendered with a given material

The String stores the original material name that will be restored after rendering.

See also:
setMaterialForVisibles

setMaterialForRenderables

restoreMaterials

std::map<Renderable*, String> OgreRenderingRun::visibleObjects [protected, inherited]

map of Renderables which will be rendered with a given material

The String stores the original material name that will be restored after rendering.

See also:
setMaterialForVisibles

setMaterialForRenderables

restoreMaterials

MovablePlane * OgreRenderingRun::fullScreenQuad [static, protected, inherited]

fulls screen quad plane used in full screen quad rendering

See also:
renderFullscreenQuad

MovablePlane* OgreRenderingRun::fullScreenQuad [static, protected, inherited]

fulls screen quad plane used in full screen quad rendering

See also:
renderFullscreenQuad

Entity * OgreRenderingRun::fullScreenQuadEntity [static, protected, inherited]

fulls screen quad Entity used in full screen quad rendering

See also:
renderFullscreenQuad

Entity* OgreRenderingRun::fullScreenQuadEntity [static, protected, inherited]

fulls screen quad Entity used in full screen quad rendering

See also:
renderFullscreenQuad

SceneNode * OgreRenderingRun::fullScreenQuadNode [static, protected, inherited]

fulls screen quad SceneNode used in full screen quad rendering

See also:
renderFullscreenQuad

SceneNode* OgreRenderingRun::fullScreenQuadNode [static, protected, inherited]

fulls screen quad SceneNode used in full screen quad rendering

See also:
renderFullscreenQuad

SpriteSet* OgreRenderingRun::pixelSprites [protected, inherited]

SpriteSet used in pixel sprite rendering.

See also:
renderPixelSprites

BillboardSet* OgreRenderingRun::pixelSprites [protected, inherited]

SpriteSet used in pixel sprite rendering.

See also:
renderPixelSprites

String OgreRenderingRun::spriteSetName [protected, inherited]

unique name of the SpriteSet used in pixel sprite rendering

See also:
renderPixelSprites

Entity* OgreRenderingRun::fullscreenGrid [protected, inherited]

Entity used in fullscreen grid rendering.

See also:
renderPixelGrid

Generated on Wed Mar 28 11:48:58 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: OgrePMEntryPointMapRenderingRun Class Reference

OgrePMEntryPointMapRenderingRun Class Reference

Entry point map computing run. More...

Inheritance diagram for OgrePMEntryPointMapRenderingRun:

OgreRenderingRun RenderingRun RenderingRun List of all members.

Public Member Functions

OgrePMEntryPointMapRenderingRun (String name)
Constructor.
String | getEntryPointTextureName ()
returns the name of the entry point texture
String | getClusterLengthTextureName ()
returns the name of the cluster length texture.
OgreRenderingRun * asOgreRenderingRun ()
Conversion to OgreRenderRun.
OgreRenderingRun * asOgreRenderingRun ()
Conversion to OgreRenderRun.
bool | update (unsigned long frameNum)
Calls updateFrame() if the run needs update according to its starting frame and update interval and has not been allready updated in this frame.
virtual bool | canJoin (RenderingRun *run)
Returns true if two runs can be joined.

Protected Member Functions

void | updateFrame (unsigned long frameNum)
This function does the actual update in a frame.
void | createEntryPointMap ()
Creates and fills the entry point and the cluster length texture.
bool | needUpdate (unsigned long frameNum)
Returns if this run needs update.
Vector3 | getCubeMapFaceDirection (unsigned char faceId)
Returns a direction for a cubemap face id.
Vector3 | getCubeMapFaceDirection (unsigned char faceId)
Returns a direction for a cubemap face id.
Texture * | createCubeRenderTexture (String name, const Vector3 position, unsigned int resolution=512, PixelFormat format=PF_FLOAT16_RGBA, int numMips=0, ColourValue clearColor=ColourValue::Black)
Creates a cubemap texture.
Texture * | createCubeRenderTexture (String name, const Vector3 position, unsigned int resolution=512, PixelFormat format=PF_FLOAT16_RGBA, int numMips=0, ColourValue clearColor=ColourValue::Black)
Creates a cubemap texture.
void | setMaterialForRenderables (String &materialName, RenderQueue *rq)
Sets the given material for each Renderable in a RenderQueue.
void | setMaterialForRenderables (String &materialName, RenderQueue *rq, bool solidsonly=false)
Sets the given material for each Renderable in a RenderQueue.
void | setMaterialForVisibles (String &materialName, Camera *cam, bool shadowcastersonly=false)
Sets the given material for each Renderable visible from a given camera.
void | setMaterialForVisibles (String &materialName, Camera *cam, bool shadowcastersonly=false, bool solidsonly=false)
Sets the given material for each Renderable visible from a given camera.
void | restoreMaterials ()
Restores previously stored materials.
void | restoreMaterials ()
Restores previously stored materials.
void | renderFullscreenQuad (String materialName, RenderTarget *target)
Renderes a full screen quad on a given RendderTarget with a given material.
void | renderFullscreenQuad (String materialName, RenderTarget *target)
Renderes a full screen quad on a given RendderTarget with a given material.
void | renderPixelSprites (String &materialName, RenderTarget *rt, int width, int height)
Renderes sprites to pixels of the screen on a given RendderTarget with a given material.
void | renderPixelSprites (String &materialName, RenderTarget *rt, int width, int height)
Renderes sprites to pixels of the screen on a given RendderTarget with a given material.
void | renderFullscreenGrid (String &materialName, RenderTarget *rt, int width, int height)
Renders a grid onto the screen.

Protected Attributes

String | name
the name of the entry point texture that was created by this run
Texture * | entryPointTexture
a pointer to the entry point texture that was created by this run
Texture * | clusterLengthTexture
a pointer to the cluster length texture that was created by this run
std::map< Renderable *, String > | visibleObjects
map of Renderables which will be rendered with a given material
std::map< Renderable *, String > | visibleObjects
map of Renderables which will be rendered with a given material
SpriteSet * | pixelSprites
SpriteSet used in pixel sprite rendering.
BillboardSet * | pixelSprites
SpriteSet used in pixel sprite rendering.
String | spriteSetName
unique name of the SpriteSet used in pixel sprite rendering
Entity * | fullscreenGrid
Entity used in fullscreen grid rendering.
unsigned long | lastupdated
The number of the last frame this run was updated.
unsigned long | startFrame
The number of the frame this run should be updated first.
unsigned long | updateInterval
Refresh frequency in frames.

Static Protected Attributes

static MovablePlane * | fullScreenQuad
fulls screen quad plane used in full screen quad rendering
static MovablePlane * | fullScreenQuad
fulls screen quad plane used in full screen quad rendering
static Entity * | fullScreenQuadEntity
fulls screen quad Entity used in full screen quad rendering
static Entity * | fullScreenQuadEntity
fulls screen quad Entity used in full screen quad rendering
static SceneNode * | fullScreenQuadNode
fulls screen quad SceneNode used in full screen quad rendering
static SceneNode * | fullScreenQuadNode
fulls screen quad SceneNode used in full screen quad rendering

Detailed Description

Entry point map computing run.

This map is used in the pathmap technique. It stores entry point positions and normals. This texture will be used to determine the amount of incoming light to an entry point.

See also:
OgrePMWeightComputeRenderingRun

Constructor & Destructor Documentation

OgrePMEntryPointMapRenderingRun::OgrePMEntryPointMapRenderingRun ( String name )

Constructor.

Parameters:
name the name of the entry point texture created ny this run

Member Function Documentation

String OgrePMEntryPointMapRenderingRun::getClusterLengthTextureName ( ) [inline]

returns the name of the cluster length texture.

This texture stores the size (number of entripoints) of each entry point cluster.

void OgrePMEntryPointMapRenderingRun::updateFrame ( unsigned long frameNum ) [protected, virtual]

This function does the actual update in a frame.

Parameters:
frameNum current frame number

Reimplemented from RenderingRun.

bool OgrePMEntryPointMapRenderingRun::needUpdate ( unsigned long frameNum ) [inline, protected, virtual]

Returns if this run needs update.

This tipically depends on the upate interval and the starting frame number.

Parameters:
frameNum current frame number

Reimplemented from RenderingRun.

OgreRenderingRun* OgreRenderingRun::asOgreRenderingRun ( ) [inline, virtual, inherited]

Conversion to OgreRenderRun.

This function is needed because of virtual inheritance.

Reimplemented from RenderingRun.

OgreRenderingRun* OgreRenderingRun::asOgreRenderingRun ( ) [inline, virtual, inherited]

Conversion to OgreRenderRun.

This function is needed because of virtual inheritance.

Reimplemented from RenderingRun.

Vector3 OgreRenderingRun::getCubeMapFaceDirection ( unsigned char faceId ) [protected, inherited]

Returns a direction for a cubemap face id.

This is a helper function to retrieve the normal direction of a given cubemap face.

Parameters:
faceId the number of the face

Vector3 OgreRenderingRun::getCubeMapFaceDirection ( unsigned char faceId ) [protected, inherited]

Returns a direction for a cubemap face id.

This is a helper function to retrieve the normal direction of a given cubemap face.

Parameters:
faceId the number of the face

Texture * OgreRenderingRun::createCubeRenderTexture | ( | String | name,
 |  | const Vector3 | position,
 |  | unsigned int | resolution = 512,
 |  | PixelFormat | format = PF_FLOAT16_RGBA,
 |  | int | numMips = 0,
 |  | ColourValue | clearColor = ColourValue::Black |
 | ) |  |  | [protected, inherited]

Creates a cubemap texture.

This is a helper function to easily create a cubemap texture and automaticly attach viewports to each face so it can be used as a rendertarget.

Parameters:
name | the name of the texture to be created
position | the initial position of the cubemap
resolution | the resolution of one cubemapface
format | the pixel format of the cubemap
numMips | the number of mipmap levels
clearColor | initial color

Texture* OgreRenderingRun::createCubeRenderTexture | ( | String | name,
 |  | const Vector3 | position,
 |  | unsigned int | resolution = 512,
 |  | PixelFormat | format = PF_FLOAT16_RGBA,
 |  | int | numMips = 0,
 |  | ColourValue | clearColor = ColourValue::Black |
 | ) |  |  | [protected, inherited]

Creates a cubemap texture.

This is a helper function to easily create a cubemap texture and automaticly attach viewports to each face so it can be used as a rendertarget.

Parameters:
name | the name of the texture to be created
position | the initial position of the cubemap
resolution | the resolution of one cubemapface
format | the pixel format of the cubemap
numMips | the number of mipmap levels
clearColor | initial color

void OgreRenderingRun::setMaterialForRenderables | ( | String & | materialName,
 |  | RenderQueue * | rq |
 | ) |  |  | [protected, inherited]

Sets the given material for each Renderable in a RenderQueue.

This is a helper function to set a material to each element of a previously filled Renderque. The orginal material of the Renderables are stored so they can be restored later. The function also tells the current SceneManager not to search for visible objects, as we are going to use the given RenderQueue during the next rendering.

Parameters:
materialName | the name of the material to set for the Renderables
rq | pointer to the filled Renderqueue instance to set material for

void OgreRenderingRun::setMaterialForRenderables | ( | String & | materialName,
 |  | RenderQueue * | rq,
 |  | bool | solidsonly = false |
 | ) |  |  | [protected, inherited]

Sets the given material for each Renderable in a RenderQueue.

This is a helper function to set a material to each element of a previously filled Renderque. The orginal material of the Renderables are stored so they can be restored later. The function also tells the current SceneManager not to search for visible objects, as we are going to use the given RenderQueue during the next rendering.

Parameters:
materialName | the name of the material to set for the Renderables
rq | pointer to the filled Renderqueue instance to set material for

void OgreRenderingRun::setMaterialForVisibles | ( | String & | materialName,
 |  | Camera * | cam,
 |  | bool | shadowcastersonly = false |
 | ) |  |  | [protected, inherited]

Sets the given material for each Renderable visible from a given camera.

This helper function is similar to setMaterialForRenderables but it is also responsible for filling the RenderQueue. First the RenderQueue of the current SceneManager fill be filled with the visible objects seen from the given camera. Then the required material will be set for each element of the RenderQueue. The orginal material of the Renderables are stored so they can be restored later. The function also tells the current SceneManager not to search for visible objects, as we are going to use the filled RenderQueue during the next rendering.

Parameters:
materialName | the name of the material to set for the Renderables
cam | pointer to the camera from which visible objects should be searched
shadowcastersonly | flag to search for only shadow casters

void OgreRenderingRun::setMaterialForVisibles | ( | String & | materialName,
 |  | Camera * | cam,
 |  | bool | shadowcastersonly = false,
 |  | bool | solidsonly = false |
 | ) |  |  | [protected, inherited]

Sets the given material for each Renderable visible from a given camera.

This helper function is similar to setMaterialForRenderables but it is also responsible for filling the RenderQueue. First the RenderQueue of the current SceneManager fill be filled with the visible objects seen from the given camera. Then the required material will be set for each element of the RenderQueue. The orginal material of the Renderables are stored so they can be restored later. The function also tells the current SceneManager not to search for visible objects, as we are going to use the filled RenderQueue during the next rendering.

Parameters:
materialName | the name of the material to set for the Renderables
cam | pointer to the camera from which visible objects should be searched
shadowcastersonly | flag to search for only shadow casters

void OgreRenderingRun::restoreMaterials ( ) [protected, inherited]

Restores previously stored materials.

This helper function is typically used after a setMaterialForRenderables or setMaterialForVisibles call and a rendering process to restore the original material settings. The function also tells the current SceneManager to search for visible objects, as this is the default behaviour of SceneManager.

void OgreRenderingRun::restoreMaterials ( ) [protected, inherited]

Restores previously stored materials.

This helper function is typically used after a setMaterialForRenderables or setMaterialForVisibles call and a rendering process to restore the original material settings. The function also tells the current SceneManager to search for visible objects, as this is the default behaviour of SceneManager.

void OgreRenderingRun::renderFullscreenQuad | ( | String | materialName,
 |  | RenderTarget * | target |
 | ) |  |  | [protected, inherited]

Renderes a full screen quad on a given RendderTarget with a given material.

Parameters:
materialName | the name of the material bind to the quad
target | the RenderTarget the quad should be rendered on

void OgreRenderingRun::renderFullscreenQuad | ( | String | materialName,
 |  | RenderTarget * | target |
 | ) |  |  | [protected, inherited]

Renderes a full screen quad on a given RendderTarget with a given material.

Parameters:
materialName | the name of the material bind to the quad
target | the RenderTarget the quad should be rendered on

void OgreRenderingRun::renderPixelSprites | ( | String & | materialName,
 |  | RenderTarget * | rt,
 |  | int | width,
 |  | int | height |
 | ) |  |  | [protected, inherited]

Renderes sprites to pixels of the screen on a given RendderTarget with a given material.

Pixel sprites are pixel sized quads, placed on each pixel of the RenderTarget. The number of sprites not necessary corresponds to the resolution of the rendertarget. The pixel quads will evenly fill the rendertarget's area with sizes corresponding to the given resolution. We can render fewer or more pixel quads than the number of pixels the rendertarget has (eg.: in case of caustic cubemap generation).

Parameters:
materialName | the name of the material bind to the pixel sprites
rt | the RenderTarget the quads should be rendered on
width | the desired resolution width of the sprites
height | the desired resolution height of the sprites

void OgreRenderingRun::renderPixelSprites | ( | String & | materialName,
 |  | RenderTarget * | rt,
 |  | int | width,
 |  | int | height |
 | ) |  |  | [protected, inherited]

Renderes sprites to pixels of the screen on a given RendderTarget with a given material.

Pixel sprites are pixel sized quads, placed on each pixel of the RenderTarget. The number of sprites not necessary corresponds to the resolution of the rendertarget. The pixel quads will evenly fill the rendertarget's area with sizes corresponding to the given resolution. We can render fewer or more pixel quads than the number of pixels the rendertarget has (eg.: in case of caustic cubemap generation).

Parameters:
materialName | the name of the material bind to the pixel sprites
rt | the RenderTarget the quads should be rendered on
width | the desired resolution width of the sprites
height | the desired resolution height of the sprites

void OgreRenderingRun::renderFullscreenGrid | ( | String & | materialName,
 |  | RenderTarget * | rt,
 |  | int | width,
 |  | int | height |
 | ) |  |  | [protected, inherited]

Renders a grid onto the screen.

Parameters:
rt | the RenderTarget the grid should be rendered on
width | the desired horizontal resolution of the grid
height | the desired vertical resolution of the grid

virtual bool RenderingRun::canJoin ( RenderingRun * run ) [inline, virtual, inherited]

Returns true if two runs can be joined.

In some cases special requirements should stand to join two runs (even if they have the same type). Eg.: two caustic cube map generation technique should only be joined if they use the same material when rendering the caustic cubemap.

Reimplemented in OgreCausticCubeMapRenderingRun, OgreChildPSystemRenderingRun, and OgrePhotonMapRenderingRun.

Member Data Documentation

Texture* OgrePMEntryPointMapRenderingRun::clusterLengthTexture [protected]

a pointer to the cluster length texture that was created by this run

This texture stores the size (number of entripoints) of each entry point cluster.

std::map<Renderable*, String> OgreRenderingRun::visibleObjects [protected, inherited]

map of Renderables which will be rendered with a given material

The String stores the original material name that will be restored after rendering.

See also:
setMaterialForVisibles

setMaterialForRenderables

restoreMaterials

std::map<Renderable*, String> OgreRenderingRun::visibleObjects [protected, inherited]

map of Renderables which will be rendered with a given material

The String stores the original material name that will be restored after rendering.

See also:
setMaterialForVisibles

setMaterialForRenderables

restoreMaterials

MovablePlane * OgreRenderingRun::fullScreenQuad [static, protected, inherited]

fulls screen quad plane used in full screen quad rendering

See also:
renderFullscreenQuad

MovablePlane* OgreRenderingRun::fullScreenQuad [static, protected, inherited]

fulls screen quad plane used in full screen quad rendering

See also:
renderFullscreenQuad

Entity * OgreRenderingRun::fullScreenQuadEntity [static, protected, inherited]

fulls screen quad Entity used in full screen quad rendering

See also:
renderFullscreenQuad

Entity* OgreRenderingRun::fullScreenQuadEntity [static, protected, inherited]

fulls screen quad Entity used in full screen quad rendering

See also:
renderFullscreenQuad

SceneNode * OgreRenderingRun::fullScreenQuadNode [static, protected, inherited]

fulls screen quad SceneNode used in full screen quad rendering

See also:
renderFullscreenQuad

SceneNode* OgreRenderingRun::fullScreenQuadNode [static, protected, inherited]

fulls screen quad SceneNode used in full screen quad rendering

See also:
renderFullscreenQuad

SpriteSet* OgreRenderingRun::pixelSprites [protected, inherited]

SpriteSet used in pixel sprite rendering.

See also:
renderPixelSprites

BillboardSet* OgreRenderingRun::pixelSprites [protected, inherited]

SpriteSet used in pixel sprite rendering.

See also:
renderPixelSprites

String OgreRenderingRun::spriteSetName [protected, inherited]

unique name of the SpriteSet used in pixel sprite rendering

See also:
renderPixelSprites

Entity* OgreRenderingRun::fullscreenGrid [protected, inherited]

Entity used in fullscreen grid rendering.

See also:
renderPixelGrid

Generated on Wed Mar 28 11:48:58 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: OgrePMWeightComputeRenderingRun Class Reference

OgrePMWeightComputeRenderingRun Class Reference

Weight computing rendering run. More...

Inheritance diagram for OgrePMWeightComputeRenderingRun:

OgreRenderingRun RenderingRun RenderingRun List of all members.

Public Member Functions

OgrePMWeightComputeRenderingRun (String name, String LightName)
Constructor.
String | getPMWeightTetureName ()
returns the name of the weight texture
OgreRenderingRun * asOgreRenderingRun ()
Conversion to OgreRenderRun.
OgreRenderingRun * asOgreRenderingRun ()
Conversion to OgreRenderRun.
bool | update (unsigned long frameNum)
Calls updateFrame() if the run needs update according to its starting frame and update interval and has not been allready updated in this frame.
virtual bool | canJoin (RenderingRun *run)
Returns true if two runs can be joined.

Protected Member Functions

void | updateFrame (unsigned long frameNum)
This function does the actual update in a frame.
void | createWeightMap ()
Creates the weight texture.
Vector3 | getCubeMapFaceDirection (unsigned char faceId)
Returns a direction for a cubemap face id.
Vector3 | getCubeMapFaceDirection (unsigned char faceId)
Returns a direction for a cubemap face id.
Texture * | createCubeRenderTexture (String name, const Vector3 position, unsigned int resolution=512, PixelFormat format=PF_FLOAT16_RGBA, int numMips=0, ColourValue clearColor=ColourValue::Black)
Creates a cubemap texture.
Texture * | createCubeRenderTexture (String name, const Vector3 position, unsigned int resolution=512, PixelFormat format=PF_FLOAT16_RGBA, int numMips=0, ColourValue clearColor=ColourValue::Black)
Creates a cubemap texture.
void | setMaterialForRenderables (String &materialName, RenderQueue *rq)
Sets the given material for each Renderable in a RenderQueue.
void | setMaterialForRenderables (String &materialName, RenderQueue *rq, bool solidsonly=false)
Sets the given material for each Renderable in a RenderQueue.
void | setMaterialForVisibles (String &materialName, Camera *cam, bool shadowcastersonly=false)
Sets the given material for each Renderable visible from a given camera.
void | setMaterialForVisibles (String &materialName, Camera *cam, bool shadowcastersonly=false, bool solidsonly=false)
Sets the given material for each Renderable visible from a given camera.
void | restoreMaterials ()
Restores previously stored materials.
void | restoreMaterials ()
Restores previously stored materials.
void | renderFullscreenQuad (String materialName, RenderTarget *target)
Renderes a full screen quad on a given RendderTarget with a given material.
void | renderFullscreenQuad (String materialName, RenderTarget *target)
Renderes a full screen quad on a given RendderTarget with a given material.
void | renderPixelSprites (String &materialName, RenderTarget *rt, int width, int height)
Renderes sprites to pixels of the screen on a given RendderTarget with a given material.
void | renderPixelSprites (String &materialName, RenderTarget *rt, int width, int height)
Renderes sprites to pixels of the screen on a given RendderTarget with a given material.
void | renderFullscreenGrid (String &materialName, RenderTarget *rt, int width, int height)
Renders a grid onto the screen.
virtual bool | needUpdate (unsigned long frameNum)
Returns if this run needs update.

Protected Attributes

Matrix4 | lightMatrix
light view-projection matrix
Matrix4 | lightViewMatrix
light view matrix
String | name
the name of the weight texture that was created by this run
Texture * | weightTexture
a pointer to the weight texture that was created by this run
Texture * | allWeightsTexture
A pointer to a texture that stores weights for all the entry point.
Light * | light
A pointer to the light source.
std::map< Renderable *, String > | visibleObjects
map of Renderables which will be rendered with a given material
std::map< Renderable *, String > | visibleObjects
map of Renderables which will be rendered with a given material
SpriteSet * | pixelSprites
SpriteSet used in pixel sprite rendering.
BillboardSet * | pixelSprites
SpriteSet used in pixel sprite rendering.
String | spriteSetName
unique name of the SpriteSet used in pixel sprite rendering
Entity * | fullscreenGrid
Entity used in fullscreen grid rendering.
unsigned long | lastupdated
The number of the last frame this run was updated.
unsigned long | startFrame
The number of the frame this run should be updated first.
unsigned long | updateInterval
Refresh frequency in frames.

Static Protected Attributes

static MovablePlane * | fullScreenQuad
fulls screen quad plane used in full screen quad rendering
static MovablePlane * | fullScreenQuad
fulls screen quad plane used in full screen quad rendering
static Entity * | fullScreenQuadEntity
fulls screen quad Entity used in full screen quad rendering
static Entity * | fullScreenQuadEntity
fulls screen quad Entity used in full screen quad rendering
static SceneNode * | fullScreenQuadNode
fulls screen quad SceneNode used in full screen quad rendering
static SceneNode * | fullScreenQuadNode
fulls screen quad SceneNode used in full screen quad rendering

Detailed Description

Weight computing rendering run.

This run is used in the pathmap technique. It creates a texture for a light source that stores the weights that should be used for each cluster of entry points.

Constructor & Destructor Documentation

OgrePMWeightComputeRenderingRun::OgrePMWeightComputeRenderingRun | ( | String | name,
 |  | String | LightName
 | ) |  |

Constructor.

Parameters:
name | the name of the weight texture to be created
LightName | the name of the light source to use

Member Function Documentation

void OgrePMWeightComputeRenderingRun::updateFrame ( unsigned long frameNum ) [protected, virtual]

This function does the actual update in a frame.

Parameters:
frameNum current frame number

Reimplemented from RenderingRun.

void OgrePMWeightComputeRenderingRun::createWeightMap ( ) [inline, protected]

Creates the weight texture.

It also creates the texture storing all weights.

See also:
allWeightsTexture

OgreRenderingRun* OgreRenderingRun::asOgreRenderingRun ( ) [inline, virtual, inherited]

Conversion to OgreRenderRun.

This function is needed because of virtual inheritance.

Reimplemented from RenderingRun.

OgreRenderingRun* OgreRenderingRun::asOgreRenderingRun ( ) [inline, virtual, inherited]

Conversion to OgreRenderRun.

This function is needed because of virtual inheritance.

Reimplemented from RenderingRun.

Vector3 OgreRenderingRun::getCubeMapFaceDirection ( unsigned char faceId ) [protected, inherited]

Returns a direction for a cubemap face id.

This is a helper function to retrieve the normal direction of a given cubemap face.

Parameters:
faceId the number of the face

Vector3 OgreRenderingRun::getCubeMapFaceDirection ( unsigned char faceId ) [protected, inherited]

Returns a direction for a cubemap face id.

This is a helper function to retrieve the normal direction of a given cubemap face.

Parameters:
faceId the number of the face

Texture * OgreRenderingRun::createCubeRenderTexture | ( | String | name,
 |  | const Vector3 | position,
 |  | unsigned int | resolution = 512,
 |  | PixelFormat | format = PF_FLOAT16_RGBA,
 |  | int | numMips = 0,
 |  | ColourValue | clearColor = ColourValue::Black |
 | ) |  |  | [protected, inherited]

Creates a cubemap texture.

This is a helper function to easily create a cubemap texture and automaticly attach viewports to each face so it can be used as a rendertarget.

Parameters:
name | the name of the texture to be created
position | the initial position of the cubemap
resolution | the resolution of one cubemapface
format | the pixel format of the cubemap
numMips | the number of mipmap levels
clearColor | initial color

Texture* OgreRenderingRun::createCubeRenderTexture | ( | String | name,
 |  | const Vector3 | position,
 |  | unsigned int | resolution = 512,
 |  | PixelFormat | format = PF_FLOAT16_RGBA,
 |  | int | numMips = 0,
 |  | ColourValue | clearColor = ColourValue::Black |
 | ) |  |  | [protected, inherited]

Creates a cubemap texture.

This is a helper function to easily create a cubemap texture and automaticly attach viewports to each face so it can be used as a rendertarget.

Parameters:
name | the name of the texture to be created
position | the initial position of the cubemap
resolution | the resolution of one cubemapface
format | the pixel format of the cubemap
numMips | the number of mipmap levels
clearColor | initial color

void OgreRenderingRun::setMaterialForRenderables | ( | String & | materialName,
 |  | RenderQueue * | rq |
 | ) |  |  | [protected, inherited]

Sets the given material for each Renderable in a RenderQueue.

This is a helper function to set a material to each element of a previously filled Renderque. The orginal material of the Renderables are stored so they can be restored later. The function also tells the current SceneManager not to search for visible objects, as we are going to use the given RenderQueue during the next rendering.

Parameters:
materialName | the name of the material to set for the Renderables
rq | pointer to the filled Renderqueue instance to set material for

void OgreRenderingRun::setMaterialForRenderables | ( | String & | materialName,
 |  | RenderQueue * | rq,
 |  | bool | solidsonly = false |
 | ) |  |  | [protected, inherited]

Sets the given material for each Renderable in a RenderQueue.

This is a helper function to set a material to each element of a previously filled Renderque. The orginal material of the Renderables are stored so they can be restored later. The function also tells the current SceneManager not to search for visible objects, as we are going to use the given RenderQueue during the next rendering.

Parameters:
materialName | the name of the material to set for the Renderables
rq | pointer to the filled Renderqueue instance to set material for

void OgreRenderingRun::setMaterialForVisibles | ( | String & | materialName,
 |  | Camera * | cam,
 |  | bool | shadowcastersonly = false |
 | ) |  |  | [protected, inherited]

Sets the given material for each Renderable visible from a given camera.

This helper function is similar to setMaterialForRenderables but it is also responsible for filling the RenderQueue. First the RenderQueue of the current SceneManager fill be filled with the visible objects seen from the given camera. Then the required material will be set for each element of the RenderQueue. The orginal material of the Renderables are stored so they can be restored later. The function also tells the current SceneManager not to search for visible objects, as we are going to use the filled RenderQueue during the next rendering.

Parameters:
materialName | the name of the material to set for the Renderables
cam | pointer to the camera from which visible objects should be searched
shadowcastersonly | flag to search for only shadow casters

void OgreRenderingRun::setMaterialForVisibles | ( | String & | materialName,
 |  | Camera * | cam,
 |  | bool | shadowcastersonly = false,
 |  | bool | solidsonly = false |
 | ) |  |  | [protected, inherited]

Sets the given material for each Renderable visible from a given camera.

This helper function is similar to setMaterialForRenderables but it is also responsible for filling the RenderQueue. First the RenderQueue of the current SceneManager fill be filled with the visible objects seen from the given camera. Then the required material will be set for each element of the RenderQueue. The orginal material of the Renderables are stored so they can be restored later. The function also tells the current SceneManager not to search for visible objects, as we are going to use the filled RenderQueue during the next rendering.

Parameters:
materialName | the name of the material to set for the Renderables
cam | pointer to the camera from which visible objects should be searched
shadowcastersonly | flag to search for only shadow casters

void OgreRenderingRun::restoreMaterials ( ) [protected, inherited]

Restores previously stored materials.

This helper function is typically used after a setMaterialForRenderables or setMaterialForVisibles call and a rendering process to restore the original material settings. The function also tells the current SceneManager to search for visible objects, as this is the default behaviour of SceneManager.

void OgreRenderingRun::restoreMaterials ( ) [protected, inherited]

Restores previously stored materials.

This helper function is typically used after a setMaterialForRenderables or setMaterialForVisibles call and a rendering process to restore the original material settings. The function also tells the current SceneManager to search for visible objects, as this is the default behaviour of SceneManager.

void OgreRenderingRun::renderFullscreenQuad | ( | String | materialName,
 |  | RenderTarget * | target |
 | ) |  |  | [protected, inherited]

Renderes a full screen quad on a given RendderTarget with a given material.

Parameters:
materialName | the name of the material bind to the quad
target | the RenderTarget the quad should be rendered on

void OgreRenderingRun::renderFullscreenQuad | ( | String | materialName,
 |  | RenderTarget * | target |
 | ) |  |  | [protected, inherited]

Renderes a full screen quad on a given RendderTarget with a given material.

Parameters:
materialName | the name of the material bind to the quad
target | the RenderTarget the quad should be rendered on

void OgreRenderingRun::renderPixelSprites | ( | String & | materialName,
 |  | RenderTarget * | rt,
 |  | int | width,
 |  | int | height |
 | ) |  |  | [protected, inherited]

Renderes sprites to pixels of the screen on a given RendderTarget with a given material.

Pixel sprites are pixel sized quads, placed on each pixel of the RenderTarget. The number of sprites not necessary corresponds to the resolution of the rendertarget. The pixel quads will evenly fill the rendertarget's area with sizes corresponding to the given resolution. We can render fewer or more pixel quads than the number of pixels the rendertarget has (eg.: in case of caustic cubemap generation).

Parameters:
materialName | the name of the material bind to the pixel sprites
rt | the RenderTarget the quads should be rendered on
width | the desired resolution width of the sprites
height | the desired resolution height of the sprites

void OgreRenderingRun::renderPixelSprites | ( | String & | materialName,
 |  | RenderTarget * | rt,
 |  | int | width,
 |  | int | height |
 | ) |  |  | [protected, inherited]

Renderes sprites to pixels of the screen on a given RendderTarget with a given material.

Pixel sprites are pixel sized quads, placed on each pixel of the RenderTarget. The number of sprites not necessary corresponds to the resolution of the rendertarget. The pixel quads will evenly fill the rendertarget's area with sizes corresponding to the given resolution. We can render fewer or more pixel quads than the number of pixels the rendertarget has (eg.: in case of caustic cubemap generation).

Parameters:
materialName | the name of the material bind to the pixel sprites
rt | the RenderTarget the quads should be rendered on
width | the desired resolution width of the sprites
height | the desired resolution height of the sprites

void OgreRenderingRun::renderFullscreenGrid | ( | String & | materialName,
 |  | RenderTarget * | rt,
 |  | int | width,
 |  | int | height |
 | ) |  |  | [protected, inherited]

Renders a grid onto the screen.

Parameters:
rt | the RenderTarget the grid should be rendered on
width | the desired horizontal resolution of the grid
height | the desired vertical resolution of the grid

virtual bool RenderingRun::canJoin ( RenderingRun * run ) [inline, virtual, inherited]

Returns true if two runs can be joined.

In some cases special requirements should stand to join two runs (even if they have the same type). Eg.: two caustic cube map generation technique should only be joined if they use the same material when rendering the caustic cubemap.

Reimplemented in OgreCausticCubeMapRenderingRun, OgreChildPSystemRenderingRun, and OgrePhotonMapRenderingRun.

virtual bool RenderingRun::needUpdate ( unsigned long frameNum ) [inline, protected, virtual, inherited]

Returns if this run needs update.

This tipically depends on the upate interval and the starting frame number.

Parameters:
frameNum current frame number

Reimplemented in OgreFocusingMapRenderingRun, and OgrePMEntryPointMapRenderingRun.

Member Data Documentation

Texture* OgrePMWeightComputeRenderingRun::allWeightsTexture [protected]

A pointer to a texture that stores weights for all the entry point.

This texture will be used to determine the weights of the clusters.

std::map<Renderable*, String> OgreRenderingRun::visibleObjects [protected, inherited]

map of Renderables which will be rendered with a given material

The String stores the original material name that will be restored after rendering.

See also:
setMaterialForVisibles

setMaterialForRenderables

restoreMaterials

std::map<Renderable*, String> OgreRenderingRun::visibleObjects [protected, inherited]

map of Renderables which will be rendered with a given material

The String stores the original material name that will be restored after rendering.

See also:
setMaterialForVisibles

setMaterialForRenderables

restoreMaterials

MovablePlane * OgreRenderingRun::fullScreenQuad [static, protected, inherited]

fulls screen quad plane used in full screen quad rendering

See also:
renderFullscreenQuad

MovablePlane* OgreRenderingRun::fullScreenQuad [static, protected, inherited]

fulls screen quad plane used in full screen quad rendering

See also:
renderFullscreenQuad

Entity * OgreRenderingRun::fullScreenQuadEntity [static, protected, inherited]

fulls screen quad Entity used in full screen quad rendering

See also:
renderFullscreenQuad

Entity* OgreRenderingRun::fullScreenQuadEntity [static, protected, inherited]

fulls screen quad Entity used in full screen quad rendering

See also:
renderFullscreenQuad

SceneNode * OgreRenderingRun::fullScreenQuadNode [static, protected, inherited]

fulls screen quad SceneNode used in full screen quad rendering

See also:
renderFullscreenQuad

SceneNode* OgreRenderingRun::fullScreenQuadNode [static, protected, inherited]

fulls screen quad SceneNode used in full screen quad rendering

See also:
renderFullscreenQuad

SpriteSet* OgreRenderingRun::pixelSprites [protected, inherited]

SpriteSet used in pixel sprite rendering.

See also:
renderPixelSprites

BillboardSet* OgreRenderingRun::pixelSprites [protected, inherited]

SpriteSet used in pixel sprite rendering.

See also:
renderPixelSprites

String OgreRenderingRun::spriteSetName [protected, inherited]

unique name of the SpriteSet used in pixel sprite rendering

See also:
renderPixelSprites

Entity* OgreRenderingRun::fullscreenGrid [protected, inherited]

Entity used in fullscreen grid rendering.

See also:
renderPixelGrid

Generated on Wed Mar 28 11:48:58 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: OgreReducedCubeMapRenderingRun Class Reference

OgreReducedCubeMapRenderingRun Class Reference

ReducedCubeMapRenderingRun used in an OGRE environment. More...

Inheritance diagram for OgreReducedCubeMapRenderingRun:

OgreRenderingRun ReducedCubeMapRenderingRun RenderingRun RenderingRun RenderingRun List of all members.

Public Member Functions

OgreReducedCubeMapRenderingRun (OgreSharedRuns *sharedRuns, String name, unsigned long startFrame, unsigned long updateInterval, unsigned int resolution, bool useDistCalc=false, bool useFaceAngleCalc=false, float distTolerance=15, float angleTolerance=10, bool updateAllFace=false)
Constructor.
String & | getReducedCubeMapTextureName ()
returns the name of the resulting downsampled color cubemap texture
OgreRenderingRun * asOgreRenderingRun ()
Conversion to OgreRenderRun.
OgreRenderingRun * asOgreRenderingRun ()
Conversion to OgreRenderRun.
bool | update (unsigned long frameNum)
Calls updateFrame() if the run needs update according to its starting frame and update interval and has not been allready updated in this frame.
virtual bool | canJoin (RenderingRun *run)
Returns true if two runs can be joined.

Protected Member Functions

void | createReducedCubeMap ()
Creates the reduced size cubemap texture.
void | updateCubeFace (int facenum)
Updates one face of the cubemap.
bool | faceNeedsUpdate (int facenum)
Checks if a cubemap face needs to be updated.
Vector3 | getCubeMapFaceDirection (unsigned char faceId)
Returns a direction for a cubemap face id.
Vector3 | getCubeMapFaceDirection (unsigned char faceId)
Returns a direction for a cubemap face id.
Texture * | createCubeRenderTexture (String name, const Vector3 position, unsigned int resolution=512, PixelFormat format=PF_FLOAT16_RGBA, int numMips=0, ColourValue clearColor=ColourValue::Black)
Creates a cubemap texture.
Texture * | createCubeRenderTexture (String name, const Vector3 position, unsigned int resolution=512, PixelFormat format=PF_FLOAT16_RGBA, int numMips=0, ColourValue clearColor=ColourValue::Black)
Creates a cubemap texture.
void | setMaterialForRenderables (String &materialName, RenderQueue *rq)
Sets the given material for each Renderable in a RenderQueue.
void | setMaterialForRenderables (String &materialName, RenderQueue *rq, bool solidsonly=false)
Sets the given material for each Renderable in a RenderQueue.
void | setMaterialForVisibles (String &materialName, Camera *cam, bool shadowcastersonly=false)
Sets the given material for each Renderable visible from a given camera.
void | setMaterialForVisibles (String &materialName, Camera *cam, bool shadowcastersonly=false, bool solidsonly=false)
Sets the given material for each Renderable visible from a given camera.
void | restoreMaterials ()
Restores previously stored materials.
void | restoreMaterials ()
Restores previously stored materials.
void | renderFullscreenQuad (String materialName, RenderTarget *target)
Renderes a full screen quad on a given RendderTarget with a given material.
void | renderFullscreenQuad (String materialName, RenderTarget *target)
Renderes a full screen quad on a given RendderTarget with a given material.
void | renderPixelSprites (String &materialName, RenderTarget *rt, int width, int height)
Renderes sprites to pixels of the screen on a given RendderTarget with a given material.
void | renderPixelSprites (String &materialName, RenderTarget *rt, int width, int height)
Renderes sprites to pixels of the screen on a given RendderTarget with a given material.
void | renderFullscreenGrid (String &materialName, RenderTarget *rt, int width, int height)
Renders a grid onto the screen.
virtual bool | needUpdate (unsigned long frameNum)
Returns if this run needs update.
virtual void | updateFrame (unsigned long frameNum)
This function does the actual update in a frame.
virtual void | updateFrame (unsigned long frameNum)
This function does the actual update in a frame.

Protected Attributes

OgreSharedRuns * sharedRuns
a pointer to the OgreSharedRuns this run belongs to
String | name
the name of the downsampled cubemap texture that was created by this run
Texture * | reducedCubemapTexture
a pointer to the downsampled cubemap texture that was created by this run
std::map< Renderable *, String > | visibleObjects
map of Renderables which will be rendered with a given material
std::map< Renderable *, String > | visibleObjects
map of Renderables which will be rendered with a given material
SpriteSet * | pixelSprites
SpriteSet used in pixel sprite rendering.
BillboardSet * | pixelSprites
SpriteSet used in pixel sprite rendering.
String | spriteSetName
unique name of the SpriteSet used in pixel sprite rendering
Entity * | fullscreenGrid
Entity used in fullscreen grid rendering.
unsigned long | lastupdated
The number of the last frame this run was updated.
unsigned long | startFrame
The number of the frame this run should be updated first.
unsigned long | updateInterval
Refresh frequency in frames.
bool | updateAllFace
defines if all cubemap faces should be updated in a frame or only one face per frame
unsigned char | currentFace
the number of the face to be updated
unsigned int | resolution
the resolution of the cubemap texture that was created by this run
bool | useDistCalc
a flag to skip cube face update if object is far away or too small.
bool | useFaceAngleCalc
a flag to skip cube face update the face is neglible.
float | distTolerance
A value used in face skip test.
float | angleTolerance
A value used in face skip test.

Static Protected Attributes

static MovablePlane * | fullScreenQuad
fulls screen quad plane used in full screen quad rendering
static MovablePlane * | fullScreenQuad
fulls screen quad plane used in full screen quad rendering
static Entity * | fullScreenQuadEntity
fulls screen quad Entity used in full screen quad rendering
static Entity * | fullScreenQuadEntity
fulls screen quad Entity used in full screen quad rendering
static SceneNode * | fullScreenQuadNode
fulls screen quad SceneNode used in full screen quad rendering
static SceneNode * | fullScreenQuadNode
fulls screen quad SceneNode used in full screen quad rendering

Detailed Description

ReducedCubeMapRenderingRun used in an OGRE environment.

Constructor & Destructor Documentation

OgreReducedCubeMapRenderingRun::OgreReducedCubeMapRenderingRun | ( | OgreSharedRuns * | sharedRuns,
 |  | String | name,
 |  | unsigned long | startFrame,
 |  | unsigned long | updateInterval,
 |  | unsigned int | resolution,
 |  | bool | useDistCalc = false,
 |  | bool | useFaceAngleCalc = false,
 |  | float | distTolerance = 15,
 |  | float | angleTolerance = 10,
 |  | bool | updateAllFace = false
 | ) |  |

Constructor.

Parameters:
sharedRuns | a pointer to the OgreSharedRuns this run belongs to
name | the name of the cubemap texture to be created
startFrame | adds an offset to the current frame number to help evenly distribute updates between frames
updateInterval | update frequency
resolution | cubemap resolution
useDistCalc | flag to skip cube face update if object is far away
useFaceAngleCalc | flag to skip cube face update if face is neglible
distTolerance | distance tolerance used in face skip
angleTolerance | angle tolerance used in face skip
updateAllFace | defines if all cubemap faces should be updated in a frame or only one face per frame

Member Function Documentation

void OgreReducedCubeMapRenderingRun::updateCubeFace ( int facenum ) [inline, protected, virtual]

Updates one face of the cubemap.

Parameters:
facenum the number of the face to be updated

Implements ReducedCubeMapRenderingRun.

bool OgreReducedCubeMapRenderingRun::faceNeedsUpdate ( int facenum ) [protected, virtual]

Checks if a cubemap face needs to be updated.

If the object we are updating the cubemap for is far from the camera, or too small, or the given cubemapface does not have significant effect on the rendering the face can be skipped.

Parameters:
facenum the number of the face to be checked

Implements ReducedCubeMapRenderingRun.

OgreRenderingRun* OgreRenderingRun::asOgreRenderingRun ( ) [inline, virtual, inherited]

Conversion to OgreRenderRun.

This function is needed because of virtual inheritance.

Reimplemented from RenderingRun.

OgreRenderingRun* OgreRenderingRun::asOgreRenderingRun ( ) [inline, virtual, inherited]

Conversion to OgreRenderRun.

This function is needed because of virtual inheritance.

Reimplemented from RenderingRun.

Vector3 OgreRenderingRun::getCubeMapFaceDirection ( unsigned char faceId ) [protected, inherited]

Returns a direction for a cubemap face id.

This is a helper function to retrieve the normal direction of a given cubemap face.

Parameters:
faceId the number of the face

Vector3 OgreRenderingRun::getCubeMapFaceDirection ( unsigned char faceId ) [protected, inherited]

Returns a direction for a cubemap face id.

This is a helper function to retrieve the normal direction of a given cubemap face.

Parameters:
faceId the number of the face

Texture * OgreRenderingRun::createCubeRenderTexture | ( | String | name,
 |  | const Vector3 | position,
 |  | unsigned int | resolution = 512,
 |  | PixelFormat | format = PF_FLOAT16_RGBA,
 |  | int | numMips = 0,
 |  | ColourValue | clearColor = ColourValue::Black |
 | ) |  |  | [protected, inherited]

Creates a cubemap texture.

This is a helper function to easily create a cubemap texture and automaticly attach viewports to each face so it can be used as a rendertarget.

Parameters:
name | the name of the texture to be created
position | the initial position of the cubemap
resolution | the resolution of one cubemapface
format | the pixel format of the cubemap
numMips | the number of mipmap levels
clearColor | initial color

Texture* OgreRenderingRun::createCubeRenderTexture | ( | String | name,
 |  | const Vector3 | position,
 |  | unsigned int | resolution = 512,
 |  | PixelFormat | format = PF_FLOAT16_RGBA,
 |  | int | numMips = 0,
 |  | ColourValue | clearColor = ColourValue::Black |
 | ) |  |  | [protected, inherited]

Creates a cubemap texture.

This is a helper function to easily create a cubemap texture and automaticly attach viewports to each face so it can be used as a rendertarget.

Parameters:
name | the name of the texture to be created
position | the initial position of the cubemap
resolution | the resolution of one cubemapface
format | the pixel format of the cubemap
numMips | the number of mipmap levels
clearColor | initial color

void OgreRenderingRun::setMaterialForRenderables | ( | String & | materialName,
 |  | RenderQueue * | rq |
 | ) |  |  | [protected, inherited]

Sets the given material for each Renderable in a RenderQueue.

This is a helper function to set a material to each element of a previously filled Renderque. The orginal material of the Renderables are stored so they can be restored later. The function also tells the current SceneManager not to search for visible objects, as we are going to use the given RenderQueue during the next rendering.

Parameters:
materialName | the name of the material to set for the Renderables
rq | pointer to the filled Renderqueue instance to set material for

void OgreRenderingRun::setMaterialForRenderables | ( | String & | materialName,
 |  | RenderQueue * | rq,
 |  | bool | solidsonly = false |
 | ) |  |  | [protected, inherited]

Sets the given material for each Renderable in a RenderQueue.

This is a helper function to set a material to each element of a previously filled Renderque. The orginal material of the Renderables are stored so they can be restored later. The function also tells the current SceneManager not to search for visible objects, as we are going to use the given RenderQueue during the next rendering.

Parameters:
materialName | the name of the material to set for the Renderables
rq | pointer to the filled Renderqueue instance to set material for

void OgreRenderingRun::setMaterialForVisibles | ( | String & | materialName,
 |  | Camera * | cam,
 |  | bool | shadowcastersonly = false |
 | ) |  |  | [protected, inherited]

Sets the given material for each Renderable visible from a given camera.

This helper function is similar to setMaterialForRenderables but it is also responsible for filling the RenderQueue. First the RenderQueue of the current SceneManager fill be filled with the visible objects seen from the given camera. Then the required material will be set for each element of the RenderQueue. The orginal material of the Renderables are stored so they can be restored later. The function also tells the current SceneManager not to search for visible objects, as we are going to use the filled RenderQueue during the next rendering.

Parameters:
materialName | the name of the material to set for the Renderables
cam | pointer to the camera from which visible objects should be searched
shadowcastersonly | flag to search for only shadow casters

void OgreRenderingRun::setMaterialForVisibles | ( | String & | materialName,
 |  | Camera * | cam,
 |  | bool | shadowcastersonly = false,
 |  | bool | solidsonly = false |
 | ) |  |  | [protected, inherited]

Sets the given material for each Renderable visible from a given camera.

This helper function is similar to setMaterialForRenderables but it is also responsible for filling the RenderQueue. First the RenderQueue of the current SceneManager fill be filled with the visible objects seen from the given camera. Then the required material will be set for each element of the RenderQueue. The orginal material of the Renderables are stored so they can be restored later. The function also tells the current SceneManager not to search for visible objects, as we are going to use the filled RenderQueue during the next rendering.

Parameters:
materialName | the name of the material to set for the Renderables
cam | pointer to the camera from which visible objects should be searched
shadowcastersonly | flag to search for only shadow casters

void OgreRenderingRun::restoreMaterials ( ) [protected, inherited]

Restores previously stored materials.

This helper function is typically used after a setMaterialForRenderables or setMaterialForVisibles call and a rendering process to restore the original material settings. The function also tells the current SceneManager to search for visible objects, as this is the default behaviour of SceneManager.

void OgreRenderingRun::restoreMaterials ( ) [protected, inherited]

Restores previously stored materials.

This helper function is typically used after a setMaterialForRenderables or setMaterialForVisibles call and a rendering process to restore the original material settings. The function also tells the current SceneManager to search for visible objects, as this is the default behaviour of SceneManager.

void OgreRenderingRun::renderFullscreenQuad | ( | String | materialName,
 |  | RenderTarget * | target |
 | ) |  |  | [protected, inherited]

Renderes a full screen quad on a given RendderTarget with a given material.

Parameters:
materialName | the name of the material bind to the quad
target | the RenderTarget the quad should be rendered on

void OgreRenderingRun::renderFullscreenQuad | ( | String | materialName,
 |  | RenderTarget * | target |
 | ) |  |  | [protected, inherited]

Renderes a full screen quad on a given RendderTarget with a given material.

Parameters:
materialName | the name of the material bind to the quad
target | the RenderTarget the quad should be rendered on

void OgreRenderingRun::renderPixelSprites | ( | String & | materialName,
 |  | RenderTarget * | rt,
 |  | int | width,
 |  | int | height |
 | ) |  |  | [protected, inherited]

Renderes sprites to pixels of the screen on a given RendderTarget with a given material.

Pixel sprites are pixel sized quads, placed on each pixel of the RenderTarget. The number of sprites not necessary corresponds to the resolution of the rendertarget. The pixel quads will evenly fill the rendertarget's area with sizes corresponding to the given resolution. We can render fewer or more pixel quads than the number of pixels the rendertarget has (eg.: in case of caustic cubemap generation).

Parameters:
materialName | the name of the material bind to the pixel sprites
rt | the RenderTarget the quads should be rendered on
width | the desired resolution width of the sprites
height | the desired resolution height of the sprites

void OgreRenderingRun::renderPixelSprites | ( | String & | materialName,
 |  | RenderTarget * | rt,
 |  | int | width,
 |  | int | height |
 | ) |  |  | [protected, inherited]

Renderes sprites to pixels of the screen on a given RendderTarget with a given material.

Pixel sprites are pixel sized quads, placed on each pixel of the RenderTarget. The number of sprites not necessary corresponds to the resolution of the rendertarget. The pixel quads will evenly fill the rendertarget's area with sizes corresponding to the given resolution. We can render fewer or more pixel quads than the number of pixels the rendertarget has (eg.: in case of caustic cubemap generation).

Parameters:
materialName | the name of the material bind to the pixel sprites
rt | the RenderTarget the quads should be rendered on
width | the desired resolution width of the sprites
height | the desired resolution height of the sprites

void OgreRenderingRun::renderFullscreenGrid | ( | String & | materialName,
 |  | RenderTarget * | rt,
 |  | int | width,
 |  | int | height |
 | ) |  |  | [protected, inherited]

Renders a grid onto the screen.

Parameters:
rt | the RenderTarget the grid should be rendered on
width | the desired horizontal resolution of the grid
height | the desired vertical resolution of the grid

virtual bool RenderingRun::canJoin ( RenderingRun * run ) [inline, virtual, inherited]

Returns true if two runs can be joined.

In some cases special requirements should stand to join two runs (even if they have the same type). Eg.: two caustic cube map generation technique should only be joined if they use the same material when rendering the caustic cubemap.

Reimplemented in OgreCausticCubeMapRenderingRun, OgreChildPSystemRenderingRun, and OgrePhotonMapRenderingRun.

virtual bool RenderingRun::needUpdate ( unsigned long frameNum ) [inline, protected, virtual, inherited]

Returns if this run needs update.

This tipically depends on the upate interval and the starting frame number.

Parameters:
frameNum current frame number

Reimplemented in OgreFocusingMapRenderingRun, and OgrePMEntryPointMapRenderingRun.

virtual void RenderingRun::updateFrame ( unsigned long frameNum ) [inline, protected, virtual, inherited]

This function does the actual update in a frame.

Parameters:
frameNum current frame number

Reimplemented in CausticCubeMapRenderingRun, ChildPsystemRenderingRun, CubeMapRenderingRun, DepthShadowMapRenderingRun, LightVolumeRenderingRun, PhaseTextureRenderingRun, PhotonMapRenderingRun, ReducedCubeMapRenderingRun, SceneCameraDepthRenderingRun, OgreChildPSystemRenderingRun, OgreDepthShadowMapRenderingRun, OgreFocusingMapRenderingRun, OgreLightVolumeRenderingRun, OgrePhaseTextureRenderingRun, OgrePhotonMapRenderingRun, OgrePMEntryPointMapRenderingRun, OgrePMWeightComputeRenderingRun, and OgreSceneCameraDepthRenderingRun.

void ReducedCubeMapRenderingRun::updateFrame ( unsigned long frameNum ) [protected, virtual, inherited]

This function does the actual update in a frame.

Parameters:
frameNum current frame number

Reimplemented from RenderingRun.

Member Data Documentation

std::map<Renderable*, String> OgreRenderingRun::visibleObjects [protected, inherited]

map of Renderables which will be rendered with a given material

The String stores the original material name that will be restored after rendering.

See also:
setMaterialForVisibles

setMaterialForRenderables

restoreMaterials

std::map<Renderable*, String> OgreRenderingRun::visibleObjects [protected, inherited]

map of Renderables which will be rendered with a given material

The String stores the original material name that will be restored after rendering.

See also:
setMaterialForVisibles

setMaterialForRenderables

restoreMaterials

MovablePlane * OgreRenderingRun::fullScreenQuad [static, protected, inherited]

fulls screen quad plane used in full screen quad rendering

See also:
renderFullscreenQuad

MovablePlane* OgreRenderingRun::fullScreenQuad [static, protected, inherited]

fulls screen quad plane used in full screen quad rendering

See also:
renderFullscreenQuad

Entity * OgreRenderingRun::fullScreenQuadEntity [static, protected, inherited]

fulls screen quad Entity used in full screen quad rendering

See also:
renderFullscreenQuad

Entity* OgreRenderingRun::fullScreenQuadEntity [static, protected, inherited]

fulls screen quad Entity used in full screen quad rendering

See also:
renderFullscreenQuad

SceneNode * OgreRenderingRun::fullScreenQuadNode [static, protected, inherited]

fulls screen quad SceneNode used in full screen quad rendering

See also:
renderFullscreenQuad

SceneNode* OgreRenderingRun::fullScreenQuadNode [static, protected, inherited]

fulls screen quad SceneNode used in full screen quad rendering

See also:
renderFullscreenQuad

SpriteSet* OgreRenderingRun::pixelSprites [protected, inherited]

SpriteSet used in pixel sprite rendering.

See also:
renderPixelSprites

BillboardSet* OgreRenderingRun::pixelSprites [protected, inherited]

SpriteSet used in pixel sprite rendering.

See also:
renderPixelSprites

String OgreRenderingRun::spriteSetName [protected, inherited]

unique name of the SpriteSet used in pixel sprite rendering

See also:
renderPixelSprites

Entity* OgreRenderingRun::fullscreenGrid [protected, inherited]

Entity used in fullscreen grid rendering.

See also:
renderPixelGrid

bool ReducedCubeMapRenderingRun::useDistCalc [protected, inherited]

a flag to skip cube face update if object is far away or too small.

See also:
distTolerance

bool ReducedCubeMapRenderingRun::useFaceAngleCalc [protected, inherited]

a flag to skip cube face update the face is neglible.

See also:
angleTolerance

float ReducedCubeMapRenderingRun::distTolerance [protected, inherited]

A value used in face skip test.

The higher this value gets the more precise, but slower the method will be.

float ReducedCubeMapRenderingRun::angleTolerance [protected, inherited]

A value used in face skip test.

The higher this value gets the more precise, but slower the method will be.

Generated on Wed Mar 28 11:48:59 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: OgreRenderable Class Reference

OgreRenderable Class Reference

Class to wrap different Ogre Renderable types. More...

Inheritance diagram for OgreRenderable:

ElementaryRenderable List of all members.

Public Member Functions

OgreRenderable (SubEntity *sube, Entity *parentEntity)
Constructor.
OgreRenderable (Entity *parentEntity, int subEntityNum)
Constructor.
OgreRenderable (BillboardSet *billboardset, ParticleSystem *sys=0)
Constructor.
~OgreRenderable (void)
Destructor.
void | setVisible (bool visible)
Sets the visibility of the wrapped renderable.
void | setRenderGroup (unsigned char groupID)
Sets the rendergroup of the wrapped renderable.
void | updateRenderQueue (RenderQueue *rq)
Updates the given renderqueue for the wrapped renderable.
bool | isVisible ()
Retrieves if the renderable is hided or shown.
void | setMaterialName (String &name)
Sets the material to be used by the renderable.
const MaterialPtr & | getMaterialPtr ()
Retrieves a resource pointer to the material used by the renderable.
const String & | getMaterialName ()
Retrieves the name of the material used by the renderable.
Material * | getMaterial ()
Retrieves a pointer to the material used by the renderable.
AxisAlignedBox & | getBoundingBox ()
Retrieves the axis-aligned bouding box of the renderable.
Sphere & | getBoundingSphere ()
Retrieves the bouding sphere of the renderable.
String & | getName ()
Retrieves the unique name assigned to the renderable.
void | updateBounds ()
Updates bounding volumes.
void | notifyCamera (Camera *cam)
Calls notifyCamera for the wrapped Renderable.
Renderable * | getRenderable ()
Returns the wrapped Renderable.

Protected Attributes

String | name
unique name assigned to the renderable
Entity * | parentEntity
pointer to the parent Entity if the renderable is a Subentity
SubEntity * | subEntityRenderable
pointer to the wrapped Subentity (if the renderable is a Subentity)
BillboardSet * | billboardSetRenderable
pointer to the wrapped BillboardSet (if the renderable is a BillboardSet)
ParticleSystem * | parentParticleSystem
pointer to the parent Particle System of the wrapped BillboardSet (if the renderable is a BillboardSet)
AxisAlignedBox | boundingBox
axis-aligned bounding box of the wrapped renderable in world space
Sphere | boundingSphere
bounding sphere of the wrapped renderable in world space
Ogre_RenderableType | renderableType
type of the renderable (see Ogre_RenderableType)

Detailed Description

Class to wrap different Ogre Renderable types.

Constructor & Destructor Documentation

OgreRenderable::OgreRenderable | ( | SubEntity * | sube,
 |  | Entity * | parentEntity
 | ) |  |

Constructor.

Creates an OgreRenderable from a SubEntity of an Entity.

Parameters:
sube | the subentity to wrap
parentEntity | the parent of the wrapped subentity

OgreRenderable::OgreRenderable | ( | Entity * | parentEntity,
 |  | int | subEntityNum
 | ) |  |

Constructor.

Creates an OgreRenderable from a SubEntity of an Entity.

Parameters:
parentEntity | the parent of the wrapped subentity
subEntityNum | the number of the subentity to wrap

OgreRenderable::OgreRenderable | ( | BillboardSet * | billboardset,
 |  | ParticleSystem * | sys = 0
 | ) |  |

Constructor.

Creates an OgreRenderable from a SubEntity of a BillboardSet.

Parameters:
billboardset the BillboardSet to wrap

Member Function Documentation

void OgreRenderable::setVisible ( bool visible ) [virtual]

Sets the visibility of the wrapped renderable.

Parameters:
visible visibility
See also:
ElementaryRenderable::setVisible()

Implements ElementaryRenderable.

void OgreRenderable::setRenderGroup ( unsigned char groupID ) [virtual]

Sets the rendergroup of the wrapped renderable.

Parameters:
groupID the ID of the group to use
See also:
ElementaryRenderable::setRenderGroup()

Implements ElementaryRenderable.

void OgreRenderable::updateRenderQueue ( RenderQueue * rq )

Updates the given renderqueue for the wrapped renderable.

Parameters:
rq pointer to the renderqueue to be updated

void OgreRenderable::setMaterialName ( String & name )

Sets the material to be used by the renderable.

Parameters:
name the name of the material to use

const MaterialPtr & OgreRenderable::getMaterialPtr ( )

Retrieves a resource pointer to the material used by the renderable.

Returns:
reference to the resource pointer

const String& OgreRenderable::getMaterialName ( ) [inline]

Retrieves the name of the material used by the renderable.

Returns:
reference to the name of the material

Material* OgreRenderable::getMaterial ( ) [inline]

Retrieves a pointer to the material used by the renderable.

Returns:
reference to the Material pointer

AxisAlignedBox& OgreRenderable::getBoundingBox ( ) [inline]

Retrieves the axis-aligned bouding box of the renderable.

Returns:
reference to the bouding box

Sphere& OgreRenderable::getBoundingSphere ( ) [inline]

Retrieves the bouding sphere of the renderable.

Returns:
reference to the bouding sphere

String& OgreRenderable::getName ( ) [inline]

Retrieves the unique name assigned to the renderable.

Returns:
reference to name of the renderable

void OgreRenderable::notifyCamera ( Camera * cam )

Calls notifyCamera for the wrapped Renderable.

Parameters:
pointer to the Camera to pass to notifyCamera()

Renderable * OgreRenderable::getRenderable ( )

Returns the wrapped Renderable.

Returns:
pointer to the wrapped Renderable

Generated on Wed Mar 28 11:48:59 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: OgreRenderingRun Class Reference

OgreRenderingRun Class Reference

Base class of a RenderingRun in an OGRE environment. More...

Inheritance diagram for OgreRenderingRun:

RenderingRun RenderingRun OgreCausticCubeMapRenderingRun OgreChildPSystemRenderingRun OgreCubeMapRenderingRun OgreDepthShadowMapRenderingRun OgreFocusingMapRenderingRun OgreLightVolumeRenderingRun OgrePhaseTextureRenderingRun OgrePhotonMapRenderingRun OgrePMEntryPointMapRenderingRun OgrePMWeightComputeRenderingRun OgreReducedCubeMapRenderingRun OgreSceneCameraDepthRenderingRun List of all members.

Public Member Functions

OgreRenderingRun (unsigned long startFrame, unsigned long updateInterval)
Constructor.
OgreRenderingRun * asOgreRenderingRun ()
Conversion to OgreRenderRun.
OgreRenderingRun (unsigned long startFrame, unsigned long updateInterval)
Constructor.
OgreRenderingRun * asOgreRenderingRun ()
Conversion to OgreRenderRun.
bool | update (unsigned long frameNum)
Calls updateFrame() if the run needs update according to its starting frame and update interval and has not been allready updated in this frame.
virtual bool | canJoin (RenderingRun *run)
Returns true if two runs can be joined.

Protected Member Functions

Vector3 | getCubeMapFaceDirection (unsigned char faceId)
Returns a direction for a cubemap face id.
Texture * | createCubeRenderTexture (String name, const Vector3 position, unsigned int resolution=512, PixelFormat format=PF_FLOAT16_RGBA, int numMips=0, ColourValue clearColor=ColourValue::Black)
Creates a cubemap texture.
void | setMaterialForRenderables (String &materialName, RenderQueue *rq)
Sets the given material for each Renderable in a RenderQueue.
void | setMaterialForVisibles (String &materialName, Camera *cam, bool shadowcastersonly=false)
Sets the given material for each Renderable visible from a given camera.
void | restoreMaterials ()
Restores previously stored materials.
void | renderFullscreenQuad (String materialName, RenderTarget *target)
Renderes a full screen quad on a given RendderTarget with a given material.
void | renderPixelSprites (String &materialName, RenderTarget *rt, int width, int height)
Renderes sprites to pixels of the screen on a given RendderTarget with a given material.
Vector3 | getCubeMapFaceDirection (unsigned char faceId)
Returns a direction for a cubemap face id.
Texture * | createCubeRenderTexture (String name, const Vector3 position, unsigned int resolution=512, PixelFormat format=PF_FLOAT16_RGBA, int numMips=0, ColourValue clearColor=ColourValue::Black)
Creates a cubemap texture.
void | setMaterialForRenderables (String &materialName, RenderQueue *rq, bool solidsonly=false)
Sets the given material for each Renderable in a RenderQueue.
void | setMaterialForVisibles (String &materialName, Camera *cam, bool shadowcastersonly=false, bool solidsonly=false)
Sets the given material for each Renderable visible from a given camera.
void | restoreMaterials ()
Restores previously stored materials.
void | renderFullscreenQuad (String materialName, RenderTarget *target)
Renderes a full screen quad on a given RendderTarget with a given material.
void | renderPixelSprites (String &materialName, RenderTarget *rt, int width, int height)
Renderes sprites to pixels of the screen on a given RendderTarget with a given material.
void | renderFullscreenGrid (String &materialName, RenderTarget *rt, int width, int height)
Renders a grid onto the screen.
virtual bool | needUpdate (unsigned long frameNum)
Returns if this run needs update.
virtual void | updateFrame (unsigned long frameNum)
This function does the actual update in a frame.

Protected Attributes

std::map< Renderable *, String > | visibleObjects
map of Renderables which will be rendered with a given material
SpriteSet * | pixelSprites
SpriteSet used in pixel sprite rendering.
String | spriteSetName
unique name of the SpriteSet used in pixel sprite rendering
std::map< Renderable *, String > | visibleObjects
map of Renderables which will be rendered with a given material
BillboardSet * | pixelSprites
SpriteSet used in pixel sprite rendering.
Entity * | fullscreenGrid
Entity used in fullscreen grid rendering.
unsigned long | lastupdated
The number of the last frame this run was updated.
unsigned long | startFrame
The number of the frame this run should be updated first.
unsigned long | updateInterval
Refresh frequency in frames.

Static Protected Attributes

static MovablePlane * | fullScreenQuad
fulls screen quad plane used in full screen quad rendering
static Entity * | fullScreenQuadEntity
fulls screen quad Entity used in full screen quad rendering
static SceneNode * | fullScreenQuadNode
fulls screen quad SceneNode used in full screen quad rendering
static MovablePlane * | fullScreenQuad
fulls screen quad plane used in full screen quad rendering
static Entity * | fullScreenQuadEntity
fulls screen quad Entity used in full screen quad rendering
static SceneNode * | fullScreenQuadNode
fulls screen quad SceneNode used in full screen quad rendering

Detailed Description

Base class of a RenderingRun in an OGRE environment.

Constructor & Destructor Documentation

OgreRenderingRun::OgreRenderingRun | ( | unsigned long | startFrame,
 |  | unsigned long | updateInterval |
 | ) |  |  | [inline]

Constructor.

Parameters:
startFrame | adds an offset to the current frame number to help evenly distribute updates between frames
updateInterval | photon map update frequency

OgreRenderingRun::OgreRenderingRun | ( | unsigned long | startFrame,
 |  | unsigned long | updateInterval |
 | ) |  |  | [inline]

Constructor.

Parameters:
startFrame | adds an offset to the current frame number to help evenly distribute updates between frames
updateInterval | photon map update frequency

Member Function Documentation

OgreRenderingRun* OgreRenderingRun::asOgreRenderingRun ( ) [inline, virtual]

Conversion to OgreRenderRun.

This function is needed because of virtual inheritance.

Reimplemented from RenderingRun.

Vector3 OgreRenderingRun::getCubeMapFaceDirection ( unsigned char faceId ) [protected]

Returns a direction for a cubemap face id.

This is a helper function to retrieve the normal direction of a given cubemap face.

Parameters:
faceId the number of the face

Texture * OgreRenderingRun::createCubeRenderTexture | ( | String | name,
 |  | const Vector3 | position,
 |  | unsigned int | resolution = 512,
 |  | PixelFormat | format = PF_FLOAT16_RGBA,
 |  | int | numMips = 0,
 |  | ColourValue | clearColor = ColourValue::Black |
 | ) |  |  | [protected]

Creates a cubemap texture.

This is a helper function to easily create a cubemap texture and automaticly attach viewports to each face so it can be used as a rendertarget.

Parameters:
name | the name of the texture to be created
position | the initial position of the cubemap
resolution | the resolution of one cubemapface
format | the pixel format of the cubemap
numMips | the number of mipmap levels
clearColor | initial color

void OgreRenderingRun::setMaterialForRenderables | ( | String & | materialName,
 |  | RenderQueue * | rq |
 | ) |  |  | [protected]

Sets the given material for each Renderable in a RenderQueue.

This is a helper function to set a material to each element of a previously filled Renderque. The orginal material of the Renderables are stored so they can be restored later. The function also tells the current SceneManager not to search for visible objects, as we are going to use the given RenderQueue during the next rendering.

Parameters:
materialName | the name of the material to set for the Renderables
rq | pointer to the filled Renderqueue instance to set material for

void OgreRenderingRun::setMaterialForVisibles | ( | String & | materialName,
 |  | Camera * | cam,
 |  | bool | shadowcastersonly = false |
 | ) |  |  | [protected]

Sets the given material for each Renderable visible from a given camera.

This helper function is similar to setMaterialForRenderables but it is also responsible for filling the RenderQueue. First the RenderQueue of the current SceneManager fill be filled with the visible objects seen from the given camera. Then the required material will be set for each element of the RenderQueue. The orginal material of the Renderables are stored so they can be restored later. The function also tells the current SceneManager not to search for visible objects, as we are going to use the filled RenderQueue during the next rendering.

Parameters:
materialName | the name of the material to set for the Renderables
cam | pointer to the camera from which visible objects should be searched
shadowcastersonly | flag to search for only shadow casters

void OgreRenderingRun::restoreMaterials ( ) [protected]

Restores previously stored materials.

This helper function is typically used after a setMaterialForRenderables or setMaterialForVisibles call and a rendering process to restore the original material settings. The function also tells the current SceneManager to search for visible objects, as this is the default behaviour of SceneManager.

void OgreRenderingRun::renderFullscreenQuad | ( | String | materialName,
 |  | RenderTarget * | target |
 | ) |  |  | [protected]

Renderes a full screen quad on a given RendderTarget with a given material.

Parameters:
materialName | the name of the material bind to the quad
target | the RenderTarget the quad should be rendered on

void OgreRenderingRun::renderPixelSprites | ( | String & | materialName,
 |  | RenderTarget * | rt,
 |  | int | width,
 |  | int | height |
 | ) |  |  | [protected]

Renderes sprites to pixels of the screen on a given RendderTarget with a given material.

Pixel sprites are pixel sized quads, placed on each pixel of the RenderTarget. The number of sprites not necessary corresponds to the resolution of the rendertarget. The pixel quads will evenly fill the rendertarget's area with sizes corresponding to the given resolution. We can render fewer or more pixel quads than the number of pixels the rendertarget has (eg.: in case of caustic cubemap generation).

Parameters:
materialName | the name of the material bind to the pixel sprites
rt | the RenderTarget the quads should be rendered on
width | the desired resolution width of the sprites
height | the desired resolution height of the sprites

OgreRenderingRun* OgreRenderingRun::asOgreRenderingRun ( ) [inline, virtual]

Conversion to OgreRenderRun.

This function is needed because of virtual inheritance.

Reimplemented from RenderingRun.

Vector3 OgreRenderingRun::getCubeMapFaceDirection ( unsigned char faceId ) [protected]

Returns a direction for a cubemap face id.

This is a helper function to retrieve the normal direction of a given cubemap face.

Parameters:
faceId the number of the face

Texture* OgreRenderingRun::createCubeRenderTexture | ( | String | name,
 |  | const Vector3 | position,
 |  | unsigned int | resolution = 512,
 |  | PixelFormat | format = PF_FLOAT16_RGBA,
 |  | int | numMips = 0,
 |  | ColourValue | clearColor = ColourValue::Black |
 | ) |  |  | [protected]

Creates a cubemap texture.

This is a helper function to easily create a cubemap texture and automaticly attach viewports to each face so it can be used as a rendertarget.

Parameters:
name | the name of the texture to be created
position | the initial position of the cubemap
resolution | the resolution of one cubemapface
format | the pixel format of the cubemap
numMips | the number of mipmap levels
clearColor | initial color

void OgreRenderingRun::setMaterialForRenderables | ( | String & | materialName,
 |  | RenderQueue * | rq,
 |  | bool | solidsonly = false |
 | ) |  |  | [protected]

Sets the given material for each Renderable in a RenderQueue.

This is a helper function to set a material to each element of a previously filled Renderque. The orginal material of the Renderables are stored so they can be restored later. The function also tells the current SceneManager not to search for visible objects, as we are going to use the given RenderQueue during the next rendering.

Parameters:
materialName | the name of the material to set for the Renderables
rq | pointer to the filled Renderqueue instance to set material for

void OgreRenderingRun::setMaterialForVisibles | ( | String & | materialName,
 |  | Camera * | cam,
 |  | bool | shadowcastersonly = false,
 |  | bool | solidsonly = false |
 | ) |  |  | [protected]

Sets the given material for each Renderable visible from a given camera.

This helper function is similar to setMaterialForRenderables but it is also responsible for filling the RenderQueue. First the RenderQueue of the current SceneManager fill be filled with the visible objects seen from the given camera. Then the required material will be set for each element of the RenderQueue. The orginal material of the Renderables are stored so they can be restored later. The function also tells the current SceneManager not to search for visible objects, as we are going to use the filled RenderQueue during the next rendering.

Parameters:
materialName | the name of the material to set for the Renderables
cam | pointer to the camera from which visible objects should be searched
shadowcastersonly | flag to search for only shadow casters

void OgreRenderingRun::restoreMaterials ( ) [protected]

Restores previously stored materials.

This helper function is typically used after a setMaterialForRenderables or setMaterialForVisibles call and a rendering process to restore the original material settings. The function also tells the current SceneManager to search for visible objects, as this is the default behaviour of SceneManager.

void OgreRenderingRun::renderFullscreenQuad | ( | String | materialName,
 |  | RenderTarget * | target |
 | ) |  |  | [protected]

Renderes a full screen quad on a given RendderTarget with a given material.

Parameters:
materialName | the name of the material bind to the quad
target | the RenderTarget the quad should be rendered on

void OgreRenderingRun::renderPixelSprites | ( | String & | materialName,
 |  | RenderTarget * | rt,
 |  | int | width,
 |  | int | height |
 | ) |  |  | [protected]

Renderes sprites to pixels of the screen on a given RendderTarget with a given material.

Pixel sprites are pixel sized quads, placed on each pixel of the RenderTarget. The number of sprites not necessary corresponds to the resolution of the rendertarget. The pixel quads will evenly fill the rendertarget's area with sizes corresponding to the given resolution. We can render fewer or more pixel quads than the number of pixels the rendertarget has (eg.: in case of caustic cubemap generation).

Parameters:
materialName | the name of the material bind to the pixel sprites
rt | the RenderTarget the quads should be rendered on
width | the desired resolution width of the sprites
height | the desired resolution height of the sprites

void OgreRenderingRun::renderFullscreenGrid | ( | String & | materialName,
 |  | RenderTarget * | rt,
 |  | int | width,
 |  | int | height |
 | ) |  |  | [protected]

Renders a grid onto the screen.

Parameters:
rt | the RenderTarget the grid should be rendered on
width | the desired horizontal resolution of the grid
height | the desired vertical resolution of the grid

virtual bool RenderingRun::canJoin ( RenderingRun * run ) [inline, virtual, inherited]

Returns true if two runs can be joined.

In some cases special requirements should stand to join two runs (even if they have the same type). Eg.: two caustic cube map generation technique should only be joined if they use the same material when rendering the caustic cubemap.

Reimplemented in OgreCausticCubeMapRenderingRun, OgreChildPSystemRenderingRun, and OgrePhotonMapRenderingRun.

virtual bool RenderingRun::needUpdate ( unsigned long frameNum ) [inline, protected, virtual, inherited]

Returns if this run needs update.

This tipically depends on the upate interval and the starting frame number.

Parameters:
frameNum current frame number

Reimplemented in OgreFocusingMapRenderingRun, and OgrePMEntryPointMapRenderingRun.

virtual void RenderingRun::updateFrame ( unsigned long frameNum ) [inline, protected, virtual, inherited]

This function does the actual update in a frame.

Parameters:
frameNum current frame number

Reimplemented in CausticCubeMapRenderingRun, ChildPsystemRenderingRun, CubeMapRenderingRun, DepthShadowMapRenderingRun, LightVolumeRenderingRun, PhaseTextureRenderingRun, PhotonMapRenderingRun, ReducedCubeMapRenderingRun, SceneCameraDepthRenderingRun, OgreChildPSystemRenderingRun, OgreDepthShadowMapRenderingRun, OgreFocusingMapRenderingRun, OgreLightVolumeRenderingRun, OgrePhaseTextureRenderingRun, OgrePhotonMapRenderingRun, OgrePMEntryPointMapRenderingRun, OgrePMWeightComputeRenderingRun, and OgreSceneCameraDepthRenderingRun.

Member Data Documentation

std::map<Renderable*, String> OgreRenderingRun::visibleObjects [protected]

map of Renderables which will be rendered with a given material

The String stores the original material name that will be restored after rendering.

See also:
setMaterialForVisibles

setMaterialForRenderables

restoreMaterials

MovablePlane * OgreRenderingRun::fullScreenQuad [static, protected]

fulls screen quad plane used in full screen quad rendering

See also:
renderFullscreenQuad

Entity * OgreRenderingRun::fullScreenQuadEntity [static, protected]

fulls screen quad Entity used in full screen quad rendering

See also:
renderFullscreenQuad

SceneNode * OgreRenderingRun::fullScreenQuadNode [static, protected]

fulls screen quad SceneNode used in full screen quad rendering

See also:
renderFullscreenQuad

SpriteSet* OgreRenderingRun::pixelSprites [protected]

SpriteSet used in pixel sprite rendering.

See also:
renderPixelSprites

String OgreRenderingRun::spriteSetName [protected]

unique name of the SpriteSet used in pixel sprite rendering

See also:
renderPixelSprites

std::map<Renderable*, String> OgreRenderingRun::visibleObjects [protected]

map of Renderables which will be rendered with a given material

The String stores the original material name that will be restored after rendering.

See also:
setMaterialForVisibles

setMaterialForRenderables

restoreMaterials

MovablePlane* OgreRenderingRun::fullScreenQuad [static, protected]

fulls screen quad plane used in full screen quad rendering

See also:
renderFullscreenQuad

Entity* OgreRenderingRun::fullScreenQuadEntity [static, protected]

fulls screen quad Entity used in full screen quad rendering

See also:
renderFullscreenQuad

SceneNode* OgreRenderingRun::fullScreenQuadNode [static, protected]

fulls screen quad SceneNode used in full screen quad rendering

See also:
renderFullscreenQuad

BillboardSet* OgreRenderingRun::pixelSprites [protected]

SpriteSet used in pixel sprite rendering.

See also:
renderPixelSprites

Entity* OgreRenderingRun::fullscreenGrid [protected]

Entity used in fullscreen grid rendering.

See also:
renderPixelGrid

Generated on Wed Mar 28 11:48:59 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: OgreRenderTechnique Class Reference

OgreRenderTechnique Class Reference

Class of RenderTechniques used in an OGRE environment. More...

Inheritance diagram for OgreRenderTechnique:

RenderTechnique OgreCausticCasterRenderTechnique OgreCausticReceiverRenderTechnique OgreCubeMapRenderTechnique OgreDepthShadowReceiverRenderTechnique OgreFireRenderTechnique OgreHierarchicalParticleSystemTechnique OgreIllumVolumeRenderTechnique OgrePathMapRenderTechnique OgreSBBRenderTechnique List of all members.

Public Member Functions

OgreRenderTechnique (Pass *pass, OgreRenderable *parentRenderable, OgreTechniqueGroup *parentTechniqueGroup)
Constructor.
virtual OgreRenderTechnique * | asOgreRenderTechnique ()
Conversion to OgreRenderTechnique.
virtual void | update (unsigned long frameNum)
Updates the resources in the given frame.
virtual void | runChanged (RenderingRunType runType, RenderingRun *run)
Called after one of he shared runs changes.
virtual void | runUpdated (RenderingRunType runType, RenderingRun *run)
Called after one of he shared runs updates.
ElementaryRenderable * getParentRenderable ()
Retrieves the renderable this technique operates on.

Protected Attributes

OgreRenderable * parentOgreRenderable
a OgreRenderable pointer to the renderable this technique operates on.
OgreTechniqueGroup * parentOgreTechniqueGroup
a OgreTechniqueGroup pointer to the TechniqueGroup this technique is attached to.
Pass * | pass
a pointer to the pass this technique operates on.
ElementaryRenderable * parentRenderable
The renderable this technique operates on.
TechniqueGroup * parentTechniqueGroup
The TechniqueGroup this RenderedTechnique is attached to.
SharedRuns * sharedRuns
The SharedRuns this RenderedTechnique is attached to.

Detailed Description

Class of RenderTechniques used in an OGRE environment.

Constructor & Destructor Documentation

OgreRenderTechnique::OgreRenderTechnique | ( | Pass * | pass,
 |  | OgreRenderable * | parentRenderable,
 |  | OgreTechniqueGroup * | parentTechniqueGroup
 | ) |  |

Constructor.

Parameters:
the | pass to operate on
parentRenderable | the object to operate on
parentTechniqueGroup | the TechniqueGroup this RenderedTechnique is attached to

Member Function Documentation

virtual OgreRenderTechnique* OgreRenderTechnique::asOgreRenderTechnique ( ) [inline, virtual]

Conversion to OgreRenderTechnique.

This function is needed because of virtual inheritance.

Reimplemented from RenderTechnique.

virtual void RenderTechnique::update ( unsigned long frameNum ) [inline, virtual, inherited]

Updates the resources in the given frame.

A RenderTechnique is usually need some resources from several runs, so these runs will be updated.

Parameters:
frameNum the actual framenumber

Reimplemented in ColorCubeMapRenderTechnique, ConvolvedCubeMapRenderTechnique, DistanceCubeMapRenderTechnique, HierarchicalParticleSystemTechnique, IllumVolumeRenderTechnique, OgreCausticReceiverRenderTechnique, OgreColorCubeMapRenderTechnique, OgreConvolvedCubeMapRenderTechnique, OgreDepthShadowReceiverRenderTechnique, OgreDistanceCubeMapRenderTechnique, OgreFireRenderTechnique, OgrePathMapRenderTechnique, and OgreSBBRenderTechnique.

virtual void RenderTechnique::runChanged | ( | RenderingRunType | runType,
 |  | RenderingRun * | run |
 | ) |  |  | [inline, virtual, inherited]

Called after one of he shared runs changes.

Parameters:
runType | enum describing the type of the changed run
run | pointer to the changed RenderingRun

Reimplemented in CausticCasterRenderTechnique, ColorCubeMapRenderTechnique, ConvolvedCubeMapRenderTechnique, CubeMapRenderTechnique, DistanceCubeMapRenderTechnique, HierarchicalParticleSystemTechnique, and IllumVolumeRenderTechnique.

virtual void RenderTechnique::runUpdated | ( | RenderingRunType | runType,
 |  | RenderingRun * | run |
 | ) |  |  | [inline, virtual, inherited]

Called after one of he shared runs updates.

Parameters:
runType | enum describing the type of the updated run
run | pointer to the updated RenderingRun

Reimplemented in CausticCasterRenderTechnique, ColorCubeMapRenderTechnique, CubeMapRenderTechnique, DistanceCubeMapRenderTechnique, HierarchicalParticleSystemTechnique, and IllumVolumeRenderTechnique.

Generated on Wed Mar 28 11:49:00 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: OgreSBBRenderTechnique Class Reference

OgreSBBRenderTechnique Class Reference

SBBRenderTechnique used in an OGRE environment. More...

Inheritance diagram for OgreSBBRenderTechnique:

OgreRenderTechnique SBBRenderTechnique UpdateListener RenderTechnique RenderTechnique List of all members.

Public Member Functions

OgreSBBRenderTechnique (unsigned char depthTexID, Pass *pass, OgreRenderable *parentRenderable, OgreTechniqueGroup *parentTechniqueGroup)
Constructor.
virtual void | update (unsigned long frameNum)
Updates the resources in the given frame.
void | preAllUpdates ()
Called before RenderTechnique updates.
void | postAllUpdates ()
Called after RenderTechnique updates.
virtual OgreRenderTechnique * | asOgreRenderTechnique ()
Conversion to OgreRenderTechnique.
virtual void | runChanged (RenderingRunType runType, RenderingRun *run)
Called after one of he shared runs changes.
virtual void | runUpdated (RenderingRunType runType, RenderingRun *run)
Called after one of he shared runs updates.
ElementaryRenderable * getParentRenderable ()
Retrieves the renderable this technique operates on.

Protected Attributes

unsigned char | depthTexID
OgreRenderable * parentOgreRenderable
a OgreRenderable pointer to the renderable this technique operates on.
OgreTechniqueGroup * parentOgreTechniqueGroup
a OgreTechniqueGroup pointer to the TechniqueGroup this technique is attached to.
Pass * | pass
a pointer to the pass this technique operates on.
ElementaryRenderable * parentRenderable
The renderable this technique operates on.
TechniqueGroup * parentTechniqueGroup
The TechniqueGroup this RenderedTechnique is attached to.
SharedRuns * sharedRuns
The SharedRuns this RenderedTechnique is attached to.

Detailed Description

SBBRenderTechnique used in an OGRE environment.

Constructor & Destructor Documentation

OgreSBBRenderTechnique::OgreSBBRenderTechnique | ( | unsigned char | depthTexID,
 |  | Pass * | pass,
 |  | OgreRenderable * | parentRenderable,
 |  | OgreTechniqueGroup * | parentTechniqueGroup
 | ) |  |

Constructor.

Parameters:
depthTexID | the id of the texture unit state the resulting scene depth map should be bound to
pass | the pass to operate on
parentRenderable | the object to operate on
parentTechniqueGroup | the TechniqueGroup this RenderedTechnique is attached to

Member Function Documentation

void OgreSBBRenderTechnique::update ( unsigned long frameNum ) [virtual]

Updates the resources in the given frame.

A RenderTechnique is usually need some resources from several runs, so these runs will be updated.

Parameters:
frameNum the actual framenumber

Reimplemented from RenderTechnique.

virtual OgreRenderTechnique* OgreRenderTechnique::asOgreRenderTechnique ( ) [inline, virtual, inherited]

Conversion to OgreRenderTechnique.

This function is needed because of virtual inheritance.

Reimplemented from RenderTechnique.

virtual void RenderTechnique::runChanged | ( | RenderingRunType | runType,
 |  | RenderingRun * | run |
 | ) |  |  | [inline, virtual, inherited]

Called after one of he shared runs changes.

Parameters:
runType | enum describing the type of the changed run
run | pointer to the changed RenderingRun

Reimplemented in CausticCasterRenderTechnique, ColorCubeMapRenderTechnique, ConvolvedCubeMapRenderTechnique, CubeMapRenderTechnique, DistanceCubeMapRenderTechnique, HierarchicalParticleSystemTechnique, and IllumVolumeRenderTechnique.

virtual void RenderTechnique::runUpdated | ( | RenderingRunType | runType,
 |  | RenderingRun * | run |
 | ) |  |  | [inline, virtual, inherited]

Called after one of he shared runs updates.

Parameters:
runType | enum describing the type of the updated run
run | pointer to the updated RenderingRun

Reimplemented in CausticCasterRenderTechnique, ColorCubeMapRenderTechnique, CubeMapRenderTechnique, DistanceCubeMapRenderTechnique, HierarchicalParticleSystemTechnique, and IllumVolumeRenderTechnique.

Member Data Documentation

unsigned char OgreSBBRenderTechnique::depthTexID [protected]

&brief the id of the texture unit state the resulting scene depth map should be bound to

Generated on Wed Mar 28 11:49:00 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: OgreSBBRenderTechniqueFactory Class Reference

OgreSBBRenderTechniqueFactory Class Reference

RenderTechniqueFactory to create OgreSBBRenderTechnique instances. More...

Inheritance diagram for OgreSBBRenderTechniqueFactory:

RenderTechniqueFactory List of all members.

Public Member Functions

OgreRenderTechnique * | createInstance (IllumTechniqueParams *params, Pass *pass, OgreRenderable *parentRenderable, OgreTechniqueGroup *parentTechniqueGroup)
Creates a RenderTechnique of the factory type.
bool | isType (String type)
Returns if this factory can create a RenderTechnique of the given type.
virtual void | parseParams (IllumTechniqueParams *params)
parses parameters from the material file.

Protected Types

typedef void(*) | ILLUM_ATTRIBUTE_PARSER (String &params, RenderTechniqueFactory *factory)
function for parsing RenderTechnique attributes
typedef std::map< String,
ILLUM_ATTRIBUTE_PARSER > 		AttribParserList
Keyword-mapped attribute parsers.

Protected Attributes

AttribParserList attributeParsers
map of parser functions
String | typeName
factoryname

Detailed Description

RenderTechniqueFactory to create OgreSBBRenderTechnique instances.

Member Typedef Documentation

typedef void(*) RenderTechniqueFactory::ILLUM_ATTRIBUTE_PARSER(String &params, RenderTechniqueFactory *factory) [protected, inherited]

function for parsing RenderTechnique attributes

Parameters:
params attribute value stored in a String

Member Function Documentation

OgreRenderTechnique * OgreSBBRenderTechniqueFactory::createInstance | ( | IllumTechniqueParams * | params,
 |  | Pass * | pass,
 |  | OgreRenderable * | parentRenderable,
 |  | OgreTechniqueGroup * | parentTechniqueGroup |
 | ) |  |  | [virtual]

Creates a RenderTechnique of the factory type.

Parameters:
params | containes constructor parameters as NameValuePairList
pass | the Pass to use in RenderTechnique constructor
pass | the parentRenderable to pass to RenderTechnique constructor
pass | the parentTechniqueGroup to pass to RenderTechnique constructor

Implements RenderTechniqueFactory.

bool RenderTechniqueFactory::isType ( String type ) [inline, inherited]

Returns if this factory can create a RenderTechnique of the given type.

Parameters:
type RenderTechnique type

void RenderTechniqueFactory::parseParams ( IllumTechniqueParams * params ) [virtual, inherited]

parses parameters from the material file.

The parsed parameters will be passed to the new RenderTechnique's constructor.

Parameters:
params pointer to the IllumTechniqueParams structure that was read from the material script and containes the parameters to be parsed.

Generated on Wed Mar 28 11:49:00 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: OgreSceneCameraDepthRenderingRun Class Reference

OgreSceneCameraDepthRenderingRun Class Reference

SceneCameraDepthRenderingRun used in an OGRE environment. More...

Inheritance diagram for OgreSceneCameraDepthRenderingRun:

OgreRenderingRun SceneCameraDepthRenderingRun RenderingRun RenderingRun RenderingRun List of all members.

Public Member Functions

OgreSceneCameraDepthRenderingRun (OgreSharedRuns *sharedRuns, String name, Viewport *playerView)
Constructor.
String | getDepthTextureName ()
returns the name of the camera depth texture
OgreRenderingRun * asOgreRenderingRun ()
Conversion to OgreRenderRun.
OgreRenderingRun * asOgreRenderingRun ()
Conversion to OgreRenderRun.
bool | update (unsigned long frameNum)
Calls updateFrame() if the run needs update according to its starting frame and update interval and has not been allready updated in this frame.
virtual bool | canJoin (RenderingRun *run)
Returns true if two runs can be joined.

Protected Member Functions

void | updateFrame (unsigned long frameNum)
This function does the actual update in a frame.
void | createDepthMap ()
Creates the depth map texture.
Vector3 | getCubeMapFaceDirection (unsigned char faceId)
Returns a direction for a cubemap face id.
Vector3 | getCubeMapFaceDirection (unsigned char faceId)
Returns a direction for a cubemap face id.
Texture * | createCubeRenderTexture (String name, const Vector3 position, unsigned int resolution=512, PixelFormat format=PF_FLOAT16_RGBA, int numMips=0, ColourValue clearColor=ColourValue::Black)
Creates a cubemap texture.
Texture * | createCubeRenderTexture (String name, const Vector3 position, unsigned int resolution=512, PixelFormat format=PF_FLOAT16_RGBA, int numMips=0, ColourValue clearColor=ColourValue::Black)
Creates a cubemap texture.
void | setMaterialForRenderables (String &materialName, RenderQueue *rq)
Sets the given material for each Renderable in a RenderQueue.
void | setMaterialForRenderables (String &materialName, RenderQueue *rq, bool solidsonly=false)
Sets the given material for each Renderable in a RenderQueue.
void | setMaterialForVisibles (String &materialName, Camera *cam, bool shadowcastersonly=false)
Sets the given material for each Renderable visible from a given camera.
void | setMaterialForVisibles (String &materialName, Camera *cam, bool shadowcastersonly=false, bool solidsonly=false)
Sets the given material for each Renderable visible from a given camera.
void | restoreMaterials ()
Restores previously stored materials.
void | restoreMaterials ()
Restores previously stored materials.
void | renderFullscreenQuad (String materialName, RenderTarget *target)
Renderes a full screen quad on a given RendderTarget with a given material.
void | renderFullscreenQuad (String materialName, RenderTarget *target)
Renderes a full screen quad on a given RendderTarget with a given material.
void | renderPixelSprites (String &materialName, RenderTarget *rt, int width, int height)
Renderes sprites to pixels of the screen on a given RendderTarget with a given material.
void | renderPixelSprites (String &materialName, RenderTarget *rt, int width, int height)
Renderes sprites to pixels of the screen on a given RendderTarget with a given material.
void | renderFullscreenGrid (String &materialName, RenderTarget *rt, int width, int height)
Renders a grid onto the screen.
virtual bool | needUpdate (unsigned long frameNum)
Returns if this run needs update.

Protected Attributes

Viewport * | playerView
pointer to the player's viewport
Camera * | playerCamera
pointer to the player's camera
OgreSharedRuns * sharedRuns
a pointer to the OgreSharedRuns this run belongs to
String | name
the name of the depth texture that was created by this run
Texture * | depthTexture
a pointer to the scene depth texture that was created by this run
std::map< Renderable *, String > | visibleObjects
map of Renderables which will be rendered with a given material
std::map< Renderable *, String > | visibleObjects
map of Renderables which will be rendered with a given material
SpriteSet * | pixelSprites
SpriteSet used in pixel sprite rendering.
BillboardSet * | pixelSprites
SpriteSet used in pixel sprite rendering.
String | spriteSetName
unique name of the SpriteSet used in pixel sprite rendering
Entity * | fullscreenGrid
Entity used in fullscreen grid rendering.
unsigned long | lastupdated
The number of the last frame this run was updated.
unsigned long | startFrame
The number of the frame this run should be updated first.
unsigned long | updateInterval
Refresh frequency in frames.

Static Protected Attributes

static MovablePlane * | fullScreenQuad
fulls screen quad plane used in full screen quad rendering
static MovablePlane * | fullScreenQuad
fulls screen quad plane used in full screen quad rendering
static Entity * | fullScreenQuadEntity
fulls screen quad Entity used in full screen quad rendering
static Entity * | fullScreenQuadEntity
fulls screen quad Entity used in full screen quad rendering
static SceneNode * | fullScreenQuadNode
fulls screen quad SceneNode used in full screen quad rendering
static SceneNode * | fullScreenQuadNode
fulls screen quad SceneNode used in full screen quad rendering

Detailed Description

SceneCameraDepthRenderingRun used in an OGRE environment.

Constructor & Destructor Documentation

OgreSceneCameraDepthRenderingRun::OgreSceneCameraDepthRenderingRun | ( | OgreSharedRuns * | sharedRuns,
 |  | String | name,
 |  | Viewport * | playerView
 | ) |  |

Constructor.

Parameters:
sharedRuns | a pointer to the OgreSharedRuns this run belongs to
name | the name of the depth texture to be created
playerView | pointer to the player's viewport

Member Function Documentation

void OgreSceneCameraDepthRenderingRun::updateFrame ( unsigned long frameNum ) [protected, virtual]

This function does the actual update in a frame.

Parameters:
frameNum current frame number

Implements SceneCameraDepthRenderingRun.

OgreRenderingRun* OgreRenderingRun::asOgreRenderingRun ( ) [inline, virtual, inherited]

Conversion to OgreRenderRun.

This function is needed because of virtual inheritance.

Reimplemented from RenderingRun.

OgreRenderingRun* OgreRenderingRun::asOgreRenderingRun ( ) [inline, virtual, inherited]

Conversion to OgreRenderRun.

This function is needed because of virtual inheritance.

Reimplemented from RenderingRun.

Vector3 OgreRenderingRun::getCubeMapFaceDirection ( unsigned char faceId ) [protected, inherited]

Returns a direction for a cubemap face id.

This is a helper function to retrieve the normal direction of a given cubemap face.

Parameters:
faceId the number of the face

Vector3 OgreRenderingRun::getCubeMapFaceDirection ( unsigned char faceId ) [protected, inherited]

Returns a direction for a cubemap face id.

This is a helper function to retrieve the normal direction of a given cubemap face.

Parameters:
faceId the number of the face

Texture * OgreRenderingRun::createCubeRenderTexture | ( | String | name,
 |  | const Vector3 | position,
 |  | unsigned int | resolution = 512,
 |  | PixelFormat | format = PF_FLOAT16_RGBA,
 |  | int | numMips = 0,
 |  | ColourValue | clearColor = ColourValue::Black |
 | ) |  |  | [protected, inherited]

Creates a cubemap texture.

This is a helper function to easily create a cubemap texture and automaticly attach viewports to each face so it can be used as a rendertarget.

Parameters:
name | the name of the texture to be created
position | the initial position of the cubemap
resolution | the resolution of one cubemapface
format | the pixel format of the cubemap
numMips | the number of mipmap levels
clearColor | initial color

Texture* OgreRenderingRun::createCubeRenderTexture | ( | String | name,
 |  | const Vector3 | position,
 |  | unsigned int | resolution = 512,
 |  | PixelFormat | format = PF_FLOAT16_RGBA,
 |  | int | numMips = 0,
 |  | ColourValue | clearColor = ColourValue::Black |
 | ) |  |  | [protected, inherited]

Creates a cubemap texture.

This is a helper function to easily create a cubemap texture and automaticly attach viewports to each face so it can be used as a rendertarget.

Parameters:
name | the name of the texture to be created
position | the initial position of the cubemap
resolution | the resolution of one cubemapface
format | the pixel format of the cubemap
numMips | the number of mipmap levels
clearColor | initial color

void OgreRenderingRun::setMaterialForRenderables | ( | String & | materialName,
 |  | RenderQueue * | rq |
 | ) |  |  | [protected, inherited]

Sets the given material for each Renderable in a RenderQueue.

This is a helper function to set a material to each element of a previously filled Renderque. The orginal material of the Renderables are stored so they can be restored later. The function also tells the current SceneManager not to search for visible objects, as we are going to use the given RenderQueue during the next rendering.

Parameters:
materialName | the name of the material to set for the Renderables
rq | pointer to the filled Renderqueue instance to set material for

void OgreRenderingRun::setMaterialForRenderables | ( | String & | materialName,
 |  | RenderQueue * | rq,
 |  | bool | solidsonly = false |
 | ) |  |  | [protected, inherited]

Sets the given material for each Renderable in a RenderQueue.

This is a helper function to set a material to each element of a previously filled Renderque. The orginal material of the Renderables are stored so they can be restored later. The function also tells the current SceneManager not to search for visible objects, as we are going to use the given RenderQueue during the next rendering.

Parameters:
materialName | the name of the material to set for the Renderables
rq | pointer to the filled Renderqueue instance to set material for

void OgreRenderingRun::setMaterialForVisibles | ( | String & | materialName,
 |  | Camera * | cam,
 |  | bool | shadowcastersonly = false |
 | ) |  |  | [protected, inherited]

Sets the given material for each Renderable visible from a given camera.

This helper function is similar to setMaterialForRenderables but it is also responsible for filling the RenderQueue. First the RenderQueue of the current SceneManager fill be filled with the visible objects seen from the given camera. Then the required material will be set for each element of the RenderQueue. The orginal material of the Renderables are stored so they can be restored later. The function also tells the current SceneManager not to search for visible objects, as we are going to use the filled RenderQueue during the next rendering.

Parameters:
materialName | the name of the material to set for the Renderables
cam | pointer to the camera from which visible objects should be searched
shadowcastersonly | flag to search for only shadow casters

void OgreRenderingRun::setMaterialForVisibles | ( | String & | materialName,
 |  | Camera * | cam,
 |  | bool | shadowcastersonly = false,
 |  | bool | solidsonly = false |
 | ) |  |  | [protected, inherited]

Sets the given material for each Renderable visible from a given camera.

This helper function is similar to setMaterialForRenderables but it is also responsible for filling the RenderQueue. First the RenderQueue of the current SceneManager fill be filled with the visible objects seen from the given camera. Then the required material will be set for each element of the RenderQueue. The orginal material of the Renderables are stored so they can be restored later. The function also tells the current SceneManager not to search for visible objects, as we are going to use the filled RenderQueue during the next rendering.

Parameters:
materialName | the name of the material to set for the Renderables
cam | pointer to the camera from which visible objects should be searched
shadowcastersonly | flag to search for only shadow casters

void OgreRenderingRun::restoreMaterials ( ) [protected, inherited]

Restores previously stored materials.

This helper function is typically used after a setMaterialForRenderables or setMaterialForVisibles call and a rendering process to restore the original material settings. The function also tells the current SceneManager to search for visible objects, as this is the default behaviour of SceneManager.

void OgreRenderingRun::restoreMaterials ( ) [protected, inherited]

Restores previously stored materials.

This helper function is typically used after a setMaterialForRenderables or setMaterialForVisibles call and a rendering process to restore the original material settings. The function also tells the current SceneManager to search for visible objects, as this is the default behaviour of SceneManager.

void OgreRenderingRun::renderFullscreenQuad | ( | String | materialName,
 |  | RenderTarget * | target |
 | ) |  |  | [protected, inherited]

Renderes a full screen quad on a given RendderTarget with a given material.

Parameters:
materialName | the name of the material bind to the quad
target | the RenderTarget the quad should be rendered on

void OgreRenderingRun::renderFullscreenQuad | ( | String | materialName,
 |  | RenderTarget * | target |
 | ) |  |  | [protected, inherited]

Renderes a full screen quad on a given RendderTarget with a given material.

Parameters:
materialName | the name of the material bind to the quad
target | the RenderTarget the quad should be rendered on

void OgreRenderingRun::renderPixelSprites | ( | String & | materialName,
 |  | RenderTarget * | rt,
 |  | int | width,
 |  | int | height |
 | ) |  |  | [protected, inherited]

Renderes sprites to pixels of the screen on a given RendderTarget with a given material.

Pixel sprites are pixel sized quads, placed on each pixel of the RenderTarget. The number of sprites not necessary corresponds to the resolution of the rendertarget. The pixel quads will evenly fill the rendertarget's area with sizes corresponding to the given resolution. We can render fewer or more pixel quads than the number of pixels the rendertarget has (eg.: in case of caustic cubemap generation).

Parameters:
materialName | the name of the material bind to the pixel sprites
rt | the RenderTarget the quads should be rendered on
width | the desired resolution width of the sprites
height | the desired resolution height of the sprites

void OgreRenderingRun::renderPixelSprites | ( | String & | materialName,
 |  | RenderTarget * | rt,
 |  | int | width,
 |  | int | height |
 | ) |  |  | [protected, inherited]

Renderes sprites to pixels of the screen on a given RendderTarget with a given material.

Pixel sprites are pixel sized quads, placed on each pixel of the RenderTarget. The number of sprites not necessary corresponds to the resolution of the rendertarget. The pixel quads will evenly fill the rendertarget's area with sizes corresponding to the given resolution. We can render fewer or more pixel quads than the number of pixels the rendertarget has (eg.: in case of caustic cubemap generation).

Parameters:
materialName | the name of the material bind to the pixel sprites
rt | the RenderTarget the quads should be rendered on
width | the desired resolution width of the sprites
height | the desired resolution height of the sprites

void OgreRenderingRun::renderFullscreenGrid | ( | String & | materialName,
 |  | RenderTarget * | rt,
 |  | int | width,
 |  | int | height |
 | ) |  |  | [protected, inherited]

Renders a grid onto the screen.

Parameters:
rt | the RenderTarget the grid should be rendered on
width | the desired horizontal resolution of the grid
height | the desired vertical resolution of the grid

virtual bool RenderingRun::canJoin ( RenderingRun * run ) [inline, virtual, inherited]

Returns true if two runs can be joined.

In some cases special requirements should stand to join two runs (even if they have the same type). Eg.: two caustic cube map generation technique should only be joined if they use the same material when rendering the caustic cubemap.

Reimplemented in OgreCausticCubeMapRenderingRun, OgreChildPSystemRenderingRun, and OgrePhotonMapRenderingRun.

virtual bool RenderingRun::needUpdate ( unsigned long frameNum ) [inline, protected, virtual, inherited]

Returns if this run needs update.

This tipically depends on the upate interval and the starting frame number.

Parameters:
frameNum current frame number

Reimplemented in OgreFocusingMapRenderingRun, and OgrePMEntryPointMapRenderingRun.

Member Data Documentation

std::map<Renderable*, String> OgreRenderingRun::visibleObjects [protected, inherited]

map of Renderables which will be rendered with a given material

The String stores the original material name that will be restored after rendering.

See also:
setMaterialForVisibles

setMaterialForRenderables

restoreMaterials

std::map<Renderable*, String> OgreRenderingRun::visibleObjects [protected, inherited]

map of Renderables which will be rendered with a given material

The String stores the original material name that will be restored after rendering.

See also:
setMaterialForVisibles

setMaterialForRenderables

restoreMaterials

MovablePlane * OgreRenderingRun::fullScreenQuad [static, protected, inherited]

fulls screen quad plane used in full screen quad rendering

See also:
renderFullscreenQuad

MovablePlane* OgreRenderingRun::fullScreenQuad [static, protected, inherited]

fulls screen quad plane used in full screen quad rendering

See also:
renderFullscreenQuad

Entity * OgreRenderingRun::fullScreenQuadEntity [static, protected, inherited]

fulls screen quad Entity used in full screen quad rendering

See also:
renderFullscreenQuad

Entity* OgreRenderingRun::fullScreenQuadEntity [static, protected, inherited]

fulls screen quad Entity used in full screen quad rendering

See also:
renderFullscreenQuad

SceneNode * OgreRenderingRun::fullScreenQuadNode [static, protected, inherited]

fulls screen quad SceneNode used in full screen quad rendering

See also:
renderFullscreenQuad

SceneNode* OgreRenderingRun::fullScreenQuadNode [static, protected, inherited]

fulls screen quad SceneNode used in full screen quad rendering

See also:
renderFullscreenQuad

SpriteSet* OgreRenderingRun::pixelSprites [protected, inherited]

SpriteSet used in pixel sprite rendering.

See also:
renderPixelSprites

BillboardSet* OgreRenderingRun::pixelSprites [protected, inherited]

SpriteSet used in pixel sprite rendering.

See also:
renderPixelSprites

String OgreRenderingRun::spriteSetName [protected, inherited]

unique name of the SpriteSet used in pixel sprite rendering

See also:
renderPixelSprites

Entity* OgreRenderingRun::fullscreenGrid [protected, inherited]

Entity used in fullscreen grid rendering.

See also:
renderPixelGrid

Generated on Wed Mar 28 11:49:00 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: OgreSharedRuns Class Reference

OgreSharedRuns Class Reference

Class of SharedRuns used in an OGRE environment. More...

Inheritance diagram for OgreSharedRuns:

SharedRuns List of all members.

Public Member Functions

OgreSharedRuns ()
Constructor.
std::map< RenderingRunType,
RenderingRun * > & 		getSharedRuns ()
Retrieves the contaied RenderingRuns with their type information.
void | setBoundingSphere (Sphere &sphere)
Sets the bounding sphere of the node.
void | setBoundingBox (AxisAlignedBox &box)
Sets the axis-aligned bounding box of the node.
Sphere & | getBoundingSphere ()
Returns the bounding sphere of the node.
AxisAlignedBox & | getBoundingBox ()
Returns the axis-aligned bounding box of the node.
Sphere & | getRootBoundingSphere ()
Returns the bounding sphere of the root parent node.
Sphere & | getRootBoundingSphere (RenderingRunType runType)
Retrieves the bounding sphere of the topmost parent node of this SharedRuns node, which have a specified RenderingRun type.
AxisAlignedBox & | getRootBoundingBox ()
Returns the axis-aligned bounding box of the root parent node.
AxisAlignedBox & | getRootBoundingBox (RenderingRunType runType)
Retrieves the axis-aligned bounding box of the topmost parent node of this SharedRuns node, which have a specified RenderingRun type.
const Vector3 & | getRootPosition ()
Returns the world space center position of the root parent node.
const Vector3 & | getRootPosition (RenderingRunType runType)
Retrieves the world space center position of the topmost parent node of this SharedRuns node, which have a specified RenderingRun type.
bool | hasOwnRun (RenderingRunType runType)
Checks if this node has a resource with the given type.
void | addRenderablesToQueue (RenderQueue *rq, bool checkVisible=true)
Adds all the Renderables connected to this node to a given RenderQueue.
void | notifyCamera (Camera *cam)
Calls notifyCamera() to all the Renderables connected to this node.
void | findSharedRootsForType (RenderingRunType runType, std::vector< OgreSharedRuns * > &roots)
Finds all the topmost nodes which have resources of the given type.
RenderingRun * | getRun (RenderingRunType runType)
void | addRun (RenderingRunType runType, RenderingRun *run)
void | updateRun (RenderingRunType runType, unsigned long frameNum)
void | updateBounds ()
Updates the boundary of this SharedRuns (and also it's parent).
void | validate ()
Validate this SharedRuns (and also all childs).
void | destroy ()
Destroys the node (and all parents recursively).
void | runUpdated (RenderingRunType runType, RenderingRun *run)
Called after one of he shared runs updates.
void | runChanged (RenderingRunType runType, RenderingRun *run)
Called after one of he shared runs changes.
virtual void | addTechniqueGroup (TechniqueGroup *group)
Adds a child TechniqueGroup.
void | setMaterial (String materialName)
Sets the given material for all connected renderables.
void | restoreMaterial ()
Restores the prevoius materials for the connected renderables.
virtual SharedRuns * | joinRuns (SharedRuns *otherRuns)
virtual void | setVisible (bool visible)
Shows or hides this SharedRuns (and also all childnodes).
virtual void | hide ()
Hides this SharedRuns (and also all childs).
virtual void | restoreVisibility ()
Restores the visibility of this SharedRuns (and also all childs).
virtual SharedRuns * | getRoot ()
Retrieves the root node of this SharedRuns node.
virtual SharedRuns * | getRoot (RenderingRunType runType)
Retrieves the topmost parent node of this SharedRuns node, which have a specified RenderingRun type.
virtual void | unbindParent ()
Unbinds the parent of the node, called at splitting.
virtual void | unbindAndKillParent ()
Unbinds the deletes the parent of the node, called at splitting.

Static Public Member Functions

static bool | canJoin (SharedRuns *r1, SharedRuns *r2)
Checks if two SharedRuns node can be joined.
static bool | haveCommonRuns (SharedRuns *r1, SharedRuns *r2, std::vector< RenderingRunType > &commonruns)
Checks if two SharedRuns have common resources so that they can be joined.

Protected Member Functions

void | gatherRuns ()
Collects RenderingRuns references from the child nodes, used when joining.
void | fireRunChanges ()
Sends runChanged events for each RenderingRun type, used after join and split.
SharedRuns * createInstance ()
Creates a new SharedRuns instance. All derivatives should implement this.
void | hideRenderables ()
Hides all the connected renderables, only used if this is a leaf.
void | restoreRenderableVisibility ()
Restires visibility of all the connected renderables, only used if this is a leaf.
void | setRenderablesVisible (bool visible)
Set visibility of connected renderables, only used if this is a leaf.

Protected Attributes

std::vector< TechniqueGroup * > | childTechniqueGroups
child TechniqueGroup instance.
std::map< RenderingRunType,
RenderingRun * > 		sharedRuns
map of contained RenderingRuns
std::map< OgreRenderable *,
bool > 		renderables
map of connected renderables with visibility information
std::map< OgreRenderable *,
String > 		renderableMaterials
map of connected renderables with material name information
Sphere | boundingSphere
the bounding sphere of all the objects connected to this node.
AxisAlignedBox | boundingBox
the axis aligned bounding box of all the objects connected to this node.
SharedRuns * parent
parent SharedRuns instance
SharedRuns * child1
child SharedRuns instance
SharedRuns * child2
child SharedRuns instance

Detailed Description

Class of SharedRuns used in an OGRE environment.

Member Function Documentation

std::map<RenderingRunType, RenderingRun*>& OgreSharedRuns::getSharedRuns ( ) [inline]

Retrieves the contaied RenderingRuns with their type information.

Returns:
map of renderables

void OgreSharedRuns::setBoundingSphere ( Sphere & sphere ) [inline]

Sets the bounding sphere of the node.

Parameters:
sphere bounding sphere

void OgreSharedRuns::setBoundingBox ( AxisAlignedBox & box ) [inline]

Sets the axis-aligned bounding box of the node.

Parameters:
box bounding box

Sphere& OgreSharedRuns::getBoundingSphere ( ) [inline]

Returns the bounding sphere of the node.

Returns:
a reference to the bounding sphere

AxisAlignedBox& OgreSharedRuns::getBoundingBox ( ) [inline]

Returns the axis-aligned bounding box of the node.

Returns:
a reference to the bounding box

Sphere& OgreSharedRuns::getRootBoundingSphere ( ) [inline]

Returns the bounding sphere of the root parent node.

Returns:
a reference to the bounding sphere

Sphere& OgreSharedRuns::getRootBoundingSphere ( RenderingRunType runType ) [inline]

Retrieves the bounding sphere of the topmost parent node of this SharedRuns node, which have a specified RenderingRun type.

Parameters:
runType the RenderingRun type
Returns:
a reference to the bounding sphere

AxisAlignedBox& OgreSharedRuns::getRootBoundingBox ( ) [inline]

Returns the axis-aligned bounding box of the root parent node.

Returns:
a reference to the bounding box

AxisAlignedBox& OgreSharedRuns::getRootBoundingBox ( RenderingRunType runType ) [inline]

Retrieves the axis-aligned bounding box of the topmost parent node of this SharedRuns node, which have a specified RenderingRun type.

Parameters:
runType the RenderingRun type
Returns:
a reference to the bounding box

const Vector3& OgreSharedRuns::getRootPosition ( ) [inline]

Returns the world space center position of the root parent node.

Returns:
a reference to the center position

const Vector3& OgreSharedRuns::getRootPosition ( RenderingRunType runType ) [inline]

Retrieves the world space center position of the topmost parent node of this SharedRuns node, which have a specified RenderingRun type.

Parameters:
runType the RenderingRun type
Returns:
a reference to the center position

bool OgreSharedRuns::canJoin | ( | SharedRuns * | r1,
 |  | SharedRuns * | r2 |
 | ) |  |  | [static]

Checks if two SharedRuns node can be joined.

Parameters:
r1 | pointer to one of the SharedRuns instance
r2 | pointer to the other SharedRuns instance

bool OgreSharedRuns::haveCommonRuns | ( | SharedRuns * | r1,
 |  | SharedRuns * | r2,
 |  | std::vector< RenderingRunType > & | commonruns |
 | ) |  |  | [static]

Checks if two SharedRuns have common resources so that they can be joined.

Parameters:
r1 | pointer to one of the SharedRuns instance
r2 | pointer to the other SharedRuns instance

bool OgreSharedRuns::hasOwnRun ( RenderingRunType runType ) [virtual]

Checks if this node has a resource with the given type.

Only this node none of the child nodes are checked.

Parameters:
the type of the RenderingRun to look for

Implements SharedRuns.

void OgreSharedRuns::addRenderablesToQueue | ( | RenderQueue * | rq,
 |  | bool | checkVisible = true
 | ) |  |

Adds all the Renderables connected to this node to a given RenderQueue.

The function is called recoursively for all child nodes.

Parameters:
pointer to the RenderQueue to add the Renderables to

void OgreSharedRuns::notifyCamera ( Camera * cam )

Calls notifyCamera() to all the Renderables connected to this node.

The function is called recoursively for all child nodes.

Parameters:
pointer to the Camera instance to call notifyCamera() with

void OgreSharedRuns::findSharedRootsForType | ( | RenderingRunType | runType,
 |  | std::vector< OgreSharedRuns * > & | roots
 | ) |  |

Finds all the topmost nodes which have resources of the given type.

This function is called for the root node, and will be called recoursively downwards in the tree for all childs. If a node with with the given resource is found, the node can be added and it's childs don't need to be checked anymore.

From a given group of objects (root node) a new set of groups will be created (they will be the members of the given vector). Each new group will be a subtree of the original tree. They will form groups that contain the maximum number of objects that can be joined by the the given resource type.

Parameters:
runType | the type of RenderingRun to look for
roots | reference to the collection to add the new groups to

RenderingRun * OgreSharedRuns::getRun ( RenderingRunType runType ) [virtual]

&brief Retrieves a shared resource.

Parameters:
runType enum, type of the RenderingRun to be retrieved
Returns:
pointer to the RenderingRun of type "runType", null if this type does not exists

Implements SharedRuns.

void OgreSharedRuns::addRun | ( | RenderingRunType | runType,
 |  | RenderingRun * | run |
 | ) |  |  | [virtual]

&brief Adds a RenderingRun instance to the shared resources.

Parameters:
runType | enum, type of the RenderingRun to add
run | pointer to the RenderingRun instance to add

Implements SharedRuns.

void OgreSharedRuns::updateRun | ( | RenderingRunType | runType,
 |  | unsigned long | frameNum |
 | ) |  |  | [virtual]

&brief Updates a shared RenderingRun.

Parameters:
runType | enum, type of the RenderingRun to update
frameNum | current framenumber

Implements SharedRuns.

void OgreSharedRuns::validate ( ) [virtual]

Validate this SharedRuns (and also all childs).

Validation meens that all the SharedRuns that are joined will be examined if the sharing is still valid. If it finds out that two SharedRuns can't be joined anymore (eg.: they moved far from each other), their parent will be split and destroyed (all parent of this node also should be deleted recursively).

Implements SharedRuns.

void OgreSharedRuns::runUpdated | ( | RenderingRunType | runType,
 |  | RenderingRun * | run |
 | ) |  |  | [virtual]

Called after one of he shared runs updates.

This message will be forwarded to each child.

Parameters:
runType | enum describing the type of the updated run
run | pointer to the updated RenderingRun

Reimplemented from SharedRuns.

void OgreSharedRuns::runChanged | ( | RenderingRunType | runType,
 |  | RenderingRun * | run |
 | ) |  |  | [virtual]

Called after one of he shared runs changes.

This message will be forwarded to each child.

Parameters:
runType | enum describing the type of the changed run
run | pointer to the changed RenderingRun

Reimplemented from SharedRuns.

virtual void OgreSharedRuns::addTechniqueGroup ( TechniqueGroup * group ) [inline, virtual]

Adds a child TechniqueGroup.

Parameters:
group pointer to the TechniqueGroup instance to add.

Implements SharedRuns.

void OgreSharedRuns::setMaterial ( String materialName )

Sets the given material for all connected renderables.

The previous materials will be stored so later can be restored.

See also:
restoreMaterial
Parameters:
name of the material to be set.

void OgreSharedRuns::restoreMaterial ( )

Restores the prevoius materials for the connected renderables.

See also:
setMaterial

SharedRuns * OgreSharedRuns::createInstance ( ) [protected, virtual]

Creates a new SharedRuns instance. All derivatives should implement this.

Returns:
a new SharedRuns instance

Implements SharedRuns.

void OgreSharedRuns::setRenderablesVisible ( bool visible ) [inline, protected, virtual]

Set visibility of connected renderables, only used if this is a leaf.

Parameters:
visible visibility

Implements SharedRuns.

SharedRuns * SharedRuns::joinRuns ( SharedRuns * otherRuns ) [virtual, inherited]

&brief Joines two SharedRuns.

The resulting SharedRuns become the parent of the two SharedRuns.

Parameters:
otherRuns pointer to the SharedRuns instance to join with
Returns:
the new parent SharedRuns instance

void SharedRuns::setVisible ( bool visible ) [virtual, inherited]

Shows or hides this SharedRuns (and also all childnodes).

Parameters:
visible visibility

void SharedRuns::hide ( ) [virtual, inherited]

Hides this SharedRuns (and also all childs).

The previous visibility is saved.

SharedRuns * SharedRuns::getRoot ( ) [virtual, inherited]

Retrieves the root node of this SharedRuns node.

Returns:
pointer to the root SharedRuns instance

SharedRuns * SharedRuns::getRoot ( RenderingRunType runType ) [virtual, inherited]

Retrieves the topmost parent node of this SharedRuns node, which have a specified RenderingRun type.

Parameters:
runType the RenderingRun type
Returns:
pointer to the parent SharedRuns instance

Member Data Documentation

std::vector<TechniqueGroup*> OgreSharedRuns::childTechniqueGroups [protected]

child TechniqueGroup instance.

If this SharedRuns node is a leaf, it containes a reference to a TechniqueGroup instance. All messages will be transfered to this object, and bounding information will be retrieved from this TechniqueGroup

std::map<OgreRenderable*, bool> OgreSharedRuns::renderables [protected]

map of connected renderables with visibility information

Used to show or hide the renderables connected to a leaf OgreSharedRuns node.

std::map<OgreRenderable*, String> OgreSharedRuns::renderableMaterials [protected]

map of connected renderables with material name information

Used to resture the original materials of the renderables connected to a leaf OgreSharedRuns node.

Generated on Wed Mar 28 11:49:01 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: OgreTechniqueGroup Class Reference

OgreTechniqueGroup Class Reference

Base class of a SharedRuns in an OGRE environment. More...

Inheritance diagram for OgreTechniqueGroup:

TechniqueGroup List of all members.

Public Member Functions

void | addRenderTechnique (RenderTechnique *technique)
Adds a rendertechnique to the group.
void | update (unsigned long frameNum)
Updates all rendertechniques.
void | runChanged (RenderingRunType runType, RenderingRun *run)
Called after one of the rendering runs changes.
void | runUpdated (RenderingRunType runType, RenderingRun *run)
Called after one of the rendering runs updates.
void | updateBounds ()
Updates the connected SharedRuns boundary.
void | addSharedRun (SharedRuns *sharedRuns)
Adds an empty SharedRuns parent.
SharedRuns * getSharedRuns ()
Retrieves the shared runs.
virtual void | validateSharedRuns ()
Validates the connected SharedRuns instance.

Protected Attributes

std::vector< OgreRenderTechnique * > | renderTechniques
Collection of OgreRenderTechniques.
SharedRuns * parentSharedRuns
Pointer to the connected SharedRuns instance each technique uses.

Detailed Description

Base class of a SharedRuns in an OGRE environment.

Member Function Documentation

void OgreTechniqueGroup::addRenderTechnique ( RenderTechnique * technique ) [virtual]

Adds a rendertechnique to the group.

Parameters:
technique the RenderTechnique instance to add.

Implements TechniqueGroup.

void OgreTechniqueGroup::update ( unsigned long frameNum ) [virtual]

Updates all rendertechniques.

Parameters:
framenum current framenumber

Implements TechniqueGroup.

void OgreTechniqueGroup::runChanged | ( | RenderingRunType | runType,
 |  | RenderingRun * | run |
 | ) |  |  | [virtual]

Called after one of the rendering runs changes.

This message will be forwarded to each RenderTechique.

Parameters:
runType | enum describing the type of the changed run
run | pointer to the changed RenderingRun

Implements TechniqueGroup.

void OgreTechniqueGroup::runUpdated | ( | RenderingRunType | runType,
 |  | RenderingRun * | run |
 | ) |  |  | [virtual]

Called after one of the rendering runs updates.

This message will be forwarded to each RenderTechique.

Parameters:
runType | enum describing the type of the updated run
run | pointer to the updated RenderingRun

Implements TechniqueGroup.

void TechniqueGroup::addSharedRun ( SharedRuns * sharedRuns ) [inline, inherited]

Adds an empty SharedRuns parent.

Used after creating a new TechniqueGroup.

Parameters:
sharedRuns pointer to the SharedRun instance this RenderTechniques will use.

SharedRuns* TechniqueGroup::getSharedRuns ( ) [inline, inherited]

Retrieves the shared runs.

Returns:
pointer to the SharedRun instance this RenderTechniques uses.

Member Data Documentation

std::vector<OgreRenderTechnique*> OgreTechniqueGroup::renderTechniques [protected]

Collection of OgreRenderTechniques.

All messages will be forwarded to each element of this vector.

Generated on Wed Mar 28 11:49:01 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: PathMapClusters Struct Reference

PathMapClusters Struct Reference

Structure to store path map cluster information for a subentity. More...

List of all members.

Public Attributes

unsigned int | count
the number of clusters this subentity belongs to
unsigned int * | clusters
the indices of the cluster this subentity belongs to.
String | pathMapTextureFilename
the name of the path map file this subentity uses
unsigned int | pathMapResolution
the resolution of the path map file.

Detailed Description

Structure to store path map cluster information for a subentity.

Generated on Wed Mar 28 11:49:01 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: PathMapEntryPoint Struct Reference

PathMapEntryPoint Struct Reference

Structure of a path map entry point. More...

List of all members.

Public Attributes

Vector3 | position
the position of the entry point.
Vector3 | normal
the normal of the entry point.
float | prob
the probability of the entry point.

Detailed Description

Structure of a path map entry point.

Generated on Wed Mar 28 11:49:01 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: PhaseTextureRenderingRun Class Reference

PhaseTextureRenderingRun Class Reference

Base abstract class that defines a rendering process that creates phase texture. More...

Inheritance diagram for PhaseTextureRenderingRun:

RenderingRun OgrePhaseTextureRenderingRun List of all members.

Public Member Functions

PhaseTextureRenderingRun (unsigned int resolutionX, unsigned int resolutionY)
Constructor.
bool | update (unsigned long frameNum)
Calls updateFrame() if the run needs update according to its starting frame and update interval and has not been allready updated in this frame.
virtual class OgreRenderingRun * | asOgreRenderingRun ()
Conversion to OgreRenderRun.
virtual bool | canJoin (RenderingRun *run)
Returns true if two runs can be joined.

Protected Member Functions

virtual void | createPhaseTexture ()=0
Creates the depth map texture.
virtual void | updateFrame (unsigned long frameNum)=0
This function does the actual update in a frame.
virtual bool | needUpdate (unsigned long frameNum)
Returns if this run needs update.

Protected Attributes

unsigned int | resolutionX
width of the texture
unsigned int | resolutionY
height of the texture
unsigned long | lastupdated
The number of the last frame this run was updated.
unsigned long | startFrame
The number of the frame this run should be updated first.
unsigned long | updateInterval
Refresh frequency in frames.

Detailed Description

Base abstract class that defines a rendering process that creates phase texture.

The phase texture can be used as a look-up table during rendering of partcipating media. If the texture is created once it can be saved and reused, so this run is usually not needed, only runned once. This texture is addressed as the following: the u coordinates represents the symmetry of scattering (negative if backward scattering, positive if forward scattering and zero if equally scaterring in the forward and in the backward directions) ; the v coordinates represent the cosine of the angle between the incoming and outgoing directions.

Constructor & Destructor Documentation

PhaseTextureRenderingRun::PhaseTextureRenderingRun | ( | unsigned int | resolutionX,
 |  | unsigned int | resolutionY |
 | ) |  |  | [inline]

Constructor.

Parameters:
resolutionX | width of the texture
resolutionY | height of the texture

Member Function Documentation

virtual void PhaseTextureRenderingRun::updateFrame ( unsigned long frameNum ) [protected, pure virtual]

This function does the actual update in a frame.

Parameters:
frameNum current frame number

Reimplemented from RenderingRun.

Implemented in OgrePhaseTextureRenderingRun.

virtual class OgreRenderingRun* RenderingRun::asOgreRenderingRun ( ) [inline, virtual, inherited]

Conversion to OgreRenderRun.

This function is needed because of virtual inheritance.

Reimplemented in OgreRenderingRun, and OgreRenderingRun.

virtual bool RenderingRun::canJoin ( RenderingRun * run ) [inline, virtual, inherited]

Returns true if two runs can be joined.

In some cases special requirements should stand to join two runs (even if they have the same type). Eg.: two caustic cube map generation technique should only be joined if they use the same material when rendering the caustic cubemap.

Reimplemented in OgreCausticCubeMapRenderingRun, OgreChildPSystemRenderingRun, and OgrePhotonMapRenderingRun.

virtual bool RenderingRun::needUpdate ( unsigned long frameNum ) [inline, protected, virtual, inherited]

Returns if this run needs update.

This tipically depends on the upate interval and the starting frame number.

Parameters:
frameNum current frame number

Reimplemented in OgreFocusingMapRenderingRun, and OgrePMEntryPointMapRenderingRun.

Generated on Wed Mar 28 11:49:01 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: PhotonMapRenderingRun Class Reference

PhotonMapRenderingRun Class Reference

Base abstract class that defines a rendering process of a photon hit map. More...

Inheritance diagram for PhotonMapRenderingRun:

RenderingRun OgrePhotonMapRenderingRun List of all members.

Public Member Functions

PhotonMapRenderingRun (unsigned long startFrame, unsigned long updateInterval)
Constructor.
bool | update (unsigned long frameNum)
Calls updateFrame() if the run needs update according to its starting frame and update interval and has not been allready updated in this frame.
virtual class OgreRenderingRun * | asOgreRenderingRun ()
Conversion to OgreRenderRun.
virtual bool | canJoin (RenderingRun *run)
Returns true if two runs can be joined.

Protected Member Functions

virtual void | updateFrame (unsigned long frameNum)=0
This function does the actual update in a frame.
virtual void | createPhotonMap ()=0
Creates a photon hit map.
virtual bool | needUpdate (unsigned long frameNum)
Returns if this run needs update.

Protected Attributes

unsigned long | lastupdated
The number of the last frame this run was updated.
unsigned long | startFrame
The number of the frame this run should be updated first.
unsigned long | updateInterval
Refresh frequency in frames.

Detailed Description

Base abstract class that defines a rendering process of a photon hit map.

A photon hit map stores the directions where the incoming photons are refracted by a caustic emitter object. One pixel of the photon map represents one photon hit, hte direction is encoded in the RGB channels. If the alpha channel has zero value, the hit is invalid.

Constructor & Destructor Documentation

PhotonMapRenderingRun::PhotonMapRenderingRun | ( | unsigned long | startFrame,
 |  | unsigned long | updateInterval |
 | ) |  |  | [inline]

Constructor.

Parameters:
startFrame | adds an offset to the current frame number to help evenly distribute updates between frames
updateInterval | update frequency

Member Function Documentation

virtual void PhotonMapRenderingRun::updateFrame ( unsigned long frameNum ) [protected, pure virtual]

This function does the actual update in a frame.

Parameters:
frameNum current frame number

Reimplemented from RenderingRun.

Implemented in OgrePhotonMapRenderingRun.

virtual class OgreRenderingRun* RenderingRun::asOgreRenderingRun ( ) [inline, virtual, inherited]

Conversion to OgreRenderRun.

This function is needed because of virtual inheritance.

Reimplemented in OgreRenderingRun, and OgreRenderingRun.

virtual bool RenderingRun::canJoin ( RenderingRun * run ) [inline, virtual, inherited]

Returns true if two runs can be joined.

In some cases special requirements should stand to join two runs (even if they have the same type). Eg.: two caustic cube map generation technique should only be joined if they use the same material when rendering the caustic cubemap.

Reimplemented in OgreCausticCubeMapRenderingRun, OgreChildPSystemRenderingRun, and OgrePhotonMapRenderingRun.

virtual bool RenderingRun::needUpdate ( unsigned long frameNum ) [inline, protected, virtual, inherited]

Returns if this run needs update.

This tipically depends on the upate interval and the starting frame number.

Parameters:
frameNum current frame number

Reimplemented in OgreFocusingMapRenderingRun, and OgrePMEntryPointMapRenderingRun.

Generated on Wed Mar 28 11:49:01 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: ReducedCubeMapRenderingRun Class Reference

ReducedCubeMapRenderingRun Class Reference

Base abstract class that defines a rendering process of a downsampled color-cubemap. More...

Inheritance diagram for ReducedCubeMapRenderingRun:

RenderingRun OgreReducedCubeMapRenderingRun List of all members.

Public Member Functions

ReducedCubeMapRenderingRun (unsigned long startFrame, unsigned long updateInterval, unsigned int resolution, bool useDistCalc, bool useFaceAngleCalc, float distTolerance, float angleTolerance, bool updateAllFace)
Constructor.
bool | update (unsigned long frameNum)
Calls updateFrame() if the run needs update according to its starting frame and update interval and has not been allready updated in this frame.
virtual class OgreRenderingRun * | asOgreRenderingRun ()
Conversion to OgreRenderRun.
virtual bool | canJoin (RenderingRun *run)
Returns true if two runs can be joined.

Protected Member Functions

virtual void | createReducedCubeMap ()=0
Creates the reduced size cubemap texture.
virtual void | updateCubeFace (int facenum)=0
Updates one face of the cubemap.
virtual bool | faceNeedsUpdate (int facenum)=0
Checks if a cubemap face needs to be updated.
virtual void | updateFrame (unsigned long frameNum)
This function does the actual update in a frame.
virtual bool | needUpdate (unsigned long frameNum)
Returns if this run needs update.

Protected Attributes

bool | updateAllFace
defines if all cubemap faces should be updated in a frame or only one face per frame
unsigned char | currentFace
the number of the face to be updated
unsigned int | resolution
the resolution of the cubemap texture that was created by this run
bool | useDistCalc
a flag to skip cube face update if object is far away or too small.
bool | useFaceAngleCalc
a flag to skip cube face update the face is neglible.
float | distTolerance
A value used in face skip test.
float | angleTolerance
A value used in face skip test.
unsigned long | lastupdated
The number of the last frame this run was updated.
unsigned long | startFrame
The number of the frame this run should be updated first.
unsigned long | updateInterval
Refresh frequency in frames.

Detailed Description

Base abstract class that defines a rendering process of a downsampled color-cubemap.

The resulting cubemap is a lower resolution variation of the color cube map. It is created with averaging the original cubemap. The lower resolution cubemap can be convolved faster and can efficiently be used in effects like diffuse reflection.

Constructor & Destructor Documentation

ReducedCubeMapRenderingRun::ReducedCubeMapRenderingRun | ( | unsigned long | startFrame,
 |  | unsigned long | updateInterval,
 |  | unsigned int | resolution,
 |  | bool | useDistCalc,
 |  | bool | useFaceAngleCalc,
 |  | float | distTolerance,
 |  | float | angleTolerance,
 |  | bool | updateAllFace
 | ) |  |

Constructor.

Parameters:
startFrame | adds an offset to the current frame number to help evenly distribute updates between frames
updateInterval | update frequency
resolution | reduced cubemap resolution
useDistCalc | flag to skip cube face update if object is far away
useFaceAngleCalc | flag to skip cube face update if face is neglible
distTolerance | distance tolerance used in face skip
angleTolerance | angle tolerance used in face skip
updateAllFace | defines if all cubemap faces should be updated in a frame or only one face per frame

Member Function Documentation

virtual void ReducedCubeMapRenderingRun::updateCubeFace ( int facenum ) [inline, protected, pure virtual]

Updates one face of the cubemap.

Parameters:
facenum the number of the face to be updated

Implemented in OgreReducedCubeMapRenderingRun.

virtual bool ReducedCubeMapRenderingRun::faceNeedsUpdate ( int facenum ) [protected, pure virtual]

Checks if a cubemap face needs to be updated.

If the object we are updating the cubemap for is far from the camera, or too small, or the given cubemapface does not have significant effect on the rendering the face can be skipped.

Parameters:
facenum the number of the face to be checked

Implemented in OgreReducedCubeMapRenderingRun.

void ReducedCubeMapRenderingRun::updateFrame ( unsigned long frameNum ) [protected, virtual]

This function does the actual update in a frame.

Parameters:
frameNum current frame number

Reimplemented from RenderingRun.

virtual class OgreRenderingRun* RenderingRun::asOgreRenderingRun ( ) [inline, virtual, inherited]

Conversion to OgreRenderRun.

This function is needed because of virtual inheritance.

Reimplemented in OgreRenderingRun, and OgreRenderingRun.

virtual bool RenderingRun::canJoin ( RenderingRun * run ) [inline, virtual, inherited]

Returns true if two runs can be joined.

In some cases special requirements should stand to join two runs (even if they have the same type). Eg.: two caustic cube map generation technique should only be joined if they use the same material when rendering the caustic cubemap.

Reimplemented in OgreCausticCubeMapRenderingRun, OgreChildPSystemRenderingRun, and OgrePhotonMapRenderingRun.

virtual bool RenderingRun::needUpdate ( unsigned long frameNum ) [inline, protected, virtual, inherited]

Returns if this run needs update.

This tipically depends on the upate interval and the starting frame number.

Parameters:
frameNum current frame number

Reimplemented in OgreFocusingMapRenderingRun, and OgrePMEntryPointMapRenderingRun.

Member Data Documentation

bool ReducedCubeMapRenderingRun::useDistCalc [protected]

a flag to skip cube face update if object is far away or too small.

See also:
distTolerance

bool ReducedCubeMapRenderingRun::useFaceAngleCalc [protected]

a flag to skip cube face update the face is neglible.

See also:
angleTolerance

float ReducedCubeMapRenderingRun::distTolerance [protected]

A value used in face skip test.

The higher this value gets the more precise, but slower the method will be.

float ReducedCubeMapRenderingRun::angleTolerance [protected]

A value used in face skip test.

The higher this value gets the more precise, but slower the method will be.

Generated on Wed Mar 28 11:49:01 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: RenderingRun Class Reference

RenderingRun Class Reference

Base class for a computation module. More...

Inheritance diagram for RenderingRun:

CausticCubeMapRenderingRun ChildPsystemRenderingRun CubeMapRenderingRun DepthShadowMapRenderingRun LightVolumeRenderingRun OgreRenderingRun OgreRenderingRun PhaseTextureRenderingRun PhotonMapRenderingRun ReducedCubeMapRenderingRun SceneCameraDepthRenderingRun List of all members.

Public Member Functions

RenderingRun (unsigned long startFrame, unsigned long updateInterval)
Constructor.
bool | update (unsigned long frameNum)
Calls updateFrame() if the run needs update according to its starting frame and update interval and has not been allready updated in this frame.
virtual class OgreRenderingRun * | asOgreRenderingRun ()
Conversion to OgreRenderRun.
virtual bool | canJoin (RenderingRun *run)
Returns true if two runs can be joined.

Protected Member Functions

virtual bool | needUpdate (unsigned long frameNum)
Returns if this run needs update.
virtual void | updateFrame (unsigned long frameNum)
This function does the actual update in a frame.

Protected Attributes

unsigned long | lastupdated
The number of the last frame this run was updated.
unsigned long | startFrame
The number of the frame this run should be updated first.
unsigned long | updateInterval
Refresh frequency in frames.

Detailed Description

Base class for a computation module.

A run typically - but not necessarily or exclusively - consists of a series of rendering passes. A run is alway created to compute some kind of resource for a RenderTechnique. The type of the resource depends on the type of the run (typically it is a Texture). Runs can be attached to only one Technique (if only one of the Techniques attached to a Renderable can use this resource, and each Renderable requires a unique one), or can be shared between several Techniques and Renderables (for example a cube-map). Runs are updated only once in a frame, but not necessary in each frame.

Constructor & Destructor Documentation

RenderingRun::RenderingRun | ( | unsigned long | startFrame,
 |  | unsigned long | updateInterval
 | ) |  |

Constructor.

Parameters:
startFrame | adds an offset to the current frame number to help evenly distribute updates between frames
updateInterval | photon map update frequency

Member Function Documentation

virtual class OgreRenderingRun* RenderingRun::asOgreRenderingRun ( ) [inline, virtual]

Conversion to OgreRenderRun.

This function is needed because of virtual inheritance.

Reimplemented in OgreRenderingRun, and OgreRenderingRun.

virtual bool RenderingRun::canJoin ( RenderingRun * run ) [inline, virtual]

Returns true if two runs can be joined.

In some cases special requirements should stand to join two runs (even if they have the same type). Eg.: two caustic cube map generation technique should only be joined if they use the same material when rendering the caustic cubemap.

Reimplemented in OgreCausticCubeMapRenderingRun, OgreChildPSystemRenderingRun, and OgrePhotonMapRenderingRun.

virtual bool RenderingRun::needUpdate ( unsigned long frameNum ) [inline, protected, virtual]

Returns if this run needs update.

This tipically depends on the upate interval and the starting frame number.

Parameters:
frameNum current frame number

Reimplemented in OgreFocusingMapRenderingRun, and OgrePMEntryPointMapRenderingRun.

virtual void RenderingRun::updateFrame ( unsigned long frameNum ) [inline, protected, virtual]

This function does the actual update in a frame.

Parameters:
frameNum current frame number

Reimplemented in CausticCubeMapRenderingRun, ChildPsystemRenderingRun, CubeMapRenderingRun, DepthShadowMapRenderingRun, LightVolumeRenderingRun, PhaseTextureRenderingRun, PhotonMapRenderingRun, ReducedCubeMapRenderingRun, SceneCameraDepthRenderingRun, OgreChildPSystemRenderingRun, OgreDepthShadowMapRenderingRun, OgreFocusingMapRenderingRun, OgreLightVolumeRenderingRun, OgrePhaseTextureRenderingRun, OgrePhotonMapRenderingRun, OgrePMEntryPointMapRenderingRun, OgrePMWeightComputeRenderingRun, and OgreSceneCameraDepthRenderingRun.

Generated on Wed Mar 28 11:49:02 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: RenderTechnique Class Reference

RenderTechnique Class Reference

Base class for a rendering technique. More...

Inheritance diagram for RenderTechnique:

CausticCasterRenderTechnique CausticReceiverRenderTechnique CubeMapRenderTechnique DepthShadowReceiverRenderTechnique HierarchicalParticleSystemTechnique IllumVolumeRenderTechnique OgreRenderTechnique SBBRenderTechnique List of all members.

Public Member Functions

RenderTechnique (ElementaryRenderable *parentRenderable, TechniqueGroup *parentTechniqueGroup)
Constructor.
virtual void | update (unsigned long frameNum)
Updates the resources in the given frame.
virtual void | runChanged (RenderingRunType runType, RenderingRun *run)
Called after one of he shared runs changes.
virtual void | runUpdated (RenderingRunType runType, RenderingRun *run)
Called after one of he shared runs updates.
virtual class OgreRenderTechnique * | asOgreRenderTechnique ()
Conversion to OgreRenderTechnique.
ElementaryRenderable * getParentRenderable ()
Retrieves the renderable this technique operates on.

Protected Attributes

ElementaryRenderable * parentRenderable
The renderable this technique operates on.
TechniqueGroup * parentTechniqueGroup
The TechniqueGroup this RenderedTechnique is attached to.
SharedRuns * sharedRuns
The SharedRuns this RenderedTechnique is attached to.

Detailed Description

Base class for a rendering technique.

A RenderTechnique gives a description about how to render an object, and what kind of resources are needed to do this. A RenderTechnique does not define the whole process of rendering only one property of the display, example: this object will need a cubemap or this object is going to be a caustic caster. RenderTechniques usually operate on one pass of the rendering, and bind some resources to this pass (for example it can bind a texture or cubemap tho the given pass).

RenderTechniques are always bound to a Renderable, and a SharedRuns object. The Renderable defines the object to operate on. SharedRuns is to register RenderingRuns which can be shared between other RenderTechniques (example: a cubemap can be used by other techniques too, or even more than one object can share a single cubemap).

Constructor & Destructor Documentation

RenderTechnique::RenderTechnique | ( | ElementaryRenderable * | parentRenderable,
 |  | TechniqueGroup * | parentTechniqueGroup
 | ) |  |

Constructor.

Parameters:
parentRenderable | the object to operate on
parentTechniqueGroup | the TechniqueGroup this RenderedTechnique is attached to

Member Function Documentation

virtual void RenderTechnique::update ( unsigned long frameNum ) [inline, virtual]

Updates the resources in the given frame.

A RenderTechnique is usually need some resources from several runs, so these runs will be updated.

Parameters:
frameNum the actual framenumber

Reimplemented in ColorCubeMapRenderTechnique, ConvolvedCubeMapRenderTechnique, DistanceCubeMapRenderTechnique, HierarchicalParticleSystemTechnique, IllumVolumeRenderTechnique, OgreCausticReceiverRenderTechnique, OgreColorCubeMapRenderTechnique, OgreConvolvedCubeMapRenderTechnique, OgreDepthShadowReceiverRenderTechnique, OgreDistanceCubeMapRenderTechnique, OgreFireRenderTechnique, OgrePathMapRenderTechnique, and OgreSBBRenderTechnique.

virtual void RenderTechnique::runChanged | ( | RenderingRunType | runType,
 |  | RenderingRun * | run |
 | ) |  |  | [inline, virtual]

Called after one of he shared runs changes.

Parameters:
runType | enum describing the type of the changed run
run | pointer to the changed RenderingRun

Reimplemented in CausticCasterRenderTechnique, ColorCubeMapRenderTechnique, ConvolvedCubeMapRenderTechnique, CubeMapRenderTechnique, DistanceCubeMapRenderTechnique, HierarchicalParticleSystemTechnique, and IllumVolumeRenderTechnique.

virtual void RenderTechnique::runUpdated | ( | RenderingRunType | runType,
 |  | RenderingRun * | run |
 | ) |  |  | [inline, virtual]

Called after one of he shared runs updates.

Parameters:
runType | enum describing the type of the updated run
run | pointer to the updated RenderingRun

Reimplemented in CausticCasterRenderTechnique, ColorCubeMapRenderTechnique, CubeMapRenderTechnique, DistanceCubeMapRenderTechnique, HierarchicalParticleSystemTechnique, and IllumVolumeRenderTechnique.

virtual class OgreRenderTechnique* RenderTechnique::asOgreRenderTechnique ( ) [inline, virtual]

Conversion to OgreRenderTechnique.

This function is needed because of virtual inheritance.

Reimplemented in OgreRenderTechnique.

Generated on Wed Mar 28 11:49:02 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: RenderTechniqueFactory Class Reference

RenderTechniqueFactory Class Reference

Base abstract class for creating RenderTechnique instances. More...

Inheritance diagram for RenderTechniqueFactory:

OgreCausticCasterRenderTechniqueFactory OgreCausticReceiverRenderTechniqueFactory OgreCubeMapRenderTechniqueFactory OgreDepthShadowReceiverRenderTechniqueFactory OgreFireRenderTechniqueFactory OgreHierarchicalParticleSystemTechniqueFactory OgreIllumVolumeRenderTechniqueFactory OgrePathMapRenderTechniqueFactory OgreSBBRenderTechniqueFactory List of all members.

Public Member Functions

bool | isType (String type)
Returns if this factory can create a RenderTechnique of the given type.
virtual OgreRenderTechnique * | createInstance (IllumTechniqueParams *params, Pass *pass, OgreRenderable *parentRenderable, OgreTechniqueGroup *parentTechniqueGroup)=0
Creates a RenderTechnique of the factory type.
virtual void | parseParams (IllumTechniqueParams *params)
parses parameters from the material file.

Protected Types

typedef void(*) | ILLUM_ATTRIBUTE_PARSER (String &params, RenderTechniqueFactory *factory)
function for parsing RenderTechnique attributes
typedef std::map< String,
ILLUM_ATTRIBUTE_PARSER > 		AttribParserList
Keyword-mapped attribute parsers.

Protected Attributes

AttribParserList attributeParsers
map of parser functions
String | typeName
factoryname

Detailed Description

Base abstract class for creating RenderTechnique instances.

Member Typedef Documentation

typedef void(*) RenderTechniqueFactory::ILLUM_ATTRIBUTE_PARSER(String &params, RenderTechniqueFactory *factory) [protected]

function for parsing RenderTechnique attributes

Parameters:
params attribute value stored in a String

Member Function Documentation

bool RenderTechniqueFactory::isType ( String type ) [inline]

Returns if this factory can create a RenderTechnique of the given type.

Parameters:
type RenderTechnique type

virtual OgreRenderTechnique* RenderTechniqueFactory::createInstance | ( | IllumTechniqueParams * | params,
 |  | Pass * | pass,
 |  | OgreRenderable * | parentRenderable,
 |  | OgreTechniqueGroup * | parentTechniqueGroup |
 | ) |  |  | [pure virtual]

Creates a RenderTechnique of the factory type.

Parameters:
params | containes constructor parameters as NameValuePairList
pass | the Pass to use in RenderTechnique constructor
pass | the parentRenderable to pass to RenderTechnique constructor
pass | the parentTechniqueGroup to pass to RenderTechnique constructor

Implemented in OgreCausticCasterRenderTechniqueFactory, OgreCausticReceiverRenderTechniqueFactory, OgreColorCubeMapRenderTechniqueFactory, OgreConvoledCubeMapRenderTechniqueFactory, OgreCubeMapRenderTechniqueFactory, OgreDepthShadowReceiverRenderTechniqueFactory, OgreDistanceCubeMapRenderTechniqueFactory, OgreFireRenderTechniqueFactory, OgreHierarchicalParticleSystemTechniqueFactory, OgreIllumVolumeRenderTechniqueFactory, OgrePathMapRenderTechniqueFactory, and OgreSBBRenderTechniqueFactory.

void RenderTechniqueFactory::parseParams ( IllumTechniqueParams * params ) [virtual]

parses parameters from the material file.

The parsed parameters will be passed to the new RenderTechnique's constructor.

Parameters:
params pointer to the IllumTechniqueParams structure that was read from the material script and containes the parameters to be parsed.

Generated on Wed Mar 28 11:49:02 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: SBBRenderTechnique Class Reference

SBBRenderTechnique Class Reference

Base abstract class of rendering a particle system with the spherical billboard method. More...

Inheritance diagram for SBBRenderTechnique:

RenderTechnique OgreSBBRenderTechnique List of all members.

Public Member Functions

SBBRenderTechnique (ElementaryRenderable *parentRenderable, TechniqueGroup *parentTechniqueGroup)
Constructor.
virtual void | update (unsigned long frameNum)
Updates the resources in the given frame.
virtual void | runChanged (RenderingRunType runType, RenderingRun *run)
Called after one of he shared runs changes.
virtual void | runUpdated (RenderingRunType runType, RenderingRun *run)
Called after one of he shared runs updates.
virtual class OgreRenderTechnique * | asOgreRenderTechnique ()
Conversion to OgreRenderTechnique.
ElementaryRenderable * getParentRenderable ()
Retrieves the renderable this technique operates on.

Protected Attributes

ElementaryRenderable * parentRenderable
The renderable this technique operates on.
TechniqueGroup * parentTechniqueGroup
The TechniqueGroup this RenderedTechnique is attached to.
SharedRuns * sharedRuns
The SharedRuns this RenderedTechnique is attached to.

Detailed Description

Base abstract class of rendering a particle system with the spherical billboard method.

This technique only defines that the rendering of the object needs depth information of the scene from the player camera's view.

Constructor & Destructor Documentation

SBBRenderTechnique::SBBRenderTechnique | ( | ElementaryRenderable * | parentRenderable,
 |  | TechniqueGroup * | parentTechniqueGroup
 | ) |  |

Constructor.

Parameters:
parentRenderable | the object to operate on
parentTechniqueGroup | the TechniqueGroup this RenderedTechnique is attached to

Member Function Documentation

virtual void RenderTechnique::update ( unsigned long frameNum ) [inline, virtual, inherited]

Updates the resources in the given frame.

A RenderTechnique is usually need some resources from several runs, so these runs will be updated.

Parameters:
frameNum the actual framenumber

Reimplemented in ColorCubeMapRenderTechnique, ConvolvedCubeMapRenderTechnique, DistanceCubeMapRenderTechnique, HierarchicalParticleSystemTechnique, IllumVolumeRenderTechnique, OgreCausticReceiverRenderTechnique, OgreColorCubeMapRenderTechnique, OgreConvolvedCubeMapRenderTechnique, OgreDepthShadowReceiverRenderTechnique, OgreDistanceCubeMapRenderTechnique, OgreFireRenderTechnique, OgrePathMapRenderTechnique, and OgreSBBRenderTechnique.

virtual void RenderTechnique::runChanged | ( | RenderingRunType | runType,
 |  | RenderingRun * | run |
 | ) |  |  | [inline, virtual, inherited]

Called after one of he shared runs changes.

Parameters:
runType | enum describing the type of the changed run
run | pointer to the changed RenderingRun

Reimplemented in CausticCasterRenderTechnique, ColorCubeMapRenderTechnique, ConvolvedCubeMapRenderTechnique, CubeMapRenderTechnique, DistanceCubeMapRenderTechnique, HierarchicalParticleSystemTechnique, and IllumVolumeRenderTechnique.

virtual void RenderTechnique::runUpdated | ( | RenderingRunType | runType,
 |  | RenderingRun * | run |
 | ) |  |  | [inline, virtual, inherited]

Called after one of he shared runs updates.

Parameters:
runType | enum describing the type of the updated run
run | pointer to the updated RenderingRun

Reimplemented in CausticCasterRenderTechnique, ColorCubeMapRenderTechnique, CubeMapRenderTechnique, DistanceCubeMapRenderTechnique, HierarchicalParticleSystemTechnique, and IllumVolumeRenderTechnique.

virtual class OgreRenderTechnique* RenderTechnique::asOgreRenderTechnique ( ) [inline, virtual, inherited]

Conversion to OgreRenderTechnique.

This function is needed because of virtual inheritance.

Reimplemented in OgreRenderTechnique.

Generated on Wed Mar 28 11:49:02 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: SceneCameraDepthRenderingRun Class Reference

SceneCameraDepthRenderingRun Class Reference

Base abstract class that defines a rendering process that creates depth map fro the camera. More...

Inheritance diagram for SceneCameraDepthRenderingRun:

RenderingRun OgreSceneCameraDepthRenderingRun List of all members.

Public Member Functions

SceneCameraDepthRenderingRun ()
Constructor.
bool | update (unsigned long frameNum)
Calls updateFrame() if the run needs update according to its starting frame and update interval and has not been allready updated in this frame.
virtual class OgreRenderingRun * | asOgreRenderingRun ()
Conversion to OgreRenderRun.
virtual bool | canJoin (RenderingRun *run)
Returns true if two runs can be joined.

Protected Member Functions

virtual void | createDepthMap ()=0
Creates the depth map texture.
virtual void | updateFrame (unsigned long frameNum)=0
This function does the actual update in a frame.
virtual bool | needUpdate (unsigned long frameNum)
Returns if this run needs update.

Protected Attributes

unsigned long | lastupdated
The number of the last frame this run was updated.
unsigned long | startFrame
The number of the frame this run should be updated first.
unsigned long | updateInterval
Refresh frequency in frames.

Detailed Description

Base abstract class that defines a rendering process that creates depth map fro the camera.

The depth map stores the scene's camera space z coordinates (rendered from the player's view).

Member Function Documentation

virtual void SceneCameraDepthRenderingRun::updateFrame ( unsigned long frameNum ) [protected, pure virtual]

This function does the actual update in a frame.

Parameters:
frameNum current frame number

Reimplemented from RenderingRun.

Implemented in OgreSceneCameraDepthRenderingRun.

virtual class OgreRenderingRun* RenderingRun::asOgreRenderingRun ( ) [inline, virtual, inherited]

Conversion to OgreRenderRun.

This function is needed because of virtual inheritance.

Reimplemented in OgreRenderingRun, and OgreRenderingRun.

virtual bool RenderingRun::canJoin ( RenderingRun * run ) [inline, virtual, inherited]

Returns true if two runs can be joined.

In some cases special requirements should stand to join two runs (even if they have the same type). Eg.: two caustic cube map generation technique should only be joined if they use the same material when rendering the caustic cubemap.

Reimplemented in OgreCausticCubeMapRenderingRun, OgreChildPSystemRenderingRun, and OgrePhotonMapRenderingRun.

virtual bool RenderingRun::needUpdate ( unsigned long frameNum ) [inline, protected, virtual, inherited]

Returns if this run needs update.

This tipically depends on the upate interval and the starting frame number.

Parameters:
frameNum current frame number

Reimplemented in OgreFocusingMapRenderingRun, and OgrePMEntryPointMapRenderingRun.

Generated on Wed Mar 28 11:49:03 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: SharedRuns Class Reference

SharedRuns Class Reference

Base abstract class for a collection of shared resources (RenderingRuns). More...

Inheritance diagram for SharedRuns:

OgreSharedRuns List of all members.

Public Member Functions

SharedRuns (void)
virtual bool | hasOwnRun (RenderingRunType runType)=0
virtual RenderingRun * | getRun (RenderingRunType runType)=0
virtual void | addRun (RenderingRunType runType, RenderingRun *run)=0
virtual void | updateRun (RenderingRunType runType, unsigned long frameNum)=0
virtual SharedRuns * | joinRuns (SharedRuns *otherRuns)
virtual void | runChanged (RenderingRunType runType, RenderingRun *run)
Called after one of he shared runs changes.
virtual void | runUpdated (RenderingRunType runType, RenderingRun *run)
Called after one of he shared runs updates.
virtual void | addTechniqueGroup (TechniqueGroup *group)=0
Adds a child TechniqueGroup.
virtual void | setVisible (bool visible)
Shows or hides this SharedRuns (and also all childnodes).
virtual void | hide ()
Hides this SharedRuns (and also all childs).
virtual void | restoreVisibility ()
Restores the visibility of this SharedRuns (and also all childs).
virtual SharedRuns * | getRoot ()
Retrieves the root node of this SharedRuns node.
virtual SharedRuns * | getRoot (RenderingRunType runType)
Retrieves the topmost parent node of this SharedRuns node, which have a specified RenderingRun type.
virtual void | updateBounds ()=0
Updates the boundary of this SharedRuns (and also it's parent).
virtual void | validate ()=0
Validate this SharedRuns (and also all childs).
virtual void | destroy ()=0
Destroys the node (and all parents recursively).
virtual void | unbindParent ()
Unbinds the parent of the node, called at splitting.
virtual void | unbindAndKillParent ()
Unbinds the deletes the parent of the node, called at splitting.

Protected Member Functions

virtual void | gatherRuns ()=0
Collects RenderingRuns references from the child nodes, used when joining.
virtual void | fireRunChanges ()=0
Sends runChanged events for each RenderingRun type, used after join and split.
virtual SharedRuns * | createInstance ()=0
Creates a new SharedRuns instance. All derivatives should implement this.
virtual void | setRenderablesVisible (bool visible)=0
Set visibility of connected renderables, only used if this is a leaf.
virtual void | hideRenderables ()=0
Hides all the connected renderables, only used if this is a leaf.
virtual void | restoreRenderableVisibility ()=0
Restires visibility of all the connected renderables, only used if this is a leaf.

Protected Attributes

SharedRuns * parent
parent SharedRuns instance
SharedRuns * child1
child SharedRuns instance
SharedRuns * child2
child SharedRuns instance

Detailed Description

Base abstract class for a collection of shared resources (RenderingRuns).

Technique resources which can be shared between several techniques or objects are managed by SharedRuns. These SharedRuns store the shared resources. They also act like nodes of a binary tree, as separate SharedRuns can also be joined if for example the objects for which they store resources are close enough so even one shared resources is enough for the given objects.

Constructor & Destructor Documentation

SharedRuns::SharedRuns ( void )

&brief Constructor.

Member Function Documentation

virtual bool SharedRuns::hasOwnRun ( RenderingRunType runType ) [pure virtual]

&brief Returns true if this shared run object has a given run type.

It returns true if the shared run object node has a rendering run object with the given type. It checks only the current node of the tree, no children nodes are searched for existing rendering runs.

Parameters:
runType enum, type of the RenderingRun to search for
Returns:
search result

Implemented in OgreSharedRuns.

virtual RenderingRun* SharedRuns::getRun ( RenderingRunType runType ) [pure virtual]

&brief Retrieves a shared resource.

Parameters:
runType enum, type of the RenderingRun to be retrieved
Returns:
pointer to the RenderingRun of type "runType", null if this type does not exists

Implemented in OgreSharedRuns.

virtual void SharedRuns::addRun | ( | RenderingRunType | runType,
 |  | RenderingRun * | run |
 | ) |  |  | [pure virtual]

&brief Adds a RenderingRun instance to the shared resources.

Parameters:
runType | enum, type of the RenderingRun to add
run | pointer to the RenderingRun instance to add

Implemented in OgreSharedRuns.

virtual void SharedRuns::updateRun | ( | RenderingRunType | runType,
 |  | unsigned long | frameNum |
 | ) |  |  | [pure virtual]

&brief Updates a shared RenderingRun.

Parameters:
runType | enum, type of the RenderingRun to update
frameNum | current framenumber

Implemented in OgreSharedRuns.

SharedRuns * SharedRuns::joinRuns ( SharedRuns * otherRuns ) [virtual]

&brief Joines two SharedRuns.

The resulting SharedRuns become the parent of the two SharedRuns.

Parameters:
otherRuns pointer to the SharedRuns instance to join with
Returns:
the new parent SharedRuns instance

void SharedRuns::runChanged | ( | RenderingRunType | runType,
 |  | RenderingRun * | run |
 | ) |  |  | [virtual]

Called after one of he shared runs changes.

This message will be forwarded to each child.

Parameters:
runType | enum describing the type of the changed run
run | pointer to the changed RenderingRun

Reimplemented in OgreSharedRuns.

void SharedRuns::runUpdated | ( | RenderingRunType | runType,
 |  | RenderingRun * | run |
 | ) |  |  | [virtual]

Called after one of he shared runs updates.

This message will be forwarded to each child.

Parameters:
runType | enum describing the type of the updated run
run | pointer to the updated RenderingRun

Reimplemented in OgreSharedRuns.

virtual void SharedRuns::addTechniqueGroup ( TechniqueGroup * group ) [pure virtual]

Adds a child TechniqueGroup.

Parameters:
group pointer to the TechniqueGroup instance to add.

Implemented in OgreSharedRuns.

void SharedRuns::setVisible ( bool visible ) [virtual]

Shows or hides this SharedRuns (and also all childnodes).

Parameters:
visible visibility

void SharedRuns::hide ( ) [virtual]

Hides this SharedRuns (and also all childs).

The previous visibility is saved.

SharedRuns * SharedRuns::getRoot ( ) [virtual]

Retrieves the root node of this SharedRuns node.

Returns:
pointer to the root SharedRuns instance

SharedRuns * SharedRuns::getRoot ( RenderingRunType runType ) [virtual]

Retrieves the topmost parent node of this SharedRuns node, which have a specified RenderingRun type.

Parameters:
runType the RenderingRun type
Returns:
pointer to the parent SharedRuns instance

virtual void SharedRuns::validate ( ) [pure virtual]

Validate this SharedRuns (and also all childs).

Validation meens that all the SharedRuns that are joined will be examined if the sharing is still valid. If it finds out that two SharedRuns can't be joined anymore (eg.: they moved far from each other), their parent will be split and destroyed (all parent of this node also should be deleted recursively).

Implemented in OgreSharedRuns.

virtual SharedRuns* SharedRuns::createInstance ( ) [protected, pure virtual]

Creates a new SharedRuns instance. All derivatives should implement this.

Returns:
a new SharedRuns instance

Implemented in OgreSharedRuns.

virtual void SharedRuns::setRenderablesVisible ( bool visible ) [protected, pure virtual]

Set visibility of connected renderables, only used if this is a leaf.

Parameters:
visible visibility

Implemented in OgreSharedRuns.

Generated on Wed Mar 28 11:49:03 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: TechniqueGroup Class Reference

TechniqueGroup Class Reference

Base abstract class for a collection of techniques. More...

Inheritance diagram for TechniqueGroup:

OgreTechniqueGroup List of all members.

Public Member Functions

TechniqueGroup (void)
Constructor.
void | addSharedRun (SharedRuns *sharedRuns)
Adds an empty SharedRuns parent.
SharedRuns * getSharedRuns ()
Retrieves the shared runs.
virtual void | addRenderTechnique (RenderTechnique *technique)=0
Adds a rendertechnique to the group.
virtual void | update (unsigned long frameNum)=0
Updates all rendertechniques.
virtual void | runChanged (RenderingRunType runType, RenderingRun *run)=0
Called after one of the rendering runs changes.
virtual void | runUpdated (RenderingRunType runType, RenderingRun *run)=0
Called after one of the rendering runs updates.
virtual void | updateBounds ()
Updates the connected SharedRuns boundary.
virtual void | validateSharedRuns ()
Validates the connected SharedRuns instance.

Protected Attributes

SharedRuns * parentSharedRuns
Pointer to the connected SharedRuns instance each technique uses.

Detailed Description

Base abstract class for a collection of techniques.

This is a helper class, to collect RenderTechnique instances bound to a single renderable. It's main task is to recieve and forward messages to each RenderTechnique.

Member Function Documentation

void TechniqueGroup::addSharedRun ( SharedRuns * sharedRuns ) [inline]

Adds an empty SharedRuns parent.

Used after creating a new TechniqueGroup.

Parameters:
sharedRuns pointer to the SharedRun instance this RenderTechniques will use.

SharedRuns* TechniqueGroup::getSharedRuns ( ) [inline]

Retrieves the shared runs.

Returns:
pointer to the SharedRun instance this RenderTechniques uses.

virtual void TechniqueGroup::addRenderTechnique ( RenderTechnique * technique ) [pure virtual]

Adds a rendertechnique to the group.

Parameters:
technique the RenderTechnique instance to add.

Implemented in OgreTechniqueGroup.

virtual void TechniqueGroup::update ( unsigned long frameNum ) [pure virtual]

Updates all rendertechniques.

Parameters:
framenum current framenumber

Implemented in OgreTechniqueGroup.

virtual void TechniqueGroup::runChanged | ( | RenderingRunType | runType,
 |  | RenderingRun * | run |
 | ) |  |  | [pure virtual]

Called after one of the rendering runs changes.

This message will be forwarded to each RenderTechique.

Parameters:
runType | enum describing the type of the changed run
run | pointer to the changed RenderingRun

Implemented in OgreTechniqueGroup.

virtual void TechniqueGroup::runUpdated | ( | RenderingRunType | runType,
 |  | RenderingRun * | run |
 | ) |  |  | [pure virtual]

Called after one of the rendering runs updates.

This message will be forwarded to each RenderTechique.

Parameters:
runType | enum describing the type of the updated run
run | pointer to the updated RenderingRun

Implemented in OgreTechniqueGroup.

Generated on Wed Mar 28 11:49:03 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: UpdateListener Class Reference

UpdateListener Class Reference

Event handler class. More...

Inheritance diagram for UpdateListener:

OgreFireRenderTechnique OgreSBBRenderTechnique List of all members.

Public Member Functions

virtual void | preAllUpdates ()
Called before RenderTechnique updates.
virtual void | postAllUpdates ()
Called after RenderTechnique updates.

Detailed Description

Event handler class.

The derived calsses of this class can register task that should be done before and/or after updating all RenderTechniques. UpdateListeners can be registered to the OgreIlluminationMager.

See also:
addUpdateListener

Generated on Wed Mar 28 11:49:03 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: Hierarchical Index

GTP Illumination Module Class Hierarchy

This inheritance list is sorted roughly, but not completely, alphabetically:
  • ElementaryRenderable
    • OgreRenderable
  • IlluminationManager
  • OgreIlluminationManager
  • PathMapClusters
  • PathMapEntryPoint
  • RenderingRun
    • CausticCubeMapRenderingRun
      • OgreCausticCubeMapRenderingRun
    • ChildPsystemRenderingRun
      • OgreChildPSystemRenderingRun
    • CubeMapRenderingRun
      • OgreCubeMapRenderingRun
    • DepthShadowMapRenderingRun
      • OgreDepthShadowMapRenderingRun
    • LightVolumeRenderingRun
      • OgreLightVolumeRenderingRun
    • OgreRenderingRun
      • OgreCausticCubeMapRenderingRun
      • OgreChildPSystemRenderingRun
      • OgreCubeMapRenderingRun
      • OgreDepthShadowMapRenderingRun
      • OgreFocusingMapRenderingRun
      • OgreLightVolumeRenderingRun
      • OgrePhaseTextureRenderingRun
      • OgrePhotonMapRenderingRun
      • OgrePMEntryPointMapRenderingRun
      • OgrePMWeightComputeRenderingRun
      • OgreReducedCubeMapRenderingRun
      • OgreSceneCameraDepthRenderingRun
    • OgreRenderingRun
    • PhaseTextureRenderingRun
      • OgrePhaseTextureRenderingRun
    • PhotonMapRenderingRun
      • OgrePhotonMapRenderingRun
    • ReducedCubeMapRenderingRun
      • OgreReducedCubeMapRenderingRun
    • SceneCameraDepthRenderingRun
      • OgreSceneCameraDepthRenderingRun
  • RenderTechnique
    • CausticCasterRenderTechnique
      • OgreCausticCasterRenderTechnique
    • CausticReceiverRenderTechnique
      • OgreCausticReceiverRenderTechnique
    • CubeMapRenderTechnique
      • ColorCubeMapRenderTechnique
        • OgreColorCubeMapRenderTechnique
      • ConvolvedCubeMapRenderTechnique
        • OgreConvolvedCubeMapRenderTechnique
      • DistanceCubeMapRenderTechnique
        • OgreDistanceCubeMapRenderTechnique
      • OgreCubeMapRenderTechnique
        • OgreColorCubeMapRenderTechnique
        • OgreConvolvedCubeMapRenderTechnique
        • OgreDistanceCubeMapRenderTechnique
    • DepthShadowReceiverRenderTechnique
      • OgreDepthShadowReceiverRenderTechnique
    • HierarchicalParticleSystemTechnique
      • OgreHierarchicalParticleSystemTechnique
    • IllumVolumeRenderTechnique
      • OgreIllumVolumeRenderTechnique
    • OgreRenderTechnique
      • OgreCausticCasterRenderTechnique
      • OgreCausticReceiverRenderTechnique
      • OgreCubeMapRenderTechnique
      • OgreDepthShadowReceiverRenderTechnique
      • OgreFireRenderTechnique
      • OgreHierarchicalParticleSystemTechnique
      • OgreIllumVolumeRenderTechnique
      • OgrePathMapRenderTechnique
      • OgreSBBRenderTechnique
    • SBBRenderTechnique
      • OgreSBBRenderTechnique
  • RenderTechniqueFactory
    • OgreCausticCasterRenderTechniqueFactory
    • OgreCausticReceiverRenderTechniqueFactory
    • OgreCubeMapRenderTechniqueFactory
      • OgreColorCubeMapRenderTechniqueFactory
      • OgreConvoledCubeMapRenderTechniqueFactory
      • OgreDistanceCubeMapRenderTechniqueFactory
    • OgreDepthShadowReceiverRenderTechniqueFactory
    • OgreFireRenderTechniqueFactory
    • OgreHierarchicalParticleSystemTechniqueFactory
    • OgreIllumVolumeRenderTechniqueFactory
    • OgrePathMapRenderTechniqueFactory
    • OgreSBBRenderTechniqueFactory
  • SharedRuns
    • OgreSharedRuns
  • TechniqueGroup
    • OgreTechniqueGroup
  • UpdateListener
    • OgreFireRenderTechnique
    • OgreSBBRenderTechnique
Generated on Wed Mar 28 11:48:46 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

Here is a list of all documented class members with links to the class documentation for each member:

- a -

  • addPathMapClusterLength() : OgreIlluminationManager
  • addPathMapClusters() : OgreIlluminationManager
  • addPathMapEntryPoint() : OgreIlluminationManager
  • addRenderablesToQueue() : OgreSharedRuns
  • addRenderTechnique() : TechniqueGroup
  • addRenderTechniqueFactory() : OgreIlluminationManager
  • addRun() : SharedRuns
  • addSharedRun() : TechniqueGroup
  • addSharedRuns() : OgreIlluminationManager , IlluminationManager
  • addTechniqueGroup() : SharedRuns
  • addUpdateListener() : OgreIlluminationManager
  • allWeightsTexture : OgrePMWeightComputeRenderingRun
  • angleTolerance : ReducedCubeMapRenderingRun , CubeMapRenderTechnique , CubeMapRenderingRun , CubeMapRenderTechnique , ReducedCubeMapRenderingRun , CubeMapRenderTechnique , CubeMapRenderingRun
  • areaLightRadius : OgreIlluminationManager
  • asOgreRenderingRun() : RenderingRun , OgreRenderingRun , RenderingRun , OgreRenderingRun , RenderingRun , OgreRenderingRun , RenderingRun , OgreRenderingRun , RenderingRun , OgreRenderingRun , RenderingRun , OgreRenderingRun , RenderingRun , OgreRenderingRun , RenderingRun , OgreRenderingRun
  • asOgreRenderTechnique() : RenderTechnique
  • attachToTexUnit : OgreCubeMapRenderTechnique
  • attenuation : OgreCausticCasterRenderTechnique , OgreCausticCubeMapRenderingRun
  • AttribParserList : RenderTechniqueFactory
  • attributeParsers : RenderTechniqueFactory
Generated on Wed Mar 28 11:48:46 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: Namespace Index

  • Namespace List
  • Namespace Members

GTP Illumination Module Namespace List

Here is a list of all documented namespaces with brief descriptions:
CausticCasterParsers | Technique Parsers
ConvolvedCubemapParsers | Technique Parsers
CubemapParsers | Technique Parsers
DepthShadowReceiverParsers | Technique parsers
HPSParsers | Technique Parsers
IllumVolumeParsers | Technique Parsers
Generated on Wed Mar 28 11:49:03 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: CausticCasterParsers Namespace Reference

  • Namespace List
  • Namespace Members

CausticCasterParsers Namespace Reference

Technique Parsers. More...

Detailed Description

Technique Parsers.
Generated on Wed Mar 28 11:49:03 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: ConvolvedCubemapParsers Namespace Reference

  • Namespace List
  • Namespace Members

ConvolvedCubemapParsers Namespace Reference

Technique Parsers. More...

Detailed Description

Technique Parsers.
Generated on Wed Mar 28 11:49:03 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: CubemapParsers Namespace Reference

  • Namespace List
  • Namespace Members

CubemapParsers Namespace Reference

Technique Parsers. More...

Detailed Description

Technique Parsers.
Generated on Wed Mar 28 11:49:03 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: DepthShadowReceiverParsers Namespace Reference

  • Namespace List
  • Namespace Members

DepthShadowReceiverParsers Namespace Reference

Technique parsers. More...

Detailed Description

Technique parsers.
Generated on Wed Mar 28 11:49:03 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: HPSParsers Namespace Reference

  • Namespace List
  • Namespace Members

HPSParsers Namespace Reference

Technique Parsers. More...

Functions

void parseUseDistCalc (String &params, RenderTechniqueFactory *factory)

Detailed Description

Technique Parsers.

Function Documentation

void HPSParsers::parseUseDistCalc | ( | String & | params,
 |  | RenderTechniqueFactory * | factory
 | ) |  |

Generated on Wed Mar 28 11:49:03 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: IllumVolumeParsers Namespace Reference

  • Namespace List
  • Namespace Members

IllumVolumeParsers Namespace Reference

Technique Parsers. More...

Functions

void parseUseDistCalc (String &params, RenderTechniqueFactory *factory)

Detailed Description

Technique Parsers.

Function Documentation

void IllumVolumeParsers::parseUseDistCalc | ( | String & | params,
 |  | RenderTechniqueFactory * | factory
 | ) |  |

Generated on Wed Mar 28 11:49:03 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: Class Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
Here is a list of all documented namespace members with links to the namespaces they belong to:

  • parseUseDistCalc() : HPSParsers , IllumVolumeParsers
Generated on Wed Mar 28 11:49:03 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: Member List

CausticCasterRenderTechnique Member List

This is the complete list of members for CausticCasterRenderTechnique, including all inherited members.

asOgreRenderTechnique() | RenderTechnique | [inline, virtual]
CausticCasterRenderTechnique(unsigned long startFrame, unsigned long photonMapUpdateInterval, unsigned int photonMapResolution, unsigned int causticCubeMapResolution, bool updateAllFace, bool useDistance, ElementaryRenderable *parentRenderable, TechniqueGroup *parentTechniqueGroup) | CausticCasterRenderTechnique |
causticCubeMapResolution | CausticCasterRenderTechnique | [protected]
causticCubeMapRunChanged(RenderingRun *run)=0 | CausticCasterRenderTechnique | [protected, pure virtual]
createCausticCubeMapRun()=0 | CausticCasterRenderTechnique | [protected, pure virtual]
createDistanceCubeMapRun()=0 | CausticCasterRenderTechnique | [protected, pure virtual]
createPhotonMapRun()=0 | CausticCasterRenderTechnique | [protected, pure virtual]
distanceCubeMapRunChanged(RenderingRun *run)=0 | CausticCasterRenderTechnique | [protected, pure virtual]
distanceCubeMapRunUpdated(RenderingRun *run)=0 | CausticCasterRenderTechnique | [protected, pure virtual]
getParentRenderable() | RenderTechnique | [inline]
parentRenderable | RenderTechnique | [protected]
parentTechniqueGroup | RenderTechnique | [protected]
photonMapResolution | CausticCasterRenderTechnique | [protected]
photonMapRunChanged(RenderingRun *run)=0 | CausticCasterRenderTechnique | [protected, pure virtual]
photonMapUpdateInterval | CausticCasterRenderTechnique | [protected]
RenderTechnique(ElementaryRenderable *parentRenderable, TechniqueGroup *parentTechniqueGroup) | RenderTechnique |
runChanged(RenderingRunType runType, RenderingRun *run) | CausticCasterRenderTechnique | [virtual]
runUpdated(RenderingRunType runType, RenderingRun *run) | CausticCasterRenderTechnique | [virtual]
sharedRuns | RenderTechnique | [protected]
startFrame | CausticCasterRenderTechnique | [protected]
update(unsigned long frameNum) | RenderTechnique | [inline, virtual]
updateAllFace | CausticCasterRenderTechnique | [protected]
useDistance | CausticCasterRenderTechnique | [protected]

Generated on Wed Mar 28 11:48:46 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: Member List

CausticCubeMapRenderingRun Member List

This is the complete list of members for CausticCubeMapRenderingRun, including all inherited members.

asOgreRenderingRun() | RenderingRun | [inline, virtual]
canJoin(RenderingRun *run) | RenderingRun | [inline, virtual]
CausticCubeMapRenderingRun(unsigned long startFrame, unsigned long updateInterval, unsigned int resolution, bool updateAllFace) | CausticCubeMapRenderingRun |
createCausticCubeMap()=0 | CausticCubeMapRenderingRun | [inline, protected, pure virtual]
currentFace | CausticCubeMapRenderingRun | [protected]
faceNeedsUpdate(int facenum)=0 | CausticCubeMapRenderingRun | [protected, pure virtual]
lastupdated | RenderingRun | [protected]
needUpdate(unsigned long frameNum) | RenderingRun | [inline, protected, virtual]
photonMapChanged(RenderingRun *run)=0 | CausticCubeMapRenderingRun | [pure virtual]
RenderingRun(unsigned long startFrame, unsigned long updateInterval) | RenderingRun |
resolution | CausticCubeMapRenderingRun | [protected]
startFrame | RenderingRun | [protected]
update(unsigned long frameNum) | RenderingRun | [inline]
updateAllFace | CausticCubeMapRenderingRun | [protected]
updateCubeFace(int facenum)=0 | CausticCubeMapRenderingRun | [inline, protected, pure virtual]
updateFrame(unsigned long frameNum) | CausticCubeMapRenderingRun | [protected, virtual]
updateInterval | RenderingRun | [protected]

Generated on Wed Mar 28 11:48:46 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: Member List

CausticReceiverRenderTechnique Member List

This is the complete list of members for CausticReceiverRenderTechnique, including all inherited members.

asOgreRenderTechnique() | RenderTechnique | [inline, virtual]
CausticReceiverRenderTechnique(ElementaryRenderable *parentRenderable, TechniqueGroup *parentTechniqueGroup) | CausticReceiverRenderTechnique |
getParentRenderable() | RenderTechnique | [inline]
parentRenderable | RenderTechnique | [protected]
parentTechniqueGroup | RenderTechnique | [protected]
RenderTechnique(ElementaryRenderable *parentRenderable, TechniqueGroup *parentTechniqueGroup) | RenderTechnique |
runChanged(RenderingRunType runType, RenderingRun *run) | RenderTechnique | [inline, virtual]
runUpdated(RenderingRunType runType, RenderingRun *run) | RenderTechnique | [inline, virtual]
sharedRuns | RenderTechnique | [protected]
update(unsigned long frameNum) | RenderTechnique | [inline, virtual]

Generated on Wed Mar 28 11:48:47 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: Member List

ChildPsystemRenderingRun Member List

This is the complete list of members for ChildPsystemRenderingRun, including all inherited members.

asOgreRenderingRun() | RenderingRun | [inline, virtual]
canJoin(RenderingRun *run) | RenderingRun | [inline, virtual]
ChildPsystemRenderingRun(unsigned int resolution, bool perspectiveRendering, unsigned long startFrame, unsigned long updateInterval) | ChildPsystemRenderingRun | [inline]
createImpostorTexture()=0 | ChildPsystemRenderingRun | [inline, protected, pure virtual]
lastupdated | RenderingRun | [protected]
needUpdate(unsigned long frameNum) | RenderingRun | [inline, protected, virtual]
perspectiveRendering | ChildPsystemRenderingRun | [protected]
RenderingRun(unsigned long startFrame, unsigned long updateInterval) | RenderingRun |
resolution | ChildPsystemRenderingRun | [protected]
startFrame | RenderingRun | [protected]
update(unsigned long frameNum) | RenderingRun | [inline]
updateFrame(unsigned long frameNum)=0 | ChildPsystemRenderingRun | [protected, pure virtual]
updateInterval | RenderingRun | [protected]

Generated on Wed Mar 28 11:48:47 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: Member List

ColorCubeMapRenderTechnique Member List

This is the complete list of members for ColorCubeMapRenderTechnique, including all inherited members.

angleTolerance | CubeMapRenderTechnique | [protected]
asOgreRenderTechnique() | RenderTechnique | [inline, virtual]
ColorCubeMapRenderTechnique(unsigned long startFrame, unsigned long cubeMapUpdateInterval, unsigned int cubeMapResolution, bool useDistCalc, bool useFaceAngleCalc, float distTolerance, float angleTolerance, bool updateAllFace, bool renderSelf, bool renderEnvironment, int layer, ElementaryRenderable *parentRenderable, TechniqueGroup *parentTechniqueGroup) | ColorCubeMapRenderTechnique |
colorCubeMapRunChanged(RenderingRun *run)=0 | ColorCubeMapRenderTechnique | [protected, pure virtual]
colorCubeMapRunUpdated(RenderingRun *run)=0 | ColorCubeMapRenderTechnique | [protected, pure virtual]
createCubeMapRun()=0 | CubeMapRenderTechnique | [protected, pure virtual]
cubemapLayer | CubeMapRenderTechnique | [protected]
CubeMapRenderTechnique(unsigned long startFrame, unsigned long cubeMapUpdateInterval, unsigned int cubeMapResolution, bool useDistCalc, bool useFaceAngleCalc, float distTolerance, float angleTolerance, bool updateAllFace, bool renderSelf, bool renderEnvironment, int layer, ElementaryRenderable *parentRenderable, TechniqueGroup *parentTechniqueGroup) | CubeMapRenderTechnique |
cubeMapResolution | CubeMapRenderTechnique | [protected]
cubeMapRunChanged(RenderingRun *run)=0 | CubeMapRenderTechnique | [protected, pure virtual]
cubeMapRunUpdated(RenderingRun *run)=0 | CubeMapRenderTechnique | [protected, pure virtual]
cubeMapUpdateInterval | CubeMapRenderTechnique | [protected]
distTolerance | CubeMapRenderTechnique | [protected]
getParentRenderable() | RenderTechnique | [inline]
layer | CubeMapRenderTechnique | [protected]
parentRenderable | RenderTechnique | [protected]
parentTechniqueGroup | RenderTechnique | [protected]
renderEnvironment | CubeMapRenderTechnique | [protected]
renderSelf | CubeMapRenderTechnique | [protected]
RenderTechnique(ElementaryRenderable *parentRenderable, TechniqueGroup *parentTechniqueGroup) | RenderTechnique |
runChanged(RenderingRunType runType, RenderingRun *run) | ColorCubeMapRenderTechnique | [virtual]
runUpdated(RenderingRunType runType, RenderingRun *run) | ColorCubeMapRenderTechnique | [virtual]
sharedRuns | RenderTechnique | [protected]
startFrame | CubeMapRenderTechnique | [protected]
update(unsigned long frameNum) | ColorCubeMapRenderTechnique | [virtual]
updateAllFace | CubeMapRenderTechnique | [protected]
useDistCalc | CubeMapRenderTechnique | [protected]
useFaceAngleCalc | CubeMapRenderTechnique | [protected]

Generated on Wed Mar 28 11:48:47 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: Member List

ConvolvedCubeMapRenderTechnique Member List

This is the complete list of members for ConvolvedCubeMapRenderTechnique, including all inherited members.

angleTolerance | CubeMapRenderTechnique | [protected]
asOgreRenderTechnique() | RenderTechnique | [inline, virtual]
colorCubeMapRunChanged(RenderingRun *run)=0 | ConvolvedCubeMapRenderTechnique | [protected, pure virtual]
ConvolvedCubeMapRenderTechnique(unsigned long startFrame, unsigned long cubeMapUpdateInterval, unsigned int cubeMapResolution, unsigned int reducedCubeMapResolution, bool useDistCalc, bool useFaceAngleCalc, float distTolerance, float angleTolerance, bool updateAllFace, bool renderSelf, bool renderEnvironment, ElementaryRenderable *parentRenderable, TechniqueGroup *parentTechniqueGroup) | ConvolvedCubeMapRenderTechnique |
createCubeMapRun()=0 | CubeMapRenderTechnique | [protected, pure virtual]
createReducedCubeMapRun()=0 | ConvolvedCubeMapRenderTechnique | [protected, pure virtual]
cubemapLayer | CubeMapRenderTechnique | [protected]
CubeMapRenderTechnique(unsigned long startFrame, unsigned long cubeMapUpdateInterval, unsigned int cubeMapResolution, bool useDistCalc, bool useFaceAngleCalc, float distTolerance, float angleTolerance, bool updateAllFace, bool renderSelf, bool renderEnvironment, int layer, ElementaryRenderable *parentRenderable, TechniqueGroup *parentTechniqueGroup) | CubeMapRenderTechnique |
cubeMapResolution | CubeMapRenderTechnique | [protected]
cubeMapRunChanged(RenderingRun *run)=0 | CubeMapRenderTechnique | [protected, pure virtual]
cubeMapRunUpdated(RenderingRun *run)=0 | CubeMapRenderTechnique | [protected, pure virtual]
cubeMapUpdateInterval | CubeMapRenderTechnique | [protected]
distTolerance | CubeMapRenderTechnique | [protected]
getParentRenderable() | RenderTechnique | [inline]
layer | CubeMapRenderTechnique | [protected]
parentRenderable | RenderTechnique | [protected]
parentTechniqueGroup | RenderTechnique | [protected]
reducedCubeMapResolution | ConvolvedCubeMapRenderTechnique | [protected]
reducedCubeMapRunChanged(RenderingRun *run)=0 | ConvolvedCubeMapRenderTechnique | [protected, pure virtual]
renderEnvironment | CubeMapRenderTechnique | [protected]
renderSelf | CubeMapRenderTechnique | [protected]
RenderTechnique(ElementaryRenderable *parentRenderable, TechniqueGroup *parentTechniqueGroup) | RenderTechnique |
runChanged(RenderingRunType runType, RenderingRun *run) | ConvolvedCubeMapRenderTechnique | [virtual]
runUpdated(RenderingRunType runType, RenderingRun *run) | CubeMapRenderTechnique | [virtual]
sharedRuns | RenderTechnique | [protected]
startFrame | CubeMapRenderTechnique | [protected]
update(unsigned long frameNum) | ConvolvedCubeMapRenderTechnique | [virtual]
updateAllFace | CubeMapRenderTechnique | [protected]
useDistCalc | CubeMapRenderTechnique | [protected]
useFaceAngleCalc | CubeMapRenderTechnique | [protected]

Generated on Wed Mar 28 11:48:48 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: Member List

CubeMapRenderTechnique Member List

This is the complete list of members for CubeMapRenderTechnique, including all inherited members.

angleTolerance | CubeMapRenderTechnique | [protected]
asOgreRenderTechnique() | RenderTechnique | [inline, virtual]
createCubeMapRun()=0 | CubeMapRenderTechnique | [protected, pure virtual]
cubemapLayer | CubeMapRenderTechnique | [protected]
CubeMapRenderTechnique(unsigned long startFrame, unsigned long cubeMapUpdateInterval, unsigned int cubeMapResolution, bool useDistCalc, bool useFaceAngleCalc, float distTolerance, float angleTolerance, bool updateAllFace, bool renderSelf, bool renderEnvironment, int layer, ElementaryRenderable *parentRenderable, TechniqueGroup *parentTechniqueGroup) | CubeMapRenderTechnique |
cubeMapResolution | CubeMapRenderTechnique | [protected]
cubeMapRunChanged(RenderingRun *run)=0 | CubeMapRenderTechnique | [protected, pure virtual]
cubeMapRunUpdated(RenderingRun *run)=0 | CubeMapRenderTechnique | [protected, pure virtual]
cubeMapUpdateInterval | CubeMapRenderTechnique | [protected]
distTolerance | CubeMapRenderTechnique | [protected]
getParentRenderable() | RenderTechnique | [inline]
layer | CubeMapRenderTechnique | [protected]
parentRenderable | RenderTechnique | [protected]
parentTechniqueGroup | RenderTechnique | [protected]
renderEnvironment | CubeMapRenderTechnique | [protected]
renderSelf | CubeMapRenderTechnique | [protected]
RenderTechnique(ElementaryRenderable *parentRenderable, TechniqueGroup *parentTechniqueGroup) | RenderTechnique |
runChanged(RenderingRunType runType, RenderingRun *run) | CubeMapRenderTechnique | [virtual]
runUpdated(RenderingRunType runType, RenderingRun *run) | CubeMapRenderTechnique | [virtual]
sharedRuns | RenderTechnique | [protected]
startFrame | CubeMapRenderTechnique | [protected]
update(unsigned long frameNum) | RenderTechnique | [inline, virtual]
updateAllFace | CubeMapRenderTechnique | [protected]
useDistCalc | CubeMapRenderTechnique | [protected]
useFaceAngleCalc | CubeMapRenderTechnique | [protected]

Generated on Wed Mar 28 11:48:48 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: Member List

CubeMapRenderingRun Member List

This is the complete list of members for CubeMapRenderingRun, including all inherited members.

angleTolerance | CubeMapRenderingRun | [protected]
asOgreRenderingRun() | RenderingRun | [inline, virtual]
canJoin(RenderingRun *run) | RenderingRun | [inline, virtual]
createCubeMap()=0 | CubeMapRenderingRun | [inline, protected, pure virtual]
CubeMapRenderingRun(unsigned long startFrame, unsigned long updateInterval, unsigned int resolution, bool useDistCalc, bool useFaceAngleCalc, float distTolerance, float angleTolerance, bool updateAllFace, bool renderSelf, bool renderEnvironment) | CubeMapRenderingRun |
currentFace | CubeMapRenderingRun | [protected]
distTolerance | CubeMapRenderingRun | [protected]
faceNeedsUpdate(int facenum)=0 | CubeMapRenderingRun | [protected, pure virtual]
lastupdated | RenderingRun | [protected]
needUpdate(unsigned long frameNum) | RenderingRun | [inline, protected, virtual]
renderEnvironment | CubeMapRenderingRun | [protected]
RenderingRun(unsigned long startFrame, unsigned long updateInterval) | RenderingRun |
renderSelf | CubeMapRenderingRun | [protected]
resolution | CubeMapRenderingRun | [protected]
startFrame | RenderingRun | [protected]
update(unsigned long frameNum) | RenderingRun | [inline]
updateAllFace | CubeMapRenderingRun | [protected]
updateCubeFace(int facenum)=0 | CubeMapRenderingRun | [inline, protected, pure virtual]
updateFrame(unsigned long frameNum) | CubeMapRenderingRun | [protected, virtual]
updateInterval | RenderingRun | [protected]
useDistCalc | CubeMapRenderingRun | [protected]
useFaceAngleCalc | CubeMapRenderingRun | [protected]

Generated on Wed Mar 28 11:48:48 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: Member List

DepthShadowMapRenderingRun Member List

This is the complete list of members for DepthShadowMapRenderingRun, including all inherited members.

asOgreRenderingRun() | RenderingRun | [inline, virtual]
canJoin(RenderingRun *run) | RenderingRun | [inline, virtual]
createDepthMap()=0 | DepthShadowMapRenderingRun | [inline, protected, pure virtual]
DepthShadowMapRenderingRun(unsigned int resolutionX, unsigned int resolutionY) | DepthShadowMapRenderingRun | [inline]
lastupdated | RenderingRun | [protected]
needUpdate(unsigned long frameNum) | RenderingRun | [inline, protected, virtual]
RenderingRun(unsigned long startFrame, unsigned long updateInterval) | RenderingRun |
resolutionX | DepthShadowMapRenderingRun | [protected]
resolutionY | DepthShadowMapRenderingRun | [protected]
startFrame | RenderingRun | [protected]
update(unsigned long frameNum) | RenderingRun | [inline]
updateDepthCubeFace(int facenum)=0 | DepthShadowMapRenderingRun | [inline, protected, pure virtual]
updateDepthMap()=0 | DepthShadowMapRenderingRun | [inline, protected, pure virtual]
updateFrame(unsigned long frameNum)=0 | DepthShadowMapRenderingRun | [protected, pure virtual]
updateInterval | RenderingRun | [protected]

Generated on Wed Mar 28 11:48:48 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: Member List

DepthShadowReceiverRenderTechnique Member List

This is the complete list of members for DepthShadowReceiverRenderTechnique, including all inherited members.

asOgreRenderTechnique() | RenderTechnique | [inline, virtual]
DepthShadowReceiverRenderTechnique(ElementaryRenderable *parentRenderable, TechniqueGroup *parentTechniqueGroup) | DepthShadowReceiverRenderTechnique |
getParentRenderable() | RenderTechnique | [inline]
parentRenderable | RenderTechnique | [protected]
parentTechniqueGroup | RenderTechnique | [protected]
RenderTechnique(ElementaryRenderable *parentRenderable, TechniqueGroup *parentTechniqueGroup) | RenderTechnique |
runChanged(RenderingRunType runType, RenderingRun *run) | RenderTechnique | [inline, virtual]
runUpdated(RenderingRunType runType, RenderingRun *run) | RenderTechnique | [inline, virtual]
sharedRuns | RenderTechnique | [protected]
update(unsigned long frameNum) | RenderTechnique | [inline, virtual]

Generated on Wed Mar 28 11:48:48 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: Member List

DistanceCubeMapRenderTechnique Member List

This is the complete list of members for DistanceCubeMapRenderTechnique, including all inherited members.

angleTolerance | CubeMapRenderTechnique | [protected]
asOgreRenderTechnique() | RenderTechnique | [inline, virtual]
createCubeMapRun()=0 | CubeMapRenderTechnique | [protected, pure virtual]
cubemapLayer | CubeMapRenderTechnique | [protected]
CubeMapRenderTechnique(unsigned long startFrame, unsigned long cubeMapUpdateInterval, unsigned int cubeMapResolution, bool useDistCalc, bool useFaceAngleCalc, float distTolerance, float angleTolerance, bool updateAllFace, bool renderSelf, bool renderEnvironment, int layer, ElementaryRenderable *parentRenderable, TechniqueGroup *parentTechniqueGroup) | CubeMapRenderTechnique |
cubeMapResolution | CubeMapRenderTechnique | [protected]
cubeMapRunChanged(RenderingRun *run)=0 | CubeMapRenderTechnique | [protected, pure virtual]
cubeMapRunUpdated(RenderingRun *run)=0 | CubeMapRenderTechnique | [protected, pure virtual]
cubeMapUpdateInterval | CubeMapRenderTechnique | [protected]
DistanceCubeMapRenderTechnique(unsigned long startFrame, unsigned long cubeMapUpdateInterval, unsigned int cubeMapResolution, bool useDistCalc, bool useFaceAngleCalc, float distTolerance, float angleTolerance, bool updateAllFace, bool renderSelf, bool renderEnvironment, int layer, ElementaryRenderable *parentRenderable, TechniqueGroup *parentTechniqueGroup) | DistanceCubeMapRenderTechnique |
distanceCubeMapRunChanged(RenderingRun *run)=0 | DistanceCubeMapRenderTechnique | [protected, pure virtual]
distanceCubeMapRunUpdated(RenderingRun *run)=0 | DistanceCubeMapRenderTechnique | [protected, pure virtual]
distTolerance | CubeMapRenderTechnique | [protected]
getParentRenderable() | RenderTechnique | [inline]
layer | CubeMapRenderTechnique | [protected]
parentRenderable | RenderTechnique | [protected]
parentTechniqueGroup | RenderTechnique | [protected]
renderEnvironment | CubeMapRenderTechnique | [protected]
renderSelf | CubeMapRenderTechnique | [protected]
RenderTechnique(ElementaryRenderable *parentRenderable, TechniqueGroup *parentTechniqueGroup) | RenderTechnique |
runChanged(RenderingRunType runType, RenderingRun *run) | DistanceCubeMapRenderTechnique | [virtual]
runUpdated(RenderingRunType runType, RenderingRun *run) | DistanceCubeMapRenderTechnique | [virtual]
sharedRuns | RenderTechnique | [protected]
startFrame | CubeMapRenderTechnique | [protected]
update(unsigned long frameNum) | DistanceCubeMapRenderTechnique | [virtual]
updateAllFace | CubeMapRenderTechnique | [protected]
useDistCalc | CubeMapRenderTechnique | [protected]
useFaceAngleCalc | CubeMapRenderTechnique | [protected]

Generated on Wed Mar 28 11:48:49 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: Member List

ElementaryRenderable Member List

This is the complete list of members for ElementaryRenderable, including all inherited members.

isVisible()=0 | ElementaryRenderable | [pure virtual]
setRenderGroup(unsigned char groupID)=0 | ElementaryRenderable | [pure virtual]
setVisible(bool visible)=0 | ElementaryRenderable | [pure virtual]
updateBounds()=0 | ElementaryRenderable | [pure virtual]

Generated on Wed Mar 28 11:48:49 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: Member List

HierarchicalParticleSystemTechnique Member List

This is the complete list of members for HierarchicalParticleSystemTechnique, including all inherited members.

asOgreRenderTechnique() | RenderTechnique | [inline, virtual]
createChildPSysRenderingRun()=0 | HierarchicalParticleSystemTechnique | [protected, pure virtual]
getParentRenderable() | RenderTechnique | [inline]
HierarchicalParticleSystemTechnique(unsigned long startFrame, unsigned long impostorUpdateInterval, unsigned int impostorResolution, bool useDistCalc, bool perspectiveRendering, ElementaryRenderable *parentRenderable, TechniqueGroup *parentTechniqueGroup) | HierarchicalParticleSystemTechnique |
impostorChanged(RenderingRun *run)=0 | HierarchicalParticleSystemTechnique | [protected, pure virtual]
impostorResolution | HierarchicalParticleSystemTechnique | [protected]
impostorUpdated(RenderingRun *run)=0 | HierarchicalParticleSystemTechnique | [protected, pure virtual]
impostorUpdateInterval | HierarchicalParticleSystemTechnique | [protected]
parentRenderable | RenderTechnique | [protected]
parentTechniqueGroup | RenderTechnique | [protected]
perspectiveRendering | HierarchicalParticleSystemTechnique | [protected]
RenderTechnique(ElementaryRenderable *parentRenderable, TechniqueGroup *parentTechniqueGroup) | RenderTechnique |
runChanged(RenderingRunType runType, RenderingRun *run) | HierarchicalParticleSystemTechnique | [virtual]
runUpdated(RenderingRunType runType, RenderingRun *run) | HierarchicalParticleSystemTechnique | [virtual]
sharedRuns | RenderTechnique | [protected]
startFrame | HierarchicalParticleSystemTechnique | [protected]
update(unsigned long frameNum) | HierarchicalParticleSystemTechnique | [virtual]
useDistCalc | HierarchicalParticleSystemTechnique | [protected]

Generated on Wed Mar 28 11:48:49 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: Member List

IllumVolumeRenderTechnique Member List

This is the complete list of members for IllumVolumeRenderTechnique, including all inherited members.

asOgreRenderTechnique() | RenderTechnique | [inline, virtual]
createLightVolumeRenderingRun()=0 | IllumVolumeRenderTechnique | [protected, pure virtual]
getParentRenderable() | RenderTechnique | [inline]
hierarchicalImpostorUpdated(RenderingRun *run)=0 | IllumVolumeRenderTechnique | [protected, pure virtual]
illumTextureResolution | IllumVolumeRenderTechnique | [protected]
IllumVolumeRenderTechnique(unsigned long startFrame, unsigned long illumVolumeUpdateInterval, unsigned int illumTextureResolution, unsigned int textureDepth, bool useDistCalc, bool useHierarchicalImpostor, ElementaryRenderable *parentRenderable, TechniqueGroup *parentTechniqueGroup) | IllumVolumeRenderTechnique |
illumVolumeUpdateInterval | IllumVolumeRenderTechnique | [protected]
lightVolumeChanged(RenderingRun *run)=0 | IllumVolumeRenderTechnique | [protected, pure virtual]
lightVolumeUpdated(RenderingRun *run)=0 | IllumVolumeRenderTechnique | [protected, pure virtual]
parentRenderable | RenderTechnique | [protected]
parentTechniqueGroup | RenderTechnique | [protected]
RenderTechnique(ElementaryRenderable *parentRenderable, TechniqueGroup *parentTechniqueGroup) | RenderTechnique |
runChanged(RenderingRunType runType, RenderingRun *run) | IllumVolumeRenderTechnique | [virtual]
runUpdated(RenderingRunType runType, RenderingRun *run) | IllumVolumeRenderTechnique | [virtual]
sharedRuns | RenderTechnique | [protected]
startFrame | IllumVolumeRenderTechnique | [protected]
textureDepth | IllumVolumeRenderTechnique | [protected]
update(unsigned long frameNum) | IllumVolumeRenderTechnique | [virtual]
useDistCalc | IllumVolumeRenderTechnique | [protected]
useHierarchicalImpostor | IllumVolumeRenderTechnique | [protected]

Generated on Wed Mar 28 11:48:49 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: Member List

IlluminationManager Member List

This is the complete list of members for IlluminationManager, including all inherited members.

addSharedRuns(SharedRuns *runs) | IlluminationManager | [inline, virtual]
joinSharedRuns() | IlluminationManager | [inline, virtual]
sharedRunJoin(SharedRuns *old1, SharedRuns *old2, SharedRuns *newsr) | IlluminationManager | [inline, virtual]
sharedRunSplit(SharedRuns *old, SharedRuns *new1, SharedRuns *new2) | IlluminationManager | [inline, virtual]
update(unsigned long frameNumber)=0 | IlluminationManager | [pure virtual]

Generated on Wed Mar 28 11:48:49 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: Member List

LightVolumeRenderingRun Member List

This is the complete list of members for LightVolumeRenderingRun, including all inherited members.

asOgreRenderingRun() | RenderingRun | [inline, virtual]
canJoin(RenderingRun *run) | RenderingRun | [inline, virtual]
createLightVolumeMap()=0 | LightVolumeRenderingRun | [inline, protected, pure virtual]
lastupdated | RenderingRun | [protected]
LightVolumeRenderingRun(unsigned long startFrame, unsigned long updateInterval, unsigned int resolution, unsigned int textureDepth) | LightVolumeRenderingRun | [inline]
needUpdate(unsigned long frameNum) | RenderingRun | [inline, protected, virtual]
RenderingRun(unsigned long startFrame, unsigned long updateInterval) | RenderingRun |
resolution | LightVolumeRenderingRun | [protected]
startFrame | RenderingRun | [protected]
textureDepth | LightVolumeRenderingRun | [protected]
update(unsigned long frameNum) | RenderingRun | [inline]
updateFrame(unsigned long frameNum)=0 | LightVolumeRenderingRun | [protected, pure virtual]
updateInterval | RenderingRun | [protected]

Generated on Wed Mar 28 11:48:49 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: Member List

OgreCausticCasterRenderTechnique Member List

This is the complete list of members for OgreCausticCasterRenderTechnique, including all inherited members.

asOgreRenderTechnique() | OgreRenderTechnique | [inline, virtual]
attenuation | OgreCausticCasterRenderTechnique | [protected]
blurCauCubeMap | OgreCausticCasterRenderTechnique | [protected]
CausticCasterRenderTechnique(unsigned long startFrame, unsigned long photonMapUpdateInterval, unsigned int photonMapResolution, unsigned int causticCubeMapResolution, bool updateAllFace, bool useDistance, ElementaryRenderable *parentRenderable, TechniqueGroup *parentTechniqueGroup) | CausticCasterRenderTechnique |
causticCubeMapResolution | CausticCasterRenderTechnique | [protected]
causticCubeMapRunChanged(RenderingRun *run) | OgreCausticCasterRenderTechnique | [protected, virtual]
causticMapMaterialName | OgreCausticCasterRenderTechnique | [protected]
createCausticCubeMapRun() | OgreCausticCasterRenderTechnique | [protected, virtual]
createDistanceCubeMapRun() | OgreCausticCasterRenderTechnique | [protected, virtual]
createPhotonMapRun() | OgreCausticCasterRenderTechnique | [protected, virtual]
distanceCubeMapRunChanged(RenderingRun *run) | OgreCausticCasterRenderTechnique | [protected, virtual]
distanceCubeMapRunUpdated(RenderingRun *run) | OgreCausticCasterRenderTechnique | [protected, virtual]
getAttenuation() | OgreCausticCasterRenderTechnique | [inline]
getCausticCubeMapName() | OgreCausticCasterRenderTechnique |
getParentRenderable() | RenderTechnique | [inline]
OgreCausticCasterRenderTechnique(unsigned long startFrame, unsigned long photonMapUpdateInterval, unsigned int photonMapResolution, unsigned int causticCubeMapResolution, String photonMapMaterialName, String causticMapMaterialName, unsigned char photonMapTexID, bool updateAllFace, bool useDistance, float attenuation, bool useTriangles, bool blurCauCubeMap, Pass *pass, OgreRenderable *parentRenderable, OgreTechniqueGroup *parentTechniqueGroup) | OgreCausticCasterRenderTechnique |
OgreRenderTechnique(Pass *pass, OgreRenderable *parentRenderable, OgreTechniqueGroup *parentTechniqueGroup) | OgreRenderTechnique |
parentOgreRenderable | OgreRenderTechnique | [protected]
parentOgreTechniqueGroup | OgreRenderTechnique | [protected]
parentRenderable | RenderTechnique | [protected]
parentTechniqueGroup | RenderTechnique | [protected]
pass | OgreRenderTechnique | [protected]
photonMapMaterialName | OgreCausticCasterRenderTechnique | [protected]
photonMapResolution | CausticCasterRenderTechnique | [protected]
photonMapRunChanged(RenderingRun *run) | OgreCausticCasterRenderTechnique | [protected, virtual]
photonMapTexID | OgreCausticCasterRenderTechnique | [protected]
photonMapUpdateInterval | CausticCasterRenderTechnique | [protected]
RenderTechnique(ElementaryRenderable *parentRenderable, TechniqueGroup *parentTechniqueGroup) | RenderTechnique |
OgreRenderTechnique::runChanged(RenderingRunType runType, RenderingRun *run) | RenderTechnique | [inline, virtual]
CausticCasterRenderTechnique::runChanged(RenderingRunType runType, RenderingRun *run) | CausticCasterRenderTechnique | [virtual]
OgreRenderTechnique::runUpdated(RenderingRunType runType, RenderingRun *run) | RenderTechnique | [inline, virtual]
CausticCasterRenderTechnique::runUpdated(RenderingRunType runType, RenderingRun *run) | CausticCasterRenderTechnique | [virtual]
sharedRuns | RenderTechnique | [protected]
startFrame | CausticCasterRenderTechnique | [protected]
update(unsigned long frameNum) | RenderTechnique | [inline, virtual]
updateAllFace | CausticCasterRenderTechnique | [protected]
useDistance | CausticCasterRenderTechnique | [protected]
useTriangles | OgreCausticCasterRenderTechnique | [protected]
~OgreCausticCasterRenderTechnique() | OgreCausticCasterRenderTechnique |

Generated on Wed Mar 28 11:48:50 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: Member List

OgreCausticCasterRenderTechniqueFactory Member List

This is the complete list of members for OgreCausticCasterRenderTechniqueFactory, including all inherited members.

AttribParserList typedef | RenderTechniqueFactory | [protected]
attributeParsers | RenderTechniqueFactory | [protected]
createInstance(IllumTechniqueParams *params, Pass *pass, OgreRenderable *parentRenderable, OgreTechniqueGroup *parentTechniqueGroup) | OgreCausticCasterRenderTechniqueFactory | [virtual]
ILLUM_ATTRIBUTE_PARSER typedef | RenderTechniqueFactory | [protected]
isType(String type) | RenderTechniqueFactory | [inline]
OgreCausticCasterRenderTechniqueFactory() | OgreCausticCasterRenderTechniqueFactory |
parseParams(IllumTechniqueParams *params) | RenderTechniqueFactory | [virtual]
typeName | RenderTechniqueFactory | [protected]

Generated on Wed Mar 28 11:48:50 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: Member List

OgreCausticCubeMapRenderingRun Member List

This is the complete list of members for OgreCausticCubeMapRenderingRun, including all inherited members.

asOgreRenderingRun() | OgreRenderingRun | [inline, virtual]
asOgreRenderingRun() | OgreRenderingRun | [inline, virtual]
attenuation | OgreCausticCubeMapRenderingRun | [protected]
bluredCausticCubemapTexture | OgreCausticCubeMapRenderingRun | [protected]
blurMap | OgreCausticCubeMapRenderingRun | [protected]
canJoin(RenderingRun *run) | OgreCausticCubeMapRenderingRun | [inline, virtual]
CausticCubeMapRenderingRun(unsigned long startFrame, unsigned long updateInterval, unsigned int resolution, bool updateAllFace) | CausticCubeMapRenderingRun |
causticCubemapTexture | OgreCausticCubeMapRenderingRun | [protected]
createCausticCubeMap() | OgreCausticCubeMapRenderingRun | [inline, protected, virtual]
createCubeRenderTexture(String name, const Vector3 position, unsigned int resolution=512, PixelFormat format=PF_FLOAT16_RGBA, int numMips=0, ColourValue clearColor=ColourValue::Black) | OgreRenderingRun | [protected]
createCubeRenderTexture(String name, const Vector3 position, unsigned int resolution=512, PixelFormat format=PF_FLOAT16_RGBA, int numMips=0, ColourValue clearColor=ColourValue::Black) | OgreRenderingRun | [protected]
currentFace | CausticCubeMapRenderingRun | [protected]
faceNeedsUpdate(int facenum) | OgreCausticCubeMapRenderingRun | [protected, virtual]
fullscreenGrid | OgreRenderingRun | [protected]
fullScreenQuad | OgreRenderingRun | [protected, static]
fullScreenQuad | OgreRenderingRun | [protected, static]
fullScreenQuadEntity | OgreRenderingRun | [protected, static]
fullScreenQuadEntity | OgreRenderingRun | [protected, static]
fullScreenQuadNode | OgreRenderingRun | [protected, static]
fullScreenQuadNode | OgreRenderingRun | [protected, static]
getAttenuation() | OgreCausticCubeMapRenderingRun | [inline]
getCausticCubeMapTextureName() | OgreCausticCubeMapRenderingRun | [inline]
getCubeMapFaceDirection(unsigned char faceId) | OgreRenderingRun | [protected]
getCubeMapFaceDirection(unsigned char faceId) | OgreRenderingRun | [protected]
lastupdated | RenderingRun | [protected]
materialName | OgreCausticCubeMapRenderingRun | [protected]
name | OgreCausticCubeMapRenderingRun | [protected]
needUpdate(unsigned long frameNum) | RenderingRun | [inline, protected, virtual]
OgreCausticCubeMapRenderingRun(OgreSharedRuns *sharedRuns, String name, unsigned long startFrame, unsigned long updateInterval, unsigned int resolution, String materialName, unsigned char photonMapTexId, bool updateAllFace, float attenuation, bool useTriangles, bool blurMap) | OgreCausticCubeMapRenderingRun |
OgreRenderingRun(unsigned long startFrame, unsigned long updateInterval) | OgreRenderingRun | [inline]
OgreRenderingRun(unsigned long startFrame, unsigned long updateInterval) | OgreRenderingRun | [inline]
photonMapChanged(RenderingRun *run) | OgreCausticCubeMapRenderingRun | [virtual]
photonMapTexId | OgreCausticCubeMapRenderingRun | [protected]
pixelSprites | OgreRenderingRun | [protected]
pixelSprites | OgreRenderingRun | [protected]
renderFullscreenGrid(String &materialName, RenderTarget *rt, int width, int height) | OgreRenderingRun | [protected]
renderFullscreenQuad(String materialName, RenderTarget *target) | OgreRenderingRun | [protected]
renderFullscreenQuad(String materialName, RenderTarget *target) | OgreRenderingRun | [protected]
RenderingRun(unsigned long startFrame, unsigned long updateInterval) | RenderingRun |
renderPixelSprites(String &materialName, RenderTarget *rt, int width, int height) | OgreRenderingRun | [protected]
renderPixelSprites(String &materialName, RenderTarget *rt, int width, int height) | OgreRenderingRun | [protected]
resolution | CausticCubeMapRenderingRun | [protected]
restoreMaterials() | OgreRenderingRun | [protected]
restoreMaterials() | OgreRenderingRun | [protected]
setBlurMap(bool blur) | OgreCausticCubeMapRenderingRun | [inline]
setMaterialForRenderables(String &materialName, RenderQueue *rq) | OgreRenderingRun | [protected]
setMaterialForRenderables(String &materialName, RenderQueue *rq, bool solidsonly=false) | OgreRenderingRun | [protected]
setMaterialForVisibles(String &materialName, Camera *cam, bool shadowcastersonly=false) | OgreRenderingRun | [protected]
setMaterialForVisibles(String &materialName, Camera *cam, bool shadowcastersonly=false, bool solidsonly=false) | OgreRenderingRun | [protected]
sharedRuns | OgreCausticCubeMapRenderingRun | [protected]
spriteSetName | OgreRenderingRun | [protected]
startFrame | RenderingRun | [protected]
update(unsigned long frameNum) | RenderingRun | [inline]
updateAllFace | CausticCubeMapRenderingRun | [protected]
updateCubeFace(int facenum) | OgreCausticCubeMapRenderingRun | [inline, protected, virtual]
OgreRenderingRun::updateFrame(unsigned long frameNum) | RenderingRun | [inline, protected, virtual]
CausticCubeMapRenderingRun::updateFrame(unsigned long frameNum) | CausticCubeMapRenderingRun | [protected, virtual]
updateInterval | RenderingRun | [protected]
useTriangles | OgreCausticCubeMapRenderingRun | [protected]
visibleObjects | OgreRenderingRun | [protected]
visibleObjects | OgreRenderingRun | [protected]

Generated on Wed Mar 28 11:48:50 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: Member List

OgreCausticReceiverRenderTechnique Member List

This is the complete list of members for OgreCausticReceiverRenderTechnique, including all inherited members.

asOgreRenderTechnique() | OgreRenderTechnique | [inline, virtual]
causticCasters | OgreCausticReceiverRenderTechnique | [protected]
causticFragmentProgram | OgreCausticReceiverRenderTechnique | [protected]
CausticReceiverRenderTechnique(ElementaryRenderable *parentRenderable, TechniqueGroup *parentTechniqueGroup) | CausticReceiverRenderTechnique |
causticVertexProgram | OgreCausticReceiverRenderTechnique | [protected]
getParentRenderable() | RenderTechnique | [inline]
maxcasters | OgreCausticReceiverRenderTechnique | [protected]
OgreCausticReceiverRenderTechnique(int maxcasters, String causticVertexProgram, String causticFragmentProgram, Pass *pass, OgreRenderable *parentRenderable, OgreTechniqueGroup *parentTechniqueGroup) | OgreCausticReceiverRenderTechnique |
OgreRenderTechnique(Pass *pass, OgreRenderable *parentRenderable, OgreTechniqueGroup *parentTechniqueGroup) | OgreRenderTechnique |
parentOgreRenderable | OgreRenderTechnique | [protected]
parentOgreTechniqueGroup | OgreRenderTechnique | [protected]
parentRenderable | RenderTechnique | [protected]
parentTechniqueGroup | RenderTechnique | [protected]
pass | OgreRenderTechnique | [protected]
passes | OgreCausticReceiverRenderTechnique | [protected]
RenderTechnique(ElementaryRenderable *parentRenderable, TechniqueGroup *parentTechniqueGroup) | RenderTechnique |
runChanged(RenderingRunType runType, RenderingRun *run) | RenderTechnique | [inline, virtual]
runUpdated(RenderingRunType runType, RenderingRun *run) | RenderTechnique | [inline, virtual]
sharedRuns | RenderTechnique | [protected]
update(unsigned long frameNum) | OgreCausticReceiverRenderTechnique | [virtual]
~OgreCausticReceiverRenderTechnique() | OgreCausticReceiverRenderTechnique |

Generated on Wed Mar 28 11:48:50 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: Member List

OgreCausticReceiverRenderTechniqueFactory Member List

This is the complete list of members for OgreCausticReceiverRenderTechniqueFactory, including all inherited members.

AttribParserList typedef | RenderTechniqueFactory | [protected]
attributeParsers | RenderTechniqueFactory | [protected]
createInstance(IllumTechniqueParams *params, Pass *pass, OgreRenderable *parentRenderable, OgreTechniqueGroup *parentTechniqueGroup) | OgreCausticReceiverRenderTechniqueFactory | [virtual]
ILLUM_ATTRIBUTE_PARSER typedef | RenderTechniqueFactory | [protected]
isType(String type) | RenderTechniqueFactory | [inline]
parseParams(IllumTechniqueParams *params) | RenderTechniqueFactory | [virtual]
typeName | RenderTechniqueFactory | [protected]

Generated on Wed Mar 28 11:48:51 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: Member List

OgreChildPSystemRenderingRun Member List

This is the complete list of members for OgreChildPSystemRenderingRun, including all inherited members.

asOgreRenderingRun() | OgreRenderingRun | [inline, virtual]
asOgreRenderingRun() | OgreRenderingRun | [inline, virtual]
canJoin(RenderingRun *run) | OgreChildPSystemRenderingRun | [inline, virtual]
childParticleSystemName | OgreChildPSystemRenderingRun | [protected]
ChildPsystemRenderingRun(unsigned int resolution, bool perspectiveRendering, unsigned long startFrame, unsigned long updateInterval) | ChildPsystemRenderingRun | [inline]
createCubeRenderTexture(String name, const Vector3 position, unsigned int resolution=512, PixelFormat format=PF_FLOAT16_RGBA, int numMips=0, ColourValue clearColor=ColourValue::Black) | OgreRenderingRun | [protected]
createCubeRenderTexture(String name, const Vector3 position, unsigned int resolution=512, PixelFormat format=PF_FLOAT16_RGBA, int numMips=0, ColourValue clearColor=ColourValue::Black) | OgreRenderingRun | [protected]
createImpostorTexture() | OgreChildPSystemRenderingRun | [inline, protected, virtual]
fullscreenGrid | OgreRenderingRun | [protected]
fullScreenQuad | OgreRenderingRun | [protected, static]
fullScreenQuad | OgreRenderingRun | [protected, static]
fullScreenQuadEntity | OgreRenderingRun | [protected, static]
fullScreenQuadEntity | OgreRenderingRun | [protected, static]
fullScreenQuadNode | OgreRenderingRun | [protected, static]
fullScreenQuadNode | OgreRenderingRun | [protected, static]
getCubeMapFaceDirection(unsigned char faceId) | OgreRenderingRun | [protected]
getCubeMapFaceDirection(unsigned char faceId) | OgreRenderingRun | [protected]
getImpostorTextureName() | OgreChildPSystemRenderingRun | [inline]
getSmallSysRadius() | OgreChildPSystemRenderingRun | [inline]
impostorCamera | OgreChildPSystemRenderingRun | [protected]
impostorTexture | OgreChildPSystemRenderingRun | [protected]
lastupdated | RenderingRun | [protected]
materialName | OgreChildPSystemRenderingRun | [protected]
name | OgreChildPSystemRenderingRun | [protected]
needUpdate(unsigned long frameNum) | RenderingRun | [inline, protected, virtual]
OgreChildPSystemRenderingRun(OgreSharedRuns *sharedRuns, String name, unsigned long startFrame, unsigned long updateInterval, unsigned int resolution, bool perspectiveRendering, String childParticleSystemName, String particleScriptName, bool useOwnMaterial, String materialName) | OgreChildPSystemRenderingRun |
OgreRenderingRun(unsigned long startFrame, unsigned long updateInterval) | OgreRenderingRun | [inline]
OgreRenderingRun(unsigned long startFrame, unsigned long updateInterval) | OgreRenderingRun | [inline]
particleScriptName | OgreChildPSystemRenderingRun | [protected]
perspectiveRendering | OgreChildPSystemRenderingRun | [protected]
pixelSprites | OgreRenderingRun | [protected]
pixelSprites | OgreRenderingRun | [protected]
renderFullscreenGrid(String &materialName, RenderTarget *rt, int width, int height) | OgreRenderingRun | [protected]
renderFullscreenQuad(String materialName, RenderTarget *target) | OgreRenderingRun | [protected]
renderFullscreenQuad(String materialName, RenderTarget *target) | OgreRenderingRun | [protected]
RenderingRun(unsigned long startFrame, unsigned long updateInterval) | RenderingRun |
renderPixelSprites(String &materialName, RenderTarget *rt, int width, int height) | OgreRenderingRun | [protected]
renderPixelSprites(String &materialName, RenderTarget *rt, int width, int height) | OgreRenderingRun | [protected]
resolution | ChildPsystemRenderingRun | [protected]
restoreMaterials() | OgreRenderingRun | [protected]
restoreMaterials() | OgreRenderingRun | [protected]
setMaterialForRenderables(String &materialName, RenderQueue *rq) | OgreRenderingRun | [protected]
setMaterialForRenderables(String &materialName, RenderQueue *rq, bool solidsonly=false) | OgreRenderingRun | [protected]
setMaterialForVisibles(String &materialName, Camera *cam, bool shadowcastersonly=false) | OgreRenderingRun | [protected]
setMaterialForVisibles(String &materialName, Camera *cam, bool shadowcastersonly=false, bool solidsonly=false) | OgreRenderingRun | [protected]
sharedRuns | OgreChildPSystemRenderingRun | [protected]
spriteSetName | OgreRenderingRun | [protected]
startFrame | RenderingRun | [protected]
sysRad | OgreChildPSystemRenderingRun | [protected]
update(unsigned long frameNum) | RenderingRun | [inline]
updateFrame(unsigned long frameNum) | OgreChildPSystemRenderingRun | [protected, virtual]
updateInterval | RenderingRun | [protected]
useOwnMaterial | OgreChildPSystemRenderingRun | [protected]
visibleObjects | OgreRenderingRun | [protected]
visibleObjects | OgreRenderingRun | [protected]

Generated on Wed Mar 28 11:48:51 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: Member List

OgreColorCubeMapRenderTechnique Member List

This is the complete list of members for OgreColorCubeMapRenderTechnique, including all inherited members.

angleTolerance | CubeMapRenderTechnique | [protected]
ColorCubeMapRenderTechnique::asOgreRenderTechnique() | RenderTechnique | [inline, virtual]
OgreCubeMapRenderTechnique::OgreRenderTechnique::asOgreRenderTechnique() | OgreRenderTechnique | [inline, virtual]
attachToTexUnit | OgreCubeMapRenderTechnique | [protected]
ColorCubeMapRenderTechnique(unsigned long startFrame, unsigned long cubeMapUpdateInterval, unsigned int cubeMapResolution, bool useDistCalc, bool useFaceAngleCalc, float distTolerance, float angleTolerance, bool updateAllFace, bool renderSelf, bool renderEnvironment, int layer, ElementaryRenderable *parentRenderable, TechniqueGroup *parentTechniqueGroup) | ColorCubeMapRenderTechnique |
colorCubeMapRunChanged(RenderingRun *run) | OgreColorCubeMapRenderTechnique | [protected, virtual]
colorCubeMapRunUpdated(RenderingRun *run) | OgreColorCubeMapRenderTechnique | [protected, virtual]
ColorCubeMapRenderTechnique::createCubeMapRun()=0 | CubeMapRenderTechnique | [protected, pure virtual]
OgreCubeMapRenderTechnique::createCubeMapRun() | OgreCubeMapRenderTechnique | [protected, virtual]
cubemapLayer | CubeMapRenderTechnique | [protected]
CubeMapRenderTechnique(unsigned long startFrame, unsigned long cubeMapUpdateInterval, unsigned int cubeMapResolution, bool useDistCalc, bool useFaceAngleCalc, float distTolerance, float angleTolerance, bool updateAllFace, bool renderSelf, bool renderEnvironment, int layer, ElementaryRenderable *parentRenderable, TechniqueGroup *parentTechniqueGroup) | CubeMapRenderTechnique |
cubeMapResolution | CubeMapRenderTechnique | [protected]
ColorCubeMapRenderTechnique::cubeMapRunChanged(RenderingRun *run)=0 | CubeMapRenderTechnique | [protected, pure virtual]
OgreCubeMapRenderTechnique::cubeMapRunChanged(RenderingRun *run) | OgreCubeMapRenderTechnique | [protected, virtual]
ColorCubeMapRenderTechnique::cubeMapRunUpdated(RenderingRun *run)=0 | CubeMapRenderTechnique | [protected, pure virtual]
OgreCubeMapRenderTechnique::cubeMapRunUpdated(RenderingRun *run) | OgreCubeMapRenderTechnique | [protected, virtual]
cubeMapUpdateInterval | CubeMapRenderTechnique | [protected]
distTolerance | CubeMapRenderTechnique | [protected]
environmentMaterial | OgreCubeMapRenderTechnique | [protected]
getMinMax | OgreCubeMapRenderTechnique | [protected]
getParentRenderable() | RenderTechnique | [inline]
layer | CubeMapRenderTechnique | [protected]
maxVariableName | OgreCubeMapRenderTechnique | [protected]
minVariableName | OgreCubeMapRenderTechnique | [protected]
OgreColorCubeMapRenderTechnique(unsigned long startFrame, unsigned long cubeMapUpdateInterval, unsigned int cubeMapResolution, unsigned char texID, bool useDistCalc, bool useFaceAngleCalc, float distTolerance, float angleTolerance, bool updateAllFace, bool renderSelf, bool renderEnvironment, String selfMaterial, String environmentMaterial, int layer, bool getMinMax, bool attachToTexUnit, String minVariableName, String maxVariableName, Pass *pass, OgreRenderable *parentRenderable, OgreTechniqueGroup *parentTechniqueGroup) | OgreColorCubeMapRenderTechnique |
OgreCubeMapRenderTechnique(unsigned long startFrame, unsigned long cubeMapUpdateInterval, unsigned int cubeMapResolution, unsigned char texID, bool useDistCalc, bool useFaceAngleCalc, float distTolerance, float angleTolerance, bool updateAllFace, bool renderSelf, bool renderEnvironment, String selfMaterial, String environmentMaterial, int layer, bool getMinMax, bool attachToTexUnit, String minVariableName, String maxVariableName, Pass *pass, OgreRenderable *parentRenderable, OgreTechniqueGroup *parentTechniqueGroup, bool createCubeRun=false) | OgreCubeMapRenderTechnique |
OgreRenderTechnique(Pass *pass, OgreRenderable *parentRenderable, OgreTechniqueGroup *parentTechniqueGroup) | OgreRenderTechnique |
parentOgreRenderable | OgreRenderTechnique | [protected]
parentOgreTechniqueGroup | OgreRenderTechnique | [protected]
parentRenderable | RenderTechnique | [protected]
parentTechniqueGroup | RenderTechnique | [protected]
pass | OgreRenderTechnique | [protected]
renderEnvironment | CubeMapRenderTechnique | [protected]
renderSelf | CubeMapRenderTechnique | [protected]
RenderTechnique(ElementaryRenderable *parentRenderable, TechniqueGroup *parentTechniqueGroup) | RenderTechnique |
runChanged(RenderingRunType runType, RenderingRun *run) | ColorCubeMapRenderTechnique | [virtual]
runUpdated(RenderingRunType runType, RenderingRun *run) | ColorCubeMapRenderTechnique | [virtual]
selfMaterial | OgreCubeMapRenderTechnique | [protected]
sharedRuns | RenderTechnique | [protected]
startFrame | CubeMapRenderTechnique | [protected]
texID | OgreCubeMapRenderTechnique | [protected]
update(unsigned long frameNum) | OgreColorCubeMapRenderTechnique | [virtual]
updateAllFace | CubeMapRenderTechnique | [protected]
useDistCalc | CubeMapRenderTechnique | [protected]
useFaceAngleCalc | CubeMapRenderTechnique | [protected]
~OgreColorCubeMapRenderTechnique() | OgreColorCubeMapRenderTechnique |
~OgreCubeMapRenderTechnique() | OgreCubeMapRenderTechnique |

Generated on Wed Mar 28 11:48:51 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: Member List

OgreColorCubeMapRenderTechniqueFactory Member List

This is the complete list of members for OgreColorCubeMapRenderTechniqueFactory, including all inherited members.

AttribParserList typedef | RenderTechniqueFactory | [protected]
attributeParsers | RenderTechniqueFactory | [protected]
createInstance(IllumTechniqueParams *params, Pass *pass, OgreRenderable *parentRenderable, OgreTechniqueGroup *parentTechniqueGroup) | OgreColorCubeMapRenderTechniqueFactory | [virtual]
ILLUM_ATTRIBUTE_PARSER typedef | RenderTechniqueFactory | [protected]
isType(String type) | RenderTechniqueFactory | [inline]
OgreColorCubeMapRenderTechniqueFactory() | OgreColorCubeMapRenderTechniqueFactory |
OgreCubeMapRenderTechniqueFactory() | OgreCubeMapRenderTechniqueFactory |
parseParams(IllumTechniqueParams *params) | RenderTechniqueFactory | [virtual]
typeName | RenderTechniqueFactory | [protected]

Generated on Wed Mar 28 11:48:52 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: Member List

OgreConvoledCubeMapRenderTechniqueFactory Member List

This is the complete list of members for OgreConvoledCubeMapRenderTechniqueFactory, including all inherited members.

AttribParserList typedef | RenderTechniqueFactory | [protected]
attributeParsers | RenderTechniqueFactory | [protected]
createInstance(IllumTechniqueParams *params, Pass *pass, OgreRenderable *parentRenderable, OgreTechniqueGroup *parentTechniqueGroup) | OgreConvoledCubeMapRenderTechniqueFactory | [virtual]
ILLUM_ATTRIBUTE_PARSER typedef | RenderTechniqueFactory | [protected]
isType(String type) | RenderTechniqueFactory | [inline]
OgreConvoledCubeMapRenderTechniqueFactory() | OgreConvoledCubeMapRenderTechniqueFactory |
OgreCubeMapRenderTechniqueFactory() | OgreCubeMapRenderTechniqueFactory |
parseParams(IllumTechniqueParams *params) | RenderTechniqueFactory | [virtual]
typeName | RenderTechniqueFactory | [protected]

Generated on Wed Mar 28 11:48:52 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: Member List

OgreConvolvedCubeMapRenderTechnique Member List

This is the complete list of members for OgreConvolvedCubeMapRenderTechnique, including all inherited members.

angleTolerance | CubeMapRenderTechnique | [protected]
ConvolvedCubeMapRenderTechnique::asOgreRenderTechnique() | RenderTechnique | [inline, virtual]
OgreCubeMapRenderTechnique::OgreRenderTechnique::asOgreRenderTechnique() | OgreRenderTechnique | [inline, virtual]
attachToTexUnit | OgreCubeMapRenderTechnique | [protected]
colorCubeMapRunChanged(RenderingRun *run) | OgreConvolvedCubeMapRenderTechnique | [protected, virtual]
ConvolvedCubeMapRenderTechnique(unsigned long startFrame, unsigned long cubeMapUpdateInterval, unsigned int cubeMapResolution, unsigned int reducedCubeMapResolution, bool useDistCalc, bool useFaceAngleCalc, float distTolerance, float angleTolerance, bool updateAllFace, bool renderSelf, bool renderEnvironment, ElementaryRenderable *parentRenderable, TechniqueGroup *parentTechniqueGroup) | ConvolvedCubeMapRenderTechnique |
ConvolvedCubeMapRenderTechnique::createCubeMapRun()=0 | CubeMapRenderTechnique | [protected, pure virtual]
OgreCubeMapRenderTechnique::createCubeMapRun() | OgreCubeMapRenderTechnique | [protected, virtual]
createReducedCubeMapRun() | OgreConvolvedCubeMapRenderTechnique | [protected, virtual]
cubemapLayer | CubeMapRenderTechnique | [protected]
CubeMapRenderTechnique(unsigned long startFrame, unsigned long cubeMapUpdateInterval, unsigned int cubeMapResolution, bool useDistCalc, bool useFaceAngleCalc, float distTolerance, float angleTolerance, bool updateAllFace, bool renderSelf, bool renderEnvironment, int layer, ElementaryRenderable *parentRenderable, TechniqueGroup *parentTechniqueGroup) | CubeMapRenderTechnique |
cubeMapResolution | CubeMapRenderTechnique | [protected]
ConvolvedCubeMapRenderTechnique::cubeMapRunChanged(RenderingRun *run)=0 | CubeMapRenderTechnique | [protected, pure virtual]
OgreCubeMapRenderTechnique::cubeMapRunChanged(RenderingRun *run) | OgreCubeMapRenderTechnique | [protected, virtual]
ConvolvedCubeMapRenderTechnique::cubeMapRunUpdated(RenderingRun *run)=0 | CubeMapRenderTechnique | [protected, pure virtual]
OgreCubeMapRenderTechnique::cubeMapRunUpdated(RenderingRun *run) | OgreCubeMapRenderTechnique | [protected, virtual]
cubeMapUpdateInterval | CubeMapRenderTechnique | [protected]
distTolerance | CubeMapRenderTechnique | [protected]
environmentMaterial | OgreCubeMapRenderTechnique | [protected]
getMinMax | OgreCubeMapRenderTechnique | [protected]
getParentRenderable() | RenderTechnique | [inline]
layer | CubeMapRenderTechnique | [protected]
maxVariableName | OgreCubeMapRenderTechnique | [protected]
minVariableName | OgreCubeMapRenderTechnique | [protected]
OgreConvolvedCubeMapRenderTechnique(unsigned long startFrame, unsigned long cubeMapUpdateInterval, unsigned int cubeMapResolution, unsigned int reducedCubeMapResolution, unsigned char texID, bool useDistCalc, bool useFaceAngleCalc, float distTolerance, float angleTolerance, bool updateAllFace, bool renderSelf, bool renderEnvironment, String selfMaterial, String environmentMaterial, bool getMinMax, bool attachToTexUnit, String minVariableName, String maxVariableName, Pass *pass, OgreRenderable *parentRenderable, OgreTechniqueGroup *parentTechniqueGroup) | OgreConvolvedCubeMapRenderTechnique |
OgreCubeMapRenderTechnique(unsigned long startFrame, unsigned long cubeMapUpdateInterval, unsigned int cubeMapResolution, unsigned char texID, bool useDistCalc, bool useFaceAngleCalc, float distTolerance, float angleTolerance, bool updateAllFace, bool renderSelf, bool renderEnvironment, String selfMaterial, String environmentMaterial, int layer, bool getMinMax, bool attachToTexUnit, String minVariableName, String maxVariableName, Pass *pass, OgreRenderable *parentRenderable, OgreTechniqueGroup *parentTechniqueGroup, bool createCubeRun=false) | OgreCubeMapRenderTechnique |
OgreRenderTechnique(Pass *pass, OgreRenderable *parentRenderable, OgreTechniqueGroup *parentTechniqueGroup) | OgreRenderTechnique |
parentOgreRenderable | OgreRenderTechnique | [protected]
parentOgreTechniqueGroup | OgreRenderTechnique | [protected]
parentRenderable | RenderTechnique | [protected]
parentTechniqueGroup | RenderTechnique | [protected]
pass | OgreRenderTechnique | [protected]
reducedCubeMapResolution | ConvolvedCubeMapRenderTechnique | [protected]
reducedCubeMapRunChanged(RenderingRun *run) | OgreConvolvedCubeMapRenderTechnique | [protected, virtual]
renderEnvironment | CubeMapRenderTechnique | [protected]
renderSelf | CubeMapRenderTechnique | [protected]
RenderTechnique(ElementaryRenderable *parentRenderable, TechniqueGroup *parentTechniqueGroup) | RenderTechnique |
runChanged(RenderingRunType runType, RenderingRun *run) | ConvolvedCubeMapRenderTechnique | [virtual]
runUpdated(RenderingRunType runType, RenderingRun *run) | CubeMapRenderTechnique | [virtual]
selfMaterial | OgreCubeMapRenderTechnique | [protected]
sharedRuns | RenderTechnique | [protected]
startFrame | CubeMapRenderTechnique | [protected]
texID | OgreCubeMapRenderTechnique | [protected]
update(unsigned long frameNum) | OgreConvolvedCubeMapRenderTechnique | [virtual]
updateAllFace | CubeMapRenderTechnique | [protected]
useDistCalc | CubeMapRenderTechnique | [protected]
useFaceAngleCalc | CubeMapRenderTechnique | [protected]
~OgreConvolvedCubeMapRenderTechnique() | OgreConvolvedCubeMapRenderTechnique |
~OgreCubeMapRenderTechnique() | OgreCubeMapRenderTechnique |

Generated on Wed Mar 28 11:48:52 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: Member List

OgreCubeMapRenderTechnique Member List

This is the complete list of members for OgreCubeMapRenderTechnique, including all inherited members.

angleTolerance | CubeMapRenderTechnique | [protected]
CubeMapRenderTechnique::asOgreRenderTechnique() | RenderTechnique | [inline, virtual]
OgreRenderTechnique::asOgreRenderTechnique() | OgreRenderTechnique | [inline, virtual]
attachToTexUnit | OgreCubeMapRenderTechnique | [protected]
createCubeMapRun() | OgreCubeMapRenderTechnique | [protected, virtual]
cubemapLayer | CubeMapRenderTechnique | [protected]
CubeMapRenderTechnique(unsigned long startFrame, unsigned long cubeMapUpdateInterval, unsigned int cubeMapResolution, bool useDistCalc, bool useFaceAngleCalc, float distTolerance, float angleTolerance, bool updateAllFace, bool renderSelf, bool renderEnvironment, int layer, ElementaryRenderable *parentRenderable, TechniqueGroup *parentTechniqueGroup) | CubeMapRenderTechnique |
cubeMapResolution | CubeMapRenderTechnique | [protected]
cubeMapRunChanged(RenderingRun *run) | OgreCubeMapRenderTechnique | [protected, virtual]
cubeMapRunUpdated(RenderingRun *run) | OgreCubeMapRenderTechnique | [protected, virtual]
cubeMapUpdateInterval | CubeMapRenderTechnique | [protected]
distTolerance | CubeMapRenderTechnique | [protected]
environmentMaterial | OgreCubeMapRenderTechnique | [protected]
getMinMax | OgreCubeMapRenderTechnique | [protected]
getParentRenderable() | RenderTechnique | [inline]
layer | CubeMapRenderTechnique | [protected]
maxVariableName | OgreCubeMapRenderTechnique | [protected]
minVariableName | OgreCubeMapRenderTechnique | [protected]
OgreCubeMapRenderTechnique(unsigned long startFrame, unsigned long cubeMapUpdateInterval, unsigned int cubeMapResolution, unsigned char texID, bool useDistCalc, bool useFaceAngleCalc, float distTolerance, float angleTolerance, bool updateAllFace, bool renderSelf, bool renderEnvironment, String selfMaterial, String environmentMaterial, int layer, bool getMinMax, bool attachToTexUnit, String minVariableName, String maxVariableName, Pass *pass, OgreRenderable *parentRenderable, OgreTechniqueGroup *parentTechniqueGroup, bool createCubeRun=false) | OgreCubeMapRenderTechnique |
OgreRenderTechnique(Pass *pass, OgreRenderable *parentRenderable, OgreTechniqueGroup *parentTechniqueGroup) | OgreRenderTechnique |
parentOgreRenderable | OgreRenderTechnique | [protected]
parentOgreTechniqueGroup | OgreRenderTechnique | [protected]
parentRenderable | RenderTechnique | [protected]
parentTechniqueGroup | RenderTechnique | [protected]
pass | OgreRenderTechnique | [protected]
renderEnvironment | CubeMapRenderTechnique | [protected]
renderSelf | CubeMapRenderTechnique | [protected]
RenderTechnique(ElementaryRenderable *parentRenderable, TechniqueGroup *parentTechniqueGroup) | RenderTechnique |
runChanged(RenderingRunType runType, RenderingRun *run) | CubeMapRenderTechnique | [virtual]
runUpdated(RenderingRunType runType, RenderingRun *run) | CubeMapRenderTechnique | [virtual]
selfMaterial | OgreCubeMapRenderTechnique | [protected]
sharedRuns | RenderTechnique | [protected]
startFrame | CubeMapRenderTechnique | [protected]
texID | OgreCubeMapRenderTechnique | [protected]
update(unsigned long frameNum) | RenderTechnique | [inline, virtual]
updateAllFace | CubeMapRenderTechnique | [protected]
useDistCalc | CubeMapRenderTechnique | [protected]
useFaceAngleCalc | CubeMapRenderTechnique | [protected]
~OgreCubeMapRenderTechnique() | OgreCubeMapRenderTechnique |

Generated on Wed Mar 28 11:48:53 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: Member List

OgreCubeMapRenderTechniqueFactory Member List

This is the complete list of members for OgreCubeMapRenderTechniqueFactory, including all inherited members.

AttribParserList typedef | RenderTechniqueFactory | [protected]
attributeParsers | RenderTechniqueFactory | [protected]
createInstance(IllumTechniqueParams *params, Pass *pass, OgreRenderable *parentRenderable, OgreTechniqueGroup *parentTechniqueGroup) | OgreCubeMapRenderTechniqueFactory | [virtual]
ILLUM_ATTRIBUTE_PARSER typedef | RenderTechniqueFactory | [protected]
isType(String type) | RenderTechniqueFactory | [inline]
OgreCubeMapRenderTechniqueFactory() | OgreCubeMapRenderTechniqueFactory |
parseParams(IllumTechniqueParams *params) | RenderTechniqueFactory | [virtual]
typeName | RenderTechniqueFactory | [protected]

Generated on Wed Mar 28 11:48:53 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: Member List

OgreCubeMapRenderingRun Member List

This is the complete list of members for OgreCubeMapRenderingRun, including all inherited members.

angleTolerance | CubeMapRenderingRun | [protected]
asOgreRenderingRun() | OgreRenderingRun | [inline, virtual]
asOgreRenderingRun() | OgreRenderingRun | [inline, virtual]
canJoin(RenderingRun *run) | RenderingRun | [inline, virtual]
createCubeMap() | OgreCubeMapRenderingRun | [inline, protected, virtual]
createCubeRenderTexture(String name, const Vector3 position, unsigned int resolution=512, PixelFormat format=PF_FLOAT16_RGBA, int numMips=0, ColourValue clearColor=ColourValue::Black) | OgreRenderingRun | [protected]
createCubeRenderTexture(String name, const Vector3 position, unsigned int resolution=512, PixelFormat format=PF_FLOAT16_RGBA, int numMips=0, ColourValue clearColor=ColourValue::Black) | OgreRenderingRun | [protected]
CubeMapRenderingRun(unsigned long startFrame, unsigned long updateInterval, unsigned int resolution, bool useDistCalc, bool useFaceAngleCalc, float distTolerance, float angleTolerance, bool updateAllFace, bool renderSelf, bool renderEnvironment) | CubeMapRenderingRun |
cubemapTexture | OgreCubeMapRenderingRun | [protected]
currentFace | CubeMapRenderingRun | [protected]
distTolerance | CubeMapRenderingRun | [protected]
faceNeedsUpdate(int facenum) | OgreCubeMapRenderingRun | [protected, virtual]
fullscreenGrid | OgreRenderingRun | [protected]
fullScreenQuad | OgreRenderingRun | [protected, static]
fullScreenQuad | OgreRenderingRun | [protected, static]
fullScreenQuadEntity | OgreRenderingRun | [protected, static]
fullScreenQuadEntity | OgreRenderingRun | [protected, static]
fullScreenQuadNode | OgreRenderingRun | [protected, static]
fullScreenQuadNode | OgreRenderingRun | [protected, static]
getCubeMapFaceDirection(unsigned char faceId) | OgreRenderingRun | [protected]
getCubeMapFaceDirection(unsigned char faceId) | OgreRenderingRun | [protected]
getCubeMapTextureName() | OgreCubeMapRenderingRun | [inline]
lastupdated | RenderingRun | [protected]
name | OgreCubeMapRenderingRun | [protected]
needUpdate(unsigned long frameNum) | RenderingRun | [inline, protected, virtual]
OgreCubeMapRenderingRun(OgreSharedRuns *sharedRuns, String name, unsigned long startFrame, unsigned long updateInterval, unsigned int resolution, bool useDistCalc, bool useFaceAngleCalc, float distTolerance, float angleTolerance, bool updateAllFace, bool renderSelf, bool renderEnvironment, String selfMaterial, String environmentMaterial, bool getMinMax, RenderingRunType cubemapRunType) | OgreCubeMapRenderingRun |
OgreRenderingRun(unsigned long startFrame, unsigned long updateInterval) | OgreRenderingRun | [inline]
OgreRenderingRun(unsigned long startFrame, unsigned long updateInterval) | OgreRenderingRun | [inline]
pixelSprites | OgreRenderingRun | [protected]
pixelSprites | OgreRenderingRun | [protected]
renderEnvironment | CubeMapRenderingRun | [protected]
renderFullscreenGrid(String &materialName, RenderTarget *rt, int width, int height) | OgreRenderingRun | [protected]
renderFullscreenQuad(String materialName, RenderTarget *target) | OgreRenderingRun | [protected]
renderFullscreenQuad(String materialName, RenderTarget *target) | OgreRenderingRun | [protected]
RenderingRun(unsigned long startFrame, unsigned long updateInterval) | RenderingRun |
renderPixelSprites(String &materialName, RenderTarget *rt, int width, int height) | OgreRenderingRun | [protected]
renderPixelSprites(String &materialName, RenderTarget *rt, int width, int height) | OgreRenderingRun | [protected]
renderSelf | CubeMapRenderingRun | [protected]
resolution | CubeMapRenderingRun | [protected]
restoreMaterials() | OgreRenderingRun | [protected]
restoreMaterials() | OgreRenderingRun | [protected]
setMaterialForRenderables(String &materialName, RenderQueue *rq) | OgreRenderingRun | [protected]
setMaterialForRenderables(String &materialName, RenderQueue *rq, bool solidsonly=false) | OgreRenderingRun | [protected]
setMaterialForVisibles(String &materialName, Camera *cam, bool shadowcastersonly=false) | OgreRenderingRun | [protected]
setMaterialForVisibles(String &materialName, Camera *cam, bool shadowcastersonly=false, bool solidsonly=false) | OgreRenderingRun | [protected]
sharedRuns | OgreCubeMapRenderingRun | [protected]
spriteSetName | OgreRenderingRun | [protected]
startFrame | RenderingRun | [protected]
update(unsigned long frameNum) | RenderingRun | [inline]
updateAllFace | CubeMapRenderingRun | [protected]
updateCubeFace(int facenum) | OgreCubeMapRenderingRun | [inline, protected, virtual]
OgreRenderingRun::updateFrame(unsigned long frameNum) | RenderingRun | [inline, protected, virtual]
CubeMapRenderingRun::updateFrame(unsigned long frameNum) | CubeMapRenderingRun | [protected, virtual]
updateInterval | RenderingRun | [protected]
useDistCalc | CubeMapRenderingRun | [protected]
useFaceAngleCalc | CubeMapRenderingRun | [protected]
visibleObjects | OgreRenderingRun | [protected]
visibleObjects | OgreRenderingRun | [protected]

Generated on Wed Mar 28 11:48:53 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: Member List

OgreDepthShadowMapRenderingRun Member List

This is the complete list of members for OgreDepthShadowMapRenderingRun, including all inherited members.

asOgreRenderingRun() | OgreRenderingRun | [inline, virtual]
asOgreRenderingRun() | OgreRenderingRun | [inline, virtual]
blurredDepthMapTexture | OgreDepthShadowMapRenderingRun | [protected]
blurredname | OgreDepthShadowMapRenderingRun | [protected]
canJoin(RenderingRun *run) | RenderingRun | [inline, virtual]
createCubeRenderTexture(String name, const Vector3 position, unsigned int resolution=512, PixelFormat format=PF_FLOAT16_RGBA, int numMips=0, ColourValue clearColor=ColourValue::Black) | OgreRenderingRun | [protected]
createCubeRenderTexture(String name, const Vector3 position, unsigned int resolution=512, PixelFormat format=PF_FLOAT16_RGBA, int numMips=0, ColourValue clearColor=ColourValue::Black) | OgreRenderingRun | [protected]
createDepthMap() | OgreDepthShadowMapRenderingRun | [inline, protected, virtual]
depthMapCamera | OgreDepthShadowMapRenderingRun | [protected]
depthMapTexture | OgreDepthShadowMapRenderingRun | [protected]
DepthShadowMapRenderingRun(unsigned int resolutionX, unsigned int resolutionY) | DepthShadowMapRenderingRun | [inline]
fullscreenGrid | OgreRenderingRun | [protected]
fullScreenQuad | OgreRenderingRun | [protected, static]
fullScreenQuad | OgreRenderingRun | [protected, static]
fullScreenQuadEntity | OgreRenderingRun | [protected, static]
fullScreenQuadEntity | OgreRenderingRun | [protected, static]
fullScreenQuadNode | OgreRenderingRun | [protected, static]
fullScreenQuadNode | OgreRenderingRun | [protected, static]
getCubeMapFaceDirection(unsigned char faceId) | OgreRenderingRun | [protected]
getCubeMapFaceDirection(unsigned char faceId) | OgreRenderingRun | [protected]
getDepthMapTextureName() | OgreDepthShadowMapRenderingRun |
getLightFarPlane() | OgreDepthShadowMapRenderingRun | [inline]
getLightViewMatrix() | OgreDepthShadowMapRenderingRun |
getLightViewProjMatrix() | OgreDepthShadowMapRenderingRun |
lastupdated | RenderingRun | [protected]
light | OgreDepthShadowMapRenderingRun | [protected]
materialName | OgreDepthShadowMapRenderingRun | [protected]
name | OgreDepthShadowMapRenderingRun | [protected]
needUpdate(unsigned long frameNum) | RenderingRun | [inline, protected, virtual]
OgreDepthShadowMapRenderingRun(OgreSharedRuns *sharedRuns, String name, Light *light, unsigned int resolutionX, unsigned int resolutionY, String materialName) | OgreDepthShadowMapRenderingRun |
OgreRenderingRun(unsigned long startFrame, unsigned long updateInterval) | OgreRenderingRun | [inline]
OgreRenderingRun(unsigned long startFrame, unsigned long updateInterval) | OgreRenderingRun | [inline]
pixelSprites | OgreRenderingRun | [protected]
pixelSprites | OgreRenderingRun | [protected]
refreshLight(unsigned long frameNum) | OgreDepthShadowMapRenderingRun |
renderFullscreenGrid(String &materialName, RenderTarget *rt, int width, int height) | OgreRenderingRun | [protected]
renderFullscreenQuad(String materialName, RenderTarget *target) | OgreRenderingRun | [protected]
renderFullscreenQuad(String materialName, RenderTarget *target) | OgreRenderingRun | [protected]
RenderingRun(unsigned long startFrame, unsigned long updateInterval) | RenderingRun |
renderPixelSprites(String &materialName, RenderTarget *rt, int width, int height) | OgreRenderingRun | [protected]
renderPixelSprites(String &materialName, RenderTarget *rt, int width, int height) | OgreRenderingRun | [protected]
resolutionX | DepthShadowMapRenderingRun | [protected]
resolutionY | DepthShadowMapRenderingRun | [protected]
restoreMaterials() | OgreRenderingRun | [protected]
restoreMaterials() | OgreRenderingRun | [protected]
setMaterialForRenderables(String &materialName, RenderQueue *rq) | OgreRenderingRun | [protected]
setMaterialForRenderables(String &materialName, RenderQueue *rq, bool solidsonly=false) | OgreRenderingRun | [protected]
setMaterialForVisibles(String &materialName, Camera *cam, bool shadowcastersonly=false) | OgreRenderingRun | [protected]
setMaterialForVisibles(String &materialName, Camera *cam, bool shadowcastersonly=false, bool solidsonly=false) | OgreRenderingRun | [protected]
sharedRuns | OgreDepthShadowMapRenderingRun | [protected]
spriteSetName | OgreRenderingRun | [protected]
startFrame | RenderingRun | [protected]
update(unsigned long frameNum) | RenderingRun | [inline]
updateDepthCubeFace(int facenum) | OgreDepthShadowMapRenderingRun | [protected, virtual]
updateDepthMap() | OgreDepthShadowMapRenderingRun | [protected, virtual]
updateFrame(unsigned long frameNum) | OgreDepthShadowMapRenderingRun | [protected, virtual]
updateInterval | RenderingRun | [protected]
visibleObjects | OgreRenderingRun | [protected]
visibleObjects | OgreRenderingRun | [protected]

Generated on Wed Mar 28 11:48:54 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: Member List

OgreDepthShadowReceiverRenderTechnique Member List

This is the complete list of members for OgreDepthShadowReceiverRenderTechnique, including all inherited members.

asOgreRenderTechnique() | OgreRenderTechnique | [inline, virtual]
DepthShadowReceiverRenderTechnique(ElementaryRenderable *parentRenderable, TechniqueGroup *parentTechniqueGroup) | DepthShadowReceiverRenderTechnique |
getParentRenderable() | RenderTechnique | [inline]
lightFarPlaneParamName | OgreDepthShadowReceiverRenderTechnique | [protected]
lightViewParamName | OgreDepthShadowReceiverRenderTechnique | [protected]
lightViewProjParamName | OgreDepthShadowReceiverRenderTechnique | [protected]
maxlights | OgreDepthShadowReceiverRenderTechnique | [protected]
OgreDepthShadowReceiverRenderTechnique(int maxlights, String shadowVertexProgram, String shadowFragmentProgram, String WorldViewProjParamName, String WorldParamName, bool setLightViewMatrix, bool setLightViewProjMatrix, bool setLightProjFarPlane, String lightViewProjParamName, String lightViewParamName, String lightFarPlaneParamName, Pass *pass, OgreRenderable *parentRenderable, OgreTechniqueGroup *parentTechniqueGroup) | OgreDepthShadowReceiverRenderTechnique |
OgreRenderTechnique(Pass *pass, OgreRenderable *parentRenderable, OgreTechniqueGroup *parentTechniqueGroup) | OgreRenderTechnique |
parentOgreRenderable | OgreRenderTechnique | [protected]
parentOgreTechniqueGroup | OgreRenderTechnique | [protected]
parentRenderable | RenderTechnique | [protected]
parentTechniqueGroup | RenderTechnique | [protected]
pass | OgreRenderTechnique | [protected]
passes | OgreDepthShadowReceiverRenderTechnique | [protected]
RenderTechnique(ElementaryRenderable *parentRenderable, TechniqueGroup *parentTechniqueGroup) | RenderTechnique |
runChanged(RenderingRunType runType, RenderingRun *run) | RenderTechnique | [inline, virtual]
runUpdated(RenderingRunType runType, RenderingRun *run) | RenderTechnique | [inline, virtual]
setLightProjFarPlane | OgreDepthShadowReceiverRenderTechnique | [protected]
setLightViewMatrix | OgreDepthShadowReceiverRenderTechnique | [protected]
setLightViewProjMatrix | OgreDepthShadowReceiverRenderTechnique | [protected]
shadowFragmentProgram | OgreDepthShadowReceiverRenderTechnique | [protected]
shadowVertexProgram | OgreDepthShadowReceiverRenderTechnique | [protected]
sharedRuns | RenderTechnique | [protected]
update(unsigned long frameNum) | OgreDepthShadowReceiverRenderTechnique | [virtual]
WorldParamName | OgreDepthShadowReceiverRenderTechnique | [protected]
WorldViewProjParamName | OgreDepthShadowReceiverRenderTechnique | [protected]
~OgreDepthShadowReceiverRenderTechnique() | OgreDepthShadowReceiverRenderTechnique |

Generated on Wed Mar 28 11:48:54 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: Member List

OgreDepthShadowReceiverRenderTechniqueFactory Member List

This is the complete list of members for OgreDepthShadowReceiverRenderTechniqueFactory, including all inherited members.

AttribParserList typedef | RenderTechniqueFactory | [protected]
attributeParsers | RenderTechniqueFactory | [protected]
createInstance(IllumTechniqueParams *params, Pass *pass, OgreRenderable *parentRenderable, OgreTechniqueGroup *parentTechniqueGroup) | OgreDepthShadowReceiverRenderTechniqueFactory | [virtual]
ILLUM_ATTRIBUTE_PARSER typedef | RenderTechniqueFactory | [protected]
isType(String type) | RenderTechniqueFactory | [inline]
parseParams(IllumTechniqueParams *params) | RenderTechniqueFactory | [virtual]
typeName | RenderTechniqueFactory | [protected]

Generated on Wed Mar 28 11:48:54 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: Member List

OgreDistanceCubeMapRenderTechnique Member List

This is the complete list of members for OgreDistanceCubeMapRenderTechnique, including all inherited members.

angleTolerance | CubeMapRenderTechnique | [protected]
DistanceCubeMapRenderTechnique::asOgreRenderTechnique() | RenderTechnique | [inline, virtual]
OgreCubeMapRenderTechnique::OgreRenderTechnique::asOgreRenderTechnique() | OgreRenderTechnique | [inline, virtual]
attachToTexUnit | OgreCubeMapRenderTechnique | [protected]
DistanceCubeMapRenderTechnique::createCubeMapRun()=0 | CubeMapRenderTechnique | [protected, pure virtual]
OgreCubeMapRenderTechnique::createCubeMapRun() | OgreCubeMapRenderTechnique | [protected, virtual]
cubemapLayer | CubeMapRenderTechnique | [protected]
CubeMapRenderTechnique(unsigned long startFrame, unsigned long cubeMapUpdateInterval, unsigned int cubeMapResolution, bool useDistCalc, bool useFaceAngleCalc, float distTolerance, float angleTolerance, bool updateAllFace, bool renderSelf, bool renderEnvironment, int layer, ElementaryRenderable *parentRenderable, TechniqueGroup *parentTechniqueGroup) | CubeMapRenderTechnique |
cubeMapResolution | CubeMapRenderTechnique | [protected]
DistanceCubeMapRenderTechnique::cubeMapRunChanged(RenderingRun *run)=0 | CubeMapRenderTechnique | [protected, pure virtual]
OgreCubeMapRenderTechnique::cubeMapRunChanged(RenderingRun *run) | OgreCubeMapRenderTechnique | [protected, virtual]
DistanceCubeMapRenderTechnique::cubeMapRunUpdated(RenderingRun *run)=0 | CubeMapRenderTechnique | [protected, pure virtual]
OgreCubeMapRenderTechnique::cubeMapRunUpdated(RenderingRun *run) | OgreCubeMapRenderTechnique | [protected, virtual]
cubeMapUpdateInterval | CubeMapRenderTechnique | [protected]
DistanceCubeMapRenderTechnique(unsigned long startFrame, unsigned long cubeMapUpdateInterval, unsigned int cubeMapResolution, bool useDistCalc, bool useFaceAngleCalc, float distTolerance, float angleTolerance, bool updateAllFace, bool renderSelf, bool renderEnvironment, int layer, ElementaryRenderable *parentRenderable, TechniqueGroup *parentTechniqueGroup) | DistanceCubeMapRenderTechnique |
distanceCubeMapRunChanged(RenderingRun *run) | OgreDistanceCubeMapRenderTechnique | [protected, virtual]
distanceCubeMapRunUpdated(RenderingRun *run) | OgreDistanceCubeMapRenderTechnique | [protected, virtual]
distTolerance | CubeMapRenderTechnique | [protected]
environmentMaterial | OgreCubeMapRenderTechnique | [protected]
getMinMax | OgreCubeMapRenderTechnique | [protected]
getParentRenderable() | RenderTechnique | [inline]
layer | CubeMapRenderTechnique | [protected]
maxVariableName | OgreCubeMapRenderTechnique | [protected]
minVariableName | OgreCubeMapRenderTechnique | [protected]
OgreCubeMapRenderTechnique(unsigned long startFrame, unsigned long cubeMapUpdateInterval, unsigned int cubeMapResolution, unsigned char texID, bool useDistCalc, bool useFaceAngleCalc, float distTolerance, float angleTolerance, bool updateAllFace, bool renderSelf, bool renderEnvironment, String selfMaterial, String environmentMaterial, int layer, bool getMinMax, bool attachToTexUnit, String minVariableName, String maxVariableName, Pass *pass, OgreRenderable *parentRenderable, OgreTechniqueGroup *parentTechniqueGroup, bool createCubeRun=false) | OgreCubeMapRenderTechnique |
OgreDistanceCubeMapRenderTechnique(unsigned long startFrame, unsigned long cubeMapUpdateInterval, unsigned int cubeMapResolution, unsigned char texID, bool useDistCalc, bool useFaceAngleCalc, float distTolerance, float angleTolerance, bool updateAllFace, bool renderSelf, bool renderEnvironment, String selfMaterial, String environmentMaterial, int layer, bool getMinMax, bool attachToTexUnit, String minVariableName, String maxVariableName, Pass *pass, OgreRenderable *parentRenderable, OgreTechniqueGroup *parentTechniqueGroup) | OgreDistanceCubeMapRenderTechnique |
OgreRenderTechnique(Pass *pass, OgreRenderable *parentRenderable, OgreTechniqueGroup *parentTechniqueGroup) | OgreRenderTechnique |
parentOgreRenderable | OgreRenderTechnique | [protected]
parentOgreTechniqueGroup | OgreRenderTechnique | [protected]
parentRenderable | RenderTechnique | [protected]
parentTechniqueGroup | RenderTechnique | [protected]
pass | OgreRenderTechnique | [protected]
renderEnvironment | CubeMapRenderTechnique | [protected]
renderSelf | CubeMapRenderTechnique | [protected]
RenderTechnique(ElementaryRenderable *parentRenderable, TechniqueGroup *parentTechniqueGroup) | RenderTechnique |
runChanged(RenderingRunType runType, RenderingRun *run) | DistanceCubeMapRenderTechnique | [virtual]
runUpdated(RenderingRunType runType, RenderingRun *run) | DistanceCubeMapRenderTechnique | [virtual]
selfMaterial | OgreCubeMapRenderTechnique | [protected]
sharedRuns | RenderTechnique | [protected]
startFrame | CubeMapRenderTechnique | [protected]
texID | OgreCubeMapRenderTechnique | [protected]
update(unsigned long frameNum) | OgreDistanceCubeMapRenderTechnique | [virtual]
updateAllFace | CubeMapRenderTechnique | [protected]
useDistCalc | CubeMapRenderTechnique | [protected]
useFaceAngleCalc | CubeMapRenderTechnique | [protected]
~OgreCubeMapRenderTechnique() | OgreCubeMapRenderTechnique |
~OgreDistanceCubeMapRenderTechnique() | OgreDistanceCubeMapRenderTechnique |

Generated on Wed Mar 28 11:48:54 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: Member List

OgreDistanceCubeMapRenderTechniqueFactory Member List

This is the complete list of members for OgreDistanceCubeMapRenderTechniqueFactory, including all inherited members.

AttribParserList typedef | RenderTechniqueFactory | [protected]
attributeParsers | RenderTechniqueFactory | [protected]
createInstance(IllumTechniqueParams *params, Pass *pass, OgreRenderable *parentRenderable, OgreTechniqueGroup *parentTechniqueGroup) | OgreDistanceCubeMapRenderTechniqueFactory | [virtual]
ILLUM_ATTRIBUTE_PARSER typedef | RenderTechniqueFactory | [protected]
isType(String type) | RenderTechniqueFactory | [inline]
OgreCubeMapRenderTechniqueFactory() | OgreCubeMapRenderTechniqueFactory |
OgreDistanceCubeMapRenderTechniqueFactory() | OgreDistanceCubeMapRenderTechniqueFactory |
parseParams(IllumTechniqueParams *params) | RenderTechniqueFactory | [virtual]
typeName | RenderTechniqueFactory | [protected]

Generated on Wed Mar 28 11:48:55 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: Member List

OgreFireRenderTechnique Member List

This is the complete list of members for OgreFireRenderTechnique, including all inherited members.

asOgreRenderTechnique() | OgreRenderTechnique | [inline, virtual]
depthTexID | OgreFireRenderTechnique | [protected]
getParentRenderable() | RenderTechnique | [inline]
OgreFireRenderTechnique(unsigned char depthTexID, Pass *pass, OgreRenderable *parentRenderable, OgreTechniqueGroup *parentTechniqueGroup) | OgreFireRenderTechnique |
OgreRenderTechnique(Pass *pass, OgreRenderable *parentRenderable, OgreTechniqueGroup *parentTechniqueGroup) | OgreRenderTechnique |
parentOgreRenderable | OgreRenderTechnique | [protected]
parentOgreTechniqueGroup | OgreRenderTechnique | [protected]
parentRenderable | RenderTechnique | [protected]
parentTechniqueGroup | RenderTechnique | [protected]
pass | OgreRenderTechnique | [protected]
postAllUpdates() | UpdateListener | [inline, virtual]
preAllUpdates() | OgreFireRenderTechnique | [virtual]
RenderTechnique(ElementaryRenderable *parentRenderable, TechniqueGroup *parentTechniqueGroup) | RenderTechnique |
runChanged(RenderingRunType runType, RenderingRun *run) | RenderTechnique | [inline, virtual]
runUpdated(RenderingRunType runType, RenderingRun *run) | RenderTechnique | [inline, virtual]
sharedRuns | RenderTechnique | [protected]
update(unsigned long frameNum) | OgreFireRenderTechnique | [virtual]

Generated on Wed Mar 28 11:48:55 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: Member List

OgreFireRenderTechniqueFactory Member List

This is the complete list of members for OgreFireRenderTechniqueFactory, including all inherited members.

AttribParserList typedef | RenderTechniqueFactory | [protected]
attributeParsers | RenderTechniqueFactory | [protected]
createInstance(IllumTechniqueParams *params, Pass *pass, OgreRenderable *parentRenderable, OgreTechniqueGroup *parentTechniqueGroup) | OgreFireRenderTechniqueFactory | [virtual]
ILLUM_ATTRIBUTE_PARSER typedef | RenderTechniqueFactory | [protected]
isType(String type) | RenderTechniqueFactory | [inline]
parseParams(IllumTechniqueParams *params) | RenderTechniqueFactory | [virtual]
typeName | RenderTechniqueFactory | [protected]

Generated on Wed Mar 28 11:48:55 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: Member List

OgreFocusingMapRenderingRun Member List

This is the complete list of members for OgreFocusingMapRenderingRun, including all inherited members.

asOgreRenderingRun() | OgreRenderingRun | [inline, virtual]
asOgreRenderingRun() | OgreRenderingRun | [inline, virtual]
camera | OgreFocusingMapRenderingRun | [protected]
canJoin(RenderingRun *run) | RenderingRun | [inline, virtual]
createCubeRenderTexture(String name, const Vector3 position, unsigned int resolution=512, PixelFormat format=PF_FLOAT16_RGBA, int numMips=0, ColourValue clearColor=ColourValue::Black) | OgreRenderingRun | [protected]
createCubeRenderTexture(String name, const Vector3 position, unsigned int resolution=512, PixelFormat format=PF_FLOAT16_RGBA, int numMips=0, ColourValue clearColor=ColourValue::Black) | OgreRenderingRun | [protected]
createFocusingMap() | OgreFocusingMapRenderingRun | [inline, protected]
focusingMapSize | OgreFocusingMapRenderingRun | [protected]
focusingTexture | OgreFocusingMapRenderingRun | [protected]
fullscreenGrid | OgreRenderingRun | [protected]
fullScreenQuad | OgreRenderingRun | [protected, static]
fullScreenQuad | OgreRenderingRun | [protected, static]
fullScreenQuadEntity | OgreRenderingRun | [protected, static]
fullScreenQuadEntity | OgreRenderingRun | [protected, static]
fullScreenQuadNode | OgreRenderingRun | [protected, static]
fullScreenQuadNode | OgreRenderingRun | [protected, static]
getCubeMapFaceDirection(unsigned char faceId) | OgreRenderingRun | [protected]
getCubeMapFaceDirection(unsigned char faceId) | OgreRenderingRun | [protected]
getFocusingTextureName() | OgreFocusingMapRenderingRun | [inline]
getMinMax(Vector3 &min, Vector3 &max) | OgreFocusingMapRenderingRun |
lastupdated | RenderingRun | [protected]
lightMatrix | OgreFocusingMapRenderingRun | [protected]
name | OgreFocusingMapRenderingRun | [protected]
needUpdate(unsigned long frameNum) | OgreFocusingMapRenderingRun | [inline, protected, virtual]
OgreFocusingMapRenderingRun(String name, Matrix4 lightMatrix, unsigned int focusingMapSize) | OgreFocusingMapRenderingRun |
OgreRenderingRun(unsigned long startFrame, unsigned long updateInterval) | OgreRenderingRun | [inline]
OgreRenderingRun(unsigned long startFrame, unsigned long updateInterval) | OgreRenderingRun | [inline]
pixelSprites | OgreRenderingRun | [protected]
pixelSprites | OgreRenderingRun | [protected]
renderFullscreenGrid(String &materialName, RenderTarget *rt, int width, int height) | OgreRenderingRun | [protected]
renderFullscreenQuad(String materialName, RenderTarget *target) | OgreRenderingRun | [protected]
renderFullscreenQuad(String materialName, RenderTarget *target) | OgreRenderingRun | [protected]
RenderingRun(unsigned long startFrame, unsigned long updateInterval) | RenderingRun |
renderPixelSprites(String &materialName, RenderTarget *rt, int width, int height) | OgreRenderingRun | [protected]
renderPixelSprites(String &materialName, RenderTarget *rt, int width, int height) | OgreRenderingRun | [protected]
restoreMaterials() | OgreRenderingRun | [protected]
restoreMaterials() | OgreRenderingRun | [protected]
setCameraMatrices(const Matrix4 &view, const Matrix4 &projection) | OgreFocusingMapRenderingRun |
setLightMatrix(Matrix4 &m) | OgreFocusingMapRenderingRun | [inline]
setMaterialForRenderables(String &materialName, RenderQueue *rq) | OgreRenderingRun | [protected]
setMaterialForRenderables(String &materialName, RenderQueue *rq, bool solidsonly=false) | OgreRenderingRun | [protected]
setMaterialForVisibles(String &materialName, Camera *cam, bool shadowcastersonly=false) | OgreRenderingRun | [protected]
setMaterialForVisibles(String &materialName, Camera *cam, bool shadowcastersonly=false, bool solidsonly=false) | OgreRenderingRun | [protected]
spriteSetName | OgreRenderingRun | [protected]
startFrame | RenderingRun | [protected]
update(unsigned long frameNum) | RenderingRun | [inline]
updateFrame(unsigned long frameNum) | OgreFocusingMapRenderingRun | [protected, virtual]
updateInterval | RenderingRun | [protected]
visibleObjects | OgreRenderingRun | [protected]
visibleObjects | OgreRenderingRun | [protected]

Generated on Wed Mar 28 11:48:55 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: Member List

OgreHierarchicalParticleSystemTechnique Member List

This is the complete list of members for OgreHierarchicalParticleSystemTechnique, including all inherited members.

asOgreRenderTechnique() | OgreRenderTechnique | [inline, virtual]
childPSysName | OgreHierarchicalParticleSystemTechnique | [protected]
childPSysScriptName | OgreHierarchicalParticleSystemTechnique | [protected]
createChildPSysRenderingRun() | OgreHierarchicalParticleSystemTechnique | [protected, virtual]
FParamRadius | OgreHierarchicalParticleSystemTechnique | [protected]
getParentRenderable() | RenderTechnique | [inline]
HierarchicalParticleSystemTechnique(unsigned long startFrame, unsigned long impostorUpdateInterval, unsigned int impostorResolution, bool useDistCalc, bool perspectiveRendering, ElementaryRenderable *parentRenderable, TechniqueGroup *parentTechniqueGroup) | HierarchicalParticleSystemTechnique |
impostorChanged(RenderingRun *run) | OgreHierarchicalParticleSystemTechnique | [protected, virtual]
impostorMaterialName | OgreHierarchicalParticleSystemTechnique | [protected]
impostorResolution | HierarchicalParticleSystemTechnique | [protected]
impostorTexID | OgreHierarchicalParticleSystemTechnique | [protected]
impostorUpdated(RenderingRun *run) | OgreHierarchicalParticleSystemTechnique | [protected, virtual]
impostorUpdateInterval | HierarchicalParticleSystemTechnique | [protected]
OgreHierarchicalParticleSystemTechnique(unsigned long startFrame, unsigned long impostorUpdateInterval, unsigned int impostorResolution, unsigned char impostorTexID, bool useDistCalc, bool perspectiveRendering, String childPSysScriptName, bool useOwnMaterial, String impostorMaterialName, bool useVParam, String VParamRadius, bool useFParam, String FParamRadius, Pass *pass, OgreRenderable *parentRenderable, OgreTechniqueGroup *parentTechniqueGroup) | OgreHierarchicalParticleSystemTechnique |
OgreRenderTechnique(Pass *pass, OgreRenderable *parentRenderable, OgreTechniqueGroup *parentTechniqueGroup) | OgreRenderTechnique |
parentOgreRenderable | OgreRenderTechnique | [protected]
parentOgreTechniqueGroup | OgreRenderTechnique | [protected]
parentRenderable | RenderTechnique | [protected]
parentTechniqueGroup | RenderTechnique | [protected]
pass | OgreRenderTechnique | [protected]
perspectiveRendering | HierarchicalParticleSystemTechnique | [protected]
RenderTechnique(ElementaryRenderable *parentRenderable, TechniqueGroup *parentTechniqueGroup) | RenderTechnique |
OgreRenderTechnique::runChanged(RenderingRunType runType, RenderingRun *run) | RenderTechnique | [inline, virtual]
HierarchicalParticleSystemTechnique::runChanged(RenderingRunType runType, RenderingRun *run) | HierarchicalParticleSystemTechnique | [virtual]
OgreRenderTechnique::runUpdated(RenderingRunType runType, RenderingRun *run) | RenderTechnique | [inline, virtual]
HierarchicalParticleSystemTechnique::runUpdated(RenderingRunType runType, RenderingRun *run) | HierarchicalParticleSystemTechnique | [virtual]
sharedRuns | RenderTechnique | [protected]
startFrame | HierarchicalParticleSystemTechnique | [protected]
OgreRenderTechnique::update(unsigned long frameNum) | RenderTechnique | [inline, virtual]
HierarchicalParticleSystemTechnique::update(unsigned long frameNum) | HierarchicalParticleSystemTechnique | [virtual]
useDistCalc | HierarchicalParticleSystemTechnique | [protected]
useFParam | OgreHierarchicalParticleSystemTechnique | [protected]
useOwnMaterial | OgreHierarchicalParticleSystemTechnique | [protected]
useVParam | OgreHierarchicalParticleSystemTechnique | [protected]
VParamRadius | OgreHierarchicalParticleSystemTechnique | [protected]
~OgreHierarchicalParticleSystemTechnique() | OgreHierarchicalParticleSystemTechnique |

Generated on Wed Mar 28 11:48:56 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: Member List

OgreHierarchicalParticleSystemTechniqueFactory Member List

This is the complete list of members for OgreHierarchicalParticleSystemTechniqueFactory, including all inherited members.

AttribParserList typedef | RenderTechniqueFactory | [protected]
attributeParsers | RenderTechniqueFactory | [protected]
createInstance(IllumTechniqueParams *params, Pass *pass, OgreRenderable *parentRenderable, OgreTechniqueGroup *parentTechniqueGroup) | OgreHierarchicalParticleSystemTechniqueFactory | [virtual]
ILLUM_ATTRIBUTE_PARSER typedef | RenderTechniqueFactory | [protected]
isType(String type) | RenderTechniqueFactory | [inline]
OgreHierarchicalParticleSystemTechniqueFactory() | OgreHierarchicalParticleSystemTechniqueFactory |
parseParams(IllumTechniqueParams *params) | RenderTechniqueFactory | [virtual]
typeName | RenderTechniqueFactory | [protected]

Generated on Wed Mar 28 11:48:56 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: Member List

OgreIllumVolumeRenderTechnique Member List

This is the complete list of members for OgreIllumVolumeRenderTechnique, including all inherited members.

asOgreRenderTechnique() | OgreRenderTechnique | [inline, virtual]
createLightVolumeRenderingRun() | OgreIllumVolumeRenderTechnique | [protected, virtual]
getParentRenderable() | RenderTechnique | [inline]
hierarchicalImpostorUpdated(RenderingRun *run) | OgreIllumVolumeRenderTechnique | [protected, virtual]
illumTexID | OgreIllumVolumeRenderTechnique | [protected]
illumTextureResolution | IllumVolumeRenderTechnique | [protected]
IllumVolumeRenderTechnique(unsigned long startFrame, unsigned long illumVolumeUpdateInterval, unsigned int illumTextureResolution, unsigned int textureDepth, bool useDistCalc, bool useHierarchicalImpostor, ElementaryRenderable *parentRenderable, TechniqueGroup *parentTechniqueGroup) | IllumVolumeRenderTechnique |
illumVolumeUpdateInterval | IllumVolumeRenderTechnique | [protected]
impostorTexID | OgreIllumVolumeRenderTechnique | [protected]
lightMatrixGPUParamName | OgreIllumVolumeRenderTechnique | [protected]
lightVolumeChanged(RenderingRun *run) | OgreIllumVolumeRenderTechnique | [protected, virtual]
lightVolumeUpdated(RenderingRun *run) | OgreIllumVolumeRenderTechnique | [protected, virtual]
materialName | OgreIllumVolumeRenderTechnique | [protected]
OgreIllumVolumeRenderTechnique(unsigned long startFrame, unsigned long illumVolumeUpdateInterval, unsigned int illumTextureResolution, unsigned int textureDepth, unsigned char illumTexID, bool useDistCalc, String materialName, String lightMatrixGPUParamName, bool useHierarchicalImpostor, unsigned char impostorTexID, Pass *pass, OgreRenderable *parentRenderable, OgreTechniqueGroup *parentTechniqueGroup) | OgreIllumVolumeRenderTechnique |
OgreRenderTechnique(Pass *pass, OgreRenderable *parentRenderable, OgreTechniqueGroup *parentTechniqueGroup) | OgreRenderTechnique |
parentOgreRenderable | OgreRenderTechnique | [protected]
parentOgreTechniqueGroup | OgreRenderTechnique | [protected]
parentRenderable | RenderTechnique | [protected]
parentTechniqueGroup | RenderTechnique | [protected]
pass | OgreRenderTechnique | [protected]
RenderTechnique(ElementaryRenderable *parentRenderable, TechniqueGroup *parentTechniqueGroup) | RenderTechnique |
OgreRenderTechnique::runChanged(RenderingRunType runType, RenderingRun *run) | RenderTechnique | [inline, virtual]
IllumVolumeRenderTechnique::runChanged(RenderingRunType runType, RenderingRun *run) | IllumVolumeRenderTechnique | [virtual]
OgreRenderTechnique::runUpdated(RenderingRunType runType, RenderingRun *run) | RenderTechnique | [inline, virtual]
IllumVolumeRenderTechnique::runUpdated(RenderingRunType runType, RenderingRun *run) | IllumVolumeRenderTechnique | [virtual]
sharedRuns | RenderTechnique | [protected]
startFrame | IllumVolumeRenderTechnique | [protected]
textureDepth | IllumVolumeRenderTechnique | [protected]
OgreRenderTechnique::update(unsigned long frameNum) | RenderTechnique | [inline, virtual]
IllumVolumeRenderTechnique::update(unsigned long frameNum) | IllumVolumeRenderTechnique | [virtual]
useDistCalc | IllumVolumeRenderTechnique | [protected]
useHierarchicalImpostor | IllumVolumeRenderTechnique | [protected]
~OgreIllumVolumeRenderTechnique() | OgreIllumVolumeRenderTechnique |

Generated on Wed Mar 28 11:48:56 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: Member List

OgreIllumVolumeRenderTechniqueFactory Member List

This is the complete list of members for OgreIllumVolumeRenderTechniqueFactory, including all inherited members.

AttribParserList typedef | RenderTechniqueFactory | [protected]
attributeParsers | RenderTechniqueFactory | [protected]
createInstance(IllumTechniqueParams *params, Pass *pass, OgreRenderable *parentRenderable, OgreTechniqueGroup *parentTechniqueGroup) | OgreIllumVolumeRenderTechniqueFactory | [virtual]
ILLUM_ATTRIBUTE_PARSER typedef | RenderTechniqueFactory | [protected]
isType(String type) | RenderTechniqueFactory | [inline]
OgreIllumVolumeRenderTechniqueFactory() | OgreIllumVolumeRenderTechniqueFactory |
parseParams(IllumTechniqueParams *params) | RenderTechniqueFactory | [virtual]
typeName | RenderTechniqueFactory | [protected]

Generated on Wed Mar 28 11:48:56 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: Member List

OgreIlluminationManager Member List

This is the complete list of members for OgreIlluminationManager, including all inherited members.

addPathMapClusterLength(unsigned int l) | OgreIlluminationManager | [inline]
addPathMapClusters(String subEntityName, PathMapClusters clusters) | OgreIlluminationManager | [inline]
addPathMapEntryPoint(PathMapEntryPoint p) | OgreIlluminationManager | [inline]
addRenderTechniqueFactory(RenderTechniqueFactory *factory) | OgreIlluminationManager | [inline]
addSharedRuns(SharedRuns *runs) | OgreIlluminationManager |
addUpdateListener(UpdateListener *l) | OgreIlluminationManager | [inline]
areaLightRadius | OgreIlluminationManager | [protected]
blurSM | OgreIlluminationManager | [protected]
createGlobalRun(RenderingRunType runType) | OgreIlluminationManager |
createPerLightRun(String lightName, RenderingRunType runType) | OgreIlluminationManager |
createTechnique(IllumTechniqueParams *params, Pass *pass, OgreRenderable *rend, OgreSharedRuns *sRuns) | OgreIlluminationManager | [protected]
fillVisibleList(RenderQueue *rq) | OgreIlluminationManager | [protected]
findRenderableInParticleSystem(ParticleSystem *system) | OgreIlluminationManager | [protected]
focusingMapSize | OgreIlluminationManager | [protected]
focusingSM | OgreIlluminationManager | [protected]
frameStarted(const FrameEvent &evt) | OgreIlluminationManager | [inline]
getAreaLightRadius() | OgreIlluminationManager | [inline]
getBlurShadowMap() | OgreIlluminationManager | [inline]
getFocusingShadowMap() | OgreIlluminationManager | [inline]
getGlobalRun(RenderingRunType runType) | OgreIlluminationManager |
getMainCamera() | OgreIlluminationManager | [inline]
getMainViewport() | OgreIlluminationManager | [inline]
getMaxJoinRadius() | OgreIlluminationManager | [inline]
getMaxJoinRadius(RenderingRunType type) | OgreIlluminationManager | [inline]
getNearestCausticCasters(Vector3 position, std::vector< OgreSharedRuns * > *nearestcasters, unsigned int maxCount) | OgreIlluminationManager |
getPathMapClusterLength(unsigned int index) | OgreIlluminationManager | [inline]
getPathMapClusterLengthsSize() | OgreIlluminationManager | [inline]
getPathMapClusters(String subEntityName) | OgreIlluminationManager | [inline]
getPathMapEntryPoints() | OgreIlluminationManager | [inline]
getPerLightRun(String lightName, RenderingRunType runType) | OgreIlluminationManager |
getSingleton() | OgreIlluminationManager | [static]
getUseLISPSM() | OgreIlluminationManager | [inline]
globalSharedRuns | OgreIlluminationManager | [protected]
initTechniques() | OgreIlluminationManager |
initTechniques(Entity *e) | OgreIlluminationManager |
initTechniques(BillboardSet *bbs, ParticleSystem *sys) | OgreIlluminationManager |
instance | OgreIlluminationManager | [protected, static]
joinSharedRuns() | OgreIlluminationManager |
mainCamera | OgreIlluminationManager | [protected]
mainViewport | OgreIlluminationManager | [protected]
maxRad | OgreIlluminationManager | [protected]
maxRads | OgreIlluminationManager | [protected]
OgreIlluminationManager() | OgreIlluminationManager | [protected]
pathMapClusterLengths | OgreIlluminationManager | [protected]
pathMapClusters | OgreIlluminationManager | [protected]
pathMapEntryPoints | OgreIlluminationManager | [protected]
perLightRuns | OgreIlluminationManager | [protected]
phaseTextureSize | OgreIlluminationManager | [protected]
postAllUpdates() | OgreIlluminationManager | [protected]
preAllUpdates() | OgreIlluminationManager | [protected]
savePhaseTextureToFile(String filename) | OgreIlluminationManager |
setAreaLigtRadius(float radius) | OgreIlluminationManager | [inline]
setBlurShadowMap(bool use) | OgreIlluminationManager | [inline]
setFireRenderTargetSize(int size) | OgreIlluminationManager | [inline]
setFocusingMapSize(unsigned int size) | OgreIlluminationManager | [inline]
setFocusingSM(bool use) | OgreIlluminationManager | [inline]
setMainCamera(Camera *camera) | OgreIlluminationManager | [inline]
setMainViewport(Viewport *viewport) | OgreIlluminationManager | [inline]
setMaxJoinRadius(float rad) | OgreIlluminationManager | [inline]
setMaxJoinRadius(RenderingRunType type, float rad) | OgreIlluminationManager | [inline]
setPhaseTextureSize(unsigned int size) | OgreIlluminationManager | [inline]
setShadowMapMaterialName(String name) | OgreIlluminationManager | [inline]
setShadowMapSize(unsigned int size) | OgreIlluminationManager | [inline]
setUseLISPSM(bool use) | OgreIlluminationManager | [inline]
shadowMapMaterialName | OgreIlluminationManager | [protected]
shadowMapSize | OgreIlluminationManager | [protected]
sharedRunJoin(SharedRuns *old1, SharedRuns *old2, SharedRuns *newsr) | OgreIlluminationManager |
sharedRunRoots | OgreIlluminationManager | [protected]
sharedRunSplit(SharedRuns *old, SharedRuns *new1, SharedRuns *new2) | OgreIlluminationManager |
techniqueFactories | OgreIlluminationManager | [protected]
update(unsigned long frameNumber, RenderTarget *rt) | OgreIlluminationManager |
updateGlobalRun(RenderingRunType runType, unsigned long frameNum) | OgreIlluminationManager |
updateListeners | OgreIlluminationManager | [protected]
updatePerLightRun(String lightName, RenderingRunType runType, unsigned long frameNum) | OgreIlluminationManager |
useLISPSM | OgreIlluminationManager | [protected]
visibleObjects | OgreIlluminationManager | [protected]
visitor | OgreIlluminationManager | [protected]
~OgreIlluminationManager() | OgreIlluminationManager | [protected, virtual]

Generated on Wed Mar 28 11:48:56 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: Member List

OgreLightVolumeRenderingRun Member List

This is the complete list of members for OgreLightVolumeRenderingRun, including all inherited members.

asOgreRenderingRun() | OgreRenderingRun | [inline, virtual]
asOgreRenderingRun() | OgreRenderingRun | [inline, virtual]
canJoin(RenderingRun *run) | RenderingRun | [inline, virtual]
createCubeRenderTexture(String name, const Vector3 position, unsigned int resolution=512, PixelFormat format=PF_FLOAT16_RGBA, int numMips=0, ColourValue clearColor=ColourValue::Black) | OgreRenderingRun | [protected]
createCubeRenderTexture(String name, const Vector3 position, unsigned int resolution=512, PixelFormat format=PF_FLOAT16_RGBA, int numMips=0, ColourValue clearColor=ColourValue::Black) | OgreRenderingRun | [protected]
createLightVolumeMap() | OgreLightVolumeRenderingRun | [inline, protected, virtual]
fullscreenGrid | OgreRenderingRun | [protected]
fullScreenQuad | OgreRenderingRun | [protected, static]
fullScreenQuad | OgreRenderingRun | [protected, static]
fullScreenQuadEntity | OgreRenderingRun | [protected, static]
fullScreenQuadEntity | OgreRenderingRun | [protected, static]
fullScreenQuadNode | OgreRenderingRun | [protected, static]
fullScreenQuadNode | OgreRenderingRun | [protected, static]
getCubeMapFaceDirection(unsigned char faceId) | OgreRenderingRun | [protected]
getCubeMapFaceDirection(unsigned char faceId) | OgreRenderingRun | [protected]
getLightViewProjectionMatrix() | OgreLightVolumeRenderingRun | [inline]
getLightVolumeTextureName() | OgreLightVolumeRenderingRun | [inline]
lastupdated | RenderingRun | [protected]
light | OgreLightVolumeRenderingRun | [protected]
lightVolumeCamera | OgreLightVolumeRenderingRun | [protected]
LightVolumeRenderingRun(unsigned long startFrame, unsigned long updateInterval, unsigned int resolution, unsigned int textureDepth) | LightVolumeRenderingRun | [inline]
materialName | OgreLightVolumeRenderingRun | [protected]
name | OgreLightVolumeRenderingRun | [protected]
needUpdate(unsigned long frameNum) | RenderingRun | [inline, protected, virtual]
OgreLightVolumeRenderingRun(OgreSharedRuns *sharedRuns, String name, unsigned long startFrame, unsigned long updateInterval, unsigned int resolution, unsigned int textureDepth, String materialName) | OgreLightVolumeRenderingRun |
OgreRenderingRun(unsigned long startFrame, unsigned long updateInterval) | OgreRenderingRun | [inline]
OgreRenderingRun(unsigned long startFrame, unsigned long updateInterval) | OgreRenderingRun | [inline]
pixelSprites | OgreRenderingRun | [protected]
pixelSprites | OgreRenderingRun | [protected]
refreshLight() | OgreLightVolumeRenderingRun |
renderFullscreenGrid(String &materialName, RenderTarget *rt, int width, int height) | OgreRenderingRun | [protected]
renderFullscreenQuad(String materialName, RenderTarget *target) | OgreRenderingRun | [protected]
renderFullscreenQuad(String materialName, RenderTarget *target) | OgreRenderingRun | [protected]
RenderingRun(unsigned long startFrame, unsigned long updateInterval) | RenderingRun |
renderPixelSprites(String &materialName, RenderTarget *rt, int width, int height) | OgreRenderingRun | [protected]
renderPixelSprites(String &materialName, RenderTarget *rt, int width, int height) | OgreRenderingRun | [protected]
resolution | LightVolumeRenderingRun | [protected]
restoreMaterials() | OgreRenderingRun | [protected]
restoreMaterials() | OgreRenderingRun | [protected]
setMaterialForRenderables(String &materialName, RenderQueue *rq) | OgreRenderingRun | [protected]
setMaterialForRenderables(String &materialName, RenderQueue *rq, bool solidsonly=false) | OgreRenderingRun | [protected]
setMaterialForVisibles(String &materialName, Camera *cam, bool shadowcastersonly=false) | OgreRenderingRun | [protected]
setMaterialForVisibles(String &materialName, Camera *cam, bool shadowcastersonly=false, bool solidsonly=false) | OgreRenderingRun | [protected]
sharedRuns | OgreLightVolumeRenderingRun | [protected]
spriteSetName | OgreRenderingRun | [protected]
startFrame | RenderingRun | [protected]
systemRadius | OgreLightVolumeRenderingRun | [protected]
textureDepth | LightVolumeRenderingRun | [protected]
update(unsigned long frameNum) | RenderingRun | [inline]
updateFrame(unsigned long frameNum) | OgreLightVolumeRenderingRun | [protected, virtual]
updateInterval | RenderingRun | [protected]
visibleObjects | OgreRenderingRun | [protected]
visibleObjects | OgreRenderingRun | [protected]

Generated on Wed Mar 28 11:48:57 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: Member List

OgrePMEntryPointMapRenderingRun Member List

This is the complete list of members for OgrePMEntryPointMapRenderingRun, including all inherited members.

asOgreRenderingRun() | OgreRenderingRun | [inline, virtual]
asOgreRenderingRun() | OgreRenderingRun | [inline, virtual]
canJoin(RenderingRun *run) | RenderingRun | [inline, virtual]
clusterLengthTexture | OgrePMEntryPointMapRenderingRun | [protected]
createCubeRenderTexture(String name, const Vector3 position, unsigned int resolution=512, PixelFormat format=PF_FLOAT16_RGBA, int numMips=0, ColourValue clearColor=ColourValue::Black) | OgreRenderingRun | [protected]
createCubeRenderTexture(String name, const Vector3 position, unsigned int resolution=512, PixelFormat format=PF_FLOAT16_RGBA, int numMips=0, ColourValue clearColor=ColourValue::Black) | OgreRenderingRun | [protected]
createEntryPointMap() | OgrePMEntryPointMapRenderingRun | [inline, protected]
entryPointTexture | OgrePMEntryPointMapRenderingRun | [protected]
fullscreenGrid | OgreRenderingRun | [protected]
fullScreenQuad | OgreRenderingRun | [protected, static]
fullScreenQuad | OgreRenderingRun | [protected, static]
fullScreenQuadEntity | OgreRenderingRun | [protected, static]
fullScreenQuadEntity | OgreRenderingRun | [protected, static]
fullScreenQuadNode | OgreRenderingRun | [protected, static]
fullScreenQuadNode | OgreRenderingRun | [protected, static]
getClusterLengthTextureName() | OgrePMEntryPointMapRenderingRun | [inline]
getCubeMapFaceDirection(unsigned char faceId) | OgreRenderingRun | [protected]
getCubeMapFaceDirection(unsigned char faceId) | OgreRenderingRun | [protected]
getEntryPointTextureName() | OgrePMEntryPointMapRenderingRun | [inline]
lastupdated | RenderingRun | [protected]
name | OgrePMEntryPointMapRenderingRun | [protected]
needUpdate(unsigned long frameNum) | OgrePMEntryPointMapRenderingRun | [inline, protected, virtual]
OgrePMEntryPointMapRenderingRun(String name) | OgrePMEntryPointMapRenderingRun |
OgreRenderingRun(unsigned long startFrame, unsigned long updateInterval) | OgreRenderingRun | [inline]
OgreRenderingRun(unsigned long startFrame, unsigned long updateInterval) | OgreRenderingRun | [inline]
pixelSprites | OgreRenderingRun | [protected]
pixelSprites | OgreRenderingRun | [protected]
renderFullscreenGrid(String &materialName, RenderTarget *rt, int width, int height) | OgreRenderingRun | [protected]
renderFullscreenQuad(String materialName, RenderTarget *target) | OgreRenderingRun | [protected]
renderFullscreenQuad(String materialName, RenderTarget *target) | OgreRenderingRun | [protected]
RenderingRun(unsigned long startFrame, unsigned long updateInterval) | RenderingRun |
renderPixelSprites(String &materialName, RenderTarget *rt, int width, int height) | OgreRenderingRun | [protected]
renderPixelSprites(String &materialName, RenderTarget *rt, int width, int height) | OgreRenderingRun | [protected]
restoreMaterials() | OgreRenderingRun | [protected]
restoreMaterials() | OgreRenderingRun | [protected]
setMaterialForRenderables(String &materialName, RenderQueue *rq) | OgreRenderingRun | [protected]
setMaterialForRenderables(String &materialName, RenderQueue *rq, bool solidsonly=false) | OgreRenderingRun | [protected]
setMaterialForVisibles(String &materialName, Camera *cam, bool shadowcastersonly=false) | OgreRenderingRun | [protected]
setMaterialForVisibles(String &materialName, Camera *cam, bool shadowcastersonly=false, bool solidsonly=false) | OgreRenderingRun | [protected]
spriteSetName | OgreRenderingRun | [protected]
startFrame | RenderingRun | [protected]
update(unsigned long frameNum) | RenderingRun | [inline]
updateFrame(unsigned long frameNum) | OgrePMEntryPointMapRenderingRun | [protected, virtual]
updateInterval | RenderingRun | [protected]
visibleObjects | OgreRenderingRun | [protected]
visibleObjects | OgreRenderingRun | [protected]

Generated on Wed Mar 28 11:48:58 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: Member List

OgrePMWeightComputeRenderingRun Member List

This is the complete list of members for OgrePMWeightComputeRenderingRun, including all inherited members.

allWeightsTexture | OgrePMWeightComputeRenderingRun | [protected]
asOgreRenderingRun() | OgreRenderingRun | [inline, virtual]
asOgreRenderingRun() | OgreRenderingRun | [inline, virtual]
canJoin(RenderingRun *run) | RenderingRun | [inline, virtual]
createCubeRenderTexture(String name, const Vector3 position, unsigned int resolution=512, PixelFormat format=PF_FLOAT16_RGBA, int numMips=0, ColourValue clearColor=ColourValue::Black) | OgreRenderingRun | [protected]
createCubeRenderTexture(String name, const Vector3 position, unsigned int resolution=512, PixelFormat format=PF_FLOAT16_RGBA, int numMips=0, ColourValue clearColor=ColourValue::Black) | OgreRenderingRun | [protected]
createWeightMap() | OgrePMWeightComputeRenderingRun | [inline, protected]
fullscreenGrid | OgreRenderingRun | [protected]
fullScreenQuad | OgreRenderingRun | [protected, static]
fullScreenQuad | OgreRenderingRun | [protected, static]
fullScreenQuadEntity | OgreRenderingRun | [protected, static]
fullScreenQuadEntity | OgreRenderingRun | [protected, static]
fullScreenQuadNode | OgreRenderingRun | [protected, static]
fullScreenQuadNode | OgreRenderingRun | [protected, static]
getCubeMapFaceDirection(unsigned char faceId) | OgreRenderingRun | [protected]
getCubeMapFaceDirection(unsigned char faceId) | OgreRenderingRun | [protected]
getPMWeightTetureName() | OgrePMWeightComputeRenderingRun | [inline]
lastupdated | RenderingRun | [protected]
light | OgrePMWeightComputeRenderingRun | [protected]
lightMatrix | OgrePMWeightComputeRenderingRun | [protected]
lightViewMatrix | OgrePMWeightComputeRenderingRun | [protected]
name | OgrePMWeightComputeRenderingRun | [protected]
needUpdate(unsigned long frameNum) | RenderingRun | [inline, protected, virtual]
OgrePMWeightComputeRenderingRun(String name, String LightName) | OgrePMWeightComputeRenderingRun |
OgreRenderingRun(unsigned long startFrame, unsigned long updateInterval) | OgreRenderingRun | [inline]
OgreRenderingRun(unsigned long startFrame, unsigned long updateInterval) | OgreRenderingRun | [inline]
pixelSprites | OgreRenderingRun | [protected]
pixelSprites | OgreRenderingRun | [protected]
renderFullscreenGrid(String &materialName, RenderTarget *rt, int width, int height) | OgreRenderingRun | [protected]
renderFullscreenQuad(String materialName, RenderTarget *target) | OgreRenderingRun | [protected]
renderFullscreenQuad(String materialName, RenderTarget *target) | OgreRenderingRun | [protected]
RenderingRun(unsigned long startFrame, unsigned long updateInterval) | RenderingRun |
renderPixelSprites(String &materialName, RenderTarget *rt, int width, int height) | OgreRenderingRun | [protected]
renderPixelSprites(String &materialName, RenderTarget *rt, int width, int height) | OgreRenderingRun | [protected]
restoreMaterials() | OgreRenderingRun | [protected]
restoreMaterials() | OgreRenderingRun | [protected]
setMaterialForRenderables(String &materialName, RenderQueue *rq) | OgreRenderingRun | [protected]
setMaterialForRenderables(String &materialName, RenderQueue *rq, bool solidsonly=false) | OgreRenderingRun | [protected]
setMaterialForVisibles(String &materialName, Camera *cam, bool shadowcastersonly=false) | OgreRenderingRun | [protected]
setMaterialForVisibles(String &materialName, Camera *cam, bool shadowcastersonly=false, bool solidsonly=false) | OgreRenderingRun | [protected]
spriteSetName | OgreRenderingRun | [protected]
startFrame | RenderingRun | [protected]
update(unsigned long frameNum) | RenderingRun | [inline]
updateFrame(unsigned long frameNum) | OgrePMWeightComputeRenderingRun | [protected, virtual]
updateInterval | RenderingRun | [protected]
visibleObjects | OgreRenderingRun | [protected]
visibleObjects | OgreRenderingRun | [protected]
weightTexture | OgrePMWeightComputeRenderingRun | [protected]

Generated on Wed Mar 28 11:48:58 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: Member List

OgrePathMapRenderTechnique Member List

This is the complete list of members for OgrePathMapRenderTechnique, including all inherited members.

asOgreRenderTechnique() | OgreRenderTechnique | [inline, virtual]
clusters | OgrePathMapRenderTechnique | [protected]
createWeightIndexTexture() | OgrePathMapRenderTechnique | [protected]
getParentRenderable() | RenderTechnique | [inline]
OgrePathMapRenderTechnique(Pass *pass, OgreRenderable *parentRenderable, OgreTechniqueGroup *parentTechniqueGroup) | OgrePathMapRenderTechnique |
OgreRenderTechnique(Pass *pass, OgreRenderable *parentRenderable, OgreTechniqueGroup *parentTechniqueGroup) | OgreRenderTechnique |
parentOgreRenderable | OgreRenderTechnique | [protected]
parentOgreTechniqueGroup | OgreRenderTechnique | [protected]
parentRenderable | RenderTechnique | [protected]
parentTechniqueGroup | RenderTechnique | [protected]
pass | OgreRenderTechnique | [protected]
pathMapPass | OgrePathMapRenderTechnique | [protected]
RenderTechnique(ElementaryRenderable *parentRenderable, TechniqueGroup *parentTechniqueGroup) | RenderTechnique |
runChanged(RenderingRunType runType, RenderingRun *run) | RenderTechnique | [inline, virtual]
runUpdated(RenderingRunType runType, RenderingRun *run) | RenderTechnique | [inline, virtual]
sharedRuns | RenderTechnique | [protected]
update(unsigned long frameNum) | OgrePathMapRenderTechnique | [virtual]
weightIndexTexture | OgrePathMapRenderTechnique | [protected]
~OgrePathMapRenderTechnique() | OgrePathMapRenderTechnique |

Generated on Wed Mar 28 11:48:57 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: Member List

OgrePathMapRenderTechniqueFactory Member List

This is the complete list of members for OgrePathMapRenderTechniqueFactory, including all inherited members.

AttribParserList typedef | RenderTechniqueFactory | [protected]
attributeParsers | RenderTechniqueFactory | [protected]
createInstance(IllumTechniqueParams *params, Pass *pass, OgreRenderable *parentRenderable, OgreTechniqueGroup *parentTechniqueGroup) | OgrePathMapRenderTechniqueFactory | [virtual]
ILLUM_ATTRIBUTE_PARSER typedef | RenderTechniqueFactory | [protected]
isType(String type) | RenderTechniqueFactory | [inline]
parseParams(IllumTechniqueParams *params) | RenderTechniqueFactory | [virtual]
typeName | RenderTechniqueFactory | [protected]

Generated on Wed Mar 28 11:48:57 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: Member List

OgrePhaseTextureRenderingRun Member List

This is the complete list of members for OgrePhaseTextureRenderingRun, including all inherited members.

asOgreRenderingRun() | OgreRenderingRun | [inline, virtual]
asOgreRenderingRun() | OgreRenderingRun | [inline, virtual]
canJoin(RenderingRun *run) | RenderingRun | [inline, virtual]
createCubeRenderTexture(String name, const Vector3 position, unsigned int resolution=512, PixelFormat format=PF_FLOAT16_RGBA, int numMips=0, ColourValue clearColor=ColourValue::Black) | OgreRenderingRun | [protected]
createCubeRenderTexture(String name, const Vector3 position, unsigned int resolution=512, PixelFormat format=PF_FLOAT16_RGBA, int numMips=0, ColourValue clearColor=ColourValue::Black) | OgreRenderingRun | [protected]
createPhaseTexture() | OgrePhaseTextureRenderingRun | [inline, protected, virtual]
fullscreenGrid | OgreRenderingRun | [protected]
fullScreenQuad | OgreRenderingRun | [protected, static]
fullScreenQuad | OgreRenderingRun | [protected, static]
fullScreenQuadEntity | OgreRenderingRun | [protected, static]
fullScreenQuadEntity | OgreRenderingRun | [protected, static]
fullScreenQuadNode | OgreRenderingRun | [protected, static]
fullScreenQuadNode | OgreRenderingRun | [protected, static]
getCubeMapFaceDirection(unsigned char faceId) | OgreRenderingRun | [protected]
getCubeMapFaceDirection(unsigned char faceId) | OgreRenderingRun | [protected]
getPhaseTextureName() | OgrePhaseTextureRenderingRun | [inline]
lastupdated | RenderingRun | [protected]
materialName | OgrePhaseTextureRenderingRun | [protected]
name | OgrePhaseTextureRenderingRun | [protected]
needUpdate(unsigned long frameNum) | RenderingRun | [inline, protected, virtual]
OgrePhaseTextureRenderingRun(String name, unsigned int resolutionX, unsigned int resolutionY, String materialName) | OgrePhaseTextureRenderingRun |
OgreRenderingRun(unsigned long startFrame, unsigned long updateInterval) | OgreRenderingRun | [inline]
OgreRenderingRun(unsigned long startFrame, unsigned long updateInterval) | OgreRenderingRun | [inline]
phaseCamera | OgrePhaseTextureRenderingRun | [protected]
phaseTexture | OgrePhaseTextureRenderingRun | [protected]
PhaseTextureRenderingRun(unsigned int resolutionX, unsigned int resolutionY) | PhaseTextureRenderingRun | [inline]
pixelSprites | OgreRenderingRun | [protected]
pixelSprites | OgreRenderingRun | [protected]
renderFullscreenGrid(String &materialName, RenderTarget *rt, int width, int height) | OgreRenderingRun | [protected]
renderFullscreenQuad(String materialName, RenderTarget *target) | OgreRenderingRun | [protected]
renderFullscreenQuad(String materialName, RenderTarget *target) | OgreRenderingRun | [protected]
RenderingRun(unsigned long startFrame, unsigned long updateInterval) | RenderingRun |
renderPixelSprites(String &materialName, RenderTarget *rt, int width, int height) | OgreRenderingRun | [protected]
renderPixelSprites(String &materialName, RenderTarget *rt, int width, int height) | OgreRenderingRun | [protected]
resolutionX | PhaseTextureRenderingRun | [protected]
resolutionY | PhaseTextureRenderingRun | [protected]
restoreMaterials() | OgreRenderingRun | [protected]
restoreMaterials() | OgreRenderingRun | [protected]
setMaterialForRenderables(String &materialName, RenderQueue *rq) | OgreRenderingRun | [protected]
setMaterialForRenderables(String &materialName, RenderQueue *rq, bool solidsonly=false) | OgreRenderingRun | [protected]
setMaterialForVisibles(String &materialName, Camera *cam, bool shadowcastersonly=false) | OgreRenderingRun | [protected]
setMaterialForVisibles(String &materialName, Camera *cam, bool shadowcastersonly=false, bool solidsonly=false) | OgreRenderingRun | [protected]
spriteSetName | OgreRenderingRun | [protected]
startFrame | RenderingRun | [protected]
update(unsigned long frameNum) | RenderingRun | [inline]
updateFrame(unsigned long frameNum) | OgrePhaseTextureRenderingRun | [protected, virtual]
updateInterval | RenderingRun | [protected]
visibleObjects | OgreRenderingRun | [protected]
visibleObjects | OgreRenderingRun | [protected]

Generated on Wed Mar 28 11:48:57 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: Member List

OgrePhotonMapRenderingRun Member List

This is the complete list of members for OgrePhotonMapRenderingRun, including all inherited members.

asOgreRenderingRun() | OgreRenderingRun | [inline, virtual]
asOgreRenderingRun() | OgreRenderingRun | [inline, virtual]
canJoin(RenderingRun *run) | OgrePhotonMapRenderingRun | [inline, virtual]
createCubeRenderTexture(String name, const Vector3 position, unsigned int resolution=512, PixelFormat format=PF_FLOAT16_RGBA, int numMips=0, ColourValue clearColor=ColourValue::Black) | OgreRenderingRun | [protected]
createCubeRenderTexture(String name, const Vector3 position, unsigned int resolution=512, PixelFormat format=PF_FLOAT16_RGBA, int numMips=0, ColourValue clearColor=ColourValue::Black) | OgreRenderingRun | [protected]
createPhotonMap() | OgrePhotonMapRenderingRun | [inline, protected, virtual]
fullscreenGrid | OgreRenderingRun | [protected]
fullScreenQuad | OgreRenderingRun | [protected, static]
fullScreenQuad | OgreRenderingRun | [protected, static]
fullScreenQuadEntity | OgreRenderingRun | [protected, static]
fullScreenQuadEntity | OgreRenderingRun | [protected, static]
fullScreenQuadNode | OgreRenderingRun | [protected, static]
fullScreenQuadNode | OgreRenderingRun | [protected, static]
getCubeMapFaceDirection(unsigned char faceId) | OgreRenderingRun | [protected]
getCubeMapFaceDirection(unsigned char faceId) | OgreRenderingRun | [protected]
getPhotonMapTextureName() | OgrePhotonMapRenderingRun | [inline]
lastupdated | RenderingRun | [protected]
light | OgrePhotonMapRenderingRun | [protected]
materialName | OgrePhotonMapRenderingRun | [protected]
name | OgrePhotonMapRenderingRun | [protected]
needUpdate(unsigned long frameNum) | RenderingRun | [inline, protected, virtual]
OgrePhotonMapRenderingRun(OgreSharedRuns *sharedRuns, String name, unsigned long startFrame, unsigned long updateInterval, unsigned int resolution, String materialName, bool useDistance) | OgrePhotonMapRenderingRun |
OgreRenderingRun(unsigned long startFrame, unsigned long updateInterval) | OgreRenderingRun | [inline]
OgreRenderingRun(unsigned long startFrame, unsigned long updateInterval) | OgreRenderingRun | [inline]
photonMapCamera | OgrePhotonMapRenderingRun | [protected]
PhotonMapRenderingRun(unsigned long startFrame, unsigned long updateInterval) | PhotonMapRenderingRun | [inline]
photonMapTexture | OgrePhotonMapRenderingRun | [protected]
pixelSprites | OgreRenderingRun | [protected]
pixelSprites | OgreRenderingRun | [protected]
refreshLight() | OgrePhotonMapRenderingRun |
renderFullscreenGrid(String &materialName, RenderTarget *rt, int width, int height) | OgreRenderingRun | [protected]
renderFullscreenQuad(String materialName, RenderTarget *target) | OgreRenderingRun | [protected]
renderFullscreenQuad(String materialName, RenderTarget *target) | OgreRenderingRun | [protected]
RenderingRun(unsigned long startFrame, unsigned long updateInterval) | RenderingRun |
renderPixelSprites(String &materialName, RenderTarget *rt, int width, int height) | OgreRenderingRun | [protected]
renderPixelSprites(String &materialName, RenderTarget *rt, int width, int height) | OgreRenderingRun | [protected]
resolution | OgrePhotonMapRenderingRun | [protected]
restoreMaterials() | OgreRenderingRun | [protected]
restoreMaterials() | OgreRenderingRun | [protected]
setMaterialForRenderables(String &materialName, RenderQueue *rq) | OgreRenderingRun | [protected]
setMaterialForRenderables(String &materialName, RenderQueue *rq, bool solidsonly=false) | OgreRenderingRun | [protected]
setMaterialForVisibles(String &materialName, Camera *cam, bool shadowcastersonly=false) | OgreRenderingRun | [protected]
setMaterialForVisibles(String &materialName, Camera *cam, bool shadowcastersonly=false, bool solidsonly=false) | OgreRenderingRun | [protected]
sharedRuns | OgrePhotonMapRenderingRun | [protected]
spriteSetName | OgreRenderingRun | [protected]
startFrame | RenderingRun | [protected]
update(unsigned long frameNum) | RenderingRun | [inline]
updateFrame(unsigned long frameNum) | OgrePhotonMapRenderingRun | [protected, virtual]
updateInterval | RenderingRun | [protected]
useDistance | OgrePhotonMapRenderingRun | [protected]
visibleObjects | OgreRenderingRun | [protected]
visibleObjects | OgreRenderingRun | [protected]

Generated on Wed Mar 28 11:48:58 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: Member List

OgreReducedCubeMapRenderingRun Member List

This is the complete list of members for OgreReducedCubeMapRenderingRun, including all inherited members.

angleTolerance | ReducedCubeMapRenderingRun | [protected]
asOgreRenderingRun() | OgreRenderingRun | [inline, virtual]
asOgreRenderingRun() | OgreRenderingRun | [inline, virtual]
canJoin(RenderingRun *run) | RenderingRun | [inline, virtual]
createCubeRenderTexture(String name, const Vector3 position, unsigned int resolution=512, PixelFormat format=PF_FLOAT16_RGBA, int numMips=0, ColourValue clearColor=ColourValue::Black) | OgreRenderingRun | [protected]
createCubeRenderTexture(String name, const Vector3 position, unsigned int resolution=512, PixelFormat format=PF_FLOAT16_RGBA, int numMips=0, ColourValue clearColor=ColourValue::Black) | OgreRenderingRun | [protected]
createReducedCubeMap() | OgreReducedCubeMapRenderingRun | [inline, protected, virtual]
currentFace | ReducedCubeMapRenderingRun | [protected]
distTolerance | ReducedCubeMapRenderingRun | [protected]
faceNeedsUpdate(int facenum) | OgreReducedCubeMapRenderingRun | [protected, virtual]
fullscreenGrid | OgreRenderingRun | [protected]
fullScreenQuad | OgreRenderingRun | [protected, static]
fullScreenQuad | OgreRenderingRun | [protected, static]
fullScreenQuadEntity | OgreRenderingRun | [protected, static]
fullScreenQuadEntity | OgreRenderingRun | [protected, static]
fullScreenQuadNode | OgreRenderingRun | [protected, static]
fullScreenQuadNode | OgreRenderingRun | [protected, static]
getCubeMapFaceDirection(unsigned char faceId) | OgreRenderingRun | [protected]
getCubeMapFaceDirection(unsigned char faceId) | OgreRenderingRun | [protected]
getReducedCubeMapTextureName() | OgreReducedCubeMapRenderingRun | [inline]
lastupdated | RenderingRun | [protected]
name | OgreReducedCubeMapRenderingRun | [protected]
needUpdate(unsigned long frameNum) | RenderingRun | [inline, protected, virtual]
OgreReducedCubeMapRenderingRun(OgreSharedRuns *sharedRuns, String name, unsigned long startFrame, unsigned long updateInterval, unsigned int resolution, bool useDistCalc=false, bool useFaceAngleCalc=false, float distTolerance=15, float angleTolerance=10, bool updateAllFace=false) | OgreReducedCubeMapRenderingRun |
OgreRenderingRun(unsigned long startFrame, unsigned long updateInterval) | OgreRenderingRun | [inline]
OgreRenderingRun(unsigned long startFrame, unsigned long updateInterval) | OgreRenderingRun | [inline]
pixelSprites | OgreRenderingRun | [protected]
pixelSprites | OgreRenderingRun | [protected]
ReducedCubeMapRenderingRun(unsigned long startFrame, unsigned long updateInterval, unsigned int resolution, bool useDistCalc, bool useFaceAngleCalc, float distTolerance, float angleTolerance, bool updateAllFace) | ReducedCubeMapRenderingRun |
reducedCubemapTexture | OgreReducedCubeMapRenderingRun | [protected]
renderFullscreenGrid(String &materialName, RenderTarget *rt, int width, int height) | OgreRenderingRun | [protected]
renderFullscreenQuad(String materialName, RenderTarget *target) | OgreRenderingRun | [protected]
renderFullscreenQuad(String materialName, RenderTarget *target) | OgreRenderingRun | [protected]
RenderingRun(unsigned long startFrame, unsigned long updateInterval) | RenderingRun |
renderPixelSprites(String &materialName, RenderTarget *rt, int width, int height) | OgreRenderingRun | [protected]
renderPixelSprites(String &materialName, RenderTarget *rt, int width, int height) | OgreRenderingRun | [protected]
resolution | ReducedCubeMapRenderingRun | [protected]
restoreMaterials() | OgreRenderingRun | [protected]
restoreMaterials() | OgreRenderingRun | [protected]
setMaterialForRenderables(String &materialName, RenderQueue *rq) | OgreRenderingRun | [protected]
setMaterialForRenderables(String &materialName, RenderQueue *rq, bool solidsonly=false) | OgreRenderingRun | [protected]
setMaterialForVisibles(String &materialName, Camera *cam, bool shadowcastersonly=false) | OgreRenderingRun | [protected]
setMaterialForVisibles(String &materialName, Camera *cam, bool shadowcastersonly=false, bool solidsonly=false) | OgreRenderingRun | [protected]
sharedRuns | OgreReducedCubeMapRenderingRun | [protected]
spriteSetName | OgreRenderingRun | [protected]
startFrame | RenderingRun | [protected]
update(unsigned long frameNum) | RenderingRun | [inline]
updateAllFace | ReducedCubeMapRenderingRun | [protected]
updateCubeFace(int facenum) | OgreReducedCubeMapRenderingRun | [inline, protected, virtual]
OgreRenderingRun::updateFrame(unsigned long frameNum) | RenderingRun | [inline, protected, virtual]
ReducedCubeMapRenderingRun::updateFrame(unsigned long frameNum) | ReducedCubeMapRenderingRun | [protected, virtual]
updateInterval | RenderingRun | [protected]
useDistCalc | ReducedCubeMapRenderingRun | [protected]
useFaceAngleCalc | ReducedCubeMapRenderingRun | [protected]
visibleObjects | OgreRenderingRun | [protected]
visibleObjects | OgreRenderingRun | [protected]

Generated on Wed Mar 28 11:48:59 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: Member List

OgreRenderTechnique Member List

This is the complete list of members for OgreRenderTechnique, including all inherited members.

asOgreRenderTechnique() | OgreRenderTechnique | [inline, virtual]
getParentRenderable() | RenderTechnique | [inline]
OgreRenderTechnique(Pass *pass, OgreRenderable *parentRenderable, OgreTechniqueGroup *parentTechniqueGroup) | OgreRenderTechnique |
parentOgreRenderable | OgreRenderTechnique | [protected]
parentOgreTechniqueGroup | OgreRenderTechnique | [protected]
parentRenderable | RenderTechnique | [protected]
parentTechniqueGroup | RenderTechnique | [protected]
pass | OgreRenderTechnique | [protected]
RenderTechnique(ElementaryRenderable *parentRenderable, TechniqueGroup *parentTechniqueGroup) | RenderTechnique |
runChanged(RenderingRunType runType, RenderingRun *run) | RenderTechnique | [inline, virtual]
runUpdated(RenderingRunType runType, RenderingRun *run) | RenderTechnique | [inline, virtual]
sharedRuns | RenderTechnique | [protected]
update(unsigned long frameNum) | RenderTechnique | [inline, virtual]

Generated on Wed Mar 28 11:49:00 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: Member List

OgreRenderable Member List

This is the complete list of members for OgreRenderable, including all inherited members.

billboardSetRenderable | OgreRenderable | [protected]
boundingBox | OgreRenderable | [protected]
boundingSphere | OgreRenderable | [protected]
getBoundingBox() | OgreRenderable | [inline]
getBoundingSphere() | OgreRenderable | [inline]
getMaterial() | OgreRenderable | [inline]
getMaterialName() | OgreRenderable | [inline]
getMaterialPtr() | OgreRenderable |
getName() | OgreRenderable | [inline]
getRenderable() | OgreRenderable |
isVisible() | OgreRenderable | [virtual]
name | OgreRenderable | [protected]
notifyCamera(Camera *cam) | OgreRenderable |
OgreRenderable(SubEntity *sube, Entity *parentEntity) | OgreRenderable |
OgreRenderable(Entity *parentEntity, int subEntityNum) | OgreRenderable |
OgreRenderable(BillboardSet *billboardset, ParticleSystem *sys=0) | OgreRenderable |
parentEntity | OgreRenderable | [protected]
parentParticleSystem | OgreRenderable | [protected]
renderableType | OgreRenderable | [protected]
setMaterialName(String &name) | OgreRenderable |
setRenderGroup(unsigned char groupID) | OgreRenderable | [virtual]
setVisible(bool visible) | OgreRenderable | [virtual]
subEntityRenderable | OgreRenderable | [protected]
updateBounds() | OgreRenderable | [virtual]
updateRenderQueue(RenderQueue *rq) | OgreRenderable |
~OgreRenderable(void) | OgreRenderable |

Generated on Wed Mar 28 11:48:59 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: Member List

OgreRenderingRun Member List

This is the complete list of members for OgreRenderingRun, including all inherited members.

asOgreRenderingRun() | OgreRenderingRun | [inline, virtual]
asOgreRenderingRun() | OgreRenderingRun | [inline, virtual]
canJoin(RenderingRun *run) | RenderingRun | [inline, virtual]
createCubeRenderTexture(String name, const Vector3 position, unsigned int resolution=512, PixelFormat format=PF_FLOAT16_RGBA, int numMips=0, ColourValue clearColor=ColourValue::Black) | OgreRenderingRun | [protected]
createCubeRenderTexture(String name, const Vector3 position, unsigned int resolution=512, PixelFormat format=PF_FLOAT16_RGBA, int numMips=0, ColourValue clearColor=ColourValue::Black) | OgreRenderingRun | [protected]
fullscreenGrid | OgreRenderingRun | [protected]
fullScreenQuad | OgreRenderingRun | [protected, static]
fullScreenQuad | OgreRenderingRun | [protected, static]
fullScreenQuadEntity | OgreRenderingRun | [protected, static]
fullScreenQuadEntity | OgreRenderingRun | [protected, static]
fullScreenQuadNode | OgreRenderingRun | [protected, static]
fullScreenQuadNode | OgreRenderingRun | [protected, static]
getCubeMapFaceDirection(unsigned char faceId) | OgreRenderingRun | [protected]
getCubeMapFaceDirection(unsigned char faceId) | OgreRenderingRun | [protected]
lastupdated | RenderingRun | [protected]
needUpdate(unsigned long frameNum) | RenderingRun | [inline, protected, virtual]
OgreRenderingRun(unsigned long startFrame, unsigned long updateInterval) | OgreRenderingRun | [inline]
OgreRenderingRun(unsigned long startFrame, unsigned long updateInterval) | OgreRenderingRun | [inline]
pixelSprites | OgreRenderingRun | [protected]
pixelSprites | OgreRenderingRun | [protected]
renderFullscreenGrid(String &materialName, RenderTarget *rt, int width, int height) | OgreRenderingRun | [protected]
renderFullscreenQuad(String materialName, RenderTarget *target) | OgreRenderingRun | [protected]
renderFullscreenQuad(String materialName, RenderTarget *target) | OgreRenderingRun | [protected]
RenderingRun(unsigned long startFrame, unsigned long updateInterval) | RenderingRun |
renderPixelSprites(String &materialName, RenderTarget *rt, int width, int height) | OgreRenderingRun | [protected]
renderPixelSprites(String &materialName, RenderTarget *rt, int width, int height) | OgreRenderingRun | [protected]
restoreMaterials() | OgreRenderingRun | [protected]
restoreMaterials() | OgreRenderingRun | [protected]
setMaterialForRenderables(String &materialName, RenderQueue *rq) | OgreRenderingRun | [protected]
setMaterialForRenderables(String &materialName, RenderQueue *rq, bool solidsonly=false) | OgreRenderingRun | [protected]
setMaterialForVisibles(String &materialName, Camera *cam, bool shadowcastersonly=false) | OgreRenderingRun | [protected]
setMaterialForVisibles(String &materialName, Camera *cam, bool shadowcastersonly=false, bool solidsonly=false) | OgreRenderingRun | [protected]
spriteSetName | OgreRenderingRun | [protected]
startFrame | RenderingRun | [protected]
update(unsigned long frameNum) | RenderingRun | [inline]
updateFrame(unsigned long frameNum) | RenderingRun | [inline, protected, virtual]
updateInterval | RenderingRun | [protected]
visibleObjects | OgreRenderingRun | [protected]
visibleObjects | OgreRenderingRun | [protected]

Generated on Wed Mar 28 11:48:59 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: Member List

OgreSBBRenderTechnique Member List

This is the complete list of members for OgreSBBRenderTechnique, including all inherited members.

asOgreRenderTechnique() | OgreRenderTechnique | [inline, virtual]
depthTexID | OgreSBBRenderTechnique | [protected]
getParentRenderable() | RenderTechnique | [inline]
OgreRenderTechnique(Pass *pass, OgreRenderable *parentRenderable, OgreTechniqueGroup *parentTechniqueGroup) | OgreRenderTechnique |
OgreSBBRenderTechnique(unsigned char depthTexID, Pass *pass, OgreRenderable *parentRenderable, OgreTechniqueGroup *parentTechniqueGroup) | OgreSBBRenderTechnique |
parentOgreRenderable | OgreRenderTechnique | [protected]
parentOgreTechniqueGroup | OgreRenderTechnique | [protected]
parentRenderable | RenderTechnique | [protected]
parentTechniqueGroup | RenderTechnique | [protected]
pass | OgreRenderTechnique | [protected]
postAllUpdates() | OgreSBBRenderTechnique | [virtual]
preAllUpdates() | OgreSBBRenderTechnique | [virtual]
RenderTechnique(ElementaryRenderable *parentRenderable, TechniqueGroup *parentTechniqueGroup) | RenderTechnique |
runChanged(RenderingRunType runType, RenderingRun *run) | RenderTechnique | [inline, virtual]
runUpdated(RenderingRunType runType, RenderingRun *run) | RenderTechnique | [inline, virtual]
SBBRenderTechnique(ElementaryRenderable *parentRenderable, TechniqueGroup *parentTechniqueGroup) | SBBRenderTechnique |
sharedRuns | RenderTechnique | [protected]
update(unsigned long frameNum) | OgreSBBRenderTechnique | [virtual]

Generated on Wed Mar 28 11:49:00 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: Member List

OgreSBBRenderTechniqueFactory Member List

This is the complete list of members for OgreSBBRenderTechniqueFactory, including all inherited members.

AttribParserList typedef | RenderTechniqueFactory | [protected]
attributeParsers | RenderTechniqueFactory | [protected]
createInstance(IllumTechniqueParams *params, Pass *pass, OgreRenderable *parentRenderable, OgreTechniqueGroup *parentTechniqueGroup) | OgreSBBRenderTechniqueFactory | [virtual]
ILLUM_ATTRIBUTE_PARSER typedef | RenderTechniqueFactory | [protected]
isType(String type) | RenderTechniqueFactory | [inline]
parseParams(IllumTechniqueParams *params) | RenderTechniqueFactory | [virtual]
typeName | RenderTechniqueFactory | [protected]

Generated on Wed Mar 28 11:49:00 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: Member List

OgreSceneCameraDepthRenderingRun Member List

This is the complete list of members for OgreSceneCameraDepthRenderingRun, including all inherited members.

asOgreRenderingRun() | OgreRenderingRun | [inline, virtual]
asOgreRenderingRun() | OgreRenderingRun | [inline, virtual]
canJoin(RenderingRun *run) | RenderingRun | [inline, virtual]
createCubeRenderTexture(String name, const Vector3 position, unsigned int resolution=512, PixelFormat format=PF_FLOAT16_RGBA, int numMips=0, ColourValue clearColor=ColourValue::Black) | OgreRenderingRun | [protected]
createCubeRenderTexture(String name, const Vector3 position, unsigned int resolution=512, PixelFormat format=PF_FLOAT16_RGBA, int numMips=0, ColourValue clearColor=ColourValue::Black) | OgreRenderingRun | [protected]
createDepthMap() | OgreSceneCameraDepthRenderingRun | [inline, protected, virtual]
depthTexture | OgreSceneCameraDepthRenderingRun | [protected]
fullscreenGrid | OgreRenderingRun | [protected]
fullScreenQuad | OgreRenderingRun | [protected, static]
fullScreenQuad | OgreRenderingRun | [protected, static]
fullScreenQuadEntity | OgreRenderingRun | [protected, static]
fullScreenQuadEntity | OgreRenderingRun | [protected, static]
fullScreenQuadNode | OgreRenderingRun | [protected, static]
fullScreenQuadNode | OgreRenderingRun | [protected, static]
getCubeMapFaceDirection(unsigned char faceId) | OgreRenderingRun | [protected]
getCubeMapFaceDirection(unsigned char faceId) | OgreRenderingRun | [protected]
getDepthTextureName() | OgreSceneCameraDepthRenderingRun | [inline]
lastupdated | RenderingRun | [protected]
name | OgreSceneCameraDepthRenderingRun | [protected]
needUpdate(unsigned long frameNum) | RenderingRun | [inline, protected, virtual]
OgreRenderingRun(unsigned long startFrame, unsigned long updateInterval) | OgreRenderingRun | [inline]
OgreRenderingRun(unsigned long startFrame, unsigned long updateInterval) | OgreRenderingRun | [inline]
OgreSceneCameraDepthRenderingRun(OgreSharedRuns *sharedRuns, String name, Viewport *playerView) | OgreSceneCameraDepthRenderingRun |
pixelSprites | OgreRenderingRun | [protected]
pixelSprites | OgreRenderingRun | [protected]
playerCamera | OgreSceneCameraDepthRenderingRun | [protected]
playerView | OgreSceneCameraDepthRenderingRun | [protected]
renderFullscreenGrid(String &materialName, RenderTarget *rt, int width, int height) | OgreRenderingRun | [protected]
renderFullscreenQuad(String materialName, RenderTarget *target) | OgreRenderingRun | [protected]
renderFullscreenQuad(String materialName, RenderTarget *target) | OgreRenderingRun | [protected]
RenderingRun(unsigned long startFrame, unsigned long updateInterval) | RenderingRun |
renderPixelSprites(String &materialName, RenderTarget *rt, int width, int height) | OgreRenderingRun | [protected]
renderPixelSprites(String &materialName, RenderTarget *rt, int width, int height) | OgreRenderingRun | [protected]
restoreMaterials() | OgreRenderingRun | [protected]
restoreMaterials() | OgreRenderingRun | [protected]
SceneCameraDepthRenderingRun() | SceneCameraDepthRenderingRun | [inline]
setMaterialForRenderables(String &materialName, RenderQueue *rq) | OgreRenderingRun | [protected]
setMaterialForRenderables(String &materialName, RenderQueue *rq, bool solidsonly=false) | OgreRenderingRun | [protected]
setMaterialForVisibles(String &materialName, Camera *cam, bool shadowcastersonly=false) | OgreRenderingRun | [protected]
setMaterialForVisibles(String &materialName, Camera *cam, bool shadowcastersonly=false, bool solidsonly=false) | OgreRenderingRun | [protected]
sharedRuns | OgreSceneCameraDepthRenderingRun | [protected]
spriteSetName | OgreRenderingRun | [protected]
startFrame | RenderingRun | [protected]
update(unsigned long frameNum) | RenderingRun | [inline]
updateFrame(unsigned long frameNum) | OgreSceneCameraDepthRenderingRun | [protected, virtual]
updateInterval | RenderingRun | [protected]
visibleObjects | OgreRenderingRun | [protected]
visibleObjects | OgreRenderingRun | [protected]

Generated on Wed Mar 28 11:49:00 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: Member List

OgreSharedRuns Member List

This is the complete list of members for OgreSharedRuns, including all inherited members.

addRenderablesToQueue(RenderQueue *rq, bool checkVisible=true) | OgreSharedRuns |
addRun(RenderingRunType runType, RenderingRun *run) | OgreSharedRuns | [virtual]
addTechniqueGroup(TechniqueGroup *group) | OgreSharedRuns | [inline, virtual]
boundingBox | OgreSharedRuns | [protected]
boundingSphere | OgreSharedRuns | [protected]
canJoin(SharedRuns *r1, SharedRuns *r2) | OgreSharedRuns | [static]
child1 | SharedRuns | [protected]
child2 | SharedRuns | [protected]
childTechniqueGroups | OgreSharedRuns | [protected]
createInstance() | OgreSharedRuns | [protected, virtual]
destroy() | OgreSharedRuns | [virtual]
findSharedRootsForType(RenderingRunType runType, std::vector< OgreSharedRuns * > &roots) | OgreSharedRuns |
fireRunChanges() | OgreSharedRuns | [protected, virtual]
gatherRuns() | OgreSharedRuns | [protected, virtual]
getBoundingBox() | OgreSharedRuns | [inline]
getBoundingSphere() | OgreSharedRuns | [inline]
getRoot() | SharedRuns | [virtual]
getRoot(RenderingRunType runType) | SharedRuns | [virtual]
getRootBoundingBox() | OgreSharedRuns | [inline]
getRootBoundingBox(RenderingRunType runType) | OgreSharedRuns | [inline]
getRootBoundingSphere() | OgreSharedRuns | [inline]
getRootBoundingSphere(RenderingRunType runType) | OgreSharedRuns | [inline]
getRootPosition() | OgreSharedRuns | [inline]
getRootPosition(RenderingRunType runType) | OgreSharedRuns | [inline]
getRun(RenderingRunType runType) | OgreSharedRuns | [virtual]
getSharedRuns() | OgreSharedRuns | [inline]
hasOwnRun(RenderingRunType runType) | OgreSharedRuns | [virtual]
haveCommonRuns(SharedRuns *r1, SharedRuns *r2, std::vector< RenderingRunType > &commonruns) | OgreSharedRuns | [static]
hide() | SharedRuns | [virtual]
hideRenderables() | OgreSharedRuns | [inline, protected, virtual]
joinRuns(SharedRuns *otherRuns) | SharedRuns | [virtual]
notifyCamera(Camera *cam) | OgreSharedRuns |
OgreSharedRuns() | OgreSharedRuns | [inline]
parent | SharedRuns | [protected]
renderableMaterials | OgreSharedRuns | [protected]
renderables | OgreSharedRuns | [protected]
restoreMaterial() | OgreSharedRuns |
restoreRenderableVisibility() | OgreSharedRuns | [inline, protected, virtual]
restoreVisibility() | SharedRuns | [virtual]
runChanged(RenderingRunType runType, RenderingRun *run) | OgreSharedRuns | [virtual]
runUpdated(RenderingRunType runType, RenderingRun *run) | OgreSharedRuns | [virtual]
setBoundingBox(AxisAlignedBox &box) | OgreSharedRuns | [inline]
setBoundingSphere(Sphere &sphere) | OgreSharedRuns | [inline]
setMaterial(String materialName) | OgreSharedRuns |
setRenderablesVisible(bool visible) | OgreSharedRuns | [inline, protected, virtual]
setVisible(bool visible) | SharedRuns | [virtual]
SharedRuns(void) | SharedRuns |
sharedRuns | OgreSharedRuns | [protected]
unbindAndKillParent() | SharedRuns | [inline, virtual]
unbindParent() | SharedRuns | [inline, virtual]
updateBounds() | OgreSharedRuns | [virtual]
updateRun(RenderingRunType runType, unsigned long frameNum) | OgreSharedRuns | [virtual]
validate() | OgreSharedRuns | [virtual]

Generated on Wed Mar 28 11:49:01 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: Member List

OgreTechniqueGroup Member List

This is the complete list of members for OgreTechniqueGroup, including all inherited members.

addRenderTechnique(RenderTechnique *technique) | OgreTechniqueGroup | [virtual]
addSharedRun(SharedRuns *sharedRuns) | TechniqueGroup | [inline]
getSharedRuns() | TechniqueGroup | [inline]
parentSharedRuns | TechniqueGroup | [protected]
renderTechniques | OgreTechniqueGroup | [protected]
runChanged(RenderingRunType runType, RenderingRun *run) | OgreTechniqueGroup | [virtual]
runUpdated(RenderingRunType runType, RenderingRun *run) | OgreTechniqueGroup | [virtual]
TechniqueGroup(void) | TechniqueGroup |
update(unsigned long frameNum) | OgreTechniqueGroup | [virtual]
updateBounds() | OgreTechniqueGroup | [inline, virtual]
validateSharedRuns() | TechniqueGroup | [inline, virtual]

Generated on Wed Mar 28 11:49:01 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: Member List

PhaseTextureRenderingRun Member List

This is the complete list of members for PhaseTextureRenderingRun, including all inherited members.

asOgreRenderingRun() | RenderingRun | [inline, virtual]
canJoin(RenderingRun *run) | RenderingRun | [inline, virtual]
createPhaseTexture()=0 | PhaseTextureRenderingRun | [inline, protected, pure virtual]
lastupdated | RenderingRun | [protected]
needUpdate(unsigned long frameNum) | RenderingRun | [inline, protected, virtual]
PhaseTextureRenderingRun(unsigned int resolutionX, unsigned int resolutionY) | PhaseTextureRenderingRun | [inline]
RenderingRun(unsigned long startFrame, unsigned long updateInterval) | RenderingRun |
resolutionX | PhaseTextureRenderingRun | [protected]
resolutionY | PhaseTextureRenderingRun | [protected]
startFrame | RenderingRun | [protected]
update(unsigned long frameNum) | RenderingRun | [inline]
updateFrame(unsigned long frameNum)=0 | PhaseTextureRenderingRun | [protected, pure virtual]
updateInterval | RenderingRun | [protected]

Generated on Wed Mar 28 11:49:01 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: Member List

PhotonMapRenderingRun Member List

This is the complete list of members for PhotonMapRenderingRun, including all inherited members.

asOgreRenderingRun() | RenderingRun | [inline, virtual]
canJoin(RenderingRun *run) | RenderingRun | [inline, virtual]
createPhotonMap()=0 | PhotonMapRenderingRun | [inline, protected, pure virtual]
lastupdated | RenderingRun | [protected]
needUpdate(unsigned long frameNum) | RenderingRun | [inline, protected, virtual]
PhotonMapRenderingRun(unsigned long startFrame, unsigned long updateInterval) | PhotonMapRenderingRun | [inline]
RenderingRun(unsigned long startFrame, unsigned long updateInterval) | RenderingRun |
startFrame | RenderingRun | [protected]
update(unsigned long frameNum) | RenderingRun | [inline]
updateFrame(unsigned long frameNum)=0 | PhotonMapRenderingRun | [protected, pure virtual]
updateInterval | RenderingRun | [protected]

Generated on Wed Mar 28 11:49:01 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: Member List

ReducedCubeMapRenderingRun Member List

This is the complete list of members for ReducedCubeMapRenderingRun, including all inherited members.

angleTolerance | ReducedCubeMapRenderingRun | [protected]
asOgreRenderingRun() | RenderingRun | [inline, virtual]
canJoin(RenderingRun *run) | RenderingRun | [inline, virtual]
createReducedCubeMap()=0 | ReducedCubeMapRenderingRun | [inline, protected, pure virtual]
currentFace | ReducedCubeMapRenderingRun | [protected]
distTolerance | ReducedCubeMapRenderingRun | [protected]
faceNeedsUpdate(int facenum)=0 | ReducedCubeMapRenderingRun | [protected, pure virtual]
lastupdated | RenderingRun | [protected]
needUpdate(unsigned long frameNum) | RenderingRun | [inline, protected, virtual]
ReducedCubeMapRenderingRun(unsigned long startFrame, unsigned long updateInterval, unsigned int resolution, bool useDistCalc, bool useFaceAngleCalc, float distTolerance, float angleTolerance, bool updateAllFace) | ReducedCubeMapRenderingRun |
RenderingRun(unsigned long startFrame, unsigned long updateInterval) | RenderingRun |
resolution | ReducedCubeMapRenderingRun | [protected]
startFrame | RenderingRun | [protected]
update(unsigned long frameNum) | RenderingRun | [inline]
updateAllFace | ReducedCubeMapRenderingRun | [protected]
updateCubeFace(int facenum)=0 | ReducedCubeMapRenderingRun | [inline, protected, pure virtual]
updateFrame(unsigned long frameNum) | ReducedCubeMapRenderingRun | [protected, virtual]
updateInterval | RenderingRun | [protected]
useDistCalc | ReducedCubeMapRenderingRun | [protected]
useFaceAngleCalc | ReducedCubeMapRenderingRun | [protected]

Generated on Wed Mar 28 11:49:01 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: Member List

RenderTechnique Member List

This is the complete list of members for RenderTechnique, including all inherited members.

asOgreRenderTechnique() | RenderTechnique | [inline, virtual]
getParentRenderable() | RenderTechnique | [inline]
parentRenderable | RenderTechnique | [protected]
parentTechniqueGroup | RenderTechnique | [protected]
RenderTechnique(ElementaryRenderable *parentRenderable, TechniqueGroup *parentTechniqueGroup) | RenderTechnique |
runChanged(RenderingRunType runType, RenderingRun *run) | RenderTechnique | [inline, virtual]
runUpdated(RenderingRunType runType, RenderingRun *run) | RenderTechnique | [inline, virtual]
sharedRuns | RenderTechnique | [protected]
update(unsigned long frameNum) | RenderTechnique | [inline, virtual]

Generated on Wed Mar 28 11:49:02 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: Member List

RenderTechniqueFactory Member List

This is the complete list of members for RenderTechniqueFactory, including all inherited members.

AttribParserList typedef | RenderTechniqueFactory | [protected]
attributeParsers | RenderTechniqueFactory | [protected]
createInstance(IllumTechniqueParams *params, Pass *pass, OgreRenderable *parentRenderable, OgreTechniqueGroup *parentTechniqueGroup)=0 | RenderTechniqueFactory | [pure virtual]
ILLUM_ATTRIBUTE_PARSER typedef | RenderTechniqueFactory | [protected]
isType(String type) | RenderTechniqueFactory | [inline]
parseParams(IllumTechniqueParams *params) | RenderTechniqueFactory | [virtual]
typeName | RenderTechniqueFactory | [protected]

Generated on Wed Mar 28 11:49:02 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: Member List

RenderingRun Member List

This is the complete list of members for RenderingRun, including all inherited members.

asOgreRenderingRun() | RenderingRun | [inline, virtual]
canJoin(RenderingRun *run) | RenderingRun | [inline, virtual]
lastupdated | RenderingRun | [protected]
needUpdate(unsigned long frameNum) | RenderingRun | [inline, protected, virtual]
RenderingRun(unsigned long startFrame, unsigned long updateInterval) | RenderingRun |
startFrame | RenderingRun | [protected]
update(unsigned long frameNum) | RenderingRun | [inline]
updateFrame(unsigned long frameNum) | RenderingRun | [inline, protected, virtual]
updateInterval | RenderingRun | [protected]

Generated on Wed Mar 28 11:49:02 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: Member List

SBBRenderTechnique Member List

This is the complete list of members for SBBRenderTechnique, including all inherited members.

asOgreRenderTechnique() | RenderTechnique | [inline, virtual]
getParentRenderable() | RenderTechnique | [inline]
parentRenderable | RenderTechnique | [protected]
parentTechniqueGroup | RenderTechnique | [protected]
RenderTechnique(ElementaryRenderable *parentRenderable, TechniqueGroup *parentTechniqueGroup) | RenderTechnique |
runChanged(RenderingRunType runType, RenderingRun *run) | RenderTechnique | [inline, virtual]
runUpdated(RenderingRunType runType, RenderingRun *run) | RenderTechnique | [inline, virtual]
SBBRenderTechnique(ElementaryRenderable *parentRenderable, TechniqueGroup *parentTechniqueGroup) | SBBRenderTechnique |
sharedRuns | RenderTechnique | [protected]
update(unsigned long frameNum) | RenderTechnique | [inline, virtual]

Generated on Wed Mar 28 11:49:02 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: Member List

SceneCameraDepthRenderingRun Member List

This is the complete list of members for SceneCameraDepthRenderingRun, including all inherited members.

asOgreRenderingRun() | RenderingRun | [inline, virtual]
canJoin(RenderingRun *run) | RenderingRun | [inline, virtual]
createDepthMap()=0 | SceneCameraDepthRenderingRun | [inline, protected, pure virtual]
lastupdated | RenderingRun | [protected]
needUpdate(unsigned long frameNum) | RenderingRun | [inline, protected, virtual]
RenderingRun(unsigned long startFrame, unsigned long updateInterval) | RenderingRun |
SceneCameraDepthRenderingRun() | SceneCameraDepthRenderingRun | [inline]
startFrame | RenderingRun | [protected]
update(unsigned long frameNum) | RenderingRun | [inline]
updateFrame(unsigned long frameNum)=0 | SceneCameraDepthRenderingRun | [protected, pure virtual]
updateInterval | RenderingRun | [protected]

Generated on Wed Mar 28 11:49:03 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: Member List

SharedRuns Member List

This is the complete list of members for SharedRuns, including all inherited members.

addRun(RenderingRunType runType, RenderingRun *run)=0 | SharedRuns | [pure virtual]
addTechniqueGroup(TechniqueGroup *group)=0 | SharedRuns | [pure virtual]
child1 | SharedRuns | [protected]
child2 | SharedRuns | [protected]
createInstance()=0 | SharedRuns | [protected, pure virtual]
destroy()=0 | SharedRuns | [pure virtual]
fireRunChanges()=0 | SharedRuns | [protected, pure virtual]
gatherRuns()=0 | SharedRuns | [protected, pure virtual]
getRoot() | SharedRuns | [virtual]
getRoot(RenderingRunType runType) | SharedRuns | [virtual]
getRun(RenderingRunType runType)=0 | SharedRuns | [pure virtual]
hasOwnRun(RenderingRunType runType)=0 | SharedRuns | [pure virtual]
hide() | SharedRuns | [virtual]
hideRenderables()=0 | SharedRuns | [protected, pure virtual]
joinRuns(SharedRuns *otherRuns) | SharedRuns | [virtual]
parent | SharedRuns | [protected]
restoreRenderableVisibility()=0 | SharedRuns | [protected, pure virtual]
restoreVisibility() | SharedRuns | [virtual]
runChanged(RenderingRunType runType, RenderingRun *run) | SharedRuns | [virtual]
runUpdated(RenderingRunType runType, RenderingRun *run) | SharedRuns | [virtual]
setRenderablesVisible(bool visible)=0 | SharedRuns | [protected, pure virtual]
setVisible(bool visible) | SharedRuns | [virtual]
SharedRuns(void) | SharedRuns |
unbindAndKillParent() | SharedRuns | [inline, virtual]
unbindParent() | SharedRuns | [inline, virtual]
updateBounds()=0 | SharedRuns | [pure virtual]
updateRun(RenderingRunType runType, unsigned long frameNum)=0 | SharedRuns | [pure virtual]
validate()=0 | SharedRuns | [pure virtual]

Generated on Wed Mar 28 11:49:03 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: Member List

TechniqueGroup Member List

This is the complete list of members for TechniqueGroup, including all inherited members.

addRenderTechnique(RenderTechnique *technique)=0 | TechniqueGroup | [pure virtual]
addSharedRun(SharedRuns *sharedRuns) | TechniqueGroup | [inline]
getSharedRuns() | TechniqueGroup | [inline]
parentSharedRuns | TechniqueGroup | [protected]
runChanged(RenderingRunType runType, RenderingRun *run)=0 | TechniqueGroup | [pure virtual]
runUpdated(RenderingRunType runType, RenderingRun *run)=0 | TechniqueGroup | [pure virtual]
TechniqueGroup(void) | TechniqueGroup |
update(unsigned long frameNum)=0 | TechniqueGroup | [pure virtual]
updateBounds() | TechniqueGroup | [inline, virtual]
validateSharedRuns() | TechniqueGroup | [inline, virtual]

Generated on Wed Mar 28 11:49:03 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: Member List

UpdateListener Member List

This is the complete list of members for UpdateListener, including all inherited members.

postAllUpdates() | UpdateListener | [inline, virtual]
preAllUpdates() | UpdateListener | [inline, virtual]

Generated on Wed Mar 28 11:49:03 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

Here is a list of all documented class members with links to the class documentation for each member:

- j -

  • joinRuns() : SharedRuns
  • joinSharedRuns() : OgreIlluminationManager , IlluminationManager
Generated on Wed Mar 28 11:48:46 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

Here is a list of all documented class members with links to the class documentation for each member:

- l -

  • lastupdated : RenderingRun
  • layer : CubeMapRenderTechnique
  • light : OgreLightVolumeRenderingRun , OgrePMWeightComputeRenderingRun , OgrePhotonMapRenderingRun , OgreDepthShadowMapRenderingRun
  • lightFarPlaneParamName : OgreDepthShadowReceiverRenderTechnique
  • lightMatrix : OgrePMWeightComputeRenderingRun , OgreFocusingMapRenderingRun
  • lightMatrixGPUParamName : OgreIllumVolumeRenderTechnique
  • lightViewMatrix : OgrePMWeightComputeRenderingRun
  • lightViewParamName : OgreDepthShadowReceiverRenderTechnique
  • lightViewProjParamName : OgreDepthShadowReceiverRenderTechnique
  • lightVolumeCamera : OgreLightVolumeRenderingRun
  • lightVolumeChanged() : IllumVolumeRenderTechnique
  • LightVolumeRenderingRun() : LightVolumeRenderingRun
  • lightVolumeUpdated() : IllumVolumeRenderTechnique
Generated on Wed Mar 28 11:48:46 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

Here is a list of all documented class members with links to the class documentation for each member:

- m -

  • mainCamera : OgreIlluminationManager
  • mainViewport : OgreIlluminationManager
  • materialName : OgreLightVolumeRenderingRun , OgrePhaseTextureRenderingRun , OgreCausticCubeMapRenderingRun , OgrePhotonMapRenderingRun , OgreChildPSystemRenderingRun , OgreDepthShadowMapRenderingRun , OgreIllumVolumeRenderTechnique
  • maxcasters : OgreCausticReceiverRenderTechnique
  • maxlights : OgreDepthShadowReceiverRenderTechnique
  • maxRad : OgreIlluminationManager
  • maxRads : OgreIlluminationManager
  • maxVariableName : OgreCubeMapRenderTechnique
  • minVariableName : OgreCubeMapRenderTechnique
Generated on Wed Mar 28 11:48:46 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

Here is a list of all documented class members with links to the class documentation for each member:

- n -

  • name : OgreRenderable , OgreChildPSystemRenderingRun , OgreLightVolumeRenderingRun , OgrePhaseTextureRenderingRun , OgreCubeMapRenderingRun , OgrePhotonMapRenderingRun , OgrePMEntryPointMapRenderingRun , OgreCausticCubeMapRenderingRun , OgreDepthShadowMapRenderingRun , OgrePMWeightComputeRenderingRun , OgreReducedCubeMapRenderingRun , OgreFocusingMapRenderingRun , OgreSceneCameraDepthRenderingRun
  • needUpdate() : RenderingRun
  • normal : PathMapEntryPoint
  • notifyCamera() : OgreSharedRuns , OgreRenderable
Generated on Wed Mar 28 11:48:46 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

Here is a list of all documented class members with links to the class documentation for each member:

- o -

  • OgreCausticCasterRenderTechnique() : OgreCausticCasterRenderTechnique
  • OgreCausticCubeMapRenderingRun() : OgreCausticCubeMapRenderingRun
  • OgreCausticReceiverRenderTechnique() : OgreCausticReceiverRenderTechnique
  • OgreChildPSystemRenderingRun() : OgreChildPSystemRenderingRun
  • OgreColorCubeMapRenderTechnique() : OgreColorCubeMapRenderTechnique
  • OgreConvolvedCubeMapRenderTechnique() : OgreConvolvedCubeMapRenderTechnique
  • OgreCubeMapRenderingRun() : OgreCubeMapRenderingRun
  • OgreCubeMapRenderTechnique() : OgreCubeMapRenderTechnique
  • OgreDepthShadowMapRenderingRun() : OgreDepthShadowMapRenderingRun
  • OgreDepthShadowReceiverRenderTechnique() : OgreDepthShadowReceiverRenderTechnique
  • OgreDistanceCubeMapRenderTechnique() : OgreDistanceCubeMapRenderTechnique
  • OgreFireRenderTechnique() : OgreFireRenderTechnique
  • OgreFocusingMapRenderingRun() : OgreFocusingMapRenderingRun
  • OgreHierarchicalParticleSystemTechnique() : OgreHierarchicalParticleSystemTechnique
  • OgreIlluminationManager() : OgreIlluminationManager
  • OgreIllumVolumeRenderTechnique() : OgreIllumVolumeRenderTechnique
  • OgreLightVolumeRenderingRun() : OgreLightVolumeRenderingRun
  • OgrePathMapRenderTechnique() : OgrePathMapRenderTechnique
  • OgrePhaseTextureRenderingRun() : OgrePhaseTextureRenderingRun
  • OgrePhotonMapRenderingRun() : OgrePhotonMapRenderingRun
  • OgrePMEntryPointMapRenderingRun() : OgrePMEntryPointMapRenderingRun
  • OgrePMWeightComputeRenderingRun() : OgrePMWeightComputeRenderingRun
  • OgreReducedCubeMapRenderingRun() : OgreReducedCubeMapRenderingRun
  • OgreRenderable() : OgreRenderable
  • OgreRenderingRun() : OgreRenderingRun
  • OgreRenderTechnique() : OgreRenderTechnique
  • OgreSBBRenderTechnique() : OgreSBBRenderTechnique
  • OgreSceneCameraDepthRenderingRun() : OgreSceneCameraDepthRenderingRun
  • OgreSharedRuns() : OgreSharedRuns
Generated on Wed Mar 28 11:48:46 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

Here is a list of all documented class members with links to the class documentation for each member:

- ~ -

  • ~OgreCausticCasterRenderTechnique() : OgreCausticCasterRenderTechnique
  • ~OgreCausticReceiverRenderTechnique() : OgreCausticReceiverRenderTechnique
  • ~OgreColorCubeMapRenderTechnique() : OgreColorCubeMapRenderTechnique
  • ~OgreConvolvedCubeMapRenderTechnique() : OgreConvolvedCubeMapRenderTechnique
  • ~OgreCubeMapRenderTechnique() : OgreCubeMapRenderTechnique
  • ~OgreDepthShadowReceiverRenderTechnique() : OgreDepthShadowReceiverRenderTechnique
  • ~OgreDistanceCubeMapRenderTechnique() : OgreDistanceCubeMapRenderTechnique
  • ~OgreHierarchicalParticleSystemTechnique() : OgreHierarchicalParticleSystemTechnique
  • ~OgreIlluminationManager() : OgreIlluminationManager
  • ~OgreIllumVolumeRenderTechnique() : OgreIllumVolumeRenderTechnique
  • ~OgrePathMapRenderTechnique() : OgrePathMapRenderTechnique
  • ~OgreRenderable() : OgreRenderable
Generated on Wed Mar 28 11:48:46 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

Here is a list of all documented class members with links to the class documentation for each member:

- b -

  • billboardSetRenderable : OgreRenderable
  • blurCauCubeMap : OgreCausticCasterRenderTechnique
  • bluredCausticCubemapTexture : OgreCausticCubeMapRenderingRun
  • blurMap : OgreCausticCubeMapRenderingRun
  • blurredDepthMapTexture : OgreDepthShadowMapRenderingRun
  • blurredname : OgreDepthShadowMapRenderingRun
  • blurSM : OgreIlluminationManager
  • boundingBox : OgreRenderable , OgreSharedRuns
  • boundingSphere : OgreRenderable , OgreSharedRuns
Generated on Wed Mar 28 11:48:46 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

Here is a list of all documented class members with links to the class documentation for each member:

- c -

  • camera : OgreFocusingMapRenderingRun
  • canJoin() : RenderingRun , OgreSharedRuns , RenderingRun
  • CausticCasterRenderTechnique() : CausticCasterRenderTechnique
  • causticCasters : OgreCausticReceiverRenderTechnique
  • CausticCubeMapRenderingRun() : CausticCubeMapRenderingRun
  • causticCubeMapResolution : CausticCasterRenderTechnique
  • causticCubeMapRunChanged() : CausticCasterRenderTechnique
  • causticCubemapTexture : OgreCausticCubeMapRenderingRun
  • causticFragmentProgram : OgreCausticReceiverRenderTechnique
  • causticMapMaterialName : OgreCausticCasterRenderTechnique
  • CausticReceiverRenderTechnique() : CausticReceiverRenderTechnique
  • causticVertexProgram : OgreCausticReceiverRenderTechnique
  • child1 : SharedRuns
  • child2 : SharedRuns
  • childParticleSystemName : OgreChildPSystemRenderingRun
  • childPSysName : OgreHierarchicalParticleSystemTechnique
  • childPSysScriptName : OgreHierarchicalParticleSystemTechnique
  • ChildPsystemRenderingRun() : ChildPsystemRenderingRun
  • childTechniqueGroups : OgreSharedRuns
  • clusterLengthTexture : OgrePMEntryPointMapRenderingRun
  • clusters : PathMapClusters , OgrePathMapRenderTechnique
  • ColorCubeMapRenderTechnique() : ColorCubeMapRenderTechnique
  • colorCubeMapRunChanged() : ColorCubeMapRenderTechnique , ConvolvedCubeMapRenderTechnique
  • colorCubeMapRunUpdated() : ColorCubeMapRenderTechnique
  • ConvolvedCubeMapRenderTechnique() : ConvolvedCubeMapRenderTechnique
  • count : PathMapClusters
  • createCausticCubeMap() : CausticCubeMapRenderingRun
  • createCausticCubeMapRun() : CausticCasterRenderTechnique
  • createChildPSysRenderingRun() : HierarchicalParticleSystemTechnique
  • createCubeMap() : CubeMapRenderingRun
  • createCubeMapRun() : CubeMapRenderTechnique
  • createCubeRenderTexture() : OgreRenderingRun
  • createDepthMap() : DepthShadowMapRenderingRun , SceneCameraDepthRenderingRun
  • createDistanceCubeMapRun() : CausticCasterRenderTechnique
  • createEntryPointMap() : OgrePMEntryPointMapRenderingRun
  • createFocusingMap() : OgreFocusingMapRenderingRun
  • createGlobalRun() : OgreIlluminationManager
  • createImpostorTexture() : ChildPsystemRenderingRun
  • createInstance() : RenderTechniqueFactory , SharedRuns
  • createLightVolumeMap() : LightVolumeRenderingRun
  • createLightVolumeRenderingRun() : IllumVolumeRenderTechnique
  • createPerLightRun() : OgreIlluminationManager
  • createPhaseTexture() : OgrePhaseTextureRenderingRun , PhaseTextureRenderingRun
  • createPhotonMap() : PhotonMapRenderingRun
  • createPhotonMapRun() : CausticCasterRenderTechnique
  • createReducedCubeMap() : ReducedCubeMapRenderingRun
  • createReducedCubeMapRun() : ConvolvedCubeMapRenderTechnique
  • createTechnique() : OgreIlluminationManager
  • createWeightIndexTexture() : OgrePathMapRenderTechnique
  • createWeightMap() : OgrePMWeightComputeRenderingRun
  • cubemapLayer : CubeMapRenderTechnique
  • CubeMapRenderingRun() : CubeMapRenderingRun
  • CubeMapRenderTechnique() : CubeMapRenderTechnique
  • cubeMapResolution : CubeMapRenderTechnique
  • cubeMapRunChanged() : CubeMapRenderTechnique
  • cubeMapRunUpdated() : CubeMapRenderTechnique
  • cubemapTexture : OgreCubeMapRenderingRun
  • cubeMapUpdateInterval : CubeMapRenderTechnique
  • currentFace : ReducedCubeMapRenderingRun , CubeMapRenderingRun , CausticCubeMapRenderingRun , CubeMapRenderingRun
Generated on Wed Mar 28 11:48:46 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

Here is a list of all documented class members with links to the class documentation for each member:

- d -

  • depthMapCamera : OgreDepthShadowMapRenderingRun
  • depthMapTexture : OgreDepthShadowMapRenderingRun
  • DepthShadowMapRenderingRun() : DepthShadowMapRenderingRun
  • DepthShadowReceiverRenderTechnique() : DepthShadowReceiverRenderTechnique
  • depthTexID : OgreSBBRenderTechnique , OgreFireRenderTechnique
  • depthTexture : OgreSceneCameraDepthRenderingRun
  • destroy() : SharedRuns
  • DistanceCubeMapRenderTechnique() : DistanceCubeMapRenderTechnique
  • distanceCubeMapRunChanged() : CausticCasterRenderTechnique , DistanceCubeMapRenderTechnique
  • distanceCubeMapRunUpdated() : CausticCasterRenderTechnique , DistanceCubeMapRenderTechnique
  • distTolerance : CubeMapRenderTechnique , CubeMapRenderingRun , ReducedCubeMapRenderingRun , CubeMapRenderTechnique , ReducedCubeMapRenderingRun , CubeMapRenderTechnique , CubeMapRenderingRun , CubeMapRenderTechnique
Generated on Wed Mar 28 11:48:46 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

Here is a list of all documented class members with links to the class documentation for each member:

- e -

  • entryPointTexture : OgrePMEntryPointMapRenderingRun
  • environmentMaterial : OgreCubeMapRenderTechnique
Generated on Wed Mar 28 11:48:46 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

Here is a list of all documented class members with links to the class documentation for each member:

- f -

  • faceNeedsUpdate() : CausticCubeMapRenderingRun , CubeMapRenderingRun , ReducedCubeMapRenderingRun
  • fillVisibleList() : OgreIlluminationManager
  • findRenderableInParticleSystem() : OgreIlluminationManager
  • findSharedRootsForType() : OgreSharedRuns
  • fireRunChanges() : SharedRuns
  • focusingMapSize : OgreFocusingMapRenderingRun , OgreIlluminationManager
  • focusingSM : OgreIlluminationManager
  • focusingTexture : OgreFocusingMapRenderingRun
  • FParamRadius : OgreHierarchicalParticleSystemTechnique
  • frameStarted() : OgreIlluminationManager
  • fullscreenGrid : OgreRenderingRun
  • fullScreenQuad : OgreRenderingRun
  • fullScreenQuadEntity : OgreRenderingRun
  • fullScreenQuadNode : OgreRenderingRun
Generated on Wed Mar 28 11:48:46 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

Here is a list of all documented class members with links to the class documentation for each member:

- g -

  • gatherRuns() : SharedRuns
  • getAreaLightRadius() : OgreIlluminationManager
  • getAttenuation() : OgreCausticCubeMapRenderingRun , OgreCausticCasterRenderTechnique
  • getBlurShadowMap() : OgreIlluminationManager
  • getBoundingBox() : OgreSharedRuns , OgreRenderable
  • getBoundingSphere() : OgreSharedRuns , OgreRenderable
  • getCausticCubeMapName() : OgreCausticCasterRenderTechnique
  • getCausticCubeMapTextureName() : OgreCausticCubeMapRenderingRun
  • getClusterLengthTextureName() : OgrePMEntryPointMapRenderingRun
  • getCubeMapFaceDirection() : OgreRenderingRun
  • getCubeMapTextureName() : OgreCubeMapRenderingRun
  • getDepthMapTextureName() : OgreDepthShadowMapRenderingRun
  • getDepthTextureName() : OgreSceneCameraDepthRenderingRun
  • getEntryPointTextureName() : OgrePMEntryPointMapRenderingRun
  • getFocusingShadowMap() : OgreIlluminationManager
  • getFocusingTextureName() : OgreFocusingMapRenderingRun
  • getGlobalRun() : OgreIlluminationManager
  • getImpostorTextureName() : OgreChildPSystemRenderingRun
  • getLightFarPlane() : OgreDepthShadowMapRenderingRun
  • getLightViewMatrix() : OgreDepthShadowMapRenderingRun
  • getLightViewProjectionMatrix() : OgreLightVolumeRenderingRun
  • getLightViewProjMatrix() : OgreDepthShadowMapRenderingRun
  • getLightVolumeTextureName() : OgreLightVolumeRenderingRun
  • getMainCamera() : OgreIlluminationManager
  • getMainViewport() : OgreIlluminationManager
  • getMaterial() : OgreRenderable
  • getMaterialName() : OgreRenderable
  • getMaterialPtr() : OgreRenderable
  • getMaxJoinRadius() : OgreIlluminationManager
  • getMinMax() : OgreFocusingMapRenderingRun , OgreCubeMapRenderTechnique
  • getName() : OgreRenderable
  • getNearestCausticCasters() : OgreIlluminationManager
  • getParentRenderable() : RenderTechnique
  • getPathMapClusterLength() : OgreIlluminationManager
  • getPathMapClusterLengthsSize() : OgreIlluminationManager
  • getPathMapClusters() : OgreIlluminationManager
  • getPathMapEntryPoints() : OgreIlluminationManager
  • getPerLightRun() : OgreIlluminationManager
  • getPhaseTextureName() : OgrePhaseTextureRenderingRun
  • getPhotonMapTextureName() : OgrePhotonMapRenderingRun
  • getPMWeightTetureName() : OgrePMWeightComputeRenderingRun
  • getReducedCubeMapTextureName() : OgreReducedCubeMapRenderingRun
  • getRenderable() : OgreRenderable
  • getRoot() : SharedRuns
  • getRootBoundingBox() : OgreSharedRuns
  • getRootBoundingSphere() : OgreSharedRuns
  • getRootPosition() : OgreSharedRuns
  • getRun() : SharedRuns
  • getSharedRuns() : TechniqueGroup , OgreSharedRuns
  • getSingleton() : OgreIlluminationManager
  • getSmallSysRadius() : OgreChildPSystemRenderingRun
  • getUseLISPSM() : OgreIlluminationManager
  • globalSharedRuns : OgreIlluminationManager
Generated on Wed Mar 28 11:48:46 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

Here is a list of all documented class members with links to the class documentation for each member:

- h -

  • hasOwnRun() : SharedRuns , OgreSharedRuns
  • haveCommonRuns() : OgreSharedRuns
  • hide() : SharedRuns
  • hideRenderables() : SharedRuns
  • hierarchicalImpostorUpdated() : IllumVolumeRenderTechnique
  • HierarchicalParticleSystemTechnique() : HierarchicalParticleSystemTechnique
Generated on Wed Mar 28 11:48:46 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

Here is a list of all documented class members with links to the class documentation for each member:

- i -

  • ILLUM_ATTRIBUTE_PARSER : RenderTechniqueFactory
  • illumTexID : OgreIllumVolumeRenderTechnique
  • illumTextureResolution : IllumVolumeRenderTechnique
  • IllumVolumeRenderTechnique() : IllumVolumeRenderTechnique
  • illumVolumeUpdateInterval : IllumVolumeRenderTechnique
  • impostorCamera : OgreChildPSystemRenderingRun
  • impostorChanged() : HierarchicalParticleSystemTechnique
  • impostorMaterialName : OgreHierarchicalParticleSystemTechnique
  • impostorResolution : HierarchicalParticleSystemTechnique
  • impostorTexID : OgreIllumVolumeRenderTechnique , OgreHierarchicalParticleSystemTechnique
  • impostorTexture : OgreChildPSystemRenderingRun
  • impostorUpdated() : HierarchicalParticleSystemTechnique
  • impostorUpdateInterval : HierarchicalParticleSystemTechnique
  • initTechniques() : OgreIlluminationManager
  • instance : OgreIlluminationManager
  • isType() : RenderTechniqueFactory
  • isVisible() : ElementaryRenderable , OgreRenderable
Generated on Wed Mar 28 11:48:46 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

Here is a list of all documented class members with links to the class documentation for each member:

- p -

  • parent : SharedRuns
  • parentEntity : OgreRenderable
  • parentOgreRenderable : OgreRenderTechnique
  • parentOgreTechniqueGroup : OgreRenderTechnique
  • parentParticleSystem : OgreRenderable
  • parentRenderable : RenderTechnique
  • parentSharedRuns : TechniqueGroup
  • parentTechniqueGroup : RenderTechnique
  • parseParams() : RenderTechniqueFactory
  • particleScriptName : OgreChildPSystemRenderingRun
  • pass : OgreRenderTechnique
  • passes : OgreCausticReceiverRenderTechnique , OgreDepthShadowReceiverRenderTechnique
  • pathMapClusterLengths : OgreIlluminationManager
  • pathMapClusters : OgreIlluminationManager
  • pathMapEntryPoints : OgreIlluminationManager
  • pathMapPass : OgrePathMapRenderTechnique
  • pathMapResolution : PathMapClusters
  • pathMapTextureFilename : PathMapClusters
  • perLightRuns : OgreIlluminationManager
  • perspectiveRendering : HierarchicalParticleSystemTechnique , ChildPsystemRenderingRun , HierarchicalParticleSystemTechnique , OgreChildPSystemRenderingRun
  • phaseCamera : OgrePhaseTextureRenderingRun
  • phaseTexture : OgrePhaseTextureRenderingRun
  • PhaseTextureRenderingRun() : PhaseTextureRenderingRun
  • phaseTextureSize : OgreIlluminationManager
  • photonMapCamera : OgrePhotonMapRenderingRun
  • photonMapChanged() : CausticCubeMapRenderingRun
  • photonMapMaterialName : OgreCausticCasterRenderTechnique
  • PhotonMapRenderingRun() : PhotonMapRenderingRun
  • photonMapResolution : CausticCasterRenderTechnique
  • photonMapRunChanged() : CausticCasterRenderTechnique
  • photonMapTexID : OgreCausticCasterRenderTechnique
  • photonMapTexId : OgreCausticCubeMapRenderingRun
  • photonMapTexture : OgrePhotonMapRenderingRun
  • photonMapUpdateInterval : CausticCasterRenderTechnique
  • pixelSprites : OgreRenderingRun
  • playerCamera : OgreSceneCameraDepthRenderingRun
  • playerView : OgreSceneCameraDepthRenderingRun
  • position : PathMapEntryPoint
  • postAllUpdates() : OgreIlluminationManager , UpdateListener
  • preAllUpdates() : UpdateListener , OgreIlluminationManager
  • prob : PathMapEntryPoint
Generated on Wed Mar 28 11:48:46 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

Here is a list of all documented class members with links to the class documentation for each member:

- r -

  • ReducedCubeMapRenderingRun() : ReducedCubeMapRenderingRun
  • reducedCubeMapResolution : ConvolvedCubeMapRenderTechnique
  • reducedCubeMapRunChanged() : ConvolvedCubeMapRenderTechnique
  • reducedCubemapTexture : OgreReducedCubeMapRenderingRun
  • refreshLight() : OgreDepthShadowMapRenderingRun , OgreLightVolumeRenderingRun , OgrePhotonMapRenderingRun
  • renderableMaterials : OgreSharedRuns
  • renderables : OgreSharedRuns
  • renderableType : OgreRenderable
  • renderEnvironment : CubeMapRenderTechnique , CubeMapRenderingRun , CubeMapRenderTechnique , CubeMapRenderingRun , CubeMapRenderTechnique
  • renderFullscreenGrid() : OgreRenderingRun
  • renderFullscreenQuad() : OgreRenderingRun
  • RenderingRun() : RenderingRun
  • renderPixelSprites() : OgreRenderingRun
  • renderSelf : CubeMapRenderTechnique , CubeMapRenderingRun , CubeMapRenderTechnique , CubeMapRenderingRun , CubeMapRenderTechnique
  • RenderTechnique() : RenderTechnique
  • renderTechniques : OgreTechniqueGroup
  • resolution : LightVolumeRenderingRun , ChildPsystemRenderingRun , OgrePhotonMapRenderingRun , ReducedCubeMapRenderingRun , CubeMapRenderingRun , CausticCubeMapRenderingRun , ChildPsystemRenderingRun , ReducedCubeMapRenderingRun , CubeMapRenderingRun , LightVolumeRenderingRun , CausticCubeMapRenderingRun
  • resolutionX : PhaseTextureRenderingRun , DepthShadowMapRenderingRun
  • resolutionY : PhaseTextureRenderingRun , DepthShadowMapRenderingRun
  • restoreMaterial() : OgreSharedRuns
  • restoreMaterials() : OgreRenderingRun
  • restoreRenderableVisibility() : SharedRuns
  • restoreVisibility() : SharedRuns
  • runChanged() : TechniqueGroup , RenderTechnique , SharedRuns , RenderTechnique
  • runUpdated() : RenderTechnique , TechniqueGroup , RenderTechnique , SharedRuns
Generated on Wed Mar 28 11:48:46 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

Here is a list of all documented class members with links to the class documentation for each member:

- s -

  • savePhaseTextureToFile() : OgreIlluminationManager
  • SBBRenderTechnique() : SBBRenderTechnique
  • SceneCameraDepthRenderingRun() : SceneCameraDepthRenderingRun
  • selfMaterial : OgreCubeMapRenderTechnique
  • setAreaLigtRadius() : OgreIlluminationManager
  • setBlurMap() : OgreCausticCubeMapRenderingRun
  • setBlurShadowMap() : OgreIlluminationManager
  • setBoundingBox() : OgreSharedRuns
  • setBoundingSphere() : OgreSharedRuns
  • setCameraMatrices() : OgreFocusingMapRenderingRun
  • setFireRenderTargetSize() : OgreIlluminationManager
  • setFocusingMapSize() : OgreIlluminationManager
  • setFocusingSM() : OgreIlluminationManager
  • setLightMatrix() : OgreFocusingMapRenderingRun
  • setLightProjFarPlane : OgreDepthShadowReceiverRenderTechnique
  • setLightViewMatrix : OgreDepthShadowReceiverRenderTechnique
  • setLightViewProjMatrix : OgreDepthShadowReceiverRenderTechnique
  • setMainCamera() : OgreIlluminationManager
  • setMainViewport() : OgreIlluminationManager
  • setMaterial() : OgreSharedRuns
  • setMaterialForRenderables() : OgreRenderingRun
  • setMaterialForVisibles() : OgreRenderingRun
  • setMaterialName() : OgreRenderable
  • setMaxJoinRadius() : OgreIlluminationManager
  • setPhaseTextureSize() : OgreIlluminationManager
  • setRenderablesVisible() : SharedRuns
  • setRenderGroup() : OgreRenderable , ElementaryRenderable
  • setShadowMapMaterialName() : OgreIlluminationManager
  • setShadowMapSize() : OgreIlluminationManager
  • setUseLISPSM() : OgreIlluminationManager
  • setVisible() : SharedRuns , ElementaryRenderable , OgreRenderable
  • shadowFragmentProgram : OgreDepthShadowReceiverRenderTechnique
  • shadowMapMaterialName : OgreIlluminationManager
  • shadowMapSize : OgreIlluminationManager
  • shadowVertexProgram : OgreDepthShadowReceiverRenderTechnique
  • sharedRunJoin() : IlluminationManager , OgreIlluminationManager
  • sharedRunRoots : OgreIlluminationManager
  • sharedRuns : RenderTechnique , OgreCubeMapRenderingRun , RenderTechnique , OgreCausticCubeMapRenderingRun , RenderTechnique
  • SharedRuns() : SharedRuns
  • sharedRuns : RenderTechnique , OgreDepthShadowMapRenderingRun , OgreLightVolumeRenderingRun , RenderTechnique , OgreReducedCubeMapRenderingRun , RenderTechnique , OgreSceneCameraDepthRenderingRun , RenderTechnique , OgreSharedRuns , RenderTechnique , OgrePhotonMapRenderingRun , RenderTechnique , OgreChildPSystemRenderingRun , RenderTechnique
  • sharedRunSplit() : IlluminationManager , OgreIlluminationManager
  • spriteSetName : OgreRenderingRun
  • startFrame : CubeMapRenderTechnique , RenderingRun , CubeMapRenderTechnique , RenderingRun , CausticCasterRenderTechnique , RenderingRun , CubeMapRenderTechnique , RenderingRun , HierarchicalParticleSystemTechnique , IllumVolumeRenderTechnique , RenderingRun , CubeMapRenderTechnique , RenderingRun , CubeMapRenderTechnique , RenderingRun , CubeMapRenderTechnique , CausticCasterRenderTechnique , IllumVolumeRenderTechnique , RenderingRun
  • subEntityRenderable : OgreRenderable
  • sysRad : OgreChildPSystemRenderingRun
  • systemRadius : OgreLightVolumeRenderingRun
Generated on Wed Mar 28 11:48:46 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

Here is a list of all documented class members with links to the class documentation for each member:

- t -

  • techniqueFactories : OgreIlluminationManager
  • TechniqueGroup() : TechniqueGroup
  • texID : OgreCubeMapRenderTechnique
  • textureDepth : IllumVolumeRenderTechnique , LightVolumeRenderingRun
  • typeName : RenderTechniqueFactory
Generated on Wed Mar 28 11:48:46 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

Here is a list of all documented class members with links to the class documentation for each member:

- u -

  • unbindAndKillParent() : SharedRuns
  • unbindParent() : SharedRuns
  • update() : RenderingRun , ColorCubeMapRenderTechnique , RenderTechnique , RenderingRun , RenderTechnique , RenderingRun , ConvolvedCubeMapRenderTechnique , DistanceCubeMapRenderTechnique , RenderTechnique , IlluminationManager , RenderTechnique , TechniqueGroup , RenderingRun , OgreIlluminationManager , RenderingRun , RenderTechnique , RenderingRun , RenderTechnique , RenderingRun , RenderTechnique , RenderingRun
  • updateAllFace : ReducedCubeMapRenderingRun , CausticCasterRenderTechnique , CubeMapRenderTechnique , CubeMapRenderingRun , CubeMapRenderTechnique , CausticCasterRenderTechnique , ReducedCubeMapRenderingRun , CubeMapRenderTechnique , CausticCubeMapRenderingRun
  • updateBounds() : SharedRuns , TechniqueGroup , OgreRenderable , ElementaryRenderable
  • updateCubeFace() : ReducedCubeMapRenderingRun , CubeMapRenderingRun , CausticCubeMapRenderingRun
  • updateDepthCubeFace() : DepthShadowMapRenderingRun
  • updateDepthMap() : DepthShadowMapRenderingRun
  • updateFrame() : RenderingRun
  • updateGlobalRun() : OgreIlluminationManager
  • updateInterval : RenderingRun
  • updateListeners : OgreIlluminationManager
  • updatePerLightRun() : OgreIlluminationManager
  • updateRenderQueue() : OgreRenderable
  • updateRun() : SharedRuns
  • useDistance : CausticCasterRenderTechnique , OgrePhotonMapRenderingRun , CausticCasterRenderTechnique
  • useDistCalc : IllumVolumeRenderTechnique , CubeMapRenderTechnique , ReducedCubeMapRenderingRun , CubeMapRenderTechnique , ReducedCubeMapRenderingRun , HierarchicalParticleSystemTechnique , CubeMapRenderingRun , HierarchicalParticleSystemTechnique , CubeMapRenderTechnique , CubeMapRenderingRun , IllumVolumeRenderTechnique , CubeMapRenderTechnique
  • useFaceAngleCalc : CubeMapRenderTechnique , CubeMapRenderingRun , CubeMapRenderTechnique , CubeMapRenderingRun , ReducedCubeMapRenderingRun , CubeMapRenderTechnique , ReducedCubeMapRenderingRun , CubeMapRenderTechnique
  • useFParam : OgreHierarchicalParticleSystemTechnique
  • useHierarchicalImpostor : IllumVolumeRenderTechnique
  • useLISPSM : OgreIlluminationManager
  • useOwnMaterial : OgreChildPSystemRenderingRun , OgreHierarchicalParticleSystemTechnique
  • useTriangles : OgreCausticCasterRenderTechnique , OgreCausticCubeMapRenderingRun
  • useVParam : OgreHierarchicalParticleSystemTechnique
Generated on Wed Mar 28 11:48:46 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

Here is a list of all documented class members with links to the class documentation for each member:

- v -

  • validate() : SharedRuns
  • validateSharedRuns() : TechniqueGroup
  • visibleObjects : OgreRenderingRun , OgreIlluminationManager , OgreRenderingRun
  • visitor : OgreIlluminationManager
  • VParamRadius : OgreHierarchicalParticleSystemTechnique
Generated on Wed Mar 28 11:48:46 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

Here is a list of all documented class members with links to the class documentation for each member:

- w -

  • weightIndexTexture : OgrePathMapRenderTechnique
  • weightTexture : OgrePMWeightComputeRenderingRun
  • WorldParamName : OgreDepthShadowReceiverRenderTechnique
  • WorldViewProjParamName : OgreDepthShadowReceiverRenderTechnique
Generated on Wed Mar 28 11:48:46 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • a
  • c
  • d
  • f
  • g
  • h
  • i
  • j
  • l
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • ~

- a -

  • addPathMapClusterLength() : OgreIlluminationManager
  • addPathMapClusters() : OgreIlluminationManager
  • addPathMapEntryPoint() : OgreIlluminationManager
  • addRenderablesToQueue() : OgreSharedRuns
  • addRenderTechnique() : TechniqueGroup
  • addRenderTechniqueFactory() : OgreIlluminationManager
  • addRun() : SharedRuns
  • addSharedRun() : TechniqueGroup
  • addSharedRuns() : IlluminationManager , OgreIlluminationManager
  • addTechniqueGroup() : SharedRuns
  • addUpdateListener() : OgreIlluminationManager
  • asOgreRenderingRun() : OgreRenderingRun , RenderingRun , OgreRenderingRun , RenderingRun , OgreRenderingRun , RenderingRun , OgreRenderingRun , RenderingRun , OgreRenderingRun , RenderingRun , OgreRenderingRun , RenderingRun , OgreRenderingRun , RenderingRun , OgreRenderingRun , RenderingRun , OgreRenderingRun , RenderingRun , OgreRenderingRun
  • asOgreRenderTechnique() : RenderTechnique
Generated on Wed Mar 28 11:48:46 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • a
  • c
  • d
  • f
  • g
  • h
  • i
  • j
  • l
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • ~

- j -

  • joinRuns() : SharedRuns
  • joinSharedRuns() : OgreIlluminationManager , IlluminationManager
Generated on Wed Mar 28 11:48:46 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • a
  • c
  • d
  • f
  • g
  • h
  • i
  • j
  • l
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • ~

- l -

  • lightVolumeChanged() : IllumVolumeRenderTechnique
  • LightVolumeRenderingRun() : LightVolumeRenderingRun
  • lightVolumeUpdated() : IllumVolumeRenderTechnique
Generated on Wed Mar 28 11:48:46 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • a
  • c
  • d
  • f
  • g
  • h
  • i
  • j
  • l
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • ~

- n -

  • needUpdate() : RenderingRun
  • notifyCamera() : OgreSharedRuns , OgreRenderable
Generated on Wed Mar 28 11:48:46 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • a
  • c
  • d
  • f
  • g
  • h
  • i
  • j
  • l
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • ~

- o -

  • OgreCausticCasterRenderTechnique() : OgreCausticCasterRenderTechnique
  • OgreCausticCubeMapRenderingRun() : OgreCausticCubeMapRenderingRun
  • OgreCausticReceiverRenderTechnique() : OgreCausticReceiverRenderTechnique
  • OgreChildPSystemRenderingRun() : OgreChildPSystemRenderingRun
  • OgreColorCubeMapRenderTechnique() : OgreColorCubeMapRenderTechnique
  • OgreConvolvedCubeMapRenderTechnique() : OgreConvolvedCubeMapRenderTechnique
  • OgreCubeMapRenderingRun() : OgreCubeMapRenderingRun
  • OgreCubeMapRenderTechnique() : OgreCubeMapRenderTechnique
  • OgreDepthShadowMapRenderingRun() : OgreDepthShadowMapRenderingRun
  • OgreDepthShadowReceiverRenderTechnique() : OgreDepthShadowReceiverRenderTechnique
  • OgreDistanceCubeMapRenderTechnique() : OgreDistanceCubeMapRenderTechnique
  • OgreFireRenderTechnique() : OgreFireRenderTechnique
  • OgreFocusingMapRenderingRun() : OgreFocusingMapRenderingRun
  • OgreHierarchicalParticleSystemTechnique() : OgreHierarchicalParticleSystemTechnique
  • OgreIlluminationManager() : OgreIlluminationManager
  • OgreIllumVolumeRenderTechnique() : OgreIllumVolumeRenderTechnique
  • OgreLightVolumeRenderingRun() : OgreLightVolumeRenderingRun
  • OgrePathMapRenderTechnique() : OgrePathMapRenderTechnique
  • OgrePhaseTextureRenderingRun() : OgrePhaseTextureRenderingRun
  • OgrePhotonMapRenderingRun() : OgrePhotonMapRenderingRun
  • OgrePMEntryPointMapRenderingRun() : OgrePMEntryPointMapRenderingRun
  • OgrePMWeightComputeRenderingRun() : OgrePMWeightComputeRenderingRun
  • OgreReducedCubeMapRenderingRun() : OgreReducedCubeMapRenderingRun
  • OgreRenderable() : OgreRenderable
  • OgreRenderingRun() : OgreRenderingRun
  • OgreRenderTechnique() : OgreRenderTechnique
  • OgreSBBRenderTechnique() : OgreSBBRenderTechnique
  • OgreSceneCameraDepthRenderingRun() : OgreSceneCameraDepthRenderingRun
  • OgreSharedRuns() : OgreSharedRuns
Generated on Wed Mar 28 11:48:46 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • a
  • c
  • d
  • f
  • g
  • h
  • i
  • j
  • l
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • ~

- ~ -

  • ~OgreCausticCasterRenderTechnique() : OgreCausticCasterRenderTechnique
  • ~OgreCausticReceiverRenderTechnique() : OgreCausticReceiverRenderTechnique
  • ~OgreColorCubeMapRenderTechnique() : OgreColorCubeMapRenderTechnique
  • ~OgreConvolvedCubeMapRenderTechnique() : OgreConvolvedCubeMapRenderTechnique
  • ~OgreCubeMapRenderTechnique() : OgreCubeMapRenderTechnique
  • ~OgreDepthShadowReceiverRenderTechnique() : OgreDepthShadowReceiverRenderTechnique
  • ~OgreDistanceCubeMapRenderTechnique() : OgreDistanceCubeMapRenderTechnique
  • ~OgreHierarchicalParticleSystemTechnique() : OgreHierarchicalParticleSystemTechnique
  • ~OgreIlluminationManager() : OgreIlluminationManager
  • ~OgreIllumVolumeRenderTechnique() : OgreIllumVolumeRenderTechnique
  • ~OgrePathMapRenderTechnique() : OgrePathMapRenderTechnique
  • ~OgreRenderable() : OgreRenderable
Generated on Wed Mar 28 11:48:46 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • a
  • c
  • d
  • f
  • g
  • h
  • i
  • j
  • l
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • ~

- c -

  • canJoin() : RenderingRun , OgreSharedRuns , RenderingRun
  • CausticCasterRenderTechnique() : CausticCasterRenderTechnique
  • CausticCubeMapRenderingRun() : CausticCubeMapRenderingRun
  • causticCubeMapRunChanged() : CausticCasterRenderTechnique
  • CausticReceiverRenderTechnique() : CausticReceiverRenderTechnique
  • ChildPsystemRenderingRun() : ChildPsystemRenderingRun
  • ColorCubeMapRenderTechnique() : ColorCubeMapRenderTechnique
  • colorCubeMapRunChanged() : ConvolvedCubeMapRenderTechnique , ColorCubeMapRenderTechnique
  • colorCubeMapRunUpdated() : ColorCubeMapRenderTechnique
  • ConvolvedCubeMapRenderTechnique() : ConvolvedCubeMapRenderTechnique
  • createCausticCubeMap() : CausticCubeMapRenderingRun
  • createCausticCubeMapRun() : CausticCasterRenderTechnique
  • createChildPSysRenderingRun() : HierarchicalParticleSystemTechnique
  • createCubeMap() : CubeMapRenderingRun
  • createCubeMapRun() : CubeMapRenderTechnique
  • createCubeRenderTexture() : OgreRenderingRun
  • createDepthMap() : DepthShadowMapRenderingRun , SceneCameraDepthRenderingRun
  • createDistanceCubeMapRun() : CausticCasterRenderTechnique
  • createEntryPointMap() : OgrePMEntryPointMapRenderingRun
  • createFocusingMap() : OgreFocusingMapRenderingRun
  • createGlobalRun() : OgreIlluminationManager
  • createImpostorTexture() : ChildPsystemRenderingRun
  • createInstance() : RenderTechniqueFactory , SharedRuns
  • createLightVolumeMap() : LightVolumeRenderingRun
  • createLightVolumeRenderingRun() : IllumVolumeRenderTechnique
  • createPerLightRun() : OgreIlluminationManager
  • createPhaseTexture() : OgrePhaseTextureRenderingRun , PhaseTextureRenderingRun
  • createPhotonMap() : PhotonMapRenderingRun
  • createPhotonMapRun() : CausticCasterRenderTechnique
  • createReducedCubeMap() : ReducedCubeMapRenderingRun
  • createReducedCubeMapRun() : ConvolvedCubeMapRenderTechnique
  • createTechnique() : OgreIlluminationManager
  • createWeightIndexTexture() : OgrePathMapRenderTechnique
  • createWeightMap() : OgrePMWeightComputeRenderingRun
  • CubeMapRenderingRun() : CubeMapRenderingRun
  • CubeMapRenderTechnique() : CubeMapRenderTechnique
  • cubeMapRunChanged() : CubeMapRenderTechnique
  • cubeMapRunUpdated() : CubeMapRenderTechnique
Generated on Wed Mar 28 11:48:46 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • a
  • c
  • d
  • f
  • g
  • h
  • i
  • j
  • l
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • ~

- d -

  • DepthShadowMapRenderingRun() : DepthShadowMapRenderingRun
  • DepthShadowReceiverRenderTechnique() : DepthShadowReceiverRenderTechnique
  • destroy() : SharedRuns
  • DistanceCubeMapRenderTechnique() : DistanceCubeMapRenderTechnique
  • distanceCubeMapRunChanged() : CausticCasterRenderTechnique , DistanceCubeMapRenderTechnique
  • distanceCubeMapRunUpdated() : CausticCasterRenderTechnique , DistanceCubeMapRenderTechnique
Generated on Wed Mar 28 11:48:46 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • a
  • c
  • d
  • f
  • g
  • h
  • i
  • j
  • l
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • ~

- f -

  • faceNeedsUpdate() : CausticCubeMapRenderingRun , CubeMapRenderingRun , ReducedCubeMapRenderingRun
  • fillVisibleList() : OgreIlluminationManager
  • findRenderableInParticleSystem() : OgreIlluminationManager
  • findSharedRootsForType() : OgreSharedRuns
  • fireRunChanges() : SharedRuns
  • frameStarted() : OgreIlluminationManager
Generated on Wed Mar 28 11:48:46 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • a
  • c
  • d
  • f
  • g
  • h
  • i
  • j
  • l
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • ~

- g -

  • gatherRuns() : SharedRuns
  • getAreaLightRadius() : OgreIlluminationManager
  • getAttenuation() : OgreCausticCubeMapRenderingRun , OgreCausticCasterRenderTechnique
  • getBlurShadowMap() : OgreIlluminationManager
  • getBoundingBox() : OgreSharedRuns , OgreRenderable
  • getBoundingSphere() : OgreSharedRuns , OgreRenderable
  • getCausticCubeMapName() : OgreCausticCasterRenderTechnique
  • getCausticCubeMapTextureName() : OgreCausticCubeMapRenderingRun
  • getClusterLengthTextureName() : OgrePMEntryPointMapRenderingRun
  • getCubeMapFaceDirection() : OgreRenderingRun
  • getCubeMapTextureName() : OgreCubeMapRenderingRun
  • getDepthMapTextureName() : OgreDepthShadowMapRenderingRun
  • getDepthTextureName() : OgreSceneCameraDepthRenderingRun
  • getEntryPointTextureName() : OgrePMEntryPointMapRenderingRun
  • getFocusingShadowMap() : OgreIlluminationManager
  • getFocusingTextureName() : OgreFocusingMapRenderingRun
  • getGlobalRun() : OgreIlluminationManager
  • getImpostorTextureName() : OgreChildPSystemRenderingRun
  • getLightFarPlane() : OgreDepthShadowMapRenderingRun
  • getLightViewMatrix() : OgreDepthShadowMapRenderingRun
  • getLightViewProjectionMatrix() : OgreLightVolumeRenderingRun
  • getLightViewProjMatrix() : OgreDepthShadowMapRenderingRun
  • getLightVolumeTextureName() : OgreLightVolumeRenderingRun
  • getMainCamera() : OgreIlluminationManager
  • getMainViewport() : OgreIlluminationManager
  • getMaterial() : OgreRenderable
  • getMaterialName() : OgreRenderable
  • getMaterialPtr() : OgreRenderable
  • getMaxJoinRadius() : OgreIlluminationManager
  • getMinMax() : OgreFocusingMapRenderingRun
  • getName() : OgreRenderable
  • getNearestCausticCasters() : OgreIlluminationManager
  • getParentRenderable() : RenderTechnique
  • getPathMapClusterLength() : OgreIlluminationManager
  • getPathMapClusterLengthsSize() : OgreIlluminationManager
  • getPathMapClusters() : OgreIlluminationManager
  • getPathMapEntryPoints() : OgreIlluminationManager
  • getPerLightRun() : OgreIlluminationManager
  • getPhaseTextureName() : OgrePhaseTextureRenderingRun
  • getPhotonMapTextureName() : OgrePhotonMapRenderingRun
  • getPMWeightTetureName() : OgrePMWeightComputeRenderingRun
  • getReducedCubeMapTextureName() : OgreReducedCubeMapRenderingRun
  • getRenderable() : OgreRenderable
  • getRoot() : SharedRuns
  • getRootBoundingBox() : OgreSharedRuns
  • getRootBoundingSphere() : OgreSharedRuns
  • getRootPosition() : OgreSharedRuns
  • getRun() : SharedRuns
  • getSharedRuns() : TechniqueGroup , OgreSharedRuns
  • getSingleton() : OgreIlluminationManager
  • getSmallSysRadius() : OgreChildPSystemRenderingRun
  • getUseLISPSM() : OgreIlluminationManager
Generated on Wed Mar 28 11:48:46 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • a
  • c
  • d
  • f
  • g
  • h
  • i
  • j
  • l
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • ~

- h -

  • hasOwnRun() : SharedRuns , OgreSharedRuns
  • haveCommonRuns() : OgreSharedRuns
  • hide() : SharedRuns
  • hideRenderables() : SharedRuns
  • hierarchicalImpostorUpdated() : IllumVolumeRenderTechnique
  • HierarchicalParticleSystemTechnique() : HierarchicalParticleSystemTechnique
Generated on Wed Mar 28 11:48:46 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • a
  • c
  • d
  • f
  • g
  • h
  • i
  • j
  • l
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • ~

- i -

  • IllumVolumeRenderTechnique() : IllumVolumeRenderTechnique
  • impostorChanged() : HierarchicalParticleSystemTechnique
  • impostorUpdated() : HierarchicalParticleSystemTechnique
  • initTechniques() : OgreIlluminationManager
  • isType() : RenderTechniqueFactory
  • isVisible() : ElementaryRenderable , OgreRenderable
Generated on Wed Mar 28 11:48:46 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • a
  • c
  • d
  • f
  • g
  • h
  • i
  • j
  • l
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • ~

- p -

  • parseParams() : RenderTechniqueFactory
  • PhaseTextureRenderingRun() : PhaseTextureRenderingRun
  • photonMapChanged() : CausticCubeMapRenderingRun
  • PhotonMapRenderingRun() : PhotonMapRenderingRun
  • photonMapRunChanged() : CausticCasterRenderTechnique
  • postAllUpdates() : OgreIlluminationManager , UpdateListener
  • preAllUpdates() : OgreIlluminationManager , UpdateListener
Generated on Wed Mar 28 11:48:46 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • a
  • c
  • d
  • f
  • g
  • h
  • i
  • j
  • l
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • ~

- r -

  • ReducedCubeMapRenderingRun() : ReducedCubeMapRenderingRun
  • reducedCubeMapRunChanged() : ConvolvedCubeMapRenderTechnique
  • refreshLight() : OgreDepthShadowMapRenderingRun , OgreLightVolumeRenderingRun , OgrePhotonMapRenderingRun
  • renderFullscreenGrid() : OgreRenderingRun
  • renderFullscreenQuad() : OgreRenderingRun
  • RenderingRun() : RenderingRun
  • renderPixelSprites() : OgreRenderingRun
  • RenderTechnique() : RenderTechnique
  • restoreMaterial() : OgreSharedRuns
  • restoreMaterials() : OgreRenderingRun
  • restoreRenderableVisibility() : SharedRuns
  • restoreVisibility() : SharedRuns
  • runChanged() : RenderTechnique , SharedRuns , RenderTechnique , TechniqueGroup , RenderTechnique
  • runUpdated() : RenderTechnique , SharedRuns , RenderTechnique , TechniqueGroup , RenderTechnique
Generated on Wed Mar 28 11:48:46 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • a
  • c
  • d
  • f
  • g
  • h
  • i
  • j
  • l
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • ~

- s -

  • savePhaseTextureToFile() : OgreIlluminationManager
  • SBBRenderTechnique() : SBBRenderTechnique
  • SceneCameraDepthRenderingRun() : SceneCameraDepthRenderingRun
  • setAreaLigtRadius() : OgreIlluminationManager
  • setBlurMap() : OgreCausticCubeMapRenderingRun
  • setBlurShadowMap() : OgreIlluminationManager
  • setBoundingBox() : OgreSharedRuns
  • setBoundingSphere() : OgreSharedRuns
  • setCameraMatrices() : OgreFocusingMapRenderingRun
  • setFireRenderTargetSize() : OgreIlluminationManager
  • setFocusingMapSize() : OgreIlluminationManager
  • setFocusingSM() : OgreIlluminationManager
  • setLightMatrix() : OgreFocusingMapRenderingRun
  • setMainCamera() : OgreIlluminationManager
  • setMainViewport() : OgreIlluminationManager
  • setMaterial() : OgreSharedRuns
  • setMaterialForRenderables() : OgreRenderingRun
  • setMaterialForVisibles() : OgreRenderingRun
  • setMaterialName() : OgreRenderable
  • setMaxJoinRadius() : OgreIlluminationManager
  • setPhaseTextureSize() : OgreIlluminationManager
  • setRenderablesVisible() : SharedRuns
  • setRenderGroup() : OgreRenderable , ElementaryRenderable
  • setShadowMapMaterialName() : OgreIlluminationManager
  • setShadowMapSize() : OgreIlluminationManager
  • setUseLISPSM() : OgreIlluminationManager
  • setVisible() : OgreRenderable , SharedRuns , ElementaryRenderable
  • sharedRunJoin() : IlluminationManager , OgreIlluminationManager
  • SharedRuns() : SharedRuns
  • sharedRunSplit() : OgreIlluminationManager , IlluminationManager
Generated on Wed Mar 28 11:48:46 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • a
  • c
  • d
  • f
  • g
  • h
  • i
  • j
  • l
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • ~

- t -

  • TechniqueGroup() : TechniqueGroup
Generated on Wed Mar 28 11:48:46 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • a
  • c
  • d
  • f
  • g
  • h
  • i
  • j
  • l
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • ~

- u -

  • unbindAndKillParent() : SharedRuns
  • unbindParent() : SharedRuns
  • update() : RenderingRun , IlluminationManager , RenderTechnique , RenderingRun , RenderTechnique , RenderingRun , TechniqueGroup , RenderTechnique , RenderingRun , ColorCubeMapRenderTechnique , OgreIlluminationManager , RenderingRun , RenderTechnique , ConvolvedCubeMapRenderTechnique , RenderTechnique , RenderingRun , RenderTechnique , RenderingRun , DistanceCubeMapRenderTechnique , RenderingRun , RenderTechnique , RenderingRun
  • updateBounds() : OgreRenderable , ElementaryRenderable , TechniqueGroup , SharedRuns
  • updateCubeFace() : ReducedCubeMapRenderingRun , CubeMapRenderingRun , CausticCubeMapRenderingRun
  • updateDepthCubeFace() : DepthShadowMapRenderingRun
  • updateDepthMap() : DepthShadowMapRenderingRun
  • updateFrame() : RenderingRun
  • updateGlobalRun() : OgreIlluminationManager
  • updatePerLightRun() : OgreIlluminationManager
  • updateRenderQueue() : OgreRenderable
  • updateRun() : SharedRuns
Generated on Wed Mar 28 11:48:46 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • a
  • c
  • d
  • f
  • g
  • h
  • i
  • j
  • l
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • ~

- v -

  • validate() : SharedRuns
  • validateSharedRuns() : TechniqueGroup
Generated on Wed Mar 28 11:48:46 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: Class Members - Typedefs

  • All
  • Functions
  • Variables
  • Typedefs

  • AttribParserList : RenderTechniqueFactory
  • ILLUM_ATTRIBUTE_PARSER : RenderTechniqueFactory
Generated on Wed Mar 28 11:48:46 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: Class Members - Variables

  • All
  • Functions
  • Variables
  • Typedefs
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- a -

  • allWeightsTexture : OgrePMWeightComputeRenderingRun
  • angleTolerance : ReducedCubeMapRenderingRun , CubeMapRenderTechnique , ReducedCubeMapRenderingRun , CubeMapRenderTechnique , CubeMapRenderingRun , CubeMapRenderTechnique
  • areaLightRadius : OgreIlluminationManager
  • attachToTexUnit : OgreCubeMapRenderTechnique
  • attenuation : OgreCausticCasterRenderTechnique , OgreCausticCubeMapRenderingRun
  • attributeParsers : RenderTechniqueFactory
Generated on Wed Mar 28 11:48:46 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: Class Members - Variables

  • All
  • Functions
  • Variables
  • Typedefs
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- l -

  • lastupdated : RenderingRun
  • layer : CubeMapRenderTechnique
  • light : OgreDepthShadowMapRenderingRun , OgreLightVolumeRenderingRun , OgrePMWeightComputeRenderingRun , OgrePhotonMapRenderingRun
  • lightFarPlaneParamName : OgreDepthShadowReceiverRenderTechnique
  • lightMatrix : OgrePMWeightComputeRenderingRun , OgreFocusingMapRenderingRun
  • lightMatrixGPUParamName : OgreIllumVolumeRenderTechnique
  • lightViewMatrix : OgrePMWeightComputeRenderingRun
  • lightViewParamName : OgreDepthShadowReceiverRenderTechnique
  • lightViewProjParamName : OgreDepthShadowReceiverRenderTechnique
  • lightVolumeCamera : OgreLightVolumeRenderingRun
Generated on Wed Mar 28 11:48:46 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: Class Members - Variables

  • All
  • Functions
  • Variables
  • Typedefs
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- m -

  • mainCamera : OgreIlluminationManager
  • mainViewport : OgreIlluminationManager
  • materialName : OgreLightVolumeRenderingRun , OgrePhaseTextureRenderingRun , OgreCausticCubeMapRenderingRun , OgrePhotonMapRenderingRun , OgreChildPSystemRenderingRun , OgreDepthShadowMapRenderingRun , OgreIllumVolumeRenderTechnique
  • maxcasters : OgreCausticReceiverRenderTechnique
  • maxlights : OgreDepthShadowReceiverRenderTechnique
  • maxRad : OgreIlluminationManager
  • maxRads : OgreIlluminationManager
  • maxVariableName : OgreCubeMapRenderTechnique
  • minVariableName : OgreCubeMapRenderTechnique
Generated on Wed Mar 28 11:48:46 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: Class Members - Variables

  • All
  • Functions
  • Variables
  • Typedefs
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- n -

  • name : OgreRenderable , OgreSceneCameraDepthRenderingRun , OgreReducedCubeMapRenderingRun , OgrePMWeightComputeRenderingRun , OgrePMEntryPointMapRenderingRun , OgrePhotonMapRenderingRun , OgrePhaseTextureRenderingRun , OgreChildPSystemRenderingRun , OgreFocusingMapRenderingRun , OgreDepthShadowMapRenderingRun , OgreCubeMapRenderingRun , OgreLightVolumeRenderingRun , OgreCausticCubeMapRenderingRun
  • normal : PathMapEntryPoint
Generated on Wed Mar 28 11:48:46 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: Class Members - Variables

  • All
  • Functions
  • Variables
  • Typedefs
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- b -

  • billboardSetRenderable : OgreRenderable
  • blurCauCubeMap : OgreCausticCasterRenderTechnique
  • bluredCausticCubemapTexture : OgreCausticCubeMapRenderingRun
  • blurMap : OgreCausticCubeMapRenderingRun
  • blurredDepthMapTexture : OgreDepthShadowMapRenderingRun
  • blurredname : OgreDepthShadowMapRenderingRun
  • blurSM : OgreIlluminationManager
  • boundingBox : OgreRenderable , OgreSharedRuns
  • boundingSphere : OgreRenderable , OgreSharedRuns
Generated on Wed Mar 28 11:48:46 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: Class Members - Variables

  • All
  • Functions
  • Variables
  • Typedefs
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- c -

  • camera : OgreFocusingMapRenderingRun
  • causticCasters : OgreCausticReceiverRenderTechnique
  • causticCubeMapResolution : CausticCasterRenderTechnique
  • causticCubemapTexture : OgreCausticCubeMapRenderingRun
  • causticFragmentProgram : OgreCausticReceiverRenderTechnique
  • causticMapMaterialName : OgreCausticCasterRenderTechnique
  • causticVertexProgram : OgreCausticReceiverRenderTechnique
  • child1 : SharedRuns
  • child2 : SharedRuns
  • childParticleSystemName : OgreChildPSystemRenderingRun
  • childPSysName : OgreHierarchicalParticleSystemTechnique
  • childPSysScriptName : OgreHierarchicalParticleSystemTechnique
  • childTechniqueGroups : OgreSharedRuns
  • clusterLengthTexture : OgrePMEntryPointMapRenderingRun
  • clusters : PathMapClusters , OgrePathMapRenderTechnique
  • count : PathMapClusters
  • cubemapLayer : CubeMapRenderTechnique
  • cubeMapResolution : CubeMapRenderTechnique
  • cubemapTexture : OgreCubeMapRenderingRun
  • cubeMapUpdateInterval : CubeMapRenderTechnique
  • currentFace : CubeMapRenderingRun , ReducedCubeMapRenderingRun , CausticCubeMapRenderingRun , CubeMapRenderingRun , ReducedCubeMapRenderingRun
Generated on Wed Mar 28 11:48:46 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: Class Members - Variables

  • All
  • Functions
  • Variables
  • Typedefs
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- d -

  • depthMapCamera : OgreDepthShadowMapRenderingRun
  • depthMapTexture : OgreDepthShadowMapRenderingRun
  • depthTexID : OgreSBBRenderTechnique , OgreFireRenderTechnique
  • depthTexture : OgreSceneCameraDepthRenderingRun
  • distTolerance : CubeMapRenderTechnique , ReducedCubeMapRenderingRun , CubeMapRenderTechnique , CubeMapRenderingRun , ReducedCubeMapRenderingRun , CubeMapRenderingRun , CubeMapRenderTechnique
Generated on Wed Mar 28 11:48:46 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: Class Members - Variables

  • All
  • Functions
  • Variables
  • Typedefs
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- e -

  • entryPointTexture : OgrePMEntryPointMapRenderingRun
  • environmentMaterial : OgreCubeMapRenderTechnique
Generated on Wed Mar 28 11:48:46 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: Class Members - Variables

  • All
  • Functions
  • Variables
  • Typedefs
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- f -

  • focusingMapSize : OgreIlluminationManager , OgreFocusingMapRenderingRun
  • focusingSM : OgreIlluminationManager
  • focusingTexture : OgreFocusingMapRenderingRun
  • FParamRadius : OgreHierarchicalParticleSystemTechnique
  • fullscreenGrid : OgreRenderingRun
  • fullScreenQuad : OgreRenderingRun
  • fullScreenQuadEntity : OgreRenderingRun
  • fullScreenQuadNode : OgreRenderingRun
Generated on Wed Mar 28 11:48:46 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: Class Members - Variables

  • All
  • Functions
  • Variables
  • Typedefs
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- g -

  • getMinMax : OgreCubeMapRenderTechnique
  • globalSharedRuns : OgreIlluminationManager
Generated on Wed Mar 28 11:48:46 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: Class Members - Variables

  • All
  • Functions
  • Variables
  • Typedefs
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- i -

  • illumTexID : OgreIllumVolumeRenderTechnique
  • illumTextureResolution : IllumVolumeRenderTechnique
  • illumVolumeUpdateInterval : IllumVolumeRenderTechnique
  • impostorCamera : OgreChildPSystemRenderingRun
  • impostorMaterialName : OgreHierarchicalParticleSystemTechnique
  • impostorResolution : HierarchicalParticleSystemTechnique
  • impostorTexID : OgreHierarchicalParticleSystemTechnique , OgreIllumVolumeRenderTechnique
  • impostorTexture : OgreChildPSystemRenderingRun
  • impostorUpdateInterval : HierarchicalParticleSystemTechnique
  • instance : OgreIlluminationManager
Generated on Wed Mar 28 11:48:46 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: Class Members - Variables

  • All
  • Functions
  • Variables
  • Typedefs
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- p -

  • parent : SharedRuns
  • parentEntity : OgreRenderable
  • parentOgreRenderable : OgreRenderTechnique
  • parentOgreTechniqueGroup : OgreRenderTechnique
  • parentParticleSystem : OgreRenderable
  • parentRenderable : RenderTechnique
  • parentSharedRuns : TechniqueGroup
  • parentTechniqueGroup : RenderTechnique
  • particleScriptName : OgreChildPSystemRenderingRun
  • pass : OgreRenderTechnique
  • passes : OgreDepthShadowReceiverRenderTechnique , OgreCausticReceiverRenderTechnique
  • pathMapClusterLengths : OgreIlluminationManager
  • pathMapClusters : OgreIlluminationManager
  • pathMapEntryPoints : OgreIlluminationManager
  • pathMapPass : OgrePathMapRenderTechnique
  • pathMapResolution : PathMapClusters
  • pathMapTextureFilename : PathMapClusters
  • perLightRuns : OgreIlluminationManager
  • perspectiveRendering : HierarchicalParticleSystemTechnique , ChildPsystemRenderingRun , HierarchicalParticleSystemTechnique , OgreChildPSystemRenderingRun
  • phaseCamera : OgrePhaseTextureRenderingRun
  • phaseTexture : OgrePhaseTextureRenderingRun
  • phaseTextureSize : OgreIlluminationManager
  • photonMapCamera : OgrePhotonMapRenderingRun
  • photonMapMaterialName : OgreCausticCasterRenderTechnique
  • photonMapResolution : CausticCasterRenderTechnique
  • photonMapTexID : OgreCausticCasterRenderTechnique
  • photonMapTexId : OgreCausticCubeMapRenderingRun
  • photonMapTexture : OgrePhotonMapRenderingRun
  • photonMapUpdateInterval : CausticCasterRenderTechnique
  • pixelSprites : OgreRenderingRun
  • playerCamera : OgreSceneCameraDepthRenderingRun
  • playerView : OgreSceneCameraDepthRenderingRun
  • position : PathMapEntryPoint
  • prob : PathMapEntryPoint
Generated on Wed Mar 28 11:48:46 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: Class Members - Variables

  • All
  • Functions
  • Variables
  • Typedefs
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- r -

  • reducedCubeMapResolution : ConvolvedCubeMapRenderTechnique
  • reducedCubemapTexture : OgreReducedCubeMapRenderingRun
  • renderableMaterials : OgreSharedRuns
  • renderables : OgreSharedRuns
  • renderableType : OgreRenderable
  • renderEnvironment : CubeMapRenderTechnique , CubeMapRenderingRun , CubeMapRenderTechnique , CubeMapRenderingRun , CubeMapRenderTechnique
  • renderSelf : CubeMapRenderingRun , CubeMapRenderTechnique , CubeMapRenderingRun , CubeMapRenderTechnique
  • renderTechniques : OgreTechniqueGroup
  • resolution : CubeMapRenderingRun , CausticCubeMapRenderingRun , CubeMapRenderingRun , LightVolumeRenderingRun , OgrePhotonMapRenderingRun , ChildPsystemRenderingRun , ReducedCubeMapRenderingRun , CausticCubeMapRenderingRun , ChildPsystemRenderingRun , LightVolumeRenderingRun , ReducedCubeMapRenderingRun
  • resolutionX : PhaseTextureRenderingRun , DepthShadowMapRenderingRun
  • resolutionY : PhaseTextureRenderingRun , DepthShadowMapRenderingRun , PhaseTextureRenderingRun , DepthShadowMapRenderingRun
Generated on Wed Mar 28 11:48:46 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: Class Members - Variables

  • All
  • Functions
  • Variables
  • Typedefs
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- s -

  • selfMaterial : OgreCubeMapRenderTechnique
  • setLightProjFarPlane : OgreDepthShadowReceiverRenderTechnique
  • setLightViewMatrix : OgreDepthShadowReceiverRenderTechnique
  • setLightViewProjMatrix : OgreDepthShadowReceiverRenderTechnique
  • shadowFragmentProgram : OgreDepthShadowReceiverRenderTechnique
  • shadowMapMaterialName : OgreIlluminationManager
  • shadowMapSize : OgreIlluminationManager
  • shadowVertexProgram : OgreDepthShadowReceiverRenderTechnique
  • sharedRunRoots : OgreIlluminationManager
  • sharedRuns : RenderTechnique , OgreCubeMapRenderingRun , RenderTechnique , OgreDepthShadowMapRenderingRun , RenderTechnique , OgreLightVolumeRenderingRun , RenderTechnique , OgrePhotonMapRenderingRun , RenderTechnique , OgreReducedCubeMapRenderingRun , RenderTechnique , OgreSceneCameraDepthRenderingRun , RenderTechnique , OgreSharedRuns , RenderTechnique , OgreCausticCubeMapRenderingRun , RenderTechnique , OgreChildPSystemRenderingRun , RenderTechnique
  • spriteSetName : OgreRenderingRun
  • startFrame : RenderingRun , IllumVolumeRenderTechnique , RenderingRun , CausticCasterRenderTechnique , RenderingRun , CubeMapRenderTechnique , CausticCasterRenderTechnique , CubeMapRenderTechnique , RenderingRun , IllumVolumeRenderTechnique , HierarchicalParticleSystemTechnique , RenderingRun , CubeMapRenderTechnique , RenderingRun , CubeMapRenderTechnique , RenderingRun , HierarchicalParticleSystemTechnique , CubeMapRenderTechnique , RenderingRun , CubeMapRenderTechnique
  • subEntityRenderable : OgreRenderable
  • sysRad : OgreChildPSystemRenderingRun
  • systemRadius : OgreLightVolumeRenderingRun
Generated on Wed Mar 28 11:48:46 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: Class Members - Variables

  • All
  • Functions
  • Variables
  • Typedefs
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- t -

  • techniqueFactories : OgreIlluminationManager
  • texID : OgreCubeMapRenderTechnique
  • textureDepth : IllumVolumeRenderTechnique , LightVolumeRenderingRun
  • typeName : RenderTechniqueFactory
Generated on Wed Mar 28 11:48:46 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: Class Members - Variables

  • All
  • Functions
  • Variables
  • Typedefs
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- u -

  • updateAllFace : CausticCubeMapRenderingRun , CausticCasterRenderTechnique , CubeMapRenderTechnique , ReducedCubeMapRenderingRun , CubeMapRenderTechnique , CubeMapRenderingRun , ReducedCubeMapRenderingRun , CubeMapRenderTechnique , CubeMapRenderingRun , CubeMapRenderTechnique , CausticCasterRenderTechnique , CausticCubeMapRenderingRun , CubeMapRenderTechnique
  • updateInterval : RenderingRun
  • updateListeners : OgreIlluminationManager
  • useDistance : CausticCasterRenderTechnique , OgrePhotonMapRenderingRun
  • useDistCalc : ReducedCubeMapRenderingRun , CubeMapRenderTechnique , IllumVolumeRenderTechnique , HierarchicalParticleSystemTechnique , ReducedCubeMapRenderingRun , CubeMapRenderingRun , CubeMapRenderTechnique , CubeMapRenderingRun , HierarchicalParticleSystemTechnique , CubeMapRenderTechnique , IllumVolumeRenderTechnique
  • useFaceAngleCalc : CubeMapRenderTechnique , CubeMapRenderingRun , ReducedCubeMapRenderingRun , CubeMapRenderTechnique , ReducedCubeMapRenderingRun , CubeMapRenderTechnique
  • useFParam : OgreHierarchicalParticleSystemTechnique
  • useHierarchicalImpostor : IllumVolumeRenderTechnique
  • useLISPSM : OgreIlluminationManager
  • useOwnMaterial : OgreHierarchicalParticleSystemTechnique , OgreChildPSystemRenderingRun
  • useTriangles : OgreCausticCasterRenderTechnique , OgreCausticCubeMapRenderingRun
  • useVParam : OgreHierarchicalParticleSystemTechnique
Generated on Wed Mar 28 11:48:46 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: Class Members - Variables

  • All
  • Functions
  • Variables
  • Typedefs
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- v -

  • visibleObjects : OgreRenderingRun , OgreIlluminationManager
  • visitor : OgreIlluminationManager
  • VParamRadius : OgreHierarchicalParticleSystemTechnique
Generated on Wed Mar 28 11:48:46 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: Class Members - Variables

  • All
  • Functions
  • Variables
  • Typedefs
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- w -

  • weightIndexTexture : OgrePathMapRenderTechnique
  • weightTexture : OgrePMWeightComputeRenderingRun
  • WorldParamName : OgreDepthShadowReceiverRenderTechnique
  • WorldViewProjParamName : OgreDepthShadowReceiverRenderTechnique
Generated on Wed Mar 28 11:48:46 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: Class Members

  • Namespace List
  • Namespace Members
  • All
  • Functions

  • parseUseDistCalc() : HPSParsers , IllumVolumeParsers
Generated on Wed Mar 28 11:49:03 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: Member List

PathMapClusters Member List

This is the complete list of members for PathMapClusters, including all inherited members.

clusters | PathMapClusters
count | PathMapClusters
pathMapResolution | PathMapClusters
pathMapTextureFilename | PathMapClusters

Generated on Wed Mar 28 11:49:01 2007 for GTP Illumination Module by doxygen 1.5.1-p1


GTP Illumination Module: Member List

PathMapEntryPoint Member List

This is the complete list of members for PathMapEntryPoint, including all inherited members.

normal | PathMapEntryPoint
position | PathMapEntryPoint
prob | PathMapEntryPoint

Generated on Wed Mar 28 11:49:01 2007 for GTP Illumination Module by doxygen 1.5.1-p1


Back to List of Techniques

Path Map Technique

A technique that defines that the rendering of the object will add indirect lighting with the use the path map effect (see: The Path Map Tool).
This technique will create a new pass after the pass which defined this technique. The new pass will add indirect lighting to the object.

Name:

PathMap

Parameters:

 no parameters needed

see also: Extending the Ogre Material Scripts